close

Вход

Забыли?

вход по аккаунту

?

Практикум по технологии работы с СУБД MS Access

код для вставкиСкачать
Министерство образования Пермского края
ГОУ СПО «Пермский педагогический колледж № 1»
Т.С.
Мартынова
ИНФОРМАТИКА
Практикум по технологии работы
с системой управления базой данных
Microsoft
office
Access
Пермь, 2007
2
Рецен
зент:
О.В.Дремина, ассистент кафедры информатики и ВТ, зам. декана факультета информатики и экономики ПГПУ.
Мартынова Т.С.
Информатика
Практикум по технологии работы с системой управления базой данных Microsoft
office
Access
Пр
актикум по технологии работы с системой управления базой данных
Microsoft
office
Access
обеспечивает методическую поддержку практических занятий
по информатики
. Учебное пособие позволит профессионально создавать и редактировать базу данных реляцион
ного типа, осуществлять к ней запросы, формировать отчеты, разрабатывать однотабличные пользовательские формы и т.п.
Для студентов
средних специальных учреждений, преподавателей и тех, кто самостоятельно осваивает основы практического пользова
ния СУБД,
С Мартынова Т.С., 2007
С Пермский педагогический колледж № 1, 2007
3
СОДЕРЖАНИЕ
Стр
. Л
абораторная работа №1
Создание структуры таблицы базы данных. Заполнение таблицы
.
......................
......................
......................
... 4
Лабораторная работа №2
Создание форм и редактирование в режиме «форма»
................
16
Лабораторная работа №
3
Информационные технологии связывания таблиц. Создание многотабличных подчиненных форм в СУБД MS
ACCESS
................................................................
.
.....
29
Лабораторная работа №
4 Назначение запросов
........................................................
.
...........
39
Лабораторная работа №
5 Создание отчетов
.........................................................................
49
4
Лаб
ораторная работа № 1
Создание структуры таблицы базы данных
.
Заполнение таблицы
.
Поскольку СУБД Access
является одним из приложений Windows
, входящих в интегрированную систему Office
, интерфейс окна программы
и ег
о основные компоненты –
меню, панели инструментов, справочная система, а также приемы работы с клавиатурой и мышью используется в работе аналогично другим приложениям
, такими как Word
, Ex
c
el
. Базы данных занимают все более прочное место в нашей жизни. Мы пользуемся ими для решения различных задач, из которых наиболее общими (и часто встречающимися) являются задачи накопления, хранения, постоянного обновления и анализа
(обработка) данных о каких
-
то объектах, будь то документация, списки продукции, клиентов,
рабочих
, учащихся
и т.д. Система MS
Access
предлагает для создания приложения, решающего подобные задачи, следующие объекты: таблицы, запросы, формы, отчеты, программные модули. Эти объекты хранятся в файлах с расширением .
mdb
.
Табл
ица
. В базах данных вся информация хранится в двумерных таблицах. Это базовый объект БД, все остальные объекты создаются на основе существующих таблиц (производные объекты). Каждая строка в таблице –
запись БД, а столбец –
поле. Запись содержит набор д
анных об одном объекте, а поле –
однородные данные обо всех объектах.
Запросы
. В СУБД запросы являются важнейшим инструментом. Главное предназначение запросов –
отбор данных на основании заданных условий. С помощью запроса из базы данных можно выбрать и
нформацию, удовлетворяющую определенным условиям.
Закладки для создания различных объектов
Кнопки выбора режима с объектами
5
Форма
. Формы позволяют отображать данные, содержащиеся в таблицах или запросах, в более удобном для восприятия виде. При помощи форм можно добавлять в таблицы новые данные, а также редактировать или удалять существующие. Форма может содержать рисунки, графики и другие внедренные объекты.
Отчеты
. Отчеты предназначены для печати данных, содержащихся в таблицах и запросах, в красиво оформленном виде
: с
красивыми заголовками, промежуточными итогами и т
.п
.
Макросы
. Макросы (т.е. наборы простых инструкций по управлению данными) служат для автоматизации повторяющихся операций. Запись макроса производится так же, как в других приложениях, например как в приложении Word
.
Модули
.
Модули служат для авто
матизации работы с БД. Модули еще называют процедурами обработки событий и пишутся на языке VBA
(
Visual
Basic
for
Applications
).
Макросы и модули
, созданные программистом, оперируют запросами, формами и отчетами и объединяют разрозненные действия в един
ую задачу пользователя.
Постановка задачи
1.
Создать новую базу данных
«
Личные дела учащихся
»
.
2.
Создать таблицу базы данных
и присвоить ей имя «
5 «А» класс
»
.
3.
Определить поля таблицы в соответствии с рис.
1
.
4.
Ввести ограничения на данные в полях
«
Табельный н
омер
» и «
Паспортные данные
»,
т.е.
данные не должны повторяться.
5.
Установить для поля «
Дата
рождения
» краткий формат даты.
6.
Установить для поля «
Сотовый
телефон
»: размер поля –
действительное
. 7.
Ввести ограничения на данные в полях «
Фамилия
», «
Им
я
», «
Отчество
», «
Домашний
адрес
», «
Дата
рождения
», «
Почтовый
индекс
», «
Дом
.
телефон
», «
Хобби
», «
Заметки
», т.е. данные могут повторяться.
8.
Заполнить таблицу данными в соответствии с таблицей 1
1
.
9.
Изменить ширину каждого столбца в соответствии с шириной данных
.
10.
Произвести редактирование данных.
10.1
. Удаление записи.
10
.2
. Изменение содержимого поля.
10
.3
. Ввод новой записи в режиме таблица.
10
.4
. Перемещение записи в таблице.
10
.5
. Копирование записи в таблице.
10
.6
. Произвести сортировку данных по возрастанию
(алфавитный порядок).
10
.7
. Изменение имени поля.
10
.8
. Удаление поля.
10
.9
. Добавление нового поля.
1
Данные находятся в таблице на стр.
6
.
6
Таб.ном
Фамилия
Имя
Отчество
Год рожд
Адрес
Индекс
Дом
телефон
Сот
телефон
Пасп
ор.
данные
Хобби
Заметки
Иванов
Иван
Иванович
︰
Б.Гагарина
ﰠ
Легкая атлетика
Соколов
Валерий
Семенович
︰
Мира,
Спортивные танцы
Петров
Иван
Петрович
︰
Ленина
擄
бокс
Бородкин
Беляева
†
Абрамова
Ольга
Владимировна
︱
Репина,
плавание
Кагоров
Сергей
Дмитриевич
︰
Баумана,
Дзюдо
Морозова
Ирина
Ивановна
︱
Мира,
擄櫓
Плавание
Калинина
Любовь
Сергеевна
︱
Мира,
Театр
Петухов
Валерий
Викторович
︰
Кирова,
Худ. Школа
Полякова
Марина
Вячеславовна
Кирова, Легкая атлетика
Зубова
Татьяна
Николаевна
︰
Пушкина,
露
Язева
Ирина
Владимировна
︱
Г. Звезда,
Цирковое искусство
Окулова
Лидия
Сем
еновна
︰
Швецова,
Фигурное
катание
Попов
Дмитрий
Сергеевич
︰
Попова,
擄
Каратэ
Смирнова
Елена
Викторовна
︰
Мира
7
Алгоритм
выполнения работы
1.
Для создания новой базы данных
:
Загрузите Access
, в появившемся диалоговом окне щелкните по кнопке «
Создать файл
».
Щелкните по кнопке «
Новая база данных
».
Выберите папку «
Мои документы
» (пункт «
Папка
»), где ваша база данных будет на
ходиться.
В диалоговом окне «
Файл новой базы данных
» задайте имя вашей базы данных следующим образом: имя файла
–
«
Личные дела учащихся
», а тип файла
–
«
База данных Access
».
Щелкните левой клавишей мыши по кнопке «
Создать
».
2.
Для создания таблицы базы данных
:
В окне базы данных выберите вкладку «
Таблицы
», а затем щелкните по кнопке «
Создать
».
В окне «
Новая таблица
» выберите п
ункт «
Конструктор
» и щелкните ОК
. В результате проделанных операций открывается окно таблицы в режиме конструктора, в котором следует определить поля таблицы.
3.
Для определения полей таблицы
: рис
.
1
Введите в строки столбца «
Имя поля
» имена полей в соответствии с рис.
1
.
В строке столбца «
Тип данных
» щелкните по значку раскрывающегося списка и выберит
е типы данных в соответствии с рис.
1
. Поля вкладки «
Общие
» оставьте такими, как предлагает Access
.
Встаньте курсором в строку поля «
Табельный номер
» и щелкните по пиктограмме «
ключ
» на панели «
Конструктор таблиц
»
Щелкните по пиктограмме -
«
Сохранить
» на панели «
Конструктор таблиц
», либо выберите меню Файл
–
Сохранить
;
Панель -
Конструктор таблиц
8
Сохраните таблицу под именем
, щелкните мышкой по кнопке ОК
Закройте окно конструктора таблицы, для этого щелкните мышкой по
кнопке -
закрыть.
4.
Введите ограничения на данные в пол
ях
«
Табельный номер
»
и «
Паспортные данные
»
, т.е.
данные не должны повторяться.
Щелкните мышкой по проектируемой таблице «
5 «А» класс
»
;
Войдите в режим Конструктор
для проектируемой таблицы –
для этого щелкните по вкладке Конструктор
Щелкните по полю «
Табельный номер
»
Щелкните по строке параметра «
Индексированное поле
»
Выберите в списке пункт: «
ДА (совпадения не допускаются
)»
Аналогично ус
тановите ограничения на данные в поле «
Паспортные данные
»
5.
Установите для поля «
Дата рождения
» краткий формат даты
.
Щелкните мышкой по полю «
Дата рождения
»
Щелкните по строке Формат поля
Щелкните мышкой по кнопке раскрывающегося списка
И
з раскрывшегося списка выберите -
краткий формат даты
5 «
А
» класс
9
6.
Установите для поля «
Сотовый
телефон
»: размер поля –
действительное число
.
Щелкните мышкой по полю «
Сотовый телефон
»
Щелкните мышкой по строке размер
поля
Щелкните мышкой по кнопке раскрывающегося списка
Из раскрывшегося списка выберите -
действительное
7.
Введите ограничения на данные в полях «
Фамилия
», «
Имя
», «
Отчество
»,
«
Адрес
»
, «
Дата
рождения
», «
Почтовый индекс
», «
Домашний телефон
», «
Хобби
», «
Заметки
»,
т.е. данные могут повторяться
.
Щелкните по полю «
Фамилия
»
Щелкните по строке параметра «
Индексированное поле
»
Выберите в списке пункт: «
ДА (совпадения допускаются
)»
Аналогично установите
ограничения на данные
в полях
с у
четом поставленной задачи.
Перейдите в режим «
Таблица
», выполнив команды: меню Вид -
Режим таблицы
На вопрос о сохранении таблицы щелкните п
о кнопке «
Да
».
8.
Заполнить таблицу данными в соответствии с таблицей 1.
2
2
См. на стр.
6
.
10
9.
Для изменения ширины каждого поля таблицы
в соответствии с шириной данных
применяются следующие действия:
Щелкните мышкой в любой строке поля «
Табельный номе
р
»
;
Меню Формат
-
Ширина столбца
;
В диалоговом окне щелкните по кнопке «
По ширине данных
»
Аналогично измените ширину остальных полей;
Попробуйте изменить ширину полей с помощью мыши (
вспомните, как это делается в
MS
Excel
).
10.
Выполнить
редактирование данных
:
10.1.
Удалить вторую
запись
.
Выделите запись, для этого щелкните мышкой по кнопке слева от записи, в которой находится вторая запись
;
Выполните команды: Правка
–
Удалить
При удалении програм
ма попросит подтверждение на удаление –
щелкните по кнопке «
Д
а
»
10.2.
В пятой записи измените фамилию Абрамова на Соколову
.
Дважды щелкните мышкой по фамилии Абрамова
(фамилия выделится темным цветом);
Наберите фамилию Соколова
.
11
10.3.
Введите новую запись в
Режиме таблица
:
Выполните команды: Записи
–
Ввод
данных
Внимание!
Вид экрана изменится
Введите новую запись:
Табельный номер
–
31, Фамилия
–
Бородкин, Имя
-
Александр, Отчество
–
Иванович, Дата
рождения
–
15.05.1
987, Адрес
–
Беляева 54
-
24, Почтовый
индекс
–
614088, Д
ом
.
телефон
–
2279415, С
от
.
тел
–
отсутствует, Паспортные
данные
–
отсутствуют
, Хобби
–
спорт. т
анцы, Заметки
–
отсутствуют.
Выполните команды: Записи
–
Удалить
фильтр
10.4.
Переместите в
торую запись в конец таблицы.
В
ыделите вторую запись
, для этого щелкните по «серой панели» второй записи
Выполните команды: Правка
–
Вырезать
, либо щелкните мышкой на панели
инструментов по пиктограмме .
Выделите свободную строку зап
иси в конце таблицы
;
Выполните команды: Правка
–
Вставить
, либо щелкните на панели инструментов по п
иктограмме
.
10.5.
Скопируйте запись с фамилией Бородкин
,
имя Александр
на в вторую
запись и измените в ней: имя на Алексей, дата рождения на 15.03.1
988,
в поле «Табельный номер» на 16, в поле «
Хобби
» -
бальные танцы
.
Выделите запись с фамилией Бородкин
и имя Александр
, выделение выполняется аналогично пункту 10
.4.
.
Выполните команды: Правка
–
Копировать
, либо щелкните мышкой на панели инструментов
по пиктограмме
.
Выделите вторую
запись, выделение выполняется аналогично пункту 10
.4.
Выполните команды: Правка
–
Вставить
, либо щелкните на панели инструментов по пиктограмме .
12
Выполните изменение данных, согласно заданию.
10.6.
Произвести
сортировку данных по
пол
ю
«Фамилия»
в порядке возрастания.
Выделите поле «
Фамилия
», для этого щелкните мышкой по его названию
Выполните команды: Записи
–
Сортировка
–
Сортировка по возрастанию
10.7.
Измените имя поля «Хобби» на «Внеучебная деятельн
ость» в режиме «Таблица»
.
Выполните двойной щелчок левой клавишей мыш
и
по имени поля «
Хобби
»
;
Введите другое имя поля «
Внеучебная деятельность
» и нажмите на клавишу «
Enter
».
10.8.
Удалите поле «
Заметки
».
Выделите поле «
Заметки
», для этого щелкните мышкой по имени данного поля;
Выполните команды: Правка
–
Удалить столбец
13
В процессе работы дать подтверждение на удаление.
. 10.9.
Добавьте перед полем «Внеучебная деятельность» новое поле с именем «Группа здоровья»
.
Выделите поле «
Внеучебная деятельность
»;
Выполните команды:
Вставка
–
Столбец
В таблице появится новый столбец с именем «
Поле1
». Присвойте созданному полю имя «
Группа здоровья
»
(См. пункт 10
.7.).
Перейдите в режим Конструктора
, для этого выполните команды: Вид
–
Конструктор
;
Встаньте курсором в поле «
Группа здоровья
» и измените тип данных на логический
тип данных
.
Выполните команды: Файл
–
Сохранить
, либо щелкните на панели инструментов по
пиктограмме .
Выполните команды: Вид
–
Режим таблицы
,
либо щелкните по пиктограмме .
14
Заполните данными в поле «
Группа здоровья
»
самостоятельно.
Для того, чтобы установить «галочку» в «квадратик» необходимо щелкнуть по «квадратику» левой клавишей мыши, либо нажать на пробе
л.
Для удобства работы с таблицей некоторые поля можно при необходимости скрывать
с помощью команд: Формат
–
Скрыть столбцы
.
Для того чтобы вызвать скрытые столбцы выполните команды: Формат
–
Отобразить столбцы
. В диалоговом окне
«Отображение стол
бцов»
установите «галочку» у того столбца
, которого вы хотите отобразить
.
Сохраните отредактированную таблиц
у
«
5
«
А» класс
», для этого выпол
ните команды: Файл
–
Сохранить
, либо щелкните мышкой по пиктограмме на панели
инструментов;
Закройте таблицу «
5 «А» класс
», для этого щелкните по кнопке закрыть Примечание
15
Пригласите преподавателя для демонстрации выполненного задания.
ВНИМАНИЕ
!
Закройте все открытые окна.
Выйдите
из
Microsoft
Office
Access
16
Лабораторная работа № 2
Создание форм и редактирование в режиме «форма
»
Вся исходная информация базы данных располагается в таблицах. Работать с базой данных в режиме таблицы не очень удобно, хотелось бы, например, видеть в отдельном окне информацию об отдельном учащемся целиком, включа
я фотографию.
Форма –
это вспомогательное средство, которое значительно облегчает ввод и просмотр данных.
Постановка задачи
1.
С помощью мастера форм создать форму «
Ученик 5 «А» класса
» (тип –
форма в один столбец
).
2.
Вставка фотографии в режиме форма.
3.
До
бавление вкладки на форму.
4.
Редактирование формы.
5.
Заполните самостоятельно пару записей в режиме форм
а
.
6.
Провести в поле «
Фамилия
» сортировку данных по возрастанию.
7.
Найти запись об ученике Иванов,
находясь в режиме форм
а
.
8.
Сохранить и просмотреть форму.
17
Алгоритм выполнения работы
1.
Создание формы «5 «А» класс».
1.1.
Пуск
–
Программы
–
Microsoft Office
-
Microsoft Office Access
.
1.2.
Щелкните мышкой по пиктограмме -
открыть
(либо меню Файл
–
О
ткрыть
).
1.3.
Щелкните мышкой по папке «
Мои документы
».
1.4.
Найдите и выберите свою базу данных «
Личные дела учащихся
».
1.5.
Щелкните мышкой по кнопке «
Открыть
».
1.6.
В окне базы данных «
Личные дела учащихся
» щелкните мышкой по значку таблиц
ы
«
5 «
А
»
класс
».
1.7.
Щелкните по кнопке «
Конструктор
».
1.8.
Д
ополните таблицу «
5 «А» класс
» новым полем «
Фото
», а тип поля –
поле объекта OLE
.
1.9.
Выполните команды: Файл
–
Сохранить
, либо щелкните по пиктограмме -
сохранить
.
1.10.
Закройте окно конструктора таблицы, для этого щелкните мышкой
по кнопке -
закрыть
.
18
1.11.
В окне базы данных
щелкните мышкой по вкладке Форм
ы
.
1.12.
Щелкните мышкой по кнопке Создать
.
1.13.
В появившемся окне выберите пункт Мастер форм
.
1.14.
Щелкните по кнопке -
список
и выберите таблицу «
5»А» клас
с
».
Щелкните по кнопке ОК
.
1.15.
Щелкните по кнопке и все Доступные поля
переместятся в Выбранные поля
.
1.16.
Щелкните по кнопке Далее
.
19
1.17.
В появившимся диалоговом окне «
внешний вид формы
»
в
ыб
ерите: в один столбец
;
1.18.
Щелкните по кнопке Далее
.
1.19.
Выберите требуемый стиль: Рисовая бумага.
1.20.
Щелкните по кнопке Далее
.
1.21.
Задайте имя формы: 5 «А» класс
. 1.22.
Щелкните по кнопке Готово
.
20
2.
Вставка фотограф
ии в режиме форма
.
2.1.
Щелкните правой кнопкой мыши
по контейнеру, в котором будет отображена фотография.
2.2.
Выберите пункт Добавить объект
.
2.3.
В появившемся диалоговом окне установите метки: Создать из файла
и
Связь.
2.4.
Щелкните по кнопке Обзор
.
21
2.5.
В диалоговом окне Обзор
выберите:
папку Мои документы
–
папка Фото
–
Фото Иванов И.И
.
и щелкните по кнопке ОК
.
2.6.
Щелкните по кнопке ОК
.
2.7.
Щелкните правой кнопкой мыши
по контейнеру, в котором отобра
жается фотография, и выберите пункт Свойства
.
2.8.
В появившемся окне перейдите на вкладку Макет
.
2.9.
В строке Установка размеров
выберите По размеру рамки
. Теперь любая фотография –
и большая, и маленькая, будет видна полностью.
2.10.
Закройте т
екущее диалоговое окно, для этого щелкните по кнопке -
закрыть.
3.
Добавление вкладки на форму
.
Если на форме слишком много данных, их можно разместить на отдельных вкладках. Сделаем это для фотографии, группы здоровья, внеучебной деятельности и паспо
ртные данные.
3.1.
Выполните команды: Вид
–
Конструктор
, либо щелкните по пиктограмме .
22
3.2.
В режиме конструктора щелкните по пиктограмме -
панель элементов
.
3.3.
На панели элементов
нажмите на кнопку -
Вкладка
(
Набор вкладок
).
3.4.
Щелкните по форме левее
фотографии –
на форме появилась вкладка.
3.5.
Щелкните правой клавишей мыши по корешку Вкладка 27
и выберите Добавить вкладку
.
Повторите аналогичное действие еще два раза.
3.6.
Перейдите на Вкладк
у
27
, щелкнув по ней мышкой.
3.7.
Щелкните левой клавишей мыши правее контейнера с фотографией
.
23
3.8.
Выполните команды: Правка
–
Вырезать
, либо щелкните по пиктограмме -
вырезать
в буфер обмена
контейнер
-
фотографию.
3.9.
Вставьте содержимое буфера на первую вклад
ку
, для этого выполните команды: Правка
–
Вставить
, либо щелкнуть по пиктограмме
-
вставить
.
3.10.
Удалите надпись «
фото
» слева от фотографии
, д
ля этого щелкните левой клавишей мыши
по надписи «
фото
» и нажмите на клавиатуре клави
шу Delete
.
В результате останется контейнер, в котором будет располагаться
сама фотография.
3.11.
Щелкните правой кнопкой мыши по корешку Вкладка
27
и выберите Свойства
.
3.12.
На вкладке Макет
в поле Подпись
впишите Фотография
, нажмите на клавишу Enter
.
3.13.
Щелкните по кнопке раскрывающегося списка и выберите Вкладку28
.
24
3.14.
На вкладке Макет
в поле Подпись
впишите Внеучебная
деятельность
и нажмите на клавишу Enter
.
3.15.
Аналогично заполните: Вкладку29
: По
дпись -
Группа здоровья
Вкладку30
: Подпись -
Паспортные данные
Вкладку31
: Подпись -
Телефоны
.
3.16.
Закройте диалоговое окно Вкладка
, для эт
ого щелкните по кнопке .
3.17.
Щелкните левой кнопкой мыши правее контейнера
Внеучебная деятельность
.
3.18.
Выполните команды: Правка
–
Вырезать
(либо щелкните по пиктограмме -
вырезать
) в буфер обмена
контейнер -
Внеучебная деятельность
.
3.19.
Вставьте содержимое буфера на В
кладку28
–
«
внеучебная деятельность
»
, для этого выполните команды: Правка
–
Вставить
(
либо щелкнуть по пиктограмме
-
вставить
).
3.20.
Удалите надпись «
Внеучебная деятельность
» слева от Внеучебн
ой
деятельно
ст
и
. Для этого щелкните левой клавишей мыши по надписи «
Внеучебная деятельность
» и нажмите на клавиатуре клавишу Delete
.
3.21.
Аналогично проведите операции с Вкладкой29
–
«группа здоровья»
, с
Вкладкой30
–
«паспортные данные»
,
с Вкладкой31
–
«телефоны»
.
Примечание
: На Вкладку 31
–
«
Телефоны
» перенесите и домашний и сотовый телефоны.
4.
Редактирование формы
.
Возможно, вас что
-
то не устраивает во внешнем виде созданной формы. Изменим ее, исполь
зуя конструктор
. В данный момент Вы находитесь в режиме Конструктора
.
Примечание
: Для того чтобы работать в режиме Конструктора
выполните команды:
Вид
–
Конструктор
(либо щелкните по пиктограмме -
Вид
)
.
25
4.1.
Щелкните по полю «
Табельный
номер
», увеличьте его ширину, ухватив боковой маркер, и когда указатель мыши примет вид черной ладошки, перетащите поле в центр.
4.2.
Остальные поля установите по выше предложенному образцу.
4.3.
Измените шрифт пол
я «
Табельный номер
» на
Times
New
Roman
Cyr
, размер
10, начертание –
полужирный курсив, цвет текста –
фиолетовый, выравнивание текста –
по центру, оформление –
с тенью.
4.4.
Измените цвет фона поля «
Табельный номер
» -
зеленый; цвет фона
полей «
Адрес
» и «
Почтовый
индекс
» -
светло
-
коричневый; 4.5.
Измените шрифт поля «
Телефоны
» на Times
New
Roman
Cyr
, размер -
10, начертание –
полужирный курсив, цвет границы поля –
темный зеленый, толщина границы линии –
1. Цвет фона поля
«№ домашнего телефона
» -
светло
-
зеленый, цвет фона поля «№ сотового телефона
» -
светло
-
желтый.
4.6.
В область «
Заголовок формы
» введите надпись «
Личные дела учащихся
», используя кнопку Надпись
на панели элементов
. Измените размер шрифта -
10, начертание –
полужирный курсив, цвет текста –
красный.
4.7.
В «
Область данных
» введите две кнопки категории «
Переходы по записям
» Предыдущая
запись
(стрелка влево) и Следующая
запись
(стрелка вправо), для это
го щелкните по кнопке -
«К
нопка
»
на панели элементов.
4.7.1.
Щелкните левой клавишей мыши в «
Области данных
» правее вкладок
.
4.7.2.
Выберите категорию
-
Переходы по записям
, действие
–
Предыдущая запись
. Щелкните по кнопке Далее
. 4.7.3.
Выберите рисунок –
стрелка влево
(синяя)
.
Щелкните по кнопке
Далее. Щелкните по кнопке
Готово.
26
4.7.4.
Щелкните по кнопке -
«К
нопка
»
на панели элементов, выберите категорию
–
Переходы по записям
, де
йствия
–
Следующая запись
. Щелкните по кнопке
Далее.
4.7.5.
Выберите рисунок –
стрелка вправо
(синяя)
.
Щелкните по кнопке
Далее. Щелкните по кнопке
Готово.
4.7.6.
Расположите кнопки друг под другом.
4.8.
Перейдите в режим Ф
орма
, для этого щелкните по пиктограмме -
Вид
(либо выполните команды: Вид
–
Режим
форма
). Убедитесь, что теперь форма выглядит красиво.
5.
Заполните самостоятельно еще пару записей в режиме формы
.
6.
Провести в поле «
Фамилия
» сортиров
ку данных по возрастанию
. Установите курсор в любую запись поля «
Фамилия
» и щелкните по пиктограмме -
Сортировка по возрастанию
(либо выполнить команды: Записи
–
Сортировка
–
Сортировка
по
возрастанию
).
27
7.
Найдите запись об ученике Иванов, находясь в режиме форма.
Установите курсор в любую запись поля «
Фамилия
» и щелкните по пикограмме -
Найти
(либо выполните команды: Правка
–
Н
айти
), введите фамилию –
Иванов и щелкните по кнопке Найти далее
. Найденная фамилия выделится черным цветом.
8.
Сохраните форму «
5 «А» класс
», для этого щелкните по пиктограмме -
сохранить
(либо выполните команды: Файл
–
Сохранить
). Закройте форму, щелкнув мышкой по кнопке -
закрыть
.
Пригласите преподавателя для демонстрации выполненного задания.
ВНИМАНИЕ
!
Закройте все открытые окна.
Выйдите
из
Microsoft
Of
fice
Access
28
Лабораторная работа № 3
Информационные технологии связывания таблиц. Создание многотабличных подчиненных форм в СУБД MS
ACCESS
.
Постановка задачи
1.
Открыть ранее созданную базу данных «
Личные дела учащихся
».
2.
В режиме Конструктора
создать в базе данных новую таблицу «
Экзаменационная оценка
5 «А» » и заполните ее данными.
3.
В режиме Конструктора
создать в базе данных еще одну таблицу «
Стипендиат –
5 «А»
» и
заполнить ее данными.
4.
Выведите таблицу «
5 «А» класс
» в режиме конструкт
ора и дополните ее новым полем –
Оценка
(
тип поля
–
Мастер подстановки
).
5.
Создать связь между таблицами «
5 «А» класс
», «
Экзаменационная оценка –
5 «А»
»
и
«
Стипендиат –
5 «А»
»
.
6.
Создать форму «
5 «А» класс –
летняя сессия
».
7.
Отр
едактирова
ть форм
у
.
29
Алгоритм выполнения работы
1.
Открыть ранее созданную базу данных «
Личные дела учащихся
».
1.1.
Пуск
–
Программы
–
Microsoft Office
-
Microsoft Office Access
.
1.2.
Щелкните мышкой по пиктограмме -
открыть
(либо меню Файл
–
О
ткрыть
).
1.3.
Щелкни
те мышкой по папке «
Мои документы
».
1.4.
Найдите и выберите свою базу данных «
Личные дела учащихся
».
1.5.
Щелкните мышкой по кнопке «
Открыть
».
2.
В режиме К
онструктора
создать в базе данных новую таблицу «
Экзаменационная оценка
5 «А» »
и заполните ее данными.
2.1.
Выполните команды: Таблицы
–
Создать
–
Конструктор
–
ОК
.
2.2.
Определение полей таблицы
:
2.3.
Для создания ключевого поля выделите поле «
Табельный номер
» и задайте команды:
Правка
–
Ключевое
поле
(либо щелкнуть по пиктограмме -
ключевое
поле
).
2.4.
Закройте текущее окно, щелкнув по кнопке , и подтвердив сох
ранение таблицы под именем «
Экзаменационная оценка
».
2.5.
Откройте вновь созданную таблицу. Заполните таблицу.
Табельный номер
Оценка1 -
математика
Оценка2 –
русский язык
Оценка3 -
история
Результат
Табельный номер
Оценка1 -
математика
Оценк
а2 –
русский язык
Оценка3 -
история
Результат
1
5
4
4
хор
хор
уд
хор
уд
отл
хор
уд
уд
хор
Имя поля
Тип поля
Табельный номер
числовой
Оценка1 математика
числовой
Оценка2
русский язык
числовой
Оценка3 история числовой
Резу
льтат
текстовый
30
2.6.
Закройте таблицу.
3.
В режиме К
онструктора
создать в базе данных еще одну таблицу «
Ст
ипендиат –
5 «А»
»
и заполните ее данными.
3.1.
Выполните команды: Таблицы
–
Создать
–
Конструктор
–
ОК
.
3.2.
Определение полей таблицы
:
3.3.
Для создания ключ
евого поля выделите поле «
Результат
» и задайте команды:
Правка
–
Ключевое
поле
(либо щелкнуть по пиктограмме -
ключевое
поле
).
3.4.
Закройте текущее окно, щелкнув по кнопке , и подтвердив сохранение таблицы под именем
«
Стипендиат –
5
«А»
».
3.5.
Откройте вновь созданную таблицу. Заполните таблицу.
3.6.
Закройте таблицу.
4.
Выведите таблицу «
5 «А» класс
» в режиме конструктора и дополните ее новым полем –
Оценка
(
тип поля
–
Мастер подстановки
).
4.1.
В окне <
База данных: Личные дела учащихся
>
щелкните мышкой по значку таблицы «5 «А» класс
».
4.2.
В том же окне нажмите кнопку Конструктор
.
4.3.
Установите курсор в строку с именем поля
Фамилия
и выполните команды
: Вставка –
Строки (либо щелкнуть по пиктограмме -
Добавить строки
)
4.4.
Введите имя поля –
Оценка
, тип поля –
Мастер подстановки
.
Имя поля
Тип поля
Результат
Текстовый
Стипендиат
Денежный (
формат поля –
Денежный)
Результат
Стипендиат
отл
150,00
хор
100,00
уд
50,00
31
4.5.
В первом окне Мастера
оставьте выбранным положение переключателя Объект «столбец подстановки» будет использовать значение из таблицы или запроса
и щелкните по кнопке Далее
.
4.6.
Выберите таблицу «
Экзаменационная оценка 5 «А»
» на роль источника подстановки. Щелкните по кнопке Далее
.
4.7.
В следующем диалоговом окне переведите все Доступные поля
в Выбранные поля
, для этого щелкните по кнопке . Щелкните по кнопке Далее
.
32
4.8.
Произвести сортировку данных по полю «
Т
абельный номер
» в порядке возрастания.
Щелкните по кнопке Далее
.
4.9.
Задайте ширину столбцов, которые содержит столбец подстановки, Для этого дважды щелкните по правой границе заголовка столбца
–
выполнится автоматический подбор ширины столбца.
4.10.
Удалите флажок –
Скрыть ключевой столбец
. Щелкните по кнопке Далее
.
4.11.
В следующе
м
диалоговом окне выберите поле Табельный
номер
, однозначно определяющее строку.
Щелкните по кнопке Далее
.
33
4.12.
Задайте имя столбца подст
ановки «
Оценка
».
Щелкните по кнопке Готово
.
4.13.
В появившемся окне диалога щелчком по кнопке Да
подтвердите необходимость сохранения построенной структуры.
4.14.
Закрыть окно Конструктора
, щелкнув по кнопке -
з
акрыть
.
5.
Создать связь между таблицами «
5 «А» класс
», «
Экзаменационная оценка –
5 «А»
»
, «
Стипендиат –
5 «А»
»
.
5.1.
Выполните команды: Сервис
–
Схема
данных
(либо щелкнуть по пиктограмме -
Схема данных
)
.
5.2.
Выполните команды: Связи
–
Д
обавить
таблицу
(либо щелкнуть по пиктограмме -
Отобразить
таблицу
).
5.3.
Добавить таблицы <
Экзаменационная оценка 5 «А»
>
, <
Стипендиат 5 «А»
>
. Добавление таблиц производится из окна Добавление
таблицы
. Для размещения таблицы в окне Сх
ема
д
анных
надо выделить ее и нажать кнопку Добавить
(либо дважды щелкнуть по требуемой таблице).
34
5.4.
Закройте окно Добавление таблицы
.
5.5.
Для установления связей между парой таблиц в окне Схема данных
надо выделить уникальное к
лючевое поле, по которому устанавливается связь
, а именно «
Табельный
номер
»
таблицы <
5 «А» класс
>
, и при нажатой левой кнопк
и
мыши протащить курсор в соответствующее поле «
Табельный
номер
» подчиненной таблицы <
Экзаменационная оцен
ка 5 «А»
>
. 5.6.
В появившемся окне Изменение связей отметьте галочкой операции «
Объединение целостности данных
», «
Каскадное обновление связанных полей
» и «
Каскадное удаление связанных полей
», после чего нажмите кнопку Со
здать
.
5.7.
Установите связь между другой парой таблиц в окне Схема данных
. Для этого выделите уникальное ключевое поле «
Результат
» в таблице <
Стипендиат 5 «А»
> и при
нажатой левой кнопк
и
мыши протащите курсор в поле «
Результат
» подчиненное таблицы <
Экзаменационная оценка 5 «А
»
>
. 35
5.8.
В появившемся окне Изменение связей отметьте галочкой операции «
Объединение целостности данных
», «
Каскадное обновление связанных полей
» и «
Каскадное удаление связ
анных полей
», после чего нажмите кнопку Создать
.
5.9.
Конечный вид схемы таблиц
:
5.10.
Закройте текущее окно, подтвердив сохранение. 6.
Созда
ть форм
у
«
5 «А» класс –
летняя сессия
».
6.1.
Выполните команды: Формы
–
Создать
–
Мастер
форм
–
5
«А» класс
. Щелкните по кнопке ОК
.
36
6.2.
Из окна Доступные поля
переведите в окно Выбранные поля
следующие поля: Табельный номер
Оценка
Фамилия
Имя
Отчество
Фото
6.3.
В этом же диалоговом окне щелкните мышкой по кноп
ке раскрывающегося списка в строке Таблицы и запросы
и выделите таблицу
<
Стипендиат
5 «А»
>
.
6.4.
Из окна Доступные поля
переведите в окно Выбранные поля
следующие поля: Результат
Стипендиат
6.5.
Щелкните по кнопке Далее
.
6.6.
Выберите тип представления да
нных 5 «А» класс
. Щелкните по кнопке Далее
.
6.7.
Выберите внешний вид формы: в один столбец
. Щелкните по кнопке Далее
.
37
6.8.
Выберите требуемый стиль –
официальный
. Щелкните по кнопке Далее
.
6.9.
Задайте имя формы –
5 «А» класс –
летние экзамены
. Ще
лкните по кнопке Готово
.
7.
Редактирование формы
.
Возможно, вас что
-
то не устраивает во внешнем виде созданной формы. Изменим ее, используя конструктор
. Для этого выполните команды: Вид
–
Конструктор
(либо щелкните по пик
тограмме -
Вид
)
.
7.1.
Установите расположение полей по предложенному образцу и учитывая следующие требования: «
Табельный номер
» -
размер шрифта -
11, начертание –
полужирный курсив, цвет текста –
темно
-
коричневый, цв
ет фона поля –
светло
-
желтый;
выравнивание текста –
по центру.
«
Фамилия
», «
Имя
», «
Отчество
» -
размер шрифта -
11, начертание –
жирный, цвет текста –
темно
-
синий;
«
Оценка
» -
размер шрифта -
11, начертание –
жирный, цвет текста –
темно
-
коричневый
, измените ширину, ухватив боковой маркер, и когда указатель мыши примет вид черной ладошки, перетащить поле до вида кнопки раскрывающегося списка.
«
Результат
», «
Стипендиат
» -
размер шрифта –
11, начерта
ние –
жирный, цвет фона поля –
светло
-
коричневый, цвет текста самого поля –
темно
-
коричневый;
«
Результат
» -
выравнивание текста по правому краю;
«
Фото
» -
удалить наименование поля.
38
7.2.
Перейдите в режим Форма
, для этого щелкните по пиктограмме -
Вид
(либо выполните команды: Вид
–
Режим
форма
). Убедитесь, что теперь форма выглядит красиво.
Пригласите преподавателя для демонстрации выполненного задания.
ВНИМАНИЕ
!
Закройте все открытые окна.
Выйдите
из
Microsoft
Office
Access
39
Лабораторная ра
бота № 4
Назначение запросов
Для отбора сведений по определенному признаку или для группировки данных из разных таблиц предусмотрены запросы. Запрос
–
это средство, позволяющее автоматизировать отбор, группировку и другие действия над данными
. Например,
есть таблица с данными о сотрудниках, и необходимо каждый месяц отбирать все сведения о тех, чей доход меньше среднего. Таким образом, появляется задача построения запроса обо всех сотрудниках, удовлетворяющих данному условию.
Запросы являются мощным сре
дством обработки данных, хранимых в таблицах Access
. С помощью запросов можно просматривать, анализировать и изменять данные из нескольких таблиц.
С помощью Access
могут быть созданы следующие типы запросов
:
Запрос
-
выборка
задает вопрос о данных, хранящихс
я в таблицах, и предоставляет полученный набор в режиме формы или таблицы без изменения данных. Перекрестные запросы предназначены для группирования данных и представления их в компактном виде.
Запрос с параметром позволяет определить одно или несколько у
словий отбора во время выполнения запроса.
Запрос
-
изменение изменяет или перемещает данные. К этому типу относятся: запрос на добавление записей, запрос на удаление записей, запрос на создание таблицы, запрос на обновление, запроса на поиск повторяющихся з
аписей в простой таблице или запросе. В Access
имеется возможность создавать запрос самостоятельно в режиме конструктора
или с помощью мастер
а по разработке запросов
. «
Мастер запросов
» автоматически выполняет основные действия в зависимости от ответов п
ользователя на поставленные вопросы. Постановка задачи
1.
Создать новую базу данных.
2.
Создать таблицу базы данных.
3.
Определить поля таблицы в соответствии с рис.
2.
4.
Ввести ограничения на данные, вводимые в поле «
Раздел
»: должны вводиться только слова «
Информ
атика
», «
Психология
», «
Статистика
», «Э
кология
», «
Математика
».
5.
Задать текст сообщения об ошибке, который будет появляться на экране при вводе неправильных данных в поле «
Раздел
».
6.
Ввести ограничения на данные в поле «
Название
»: эти данные не должны повторять
ся.
7.
Заполнить таблицу данными в соответствии с рис.1
. и проверить реакцию системы на ввод неправильных данных в поле «
Раздел
».
8.
Изменить ширину каждого поля таблицы в соответствии с шириной данных.
9.
Произвести быстрый поиск данных в таблице «
Таблица книг
».
10.
П
роизвести поиск данных с помощью фильтров по полю «
Раздел
».
11.
Произвести поиск данных с помощью расширенного фильтра по заданному условию.
12.
Создать простой запрос на выборку
.
13.
Данные запроса отсортируйте по полю «
Автор
» в порядке возрастания.
14.
Предварительный п
росмотр запроса на выборку.
15.
Сохранение запроса.
16.
Создать запрос на выборку с параметрами, в котором должны отображаться название книги
, автор
,
наличие
и год
, а в качестве параметра задайте название книги
. Выполните этот запрос для книги «
Математическая стат
истика
».
40
Рис.1
Код
Раздел
Название
Автор Издательство
Год
Нали
чие
125
Статистика
Математическая статистика
Калинина В.Н.
Дрофа
2002
26
101
Статистика
Статистика
Минашкин В.Г.
Проспект
2005
18
109
Статистика
Теория вероятностей и матем. статистика
Фадеева Л.Н.
Эксмо
2007
15
131
Статистика
Математические методы статистики
Крамер Г.
Мир
1975
2
74
Математика
Повторяем и систематизируем шк. курс алгебры и начала анализа
Крамор В.С.
Просвещение
1990
64
34
Математика
Математика
Бродский
Мир и образован
ие
2005
127
44
Математика
Конструирование современного урока математики.
Манвелов С.Г.
Просвещение
2005
8
284
Математика
Курс тригонометрии
Андронов Н.К.
Просвещение
1967
72
253
Математика
Высшая математика в упражнениях и задачах
Данко П.Е.
Высшая школ
а
1986
14
294
Психология
3
142
Экология
57
315
Информатика
Информационные технологии в профессиональной деятельности
Филимонова Е.В.
Феникс
2004
20
356
Информатика
Информационные технологии
Шафрин Ю.
Бином. Лаборатория знаний
2002
20
305
Инф
орматика
Практикум по информатике
Михеева Е.В.
Академия
2004
31
Алгоритм выполнения работы
1.
Для создания новой базы данных
:
Загрузите Access
, в появившемся диалоговом окне щелкните по кнопке «
Создать файл
».
Щелкните по кнопке «
Новая база данных
».
Выб
ерите папку «
Мои документы
» (пункт «
Папка
»), где ваша база данных будет находиться.
В диалоговом окне «
Файл новой базы данных
» задайте имя вашей базы данных следующим образом: имя файла
–
«
Книги
», а тип файла
–
«
База данных Access
».
Щелкните левой клавише
й мыши по кнопке Создать
.
41
2.
Для создания таблицы базы данных
:
В окне базы данных выберите вкладку Таблицы
, а затем щелкните по кнопке Создать
.
В окне Новая таблица
выберите пункт Конструктор
и щелкните ОК
. В результате проделанных операций открывается ок
но таблицы в режиме конструктора, в котором следует определить поля таблицы.
3.
Для определения полей таблицы
: рис.2
Введите в строки столбца «
Имя поля
» имена полей в соответствии с рис.2.
В строке столбца «
Тип данных
» щелкните по значку раскрывающегося списка и выберите типы данных в соответствии с рис.2
. Поля вк
ладки «
Общие
» оставьте такими, как предлагает Access
.
Встаньте курсором в строку поля «
Код
» и щелкните по пиктограмме «
ключ
» на панели Конструктор таблиц
.
Щелкните по пиктограмме -
Сохранить
и сохраните таблицу под именем «
Таблица
книг
», д
алее щелкните по кнопке .
4.
Для задания условия на значение для вводимых данных
:
Щелкните мышкой по значку проектируемой таблице «
Таблица книг
»
.
Войдите в режим Конструктор
для проектируемой таблицы –
для этого щелкните по вкладке Конструктор
.
В верхней части окна щелкните по полю «
Раздел
»
.
В нижней части окна
щелкните сначала по строке параметра «
Условие на значение
», а затем по кнопке Построитель выражений
.
Панель -
Конструктор таблиц
42
В появившемся окне «
Построитель выражений
» напишите сло
во Информатика
, а затем щелкните по кнопке , выполняющей функцию ИЛИ
, напишите Статистика
, снова щелкните по этой же кнопке, напишите слово Математика
, снова щелкните по этой же кнопке, напишите слово
Экология
, снова щелкните по этой же кнопке, нап
ишите слово Психология
Щелкните по кнопке ОК
.
5.
В строке «
Сообщение об ошибке
» введите предложение:
Такой дисциплины нет, правильно введите данные
6.
Введите ограничения на данные в поле «
Название
», т.е. данные не должны повторя
ться.
Для этого:
Щелкните по полю «
Название
»
.
Щелкните по строке параметра «
Индексированное поле
»
.
Выберите в списке пункт: «
ДА (совпадения не допускаются
)»
Перейдите в режим «
Таблица
», выполнив команды: меню В
ид -
Режим таблицы
На вопрос о сохранении таблицы щелкните по кнопке «
Да
».
7.
Введите данные в таблицу в соответствии с рис.1
(см. в начале лаб
. р
аботы)
.
43
Попробуйте в поле «
Раздел
» ввести слово Физика и
нажмите на клавишу
Enter
.
На экране должно появиться сообщение:
«
Такой дисциплины нет, правильно введите данные
» Щелкните по кнопке OK
и введите всю информацию в т
аблицу –
см.
рис.1
.
8.
Для изменения ширины каждого поля таблицы
в соответствии с шириной данных применяются следующие действия:
Щелкните мышкой в любой строке поля «
Код
»
.
Меню Формат
-
Ширина столбца
.
В диалоговом окне щелкните по кнопке «
По ширине данных
»
.
Аналогично измените ширину остальных полей
.
Попробуйте изменить ширину поле
й с помощью мыши (вспомните, как это делается в MS
Excel
).
9.
Для поиска в таблице «
Таблиц книг
» книги «
Математические методы статистики
»:
Переведите курсор в первую строку поля «
Название
»
.
Выполните команды: меню «
Правка
» -
«
Найти
»
.
В появившейся ст
р
оке параметра «
Образец
» введите Математические методы статистики
.
В строке параметра «
Просмотр
» должно быть слово «
Все
»
.
В строке параметра «
Совпадение
» выберите из списка «
С начала поля
»
Щелкните по кнопке «
Найти далее
» -
выделится название книги
!
!!!
!
Для выхода из режима поиска
щелкните по кнопке «
Закрыть
».
10.
Произвести поиск данных с помощью фильтр
а по полю «
Раздел
».
Щелкните по записи «
Информатика
» поля «
Раздел
»
.
Выполните команды: меню «
Записи
» -
«
Фильтр
» -
«
Фильтр по выделенному
»
.
В исходной таблице останутся записи только о книгах, относящихся к дисциплине «
Информатика
»
.
Выполните команды: меню «
Записи
» -
«
Удалить фильтр
».
44
В таблице появятся снова все исходные данные
.
Самостоятельно произведите поиск -
книг толь
ко
2005 года издания
.
Самостоятельно произведите поиск -
книг, наличие которых равно 20
.
11.
Произвести поиск данных с помощью расширенного фильтра по полю «
Наличие
»
. Для этого выполните команды:
Меню «
Записи
» -
«
Фильтр
» -
«
Расширенный фи
льтр
»
.
Перенесите с помощью нажатой левой клавиши мыши
все названия полей в строку поле: «
Код
книги
», «
Название
»,
«
Автор
», «
Год издания
», «
Издательство
», «
Раздел
», «
Наличие
».
В строку «
Условия отбора
» для поля «
Наличие
» введите параметр: >5
Щелкните по меню «
Фильтр
» -
«
Применить фильтр
» (либо щелкнуть левой клавиши мыши на панели Фильтр
по пиктограмме
-
«
Применить фильтр
»).
Появится новая таблица, в которой отразятс
я только те книги, количество которых больше пяти.
Щелкните меню «
Записи
» -
«
Удалить фильтр
». Аналогично произведите фильтрацию по полю «
Раздел
», для этого в строке «
Условие отбора
» введите параметр: Математика
Аналогично произведите филь
трацию по полю «
Год
», для этого в строке «
Условие отбора
» введите параметр: 2002
Аналогично произведите фильтрацию по полю «
Издательство
», для этого в строке «
Условие отбора
» введите параметр: Мир
Аналогично произведите фильтрацию по полю «
Разд
ел
», для это в строке «
Условие отбора
» введите параметр: Статистика
, а в строке «
Условие отбора
» поля «
Наличие
» введите параметр: >15
Панель -
Фильтр
45
Закройте диалоговое окно «
Таблица книг: таблица
»
, для этого щелкните по кнопке .
12.
На основе таблицы «
Таблица кни
г
» создать простой запрос на выборку, в котором должны отображаться названия книг
.
В окне базы данных откройте вкладку «
Запросы
»
.
Щелкните по кнопке «
Создать
»
.
В появившемся диалоговом окне «
Новый запрос
» выберите «
Простой запрос
», щелкните ОК
.
В появившемся диалоговом окне в строке «
Таблицы
и запросы
:» выберите таблицу «
Т
аблица книг
», для этого щелкните по значку раскрывающего списка.
В окне «
Доступные поля
:» выделите параметр «
А
втор
»
.
Переведите параметр «
Автор
» в окно «
Выбранные поля
», для этого щелкните по кнопке .
Аналогично в окно «
Выбранные поля
» переведите поля «
Название
» и «
Год
»
.
46
Щелкните по кнопке Далее
.
В диалоговом окне «
Создание простых запросов
» выбер
ите «
подробный отчет
»
Щелкните по кнопке Далее
.
В появившемся диалоговом окне в строке параметра «
Задайте имя запроса
» введите новое имя «
Автор, название, год
» Щелкните по кнопке .
Готово
.
В результате на экране появится таблица с результат
ами запроса.
47
13.
Данные запроса отсортируйте по полю «
Автор
» в порядке возрастания
. Щелкните в любой строке поля «
Автор
»
Выполните команды: меню «
Записи
» -
«
Сортировка
» -
«
Сортировка по возрастанию
»
14.
Для просмотра запроса на выборку «
Автор, назван
ие, год
» выполните кома
нды
:
Меню «
Файл
» -
«
Предварительный просмотр
» Закройте окно просмотра
, для этого щелкните по кнопке З
акрыть
.
15.
Для сохранения запроса
на выборку «
Автор, название, год
»
:
выполните команды: меню «
Файл
» -
«
Сохранить
»
закройте окно запроса.
16.
Для создания запроса на выборку с параметрами
, в котором должны отображаться «
название
», «
автор
», «
наличие
» и «
год
», с учетом того, что в качестве параметра задается «
название
книги
», выполните следующие команды:
Щелкните по вкладке «
Зап
росы
» по кнопке Конструктор
.
В появившемся диалоговом окне «
Автор, название, год
: запрос на выборку
»
перенесите в строку «
Поле
» следующие поля: «
н
азвание
», «
а
втор
», «
н
аличие
» и «
год
» с помощью нажатой левой клавишей мыши
!!!
В строке «
Условия от
бора
:» для поля «
Название
» введите фразу (
скобки тоже вводить !!
!):
[
н
азвание книги
]
48
Сохраните запрос на выборку
«
Автор, название, год
», выполнив команды:
меню «
Файл
»
-
«
Сохранить
» Закройте окно запроса
, щелкнув левой клавишей мыши по кнопке Щелкните дважды мышкой
по значку запроса «
Автор, название, год
» В появившемся окне введите название книги «
Математическая статистика
» и щелкните ОК.
На экране появится таблица с данными о книге.
Закройте окно запроса.
Аналогично сформируй
те запрос о книги «
Высшая математика в упражнениях и задачах
». Пригласите преподавателя для демонстрации выполненного задания.
ВНИМАНИЕ
!
Закройте все открытые окна.
Выйдите
из
Microsoft
Office
Access
49
Лабораторная работа № 5
Создание отчетов
Отчет
–
это гибкое и эффективное средство для просмотра и ра
спечатки итоговой информации. В отчете можно представить данные в удобной для чтения и анализа форме, сгруппировать записи
(по нескольким уровням) с вычислением итоговых и средних значений, получить результаты сложных расчетов, статистических сравнений, в него можно поместить рисунки и диаграммы.
Access
выводит информацию из базы данных в виде отчета (распечатки содержимого базы данных). Все отчеты подразделяются на три категории:
Простая распечатка
содержимого базы данных из режимов таблицы или формы;
Дет
альные отчеты
–
хорошо подготовленные отчеты, представленные в любом удобном для пользователя виде и включающие в себя ряд дополнительных элементов;
Специальные отчеты
–
позволяют подготавливать почтовые наклейки и формы писем.
Способ вывода на печать таб
лиц и форм удобен для построения быстрого чернового варианта отчета
. Преимущество
таких отчетов –
быстрота и простота их получения. Недостатком
является вывод данных точно в таком же виде, в каком они содержатся в таблице или форме, а
при распечатке данных с использованием формы Access
выводит на странице столько записей, сколько на ней может поместиться и возможен вариант, когда часть одной записи разместиться в конце одной страницы, а другая –
в конце следующей.
Пр
и выводе на печать данных из табличного режима с целью улучшения вида распечатки можно использовать следующие возможности изменения внешнего вида таблицы:
Уменьшить ширину некоторых столбцов таблицы;
Скрыть некоторые столбцы;
Поменять ориентацию страниц
ы с книжной на альбомную.
Для получения отчета улучшенного внешнего вида необходимо подготовить детальный отчет
. Он должен иметь наглядную форму и содержать больше информации, чем простая распечатка таблицы. Целесообразно для создания обычного детально
го отчета использовать мастера отчетов
. Мастер по разработке отчетов выполняет всю рутинную работу и позволяет быстро разработать отчет. После вызова мастера выводятся диалоговые окна с приглашением ввести необходимые данные, и отчет создается на основании
отчетов пользователя. Если созданный мастером отчет не полностью вас удовлетворяет, то вы можете изменить его в режиме конструктора.
Access
включает следующие отчеты
: конструктор, мастер отчетов, автоотчет в столбец, автоотчет ленточный, мастер диагра
мм, почтовые наклейки.
50
Постановка задачи
На основании таблицы «
Таблица книг
» создайте отчет с группированием данных по разделам.
Алгоритм выполнения работы
1.
Пуск
–
Программы
–
Microsoft Office
-
Microsoft Office Access
2.
Щелкните мышкой п
о пиктограмме -
открыть
(либо меню Файл
–
О
ткрыть
)
3.
Щелкните мышкой по папке «
Мои документы
»
4.
Найдите и выберите свою базу данных «
Книги –
ваша Фамилия
»
5.
Щелкните мышкой по кнопке «
Открыть
»
6.
В окне базы данных
выберите вкладку «
Отчеты
» и щелкните по
кнопке «
Создать
»;
7.
В открывшемся диалоговом окне «
Новый отчет
» выберите пункт «
Мастер отчетов
»;
8.
Щелкните по значку раскрывающегося списка в нижней части окна и выберите в качестве источника данных таблицу «
Таблица книг
» и щелкните по кнопке ОК
;
51
9.
В появившемся диалоговом окне выберите все поля таблицы
и из окна «
Доступные поля:
» переведите их в окно «
Выбранные поля:
», для этого щелкните по кнопке 10.
В окне «
Выбранные поля:
» выделите поле «
Код
» и переведите его обратно в окно «
Доступные поля
:», для этого щелкните по кнопке 11.
Щелкните по кнопке «
Далее
»
.
52
12.
В новом диалоговом окне «
Добавить уровни группировки?
» выделить поле «
Раздел
» и щ
елкните по кнопке , таким образом вы зададите группировку данных по разделам.
13.
Щелкните по кнопке «
Далее
».
14.
В появившемся диалоговом окне «
Выберите порядок сортировки и вычисления, выполняемые для записей
» щелкните по значку раскрывающего списка , находящегося около кнопки «
по возрастанию
»;
15.
Выделите поле «
Автор
», таким образом по заданному полю все фамилии будут отсортированы в алфавитном порядке
;
16.
Щелкните по кнопке «
Итоги
»
53
17.
В по
явившемся диалоговом окне «
Какие итоговые значения необходимо вычислить?
» напротив поля «
Наличие
» установите флажок
и щелкните по кнопке ОК
18.
Щелкните по кнопке «
Далее
»;
19.
В появившемся окне «
Выберите вид макет
а для отчета
» выберите:
вид оформления отчета
–
ступенчатый
;
ориентацию
–
альбомная
;
20.
Щелкните по кнопке «
Далее
»
21.
В диалоговом окне «
Выберите требуемый стиль
» выберите стиль оформления –
«Д
еловой
»
22.
Щелкните по кнопке «
Далее
»
.
54
23.
В появившемся окн
е введите имя отчета «
Книги
» и щелкните по кнопке «
Готово
», на экране появится сформированный отчет;
24.
Просмотрите, возможно, вас что
-
то не устраивает во внешнем виде созданного отчета. Измени
те
его
самостоятель
но
, используя К
онструктор
. Для того чтобы работать в режиме Конструктора
выполните команды: Вид
–
Конструктор
(либо щелкните по пиктограмме -
Вид
)
.
Пригласите преподавателя для демонстрации выполненно
го задания.
ВНИМАНИЕ
!
Закройте все открытые окна.
Выйдите
из
Microsoft
Office
Access
55
Учебное издание
Практикум по технологии работы
с системой управления базой данных
Microsoft office Access
Автор
–
Мартынова
Т
.
С
.
Автор
permwiki
Документ
Категория
Без категории
Просмотров
406
Размер файла
1 784 Кб
Теги
практикум, технология, работа, субд, access
1/--страниц
Пожаловаться на содержимое документа