close

Вход

Забыли?

вход по аккаунту

?

Широкова И.Э., Полюшкина Н.А. Использование электронных таблиц Excel 2007 в профессиональной деятельности учителя начальной школы. Методические рекомендации

код для вставкиСкачать
Иркутск: ИПКРО, 2011. –36 с.
Министерство образования и науки РФ
ОГОУ ДПО «Институт повышения квалификации
работников образования»
Широкова И.Э., Полюшкина Н.А.
Использование электронных таблиц
Excel 2007 в профессиональной деятельности
учителя начальной школы.
Методические рекомендации
Иркутск, 2011
1
Печатается по решению Редакционно-издательского совета ИПКРО
УДК 371
ББК 74.202.2
Ш 87
Широкова И.Э., Полюшкина Н.А. Использование электронных
таблиц Excel 2007 в профессиональной деятельности
учителя
начальной школы. Методические рекомендации. –Иркутск: ИПКРО,
2011. –36 с.
Рецензент:
В.А. Дурасов, к.т.н., зав кафедрой информатики ИПКРО
Методические рекомендации предназначены для педагогов
начальной школы, желающих овладеть знаниями и умениями,
позволяющими высокоэффективно использовать информационные
технологии, в частности, электронные таблицы MS Excel, в
профессиональной деятельности. Методические рекомендации
помогут педагогу начальной школы создать комплекс обучающих и
тестовых заданий для уроков математики, русского языка и др., а
также использовать возможности программы для создания
дидактических, раздаточных материалов.
ISBN 978-5-91344-252-9
© Иркутский ИПКРО, 2011
© Широкова И.Э.,Полюшкина Н.А. 2011
2
Содержание
Введение
4
Справочный материал по Exel 2007
6
Создание таблиц. Форматирование ячеек. Простейшие
формулы и функции
10
Работа с объектами (рисунками, фигурами)
16
Использование формул и функций
24
Создание кроссвордов. Использование макроса.
29
3
Введение.
Дети младшего школьного возраста, как правило, с большим
интересом участвуют в реализации небольших учебных проектов, и
при этом зачастую
самостоятельно и без ощутимых усилий,
выполняя несложные задания, осваивают новые действия и операции.
Это объясняется психологическими особенностями восприятия,
памяти и поведения учащихся начальной школы. Часто ребенку
достаточно один раз посмотреть «как это делается», чтобы повторить
это действие самому.
Дети легко запоминают действия учителя в процессе демонстрации
чего-либо на экране компьютера (электронной доске) и визуально
осваивают многие операции и способы деятельности с экранными
объектами
(с
символами,
словами,
абзацами,
графическими
примитивами, связанные с выделением, изменением цвета, вставкой
рисунков и т.д.) В дальнейшем обучении, при возможности
поработать самостоятельно, дети активно применяют эти умения.
Применение компьютерных технологий в начальной школе помогает
учителю по-новому организовать учебный процесс, оживить и
разнообразить, сделать более интересным и позволяет:
 усилить образовательные эффекты;
 повысить качество усвоения материала;
 осуществить дифференцированный подход к детям с разным
уровнем готовности к обучению;
 организовать одновременно детей, обладающих различными
способностями и возможностями.
4
В начальной школе информационные технологии могут быть
использованы на всех этапах урока: при объяснении нового
материала, закреплении, повторении, во время устного счёта.
Применение на уроке компьютерных тестов, самостоятельных
работ,
позволит
учителю
за
короткое
время
получать
объективную картину уровня усвоения изучаемого материала и
своевременно его скорректировать.
Под использованием “новых информационных технологий” в
начальной
школе
следует
понимать
не
обучение
адаптированным для начальной школы “основам информатики”,
а комплексное преобразование “среды обитания” учащегося,
создание новых средств для его развития и активной творческой
деятельности.
Компьютер в обучении младшего школьника должен стать
обогащающим и преобразующим элементом развивающей
предметной среды. Ведь именно в этом возрасте происходит
интенсивное
развитие
умственных
способностей
ребенка,
закладывается фундамент его дальнейшего интеллектуального
развития. Такое понимание использования компьютера имеет
гуманитарный развивающий характер.
Представленные в данном пособии задания могут быть
использованы при работе в компьютерном классе, в классе,
оборудованном
учебного
интерактивной
материала
с
доской,
для
использованием
демонстрации
проектора,
для
самостоятельной работы учащихся.
5
Справочный материал по Excel 2007
Кнопка Office – действия с
документом (открытие, создание)
и параметры Excel
Панель быстрого доступа
Панель вкладок
Строка заголовка
Группы команд
Ярлыки вкладок
Всплывающая контекстная вкладка (содержит команды для
выделенного объекта: таблицы, рисунка и т.д.)
Поставленн
Требуемые действия
ая задача
Ввести
Щелкните нужную ячейку и введите текст.
текст в одну Зафиксировать данные можно одним из способов:
из ячеек
- начать клавишу {Enter};
- щелкнуть мышкой по другой ячейки;
Выделение 1. Блок ячеек – Нажмите кнопку мыши на верхней
элементов
левой ячейке блока, не отпуская кнопки мыши,
таблицы
протяните курсор до нижней правой ячейки блока,
затем отпустите кнопку мыши.
6
2. Строку или столбец – Щелкните по заголовку
строки или столбца.
3. Несколько строк или столбцов – Нажмите кнопку
мыши на заголовке первой строки или столбца, не
отпуская кнопки мыши, протяните курсор до
последнего заголовка строки или столбца нужного
диапазона, затем отпустите кнопку мыши.
4. Несколько блоков ячеек – Выделите первый блок
ячеек, затем нажмите клавишу {Ctrl} и, не отпуская ее,
выделите остальные блоки.
5. Выделить все ячейки листа – Щелкните по
прямоугольнику в верхнем левом углу рабочего листа,
где пересекаются полосы заголовков строк и столбцов.
Изменить
Выделите столбец или несколько столбцов. Протащите
ширину
с помощью мыши правую границу заголовка столбца
столбцов
до тех пор, пока столбец не станет нужной ширины
(все выделенные столбы станут одинаковой ширины).
Изменить
Выделите строку или несколько строк. Протащите с
высоту
помощью мыши нижнюю границу заголовка строки до
строк
тех пор, пока строка не станет нужной высоты (все
выделенные строки станут одинаковой высоты).
Изменить
Выделите ячейки или отдельные символы, которые
размер,
нужно отформатировать.
стиль,
Дальнейшие действия сходны с действиями,
выравниван выполняемыми в текстовом редакторе Microsoft Word
ие текста в (можно выбрать команды на вкладке Главная, в
ячейке;
группах команд Шрифт и Выравнивание, либо
добавить
нажать на кнопку открытия диалогового окна Формат
обрамление ячеек в любой из групп команд, эта кнопка находится
ячеек
в правом нижнем углу группы команд).
Разместить Выделите нужные ячейки. Выберите на вкладке
текст
в Главная  Выравнивание Перенос текста. Либо
7
несколько
строк
Объединить
несколько
ячеек
Повернуть
содержимое
ячейки
Копировать
данные
с
помощью
протаскиван
ия маркера
заполнения
Заполнить
ряд членами
арифметиче
ской
прогрессии
откройте диалоговое окно Формат ячеек, нажав кноку
в правом нижнем углу любой из групп команд,
выберите вкладку Выравнивание и установите
флажок Переносить по словам. Нажмите кнопку Ок.
Выделите блок ячеек, которые нужно объединить в
одну. Выберите на вкладке Главная  Объединить и
поместить в центре. Объединять ячейки, которые
будут
использоваться
при
вычислении,
не
рекомендуется.
Для того чтобы снять объединение ячеек, выделите
объединеннную ячейку и выберите на вкладке
Главная группу команд Выравнивание, нажмите на
кнопку раскрывающегося списка команд рядом с
кнопкой Объединить и поместить в центре.
Выберите команду Отменить объединение ячеек.
Выделите ячейки, которые нужно отформатировать.
Нажмите на вкладке Главная, в группе команд
Выравнивание, кнопку Ориентация. Выберите в
появившемся списке команд нужный вариант.
Выделите ячейку, содержащую данные, которые
нужно скопировать. Протащите маркер заполнения
(квадратик в нижнем правом углу ячейки) так, чтобы
выделить все ячейки, которые нужно заполнить, а
затем отпустите кнопку мыши.
Все существующие ранее значения или формулы в
заполняемых ячейках будут замещены.
Введите в соседних ячейках два значения
арифметической прогрессии. Выделите эти две ячейки.
Протащите маркер заполнения (квадратик в нижнем
правом углу ячейки) в направлении, которое нужно
заполнить.
8
Вставить
формулу
Выделите ячейку, в которую вы хотите поместить
формулу. Введите знак равенства (=) для активизации
строки формул. Наберите формулу. Чтобы вставить
ссылки на данные в ячейках в формулу, щелкните по
ячейке левой кнопкой мыши (адрес ячейки запишется
в формулу). Чтобы завершить ввод формулы, нажмите
клавишу {Enter}.
Знаки, которые можно использовать в формуле:
+ сложение;
- вычитание;
/ деление;
* умножение;
() скобки;
: используется для обозначение диапазона ячеек
(например, B2:D5 – обозначает блок ячеек B2, B3, B4,
B5, C2, C3, C4, C5, D2, D3, D4, D5).
Вставить
Выделите ячейку, в которой вы хотите набрать
функцию в формулу. В строке формул нажмите на кнопку
формулу с Вставить функцию. В окне диалога Мастера
помощью
Функций, вводится список типов функций. Выберите
Мастера
категорию функции. Категория Все включает все
Функций
функции рабочего листа. Далее следуйте указаниям
Мастера Функций, вводя требуемые значения
аргументов и ссылки.
Вставить
Нажмите на кнопку Вставить лист рядом с
рабочий
ярлычками листов, либо на вкладке Главная, в группе
лист
инструментов Ячейки, выберите раскрывающийся
список Вставить, затем Вставить лист.
Переместит Потяните ярлычок перемещаемого листа вдоль ряда
ь
лист ярлычков. Черный треугольник служит указателем
внутри
места, в которое будут вставлены перемещаемые
рабочей
листы.
9
книги
Переименов
ать лист
Удалить
листы
Дважды щелкните по ярлычку листа. Введите с
клавиатуры новое имя листа. Нажмите Enter.
Выберите лист, который нужно удалить. на вкладке
Главная, в группе инструментов Ячейки, выберите
раскрывающийся список Удалить, затем Удалить
лист.
Создание таблицы. Форматирование ячеек.
Простейшие формулы и функции.
Запустите программу табличного редактора. Обратите внимание,
что электронные таблицы – это таблицы со столбцами и строками.
Столбцы пронумерованы буквами, строки пронумерованы цифрами.
Поле, которое расположено на пересечении столбца и строки,
называется ячейкой. Каждая ячейка идентифицируется с помощью
буквы столбца и цифры строки, например, А1. В течение 10 минут
выполните следующее задание:
1. Напечатайте 3 различных слова в ячейках A1, A2 и A3.
2. Введите 3 различных цифры в ячейки B1, B2
и B3.
3. Измените ширину столбцов и высоту строк.
Задание 1. Операции с числами
10
1. Объедините ячейки А1 – Е1. Впишите заголовок и
расположите его по центру. Измените цвет текста.
2. В ячейки А2 – Е2 впишите заголовки столбцов таблицы,
изменив их ширину. Закрасьте каждую ячейку заголовка своим
цветом.
3. Заполните столбцы Число 1 и Число 2.
4. В ячейку С3 введите формулу =a3+b3. Заполните
аналогичным способом ячейки С4, С5, С6, С7.
5. В ячейку D3 введите формулу =a3-b3. Заполните ячейки D4D7, используя маркер заполнения (квадратик в нижнем правом углу
ячейки).
6. Заполните ячейки Е3-Е7 самостоятельно.
Задание 2. Классный журнал
Создайте журнал в виде таблицы, основанной на заданиях и
практике оценивания, которые Вы используете в классе. Посмотрите
на следующий пример.
Запустите программу табличного редактора и откройте новую,
пустую таблицу.
1. Переименуйте Лист 1, присвоив ему имя школьного предмета,
который Вы выбрали.
2. В ячейке А1 напишите заголовок – название таблицы. Измените
внешний вид заголовка.
3. Сейчас вы будете добавлять заголовки столбцов в свою таблицу.
Впишите «Фамилия» в ячейку А3 и «Имя» в ячейку В3. Затем в
11
ячейки от С3 до F3 впишите информацию, которая определяет 4 из 5
заданий или упражнений, которые вы хотите включить в журнал. В
конце напечатайте «Сумма баллов» и «Средний балл» в ячейках G3 и
H3.
4. Измените внешний вид заголовка в строке 3.
Задание повышенной сложности: Поверните заголовки в ячейках от
C3 до H3 так, чтобы они располагались по диагонали. (Смотрите
пример в конце раздела - таблица с журналом по математике). (За
справкой обращайтесь к разделу Электронные таблицы 5.7. Как
изменить выравнивание информации в ячейке или ячейках).
5. Измените ширину столбцов от B до H, чтобы вместить всю
информацию. Если ваши столбцы всё еще слишком широкие,
измените перенос текста так, чтобы информация располагалась на
двух или более строках.
6. В ячейках от A4 до A9 впишите фамилии пяти учащихся. Затем в
ячейках от B4 до B9 впишите имена учащихся. Если нужно, измените
ширину столбцов.
7. Напишите оценки или баллы за каждое задание или упражнение в
четырех ячейках справа от имени школьника.
8. В ячейку G4 вставьте функцию Суммы, которая посчитает общий
балл первого ученика. Затем скопируйте формулу в четыре ячейки
ниже.
9. В ячейке H4 вставьте функцию Среднее значение, которая
вычислит средний балл для первого ученика. Убедитесь, что ряд
ячеек включает только ячейки с оценками заданий (ячейки с C4 до
F4), и не включают общую оценку (ячейку G4).
10. Примените функцию Среднее значение для 4 ячеек ниже H4.
11. Измените средние значения, так чтобы они все имели два знака
после запятой. Измените ширину столбца если необходимо.
12
12. Чтобы убедиться, что журнал будет функционировать правильно,
когда будет добавлена новая оценка, вставьте столбец между
столбцами F и G.
13. В ячейку G3 впишите название пятого задания или упражнения.
Затем впишите оценку, которую каждый из пяти учеников получил за
пятое задание. Обратите внимание, что сумма баллов и средний балл
для каждого ученика меняется автоматически, когда добавляется
новая информация.
14. Используйте фамилию ученика в столбце А, чтобы расположить
ряды с 4 по 8 в алфавитном порядке или по возрастанию. (За
справкой обращайтесь к разделу Электронные таблицы 6.7. Как на
основании определенной информации отсортировать строки или
изменить их порядок).
15. Добавьте границы вокруг ячеек в таблице (За справкой
обращайтесь к разделу Электронные таблицы 5.8. Как добавить
границы ячейкам, строкам, столбцам или электронной таблице).
Задание повышенной сложности: Возможно, Вы захотите
сделать другой журнал для второго школьного предмета. Для
этого продублируйте лист, который только что создали, и
присвойте ему другое имя. Затем измените заголовок листа и
впишите новые задания или упражнения для оценивания
школьников. Вам также следует переименовать заголовок
таблицы. (Смотрите примеры в конце раздела).
16. Удалите все ненужные листы.
17. Сохраните свою таблицу.
13
Пример классного журнала по математике
Задание 3. Успеваемость
1. Открыть свою рабочую книгу. Добавить лист. Дать ему имя
Журнал 4А.
14
2. Начиная с ячейки А1 ввести заголовок, шапку таблицы. Заполнить
колонки ФИО, Дата по образцу.
3. Заполнить колонку №
с использованием автоматического
формирования арифметической прогрессии (автозаполнения).
4. Заполнить первую ячейку колонки средний балл с помощью
функции Среднее значение. Распространить эту формулу на
остальные ячейки колонки. Установить для этой колонки 2 знака
после запятой, используя соответствующую пиктограмму на
панелях инструментов.
5. Колонку Оценка заполнить вручную на усмотрение учителя.
6. Заполнить первую ячейку колонки количество пропусков с
помощью функции СЧЕТЕСЛИ. Распространить эту формулу на
остальные ячейки колонки.
7. Количество пропусков по всему классу считать с помощью
АВТОСУММА.
8. Присвоить ячейке кол-во учащ-ся значение последней ячейки
колонки № п/п.
9. Считать средний балл по классу с использованием функции
СРЗНАЧ. Установить формат по образцу с использованием меню
Формат.
10. Считать количество 5, 4, 3 и 2 с использованием функции
СЧЕТЕСЛИ.
11. Считать Успеваемость по формуле: (Кол-во 5+ Кол-во 4 + Колво 3)/Кол-во учащихся. Присвоить результату
формат
Процентный, используя пиктограмму.
12. Считать Качество обуч. по формуле: (Кол-во 5+ Кол-во 4)/Колво учащихся. Присвоить результату
формат Процентный,
используя пиктограмму.
13. Построить круговую диаграмму по Количеству оценок.
14. Выделить данные, по которым будем строить диаграмму.
15. Выбрать тип диаграммы Объемная круговая, используя группу
команд Диаграмма вкладки Вставка.
15
16. Работая с контекстной вкладкой Работа с диаграммами (вкладка
Макет) – придать диаграмме нужный внешний вид.
Работа с объектами (рисунками, фигурами)
Задание 1. Соедините стрелками слова в словосочетаниях.
1. В ячейке А1 напишите задание. Измените по своему вкусу цвет
и размер шрифта.
2. Напишите слова в два столбика, как показано на рисунке.
16
В процессе выполнения задания слова соединяются при помощи
стрелок: на вкладке Вставка в группе команд Иллюстрации
раскройте выпадающий список Фигуры и выберите в нем стрелку.
Нарисуйте стрелку: щелкнете мышью около первого слова (начало
стрелки), протяните указатель мыши до второго слова (конец
стрелки) и отпустите кнопку мыши. Чтобы нарисовать следующую
стрелку, нужно опять выбрать стрелку на панели вкладок! После
рисования первой стрелки панель вкладок примет следующий вид:
Т.е. при выделенной стрелке будет активна вкладка Средства
рисования – Формат, и в группе команд Вставить фигуры нужно
выбрать стрелку и соединить ею следующую пару слов.
Используя эту вкладку, можно
настроить вид стрелки – изменить
цвет,
толщину
линии,
вид
наконечника стрелки, создать для нее тень, придать объем и т.п.
Чтобы все стрелки в дальнейшем сразу рисовались такими
красивыми, щелкните по стрелке правой кнопкой мыши и выберите в
контекстном меню Назначить линией по умолчанию.
3. Ниже напишите вторую часть задания: Подчеркни
буквосочетания ЧК,ЧН, ЩН. Для подчеркивания буквосочетаний
выберите на вкладке Вставка – Фигуры – Фигуры для формул –
знак минуса. Этот знак рисуется всегда строго горизонтально.
17
Задание 2. Разделите рисунок тремя отрезками так, чтобы в
каждой части было по одному фрукту.
1. В ячейке А1 напишите задание (Как
разделить рисунок тремя отрезками,
чтобы в каждой его части было по
одному фрукту?),
измените по
своему вкусу цвет и размер шрифта.
2. Нарисуйте
под
заданием
прямоугольник (фон для картинок). Выберите на вкладке
Вставка
- Фигуры
и в группе Прямоугольники –
прямоугольник
нужного вида, нарисуйте его на экране. Чтобы
Рис.1
изменить цвет прямоугольника, выделите его и выберите на
вкладке Средства рисования – Формат – Заливка фигуры
нужный цвет, либо выберите в контекстном меню Формат
фигуры – Заливка – Цвет.
3. Вставьте в документ все необходимые картинки. Для этого на
вкладке Вставка выберите Рисунок, в открывшемся
диалоговом окне Вставка рисунка найдите необходимую
картинку (Рабочий стол – Картинки – Фрукты) и нажмите
Вставить.
4. Расположите картинки на экране поверх прямоугольника, как
показано на рис. 1. Если картинки слишком большие
(маленькие), их размер можно изменить, потянув мышью за
один из маркеров изменения размера.
5. Выделите все картинки и прямоугольник, щелкая по ним левой
кнопкой мыши при нажатой Shift на клавиатуре.
18
6. В контекстном
Группировать.
меню
выберите
Группировать
–
7. Нарисуйте разделительные линии. Для этого в меню Вставка
выберите Фигуры – Линии. Нарисуйте разделительные линии,
как на рис. 1. Выделите все три линии и сгруппируйте их.
8. Выделите группу линий и выберите в контекстном меню На
задний план – На задний план.
9. Чтобы продемонстрировать правильное решение, отправьте на
задний план группу фруктов.
10. Ниже рисунка напишите вопросы: Сколько отрезков получилось
на рисунке? Какие геометрические фигуры образовались?
Выделите границами ячейки, в которые должны вводиться ответы
(вкладка Главная, группа команд Абзац, кнопка Границы).
Задание 3. Часы.
В этом задании ученики должны определить по картинке, какие углы
(острый, прямой, тупой) образуют стрелки часов. Затем они отвечают
на вопрос по второй картинке – Сколько времени должно быть на
часах, чтобы стрелки образовали прямой угол, острый, тупой?
1. Нам понадобится изображение часов без стрелок. Создадим его
при помощи рисунка SmartArt.
На вкладке Вставка в группе команд Иллюстрации выберите
SmartArt, в меню открывшегося диалогового окна (слева) – Цикл, в
19
центральной части окна выберите самую первую фигуру – Простой
цикл.
Щелкните правой кнопкой мыши по любому из кружочков, и
выберите в контекстном меню команду Добавить фигуру. После
выполнения этой команды кружочков станет 6. Добавляйте фигуры,
пока их не станет 12.
Чтобы подписать цифры, щелкните по кружочку левой кнопкой
мыши 1 раз и введите число с клавиатуры.
Чтобы изменить цвет фигур, придать им объем, изменить форму и
т.п. – выделите их все одновременно, щелкая по фигурам левой
кнопкой мыши при нажатой клавише Shift на клавиатуре.
Затем измените параметры фигур, выбирая команды на всплывающей
контекстной вкладке Работа с рисунками SmartArt – Формат.
Таким же образом можно скорректировать вид
стрелочек, соединяющих кружочки – заменить
их, например, на прямоугольники.
В центре получившегося циферблата нарисуйте
маленький кружочек (Вставка – Фигуры).
Сгруппируйте его с циферблатом.
Наша заготовка для часов готова. Выделите ее,
скопируйте в буфер обмена и вставьте на лист 5 раз. У вас должно
получиться 6 циферблатов.
20
2. Напишите задание, используя Word Art.
Раскройте на вкладке Вставка в группе команд Текст выпадающий
список WordArt. Выберите один из стилей оформления. Вместо
«Текст надписи» введите «Какие углы образуют стрелки часов?»
Чтобы изменить размер шрифта, выделите весь текст надписи и
задайте нужный размер на вкладке Главная, в группе команд
Шрифт. Если выделить надпись как объект (а не текст внутри нее),
на панели вкладок станет активной вкладка Средства рисования Формат, и с надписью можно будет работать, как с рисунком –
добавлять тень, рельеф, поворот, изменять цвет заливки и текста и
т.п.
Таким же образом создайте отдельные надписи со словами
«Острый», «Тупой», «Прямой».
3. Расположите часы и надписи, как на рисунке. Нарисуйте стрелочки
(Вставка – Фигуры).
Совет: нарисовав первую стрелочку, измените ее цвет на черный,
увеличьте толщину линии. А затем выберите в контекстном меню для
этой стрелочки Назначить линией по умолчанию, тогда вам не
придется настраивать параметры линии для каждой стрелки отдельно.
4. Таким же образом оформите вторую часть задания:
21
Задание 4. Остров сокровищ.
В этом задании ученикам нужно найти клад – решить примеры и
составить фразу из соответствующих букв, расположив результаты в
порядке возрастания. Для оформления задания используются
картинки из коллекции ClipArt и буквы, созданные с помощью
WordArt.
Чтобы вставить картинку ClipArt:
Выберите на вкладке Вставка – Клип. В появившемся справа окне
введите следующие параметры:
Просматривать – Выделенные коллекции: галочки могут стоять
напротив Мои коллекции и Коллекции Microsoft Office, напротив
Веб-коллекции – галочку убрать!
Искать объекты – выберите Клипы; в строке Искать – можно
задать «Природа», «Растения», «Деревья».
Нажмите кнопку Начать. Выберите в найденных картинках нужное
изображение, щелкните по нему левой кнопкой мыши.
Найдите и вставьте в документ Excel несколько картинок.
Чтобы изменить размер картинки:
22
Выделите картинку (или несколько картинок) и потяните за маркер
изменения размера. Точный размер в см можно задать на вкладке
Работа с рисунками – Формат, в группе команд Размер.
Задание 5. Образовать из слогов слова.
23
Для оформления этого задания используются объекты Надпись, или
фигуры с добавленным текстом.
Создав первую фигуру и настроив ее свойства (выделите фигуру и
на всплывающей контекстной вкладке Средства рисования –
Формат задайте значения свойств), скопируйте ее в буфер обмена и
вставьте в документ. Вы можете изменить текст внутри фигуры через
контекстное меню, внешнее оформление и размер будут
одинаковыми для всех фигур.
Чтобы на экране не отображалась сетка, выберите на вкладке Вид –
Показать или скрыть, и уберите галочку у слова Сетка.
Использование формул и функций.
Задание 6. Занимательные квадраты.
В этом задании нужно составить «магические» квадраты с
предложенными числами. В магических квадратах сумма чисел в
каждом ряду, столбце и по диагоналям одинакова.
Чтобы организовать подсчет сумм чисел по строкам, столбцам и
диагоналям, используем функцию СУММ.
1. Выделите ячейку, в которой будет отображаться сумма чисел
первого столбца (в моем примере – ячейка H4).
24
2. На вкладке Главная в группе команд Редактирование нажмите на
кнопку со значком суммы (∑) выделите три ячейки ниже (в моем
примере – H5, H6, H7).
3. Нажмите кнопку Enter на клавиатуре, чтобы завершить ввод.
Теперь в строке формул для ячейки Н4 будет отображаться формула:
=СУММ(H5:H7).
4. Скопируйте эту формулу в ячейки, отображающие суммы по
второму и третьему столбцу (в моем примере – ячейки I4 и J4). Для
этого выделите ячейку с формулой (Н4) и потяните за маркер
заполнения в правом нижнем углу ячейки.
5. Аналогично подсчитываются суммы по строкам. Для первой
строки формула будет выглядеть так: =СУММ(H5:J5).
6. Чтобы подсчитать сумму по диагоналям, необходимо выделить три
несмежные ячейки, например, в моем примере для правой диагонали
– ячейки H5, I6, J7. Для выделения несмежных ячеек необходимо
удерживать нажатой клавишу Ctrl на клавиатуре.
Задание 7. Вставь пропущенные буквы.
В этом задании учащиеся
должны вписать пропущенные
буквы в пустые ячейки, и если
буква вписана правильно –
справа будет отображаться
красная галочка.
1. Напишите заголовок и слова
с пропущенными буквами в
столбик.
2. Для отображения галочек
будем использовать функцию
ЕСЛИ.
25
Внимание! Сама галочка – это символ, соответствующий клавише с
буквой «Ь» при использовании шрифта Wingdings.
Поэтому выделите все ячейки, в которых будут отображаться галочки
и установите для них следующие значения свойств: шрифт –
Wingdings, цвет – красный, размер – 48.
Выделите ячейку, в которой будет отображаться галочка (в моем
примере – ячейка L3).
Нажмите на кнопку Вставить функцию в строке функций.
В открывшемся окне Мастера функций выберите категорию –
Логические, функцию – ЕСЛИ. Нажмите кнопку ОК.
В открывшемся окне введите аргументы функции:
Логическое выражение (проверяем, равно ли значение в ячейке с
пропущенной буквой (в моем примере - D3) «правильной» букве (в
моем примере – букве У): D3 = «у»
Значение если истина (т.е. если ученик правильно вписал букву):
«ь»
Значение если ложь: (т.е. либо ученик написал неправильную букву,
либо ячейка пуста): « » (пустые кавычки).
Нажмите на кнопку ОК.
Теперь в строке формул для ячейки L3 будет отображаться формула:
=ЕСЛИ(D3="У";"ь";" ")
Аргументы функции записываются в скобках после названия
функции и разделяются ;.
3. Вставьте формулы проверки для остальных слов задания.
Задание 8. Запиши подходящие по смыслу слова.
В этом задании будем проверять правильность ответов с помощью
функции ЕСЛИ. В данном случае в ячейке может отображаться:
- слово «Правильно», если ученик ответил верно;
- слово «Неверно», если ученик ввел неправильный ответ;
- ничего не отображается, если ячейка с ответом пуста.
Так как у нас не 2, а три варианта содержимого ячейки, будем
использовать вложенную функцию (т.е. в качестве значения
26
аргумента функции ЕСЛИ будет использоваться не числовое или
текстовое значение, а значение другой функции (в нашем примере это
еще одна функция ЕСЛИ)).
Итак, пусть слова «Заяц прыгает, а ласточка» располагаются в ячейке
В2, ячейка для ответа ученика – С2, ячейка для проверки
правильности ответа – D2.
Тогда аргументами функции ЕСЛИ, которую мы должны ввести в
ячейку D2, будут:
Логическое выражение: С2= «летает»
Значение если истина: «правильно»
Значение если ложь: здесь мы можем написать либо «Неверно» либо
оставить ячейку пустой. Чтобы определиться, как именно поступить,
мы должны выяснить – ввел ли ученик неправильный ответ, или
ячейка для ответа пуста. Поэтому значением этого аргумента будет
определено в зависимости от того, выполняется ли условие: ЕСЛИ
С2 = «» (т.е. ячейка пуста), то и D2= «», иначе D2 = «Неверно».
ЕСЛИ(C2=0;" ";"Неверно")
Общий вид формулы, которая будет записана в ячейке D2:
=ЕСЛИ(C2="летает";"Правильно";ЕСЛИ(C2="";"
";"Неверно"))
27
Напишите формулы проверки правильности ответа для остальных
слов задания.
Задание 9. Заполни таблицу.
В этом задании будем
проверять
правильность
заполнения не каждой
клетки отдельно, а
выполнения всего
задания целиком.
После того, как ученик введет все ответы в пустые клетки, внизу
отображается одна из надписей: «Молодец, таблица заполнена без
единой ошибки!», «Есть ошибки, подумай еще», или ничего не
отображается (если хотя бы одна клетка пуста).
1. Оформите задание по образцу.
2. Объедините ячейки А12-Н12. В ней будет отображаться надпись.
3. Выделите объединенную ячейку. Для проверки правильности
выполнения задания будем использовать функцию ЕСЛИ.
Логическое выражение: (проверяем, правильно ли заполнены
ячейки) Чтобы показать, что правильные значения должны быть
введены во все ячейки таблицы, используется логическая функция И.
И(B10=3;C8=90;D9=3;E8=96;F9=2;G8=90;H10=28)
Значение если истина: "Молодец, таблица заполнена без единой
ошибки!"
Значение если ложь: мы должны проверить, есть ли среди ячеек,
предназначенных для ответа хотя бы одна пустая, и действовать в
зависимости от результата – либо написать «Есть ошибки, подумай
еще», либо оставить объединенную ячейку пустой. Как и в
предыдущем задании, используется вложенная функция ЕСЛИ.
28
Для проверки наличия хотя бы одной пустой ячейки используем
функцию ИЛИ.
ЕСЛИ(ИЛИ(B10=0;C8=0;D9=0;E8=0;F9=0;G8=0;H10=0))
У этой вложенной функции есть свои аргументы:
Значение если истина: (то есть имеется хотя бы одна пустая
ячейка): «» (пустые кавычки)
Значение если ложь: «Есть ошибки, подумай еще»
Итак, общий вид формулы:
=ЕСЛИ(И(B10=3;C8=90;D9=3;E8=96;F9=2;G8=90;H10=28);"Молодец,
таблица заполнена без единой
ошибки!";ЕСЛИ(ИЛИ(B10=0;C8=0;D9=0;E8=0;F9=0;G8=0;H10=0);"
";"Есть ошибки, подумай еще"))
Создание кроссвордов в электронной таблице Microsoft Excel 2007
Создание макета кроссворда.
 Запустите электронную таблицу MS Excel: Пуск – Программы –
Microsoft Office – Microsoft Excel.
 Перенесите макет кроссворда (столбцы и строки) на рабочий лист
программы, выделив ячейки для слов с помощью инструмента
Таблицы и границы – вкладка Главная. Оставьте сверху одну или
две пустые строки для названия кроссворда.
 Заполните и пронумеруйте слова в кроссворде. В каждую ячейку
должна вводиться одна буква. Установите желаемый размер и тип
шрифта.
 Настройте высоту и ширину ячеек: выделите столбцы B-F,
подведите курсор к границе столбца в области строки с буквамиименами столбцов. Нажав левую кнопку мыши, перетащите
границу одного из столбцов (ширина всех выделенных столбцов
станет одинаковой).
29
 На первой строке напечатайте заголовок и отформатируйте его по
центру, объединив ячейки А1-S1.
 Напечатайте вопросы.
Проверка правильности решения кроссворда.
Чтобы проверить, правильно ли ученик заполнил кроссворд, нужно
сравнить каждое введенное слово с образцом – правильным ответом.
Иначе говоря, для каждого слова мы будем сравнивать значения двух
30
ячеек – с введенным словом и правильным ответом, и если они
равны, помечать это слово как «верно».
Запишем на свободном месте листа Excel правильные ответы (потом
эта информация будет скрыта).
Но если правильный ответ представляет из себя целое слово,
записанное в одной ячейке, то ответ ученика – это совокупность
нескольких ячеек, в каждой из которых записано по одной букве.
Поэтому мы должны ответ ученика преобразовать так, чтобы его
можно было сравнить с правильным ответом, то есть соединить
отдельные буквы из разных ячеек в целое слово, записанное в одной
ячейке. Для этого будем использовать функцию для текстовых
величин СЦЕПИТЬ.
 Выделите ячейку, в которой будет записан преобразованный ответ
ученика (в моем примере это ячейка J20).
 В данной ячейке введите формулу (наберите с клавиатуры или
воспользуйтесь командой Вставить функцию на вкладке Формулы):
=СЦЕПИТЬ (M5;N5;O5;P5;Q5;R5;S5).
31
Аналогично сцепите остальные слова кроссворда.
Теперь можно сравнить правильный ответ с ответом ученика.
Для этого будем использовать функцию ЕСЛИ: если слова совпадут,
напишем напротив ответа «1», если нет «0». Мы используем
числовые значения, а не слова «верно» - «неверно», потому что в
дальнейшем проще будет подсчитать количество правильно
угаданных слов.
Введите в ячейку Р20: =ЕСЛИ(C20=J20;1;0).

С помощью маркера автозаполнения копируем формулу по столбцу
на весь необходимый диапазон (выделите ячейку Р20 и, удерживая
маркер автозаполнения левой кнопкой мыши, протяните до ячейки
Р30 включительно, затем очистите ячейку Р25).
32
Ниже напишите «Количество правильных ответов» и введите в
соседнюю ячейку формулу: =СУММ(P20:P30)
Скройте все строки (с 18 по 30) с ответами ученика, правильными
ответами и количеством угаданных слов.
Комментарий.
Пусть в процессе разгадывания кроссворда на экране высвечивается
комментарий «Отлично!», «Хорошо!», «Пока на «троечку»», «Пока
не угадано ни одного слова». Для этого введите в ячейку формулу:
=ЕСЛИ(P32=0;"Пока не угадано ни одного слова";ЕСЛИ (P32<7;
"Пока на троечку"; ЕСЛИ(P32<9;"хорошо!";"отлично!")))

Создание кнопки очистки кроссворда.
Создадим кнопку для очистки ячеек кроссворда с использованием
макроса.
Нажмите кнопку «Office»
, затем «Параметры Excel», выберите в
списке с левой стороны открывшегося окна «Настройка», затем из
списка вкладок выберите «Разработчик».
33
В списке команд найдите «Элементы управления» и нажмите кнопку
«Добавить», затем кнопку «ОК». Кнопка «Элементы управления»
будет добавлена на панель быстрого доступа.
На панели быстрого доступа нажмите кнопку «Элементы
управления», «Вставить», «Элементы управления формы», «Кнопка»
.
34
Нарисуйте кнопку. Автоматически откроется окно «Назначить
макрос объекту». Нажмите на кнопку «Записать», затем «ОК».
Выделите последовательно все клетки кроссворда и удалите из них
буквы.
На вкладке Вид выберите Макросы  Остановить запись.
Теперь щелчок левой кнопкой мыши будет запускать макрос, а
щелчок правой кнопкой – вызывать контекстное меню.
Чтобы изменить название кнопки, выберите в контекстном меню
«Изменить текст» и введите свое название (Очистить кроссворд).
Для правильного функционирования макроса не забудьте перед
работой уровень безопасности макроса выбрать Низкий: кнопка
Office – Параметры Excel – Центр управления безопасности –
Параметры центра – управление безопасностью – Параметры
макросов – Включить макросы.
Проверьте работу кроссворда (выставление оценки и кнопку очистки
кроссворда).
35
36
Автор
irina.shir
Документ
Категория
Методические пособия
Просмотров
303
Размер файла
5 074 Кб
Теги
методические рекомендации, начальная школа, excel
1/--страниц
Пожаловаться на содержимое документа