close

Вход

Забыли?

вход по аккаунту

?

отчет(2)

код для вставкиСкачать
ВВЕДЕНИЕ
Уже сравнительно давно компьютеры стали необходимой частью многочисленных производственных и управленческих процессов. Однако никогда ранее они столь не проникали в деятельность конкретных работников. Применение компьютеров в большой степени изменило привычный образ многих профессий, в одних случаях устраняя утомляющий однообразный характер работы, в других оставляя больше времени для творческого труда.
Практически все разнообразие применений компьютеров достигается за счет определенным образом проектированного программного обеспечения. Роль, которую отводит современная информатика пользовательской обработке данных и пользовательскому проектированию, резко возросло. Труд руководителей и сотрудников становится более производительным - за счет автоматизации рутинных операций, быстрой и удобной подготовки информации для принятия решений на разных уровнях. Современный эргономичный интерфейс обеспечивает легкость освоения для начинающих и высокую скорость работы для опытных пользователей.
В ходе прохождения практики на предприятии был разработан программный продукт, конечной целью использования которого на предприятии является повышение эффективности его работы, которое может выражаться, например, в увеличении прибыли и коммуникабельности предприятия.
Также в ходе прохождения проектно-технологической практики были изучены вопросы научной организации труда, техники безопасности, произведен анализ технико-экономических показателей предприятия.
1 ОПИСАНИЕ СТРУКТУРЫ ПРЕДПРИЯТИЯ, ОСНОВНЫХ ИНФОРМАЦИОННЫХ ПОТОКОВ, ИНФОРМАЦИОННОЙ СИСТЕМЫ ПРЕДПРИЯТИЯ. ИЗУЧЕНИЕ ТЕХНИКО-ЭКОНОМИЧЕСКИХ ПОКАЗАТЕЛЕЙ ДЕЯТЕЛЬНОСТИ ПРЕДПРИЯТИЯ
1.1 Структура предприятия
В сферу деятельности предприятия ООО "Копи-сервис" входит заправка использованных и продажа оригинальных и лицензионных картриджей, принтеров и канцелярии, а также набор и распечатка текста заказчика, дизайн визиток и ксерокопия.
Структура предприятия схематично представлена на Рисунке 1.1.
Рисунок 1.1 - Структура предприятия ООО "Копи-сервис"
1.2 Информационная система и информационные потоки предприятия
Информационная система предприятия - это все информационные потоки на предприятии, точки их возникновения, обработки, накопления и потребления конечными пользователями.
Информационные потоки (потоки данных) переносят информацию подсистемам или процессам, которые в свою очередь преобразуют информацию и порождают новые потоки, которые переносят информацию к другим процессам или подсистемам.
Для описания работы предприятия необходимо построить модель, модель должна быть адекватна предметной области, следовательно, она должна содержать в себе знания всех участников бизнес-процесса организации.
IDEF0 - Function Modeling - методология функционального моделирования и графическая нотация, предназначенная для формализации и описания бизнес-процессов. Отличительной особенностью IDEF0 является её акцент на соподчинённость объектов. В IDEF0 рассматриваются логические отношения между работами, а не их временна́я последовательность (WorkFlow).
Так же отображаются все сигналы управления, которые на DFD (Диаграмме Потоков Данных) не отображались. Данная модель является одной из самых прогрессивных моделей и используется при организации бизнес-проектов и проектов, основанных на моделировании всех процессов, как административных, так и организационных.
В IDEF0 система представляется как совокупность взаимодействующих работ или функций. Такая чисто функциональная ориентация является принципиальной - функции системы анализируются независимо от объектов, которыми они оперируют. Это позволяет более четко смоделировать логику и взаимодействие процессов организации.
Для реализации IDEF0 была использована программа BPWin. Она отличается достаточной простотой и большими возможностями анализа. Функциональность BPWin заключается не только в создании диаграмм, но и в проверке целостности и согласованности модели. BPWin обеспечивает логическую четкость в определении и описании элементов диаграмм, а также проверку целостности связей между диаграммами. Инструмент обеспечивает коррекцию наиболее часто встречающихся ошибок при моделировании. Кроме того, BPWin поддерживает пользовательские свойства, которые применяются к элементам диаграммы для описания специфических свойств, присущих данному элементу. Основным ограничением этой системы является положенный в ее основу стандарт IDEF, в котором существуют жесткие ограничения при построении моделей. Это упрощает задачу при описании простых процедур, но усложняет описание больших процессов. Схемы IDEF при описании сложных процессов начинают представлять бесчисленное множество взаимосвязанных схем, внешне очень похожих, что затрудняет понимание процесса в целом. Часто не удается представить нужную степень точности описания на одной схеме. IDEF0 модель, реализованная в среде BPwin, показана на рисунке 1.2.
Рисунок 1.2 - Контекстная диаграмма информационной системы предприятия ООО "Копи-сервис"
Рисунок 1.3 - Детализация контекстной диаграммы информационной системы предприятия ООО "Копи-сервис"
1.3 Анализ технико-экономических показателей деятельности предприятия
Сравнение технико-экономических показателей за 2010-2011 года деятельности ООО "Копи-сервис" представлены на рисунках 1.4-1.5.
Рисунок 1.4 - Объем проданной продукции за 2010-2011 гг.
Рисунок 1.5 - Объем выполненных работ по ремонту и заправке картриджей за 2010-2011 гг.
2 ОЗНАКОМЛЕНИЕ С ИНФОРМАЦИОННЫМИ ПОТОКАМИ ПОДРАЗДЕЛЕНИЯ, ВХОДЯЩЕЙ И ИСХОДЯЩЕЙ ИНФОРМАЦИЕЙ. АНАЛИЗ ИНФОРМАЦИОННОЙ СИСТЕМЫ ПОДРАЗДЕЛЕНИЯ
Отдел маркетинга осуществляет формирование спроса на услуги производимые организацией и разработку реальных и гибких программ действий организации на конкретном рынке.
В условиях жесткой конкуренции и роста издержек непременным условием выживания компании становится маркетинг, именно он способствует более успешному выступлению на рынке. И чтобы должным образом функционировать в условиях маркетинга, необходимо получать адекватную информацию до и после принятия решения. Существует множество причин, в силу которых маркетинговая информация должна собираться при разработке, реализации, пересмотре каких-либо элементов маркетингового плана, и храниться в удобном для маркетолога виде.
Основные функции, выполняемые отделом маркетинга:
- анализ рынка потребителей;
- поиск и выбор поставщиков;
- работа с клиентами;
- разработка стратегии развития бизнеса.
Выходными данными отдела является маркетинговый отчет.
Контекстная диаграмма информационной системы отдела реализована в среде BPwin, что показано на рисунке 2.1.
Информационные потоки показаны на рисунках 2.2-2.3.
Рисунок 2.1 - Контекстная диаграмма деятельности отдела маркетинга
Рисунок 2.2 - Детализация процесса "Анализ поставщиков и конкурентов"
Рисунок 2.3 - Детализация процесса "Анализ потребительской аудитории"
3 АНАЛИЗ ПРОГРАММНЫХ ОБОЛОЧЕК И МЕТОДОВ ОБРАБОТКИ ЭКОНОМИЧЕСКОЙ ИНФОРМАЦИИ. АНАЛИЗ ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ НА ПРЕДПРИЯТИИ
К экономической информации относятся сведения, которые циркулируют в экономической системе, о процессах производства, материальных ресурсах, процессах управления производством, финансовых процессах, а также сведения экономического характера, которыми обмениваются между собой различные системы управления.
Для обработки экономической информации используется пакет Microsoft Office. В частности Microsoft Office Word, который позволяет создавать и редактировать профессионально оформленные документы, письма, статьи, отчеты и брошюры. Также широко используется программа Microsoft Office Excel, которая позволяет выполнять вычисления, а также анализировать и визуализировать данные в электронных таблицах. Работа в Excel позволяет выполнять сложные расчеты, в которых могут использоваться данные, расположенные в разных областях электронной таблицы и связанные между собой определенной зависимостью. Для выполнения таких расчетов в Excel существует возможность вводить различные формулы в ячейки таблицы. Таблица Excel выполняет вычисления и отображает результат в ячейке с формулой. Доступный диапазон формул - от простого сложения и вычитания до финансовых и статистических вычислений. Таблица Excel - основное средство, используемое для обработки и анализа цифровой информации средствами вычислительной техники. Хотя работа с таблицами Excel в основном связана с числовыми или финансовыми операциями, они также могут использоваться для различных задач анализа данных, предоставляя пользователю большие возможности по автоматизации обработки данных.
Для ведения всего бухгалтерского учета на предприятии используется программа 1С: Предприятие.
1C: Предприятие - это набор прикладных решений, построенных по единым принципам и на единой технологической платформе. Система программ позволяет решать различные задачи учета и управления на предприятиях независимо от их профиля. Руководитель может выбрать решение, которое соответствует текущим потребностям предприятия и будет в дальнейшем развиваться по мере роста предприятия или расширения задач автоматизации.
Фирма " 1C" выпускает набор типовых решений, ориентированных на массовые типы предприятий. Основные задачи автоматизации, решаемые тиражными прикладными решениями, поставляемыми фирмой " 1c ":
1C: Предприятие: Бухгалтерский учет:
* Бухгалтерский и налоговый учет в полном соответствии с национальным законодательством;
* Учет основных средств и расчет амортизации;
* Формирование налоговой, бухгалтерской и другой регламентированной отчетности в различные органы;
* Бухгалтерский учет и контроль смет расходов бюджетных организаций в полном соответствии с законодательством и ведомственными инструкциями;
* Сбор сводной отчетности бюджетных организаций
1C: Предприятие: Складской, торговый, учет производства:
* Автоматизация складского учета, анализ состояния складов, контроль движения товарно-материальных ценностей;
* Управление номенклатурой товаров, продукции и услуг, включая автоматизацию ценообразования, составление сложных калькуляций, учет сложных комплектов и изделий;
* Управление торговой деятельностью и автоматизация торгового документооборота;
* Анализ эффективности торговой деятельности и прогнозирование продаж;
* Автоматизация расчетов с контрагентами, анализ состояния и динамики взаиморасчетов;
* Управление комиссионной торговлей от лица комитента и комиссионера;
* Расчет себестоимости продукции и анализ экономической эффективности производственной деятельности;
* Управление производством, включая незавершенное производство, многопередельное производство, обработку давальческого сырья;
* Учет заказов от покупателей, внутреннее планирование выпуска продукции, контроль исполнения заказов;
* Планирование и контроль выполнения заказов на закупку продукции.
1C: Предприятие: Расчет зарплаты и кадровый учет:
* Расчет зарплаты и кадровый учет включает практически полный способов набор начислений, удержаний, выплат и компенсаций с учетом национальной и местной специфики.
1C: Предприятие: Задачи планирования и финансового анализа:
* Планирование, управление и анализ финансовых результатов деятельности предприятия (бюджетирование, планирование финансовых показателей, сравнение плановых и фактических показателей за различные периоды).
Существует большое количество типовых отраслевых решений на базе платформы " 1C :Предприятие", разработанных партнерами фирмы " 1c ". Примерами таких решений являются программы для автоматизации банковской и инвестиционной деятельности, розничной торговли, фармацевтики, автосервисов, предприятий общественного питания и т.п. Каталог успешно применяемых отраслевых решений постоянно расширяется.
Кроме того, возможности платформы позволяют создавать и использовать индивидуальные конфигурации, как разработанные на базе типовых (фирмы " 1c ") или специализированных отраслевых решений, так и созданные "с нуля".
4. ОПИСАНИЕ СИСТЕМЫ ОХРАНЫ ТРУДА НА ПРЕДПРИЯТИИ
Основной функцией управления производством является выявление всех технических, экономических, организационных и социальных возможностей улучшения условий и безопасности труда; сохранение здоровья и работоспособности человека.
Для каждой управляемой системы должна быть четкая структура, не менее важным является определение функций системы управления безопасности труда
Санитарно-гигиенические условия работы в отделе, где находятся компьютеры характеризуются наличием в воздухе пыли. Содержание вредных веществ в воздухе рабочей зоны не должно превышать предельно допустимые концентрации, что должно обеспечиваться применением защитных мер.
Параметры воздуха рабочей зоны обеспечиваются системами отопления приточной вентиляции. Общая вытяжная вентиляция обеспечивает удаление нагретого воздуха, пыли. Электропроводка должна иметь цветную изоляцию, позволяющую различать назначение проводки и движение электрического тока.
Пожарная безопасность. Пожар может возникнуть вследствие нарушения правил пожарной безопасности.
Для предупреждения пожаров проводят мероприятия по пожарной профилактике. Они сводятся к непрерывному удалению пыли и газов, образующихся в процессе производства, вытяжной вентиляцией; регулярной очистке трубопроводов; обучению рабочих правилам пожарной безопасности.
Инструкция по технике безопасности. При пользовании компьютером следует носить чистую и сухую одежду и обувь. Если монитор не имеет защиты от излучения, следует пользоваться защитным экраном. Излучение монитора в сторону противоположную экрану может быть значительно больше, поэтому нельзя его заднюю часть обращать к соседям по офису или комнате.
При обнаружении неисправности ПЭВМ или появлении необычных звуков в процессе работы следует выключить компьютер.
Для устранения последствий скачков напряжения в сети, компьютер должен быть подключен к электросети через стабилизатор напряжения (бесперебойный источник питания).
Запрещается:
- включать и выключать компьютер без необходимости (это может привести к его неисправности);
- трогать разъемы соединительных кабелей, проводов, вилки и розетки;
- прикасаться к экрану и к тыльной стороне блоков компьютера;
- работать на ПЭВМ мокрыми руками;
- работать на ПЭВМ, имеющих нарушения целостности корпуса, нарушения изоляции проводов, неисправную индикацию включения питания, с признаками электрического напряжения на корпусе
- класть на ПЭВМ посторонние предметы (кружки с жидкостями, жирные предметы, книги и предметы, излучающие электромагнитные поля)
Рабочее место должно состоять из стола с размещенным на нем монитором, клавиатурой, подставкой под документы, кресла и подставки для ног.
а)Стол для компьютера:
1) оптимальные размеры стола зависят от размеров монитора и клавиатуры, но ориентировочно они должны быть шириной не менее 90 см, длиной - 160см;
2) желательно чтобы высота стола могла регулироваться в соответствии с вашим ростом; 3) при естественном освещении стол нужно поставить дальше от окна, чтобы свет падал с левой стороны;
4) при естественном освещении стол нужно поставить дальше от окна, чтобы свет падал с левой стороны;
5) если необходимо работать с какими-либо документами, желательно располагать их на подвижной подставке, которая должна находится в одной плоскости и на одной высоте с экраном.
б)Монитор:
1) экран монитора должен находиться от глаз на расстоянии не менее 40 см; 2) оптимальное расстояние подбирается с учетом характера работы (набор текста, компьютерная графика и т.д.), размера диагонали экрана и остроты вашего зрения, и именно таким образом, чтобы не приходилось напрягать зрение; 3) плоскость экрана должна быть расположена вертикально или с наклоном на вас, это позволит избежать напряжения мышц шеи и спины;
4) угол зрения, при котором обеспечивается оптимальное различие символов на экране, находится в пределах 15 - 20 градусов; в) Кресло:
1) для работы очень важно иметь удобное подвижное кресло, в котором регулируется все: высота, наклон спинки, расстояние спинки от сидения.
2) обязательно подбирайте кресло с подлокотниками, это поможет менять позу и положение рук;
3) лучше если подлокотники будут короткими и обеспечат положение рук чуть выше стола;
4) кресло должно быть с невысокой спинкой, максимум до лопаток. Такое кресло гораздо удобнее и лучше способствует правильной осанке во время работы;
5) чтобы ноги были расслаблены и не затекали, необходимо использовать подставку для ног с регулируемым углом наклона от 0 до 30 градусов;
6) Если ноги не касаются пола, то человек, работающий за компьютером, обязательно будет сутулиться.
Требования к помещениям для эксплуатации ПЭВМ. Помещения с ПЭВМ должны иметь естественное и искусственное освещение. Окна должны быть ориентированы преимущественно на север и северо-восток.
Искусственное освещение должно осуществляется системой общего равномерного освещения. В случаях преимущественной работы с документами, допускается применение комбинированного освещения (дополнительно светильники местного освещения). Освещенность на поверхности стола должна быть 300-500 лк.
Следует ограничивать отраженную и прямую блесткость.
В качестве источников искусственного освещения должны применяться преимущественно люминесцентные лампы тип ЛБ. Применение светильников без рассеивателей и экранирующих решеток не допускается. В помещениях следует проводить чистку стекол оконных рам и светильников не реже двух раз в год и проводить своевременную замену перегоревших ламп.
Площадь на одно рабочее место с ПЭВМ должна быть не менее 6,0 кв.м, а объем - не менее 24,0 куб.м.
Звукоизоляция помещений должна отвечать гигиеническим требованиям и обеспечивать нормируемые параметры шума согласно требованиям не более 50 дБА.
Помещения должны оборудоваться системами отопления, конденционирования воздуха или эффективной приточно-вытяжной вентиляцией. В помещении, где эксплуатируется ПЭВМ, должны поддерживаться следующие климатические условия: - температура воздуха - +15...+35 градусов С; - относительная влажность воздуха - 10 - 80% без конденсации; - вибрация max - 0,25 - 55Гц.
Во время эксплуатации техники форточки и рамы окон должны быть закрыты. Техника должна быть защищена от воздействия прямых лучей. В помещениях с ПЭВМ ежедневно должна производиться влажная уборка.
5 РАЗРАБОТКА ПРЕДЛОЖЕНИЯ ОТНОСИТЕЛЬНО ПОВЫШЕНИЯ ЭФФЕКТИВНОСТИ РАБОТЫ ПРОИЗВОДСТВА (ПОДРАЗДЕЛЕНИЯ)
5.1 Назначение и цели создания системы
Разрабатываемая АИС предназначена для обеспечения эффективной работы предприятия на основе новых технологий и оборудования, отвечающих современным требованиям, действующим нормативным документам, техническим требованиям. Автоматизации подлежат следующие системы:
• Система складского учета
• Система ведения БД с возможностью печати отчетов различных конфигураций;
• Система создания отчетов различных форм.
Цели создания системы:
- уменьшение ручной работы сотрудников;
- минимизация ошибок в их работе.
- повышение производительности.
Так как OОO "Копи-сервис" оказывает услуги по ремонту компьютерной техники, очевидно, что для ведения учета потребуется задать некоторую списочную информацию. В системе 1С: Предприятие такая информация хранится в объекте Справочник.
Создадим Справочники:
1.Поставщики.
2.Клиенты.
3.Сотрудники.
4. Номенклатура: 4.1. Материалы.
4.2. Услуги. 5. Склады.
Если смотреть на объект конфигурации справочник со стороны пользователя, то его можно рассматривать как объект для ввода списочной информации. Для программиста же справочник является инструментом, задающим тип переменной. То есть, создавая справочник Поставщики, мы создаем переменную типа Поставщик, которая может принимать значения соответствующие названию конкретного поставщика.
Для того чтобы хранить информацию в информационной системе, необходимо создать объект конфигурации Реестр. Из технического задания следует, что нашей организации следует вести количественный учет материалов на складе (создадим для этого реестр "Остатки материалов на складах"), стоимостной учет материалов на складе (создадим реестр "Стоимость материалов"), учет выручки от оказанных услуг (реестр "Продажи"), учет текущих цен материалов на рынке (реестр "цены").
1. Реестр остатков "Остатки материалов на складах"
Измерения:
- склад
- материал
Ресурсы:
- количество
2. Реестр остатков "стоимость материалов"
Измерения:
- склад
- материал
Ресурсы:
- стоимость
3. Реестр оборотов "Продажи"
Измерения:
- материал
- клиент
- мастер
Ресурсы:
- выручка
- количество - стоимость
4. Реестр "цены"
Измерения:
- номенклатура
Ресурсы:
- цена
Вручную изменения в реестры вносить запрещено. Для того чтобы вносить изменения в реестры вводится объект документ. То есть изменить значение реестров сотрудник сможет лишь после того, как официально составит документ.
Для изменения данных в реестрах создадим четыре документа: Приходная накладная (добавляет материалы в реестр "остатки материалов на складе" и увеличивает общую стоимость материалов в реестр "стоимость материалов"), акт перемещения материалов (вносит изменения в реестр "остатки материалов на складе"), акт оказания услуги (Списывает материалы из реестра "остатки материалов на складе", но увеличивает выручку в реестре оборотов "продажи"), акт списания бракованных товаров (Списывает материалы из реестра "остатки материалов на складе").
Для того чтобы показывать информацию из реестров в удобном для сотрудников виде в системе 1С Предприятие есть объект Отчет.
Создадим отчеты:
1. Материалы (показывает в удобном виде информацию о материалах на складе)
2. Рейтинг услуг (Извлекает информацию об услугах из реестра "Продажи")
3. Рейтинг клиентов (Извлекает информацию о клиентах из реестра "Продажи")
4. Отчет Реестр документов акт оказание услуги ( выводит по датам информацию о всех созданных документов "Акт оказания услуги")
5.2 Реализация в 1С: Предприятие
Реализация и работа системы представлена на рисунках 5.1-5.8.
Рисунок 5.1 - Главная форма
Рисунок 5.2 - Дерево конфигурации
Рисунок 5.3 - Документ Приходная накладная
Рисунок 5.4 - Документ Акт оказания услуги
Рисунок 5.5 - Реестр Материалы на складе
Рисунок 5.6 - Добавление нового работника
Рисунок 5.7 - Отчет Рейтинг услуг
Рисунок 5.8 - Отчет Реестр документов оказания услуги
ВЫВОДЫ
В ходе прохождения проектно-технологической практики была создана система, реализованная средствами системы разработки 1С: Предприятие, которая осуществляет автоматизацию функций:
- приходования материалов на склад;
- организации полного и достоверного учета всех поставщиков;
- информационной поддержки принимаемых заказов, формирования полной и достоверной информации о существующих услугах;
- устранения дублирования при вводе информации и возникающих при этом механических ошибок;
- подготовки списков материалов, имеющихся в наличии на складе;
- выдачи на печать отчетов.
Также был проведен анализ поставленной задачи (по индивидуальному заданию анализ предметной области), и технико-экономических показателей деятельности предприятия. Были изучены вопросы научной организации и охраны труда, техники безопасности на предприятии и в отделе прохождения практики. СПИСОК ИСПОЛЬЗОВАННОЙ ЛИТЕРАТУРЫ
1. Вендров А.М.CASE-технологии. Современные методы и средства проектирования информационных систем .- М.: Финансы и статистика, 1998 .- 176.
2. Анализ хозяйственной деятельности предприятия / Савицкая Г.С. - М.: ИНФРА-М, 2002. - 336 с.
3. Савицкая Г.В. Анализ хозяйственной деятельности предприятия, учебное пособие, Издание второе, переработанное и дополненное, Мн., "Экоперспектива", 1997 г.
4. Баканов М.И., Шеремет А.Д. Теория экономического анализа: Учебник .- 4-е изд., Доп. и перераб-М.: Финансы и статистика, 2002 .- 416 с.
5. Павловская О.В., Притуляк Н.Н., Невмержы Н.Ю. Финансовый анализ: Учебно-метод.пособие. - К.: КНЕУ, 2002. - 388с.
6. Петерсен Р.. "Linux. Руководство по операционной системе". BHV, 1997.
7. Жидецкий В., Мельников А., Джигирей В. Основы охраны труда: Учебник .- 5-е изд, доп .- М.: Афиша, 2001 .- 350
8. Жидецкий В. Средства индивидуальной защиты и электрозащитные средства. Вопросы и ответы, тесты: Учебное пособие .- М.: Основа, 2003 .- 136
9. Жидецкий В. Ц. Основы охраны труда: Учебник.- М.: Афиша,2002 .- 320
10. Жидецкий В. Охрана труда пользователей компьютеров: Учеб., Пособие .- 2-е изд,, доп .- М.: Афиша, 2000 .- 176
11. Бабенко Л.П., Лаврищева К. М. Основы программной инженерии: Учебное пособие .- М.: Знание, 2001 .- 269с.
12. Вендров А. М. Практикум по проектированию программного обеспечения экономических информационных систем: Учебное пособие .- М.: Финансы и статистика, 2002 .- 192 13. Вендров А. М. Проектирование программного обеспечения экономических информационных систем: Учебник .- М.: Финансы и статистика, 2002 .- 352
14. Гаврилова Т.А.,, Хорошевском В. Ф. Базы знаний интеллектуальных систем .- СПб.: Питер, 2000 .- 384
15. Гаврилова Т.А., Хорошевском В. Ф. Базы знаний интеллектуальных систем .- СПб.: Питер, 2001 .- 384
16. Гаврилова Т.А., Червинская К. Р. Извлечение и Структурирование знаний для экспертных систем .- М.: Радио и связь, 1992 .- 199
17. Гужва В.М. Информационные системы и технологии на предприятиях: Учеб.пособие. - К.: КНЕУ, 2001. - 400с.
ПРИЛОЖЕНИЕ А
Процедура ОбработкаПроведения(Отказ, Режим)
Для Каждого ТекСтрокаМатериалы Из Материалы Цикл
Движение = Движения.ОстаткиМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Материал = ТекСтрокаМатериалы.Материал;
Движение.Склад = Склад;
Движение.Количество = ТекСтрокаМатериалы.Количество;
Движение = Движения.СтоимостьМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Материал = ТекСтрокаМатериалы.Материал;
Движение.Стоимость = ТекСтрокаМатериалы.Сумма;
КонецЦикла;
КонецПроцедуры
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
СтрокаТабличнойЧасти.сумма= СтрокаТабличнойЧасти.количество * СтрокаТабличнойЧасти.цена;
КонецПроцедуры
Функция РозничнаяЦена (АктуальнаяДата, ЭлементНоменклатуры) Экспорт
//создать вспомогательный объект отбор
Отбор = Новый Структура("Номенклатура", ЭлементНоменклатуры);
//Получить актуальные значения ресурсов регистра сведений
ЗначенияРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(АктуальнаяДата, Отбор);
Возврат ЗначенияРесурсов.цена;
КонецФункции
Процедура ОбработкаПроведения(Отказ, Режим)
Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
// регистр ОстаткиМатериалов Расход
//Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Материал Тогда //Продолжить; //Иначе
//Сообщить("Вы указали услугу в столбце материалов - данные операции не будут проведены"); //КонецЕсли; Движение = Движения.ОстаткиМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;
Движение.Склад = Склад;
Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;
// регистр СтоимостьМатериалов Расход
Движение = Движения.СтоимостьМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;
Движение.Стоимость = ТекСтрокаПереченьНоменклатуры.Стоимость * ТекСтрокаПереченьНоменклатуры.Количество ;
КонецЦикла;
Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
движение = Движения.Продажи.Добавить();
Движение.Период = дата;
Движение.Номенклатура = текСтрокаПереченьНоменклатуры.Номенклатура;
Движение.Клиент = клиент;
Движение.Мастер = мастер;
Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;
Движение.Выручка = ТекСтрокаПереченьНоменклатуры.Сумма;
Движение.Стоимость = ТекСтрокаПереченьНоменклатуры.Стоимость * ТекСтрокаПереченьНоменклатуры.Количество ;
КонецЦикла;
Для Каждого ТекСтрокаДополнительныеДанныеОУслуге Из ДополнительныеДанныеОУслуге Цикл
движение = Движения.Продажи.Добавить();
Движение.Период = дата;
Движение.Номенклатура = ТекСтрокаДополнительныеДанныеОУслуге.Услуга;
Движение.Клиент = клиент;
Движение.Мастер = мастер;
Движение.Выручка = ТекСтрокаДополнительныеДанныеОУслуге.СтоимостьУслуги;
КонецЦикла;
КонецПроцедуры
Процедура МатериалыИнициализация()
ПостроительОтчетаМатериалы.Текст ="ВЫБРАТЬ
|ОстаткиМатериаловОстаткиИОбороты.Материал,
|ПРЕДСТАВЛЕНИЕ(ОстаткиМатериаловОстаткиИОбороты.Материал),
|ОстаткиМатериаловОстаткиИОбороты.Склад КАК Склад,
|ПРЕДСТАВЛЕНИЕ(ОстаткиМатериаловОстаткиИОбороты.Склад),
|ОстаткиМатериаловОстаткиИОбороты.КоличествоНачальныйОстаток,
|ОстаткиМатериаловОстаткиИОбороты.КоличествоПриход,
|ОстаткиМатериаловОстаткиИОбороты.КоличествоРасход,
|ОстаткиМатериаловОстаткиИОбороты.КоличествоКонечныйОстаток
|ИЗ
|РегистрНакопления.ОстаткиМатериалов.ОстаткиИОбороты КАК ОстаткиМатериаловОстаткиИОбороты
|ИТОГИ ПО
|Склад";ПостроительОтчетаМатериалы.ЗаполнитьНастройки();
ПостроительОтчетаМатериалы.ЗаполнениеРасшифровки = ВидЗаполненияРасшифровкиПостроителяОтчета.ЗначенияГруппировок;
ПостроительОтчетаМатериалы.ТекстЗаголовка = "Материалы";
Настройка = ВосстановитьЗначение("НастройкаОтчетыМатериалыМатериалы_c5ff7d03-2152-4e8f-876e-abdd2a091e34");
Если Настройка <> Неопределено Тогда
ПостроительОтчетаМатериалы.УстановитьНастройки(Настройка);
КонецЕсли;
КонецПроцедуры
Процедура ДействияФормыМатериалыНастройка(Кнопка)
Форма = ОтчетОбъект.ПолучитьФорму("МатериалыНастройка");
Форма.ПостроительОтчета = ПостроительОтчетаМатериалы;
Настройка = ПостроительОтчетаМатериалы.ПолучитьНастройки();
Если Форма.ОткрытьМодально() = Истина Тогда
МатериалыВывести();
Иначе
ПостроительОтчетаМатериалы.УстановитьНастройки(Настройка);
КонецЕсли;
КонецПроцедуры
Процедура ПриЗакрытии()
СохранитьЗначение("НастройкаОтчетыМатериалыМатериалы_c5ff7d03-2152-4e8f-876e-abdd2a091e34", ПостроительОтчетаМатериалы.ПолучитьНастройки());
КонецПроцедуры
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
МатериалыИнициализация();
КонецПроцедуры.
6
Документ
Категория
Рефераты
Просмотров
30
Размер файла
1 213 Кб
Теги
отчет, практика
1/--страниц
Пожаловаться на содержимое документа