close

Вход

Забыли?

вход по аккаунту

?

Урок 5

код для вставки
Урок 5. Использование функций для принятия решения
Excel позволяет принимать то или иное решение в зависимости от поставленного условия, используя функцию ЕСЛИ. Ее синтаксис следующий:
ЕСЛИ (условие; команда1; команда2) - если выполняется условие, то выполняется команда1, иначе выполняется команда2. При этом условие может быть любым выражением, состоящим из переменных, функций, связанных между собой операциями отношений > (больше), < (меньше), = (равно) и т.д.
Команды1-2 также могут состоять из функций и переменных, в том числе содержать вложенные функции ЕСЛИ. Допускается до семи вложений.
Microsoft Excel предлагает дополнительные функции, которые можно применять для анализа данных с использованием условий. Например, для вычисления числа появлений текстовой строки или числа в диапазоне ячеек используйте функцию СЧЁТЕСЛИ. Для вычисления суммы значений, попадающих в интервал, заданный текстовой строкой или числами, используйте функцию СУММАЕСЛИ.
Совместно с функцией если часто используются логические функции И(), ИЛИ(), НЕ()
ИЛИ() - возвращает ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА; возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.
Синтаксис
ИЛИ(логическое_значение1;логическое_значение2; ...)
Логическое_значение1, логическое_значение2,... - от 1 до 30 проверяемых условий, которые могут иметь значение либо ИСТИНА, либо ЛОЖЬ.
И() - возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.
Синтаксис
И(логическое_значение1; логическое_значение2; ...)
Логическое_значение1, логическое_значение2, ... - это от 1 до 30 проверяемых условий, которые могут иметь значение либо ИСТИНА, либо ЛОЖЬ.
НЕ() - Меняет на противоположное логическое значение своего аргумента. Функция НЕ используется в тех случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.
Синтаксис
НЕ(логическое_значение). Логическое_значение - величина или выражение, которые могут принимать два значения: ИСТИНА или ЛОЖЬ.
Задание к уроку 5.
1. Создайте книгу под названием логика.xls и введите следующие таблицы:
2. Первый лист переименуйте на "7 км" и введите таблицу, содержащую столбцы "Фамилия реализатора", "объем продаж за день" и "дневная зарплата". При этом объем продаж - случайное число от 3000 грн до 50000 грн, зарплата - в зависимости от выручки: если объем продаж больше 10000 грн, реализатор получает зарплату 4% от выручки, иначе - 3%. Всего 10 реализаторов, таблицу отформатируйте собственным форматом.
3. Вторая таблица (второй лист - "зарплатная ведомость") - смотрите таблицу ниже.
4. Колонку "ФИО работника" заполните фамилиями из списка, либо создайте список перед заполнением, если его нет.
5. Колонку "оклад" заполните случайными числами, моделирующими оклады работников в диапазоне 300-1500 грн с учетом копеек (=ОКРУГЛ(СЛЧИС()*1200+300;2))
6. Колонку "стаж" заполните стажем работников в диапазоне 3-20 лет (=ОКРУГЛ(СЛЧИС()*17+3;0))
7. Колонка "премия" заполняется (моделируется) случайным процентом в диапазоне 10-50% (=ОКРУГЛ(СЛЧИС()*40+10;0))
8. Колонка "аванс" вычисляется как 30% от оклада, увеличенного на процент премии (=(C3+C3*E3%)*30%)
9. Колонка "зарплата" вычисляется как разница между окладом, увеличенным на процент премии и уже выплаченным авансом (=(C3+C3*E3%)-F3)
10. Колонка "характеристика": если полная зарплата в месяц больше 50 грн, то работник молодец, а иначе - мало зарабатывает (=ЕСЛИ(СУММ(F8:G8)>500;"молодец";"мало зарабатывает"))
11. Для колонок "оклад", "аванс" и "зарплата" установите тип данных - денежный, а денежная единица - гривня Украины.
12. Отформатируйте и сохраните созданную таблицу.
Попробуйте сделать настоящую бухгалтерскую ведомость. Если не получится, жалуйтесь.
зарплатная ведомость фирмы "Рога и копыта" на апрель 2011 года №п/пФИО работникаокладстажпремияавансзарплатахарактеристика 1Иванов 11 265,78 грн.612425,30 грн.992,37 грн.молодец 2Иванов 2774,58 грн.717271,88 грн.634,38 грн.молодец 3Иванов 3333,35 грн.1417117,01 грн.273,01 грн.мало зарабатывает 4Иванов 4547,33 грн.1350246,30 грн.574,70 грн.молодец 5Иванов 51 078,23 грн.737443,15 грн.1 034,02 грн.молодец 6Иванов 6338,02 грн.423124,73 грн.291,04 грн.мало зарабатывает 7Иванов 7429,91 грн.1211143,16 грн.334,04 грн.мало зарабатывает 8Иванов 8846,70 грн.1514289,57 грн.675,67 грн.молодец 9Иванов 91 493,00 грн.1511497,17 грн.1 160,06 грн.молодец 10Иванов 101 016,12 грн.1129393,24 грн.917,56 грн.молодец Примечание. Ивановы потому, что в списке фамилий не было. Не забудьте переслать задание по почте sob-mk@ukr.net . Удачи! 
Автор
sob-mk
sob-mk146   документов Отправить письмо
Документ
Категория
Школьные материалы
Просмотров
46
Размер файла
23 Кб
Теги
урок
1/--страниц
Пожаловаться на содержимое документа