close

Вход

Забыли?

вход по аккаунту

?

Урок 6 Вложенные функции ЕСЛИ

код для вставки
Excel
 Урок 6. Вложенные функции "ЕСЛИ".
Excel позволяет использовать до семи уровней вложения функций. Поэтому при применении вложенных функций "ЕСЛИ" весь диапазон исходных данных можно разбить до 8 поддиапазонов. При этом разбивать надо с верхнего поддиапазона и идти вниз.
Например, для разбивки диапазона 1-1000 на 3 поддиапазона используем следующую формулу:
ЕСЛИ(А1> 667; "1 диапазон"; ЕСЛИ(А1> 334; "2 диапазон "; "3 диапазон "))
Существуют дополнительные функции с использованием ЕСЛИ:
СУММЕСЛИ(диапазон;критерий;диапазон_суммирования) - суммирует ячейки, заданные критерием в форме числа, выражения или текста в указанном диапазоне
* Ячейки в "диапазон_суммирования" суммируются, только если соответствующие им ячейки в аргументе "диапазон" удовлетворяют критерию.
* Если "диапазон_суммирования" опущен, то суммируются ячейки в аргументе "диапазон".
СЧЁТЕСЛИ(диапазон;критерий) - Подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию (критерий в форме числа, выражения или текста, который определяет, какие ячейки надо подсчитывать).
СЧИТАТЬПУСТОТЫ(диапазон) - подсчитывает количество пустых ячеек в заданном диапазоне.
Ячейки с формулами, которые возвращают значение "" (пустой текст), учитываются при подсчете. Ячейки с нулевыми значениями не учитываются.
Эффективность работы.
Для "замораживания" случайных чисел ячейки с формулами копируют, затем, по правой кнопке, вставляют специальной вставкой - только значения.
Для закрепления заголовков (будут всегда находиться на экране) выделяют ячейку, выше и правее которой находятся заголовки и выбирают ленту Вид - Закрепить области - Закрепить области, Первую стоку или Первый столбец. Аналогично снимается закрепление областей.
Для скрытия мешающих в настоящий момент листов, строк или столбцов, их выделяют, нажимают на ленте Главная - Формат - Скрыть или отобразить. Аналогичная процедура для их отображения. Иногда удобнее выделить часть столбцов и, по правой кнопке, выбрать "скрыть". Для их открытия выделить столбцы, между которыми находятся скрытые столбцы, и выбрать, по правой кнопке, "отобразить". Здесь же можно установить параметры защиты листа, форматирование ячеек, изменение или автоподбор высоты строк и ширины столбцов. Задание к уроку 6.
1. Создайте книгу под названием "Успеваемость_2.xls
2. Введите и отформатируйте заголовок таблицы согласно рисунка
3. Закрепите область заголовков
4. Заполните фамилиями из списка (30 фамилий)
5. Сгенерируйте случайные оценки по предметам согласно формулы:
=ОКРУГЛ(СЛЧИС()*11+1;0)
6. Заполните столбец "характеристика" согласно формулы, разбивающей учеников класса по категориям: =ЕСЛИ(СРЗНАЧ(D27:I27)>9; "отличник"; ЕСЛИ(СРЗНАЧ(D27:I27)>6; "хорошист"; ЕСЛИ(СРЗНАЧ(D27:I27)>3; "троечник";"бедные родители!!")))
7. Определите количество хорошо успевающих по предметам учеников (7 и более баллов) согласно формулы: =СЧЁТЕСЛИ(D4:D33;">6")
8. Выведите статистику по количеству отличников (=СЧЁТЕСЛИ(J4:J33;"отличник")), хорошистов (=СЧЁТЕСЛИ(J5:J34;"хорошист")) и т.д.
9. Отформатируйте полученную таблицу собственным форматом и сохраните в своей папке как "успеваемость_10-A.xls".
10. Скройте все оценки, защитите лист и формулы и сохраните как "успеваемость_10-A_2.xls"
Успеваемость 10-А класса № п/п Фамилия ИмяПредметы характеристика химияфизикаисторияпениегеографияЧерчение 1 Иванов 1 Иван 12 5 5 12 10 6 Хорошист 2 Иванов 2 Иван 3 4 6 12 8 1 Троечник .. .. .. .. .. .. .. .. .. .. 29 Иванов 29 Иван 9 11 7 4 5 2 Хорошист 30 Иванов 30 Иван 10 3 2 7 10 9 Хорошист количество успевающих по предмету 18 13 16 12 17 15 количество: Отличники 1 Хорошисты 19 Троечники 7 неуспевающие 1 
Автор
sob-mk
sob-mk146   документов Отправить письмо
Документ
Категория
Школьные материалы
Просмотров
5 567
Размер файла
24 Кб
Теги
урок, вложенные функции если, excel
1/--страниц
Пожаловаться на содержимое документа