close

Вход

Забыли?

вход по аккаунту

?

Функции

код для вставки
Работа с функциями. Функция состоит из имени функции и следующего за ним списка аргументов, заключенного в круглые скобки .
Аргументами называются величины, которые используются для вычисления значений функций .
Возвращаемыми значениями называются величины, которые являются результатом вычисления функций .
Функцией в Excel называется часть формулы, указывающая на необходимость выполнения стандартных вычислений Примеры функций в формулах =СРЗНАЧ(D2:D4) Эта формула возвращает среднее арифметическое трех чисел, записанных в ячейках со вторую по четвертую столбца D =ЕСЛИ(СУММ(D2:D4)>=100000;5%;ЕСЛИ(СУММ(D2:D4)>=50000;2,5%;0%)) Эта формула возвращает процент скидки, который определяется в зависимости от общей суммы трех покупок. Если эта сумма превышает сто тысяч, то скидка будет равна пяти процентам. Если сумма меньше ста тысяч, но больше пятидесяти тысяч, скидка будет равна двум с половиной процентам. Если сумма меньше пятидесяти тысяч, процент скидки будет равен нулю Список аргументов функции
> > Круглые скобки обозначают начало и конец списка аргументов. Скобки должны быть парными, пробелы перед скобками или после них не допускаются.
> Внутри скобок аргументы отделяются друг от друга точкой с запятой.
> Аргументы могут быть как константами, так и выражениями. Эти выражения, в свою очередь, могут содержать другие функции.
> Назначение и тип данных каждого из аргументов определяется для каждой из функций отдельно, в соответствии с тем, что и как она вычисляет.> Задаваемые аргументы должны иметь допустимые для данного аргумента функции значения.
Функции, являющиеся аргументом другой функции, называются вложенными
Функция подсчета значений
СЧЁТ(значение1; значение2; ...) Подсчитывает количество чисел в списке аргументов. Функция СЧЁТ используется для получения количества числовых ячеек в диапазонах ячеек. Значение1, значение2, ... - это от 1 до 30 аргументов, которые могут содержать или ссылаться на данные различных типов, но в подсчете участвуют только числа. Пример
Если ячейка А1 содержит слово "Продажи", A2 содержит 12, A3 - пустая, а A4 содержит 22,24, то
СЧЁТ(A1:A4) возвращает значение 2
Функции минимума и максимума МИН(число1; число2; ...) МАКС(число1; число2; ...) Возвращают соответственно наименьшее и наибольшее значение в списке аргументов. Число1, число2, ... - это от 1 до 30 аргументов, среди которых ищется минимальное (максимальное) значение. Если аргумент является ссылкой, то учитываются только числа. Пустые ячейки, логические значения, тексты в ссылке игнорируются.
Если аргументы не содержат чисел, то функции возвращают 0.
Пример
Если A1:A5 содержит числа 10, 7, 9, 27 и 2, то:
МИН(A1:A5) равняется 2, МАКС(А1:А5) равняется 27
МИН(A1:A5; 0) равняется 0
Функция условного выбора
ЕСЛИ(лог_выражение; значение_если_истина; значение_если_ложь)
Функция ЕСЛИ используется для проверки значений и организации выбора в зависимости от результатов этой проверки. Результат проверки определяет значение, возвращаемое функцией ЕСЛИ.
Лог_выражение - это выражение, которое при вычислении дает значение ИСТИНА или ЛОЖЬ, т.е. условие.
Значение_если_истина - это значение, которое возвращается, если лог_выражение имеет значение ИСТИНА.
Значение_если_ложь - это значение, которое возвращается, если лог_выражение имеет значение ЛОЖЬ. Функция ПРОСМОТР для проверки значений и организации поиска в векторе или массиве . Функция ПРОСМОТР имеет две синтаксические формы: вектор и массив. Векторная форма функции ПРОСМОТР просматривает диапазон, в который входят значения только одной строки или одного столбца (так называемый вектор) в поисках определенного значения и возвращает значение из другого столбца или строки. ПРОСМОТРискомое_значение; просматриваемыйй_вектор; вектор_результатов Искомое_значение - это значение, которое ПРОСМОТР ищет в первом векторе. Искомое_значение может быть числом, текстом, логическим значением, именем или ссылкой, ссылающимися на значение.
Просматриваемый_вектор - это интервал, содержащий только одну строку или один столбец. Значения в аргументе просматриваемый_вектор могут быть текстами, числами или логическими значениями.
Вектор_результатов - это интервал, содержащий только одну строку или один столбец. Он должен быть того же размера, что и просматриваемый_вектор.
Пример
ПРОСМОТР(4,91;A2:A7;B2:B7) равняется "оранжевый"
ПРОСМОТР(5,00;A2:A7;B2:B7) равняется "оранжевый"
ПРОСМОТР(7,66;A2:A7;B2:B7) равняется "фиолетовый"
Если ПРОСМОТР не может найти искомое_значение, то подходящим считается наибольшее значение в аргументе просматриваемый_вектор, которое меньше, чем искомое_значение
Форма массива функции ПРОСМОТР просматривает первую строку или первый столбец массива, находит указанное значение и возвращает значение из аналогичной позиции последней строки или столбца массива ПРОСМОТР(искомое_значение;массив)
Искомое_значение - это значение, которое ПРОСМОТР ищет в массиве. Искомое_значение может быть числом, текстом, логическим значением, именем или ссылкой, ссылающимися на значение.
Массив - это интервал ячеек содержащих текст, числа или логические значения, которые нужно сравнивать с искомым значением.
Пример
ПРОСМОТР("В";{"а";"б";"в";"г":1;2;3;4}) равняется 3
ПРОСМОТР("бак";{"а";1:"б";2:"в";3}) равняется 2
Автор
georg88
Документ
Категория
Без категории
Просмотров
145
Размер файла
27 Кб
Теги
функции
1/--страниц
Пожаловаться на содержимое документа