close

Вход

Забыли?

вход по аккаунту

?

263.434 Средства отображения трехмерных объектов в системе AutoCad

код для вставкиСкачать
1
Федеральное агентство по образованию
Государственное образовательное учреждение
высшего профессионального образования
Воронежский государственный архитектурно-строительный университет
Кафедра математического моделирования и вычислительной техники
СРЕДСТВА ОТОБРАЖЕНИЯ
ТРЕХМЕРНЫХ ОБЪЕКТОВ
В СИСТЕМЕ AutoCAD
Методические указания
к выполнению чертежно-графических работ по курсу
«Автоматизированные системы проектирования в строительстве»
для студентов 4-го курса специальности 230201 –
«Информационные системы и технологии»
Воронеж 2009
2
Составители В.П. Авдеев, Р.А. Ефанова
УДК 681.3.06
ББК 32. 973. 26 - 018.2
Средства отображения трехмерных объектов в системе AutoCAD
[Текст]: метод. указания к выполнению чертежно-графических работ для студ.
спец. 230201 / Воронеж. гос. арх.-строит ун-т; сост.: В.П. Авдеев, Р.А. Ефанова.
– Воронеж, 2009. – 36с.
На конкретных примерах рассматриваются профессиональные примеры применения различных средств визуализации трехмерных объектов.
Большое внимание уделяется созданию и эффективному использованию видовых экранов пространства модели и пространства листа.
Предназначены для студентов специальности 230201 – «Информационные системы и технологии».
Ил. 27. Библ.: 7 назв.
Печатается по решению редакционно-издательского совета
Воронежского государственного архитектурно-строительного
университета
Рецензент –
Л.Н. Шерстюкова, к. т .н. доцент кафедры начертательной геометрии и графики Воронежского государственного архитектурно-строительного
университета
3
ВВЕДЕНИЕ
Система AutoCAD предоставляет пользователю множество различных
средств для экранного отображения трехмерных объектов, как в пространстве модели, так и в пространстве листа; как в мировой системе координат, так
и в пользовательских системах координат. Эти средства весьма разнообразны
и во многих случаях требуют специальных навыков в их использовании.
В данных методических указаниях достаточно подробно на конкретных
примерах разбираются такие вопросы: как правильно задать точку зрения,
используя соответствующее диалоговое окно; как построить перспективу
трехмерного объекта, грамотно используя разнообразные опции команды
DVIEW. При этом система предлагает удобный способ выбора расстояния от
камеры до объекта при постоянном контроле изменяющегося перспективного
изображения в динамическом режиме. Используя опцию Панорамирование
объекта, можно добиться наилучшего расположения объекта в графической
зоне.
Для лучшего зрительного восприятия трехмерного объекта предлагаются различные средства визуализации, такие как удаление невидимых линий, использование визуальных стилей, тонирование, работа с источниками
света, присвоение объектам свойств различных материалов и т.п.
Для нахождения оптимального вида очень удобен интерактивный режим орбитального вращения, работающий только в пространстве модели.
При работе с изображениями трехмерных объектов имеется возможность разделять экран на части – видовые экраны, в каждом из которых можно устанавливать определенный вид одной и той же детали. Создание и использование видовых экранов пространства модели и пространства листа
значительно различаются. Так видовые экраны в пространстве листа обладают признаками обычных примитивов и их можно редактировать. Также в
пространстве листа возможно создание согласованных видов, что очень важно для подготовки проектной документации. Все вышеизложенное указывает
на то, как важно пользователю овладеть материалом, представленным в данной работе.
1. ПОЛЬЗОВАТЕЛЬСКИЕ СИСТЕМЫ КООРДИНАТ
1.1. Координатные системы
Для описания любой точки в трехмерном пространстве AutoCAD использует традиционную прямоугольную (декартову) систему трех координат
XYZ. Кроме того, AutoCAD позволяет создавать новые системы координат,
например: изменение положения начала координат и изменение ориентации
в пространстве.
Основная система, в которой AutoCAD хранит описание всех элементов, называется мировой (WCS-MCK). По отношению к другим системам она
является абсолютной, ее невозможно удалить. Плоскость XY представляет
4
горизонтальную плоскость. Для ориентации осей координат используется
правило правой руки.
Задание новой системы координат выполняется командой UCS (ПСК) –
пользовательская система координат. Пользовательские системы координат
могут именоваться. Команда ПСК позволяет задать начало новой системы
координат и ориентацию осей X и Y, а положение новой оси Z, зависящей от
положения соответствующих осей X и Y, определяется автоматически.
Плоскость XY мировой системы координат МСК в новом рисунке совпадает с плоскостью графического экрана. Ось Z МСК располагается перпендикулярно экрану, причем положительная часть ее направлена от экрана
на нас.
Пиктограмма МСК имеет два стиля: cтиль 2D (рис.1.1) и стиль 3D
(рис.1.2).
Рис. 1.2. Пиктограмма МСК
Рис. 1.1. Пиктограмма МСК
(Стиль 3D)
(Стиль 2D)
Настройка формы и размера пиктограммы выполняется в диалоговом
окне UCS Icon (Знак ПСК), которое вызывается соответствующий командой
UCSICON (ЗНАКПСК) и ее опцией Свойства (рис. 1.3).
Рис. 1.3. Диалоговое окно «Знак ПСК»
5
В этом диалоговом окне в области Стиль знака ПСК включается переключатель 2D или 3D. Вносимые в окно изменения сразу же отражаются в
области Образец.
Если включен переключатель 3D, то доступен флажок Конус, при этом
оси координат заканчиваются не стрелками, а конусами.
В областях Размер знака ПСК и Цвет знака ПСК устанавливаются величина знака и его цвет.
Через это же окно можно разместить пиктограмму в точке начала системы координат или в левом нижнем углу, или отключить его видимость.
В некоторых командах, например, вращение по орбите, пиктограмма
имеет твердотельный вид с цветными осями и конусами на конце, при этом
ось X имеет красный цвет, ось Y – зеленый и ось Z – синий.
1.2. Уровень
Уровень и высота - два базовых свойства двумерных объектов, благодаря которым можно перейти к пространственному моделированию.
Уровень – это смещение плоскости построения объекта относительно
ПСК. Текущее значение уровня хранится в системной переменной
ELEVATON.
Для задания уровня существует команда ELEV (УРОВЕНЬ), которая
выдает запрос:
Новый уровень по умолчанию <0.0000>:
После задания текущего уровня система запрашивает:
Новая высота по умолчанию <0.0000>:
Текущее значение высота хранится в системной переменной THICKNESS.
На рисунках 1.4, 1.5, 1.6 представлена окружность, построенная соответственно на нулевом уровне, на уровне 200 и на уровне -200.
Для изменения уровня объекта следует изменить значения координат Z
для центра окружности. Это выполняется с помощью команды CHANGE
(ИЗМЕНИТЬ) или MOVE (ПЕРЕНЕСТИ).
Рис. 1.4. Построение окружности на нулевом уровне
6
Рис. 1.5. Построение окружности на уровне 200
Рис. 1.6. Построение окружности на уровне - 200
1.3. Ортогональные системы координат
Системы координат, определяемые плоскостями XY, YZ, ZX мировой
системы, называются ортогональными. Для задания их в качестве текущих
плоскостей используют диалоговое окно UCS (ПСК) (рис. 1.7).
7
Рис. 1.7. Диалоговое окно «ПСК»
«Ортогональные ПСК»
Выбирают опцию Ортогональные, которая предлагает шесть вариантов: Top (Сверху), Bottom (Cнизу), Front (Спереди), Back (Сзади), Left (Слева) и Right (Справа). Каждая из шести ортогональных ПСК может иметь глубину, которая отображается в диалоговом окне UCS (ПСК). Сохранение текущей ПСК под именем выполняется с помощью опции Save (Сохранить)
команды UCS (ПСК). Как только ПСК получила имя, она сразу же появляется на вкладке именованные ПСК диалогового окна ПСК. Именованная
ПСК в любой момент может быть восстановлена в графическом окне или
видовом экране. Новый режим ДПСК (динамический) позволяет автоматически устанавливать новую ПСК по плоской грани тела, находящийся под курсором.
1.4. Команда UCS (ПСК)
Команде ПСК соответствуют две панели инструментов ПСК и ПСК-2.
При вводе команды с клавиатуры или щелчком по кнопке панели ПСК
система выводит сообщение:
8
Текущая ПСК: *мировая*
и запрос:
начало ПСК или
[Грань/именоваННая/Объект/преДыдущая/Вид/Мир/X/Y/ZОсь]<Мир>.
Предлагаются следующие опции задания новых ПСК:
Грань – установка ПСК на плоскости грани трехмерного тела;
именоваННая – переход к операции с именованными ПСК (восстановление, сохранение, удаление, справка);
Объект – установка ПСК по плоскости двумерного объекта;
преДыдущая – возврат к предыдущей ПСК;
Вид – установка ПСК перпендикулярно направлению взгляда (в плоскости вида) с сохранением начала координат;
Мир – восстановление МСК;
X, Y, Z – поворот текущей ПСК вокруг осей, соответственно X, Y, Z;
ZОсь – указания нового начала координат и точки, лежащей на положительном направлении новой оси Z.
Команда ДИСПСК – открывает диалоговое окно ПСК, которое имеет
три вкладки:
Именованные ПСК, Ортогональные ПСК и Режимы.
Вкладка Именованные ПСК выдает список именованных пользовательских систем координат и дает возможность установить любую из них с
помощью кнопки Установить. Кнопка Подробности открывает окно Подробности ПСК с характеристиками отмеченной ПСК.
Вкладка Ортогональные ПСК диалогового окна ПСК предназначена
для работы с основными ортогональными ПСК.
Вкладка Режим имеет области:
Режимы пиктограммы ПСК и Режимы ПСК.
Первая из них имеет три флажка: включение пиктограммы, перенос
пиктограммы из левого нижнего угла графического экрана в начало координат, распространение установки режимов пиктограммы ПСК на все видовые
экраны.
Вкладка Режимы ПСК имеет два флажка: для каждого видового экрана; автоматическая установка вида перпендикулярно плоскости XY текущей
ПСК.
Вопросы и упражнения
1. Что такое мировая система координат (МСК) и пользовательские системы
координат ПСК? Опишите ориентацию МСК.
2. Какая команда и диалоговое окно служат для работы с системами координат?
3. Что такое пиктограмма, какие стили она имеет?
4. В каком диалоговом окне производится настройка формы и размеры пиктограммы, ее расположение на экране?
5. Что представляет собой такие свойства объектов как уровень и высота?
Объясните их графически.
9
6. Введите команду ELEV (Уровень). Проследите за диалогом, который
предлагает система.
7. Как изменить уровень и высоту при построении объекта?
8. Какие варианты ортогональных систем координат предлагает система?
9. Введите или выберите команду ПСК. Дайте характеристику опциям этой
команды.
10. Какие панели инструментов служат для работы с ПСК?
11. Как вызвать диалоговое окно?
12. Какие вкладки имеет это окно, и какие режимы ПСК можно установить
через него?
13. Выполните построения в различных ПСК по заданию преподавателя.
2. ЭКРАННОЕ ОТОБРАЖЕНИЕ ТРЕХМЕРНЫХ ОБЪЕКТОВ
2.1. Точка зрения
AutoCAD предоставляет множество средств для экранного отображения трехмерных объектов в пространстве. Вид трехмерного объекта зависит,
в первую очередь, от точки зрения, то есть точки, из которой направляется
взгляд, устанавливаемый пользователем.
Рассмотрим основные команды, используемые для этой цели.
Команда VPOINT (ТЗРЕНИЯ) позволяет практически обозреть трехмерный объект под любым углом зрения. Эта команда выдает запрос:
* * * Переключение в МСК * * *
Текущее направление взгляда:
Задайте точку зрения или [Повернуть]<Компас и тройка осей >:
Возможны следующие варианты:
- Указать точку, которая станет новой точкой зрения.
- Выбрать опцию Повернуть, при этом запрашиваются углы установки
направления взгляда: сначала угол в плоскости XY относительно оси X, потом угол относительно плоскостиXY.
- Если выбираем опцию по умолчанию <Компас и тройка осей>, то
система отображает компас с точкой взгляда и оси координат (рис. 2.1).
Положение перекрестия внутри круга обозначает, что он перемещается
по верхней части сферы, а между двумя окружностями – по нижней. Поместив перекрестие на большую окружность в любом месте – мы располагаем
точку зрения на «южном полюсе». При перемещении перекрестия по «компасу» наблюдается изменение положения осей X, Y и их длин, а направление
оси Z не изменяется, изменяется только длина. Это диктуется условиями зрительного восприятия наглядных проекционных изображений.
10
Экватор
Северный
полюс
Южный полюс
Точка зрения
Рис. 2.1. Выбор точки зрения
Команда DDVPOINT (ДИАЛТЗРЕН) также применяет точку зрения.
При вызове этой команды открывается диалоговое окно Задание точки зрения (рис. 2.2), в котором точка зрения задается с помощью двух углов. Угол
определяют две плоскости, линия пересечения которых и будет линией направления взгляда.
Команда PLAN (ПЛАН) применяется для выбора точки зрения, когда в
рисунке есть разные ПСК. В качестве направления взгляда будет взято
направление с конца оси Z на плоскость XY той ПСК, которая будет указана
пользователем в ответ на запрос:
Задайте опцию [Текущая /ПСК/Ми]<Текущая>:
Первая опция устанавливает вид в плане текущей ПСК, имя этой ПСК
запрашивается следующим шагом, а третья опция – устанавливает вид в
плане МСК.
2.2. Построение перспективы
Команда DVIEW (ДВИД) предоставляет пользователю перспективные
изображения трехмерных объектов в пространстве. Перспективные изображения, по сравнению с аксонометрическими, обладают большей естественностью зрительного восприятия этих объектов. Команда ДВИД работает в
динамическом режиме. Для удобства пользования этой командой в AutoCAD
введены понятия камеры (точка зрения) и цели (точка в районе объекта, задающая направление камеры). Фактически камерой и целью задается главный луч, перпендикулярно которому AutoCAD формирует плоскость проекций, где и создается перспективное или аксонометрическое изображение.
11
Рис. 2.2. Диалоговое окно " Задание точки зрения"
Рассмотрим опции этой команды. Запрос:
Задайте опцию [Камера/Цель/Расстояние/Точки/ПАн/ПОказать/ВРащать/
СЕчение/СКрыть/ОТКл/ОТМенить]:
• Камера – задает точку зрения, получаемую с помощью трех пространственных координат, то есть дает динамическое указание начальной
точки для вектора камера-цель, определяющее направление взгляда.
• Цель – задает направление камеры, также определяемое с помощью
трех координат, то есть динамическое указание конечной точки (точки
цели) для вектора камера-цель.
• Расстояние – ввод нового расстояния между камерой и целью с отключением обычной параллельной проекции и включением перспективной
проекции.
• Точки – задает точку камеры и точку цели с помощью пространственных координат, которые можно указывать любым допустимым способом, в т.ч. с помощью координатных фильтров и объектной привязки.
• Пан (панорамирование) – перемещение перспективного изображения
вдоль плоскости экрана с помощью двух точек, определяющих вектор
перемещения.
12
• ПОказать – увеличивает или уменьшает перспективное изображение,
задает коэффициент увеличения от 0х до 16х, а также фокусное расстояние при включенной перспективе.
• Вращать – вращение и наклон вида относительно направления взгляда.
• Сечение – отсекает от экранного изображения переднюю или заднюю
часть объекта относительно передней или задней секущей плоскости,
располагаемой параллельно перспективному изображению и перемещаемой вдоль главного луча на указанное расстояние от точки цели.
• Скрыть – удаляет скрытые линии без выхода из команды.
Указание точки вместо выбора опций работает как указание точки для
опции Цель.
Рассмотрим работу команды ДВИД на конкретном примере.
Выполним предварительное построение (рис.2.3).
цель
Камера
Рис. 2.3. Предварительное построение
Нарисуем квадратную сетку 10 на 10 гнезд с шагом 20 единиц. Зададим
свойству Высота значение 60 (высота выдавливания). Построим с помощью
команды ПЛИНИЯ прямоугольники, располагая их в виде домов вдоль улицы. Изменим высоту на 20 и построим командой ПЛИНИЯ прямоугольник
поперек улицы. Построения закончены.
Вызовем команду ДВИД. Первый запрос команды:
Выберите объекты или <Использовать DVIEWBLOCK>:
Укажем все объекты, в том числе и квадратную сетку для работы в
этой команде. Изменение значений опций происходит в динамическом режиме и для этого AutoCAD требуется постоянно производить регенерацию
(новый перерасчет всей картины), поэтому выбор большого количества объектов будет ее замедлять. Среди выбранных объектов должны быть характерные для зрительного восприятия перспективы. В нашем примере объек-
13
тов очень мало. Потому выбор всех объектов не повлияет на скорость регенерации в динамическом режиме.
Выберем главный луч.
Для этой цели воспользуемся опцией Points (Точки) и зададим точку
цели. Ее удобно располагать приблизительно в центре объекта. Далее зададим точку положения камеры. Эти точки и определяют в пространстве расстояние от камеры до цели, положение главного луча, а, следовательно, и
картинной плоскости, которая расположена перпендикулярно лучу.
Если главный луч будет располагаться параллельно плоскости XY в
МСК, то картинная плоскость будет ориентирована в пространстве вертикально. Так, если точка цели и точка камеры будут указаны в одной плоскости, например в XY, то сетка и нижние основания зданий совпадут и проецируются в линию.
Прервем выполнение команды нажатием клавиши Esc и выполним еще
раз построение перспективы: зададим точку камеры и точку цели по–
другому. Снова вызываем команду ДВИД, также выбираем объекты и вызываем опцию Точки, по точке камеры и цели зададим координаты с помощью
координатных фильтров. Это делается так. Перед тем как указать точку цели
курсором введем с клавиатуры координаты, которые мы хотим указать с экрана, поставим перед ними точку: ▪ XY. После нажатия клавиши ENTER
укажем курсором положение точки цели, а затем на запрос – ввести координаты Z, введем с клавиатуры число, равное предполагаемой высоте точки
цели – в нашем случае 30. Таким же образом введем значения для положения
точки камеры, указав то же значение координат Z. Включаем перспективу с
помощью опции Расстояние. Теперь линия горизонта будет проходить выше.
Рис. 2.4. Различные виды перспективы
14
Расстояние от камеры до объекта искажает изображение, причем, чем
короче расстояния, тем сильнее перспективные искажения, а при большом
расстоянии перспективное изображение стремится к аксонометрическому.
Система предлагает удобный способ выбора расстояния при постоянном контрасте изменяющегося перспективного изображения в диалоговом
режиме.
Итак, манипулируя точками зрения и цели, а также значением расстояния, добьемся различных перспективных изображений, представленных на
рисунке 2.4.
Панорамирование объекта производится командой ПАн. Сдвигаем изображение относительно экрана так, чтобы изображение располагалось в графической зоне наилучшим образом. После вызова опции зафиксируем базовую точку, после чего изображение будет перемещаться вместе с курсором
до тех пор, пока мы не зафиксируем вторую точку.
2.3. Визуализация трехмерных объектов
В обычном режиме AutoCAD отображает на экране все элементы, в т.ч.
принадлежащие дальним граням одного объекта, которые, накладываясь на
линии передних граней, создают трудности для зрительного восприятия. Для
удаления скрытых линий используется опция Скрыть, которая сравнивает
расположение всех объектов относительно картинной плоскости, моделируемой видовым экраном, и делает невидимыми объекты или их части, если
они перекрываются другими, расположенными ближе.
Свойством непрозрачности объектов обладают круг, фигура, полилиния (закрашенные), выдавленные участки двумерных примитивов, многоугольные сети и твердотельные объекты.
Визуальные стили
Для расширения возможностей отображения трехмерных объектов существует целый ряд операций, которые сосредоточены в подменю Визуальные стили, оно содержится в падающем меню Вид.
Рассмотрим основные из них:
• 2D каркас – показ содержимого видового экрана в виде 2D-каркас.
• 3D каркас – показ содержимого видового экрана в виде 3D-каркас.
• Реалистичный – показ в реалистичном стиле по Гуро.
•
Концептуальный – показ в концептуальном стиле по Гучу.
Тонирование
Операции тонирования находятся в одноименном подменю Тонирование в меню Вид. Они также предназначены для улучшения восприятия трехмерных объектов.
Работа с источником света
Для этого служит подменю Свет, которое предлагает следующие операции:
• Новый точечный источник света – создание точного источника.
• Новый прожектор.
• Новый удаленный свет.
• Список источников света.
15
• Географическое положение – задания географических координат
• положения модели с учетом времени суток при тонировании.
•
Свойства солнца.
Материалы
Для придания большей реалистичности, при тонировании используется
возможность присвоения объектам свойств материала, таких как отражательная способность, прозрачность, фактура поверхности и т.п. Для этого также
существует специальное диалоговое окно Материалы (Меню Вид – подменено Материалы).
Сохранение и восстановление видов
Рассмотрим диалоговое окно Диспетчер видов (рис.2.5), которое открывается командой ВИД.
Рис. 2.5. Диалоговое окно «Диспетчер видов»
В левой части диалогового окна в виде дерева расположен список именованных и стандартных видов. Текущий вид тоже включен в дерево – верхний элемент списка.
Виды разделены на три большие группы:
•
Виды моделей – именованные виды пространства моделей и камеры (перспективные виды, сведенные с камерами).
• Виды на листе – именованные компоновки листов, состоящие из
нескольких видов экранов листа с видами.
• Стандартные виды – стандартные ортогональные и изометрические виды.
16
В средней части диалогового окна отображаются свойства выбранного
вида моделей. Для этого имеются три внутренних вкладки: General (Общие),
View (Вид), Clipping (Подрезка).
На вкладке General (Общие) располагаются следующие свойства:
- наименование вида;
- название категории, в которой данный вид фигурирует в диспетчере
подшивок;
- имя системы координат, если она сохранена с видом;
- снимок слоев – признак сохранения настроек видимости Слоев с видом;
- стиль отображения – визуальный стиль, который связывается с видом;
- переопределение фона – особый фон, который может быть привязан
к виду (одноцветный, градиентный или растровое изображение);
- псевдоразряд - признак показа псевдоразряда при восстановлении вида.
На внутренней вкладке View (Вид) описываются такие настройки: координаты точки камеры; координаты точки цели; угол наклона; высота и ширина вида; признак перспективы; фокусное расстояние для перспективы и
угол обзора.
На вкладке Подрезка задаются параметры подрезки вида, которые
можно задать; состояние передней и задней плоскости подрезки, а также
признак включения подрезки. Каждый вид дерева имеет контекстные меню
из пяти пунктов: Диспетчер видов, Установить, Создать, Обновить слои, Редактировать контуры, Удалить.
Для создания нового вида в диалоговом окне Диспетчер видов нажимаем кнопку New (Создать), после чего открывается диалоговое окно Создать вид, через которое можно задать множество свойств создаваемого вида.
2.4. Орбитальный режим
Для нахождения оптимального вида очень удобен интерактивный режим, работающий только в пространстве модели. На экране дополнительно
появляется вспомогательная окружность, центр которой совпадает с серединой видового экрана. Окружность обозначает очерк сферы, в центре которой
располагается точка цели. Эту окружность называют Орбитой. Точка воображаемой камеры при этом расположена в пространстве на линии, проходящей через точку цели и перпендикулярной видовому экрану и, соответственно, плоскости Орбита. При перемещении мыши с нажатой левой клавишей
мы поворачиваем сферу вместе с пространством и объектами вокруг точки
цели. Для более наглядной пространственной ориентации наряду с сеткой и
трехмерным знаком ПСК можно воспользоваться еще одним средством-компасом, представляющим собой экватор и два основных меридиана
сферы, которые всегда согласованы с МСК. Когда включается компас, орбита условно делит видовой экран на две области. От того, в какой области будет находиться в текущий момент курсор, зависит, как будет происходить
вращение; графическая форма курсора при этом будет меняться. На Орбите,
в точках определяющих квадраты, расположено 4 малых круга. Курсор, рас-
17
положенный в этих кругах, также приобретает очертание в зависимости от
характера вращения.
Для вывоза команд орбитального вращения используются как панель
инструментов 3D навигация, так и панель 3D навигация пульта управления.
Меню Пульт управления оформлено в виде сложного окна ПУЛЬТУПР, которое вызывается одноименной командой (рис.2.6).
а)
б)
Рис. 2.6. а) Панель 3D Навигация
б) Панель 3D Навигация пульта управления
Наряду с традиционными опциями, такими как: перемещение изображения в плоскости видового экрана; уменьшение или увеличение изображения, имитирующее изменение фокусного расстояния объектива камеры, и
другие, представляют интерес дополнительные опции: установки проекций
параллельной и перспективной. Здесь же имеются средства для настройки
перспективы (фокусного расстояния).
Далее расположены кнопки управления конфигурациями видовых экранов и управления показом объектов-камер, а также кнопки анимации, операции облета и обхода модели. Внизу этой панели приводятся значения те-
18
кущего положения точки камеры (откуда направлен взгляд) и точки цели
(куда направлен взгляд).
С режимом орбитального вращения связаны следующие команды:
3DОРБИТА – зависимая (ограниченная) орбита. Вращают вид относительно точки центра;
3DСОРБИТА – свободная орбита. Может поворачивать вид как относительно точки центра, так и относительно главных осей вида;
3DПОРБИТА – постоянная орбита. Непрерывно вращает вид по заданному пользователем направлению.
Самым общим вариантом является команда 3DFORBIT (3DСОРБИТА).
Если в момент вызова этой команды на рисунке были выбраны какие-то объекты, то в дальнейших манипуляциях установки вида участвуют только они.
При отсутствии выбранных объектов динамическое изменение показывает
новое положение всех видимых объектов рисунка. На период работы этой
команды видно орбитальное кольцо (рис. 2.7).
Рис. 2.7. Орбитальное кольцо
Как указывалось выше, центр орбитального кольца совпадает с центром вида, вокруг которого пользователь может перемещать камеру. При
движении курсор (перекрестие) может принимать разные формы, отражая
механизм вращения вида.
Если устройство указания находится внутри орбитального кольца, то
курсор принимает форму сферы с двумя внешними окружностями-орбитами.
В этом случае нажатие левой кнопки мыши и перемещение курсора внутри
19
кольца вращает вид вокруг точки цели. Вращение возможно во всех направлениях.
Если курсор находится вне орбитального кольца, он выглядит как сфера с внешней окружностью-стрелкой. В этом случае нажатие левой кнопки
мыши и перемещение курсора вне кольца вращает вид вокруг оси, проходящей через центр орбитального кольца перпендикулярно экрану.
Если курсор находится на левом или правом малых кругах, расположенных в точках левого и правого квадрантов орбитального кольца, то он
принимает форму сферы с горизонтальным эллипсом-стрелкой. Нажатие левой кнопки мыши и перемещение курсора из этих точек вызывает вращение
вида относительно вертикальной оси, расположенной в плоскости орбитального кольца и проходящей через его центр.
Если курсор находится на верхнем или нижнем малых кругах (квадрантах) орбитального кольца, то он имеет форму сферы с вертикальным эллипсом-стрелкой. Нажатие левой кнопки мыши и перемещение курсора из
этих точек вызывает вращение вида относительно горизонтальной оси, расположенной в плоскости кольца и проходящей через его центр.
Нажатие клавиш <Esc> и <Enter> обеспечивает выход из орбитальных
команд, также можно воспользоваться контекстным меню, нажав правую
кнопку мыши.
Перечислим команды этого меню:
- Выход из орбитальной команды;
- Текущий режим - информация о том, какая из орбитальных команд в
данный момент активна: Зависимая орбита, Свободная орбита, Непрерывная
орбита;
- Режимы навигации – подменю смены типа навигации по модели: Зависимая орбита, Свободная орбита, Непрерывная орбита, Регулировка расстояния, Шарнир, Обход, Облет, Зумирование, Панорамирование;
- Включить автоприцел орбиты - разрешение автоматического выбора
точки цели.
Кроме того, контекстное меню предлагает вызов диалогового окна Параметры анимации.
Изменить размеры орбитального вида с помощью рамки можно посредством пункта Окно зумирования, а изменение размеров орбитального
вида с помощью границ рисунка производится через пункт Зумировать в границах.
Через контекстное меню также возможно выполнить следующие операции:
- переход к предыдущему орбитальному виду;
- установка режима параллельной проекции;
- установка режима перспективной проекции;
- восстановить вид, с которого начался орбитальный режим;
- установить один из 6 стандартных видов;
- осуществить выбор именованного вида, если они были сохранены;
20
- выбрать стиль визуализации и средства визуализации: компас, сетка,
знак ПСК.
Режим Непрерывная орбита позволяет перевести рисунок в режим постоянного вращения. Для этого движением мыши с нажатой левой кнопкой
надо указать направление вращения и отпустить кнопку. Щелчок левой
кнопкой мыши, а также нажатие клавиши <Esc> или <Enter> останавливает
постоянное вращение.
Вопросы и упражнения
1. Перечислите основные средства, которые предлагает система AutoCAD
для экранного отображения трехмерных объектов в пространстве.
2. Какие возможности предоставляет команда VPOINT (ТЗРЕНИЯ), и какой при этом ведется диалог?
3. Какие варианты предлагаются для указания точки зрения?
4. Как работает опция Повернуть при задании точки зрения? Продемонстрировать эту опцию на примере.
5. Какая опция предлагается по умолчанию? Войдите в этот режим, т.е.
выберите эту опцию.
6. Что такое «компас» в средствах отображения 3-х мерных объектов?
Объясните его графические элементы.
7. Что означает перемещение перекрестия: а) внутри малого круга; б) между двумя окружностями; в) по большей окружности? Как «ведут себя» при этом оси координат?
8. Вызовите команду DDVPOINT (ДИАЛТЗРЕН). Объясните назначение
разделов появившегося диалогового окна?
9. Для каких целей применяется команда PLAN (ПЛАН)?
10. Что такое перспективное изображение трехмерного объекта? Какая команда используется для этой цели?
11. Что такое «камера» и «точка цели»?
12. Перечислите опции команды DVIEW (ДВИД).
13. Какие опции служат для задания главного луча при построении перспективы?
14. Как устанавливается расстояние от точки цели до камеры?
15. Что такое панорамирование перспективы и как оно осуществляется?
16. Как произвести уменьшение и увеличение перспективы изображения, а
также изменить фокусное расстояние?
17. Какая опция осуществляет порот перспективы вокруг главного луча и
ее наклон?
18. Объясните, как работает опция Сечение и продемонстрируйте это на
конкретном примере.
19. Постройте архитектурный ансамбль по заданию преподавателя и отработайте на нем все опции команды ДВИД.
20. Для какой цели и как осуществляется удаление невидимых линий?
21. Какие существуют визуальные стили? Дайте им характеристику и назначение.
21
22. На предварительно построенном трехмерном объекте продемонстрируйте показ 3D-каркаса, реалистический вид по Гуро и по Гучу.
23. Как осуществить тонирование объекта?
24. Объясните работу с источником света.
25. Как придать объекту то или иное свойство материала?
26. Какие разделы имеются в диалоговом окне Диспетчер видов?
27. Как можно просмотреть свойства выбранного вида моделей отображения?
28. Какие свойства располагаются на вкладке Genеral (Общие)? Перечислите
их.
29. Как изменить настройки вида?
30. Что такое подрезка вида и как ее осуществить?
31. Как создать новый вид?
32. Дайте характеристику орбитального режима. Для какой цели он служит?
33. Опишите панель инструментов 3DНавигация и панель 3DНавигация
пульта управления.
34. Какие разделы имеет меню Пульт управления и их назначение?
35. Продемонстрируйте работу команд 3DОрбита (Зависимая орбита),
3ВСОРБИТА (Сводная орбита) и 3DПОРБИТА (Построенная орбита).
36. Как выглядит курсор, когда находится внутри орбитального кольца,
вне его, на левом или правом малых кругах, на верхнем или нижнем
малых кругах?
37. Какие возможности имеет контекстное меню при выполнении орбитальных команд?
3. ВИДОВЫЕ ЭКРАНЫ
При работе с изображениями трехмерных объектов удобно разделить
экран на части, в каждой из которых можно устанавливать свой вид одной и
той же детали. Такие экраны называют видовыми. Следует различать видовые экраны пространства модели и видовые экраны пространства листа. Пространство модели предназначено для работы с трехмерными объектами, пространство листа представляет собой плоскость с проекциями этих объектов
для плоского чертежа. Роль пространственных объектов состоит не только в
построении проекций чертежа, но и в использовании их в качестве моделей
для прочностных расчетов. Построенную трехмерную модель можно экспортировать в соответствующие системы для исследования на прочность.
Работая в пространстве модели или листа, мы можем увеличивать или
уменьшать изображения пространства в листе с объектами или перемещать
их относительно рамок графического экрана. Но только в пространстве модели мы можем с помощью соответствующих команд получить любую параллельную прямоугольную аксонометрическую проекцию или перспективу
из любой точки зрения. Переход из одного пространства в другое происходит
с помощью вкладок, расположенных у нижней кромки графической области
экрана.
22
3.1. Видовые экраны пространства модели
Система AutoCAD позволяет создавать конфигурацию из любого количества частей (неперекрывающихся видовых экранов) и присваивать имя каждой такой конфигурации, по которому она может быть в любое время восстановлена. Для этой цели служит команда VPORTS (ВЭКРАН). Задать эту
команду можно различными способами, которые всегда доступны пользователю, а именно: используя соответствующую копку на панели инструментов
Видовые экраны или пункт меню Вид – Видовые экраны, или набором в командной строке имени команды. Эта команда открывает диалоговое окно
Viewports (Видовые экраны) с вкладкой New Viewports (Новые ВЭКраны)
(рис. 3.1).
Рис. 3.1. Диалоговое окно «Видовые экраны»
Новые видовые экраны
Рассмотрим разделы этого окна. В строке Новое имя можно задать имя
создаваемой конфигурации видовых экранов. Если не задать им имя, то новая
конфигурация экранов все равно будет создана. То есть графический экран
будет разделен на соответствующие части, но данная конфигурация не будет
сохранена, и при переходе к другой конфигурации она не может быть восстановлена.
23
В разделе Preview (Образец) отображается вид той конфигурации экрана, которая выбрана в списке Стандартные конфигурации. Одна из них, например, может быть такой: Изложения, Вид сверху, Вид спереди.
В раскрывающемся списке Применить (внизу слева диалогового окна)
можно выбрать одно из двух значений, указывающих, к какой части графического экрана будет применяться операция На части: ко всему экрану или к
текущему видовому окну. Последнее применяется в тех случаях, когда есть
необходимость один из видовых экранов разделить на части.
В списке Режим содержится два значения: 2D-текущий вид, то есть
вид, установленный в активном видовом экране, который будет делиться на
части – он распространяется на все новые видовые экраны; 3-D текущий вид
устанавливается в одном из создаваемых видовых экранов, в остальных система выбирает соответствующие ортогональные виды. Поле просмотра (Образец) разбито на части, согласно выбранной схеме деления, причем один из
видовых экранов является активным. Активизация экрана осуществляется
щелчком мыши в этой области.
Список Сменить вид на… дает возможность установить нужный вид в
том видовом экране, который активен в поле просмотра в режиме 3D. При
этом в раскрывающемся списке доступны имена стандартных и изометрических видов, имена сохраненных видов и имя Текущий.
В списке Визуальный стиль для выделенного видового экрана устанавливается стиль визуализации (см. §2.3).
Курсор на активном экране имеет вид перекрестия, а рамка активного
экрана более жирная.
При сохранении конфигурации система заполняет параметры видов
каждого экрана, систему координат и свойства пиктограммы ПСК.
Команда VPORTS (ВЭКРАН), работающая в режиме командной строки, выводит следующий запрос:
Задайте опцию [Сохранить/Восстановить/Удалить/cоЕдинить/
Один/?/2/3/4],<3>:
Опции этой команды аналогичны команде VPORTS (ВЭКРАН). При
выборе опции ? получаем справочную информацию о конфигуральных видовых экранах в виде листинга, в котором указывается условные координаты
углов в долях от полного экрана.
Опишем работу с конфигурациями видовых экранов.
Если необходимо вернуться к одноэкранному виду, то следует активизировать тот видовой экран, вид которого хотим оставить для использования.
Затем командой ВЭКРАН откроем диалоговое окно Видовые экраны, на
вкладке Новые ВЭкране выберем конфигурацию Один и в списке Применить
выберем пункт Ко всему экрану.
Снова вернемся к диалоговому окну Видовые экраны, но установим
вкладку Именованные Вэкраны(рис 3.2).
Это позволит нам выбрать конфигурацию видовых экранов из тех, которые были сохранены ранее. Контекстное меню, вызываемое щелчком правой
24
кнопки мыши в зоне списка именованных конфигураций, имеет два пункта:
Переименовать и Удалить.
Рис. 3.2. Диалоговое окно «Видовые экраны»
«Именованные видовые экраны»
3.2. Оформление чертежа в пространстве листа
Как уже говорилось в начале этой главы, пользователю предоставляется возможность работать в двух пространствах: в пространстве модели и в
пространстве листа. Работая в пространстве модели, специалист создает модель того или иного объекта, например, твердотельной трехмерной детали.
Причем можно создавать модель в любом масштабе, ее можно строить с истинными размерами, то есть в натуральную величину. Это избавляет от множества проблем с пересчетом размеров.
Пространство листа позволяет оформить чертежные документы, удовлетворяющие соответствующим требованиям. В пространстве листа предусмотрен особый механизм – создание мостов (вкладок) с видовыми экранами,
каждый из которых является видом, проекцией или сечением модели с нужным масштабом. Фактически вкладка листа – это лист бумажного чертежа.
25
Максимальное количество вкладок листов файла чертежа – 235, поэтому общее количество вкладок вместе с вкладкой Модель – не превышает 256.
Рассмотрим некоторые особенности пространства листа. При работе с
системой под графическим полем имеются клавиши, которые подключают
пространство модели Model (Модель) или две вкладки пространства листа
Layout 1(Лист 1) и Layout 2 (Лист 2). Одна вкладка листа соответствует одному листу графического документа, выпускаемого по модели, созданной на
вкладке Model (Модель).
Рис. 3.3. Пространство листа, вкладка Layuot1(Лист 1)
нового рисунка
Для каждой вкладки листа необходимо описать все, что связано с этим
листом: устройство печати, размер листа, поля, масштаб и т.д. Эта информация хранится в параметрах вкладки в текущем рисунке. В первый раз вкладка
открывается с настройками, сделанными по умолчанию. Рассмотрим, как
оформлено графическое окно в пространстве листа (рис.3.3).
В левом нижнем углу листа виден знак – треугольник Белое поле – это
лист бумаги, на который настроена вкладка. Пунктирная линия – область печати, фактически доступная для печати на устройстве, указанном в параметрах настройки вкладки. Сплошная линия обозначает сам видовой экран.
Причем Видовой экран в пространстве листа является примитивом AutoCAD, в отличие от видовых экранов в пространстве модели. Тип примитива
VIEWPORT. Этот видовой экран – примитив называется плавающим. Это название связано с тем, что его можно перемещать, стирать, копировать, то есть
он доступен редактированию.
26
В пространстве листа можно строить любые примитивы, но они будут
принадлежать только своей вкладке, и не будут отображаться ни в пространстве модели, ни в других вкладках листов. Настройка параметров вкладки
листа выполняется с помощью команды PAGESETUP (ПАРАМЛИСТ). Эта
команда открывает диалоговое окно Диспетчер наборов параметров листов (рис. 3.4). Рассмотрим разделы этого окна. Вверху высвечивается имя активной вкладки, например, Layout 1 (Лист 1). В области Параметры листа
перечисляются имена наборов, сохраненных в этом рисунке. Наборы параметров, создаваемые по умолчанию, получают имена Лист 1, Лист 2, . . .
Рис. 3.4. Диалоговое окно «Диспетчер наборов параметров листов»
В нижней части диалогового окна располагаются сведения о выделенном наборе параметров, то есть основные настройки этого набора. Если в рисунке ни разу не открывался какой-то лист, то параметров этой вкладки в
списке не будет.
В правой части окна расположены кнопки, имеющие следующие назначение:
Установить – устанавливает в качестве текущего набор параметров,
отмеченных в списке;
27
Создать – создает новый набор параметров вкладки листа;
Изменить – изменяет параметры, включенные в выделенный набор;
Импорт – импортирует набор параметров из другого DWG – рисунка.
При наличии кнопки Создать открывается окно Создание набора параметров листа (рис.3.5), а после нажатия кнопки ОК открывается диалоговое
окно Параметры листа (рис.3.6).
Рис. 3.5. Диалоговое окно «Создание наборов параметров листа
(New Page Setup)»
Оно полностью совпадает с окном Печать, потому что, когда создается
вклад листа, необходимо описать все, что связано с печатью этого листа. Вся
указанная информация далее будет храниться в текущем рисунке.
3.3. Видовые экраны пространства листа
Как отмечалось выше, видовые экраны пространства листа – это примитивы типа VIEWPORT. При первом переходе на лист система по умолчанию создает только один видовой экран. В нем появляется вид, идентичный
виду, установленному в активном видовом экране пространства модели.
Видовые экраны в листе обладают признаком обычных примитивов и их
можно редактировать.
Рассмотрим создание плавающего видового экрана прямоугольной
формы. Для этого воспользуемся командой VPORTS (ВЭКРАН). Появляется
запрос о расположении новых видовых экранов.
Угловая точка видового экрана или [Вкл/Откл/Вписать/Тонировать/
Блокировать/Объект/Многоугольник/Восстановить/2/3/4]<ВПисать>:
28
Рис. 3.6. Диалоговое окно «Параметры листа»
Для определения границ одного прямоугольного видового экрана нужно задать две его угловые точки, расположенные по диагонали будущего
прямоугольника. После указания первой точки появляется запрос:
Противоположный угол:
Указываем вторую точку. Эту операцию по созданию видовых экранов
на свободном листе можно повторять несколько раз. На рисунке 3.7 показано
4 видовых экрана на одном листе.
Размеры и местоположение экранов определяет сам пользователь. Их
можно смещать, копировать, удалять. Видовые экраны могут даже пересекаться или целиком лежать внутри других экранов. Рассмотрим опции команды –MVIEW (СВИД):
ВКЛ, ОТКЛ – включает или выключает видимость объектов на экране;
ВПИСАТЬ – создает видовой экран с размерами рабочего поля листа;
ТОНИРОВАТЬ – задает режим печать видового экрана (нормальный,
каркасный, со скрытием невидимых линий, тонированный);
БЛОКИРОВАТЬ – включает или выключает блокировку дальнейшего
изменения масштаба видового экрана;
ОБЪЕКТ – создает видовой экран с границей, идентичной указанному
замкнутому объему (полилинии, эллипсу, сплайну, области или окружности);
29
Рис. 3.7. Создание нескольких плавающих видовых экранов
МНОГОУГОЛЬНЫЙ – создает видовой экран с многоугольной границей (стороны многоугольника могут быть и дуговыми сегментами);
ВОССТАНОВИТЬ – создает группу плавающих видовых экранов, расположенных аналогично именованной конфигурации видовых экранов пространства модели;
2/3/4 – делит экран на 2,3,4 зоны.
После создания плавающих видовых экранов дальнейшая работа с листом заключается в следующем:
• В каждом видовом экране установить свой вид и масштаб.
• Заморозить в каждом видовом экране лишние слои.
• Сделать невидимыми рамки видовых экранов.
• Добавить на вкладку листа элементы оформления (наименования
видов и сечений, надписи, рамки, штамп и т.п.).
Рассмотрим, как это делается.
Чтобы установить в видовых экранах требуемые виды необходимо в
режиме Модель активировать нужный видовой экран пространства модели.
Команда CHSPACE (СМЕНАПРОСТР) позволяет переносить изображения из пространства модели в пространство листа или наоборот, рассчитывая соответствующие объекты в новом пространстве и удаляя объекты
старого пространства. Сделать невидимыми рамки видовых экранов.
30
Создание согласованных видов
В системе AutoCAD предусмотрены средства, которые вызывают команды подготовки согласованных видовых экранов с проекциями трехмерных тел. Создаваемые и отрабатываемые этими командами видовые экраны
имеют специальную организацию, которая отличается от вышеизложенных
операций. Видовые экраны получают имена, и с этими видовыми экранами
связываются специально создаваемые слои рисунка.
Нарисуем твердотельный объект, для которого необходимо создать согласованные виды (рис.3.8).
Рис. 3.8. Твердотельный объект, для которого необходимо создать
согласованные виды
Перед построением уберем раскрашивание, установив в модели режим
двумерного каркаса. Перейдем на вкладку Layout 1 (Лист 1), в которой нет
никаких видовых экранов. Если они окажутся, то их надо удалить.
Затем вызываем команду SOLVIEW (Т-ВИД) по такому маршруту:
Черчение/Моделирование/Подготовки/Вид.
Первый запрос команды SOLVIEW:
Задайте опцию /Пск/Орто/Дополнительный/Сечение:
Пск – создает видовой экран с установкой вида в заданной ПСК;
Орто – создает видовой экран с видом, ортогональным виду указанного видового экрана;
Дополнительный – осуществляет создание видового экрана с видом дополнительного сечения;
Сечение – создает видовой экран с сечением.
Выберем опцию ПСК. Появляется запрос:
Задайте опцию [Имя/Мск/?/Текущая]<Текущая>:
Выберем опцию Мск для вида сверху, так как МК соответствует плоскости нижнего основания моделируемого объекта.
Запрос:
Масштаб вида <1.0>:
Возьмем, например, масштаб равный 0.05, т.е. 1:20. Система начинает
строить первую проекцию и запрашивает положение центра вида:
31
Рис. 3.9. Размещение центра первого вида (вид сверху)
Центр вида:
Укажем точку центра вида в любой нижней четверти листа (рис.3.9).
Этот запрос циклический, он позволит «вручную» уточнять положение
центра вида, что очень удобно. После нажатия клавиши ENTER, положение
вида фиксируется и появляется новый запрос:
Первый угол видового экрана:
Указываем.
Далее запрос:
Противоположный угол видового экрана:
Указываем. Получаем изображение (рис.3.10).
Запрос:
Имя вида:
Можно ввести имя Сверху. Система завершает построение первого видового экрана и выдает сообщение о сохранении ПСК вместе с видом. Это
мы создали вид сверху. Теперь перейдем к построению вида спереди.
Система продолжает запрашивать:
Задайте опцию: [Пск/Орто/Дополнительный/Сечение];
Выберем опцию Орто.
32
Рис. 3.10. Видовой экран Вид сверху
Запрос:
Укажите строку видового экрана для проекции:
Укажем нижнюю сторону видового экрана, используя значок объектной привязки Середина треугольника, появляющийся автоматически.
Далее запрашивается центр второго вида. Появляется резиновая нить,
которая позволит разместить новый вид только строго вертикально от вида
сверху.
На листе уже два видовых экрана (рис. 3.11).
Указываем центр, затем границы видового экрана, как это делалось
выше, и зададим имя второго вида Спереди. Аналогично построим третий
видовой экран Вид слева в правой верхней части листа. А с помощью команды VPORTS (ВЭКРАН) в правом нижнем углу построим еще один видовой
экран, установив в нем изометрический вид. Получается чертеж с четырьмя
проекциями, три из которых полностью согласуются между собой (рис.3.12).
Созданные командой SOLVITW (Т-ВИД) видовые экраны обладают
особыми свойствами. Имена, которые им задали для видов, связаны с именами автоматически заданных слоев, которые можно увидеть, вызвав с помощью команды LFYER (СЛОЙ) окно Диспетчер свойств слоев (рис. 3.13).
На VPORTS размещены границы видовых экранов. Его можно отключить, если границы невидимы.
По имени каждого из видов (Сверху, Спереди, Слева) создались новые
тройки слоев, имена которых оканчиваются на DIM, HID, VIS. Эти слои
33
имеют специальные назначения. Слой с окончанием DIM должен хранить
размерные примитивы соответствующего вида; слой с окончанием HID - невидимые линии вида; слой с окончанием VIS – видимые линии вида. Управление видимыми и невидимыми линиями осуществляется командой
SOLDRAW (Т-Рисование).
Рис. 3.11. Видовые экраны «Сверху и Спереди»
3.4. Вопросы и упражнения
1. Что представляет собой видовой экран?
2. Что такое пространство модели и пространство листа? Какие особенности трехмерного моделирования в этих пространствах?
3. Какая команда служит для создания той или иной конфигурации видовых экранов в пространстве листа? Какими способами можно задать
эту команду?
4. Вызовите диалоговое окно Видовые экраны. Рассмотрите все разделы этого окна.
5. Как сохранить конфигурацию экранов для дальнейшего использования?
6. Как работают списки Применить, Режим, Сменить вид на…, Визуальный стиль?
7. Что такое «вкладки листа» и каково их максимальное количество?
34
Рис. 3.12. Построение нескольких видовых экранов с сохраненной
проекционной связью
Рис. 3.13. Слои, создаваемые командой SOLVIEW
35
8. Перечислите параметры вкладки листа. Какие настройки используются по
умолчанию?
9. Какое диалоговое окно служит для настройки параметров вкладки листа? Опишите разделы этого окна.
10. Как создать новый набор параметров листа?
11. Создайте несколько плавающих видовых экранов прямоугольной формы пространства листа. Какая команда для этого используется? Опишите опции этой команды.
12. Какую работу с листом можно выполнять в каждом видовом экране?
13. Что такое согласованные виды? Как они создаются?
14. Постройте согласованные виды детали, предложенной преподавателем.
БИБЛИОГРАФИЧЕСКИЙ СПИСОК
1.
2.
3.
4.
5.
6.
7.
Зуев, С.А. САПР на базе AutoCAD – как это делается/С.А. Зуев,
Н.Н. Полещук. – СПб.: БХВ – Петербург, 2004. - 1168 с.
Полещук, AutoCAD: разработка приложений, настройка и адаптация/
Н.Н. Полещук – СПб.: БХВ – Петербург, 2006. – 994 с.
Савельева, В.А. Самоучитель AutoCAD 2007/ В.А Савельева,
Н.Н. Полещук – СПб.: БХВ – Петербург, 2006. – 624 с.
Полещук, Н.Н. AutoCAD 2007/Н.Н.Полещук. – СПб.: БХВ – Петербург,
2007. – 1120 с.
Основы автоматизированного проектирования в системе AutoCAD. Этапы подготовки системы AutoCAD к работе: метод. указания к выполнению чертежно-графических работ для студ. 3-го курса спец. «Подъемнотранспортные, строительные, дорожные машины и оборудование»/. Воронеж. гос. арх.-строит. ун-т; сост.: В.П. Авдеев, Р.А. Ефанова– Воронеж, 2007.- 29 с.
Основы автоматизированного проектирования в системе AutoCAD.
Пользовательский интерфейс русифицированных версий: метод. указания к выполнению чертежно-графических работ для студ. 3-го курса
спец. «Подъемно-транспортные, строительные, дорожные машины и
оборудование»/ Воронеж. гос. арх.-строит. ун-т; сост.: Авдеев В.П. ,
Ефанова Р.А. – Воронеж, 2007.- 22 с.
Проектирование поверхностей в системе AutoCAD: метод. указания по
курсовому и дипломному проектированию для студентов строительных
специальностей»/Воронеж. гос. арх.-строит. ун-т; сост.: Л.Н. Шерстюкова, Р.А. Ефанова, И.Ю. Марков. – Воронеж, 2004.- 46 с.
36
ОГЛАВЛЕНИЕ
Введение . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.
Пользовательские системы координат . . . . . . . . . . . . . . . . . .
1.1. Координатные системы . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.2. Уровень . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.3. Ортогональные системы координат. . . . . . . . . . . . . . . . . . . . . . .
1.4. Команды UCS (ПСК) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Вопросы и упражнения . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
2.
Экранное отображение трехмерных объектов . . . . . . . . . . . . . .
2.1. Точка зрения . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
2.2. Построение перспективы . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
2.3. Визуализация трехмерных объектов . . . . . . . . . . . . . . . . . . . . . .
2.4. Орбитальный режим . . . . . . . . . . . . . . . . . . . . . .
Вопросы и упражнения . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
3.
Видовые экраны . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
3.1. Видовые экраны пространства модели . . . . . . . . . . . . . . . . . . . .
3.2. Оформление чертежа в пространстве листа . . . . . . . . . . . . . . . .
3.3. Видовые экраны пространства листа. . . . . . . . . . . . . . . . . . . . . .
Вопросы и упражнения . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Библиографический список . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
3
3
3
5
6
7
8
9
9
10
14
16
20
21
22
24
27
33
35
СРЕДСТВА ОТОБРАЖЕНИЯ
ТРЕХМЕРНЫХ ОБЪЕКТОВ В СИСТЕМЕ AutoCAD
Методические указания
к выполнению чертежно-графических работ по курсу
"Автоматизированные системы проектирования в строительстве"
для студентов 4-курса специальности 230201
"Информационные системы и технологии"
Составители: д.т.н., проф. Авдеев Виктор Петрович,
к.т.н., доц. Ефанова Римма Александровна
Подписано в печать 15.04.09.
Формат 60×84 1/16. Уч.-изд. л. 2,2.
Усл. – печ. л. 2,3. Бумага писчая. Тираж 250 экз. Заказ № __________
____________________________________________________________________________________________________________________
Отпечатано: отдел оперативной полиграфии Воронежского государственного архитектурно-строительного университета
394006 Воронеж, ул.20-летия Октября, 84
Документ
Категория
Без категории
Просмотров
9
Размер файла
1 605 Кб
Теги
autocad, трехмерная, объектов, система, 263, отображений, средств, 434
1/--страниц
Пожаловаться на содержимое документа