close

Вход

Забыли?

вход по аккаунту

?

390.Технологии локальных инфокоммуникационных сетей учеб.-метод. пособие для лаб. и самостоят

код для вставкиСкачать
Министерство образования и науки Российской Федерации
Сибирский федеральный университет
ТЕХНОЛОГИИ ЛОКАЛЬНЫХ
ИНФОКОММУНИКАЦИОННЫХ СЕТЕЙ
Учебно-методическое пособие
для выполнения лабораторных и самостоятельных работ
Электронное издание
Красноярск
СФУ
2013
УДК 004.057.4(07)
ББК 32.973я73
Т384
Составители: Гаипов Константин Эдуардович, Турбов Алексей Юрьевич
Т384
Технологии локальных инфокоммуникационных сетей: учебнометодическое пособие для выполнения лабораторных и самостоятельных
работ [Электронный ресурс] / сост. К. Э. Гаипов, А. Ю.Турбов. –
Электрон. дан. – Красноярск: Сиб. федер. ун-т, 2013. – Систем.
требования: PC не ниже класса Pentium I; 128 Mb RAM; Windows 98/XP/7;
Adobe Reader V8.0 и выше. – Загл. с экрана.
Представлены сведения об установке необходимых программ для проведения
лабораторных работ; даны
указания
по
выполнению
лабораторных и
самостоятельных
работ
по
дисциплине «Технологии локальных
инфокоммуникационных сетей».
Предназначено для студентов радиотехнического факультета направления
подготовки 210400.62 «Телекоммуникации» и специальности «210406.65» «Сети
связи и системы коммутации».
УДК 004.057.4(07)
ББК 32.973я73
© Сибирский
федеральный
университет, 2013
Учебное издание
Подготовлено к публикации ИЦ БИК СФУ
Подписано в свет 19.06.2013 г. Заказ 2178.
Тиражируется на машиночитаемых носителях.
Издательский центр
Библиотечно-издательского комплекса
Сибирского федерального университета
660041, г. Красноярск, пр. Свободный, 79
Тел/факс (391)206-21-49. E-mail rio@sfu-kras.ru
http://rio.sfu-kras.ru
2
ОГЛАВЛЕНИЕ
1. Графический сетевой симулятор GNS3 ............................................................ 4
1.1 Инсталляция GNS3 ............................................................................................ 4
1.2 Подключение образов операционных систем в GNS3 .................................. 8
1.3 Графический интерфейс GNS3 ...................................................................... 10
1.4 Создание петлевых интерфейсов ................................................................... 16
2. VirtualBox ........................................................................................................... 18
2.1 Работа в среде VirtualBox ............................................................................... 18
2.2 Создание петлевых интерфейсов для VirtualBox машин ............................ 25
2.3 Подключение VirtualBox машин к GNS3...................................................... 26
3. Сетевой анализатор трафика WireShark.......................................................... 27
4. Лабораторные работы ....................................................................................... 29
4.1 Лабораторная работа № 1 Изучение работы коммутаторов Ethernet ........ 29
4.2 Лабораторная работа №2 Изучение статической маршрутизации ............ 38
4.3 Лабораторная работа №3 Анализ работы техники VLAN .......................... 44
4.4 Лабораторная работа №4 Анализ работы протокол RIP ............................. 53
Библиографический список.................................................................................. 69
3
1. Графический сетевой симулятор GNS3
Графический сетевой симулятор GNS3 предназначен для виртуализации
работы операционных систем различного назначения, в основном для
операционных систем маршрутизаторов/коммутаторов Cisco IOS (internetwork
operation system – межсетевая операционная система) и JunOS (juniper operation
system – операционная система фирмы juniper) с целью моделирования работы
сетевых протоколов и технологий. Так же графический симулятор позволят
подключать и другие операционные системы, используя виртуальные машины
Qemu и VirtualBox.
1.1. Инсталляция GNS3
Для
инсталляции
GNS3
зайдите
на
официальный
сайт
http://www.gns3.net/download/ и скачайте последнюю версию программы в
зависимости от типа операционной системы и ее разрядности. В данном
примере показана установка GNS3-all-in-one для 32 битной операционной
системы Windows XP.
Запустив программу, следуйте инструкциям мастера установки,
одновременно с установкой самой программы GNS3, мастер предложит вам
установить также Wireshark и winPCAP, процесс инсталляции необходимых
компонентов показан на рис. 1. По окончанию работы всех мастера установки,
запустите GNS3, он запустится автоматически, если не будет снята галочка
«Start GNS3», после нажатия на клавишу finish в последнем окне мастера.
4
Рис. 1. Процедура инсталляция GNS3
5
Перед вами откроется два окна, окно «Setup wizard» другое GNS3, окно
«Setup wizard» нужно для предварительных настроек программы GNS. При
последующих запусках оно открываться не будет, поэтому просто нажмите
кнопу «ОК» в низу окна, как показано на рис. 2.
Рис. 2. Окно Setup Wizard
Для запуска программы необходимо проверит работу нескольких
компонентов программы GNS3, такие как: dynamips, qemuwrapper, vboxwrapper,
данные компоненты позволяют запускать различные операционные системы,
но для работы операционных систем коммутаторов и маршрутизаторов Cisco
IOS, необходима корректная работа только dymamips. Перед проверкой
основных компонентов программы можно произвести русификацию
интерфейса. Для этого в строке меню окна GNS3 зайдите в меню Edit =>
Preferences, в открывшемся окне «Preferences» в строке Language из списка
выберите русский язык, как показано на рис. 3 и нажмите кнопку «Apply» в
нижнем левом углу окна.
,
Рис. 3. Изменение языка интерфейса
6
Проверка
работоспособности
основных
компонентов
также
осуществляется из окна «Preferences». Для проверки Dymamips в окне
«Preferences» выберете меню Dymamips и нажмите кнопку «Test Settings», как
показано на рис. 4.
Рис. 4. Окно «Preferences» меню Dynamips
Если в ходе установки GNS3 не возникало никаких ошибок, то после
нажатия этой кнопки вы должны увидеть сообщение зеленого цвета: Dynamips
0.2.8-RC3 успешно запущен.
Если сообщение будет красного цвета, это свидетельствует о
некорректной установке программы или наличия ошибок в операционной
системе.
7
1.2. Подключение образов операционных систем в GNS3
После проверки всех компонент GNS3 необходимо подключить образы
маршрутизаторов и пользовательских операционных систем. Файлы
операционных систем маршрутизаторов возьмите у преподавателя и сохраните
их в каталог путь, к которому будет содержать только латинские буквы, в
противном случае образы нельзя будет подключить. Для подключения образов
Cisco IOS зайдите в меню «Редактировать»=> «Образы IOS и гипервизоры»,
после чего откроется окно «Образы IOS и гипервизоры», рис. 5.
Рис. 5. Окно Образы IOS и гипервизоры
Процесс подключения операционной системы показан на рис. 6, в данном
примере показан пример подключения Cisco IOS для маршрутизатора Cisco
3640.
8
Рис. 6. Процедура подключения образа операционной системы Cisco IOS
Пункты с 1 по 3, не требуют пояснения, на четвертом этапе после
нажатия кнопки «ДА» программа GNS3 распаковывает образ операционной
9
системы и создает файл с расширением *.image в той же директории, где
находился исходный файл, в данном случае был создан c3640-jk9s-mz.12416.image. Данная процедура нужна для того чтобы загрузка операционной
системы происходила быстрее. Если же нажать кнопку «Нет», то загрузка
операционной системы начнет с ее распаковки в оперативную память
компьютера. Обязательно нажмите кнопу «Сохранить» (пункт 5 на рисунке 6),
после чего появится строчка в поле образы (пункт 6), также проверьте, что
платформа и модель соответствуют подключенному образу, если это не так
выберите из списка соответствующую модель и платформу. По окончанию
нажмите кнопку «Закрыть».
1.3. Графический интерфейс GNS3
После подключения образа Cisco IOS можно перейти к непосредственной
работе с графическим интерфейсом рис. 7.
Рис. 7. Графический интерфейс GNS3
В графическом интерфейсе можно выделить 7 областей:
1 – строка меню;
2 – панель инструментов;
3 – типы узлов;
4 – рабочая область (в этом поле создается топология моделируемой сети)
5 – топология (здесь отображается, как узлы связаны между собой и их
состояние);
6 – захват пакетов;
7 – консоль.
10
Рис. 8. Панель инструментов
Для создания сети перетащите из области «Типы узлов» то устройство,
чей образ был подключен к GNS3, те устройства, к которым образы не были
подключены, перетащить на рабочую область не получится. Ниже описан
пример соединения двух маршрутизаторов Cisco 3640.
Перетащите в рабочую область два маршрутизатора с3640 как показано
на рис. 9.
Рис. 9. Соединение маршрутизаторов
Для их соединения к маршрутизаторам необходимо подключить сетевые
интерфейсы, для чего необходимо выбрать (щелкните право кнопкой мыши по
немаршрутизатору) маршрутизатор, выбранный маршрутизатор имеет более
темный оттенок зеленого, после чего зайдите в меню Device =>Настроить рис.
9.
11
Рис. 10. Конфигурация узла
На рис. 10 показано подключение сетевого модуля NM-1FE-TX, данный
модуль содержит один порт fastEthernet 100BaseTX. 1-м пунктом необходимо
выбрать маршрутизатор R1, затем перейти на вкладку слоты и в строке «слот 0»
из списка выбрать нужный сетевой модуль. Аналогично необходимо
подключить сетевой модуль NM-1FE-TX и для маршрутизатора R2.
Для соединения маршрутизаторов между собой нажмите на кнопку
«Добавить линк» на панели инструментов и выберете режим manual, после
чего кнопка «Добавить линк» изменит свой графический вид, как показано на
рис. 11, также изменится указатель курсора мыши.
Рис. 11. Соединение маршрутизаторов
В таком режиме указателя мыши необходимо щелкнуть левой кнопкой на
маршрутизатор, после чего будет отображен список интерфейсов
маршрутизатора, в данном случае будет отображен список только из одного
12
интерфейса f 0/0, щелчком мыши из списка выбрать нужный интерфейс и
перевести указатель мыши на другой маршрутизатор. Затем также левой
кнопкой мыши щелкнуть по второму маршрутизатору и из появившегося
списка интерфейсов выбрать необходимый, в данном случае это будет
интерфейс f0/0. данная процедура показана на рис.11. после чего снова нажмите
кнопку «Добавить линк» для перевода курсора в нормальное состояние.
а
б
в
Рис. 12. Соединение двух маршрутизаторов
Для отображения интерфейсов маршрутизаторов нажмите кнопку
«Показать названия интерфейсов», в результате интерфейсы маршрутизаторов
будут подписаны рис. 13.
Рис. 13. Отображение имен интерфейсов
Далее необходимо включить маршрутизаторы, это можно сделать
отдельно для каждого маршрутизатора либо включить все маршрутизаторы
одновременно, рекомендуется включать по очереди маршрутизаторы,
дожидаясь их полной загрузки. Ниже приведем порядок по очередного
включения маршрутизаторов. Включить маршрутизатор можно двумя
способами либо из меню «Device», предварительно щелкнув левой кнопкой на
включаемый маршрутизатор, либо из контекстного меню, которое появится
после нажатия правой кнопки мыши, данное меню полностью дублирует меню
«Device», в списке команд выберете запустить, рис. 14.
13
Рис. 14. Запуск маршрутизатора
Загрузку маршрутизатора можно наблюдать из окна консоль, которое
вызывается из того же контекстного меню, рис. 15. Из окна консоли
осуществляется вся настройка маршрутизатора.
Рис. 15. Запуск консоли
После запуска маршрутизатора центральный процессор вашего
компьютера может быть сильно загружен, для выявления этого факта запустите
«Диспетчер задач» вашей операционной системы и во вкладке «Процессы»
найдите в столбце «Имя образа» dynamips.exe, рис.16.
14
Рис. 16. Отображение загрузки ЦП процессом dynamips
Как видно из рис. 16 запуск только одно маршрутизатора вызвал 50
процентную загрузку, загрузка центрального процессора зависит от количества
ядер на вашем компьютере, чем их больше тем меньшую загрузку бeдет
испытывать ЦП, для одноядерных компьютеров загрузка будет 100 %, для двух
ядерного 50% и так далее. Для снижение загрузки ЦП необходимо щелкнуть,
правой кнопкой мыши по запущенному маршрутизатору и выбрать пункт «Idle
PC», как показано на рис. 17.
а
б
Рис. 17. Выбор значения Idle PC
В появившемся окне выберите число помеченное звездочкой, если такого
числа нет, то выберите любое, и нажмите кнопку «Применить», после чего
посмотрите на загрузку ЦП в диспетчере задач, если загрузка центрального
процессора спала, то нажимайте кнопку «ОК», если нет, то выберете другое
число из списка и снова посмотрите загрузку ЦП. Если ничего не помогло,
перезапустите IDEL PC сначала и повторите процедуру заново. Выбранное
значение IDEL PС будет применено для всех маршрутизаторов такой же серии,
в данном случае для всех маршрутизаторов Cisco 3640.
15
1.4. Создание петлевых интерфейсов
Для создания петлевого интерфейса в ОС Windows XP зайдите ПУСК=>
Панель управления => Установка оборудования, перед вами откроется окно
«Мастер установки оборудования», нажмите «Далее», в следующем окне
отметьте, что «Да, устройство уже подключено» и нажмите «Далее», в
следующем окне опуститесь в самый низ списка устройств, и выберите строку
«Добавление нового устройства», в следующем окне отметьте «Установка
оборудования выбранного из списка в ручную» и нажмите «Далее», в списке
стандартные типы оборудования выберите «сетевые платы» и нажмите
«Далее», затем в колонке изготовитель выберите «Microsoft», а в столбце
«сетевой адаптер» выберите «Адаптер Microsoft замыкания на себя», нажмите
«Далее» и «Готово».
По завершению работы мастера зайдите в «Панель управления» и
запустите «Сетевые подключения» рис. 18. Данный петлевой интерфейс нужен
для подключения операционной системы и других виртуальных машин к
программе GNS3.
Рис. 18. Сетевые подключения
В выделенной строке видно, что петлевой интерфейс был создан. Для
подключения петлевого интерфейса к программе GNS3 в области «Type node»
выберите значок «Host» и перетащите его на рабочую область. Зайдите в
настройки Хоста (Device => настроить) перед вами откроется окно
«Конфигуратор узла» рис. 19.
16
Рис. 19. Конфигуратор узла
В выделенной области удалите все строки с помощью кнопки «Удалить»,
затем из списка выберите петлевой интерфейс, которым является
«подключение по локальной сети 2» рис. 20, и нажмите кнопку «Добавить» и
«Ок».
Рис. 20. Подключение петлевого интерфейса.
После этой операции, у хоста появится интерфейс, который можно будет
затем подключать к маршрутизатору или коммутатору, рис. 21.
Рис. 21. Подключенный петлевой интерфейс
17
2. VirtualBox
Программа VirtualBox в отличие от GNS3 предназначена для
виртуализации серверных и пользовательских операционных систем, таких как:
Windows, Linux, UNIX, FreeBSD и другие, но виртуализировать операционные
системы маршрутизаторов в среде VirtualBox нельзя. Последнюю версию
VirtualBox
можно
скачать
с
официального
сайта
https://www.virtualbox.org/wiki/Downloads.
Инсталляция VirtualBox является тривиальной, достаточно проследовать
инструкциям мастера установки (Setup Wizard), по окончанию установки
программа создаст в сетевом окружении новое сетевое подключение (петлевой
интерфейс VirtualBox Host-Only Network, все сетевые интерфейсы ОС Windows
располагаются в «Пуск=> панель управления=> Сетевые подключения»),
данный интерфейс также можно подключать к GNS3. По завершению
перезагрузите компьютер.
2.1. Работа в среде VirtualBox
Для выполнения лабораторных работ необходимо установить четыре
операционных системы. В качестве операционных систем будем использовать
специальную версию ОС Linux так ее сетевых функций достаточно для
выполнения лабораторных заданий, а требование к системным ресурсам очень
скромны. Данные версии операционных систем доступны с сайта
http://distro.ibiblio.org/tinycorelinux/downloads.html., скачайте версию CorePlus
или TinyCore, которая обладает простым графическим интерфейсом. После
скачивания у вас появится образ CorePlus-current.iso или TinyCore- current.iso.
Для установки операционной системы запустите VirtualBox и нажмите
кнопку создать, как показано на рис. 22.
Рис. 22. Подключение операционной системы
18
После чего перед вами запустится мастер создания виртуальной машины
рис. 23, нажмите кнопку «Вперед».
Рис. 23. Мастер создания виртуальной машины
После чего мастер предложит вам выбрать тип операционной системы и
придумать ей название, рис. 24.
Рис. 24. Выбор типа операционной системы
В строке Имя (обозначена цифрой 1) введите любое название вашей
операционной системы, это название будет отображаться в VirtualBox, в строке
«Операционная система» выберите Linux, в строке «Версия» выберите Other
Linux, после чего нажмите «Вперед». В следующем окне мастер предложит вам
выбрать необходимо количество оперативной памяти, для данного типа
операционной системы достаточным будет 64 Мбайт RAM, рис. 25, нажмите
«Вперед».
19
Рис. 25. Установка размера оперативной памяти
Следующим этапом мастер установки предложит вам выбрать тип
жесткого диска, используйте настройки предложенные мастером по умолчанию
и нажмите «Вперед», рис. 26.
Рис. 26. Создание жесткого диска этап 1
В следующем окне мастер предложит вам указать тип файла, в котором
будет храниться виртуальный жесткий диск. Используйте значение по
умолчанию и нажмите «Вперед», рис. 27.
Рис. 27. Создание жесткого диска этап 2
20
В следующем окне мастер предложит вам выбрать тип виртуального
диска «Динамический» или «Фиксированный», выбираем динамический, так
как в этом случае установленная операционная система будет занимать столько
места, сколько ей на самом деле необходимо, рис. 28.
Рис. 28. Создание жесткого диска этап 3
В следующем окне рис. 29 мастер предложит вам выбрать расположение
и максимально допустимый размер файла, в котором будет храниться
виртуальный жесткий диск, для наших целей достаточно 128 Мбайт, по
умолчанию файл с виртуальным жестким диском сохраняется в
C:\Documents and Settings\Admin\VirtualBox VMs\Linux PC1\Linux PC1.vdi,
нажмите «Вперед».
Рис. 29. Создание жесткого диска этап 4
21
В последнем окне мастер покажет вам итоговое окно о тех параметрах,
которые вы устанавливали входе работы мастера, если они вас устраивают, то
нажмите кнопку «Создать», в результате в окне VirtualBox менеджера появится
созданная вами операционная система, рис. 30.
Рис. 30. Создание виртуальной машины
После того как была создана гостевая операционная система, необходимо
в ее настройках указать путь к файлу образа операционной системы (CorePluscurrent.iso, TinyCore-current.iso), для этого в окне VirtualBox менеджера
щелкните правой кнопкой мыши по виртуальной машине и в контекстном
меню выберите пункт «Свойства», рис. 31. Перед вами откроется окно настроек
виртуальной машины, в данном случае окно называется «Linux PC1 –
Свойства».
а
б
Рис. 31. Свойства виртуальной машины
22
В окне «Linux PC1 – Свойства» в крайнем левом столбце выберите пункт
носители (цифра 1) как показано на рис. 32.
Рис. 32. Подключение образа операционной системы этап 1
Затем в поле «Носители информации» выберите значок в виде компакт
диска (цифра 2), в поле «Атрибуты» нажмите на кнопку «Настроить привод
оптических дисков» (цифра 3), в контекстном меню выберите пункт «Выбрать
образ оптического диска» (цифра 4), затем в открывшемся окне зайдите в
каталог, куда был сохранен образ операционной системы, и нажмите кнопку
открыть, рис. 33.
Рис. 33. Подключение образа операционной системы этап 2
23
После чего в окне «Linux PC1 – Свойства» нажмите кнопку «ОК», теперь
можно запустить виртуальную машины для этого в окне VirtualBox менеджера
выберите операционную системы Linux PC1 и нажмите кнопку «Старт», рис.
34.
Рис. 34. Запуск операционной системы
Перед вами появится два окна. В окне информации будет
предупреждение о том, что курсор мыши будет захвачен, прочитайте эту
информации внимательно, нажмите кнопку «ОК», для предотвращения захвата
необходимо нажать правую кнопку ctrl. В другом окне начнется загрузка
операционной системы, в этом же окне вам предложат выбрать тип загрузки,
выберите «Boot Tiny Core» и нажмите Enter. По окончанию загрузки перед вами
будет окно следующего вида рис. 35.
Рис. 35. Окно операционной системы Tiny Core
24
2.2. Создание петлевых интерфейсов для VirtualBox машин
Поскольку в ходе выполнения лабораторных работ потребуется более
одной виртуальной машины, а, следовательно, и более одного петлевого
интерфейса. Для создания петлевых интерфейсов можно воспользоваться
средствами VirtualBox, для этого в окне VirtualBox менеджера зайдите в меню
Файл=>Свойства, рис. 36.
Рис. 36. Свойства VirtualBox
В открывшемся окне «VirtualBox – Cвойства», рис. 37, выберите пункт
«Сеть», а затем нажмите кнопку добавление сетевого адаптера. В результате
будет создан еще один петлевой интерфейс VirtualBox Host-Only Network #2,
который также будет создан и в сетевых подключениях.
Рис. 37. Создание петлевого интерфейса
25
2.3. Подключение VirtualBox машин к GNS3
После создания виртуальной машины ее необходимо подключить к
GNS3, для этого необходимо связать петлевой интерфейс VirtualBox Host-Only
Network с гостевой операционной системой. Для этого необходимо зайти в
свойства виртуальной машины, как это показано на рисунке 31. Затем выбрать
пункт сеть, а в строке «Тип подключения» выбрать пункт «Виртуальный
адаптер хоста», рис. 38.
Рис. 38. Подключение виртуального адаптера
Затем необходимо проследовать инструкциям, описанным в разделе 1.4,
только в качестве подключаемого интерфейса выбрать VirtualBox Host-Only
Network.
26
3. Сетевой анализатор трафика WireShark
Данная программа предназначена для мониторинга передаваемых данных
через интерфейсы телекоммуникационных устройств, и необходима для
выполнения всех лабораторных работ, последнюю версию программы можно
загрузить
с
официального
сайта
разработчика
http://www.wireshark.org/download.html. Инсталляция WireShark, является
простой, достаточно проследовать инструкциям мастера установки.
Для перехвата пакетов в среде GNS3 необходимо собрать топологию и
выбрать канал связи, на котором будет осуществлен захват передаваемых
пакетов, пример запуска захвата пакетов показан на рис. 39 а. По каналу связи
щелкните правой кнопкой мыши и из контекстного меню выберите «Start
capturing». После чего перед вами появится окно «Захват» рис. 39 б.
а
б
Рис. 39. Захват пакетов этап 1
В окне «Захват» в строке «Пожалуйста, выберите источник» из списка
выберите тот канал и метод инкапсуляции, который вы собираетесь захватить,
после чего нажмите кнопку «Ок». В поле «Захват пакетов» появится имя
устройства с интерфейса, которого будут захватываться пакеты, рис. 40.
Рис. 40. Захват пакетов этап 2
Щелкните правой кнопкой мыши по имени устройства, в открывшемся
контекстном меню выберите пункт «Запустить Wireshark». Перед вами
откроется окно программы WireShark, рис. 41.
27
Рис. 41. Окно программы Wireshark
На рис. 41 цифрами обозначены следующие поля:
1 - строка меню;
2 - панель инструментов;
3 - панель для поиска пакетов удовлетворяющих условию фильтра;
4 - захваченные пакеты;
5 - данное поле отображает информацию выбранного пакета;
6 - в данном поле показан захваченный пакет в шестнадцатеричном и
ASCII представлении.
28
4. Лабораторные работы
4.1. Лабораторная работа № 1 Изучение работы коммутаторов
Ethernet
Цель: Освоить правило формирования таблиц коммутации в
коммутаторах Ethernet и формирование логических топологий с помощью
протокола покрывающего дерева STP.
Оборудование лабораторной работы: программа GNS3, сетевой
анализатор протоколов WireShark.
1. В программе GNS3 составьте следующую топологию, рис. 42.
Рис. 42. Топология сети
Для моделирования коммутаторов воспользуйтесь соответствующим
значков панели "Типы узлов", данный узел оснащен 2 портами маршрутизатора
f0/0 и f0/1, а также 16 портами коммутатора f1/0 - f1/15, коммутаторы
соединяйте между собой только через интерфейсы f1/х. Для работы
коммутатора подключите образ маршрутизатора Cisco IOS с3745. В качестве
хостов выбраны маршрутизаторы 3640, для которых в настройках необходимо
добавить 1 слот NM-1FE-TX.
С помощью параметра IdelPC отрегулируйте загрузку центрального
процессора вашего персонального компьютера для повышения быстродействия.
29
2. Настройте IP адреса для маршрутизаторов на примере R2:
2.1 На маршрутизаторе войдите в привилегированный режим в режим
глобальной конфигурации:
R2>enable
R2#
2. 2 Войдите в режим конфигурации терминала:
R2#configure terminal
R2(config)#
2.3 Введите команду, чтобы войти в режим конфигурации интерфейса
FastEthernet 0/0:
R2(config)#interface f 0/0
R2(config-if)#
2. 4 Выведите на экран все доступные команды режима конфигурации
интерфейса командой «?»:
R2(config-if)#?
2.5 Для включения интерфейса используйте команду «no shutdown» для
отключения интерфейса используется команда shutdown интерфейс.
2.6 Включите все интерфейсы каждого маршрутизатора.
2.7 Введите команду, которая установит IP адрес 192.168.1.1
255.255.255.0 на интерфейс FastEthernet 0/0 и включите интерфейс:
R2(config-if)#ip address 192.168.1.1 255.255.255.0
2.8 Включите интерфейс, введя следующую команду:
R2(config-if)#no shutdown
2.9 Добавьте описание этого интерфейса.
R2(config-if)#description Ethernet interface on R2
Для просмотра описания интерфейса, вернитесь обратно в
привилегированный режим и запустите команду show interface. Вы должны
увидеть описание FastEthernet 0/0:
R2(config-if)#end
R2#show interface F0/0
FastEthernet0/0 is up, line protocol is up
Hardware is AmdFE, address is cc0a.194c.0000 (bia cc0a.194c.0000)
Internet address is 192.168.1.102/24
---- more ---
Обратите внимание на МАС адрес интерфейсов. Повторите пункты с
первого по восьмой для хостов R8, R9, R10, только в качестве IP адресов
возьмите соответственно 192.168.1.100, 192.168.1.101 и 192.168.1.102.
30
2. 10 Проверьте, включены ли порты коммутаторов, для этого зайдите в
привилегиированый режим каждого коммутатора и выполните команду show
running-config, данная команда отобразит содержимое файла конфигурации,
если интерфейс будет выключен, то под строкой с именем этого интерфейса
будет написано shutdown, если слово shutdown отсутствует под названием
интерфейса значит интерфейс активный.
В примере ниже показано, что интерфейс FastEthernet0/1 отключен, а все
остальные включены.
Switch>enablr
Switch#show running-config
Building configuration...
Current configuration : 947 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
interface FastEthernet0/1
shutdown
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
--More—
Проверьте связь между всеми маршрутизаторами с помощью утилиты
ping, для этого зайдите на любой из маршрутизаторов и в привилегированном
режиме введите команду ping [ip адрес], как показано ниже:
R2# ping 192.168.1.100
Появляющиеся восклицательные знаки говорят о доступности
соответствующих устройств, если вместо восклицательных знаком появляется
точка ".", это говорит о недоступности устройства, в этом случае проверьте
правильность введенных вами IP адресов и номера интерфейсов, которыми
соединены между собой все устройства.
31
3. Просмотр таблицы коммутации
После того как вы «пропинговали» все маршрутизаторы, коммутаторы
составили таблицу коммутации, которую можно посмотреть введя в
привилегированном режиме команду:
Sw1#show mac-address-table
После чего будет выведена следующая таблица:
Destination Address Address Type VLAN Destination Port
------------------------ ------------------ -------- -------------------c40c.0b28.0000
Self
1 Vlan1
cc02.194c.0000
Dynamic
1 FastEthernet1/0
c40e.19cc.f100
Dynamic
1 FastEthernet1/2
c40e.19cc.f102
Dynamic
1 FastEthernet1/3
c40e.19cc.0000
Dynamic
1 FastEthernet1/2
cc0b.06a4.0000
Dynamic
1 FastEthernet1/3
Как видно в таблице коммутации в столбце Address Type указаны два
типа записей: Self и Dynamic. Self - указывает на свой МАС адрес, Dynamic
указывает на то, что данная запись была получена при обучении коммутатора.
Помимо этого в таблицу коммутации можно заносить и статические записи с
использованием следующей команды: mac-address-table static [H.H.H {мас
адрес}] interface [номер интерфейса] vlan [номер VLAN].
Пример: необходимо указать коммутаторы, что устройство с МАС
адресом 1111.2222.3333 закреплено за интерфейсом fastEthernet 1/1, и оно
находится в VLAN 1, такая команда будет выглядеть следующим образом:
SW2(config)#mac-address-table static 1111.2222.3333 interface fastethernet 1/1 vlan 1
SW1#show mac-address-table
Destination Address Address Type
-------------------------- ----------------c40c.0b28.0000
Self
cc02.194c.0000
Dynamic
1111.2222.3333
Static
VLAN Destination Port
-------- -------------------1
Vlan1
1
FastEthernet1/0
1
FastEthernet1/1
Обратите внимание на новый тип записи – Static.
4. Просмотр статистики по протоколу STP
В любом из коммутаторов в привилегированном режиме введите
следующую команду:
SW2#show spanning-tree brief
VLAN1
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address c40c.0b28.0000
Cost
19
Port
42 (FastEthernet1/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
32
Bridge ID Priority 32768
Address c40d.0b28.0000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
Interface
Designated
Name
Port ID Prio Cost Sts
Cost
Bridge ID
---------------------------- ---- ----- -------------------------------------FastEthernet1/0
128.41
128 19 FWD
19
32768 c40d.0b28.0000
FastEthernet1/1
128.42
128 19 FWD
0
32768 c40c.0b28.0000
FastEthernet1/2
128.43
128 19 FWD
19
32768 c40d.0b28.0000
FastEthernet1/3
128.44
128 19 FWD
19
32768 c40d.0b28.0000
FastEthernet1/4
128.45
128 19 FWD
19
32768 c40d.0b28.0000
Port ID
----------128.41
128.44
128.43
128.44
128.45
Первое значение Port ID - указывает на идентификатор собственного
порта, последнее значение Port ID в этой таблице указывает идентификатор
порта соседнего коммутатора.
Задание:
Составьте следующую таблицу, как это показано ниже, для каждого
коммутатора.
Таблица 1
Идентификаторы коммутаторов
Имя коммутатора
SW2
MAC адрес
c40c.0b28.0000
Приоритет
32768
....
....
....
Идентификатор порта
FastEthernet1/0
128.41
FastEthernet1/1
128.42
FastEthernet1/2
128.43
FastEthernet1/3
128.44
FastEthernet1/4
128.45
...
По данным из таблицы 1 определите логическую топологию, которую
составил протокол STP, и состояние каждого порта, затем полученные вами
результаты сравните со статистикой протокола STP
5. Изменение идентификаторов протокола STP
В качестве изменяемых идентификаторов в протоколе STP могут
выступать приоритеты мостов и значение стоимости канала связи.
5.1. Изменение приоритетов мостов
Данные для изменения работы протокола STP необходимо вводит в
режиме конфигурации терминала.
spanning-tree vlan [номер Vlan] priority [значение приоритета]
Пример. Необходимо назначить значение приоритета равное 10000
коммутатору SW1 для VLAN 1: SW1(config)#spanning-tree vlan 1 priority
10000.
Введите данную команду на коммутаторе SW1, предварительно запустив
анализатор протокола между SW1 и SW2, обратите внимание на то, что сразу
произойдет отправка сообщения об изменении топологии TCN (topology change
notification), а если коммутатор SW1 был корневым коммутатором, то будет
33
отправлено конфигурационное сообщение с флагом TC=1, который указывает
на факт изменения топологии.
Еще одной командой для изменения приоритетов коммутаторов является
команда: spanning-tree vlan [номер Vlan] root primary diameter [диаметр
сети] hello-time [значение таймера].
Данная команда заставит работать коммутатор как корневой, путем
установки собственного приоритета меньшего чем у текущего корневого.
диаметр сети указывает максимальное количество коммутаторов между двумя
самыми удаленными коммутаторами в сети.
В качестве команды primary можно указать secondary, заставив
коммутатор, установить приоритет больший, чем у корневого, но меньший чем
у всех остальных.
Cконфигурируйте SW3 как secondary, а SW4 как primary, и
проанализируйте вновь полученную топологию протокола STP.
5.2. Изменение идентификаторов портов
В режиме конфигурации порта коммутатора можно изменить приоритет
порта и корневую стоимость, оба параметра влияют на логическую топологию
протокола STP.
Таблица 2
Стоимость маршрутов для портов коммутатора
4 Мбит/с
Стандартная стоимость
порта в «сокращенном
режиме»
250
Стандартная стоимость
порта в «расширенном
режиме»
нет
10 Мбит/с
100
2 000 000
16 Мбит/с
62
нет
45 Мбит/с
39
нет
100 Мбит/с
19
200 000
155 Мбит/с
14
нет
622 Мбит/с
6
нет
1 Гбит/с
4
20 000
10 Гбит/с
2
2 000
100 Гбит/с
нет
200
1000 Гбит/с
нет
20
10 Тбит/с
нет
2
Скорость порта
[Мбит/с]
34
Для изменения корневой стоимости порта необходимо ввести
следующую команду: SW(config-if)#spanning-tree cost [стоимость].
Для коммутатора SW1 и его порта f1/4 измените, стоимость на 200, для
этого введи следующую команду: SW5(config-if)#spanning-tree cost 200.
После чего заново проанализируйте новую логическую топологию.
Следующей командой можно изменить приоритет порта: spanning-tree
port-priority [приоритет].
Для коммутатора SW5 уменьшите значение приоритета порта f1/2 до 80,
введя следующую команду: SW5(config-if)#spanning-tree port-priority 80.
После чего в привилегированном режиме введите команду show
spanning-tree brief, и посмотрите на изменение в идентификаторе порта
(примечание значение поля приоритета должно быть кратно 8).
6. Сохранение настроек
Во время настройки маршрутизаторы/коммутаторы хранят вводимые
команды в оперативной памяти в файле running-config, поэтому после
перезапуска, все данные о настройках будут стерты, с целью предотвращения
потери конфигурации необходимо сохранить введенные команды. Сохранение
идет в энергонезависимую память маршрутизатора/коммутатора в файл startupconfig, с которого маршрутизатор берет первоначальную конфигурацию при
загрузке.
Для сохранения вашей лабораторной работы
Зайдите в меню файл и выберите пункт «Сохранить проект как…», рис.
43.
Рис.43. Сохранение проекта этап 1
Перед вами появится сообщение, рис. 44, нажмите кнопку «ДА».
Рис. 44. Сохранение проекта этап 2
35
Далее появится окно «Save Project As…», рис. 45, где вам необходимо
указать имя проекта и путь к папке будут храниться файлы проекта, также
галочкой должно быть отмечено «Сохранить базовые файлы конфигурации»,
нажмите ОК.
Рис. 45. Сохранение проекта этап 3
Затем в консолях всех маршрутизаторов и коммутаторов введите
следующие команды:
R1#copy running-config startup-config
Destination filename [startup-config]?
// нажмите Enter
В результате данные из файла рабочей конфигурации перезапишутся в
файл стартовой конфигурации. Потом нажмите кнопку «Сохранить» на панели
инструментов, если вы внесли какие-либо изменения в конфигурацию
устройства, не забывайте набирать команду copy running-config startup-config
и нажимать кнопку «Сохранить», автосохранение не предусмотрено! Файлы
конфигурации хранятся в папке проекта в папке «configs», сами файлы имеют
расширения *.cfg и могут быть открыты любым текстовым редактором.
Отчет о лабораторной работе должен содержать:
1. Исходную топологию;
2. Логическую топологию, составленную протоколом STP, с указанием
ролей каждого из портов коммутатора;
3. Таблицу 1 для коммутаторов исходной топологии;
4. Логические топологии, получившиеся в результате изменения
приоритета коммутатора и стоимости порта (две топологии);
5. Приведите три захваченных сообщения с помощью wireshark:
конфигурационное
сообщение,
конфигурационное
сообщение
с
установленными флагами TC и TCA, сообщение об уведомлении изменения
топологии TCN;
36
Контрольные вопросы:
1. Процедура составления таблицы коммутации;
2. Методы коммутации;
3. Структура МАС адреса;
4. Структура кадра Ethernet;
5. В чем разница между повторителем и коммутатором;
6. Объясните, почему нельзя создавать петлевые соединения в сети
Ethernet без поддержки протокола STP;
7. Объясните алгоритм работы метода доступа к среде CSMA/CD;
8. Чем обусловленная максимальная длина коллизионного домена;
9. Какой минимальный размер кадра определен стандартом для
технологии Ethernet;
10. Перечислите скорости, на которых может работать технология
Ethernet;
11. Перечислите виды коллизий в сети Ethernet;
12. Объясните назначение процедуры автосогласования;
13. Какой метод кодирования на физическом уровне используется
технологией Ethernet 10BaseT, 100BaseTX, 100BaseFX, 1000BaseT;
14. Объясните в чем разница методов разводки контактов по стандарту
EIA/TIA 586A и EIA/TIA 586B;
15. Объясните, как выбирается корневой коммутатор;
16. Объясните правила выбора коневых портов;
17. Объясните правила выбора назначенных портов;
18. Какие состояния проходит порт, прежде чем перейти в состояние
перенаправления;
19. Какие основные таймеры определены в протоколе STP;
20. Поясните, какими правилами надо руководствоваться для того чтобы
определить местоположение корневого коммутатора в сети;
21. Объясните алгоритм работы протокола STP при обнаружении
изменения топологии;
22.Поясните назначение флагов конфигурационного сообщения BTDU;
23. Объясните назначение такого устройства как медиаконвертер.
37
4.2. Лабораторная работа №2 Изучение статической маршрутизации
Основная цель: настроить маршрутизаторы 1, 2, 3 с IP адресами, затем
добавить статические маршруты для всех маршрутизаторов.
Промежуточные цели:
1. Установить имя хоста и «поднять» интерфейсы;
2. Назначить IP адрес коммутатору;
3. Настроить статическую маршрутизацию для топологии;
4. Настроить IP адреса и шлюз по умолчанию на ОС Linux;
5. Изучение работы протокола ARP;
6. Изучение протокола ICMP;
7. Создание таблицы хостов;
8. Сохранение конфигурации.
Оборудование: три маршрутизатора С3640 с двумя слотами NM-1FE-TX,
три коммутатора, три персональных компьютера.
В GNS3 соберите топологию, как показано на рис. 46.
Рис. 46. Исследуемая топология
1. Настройте IP адреса для каждого маршрутизатора, как это сделано в
лабораторной работе №1
2. Настройте IP параметры для хостов
В данной работе в качестве операционной системы хостов используются
ОС Linux, для настройки ip параметров каждой linux машины необходимо
ввести команды представленные в табл. 3,4,5.
38
Таблица 3
Настройка qemu1
Команда
Sudo su
Значение
Вход в режим суперпользователя (режим
администратора)
Задать ip адрес и маску хосту
ifconfig eth0 192.168.1.2 netmask
255.255.255.0
route add -net 0/0 gw 192.168.1.1
задать ip-адрес шлюза по умолчанию
(default gateway)
Таблица 4
Настройка qemu2
Команда
sudo su
ifconfig eth0 10.0.0.3 netmask 255.0.0.0
route add -net 0/0 gw 10.0.0.1
Значение
Вход в режим суперпользователя (режим
администратора)
Задать ip адрес и маску хосту
задать ip-адрес шлюза по умолчанию
(default gateway)
Таблица 5
Настройка qemu3
Команда
sudo su
ifconfig eth0 32.16.8.2 netmask 255.255.255.0
route add -net 0/0 gw 32.16.8.1
Значение
Вход в режим суперпользователя (режим
администратора)
Задать ip адрес и маску хосту
задать ip-адрес шлюза по умолчанию
(default gateway)
Эти же команды можно ввести и используя средства графического
интерфейса.
3. Настройте IP параметры для коммутаторов
Особенностью настройки коммутаторов является, то, что ip адрес
присваивается не конкретному интерфейсу, а всему коммутатору, для этого
необходимо зайти в специальный интерфейс Vlan 1, все остальные команды
очевидны. Настройка коммутатора Sw1:
Sw1>ena
Sw1#config t
Sw1(config)#interface vlan 1
Sw1(config-if)#ip address 192.168.1.3 255.255.255.0
Sw1(config-if)#no shutd
Sw1(config-if)#exit
Sw1(config)# ip default-gateway 192.168.1.1
Sw1(config)#^Z
Sw1#ping 192.168.1.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/27/56 ms
39
Настройка коммутатора Sw2:
Sw2>ena
Sw2#config t
Sw2(config)#interface vlan 1
Sw2(config-if)#ip address 10.0.0.4 255.0.0.0
Sw2(config-if)#no shutd
Sw2(config-if)#exit
Sw2(config)# ip default-gateway 10.0.0.1
Sw2(config)#^Z
Sw2#ping 10.0.0.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/27/56 ms
Настройка коммутатора Sw3:
Sw3>ena
Sw3#config t
Sw3(config)#interface vlan 1
Sw3(config-if)#ip address 32.16.8.3 255.255.255.0
Sw3(config-if)#no shutd
Sw3(config-if)#exit
Sw3(config)# ip default-gateway 32.16.8.1
Sw3(config)#^Z
Sw3#ping 32.16.8.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/27/56 ms
После задания IP адресов всем устройствам, используя утилиту ping, и
проверьте доступность устройств. На данном этапе настройки связь на сетевом
уровне будет возможно только в рамках одной IP подсети, это означает, что
связь устройств находящихся в разных подсетях невозможна, так как еще не
настроены таблицы маршрутизации.
4. Настройка удаленного доступа
На каждом маршрутизаторе и коммутаторе настройте удаленный доступ
по протоколу telnet. Для настройки удаленного доступа по telnet необходимо
задать пароль для входа в привилегированный режим, а также пароль для
авторизации по протоколу telnet:
Sw1(config)#enable secret qwerty
Sw1(config)#line vty 0 4
Sw1(config-line)#login
Sw1(config-line)#password asdfg
Sw1(config-line)#exit
//установка зашифрованного пароля "qwerty" для
//привилегированного режима
//установка количества одновременных сессий по
// протоколу telnet в данном случае, с устройством
// можно установить одновременно пять сеансов telnet
//данная команда инструктирует коммутатор о том, что
//нужно запрашивать пароль без имени
// пароль для доступа по протоколу telnet
40
После настроек зайдите на хост и попробуйте ввести команду telnet [ip
адрес устройства]. Пример для хоста qemu1:
root@box:~# telnet 192.168.1.3
Entering character mode
Escape character is ’^]’
User Access Verification
Password
Далее необходимо ввести пароль, указанный для доступа по протоколу
telnet, после чего вы попадете в режим настройки маршрутизатора R1, для
выхода из терминала наберите команду quit.
5. Установка статических маршрутов
Теперь вам нужно установить статические маршруты на каждом
маршрутизаторе для сетей, которые не присоединены непосредственно. Для
сетей, которые не подключены непосредственно к маршрутизатору,
необходимо сконфигурировать статические маршруты. Например, к
маршрутизатору R1 подключены сети 192.168.1.0/24 и 172.16.0.0/16, остальные
сети: 10.0.0.0/8 и 32.16.8.0/24, - не являются непосредственно подключенными к
маршрутизатору, поэтому для этих сетей и необходимо сконфигурировать
статические маршруты, используя команду ip route, в режиме конфигурации
терминала. Создание статических маршрутов для R1:
R1(config)#ip route 10.0.0.0 255.0.0.0 172.16.0.2
R1(config)#ip route 32.16.8.0 255.255.255.0 172.16.0.2
Команду ip route 10.0.0.0 255.0.0.0 172.16.0.2 необходимо понимать
следующим образом: если в ip пакете указан адрес хоста, находящегося в сети
10.0.0.0/8, то такой пакет необходимо переслать следующему устройству, чей ip
адрес равен 172.16.0.2
Теперь попробуйте «пропинговать» с хоста Qemu1 устройства, которые
находятся в сетях 10.0.0.0 и 32.16.8.0, хотя в маршрутизаторе R1 и прописаны
статические маршруты к этим сетям, но ответа от узлов получено не будет, так
как остальные маршрутизатры, не имеют в своих таблицах информации о сети
192.168.1.0/24, куда надо отправить ответный пакет.
Сконфигурируйте остальные маршруты на других маршрутизаторах и
попробуйте "пропинговать" с Qemu1 все остальные устройства:
R2(config)#ip route 192.168.1.0 255.255.255.0 172.16.0.1
R2(config)#ip route 32.16.8.0 255.255.255.0 10.0.0.2
R3(config)#ip route 192.168.1.0 255.255.0.0 10.0.0.1
R3(config)#ip route 172.16.0.0 255.255.0.0 10.0.0.1
41
Для просмотра текущей таблицы
маршрутизаторе наберите команду:
маршрутизации
на
любом
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
32.0.0.0/24 is subnetted, 1 subnets
S
32.16.8.0 [1/0] via 172.16.0.2
C 172.16.0.0/16 is directly connected, FastEthernet1/0
S 10.0.0.0/8 [1/0] via 172.16.0.2
C 192.0.0.0/8 is directly connected, FastEthernet0/0
S - статический маршрут, ведущий к соответствующей сети через (via)
определенный интерфейс, цифры в квадратных скобках указывают
приоритет/стоимость данного маршрута.
После указания статических маршрутов, любые устройства из любой сети
могут взаимодействовать между собой, для проверки этого утверждения
зайдите на любую Vbox/Qemu машину и «пропингуйте» все устройства, а также
проверьте работу удаленного доступа по протоколу telnet.
6. Создание таблицы хостов.
Таблица хостов может быть использована для установления имён для
обычно используемых IP адресов, которые помогают при поиске и устранении
неисправностей. Для создания таблицы хостов используется следующая
команда:
ip host [имя хоста] [ip адрес хоста]
Данная команда связывает имя хоста с его ip адресом, после этой
команды в место ip адресов можно использовать символьные имена.
Пример, создания таблицы хостов на маршрутизаторе R1:
R1(config)#ip host R2 172.16.0.2
R1(config)#ip host R3 10.0.0.2
R1(config)#ip host Sw1 192.168.1.3
R1(config)#ip host Sw2 10.0.0.4
R1(config)#ip host Sw3 32.16.8.1
42
Теперь попробуйте проверить соединение R3 из R1, просто командой
ping R3: R1#ping R3.
Или попробуйте соединиться по протоколу telnet с коммутатором Sw2,
используя команду telnet Sw2:R1#telnet Sw2.
Используйте команду show hosts для проверки, что введенное сохранено
таблице хостов маршрутизатора:R1#show hosts.
7. Работа с таблицами ARP
После разрешения IP адреса в МАС с помощью протокола ARP, данная
пара IP-MAC сохраняется в кэш памяти устройства, которое использовало
протокол ARP, для просмотра таблицы ARP на маршрутизаторах и
коммутаторах необходимо ввести команду в привилегированном режиме: R1#
show arp.
Для отчистки кэша в привилегированном режиме наберите команду: R1#
clear arp-cache.
Для создания статической записи в кэше необходимо зайти в режим
конфигурации терминала и ввести команду: arp [ip адресс] [мас адрес] arpa.
Пример, для создания статической записи, что IP адрес 1.0.0.10
соответствует МАС адресу 1111.2222.3333 необходимо ввести следующую
команду: R1(config)#arp 1.0.0.10 1111.2222.3333 arpa.
Отчет о лабораторной работе должен содержать:
1. Исходную топологию;
2. Листинг команд конфигурации, либо конфигурационные файлы;
3. Захваты следующих пакетов с помощью программы Wireshark: Arp
request, Arp reply, ICMP echo request, ICMP echo reply, пояснение значений всех
полей данных пакетов.
Контрольные вопросы:
1. Структура IP пакета;
2. Процедура фрагментации и сборки IP пакета;
структура ICMP пакетов echo request, echo reply;
3. Структура ARP пакетов request и reply;
4. Объясните структуру таблицы маршрутизации;
5. Объясните процесс маршрутизации между персональными
компьютерами 1 и 3, находящихся в разных сетях, рисунок 42;
6. Назовите, сколько классов IP адресов существует и диапазоны каждого
класса;
7. Каково назначение сетевой маски;
8. Что такое суммирование маршрутов;
43
9. Поясните процедуру разбиения сети на подсети;
10. Какие IP адреса зарезервированы для частного пользования;
11. В чем различие широковещательных и многоадресатных адресов;
12. Поясните, почему хосты, находящиеся в одном широковещательном
домене, должны иметь IP адреса из одной подсети;
13. В чем разница между работой маршрутизатора и коммутатора;
14. Поясните процедуру наложения маски на IP адрес.
4.3. Лабораторная работа №3 Анализ работы техники VLAN
Цель работы: исследовать принцип работы виртуальных локальных сетей
VLAN (Virtual Local Area Network) на основе портов и стандарта IEEE 802.1q.
1. В программе GNS3 постройте следующую топологию:
Рис. 47. Исследуемая сеть
В данном примере в качестве маршрутизатора используется Cisco 3640 c
двумя сетевыми модулями NM-1FE-TX. для моделирования персональных
компьютеров используются QEMU или VirtualBox машины с образом
операционной системы linux-microcore 2.10 или tinyCore.
2. Настройка персональных компьютеров
Настройте персональные компьютеры на работу с соответствующими IP
адресами, используя следующие команды:
1. Вход в режим суперпользователя:
sudo su
2. выставить интерфейсу eth0 ip-адрес и маску подсети:
ifconfig eth[X] [IP_address] netmask [MASK]
3. задать ip-адрес шлюза по умолчанию (default gateway):
route add -net 0/0 gw [IP_Gateway]
44
Пример для компьютера PC1
tc@box:"$ sudo su
root@box:"# ifconfig eth0 1.0.0.2 netmask 255.0.0.0
root@box:"#route add -net 0/0 gw 1.0.0.1
С помощью следующих команд убедитесь в правильности введенной
вами конфигурации:
root@box:"# ifconfig eth0 // для просмотра информации об интерфейсе
root@box:"# route // выводит таблицу маршрутизации
После ввода команды route, в таблице должна существовать следующая
запись:
Destination
Gateway
Genmask
default
1.0.0.1
0.0.0.0
таким же образом настройте оставшиеся персональные компьютеры
3. Настройка коммутаторов
Перед настройкой коммутаторов составьте таблицу, в которой указано
какие номера виртуальных локальных сетей, сопоставлены интерфейсам
коммутаторов.
Таблица 6
Номера VLAN и связанные с ними интерфейсы
Коммутатор
Switch1
Switch2
VLAN2
f1/0, f1/2
f1/0, f1/4, f1/2
VLAN3
f1/1, f1/3
f1/1, f1/3, f1/5
4 Настройка коммутатора Switch1:
Router>ena
Router#vlan database
// команда для входа в режим создания VLAN
Router(vlan)#vlan 2 // создание VLAN 2
VLAN 2 added:
Name: VLAN0002
Router(vlan)#vlan 3 name QWERTY
// создание VLAN 3 с именем
VLAN 3 added:
// QWERTY
Name: QWERTY
Router(vlan)#apply // команда применяющая введенные настройки
APPLY completed.
Router(vlan)#exit
// команда выхода из режима конфигурации VLAN
APPLY completed.
Exiting....
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname SW1
SW1(config)#int f1/0
SW1(config-if)#switchport access vlan 2 // сопоставление порта f1/0 c VLAN 2
SW1(config-if)#int f1/1
SW1(config-if)#switchport access vlan 3 // сопоставление порта f1/1 c VLAN 3
45
SW1(config-if)#int f1/2
SW1(config-if)#switchport access vlan 2 // сопоставление порта f1/2 c VLAN 2
SW1(config-if)#int f1/3
SW1(config-if)#switchport access vlan 3 // сопоставление порта f1/3 c VLAN 3
Для просмотра информаци о VLAN введи команду SW1#show vlan-switch:
VLAN
---1
Name
---------------------default
2
3
1002
1003
1004
1005
VLAN0002
QWERTY
fddi-default
token-ring-default
fddinet-default
trnet-default
Status Ports
--------------------------------------active Fa1/4, Fa1/5, Fa1/6, Fa1/7
Fa1/8, Fa1/9, Fa1/10, Fa1/11
Fa1/12, Fa1/13, Fa1/14, Fa1/15
active
Fa1/0, Fa1/2
active Fa1/1, Fa1/3
active
active
active
active
Обратите внимание на выделенные строки в данной таблице.
Сохраните конфигурацию:
SW1#copy run start
Destination filename [startup-config]? y
Building configuration...
[OK]
SW1#
5. Настройка коммутатора Switch2
Router>ena
Router#vlan database
Router(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
Router(vlan)#vlan 3
VLAN 3 added:
Name: VLAN0003
Router(vlan)#apply
APPLY completed.
Router(vlan)#exit
APPLY completed.
Exiting....
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname SW2
SW2(config)#int f1/1
SW2(config-if)#switchport access vlan 3
SW2(config-if)#int f1/0
SW2(config-if)#switchport access vlan 2
46
SW2(config-if)#int f1/2
SW2(config-if)#switchport access vlan 2
SW2(config-if)#int f1/4
SW2(config-if)#switchport access vlan 2
SW2(config-if)#int f1/3
SW2(config-if)#switchport access vlan 3
SW2(config-if)#int f1/5
SW2(config-if)#switchport access vlan 3
SW2(config-if)#
*Mar 1 00:03:04.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1,
changed state to down
SW2#show vlan-switch brief
VLAN
Name
Status
Ports
-------------------------- --------------------------------------1
default
active Fa1/6, Fa1/7, Fa1/8, Fa1/9
Fa1/10, Fa1/11, Fa1/12, Fa1/13
Fa1/14, Fa1/15
2
VLAN0002
active
Fa1/0, Fa1/2, Fa1/4
3
VLAN0003
active
Fa1/1, Fa1/3, Fa1/5
1002
fddi-default
active
1003
token-ring-default
active
1004
fddinet-default
active
1005
trnet-default
active
После настройки коммутаторов с помощью утилиты Ping проверьте
доступность хостов. Компьютеры одной VLAN должны взаимодействовать
друг с другом, когда компьютеры из разных VLAN взаимодействовать не
будут. Для остановки посылки пакетов нажмите Ctrl+C.
6. Настройка Маршрутизатора
Настройка маршрутизатора тривиальна и состоит
соответствующим интерфейсам правильных IP адресов.
в
задании
Router>ena
Router#config t
Router(config)#int f0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shutd
Router(config-if)#int f1/0
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shutd
После настройки маршрутизатора снова проверьте доступность хостов с
помощью утилиты Ping, если все сделано правильно, то сообщения ICMP эхо
запросы должны доходить до любого интерфейса в любой сети.
47
7.Составьте следующую топологию:
Рис. 48 Исследуемая сеть
8. Настройка компьютеров
Такая же, как и в пункте 1.2.
9. Настройка коммутаторов
Настройка коммутаторов полностью идентична пунктам 1.3.1 и 1.3.2, за
исключением настройки портов которые стали транкинговыми. Для
коммутатора Switch1 это порт f1/0, а для коммутатора Switch2 это порты f1/0 и
f1/2. В режиме конфигурации этих портов необходимо ввести команду:
switchport mode trunk, то есть перевести порты в магистральный режим.
10. Настройка коммутатора Switch1
Router>ena
Router#vlan database
Router(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
Router(vlan)#vlan 3 name QWERTY
Router(vlan)#apply
Router(vlan)#exit
Router#config t
Router(config)#hostname SW1
SW1(config)#int f1/0
SW1(config-if)#switchport mode trunk
SW1(config-if)#int f1/2
SW1(config-if)#switchport access vlan 2
SW1(config-if)#int f1/3
SW1(config-if)#switchport access vlan 3
SW1#show vlan-switch
48
После ввода этой команды обратите внимание что порт, который стал
транкинговым не принадлежит ни одной VLAN.
SW1#show int f1/0 switchport
Name: Fa1/0
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1-3
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Внимательно посмотрите на выведенную информацию, из которой видно
режим работы порта, тип инкапсуляции, и номера VLAN, которые разрешены
на транкинговом порте. Сохраните конфигурацию:
SW1#copy run start
Destination filename [startup-config]? y
Building configuration...
[OK]
SW1#
11. Настройка коммутатора Switch2
Router>ena
Router#vlan database
Router(vlan)#vlan 2
Router(vlan)#vlan 3
Router(vlan)#apply
Router(vlan)#exit
Router#config t
Router(config)#hostname SW2
SW2(config-if)#int f1/0
SW2(config-if)# switchport mode trunk
SW2(config-if)#int f1/2
SW2(config-if)# switchport mode trunk
SW2(config-if)#int f1/4
SW2(config-if)#switchport access vlan 2
SW2(config-if)#int f1/5
SW2(config-if)#switchport access vlan 3
SW2(config-if)#
SW2#show vlan-switch brief
SW1#show int f1/0 switchport
SW1#show mac-address-table //просмотр таблицы коммутации
49
Destination Address
------------------c403.0f04.0000
cc05.1674.0000
cc05.1674.0000
00aa.0078.2600
00aa.0018.4f00
00aa.0026.f900
00aa.009a.9400
Address Type
-----------Self
Dynamic
Dynamic
Dynamic
Dynamic
Dynamic
Dynamic
VLAN
---1
2
3
3
2
3
2
Destination Port
-------------------Vlan1
FastEthernet1/0
FastEthernet1/0
FastEthernet1/3
FastEthernet1/2
FastEthernet1/0
FastEthernet1/0
Обратите внимание на столбец VLAN.
После настройки коммутаторов с помощью утилиты Ping проверьте
доступность хостов. Компьютеры одной VLAN должны взаимодействовать
друг с другом, когда компьютеры из разных VLAN взаимодействовать не
будут.
12. Настройка марщрутизатора
Для работы с VLAN на маршрутизаторе необходимо сконфигурировать
столько подынтерфейсов сколько VLAN существует, затем указать тип
инкапсуляции для каждого подынтерфейса и задать ip адрес каждому
подынтерфейсу маршрутизатора. Перед созданием подынтерфейса необходимо
командой no shutdown включить основной интерфейс.
Например, для создания подынтерфейса 43 на интерфейсе f0/0,
необходимо в режиме конфигурации ввести interface f0/0.43. Номер интерфейса
ни как ни связан с номером VLAN, но для удобства, как правило, номер
подынтерфеса устанавливают равным номеру VLAN. то есть интерфейс f0/0.43
может принадлежать VLAN 50 и на оборот, интерфейс f0/0.50 может
принадлежать VLAN 43, но одновременно интерфейс f0/0.43 не может
принадлежать сразу двум VLAN. Указание типа инкапсуляции: encapsulation
dot1Q [номер VLAN].
Пример конфигурации маршрутизатора
Router>ena
Router#config t
Router(config)#int f0/0
// заходим на основной интерфей
Router(config-if)#no shutdown
// включаем его
Router(config-if)#int f0/0.2
//создаем подъинтерфейс номер 2
Router(config-subif)#encapsulation dot1Q 2
// задаем тип инкапсуляции
// dot1q, а 2 указывает номер
//VLAN, к которой
//принадлежит данный
//подъинтерфейс
Router(config-subif)#ip address 1.0.0.1 255.0.0.0 // устанавливаем ip адрес
Router(config-subif)#exit
// выходим из режима конфигураци
// подъинтерфейса
50
Router(config)#int f0/0.3
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip address 2.0.0.1 255.0.0.0
Router(config-subif)#^Z
Router#show
Router#show ip route
C 1.0.0.0/8 is directly connected, FastEthernet0/0.2
C 2.0.0.0/8 is directly connected, FastEthernet0/0.3
Обратите внимание на номера интерфейсов, к которым подключены сети
1.0.0.0 и 2.0.0.0. После настройки маршрутизатора с помощью утилиты ping
проверьте связь между компьютерами, находящимися в разных VLAN.
13. Анализ форматов кадров
Вовремя или до запуска утилиты Ping между хостами PC1 и РС2
запустите сетевой анализатор протокола WireShark и посмотрите
перехваченные пакеты между коммутаторами и между хостом и коммутатором,
обратите внимание на разные форматы кадров. Точки захвата указаны
стрелками на рис. 49. Для остановки посылки пакетов ICMP нажмите Ctrl+C.
Рис. 49. Места захвата пакетов
На рис. 50 изображено окно сетевого анализатора пакетов, в котором
отображен формат пакета ICMP(столбец Protocol, цифра 3) echo request
(столбец info, цифра 4) отправленного с адреса 1.0.0.2 (столбец source цифра 1),
на адрес 2.0.0.1 (столбец destination, цифра 2). Детализация захваченного пакета
показана в окне ниже, а заголовок Ethernet (цифра 5) и заголовок IP (цифра 6)
выделены.
51
Рис. 50. Пример захвата пакета ICMP echo request
Пакет отправленный с компьютера PC1 до РС2, пройдет следующий
маршрут: РС1(int e0) =1=> (int f1/2)Switch1(int f1/0) =2=> (int f1/0)Switch2 (int
f1/2) =3=> (int f0/0.2) Router (int f0/0.3) =4=> (int f1/2)Switch2 (int f1/0) =5=>
(int f1/0)Switch1(int f1/2) =6=> (int e0)РС2.
Отчет о лабораторной работе должен содержать:
1. Исходную топологию;
2. Листинг команд конфигурации, либо конфигурационные файлы;
3. Захваты следующих пакетов с помощью программы Wireshark: Arp
request, Arp reply, ICMP echo request, ICMP echo reply, пояснить значение всех
полей данных пакетов.
Контрольные вопросы:
Формат метки VLAN согласно стандарту IEEE802.1 q;
Объясните принцип коммутации пакетов с учетом техники VLAN;
Дайте определение виртуальной локальной сети;
В чем разница между транкинговым портом и портом магистральным;
Какое максимальное количество VLAN можно организовать соглаcно
стандарту IEEE 802.1q;
6. Поясните процедуру передачи пакета ICMP echo request от PC1 к РС2.
1.
2.
3.
4.
5.
52
4.4. Лабораторная работа №4 Анализ работы протокол RIP
Основная цель: Настроить маршрутизаторы для работы с протоколом
RIP.
Промежуточные цели:
1. Установить имя хоста и «поднять» интерфейсы.
2. Вывести на экран таблицу маршрутизации.
3. Вывести на экран информацию о протоколе RIP.
4. Познакомиться с правилами приема и передачи анонсов.
5. Настроить аутентификацию.
6. Настроить перераспределение статических маршрутов.
7. Настроить смещение метрик.
8. Настроить суммирование маршрутов.
1. Исследование работы основных механизмов протокола RIP
Соберите следующую топологию рис. 51 в качестве машрутизаторов
использовались модели С3640, в качестве интерфейсов используйте NM-1FETX.
Рис. 51. Исследуемая сеть
Настройте ip адреса на каждом из интерфейсов маршрутизаторов в
соответствии с рисунком 49. Для запуска же протокола RIP достаточно вести
всего два типа команд: router rip – эта команда позволяет войти в режим
конфигурации протокола RIP, network [ip адрес сети] – эта команда указывает
на каких интерфейсах необходимо активировать работу протокола RIP, если IP
53
адрес интерфейса в ходит в диапазон, указанный в аргументе команды network,
то этот интерфейс учувствует в приеме и передачи анонсов протокола RIP.
Настройка каждого маршрутизатора приведена в табл. 7.
Таблица 7
Конфигурация маршрутизаторов
Конфигурация
маршрутизатора R1
R1(config)#int f0/0
R1(config-if)#ip
address 192.168.1.1
255.255.255.0
R1(config-if)#no
shutd
R1(config-if)#int f1/0
R1(config-if)#ip
address 192.168.2.1
255.255.255.0
R1(config-if)#no
shutd
R1(config-if)#int f2/0
R1(config-if)#int f2/0
R1(config-if)#ip
address 192.168.3.1
255.255.255.0
R1(config-if)#no
shutd
R1(config-if)#int f3/0
R1(config-if)#ip
address 192.168.4.1
255.255.255.0
R1(config-if)#no
shutd
R1(config)#router rip
R1(configrouter)#network
192.168.1.0
R1(configrouter)#network
192.168.2.0
R1(configrouter)#network
192.168.3.0
R1(configrouter)#network
192.168.4.0
Конфигурация
маршртизатора R2
R2#config t
R2(config)#int f0/0
R2(config-if)#ip
address 192.168.2.2
255.255.255.0
R2(config-if)#no
shutd
R2(config-if)#int f/0
Interface
FastEthernet0/0,
changed state to up
R2(config-if)#int f1/0
R2(config-if)#ip
address 192.168.5.1
255.255.255.0
R2(config-if)#no
shutd
R2(config-if)#int f2/0
R2(config-if)#
R2(config-if)#ip
address 192.168.6.1
255.255.255.0
R2(config-if)#no
shutd
R2(config)#router rip
R2(configrouter)#network
192.168.2.0
R2(configrouter)#network
192.168.5.0
R2(configrouter)#network
192.168.6.0
Конфигурация
маршртизатора R3
R3#config t
R3(config)#int f0/0
R3(config-if)#ip
address 192.168.7.1
255.255.255.0
R3(config-if)#no
shutd
R3(config-if)#int f1/0
R3(config-if)#ip
address 192.168.4.2
255.255.255.0
R3(config-if)#no shut
R3(config-if)#int f2/0
R3(config-if)#ip
address 192.168.8.1
255.255.255.0
R3(config-if)#no
shutd
R3(config)#router rip
R3(configrouter)#network
192.168.7.0
R3(configrouter)#network
192.168.8.0
R3(configrouter)#network
192.168.4.0
Конфигурация
маршртизатора R4
R4(config)#int f0/0
R4(config-if)#ip
address 192.168.5.2
255.255.255.0
R4(config-if)#no
shutd
R4(config-if)#int f1/0
R4(config-if)#no
shutd
R4(config-if)#ip
address 192.168.9.1
255.255.255.0
R4(config-if)#no
shutd
R4(config-if)#int f2/0
R4(config-if)#ip
address 192.168.8.2
255.255.255.0
R4(config-if)#no shut
R4(config)#router rip
R4(configrouter)#network
192.168.5.0
R4(configrouter)#network
192.168.9.0
R4(configrouter)#network
192.168.8.0
Конфигурация
маршртизатора R5
R5#config t
R5(config)#int f0/0
R5(config-if)#ip
address 192.168.6.2
255.255.255.0
R5(config-if)#no
shutd
R5(config-if)#int f1/0
R5(config-if)#ip
address 192.168.7.2
255.255.255.0
R5(config-if)#no
shutd
R5(config-if)#int f2/0
R5(config-if)#ip
address 192.168.3.2
255.255.255.0
R5(config-if)#no
shutd
R5(config-if)#exit
R5(config)#router rip
R5(configrouter)#network
192.168.6.0
R5(configrouter)#network
192.168.7.0
R5(configrouter)#network
192.168.3.0
Командой show ip route на маршрутизаторе R1 посмотрите таблицу
маршрутизации.
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
54
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 192.168.8.0/24 [120/1] via 192.168.4.2, 00:00:21, FastEthernet3/0
R 192.168.9.0/24 [120/1] via 192.168.2.2, 00:00:16, FastEthernet1/0
C 192.168.4.0/24 is directly connected, FastEthernet3/0
R 192.168.5.0/24 [120/1] via 192.168.2.2, 00:00:16, FastEthernet1/0
R 192.168.6.0/24 [120/1] via 192.168.3.2, 00:00:20, FastEthernet2/0
[120/1] via 192.168.2.2, 00:00:16, FastEthernet1/0
R 192.168.7.0/24 [120/1] via 192.168.4.2, 00:00:21, FastEthernet3/0
[120/1] via 192.168.3.2, 00:00:21, FastEthernet2/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet1/0
C 192.168.3.0/24 is directly connected, FastEthernet2/0
Как видно из таблицы маршрутизации кодом R отмечены маршруты,
полученные маршрутизатором по протоколу RIP. Рассмотрим маршрут к сети
192.168.6.0, как видно запись об этом маршруте занимает две строки, это
означает, что к сети 192.168.6.0 ведут два разных маршрута с одинаковой
метрикой один через адрес 192.168.3.2, другой маршрут идет через интерфейс с
адресом 192.168.2.2.
Утилитой Ping поверьте связность компьютеров между собой.
2. Исследование расширенных функций протокола RIP.
2.1. Соберите и настройте следующую сеть, рис. 52.
Рис. 52 Исследуемая топология
55
Таблица 8
Конфигурации маршрутизаторов
Конфигурация маршрутизатора R1
R1>ena
R1#config t
R1(config)# int f0/0
R1(config-inf)# ip address 10.10.0.1 255.255.0.0
R1(config-inf)#no shutd
R1(config)# int f0/1
R1(config-inf)# ip address 172.16.80.1 255.255.240.0
R1(config-inf)#no shutd
R1(config)# int f1/0
R1(config-inf)# ip address 172.16.64.1 255.255.240.0
R1(config-inf)#no shutd
R1(config)# int f1/1
R1(config-inf)# ip address 172.16.128.1 255.255.224.0
R1(config-inf)#no shutd
R1(config)# int f2/0
R1(config-inf)# ip address 172.16.192.1 255.255.192.0
R1(config-inf)#no shutd
R1(config-inf)#exit
R1(config)# router rip
R1(config-router)#network 172.16.0.0
R1(config-router)#network 10.0.0.0
Конфигурация маршрутизатора R0
R0>ena
R0#config t
R0(config)# int f0/0
R0(config-inf)# ip address 172.16.192.2 255.255.192.0
R0(config-inf)#no shutd
R0(config-inf)#exit
R0(config)# router rip
R0(config-router)#network 172.16.0.0
Проверка таблицы маршрутизации на маршрутизаторе R0:
R0# show ip rout
172.16.0.0/18 is subnetted, 1 subnets
C
172.16.192.0 is directly connected, FastEthernet0/0
R 10.0.0.0/8 [120/1] via 172.16.192.1, 00:00:11, FastEthernet0/0
Обратите внимание на то, что не все сети, подключенные к R1,
отображены в таблице маршрутизации маршрутизатора R0. Данное
обстоятельство объясняется правилом анонсирования маршрутов для
протокола RIPv1. Которое заключается в следующем, что сети не могут
анонсироваться через интерфейс с ip адресом того же класса, но с разной
маской.
В нашем примере маршрутизатор R1 не будет анонсировать сети
172.16.64.0/20, 172.16.80.0 /20 и 172.16.128.0/19 через интерфейс f2/0. Так же
отметим, что к маршрутизатору R1 подключена сеть 10.10.0.0/16, но в
маршрутизаторе R0 эта сеть отображена, как сеть 10.0.0.0 /8. Поэтому запишем
еще одно право передачи анонсов. Если через интерфейс анонсируется сеть и
сетевая часть на основе классов отличается от сетевой части ip адреса
анонсирующего интерфейса, то такая сеть анонсируется как стандартная
сеть на основе классов
Анонс, отправляемый интерфейсом f2/0, протокола RIPv1 показан ниже:
Frame 12: 66 bytes on wire (528 bits), 66 bytes captured (528 bits)
Ethernet II, Src: ca:04:01:b4:00:38 (ca:04:01:b4:00:38), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 172.16.192.1 (172.16.192.1), Dst: 255.255.255.255 (255.255.255.255)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
56
Routing Information Protocol
Command: Response (2)
Version: RIPv1 (1)
IP Address: 10.0.0.0, Metric: 1
Address Family: IP (2)
IP Address: 10.0.0.0 (10.0.0.0)
Metric: 1
Обратите внимание, что в анонсе находится всего лишь одна сеть:
10.0.0.0
2.2. Измените маску интерфейса f2/0, рис. 53.
Рис. 53. Исследуемая сеть
Такая настройка противоречит правилам адресации и может привести к
появлению маршрутных циклов, но в некоторых случаях данная конфигурация
может оказаться полезной. Изменить маску интерфейса можно следующим
образом:
R1(config)#int f2/0
R1(config-if)#no ip address 172.16.192.1 255.255.192.0
R1(config-if)#ip address 172.16.192.1 255.255.240.0
В данном примере используется команда no. После смены маски,
посмотрите на таблицу маршрутизации на маршрутизаторе R0:
C
R
R
R
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
172.16.192.0/18 is directly connected, FastEthernet0/0
172.16.80.0/32 [120/1] via 172.16.192.1, 00:00:24, FastEthernet0/0
172.16.64.0/18 [120/1] via 172.16.192.1, 00:00:24, FastEthernet0/0
10.0.0.0/8 [120/1] via 172.16.192.1, 00:00:24, FastEthernet0/0
57
Обратите внимание на то, что в таблице появились новые маршрутные
записи, это вытекает из первого правила, которое разрешает анонсировать
номера сетей только в том случае, если совпадают и сетевые части ip
адресов и их маски. Посмотрим на трассировку сетевого монитора, который
захватывает пакеты через порт f2/0:
Ethernet II, Src: ca:04:01:b4:00:38 (ca:04:01:b4:00:38), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 172.16.192.1 (172.16.192.1), Dst: 255.255.255.255 (255.255.255.255)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Command: Response (2)
Version: RIPv1 (1)
IP Address: 10.0.0.0, Metric: 1
Address Family: IP (2)
IP Address: 10.0.0.0 (10.0.0.0)
Metric: 1
IP Address: 172.16.64.0, Metric: 1
Address Family: IP (2)
IP Address: 172.16.64.0 (172.16.64.0)
Metric: 1
IP Address: 172.16.80.0, Metric: 1
Address Family: IP (2)
IP Address: 172.16.80.0 (172.16.80.0)
Metric: 1
Давайте проанализируем получившуюся таблицу маршрутизации на
маршрутизаторе R0. Маршрутизатор R0 получил на интерфейс анонсы только о
трех сетях, как это видно из трассировки, в данном анонсе отсутствует
информация о сети 172.16.128.0/19, так как эта сеть имеет маску отличную от
интерфейса, который её анонсирует. В таблице маршрутизации есть запись о
сети 172.16.80.0/32. Обратите внимание, что к этой сети применена маска 32
(255.255.255.255), такая ситуация возникает в том случае когда на интерфейс
поступает такой сетевой адрес у которого по отношению к принимаемому
интерфейсу часть бит адреса сети установлена в части адреса хоста. Сеть
анонсируемая маршрутизатором R1:
172.16.80.0
10101100. 0001000 . 01010000. 0000000
Рис. 54. Анонсируемые сети
Красными цифрами указаны, биты, относящиеся к адресу сети, зелеными
биты хоста. Распишем адрес приемного интерфейса.
172.16.192.2 /18
10101100. 0001000. 11000000. 0000010
Рис. 55. Биты приемного интерфейса
58
Сравним адрес принимаемого интерфейса с адресом сети, принятом в
анонсе, между собой:
10101100. 0001000. 01 01 0000. 0000000
10101100. 0001000. 11 00 0000. 0000010
Рис. 56. Сравнение приемного интерфейса с адресом сети
Как видно часть битов в адресе хоста у анонсируемой сети с точки зрения
приемного интерфейса установлена в 1. А если сравнить сеть 172.16.64.0 /20 и
ip адрес приемного интерфейса, то мы обнаружим что в адресе хоста нет битов
установленных в 1, в таком случае к сети применяется маска, установленная
для приемного интерфейса.
Сформулируем правило приема. Если на интерфейс приходит анонс о
сети и сетевая часть на основе классов у них совпадает, то к данной сети
применяется маска интерфейса, если в части адреса хоста после
наложении маски интерфейса нет бит установленных в единицу, если хотя
бы один бит в части адреса установлен в единицу, то к адресу применяется
маска 32.
Для проверки этого правила изменим маску интерфейса f0/0 на
маршрутизаторе R0:
R0(config)#int f0/0
R0(config-if)#no ip address 172.16.192.2 255.255.192.0
R0(config-if)#ip address 172.16.192.2 255.255.240.0
После чего посмотрим таблицу маршрутизации:
172.16.0.0/20 is subnetted, 3 subnets
C
172.16.192.0 is directly connected, FastEthernet0/0
R
172.16.80.0 [120/1] via 172.16.192.1, 00:00:26, FastEthernet0/0
R
172.16.64.0 [120/1] via 172.16.192.1, 00:00:26, FastEthernet0/0
R 10.0.0.0/8 [120/1] via 172.16.192.1, 00:00:26, FastEthernet0/0
Как видно из данной таблице существуют три подсети 172.16.0.0 с
маской 20. Обратите внимание на то, что теперь все сети имеют правильные
маски, отсутствует только сеть 172.16.128.0 /19, так как данная сеть имеет
маску отличную от интерфейса f2/0 маршрутизатора R1.
2.3. Пассивные интерфейсы
Если интерфейс необходимо сделать пассивным, то необходимо ввести
команду passive interface [имя интерфейса]. Например для маршрутизатора R1
сделаем интерфейс f2/0 пассивным: R1(config-router)#passive-interface
fastEthernet 2/0.
Если теперь подключить анализатор протоколов к этому интерфейсу, то
через него не будут передаваться анонсы о подключенных и известных сетях
маршрутизатора R1, а по истечению таймера удаления таблица маршрутизации
59
маршрутизатора R0 будет полностью удалена. Примерно через три минуты
посмотрите на таблицу маршрутизации R0:
172.16.0.0/20 is subnetted, 3 subnets
172.16.192.0 is directly connected, FastEthernet0/0
172.16.80.0/20 is possibly down,
routing via 172.16.192.1, FastEthernet0/0
R
172.16.64.0/20 is possibly down,
routing via 172.16.192.1, FastEthernet0/0
R 10.0.0.0/8 is possibly down, routing via 172.16.192.1, FastEthernet0/0
C
R
Отмена режима пассивного интерфейса осуществляется той же командой
только с приставкой no: R1(config-router)#no passive-interface fastEthernet
2/0.
2.4. Настройка одноадресных обновлений
Для того чтобы анонсы передавались не на широковещательный ip адрес,
а на одноадресный, необходимо ввести команду neighbor [ip address].
В следующем примере маршрутизатор R1 будет посылать анонсы
маршрутизатору R0 на одноадресный адрес интерфейса f0/0.
R1(config)#router rip
R1(config-router)#neighbor 172.16.192.2
При этом анализ захваченных пакетов покажет, что маршрутизатор R1
стал отправлять не только анонсы протокола RIP на одноадресный адрес, но
также продолжает отправлять эти же анонсы на широковещательный адрес:
Ethernet II, Src: ca:04:01:b4:00:38 (ca:04:01:b4:00:38), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 172.16.192.1 (172.16.192.1), Dst: 255.255.255.255 (255.255.255.255)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Ethernet II, Src: ca:04:01:b4:00:38 (ca:04:01:b4:00:38), Dst: cc:03:0c:0c:00:00 (cc:03:0c:0c:00:00)
Internet Protocol Version 4, Src: 172.16.192.1 (172.16.192.1), Dst: 172.16.192.2 (172.16.192.2)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Для того чтобы маршрутизтор R1 отправлял пакеты только на
одноадресный адрес, необхоимо объявить анонсирующий интерфейс
маршрутизатора R1 пассивным.
2.5. Увеличение или уменьшение метрики
Изменение метрики маршрута необходимо в том случае, когда требуется
изменить маршрут следования трафика. Такие ситуации возникают, когда
наикратчайший маршрут обладает меньшей пропускной способностью, а
альтернативный маршрут с большей метрикой обладает большей пропускной
способностью.
60
Изменение метрики можно сделать двумя путями, либо сделать так
чтобы анонсирующий маршрутизатор увеличил/уменьшил метрику, либо
принимающий маршрутизатор также увеличил/уменьшил метрику.
Рассмотрим следующий пример, когда маршрутизатор R1 увеличит
метрику на 5 для сетей, которые анонсируются через интерфейс f2/0: R1(configrouter)#offset-list qwerty out 5 f2/0.
Команда offset-list указывает на то, что необходимо изменить метрику.
Параметр qwerty – это имя списка доступа, поскольку списка доступа у нас нет,
то слово qwerty нужно для соблюдения синтаксиса команды и не несет ни каких
функций, в место него можно написать что угодно. out – указывает на то, что
изменению будет подвержена исходящая метрика. Цифра 5 указывает,
насколько изменится метрика. F2/0 – интерфейс, который будет увеличивать
метрику.
Теперь посмотрим на таблицу маршрутизации маршрутизатора R0:
C
R
R
R
172.16.0.0/20 is subnetted, 3 subnets
172.16.192.0 is directly connected, FastEthernet0/0
172.16.80.0 [120/6] via 172.16.192.1, 00:00:01, FastEthernet0/0
172.16.64.0 [120/6] via 172.16.192.1, 00:00:01, FastEthernet0/0
10.0.0.0/8 [120/6] via 172.16.192.1, 00:00:01, FastEthernet0/0
Обратите внимание, что новое значение метрики стало 6=5+1, для всех
сетей, которые анонсировались маршрутизатором R1. Ниже показан анонс,
отправляемый маршрутизатором R1:
Ethernet II, Src: ca:04:01:b4:00:38 (ca:04:01:b4:00:38), Dst: cc:03:0c:0c:00:00 (cc:03:0c:0c:00:00)
Internet Protocol Version 4, Src: 172.16.192.1 (172.16.192.1), Dst: 172.16.192.2 (172.16.192.2)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Command: Response (2)
Version: RIPv1 (1)
IP Address: 10.0.0.0, Metric: 6
Address Family: IP (2)
IP Address: 10.0.0.0 (10.0.0.0)
Metric: 6
IP Address: 172.16.64.0, Metric: 6
Address Family: IP (2)
IP Address: 172.16.64.0 (172.16.64.0)
Metric: 6
IP Address: 172.16.80.0, Metric: 6
Address Family: IP (2)
IP Address: 172.16.80.0 (172.16.80.0)
Metric: 6
Теперь отменим присвоенное смещение метрики на маршрутизаторе R1 и
сделаем так, чтобы маршрутизатор R0 сам увеличивал метрику до 6 в
полученных анонсах. Отмена смещения метрики на маршрутизаторе R1
задается с помощью команды no:
R1(config-router)#no offset-list qwerty out 5 f 2/0
На маршрутизаторе R0 увеличим метрику:
R0(config-router)#offset-list qwerty in 5 f0/0
61
Хотя таблица маршрутизации и не изменилась на маршрутизаторе R0:
C
R
R
R
172.16.0.0/20 is subnetted, 3 subnets
172.16.192.0 is directly connected, FastEthernet0/0
172.16.80.0 [120/6] via 172.16.192.1, 00:00:01, FastEthernet0/0
172.16.64.0 [120/6] via 172.16.192.1, 00:00:01, FastEthernet0/0
10.0.0.0/8 [120/6] via 172.16.192.1, 00:00:01, FastEthernet0/0
Но анонсы, отправляемые маршрутизатором R1, содержат значение
метрик равные единице:
Ethernet II, Src: ca:04:01:b4:00:38 (ca:04:01:b4:00:38), Dst: cc:03:0c:0c:00:00 (cc:03:0c:0c:00:00)
Internet Protocol Version 4, Src: 172.16.192.1 (172.16.192.1), Dst: 172.16.192.2 (172.16.192.2)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Command: Response (2)
Version: RIPv1 (1)
IP Address: 10.0.0.0, Metric: 1
Address Family: IP (2)
IP Address: 10.0.0.0 (10.0.0.0)
Metric: 1
IP Address: 172.16.64.0, Metric: 1
Address Family: IP (2)
IP Address: 172.16.64.0 (172.16.64.0)
Metric: 1
IP Address: 172.16.80.0, Metric: 1
Address Family: IP (2)
IP Address: 172.16.80.0 (172.16.80.0)
Metric: 1
2.6. Перераспределение статических маршрутов в протокол RIP
Перераспределение маршрутов позволяет анонсировать маршрутизаторам
статические записи в анонсах протокола RIP. Например, в маршрутизаторе R1
введем статический маршрут к гипотетической сети 192.168.2.0 /24, которая
доступна через какой-то маршрутизатор 10.10.0.10:
R1(config)#ip route 192.168.2.0 255.255.255.0 10.10.0.10
Далее в режиме конфигурирования протокола RIP перераспределим этот
маршрут в протокол RIP:
R1(config)#router rip
R1(config-router)#redistribute static metric 10
Команда redistribute static перераспределяет статические маршруты в
протокол RIP, параметр metric 10 задает значение метрики, с которым
перераспределяется данный маршрут. После введения данной команды на R1
посмотрим таблицу маршрутизации на R0
C
R
R
R
R
172.16.0.0/20 is subnetted, 3 subnets
172.16.192.0 is directly connected, FastEthernet0/0
172.16.80.0 [120/1] via 172.16.192.1, 00:00:25, FastEthernet0/0
172.16.64.0 [120/1] via 172.16.192.1, 00:00:25, FastEthernet0/0
10.0.0.0/8 [120/1] via 172.16.192.1, 00:00:25, FastEthernet0/0
192.168.2.0/24 [120/10] via 172.16.192.1, 00:00:25, FastEthernet0/0
62
Как видно в маршрутной записи появилась новая запись о сети
192.168.2.0.
2.7. Аутентификация анонсов протокола RIP
Данная функция доступна только для протокола RIP v2. Чтобы перевести
маршрутизаторы в режим работы c протоколом RIP v2 необходимо в режиме
конфигурации протокола RIP задать команду version 2:
R0(config-router)#version 2
R1(config-router)#version 2
Аутентификация необходимо для того чтобы проверить подлинность
маршрутизатора, который отправляет данный анонс. Для этих целей
необходимо указать пароль на каждом из маршрутизаторов, в качестве пароля
возьмем слово secret.
Настройка параметров аутентификации требует ввода нескольких команд,
которые приведены ниже для каждого маршрутизатора.
Таблица 9
Конфигурация маршрутизаторов
Конфигурация маршрутизатора R0
Конфигурация маршрутизатора R1
R0(config)#key chain test
R0(config-keychain)#key 1
R0(config-keychain-key)#key-string secret
R0(config-keychain-key)#exit
R0(config-keychain)#exit
R0(config)#int f0/0
R0(config-if)#ip rip authentication key-chain test
R1(config)#key chain test
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string secret
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#int f2/0
R1(config-if)#ip rip authentication key-chain test
Анализ перехваченных пакетов показывает, что такой способ
аутентификации подразумевает передачу паролей в не зашифрованном виде:
Ethernet II, Src: ca:04:01:b4:00:38 (ca:04:01:b4:00:38), Dst: cc:03:0c:0c:00:00 (cc:03:0c:0c:00:00)
Internet Protocol Version 4, Src: 172.16.192.1 (172.16.192.1), Dst: 172.16.192.2 (172.16.192.2)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Command: Response (2)
Version: RIPv2 (2)
Authentication: Simple Password
Authentication type: Simple Password (2)
Password: secret
IP Address: 10.0.0.0, Metric: 1
IP Address: 172.16.64.0, Metric: 1
IP Address: 172.16.80.0, Metric: 1
IP Address: 172.16.128.0, Metric: 1
IP Address: 192.168.2.0, Metric: 10
63
В Cisco IOS предусмотрена возможность передачи хэша, вычисленного
по алгоритму MD5, а не самого пароля, для этого необходимо в режиме
конфигурации интерфейса сменить тип аутентификации как показано ниже:
R0(config-if)#ip rip authentication mode md5
R1(config-if)#ip rip authentication mode md5
Ethernet II, Src: ca:04:01:b4:00:38 (ca:04:01:b4:00:38), Dst: cc:03:0c:0c:00:00 (cc:03:0c:0c:00:00)
Internet Protocol Version 4, Src: 172.16.192.1 (172.16.192.1), Dst: 172.16.192.2 (172.16.192.2)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Command: Response (2)
Version: RIPv2 (2)
Authentication: Keyed Message Digest
Authentication type: Keyed Message Digest (3)
Digest Offset: 124
Key ID: 1
Auth Data Len: 20
Seq num: 2
Zero Padding
Authentication Data Trailer
Authentication Data: 86 58 5f 3d dd 86 af a7 41 de 4d 3b ef 7a 74 3b
IP Address: 10.0.0.0, Metric: 1
IP Address: 172.16.64.0, Metric: 1
IP Address: 172.16.80.0, Metric: 1
IP Address: 172.16.128.0, Metric: 1
IP Address: 192.168.2.0, Metric: 10
2.8. Суммирование маршрутов
Составьте топологию, как показано на рис. 57.
Рис. 57. Исследуемая сеть
64
При такой топологии применение средств маршрутизации протокола RIP
v1 приведет к некорректной работе сети, так как согласно правилу передачи
анонсов, каждый из маршрутизаторов будет анонсировать суммарный маршрут
к сети 172.16.0.0, это в свою очередь означает, что каждый маршрутизатор
должен иметь две маршрутные записи к сетям 172.16.0.0. Рассмотрим этот
случай на примере маршрутизатора R2. Ниже приведем первоначальную
конфигурацию каждого маршрутизатора в табл. 10.
Таблица 10
Первоначальная конфигурация
Конфигурация R1
Конфигурация R2
Конфигурация R3
R1#config t
R1(config)#int f 0/0
R1(config-if)#ip
address
172.16.64.1 255.255.255.0
R1(config-if)#no shutd
R1(config-if)#int f 1/0
R1(config-if)#ip
address
172.16.65.1 255.255.255.0
R1(config-if)#int f 2/0
R1(config-if)#ip address 10.0.0.1
255.0.0.0
R1(config-if)#no shutd
R1(config-if)#router rip
R1(config-router)#network
172.16.0.0
R1(config-router)#network
10.0.0.0
R2#config t
R2(config)#int f0/0
R2(config-if)#ip address 172.16.66.1
255.255.255.0
R2(config-if)#no shutd
R2(config-if)#int f1/0
R2(config-if)#ip address 172.16.67.1
255.255.255.0
R2(config-if)#no shutd
R2(config-if)#int f2/0
R2(config-if)#ip address 10.0.0.2
255.0.0.0
R2(config-if)#no shutd
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#net
R2(config-router)#network
172.16.0.0
R2(config-router)#network 10.0.0.0
R3#config t
R3(config)#int f0/0
R3(config-if)#ip address 172.16.69.1
255.255.255.0
R3(config-if)#no shutd
R3(config-if)#int f1/0
R3(config-if)#ip address 172.16.68.1
255.255.255.0
R3(config-if)#no shutd
R3(config-if)#int f2/0
FastEthernet1/0, changed state to up
R3(config-if)#ip address 10.0.0.3
255.0.0.0
R3(config-if)#no shutd
R3(config-if)#router rip
R3(config-router)#network
172.16.0.0
R3(config-router)#network 10.0.0.0
После конфигурирования маршрутизаторов стандартным образом на R2
будет следующая маршрутная запись:
R2#show ip route
172.16.0.0/24 is subnetted, 2 subnets
C
172.16.66.0 is directly connected, FastEthernet0/0
C
172.16.67.0 is directly connected, FastEthernet1/0
C 10.0.0.0/8 is directly connected, FastEthernet2/0
Как видно из маршрутной записи маршрутизатор R2 не занес себе в
таблицу информацию о сетях 172.16.0.0, которая ему приходила от
маршрутизатора R1 и R2, такая ситуация является исключением из правил
передачи и приема анонсов реализованная в оборудовании Cisco. Для того
чтобы информация о сетях 172.16.64.0, 172.16.65.0, 172.16.68.0, 172.16.69.0
появилась в таблице маршрутизации маршрутизатора R2 необходимо перевести
маршрутизаторы в режим работы протокола RIPv2, как это было сделано в
разделе 2.7, так как протоколом RIPv2 предусмотрена передача не только
номеров сетей, но и их масок. После ввода команда version 2, на всех
маршрутизаторах, снова проверим таблицу маршрутизации R2:
R2#show ip route
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
65
R
C
C
C
172.16.0.0/16 [120/1] via 10.0.0.3, 00:00:08, FastEthernet2/0
[120/1] via 10.0.0.1, 00:00:02, FastEthernet2/0
172.16.66.0/24 is directly connected, FastEthernet0/0
172.16.67.0/24 is directly connected, FastEthernet1/0
10.0.0.0/8 is directly connected, FastEthernet2/0
Как видно в таблицы маршрутизации появились две записи касательно
сети 172.16.0.0, из которых следует, что сеть 172.16.0.0 доступна через 10.0.0.1
и 10.0.0.3, это связано с тем, что маршрутизаторы в анонсах протокола RIPv2
вставляют информацию не о подсетях 172.16.64.0, 172.16.65.0, 172.16.68.0,
172.16.69.0, а о суммарной записи на основе классов, то есть маршрутизатор
автоматически суммирует диапазоны IP адресов, если маска сети не является
стандартной. Анонсы, получаемые, маршрутизатором R2 показаны ниже:
Ethernet II, Src: cc:00:0f:c8:00:20 (cc:00:0f:c8:00:20), Dst: IPv4mcast_00:00:09 (01:00:5e:00:00:09)
Internet Protocol Version 4, Src: 10.0.0.1 (10.0.0.1), Dst: 224.0.0.9 (224.0.0.9)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Command: Response (2)
Version: RIPv2 (2)
IP Address: 172.16.0.0, Metric: 1
Address Family: IP (2)
Route Tag: 0
IP Address: 172.16.0.0 (172.16.0.0)
Netmask: 255.255.0.0 (255.255.0.0)
Next Hop: 0.0.0.0 (0.0.0.0)
Metric: 1
Ethernet II, Src: cc:02:0f:c8:00:20 (cc:02:0f:c8:00:20), Dst: IPv4mcast_00:00:09 (01:00:5e:00:00:09)
Internet Protocol Version 4, Src: 10.0.0.3 (10.0.0.3), Dst: 224.0.0.9 (224.0.0.9)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Command: Response (2)
Version: RIPv2 (2)
IP Address: 172.16.0.0, Metric: 1
Address Family: IP (2)
Route Tag: 0
IP Address: 172.16.0.0 (172.16.0.0)
Netmask: 255.255.0.0 (255.255.0.0)
Next Hop: 0.0.0.0 (0.0.0.0)
Metric: 1
Как видно из анонсов два маршрутизатора посылают абсолютно
одинаковые анонсы. Обратите внимание на то, что в маршрутной записи
имеется два маршрутка к сети 172.16.0.0 одна через 10.0.0.1 а другая через
10.0.0.2. В такой ситуации маршрутизатор R2 при отправке пакетов в сеть
172.16.64.0/24, будет отправлять пакеты поочередно то в маршрутизатор R1 то
в R2.Это означает что только половина пакетов достигнет адресатов. Для
предотвращения такой ситуации необходимо запустить протокол RIP v2 и
отменить автосуммирование командой no auto-summary, так как протокол RIP
v2, иначе маршрутные записи не изменятся:
R1(config-router)#no auto-summary
R2(config-router)#no auto-summary
R3(config-router)#no auto-summary
66
Снова посмотрим таблицу маршрутизации на маршрутизаторе R2.
R2#show ip route
R
172.16.68.0/24 [120/1] via 10.0.0.3, 00:00:19, FastEthernet2/0
R
172.16.69.0/24 [120/1] via 10.0.0.3, 00:00:19, FastEthernet2/0
R
172.16.64.0/24 [120/1] via 10.0.0.1, 00:00:03, FastEthernet2/0
R
172.16.65.0/24 [120/1] via 10.0.0.1, 00:00:24, FastEthernet2/0
C
172.16.66.0/24 is directly connected, FastEthernet0/0
C
172.16.67.0/24 is directly connected, FastEthernet1/0
C 10.0.0.0/8 is directly connected, FastEthernet2/0
Для данного примера отмена автосуммирования вполне приемлема, так
как количество сетей небольшое, но в крупных сетях, это может привести к
резкому росту таблиц маршрутизации, что замедлит работу маршрутизаторов.
В таких случаях необходимо вручную суммировать маршруты. В данном
примере суммарный маршрут к сетям 172.16.64.0/24 и 172.16.65.0/24 можно
записать как один единственный 172.16.64.0/23.
Аналогично суммарный маршрут для сетей: 172.16.66.0/24 и
172.16.67.0/24 – 172.16.66.0./23, 172.16.68.0/24 и 172.16.69.0/24 – 172.16.68.0./23
Для настройки ручного суммирования необходимо ввести следующие
команды в режиме конфигурации интерфейса, например, для маршрутизатора
R1 эту команду необходимо вводит на интерфейсе f0/0:
R1(config-if)#ip summary-address rip 172.16.64.0 255.255.254.0
Для R2 на интерфейсе f0/0:
R2(config-if)#ip summary-address rip 172.16.66.0 255.255.254.0
Для R3 на интерфейсе f0/0:
R3(config-if)#ip summary-address rip 172.16.68.0 255.255.254.0
После вода команды суммирования сделает захват пакета посланного
маршрутизатором R1:
Ethernet II, Src: ca:00:0c:20:00:00 (ca:00:0c:20:00:00), Dst: IPv4mcast_00:00:09 (01:00:5e:00:00:09)
Internet Protocol Version 4, Src: 10.0.0.1 (10.0.0.1), Dst: 224.0.0.9 (224.0.0.9)
User Datagram Protocol, Src Port: router (520), Dst Port: router (520)
Routing Information Protocol
Command: Response (2)
Version: RIPv2 (2)
IP Address: 172.16.64.0, Metric: 1
Address Family: IP (2)
Route Tag: 0
IP Address: 172.16.64.0 (172.16.64.0)
Netmask: 255.255.254.0 (255.255.254.0)
Next Hop: 0.0.0.0 (0.0.0.0)
Metric: 1
67
Из данного сообщения видно, что теперь маршрутизатор отправляет
анонс только об одной сети 172.16.64.0 с маской 255.255.254.0, что и
требовалось сделать. После чего посмотрим на вновь получившиеся таблицы
маршрутизации на R2.
R2#show ip route
R
172.16.68.0/23 [120/1] via 10.0.0.3, 00:00:19, FastEthernet2/0
R
172.16.64.0/23 [120/1] via 10.0.0.1, 00:00:03, FastEthernet2/0
C
172.16.66.0/24 is directly connected, FastEthernet0/0
C
172.16.67.0/24 is directly connected, FastEthernet1/0
C 10.0.0.0/8 is directly connected, FastEthernet2/0
Обратите внимание на маску в таблице маршрутизации.
В случае неисправности в протоколе RIP необходимо запустить команду
debug ip rip в привилегированном режиме, данная команда позволит
отслеживать события в работе протокола RIP, запустите эту команду на любом
маршрутизаторе и пронаблюдайте за выводимыми системными сообщениями в
течение 2 минут. Для отключения выводимых системных сообщений о
действии протокола RIP наберите команду no debug ip rip.
Отчет о лабораторной работе должен содержать:
1. Все исследуемые топологии;
2. Листинг команд конфигурации, либо конфигурационные файлы для
каждой исследуемой топологии
3. Захваты пакетов RIPv1 и RIPv2, для всех рассматриваемых случаев.
Контрольные вопросы:
1. Поясните работу таймеров протокола RIP;
2. Расскажите правила приема и передачи анонсов;
3. Что такое метод расщепления горизонта;
4. Объясните причины возможных появлений петель маршрутизации;
5. В чем отличие протоколов внутреннего шлюза от протоколов внешнего
шлюза;
6. Какие сообщения определены в протоколе RIP;
7. Какие основные различия между протоколами RIPv1 и RIPv2;
8. Что такое пассивные интерфейсы;
9. В каких ситуациях необходимо изменять значение метрик;
10. Для чего нужны пассивные интерфейсы;
11. В каких ситуациях необходимо отключать автосуммироание, а в каких
можно оставить;
12. Что такое активизированные обновления;
13. Поясните алгоритм составления таблиц маршрутизации по протоколу
RIP.
68
Библиографический список
Основная литература:
1. Электронный каталог Documentation [Электронный ресурс]. - Режим
доступа: http://www.gns3.net/documentation/ . – Загл. с экрана.
2. Электронный каталог VirtualBox Documentation [Электронный ресурс].
- Режим доступа: https://www.virtualbox.org/wiki/Documentation . – Загл. с
экрана.
3. Электронный каталог Wireshark User's Guide for Wireshark 1.9
[Электронный
ресурс].
–
Режим
доступа:
http://www.wireshark.org/docs/wsug_html_chunked/ . – Загл. с экрана.
4. Одом, Уэнделл. Официальное руководство Cisco по подготовке к
сертификационным экзаменам CCNA ICND1, 2-е изд.: Пер. с англ. – М.: . «И.Д.
Вильямс», 2010. – 672 с.: ил. – Парал. тит. англ.
5. Одом, Уэнделл. Официальное руководство Cisco по подготовке к
сертификационным экзаменам CCNA ICND2, 2-е изд.: Пер. с англ. – М.: . «И.Д.
Вильямс», 2011. – 736 с.: ил. – Парал. тит. англ.
Дополнительная литература:
1. Брайан Хилл. Полный справочник по Cisco.: Пер. с англ. – М.:
Издательский дом «Вильямс», 2004. – 1079 с.: ил. – Парал. тит. англ.
2. Кларк, Кеннеди, Гамильтон Кевин. Принципы коммутации в локальных
сетях Cisco.: Пер. с англ. – М.: Издательский дом «Вильямс», 2003. – 976 с.: ил.
– Парал. тит. англ.
69
Документ
Категория
Без категории
Просмотров
31
Размер файла
2 951 Кб
Теги
локальные, самостоят, метод, технология, 390, учеб, сетей, лаб, пособие, инфокоммуникационных
1/--страниц
Пожаловаться на содержимое документа