close

Вход

Забыли?

вход по аккаунту

?

927

код для вставкиСкачать
А. В. МАЛЬЦЕВА
МЕТОДИЧЕСКИЕ УКАЗАНИЯ
К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ ПО ДИСЦИПЛИНЕ
"СИСТЕМЫ АВТОМАТИЗИРОВАННОГО ПРОЕКТИРОВАНИЯ
СИСТЕМ ЭЛЕКТРОСНАБЖЕНИЯ"
ОМСК 2012
Министерство транспорта Российской Федерации
Федеральное агентство железнодорожного транспорта
Омский государственный университет путей сообщения
____________________________________
А. В. Мальцева
МЕТОДИЧЕСКИЕ УКАЗАНИЯ
К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ ПО ДИСЦИПЛИНЕ
"СИСТЕМЫ АВТОМАТИЗИРОВАННОГО ПРОЕКТИРОВАНИЯ
СИСТЕМ ЭЛЕКТРОСНАБЖЕНИЯ"
Утверждено редакционно-издательским советом университета
Омск 2012
1
УДК 621.331:519.673 (075.8)
ББК 39.217 я73
М21
Методические указания к выполнению лабораторных работ по дисциплине "Системы автоматизированного проектирования систем электроснабжения" / А. В. Мальцева; Омский гос. ун-т путей сообщения. Омск,
2012. 39 с.
Изложены краткие теоретические сведения о системах автоматизированного проектирования как мощного инструментария по проектированию, расчету и оформлению текстовой и графической документации систем электроснабжения промышленных предприятий и их элементов. Приведены характеристики наиболее распространенных программных продуктов, описание алгоритмов
и приемов работы в указанном программном обеспечении.
Предназначены для студентов пятого курса специальности 101600 –
"Энергообеспечение предприятий", могут быть полезны пользователям ЭВМ и
слушателям Института повышения квалификации и переподготовки в приобретении начальных навыков работы в программах AutoCAD, "Компас-3D",
T-FLEX CAD 3D.
Библиогр.: 3 назв. Рис. 29.
Рецензенты: доктор техн. наук, доцент А. Т. Когут;
начальник центра информационных технологий
ОмГТУ С. П. Шамец.
________________________
© Омский гос. университет
путей сообщения, 2012
2
ОГЛАВЛЕНИЕ
Введение …………………………………………………………………………
Лабораторная работа 1. Выполнение фрагмента схемы электроснабжения
объекта в программе AutoCAD ……………………………………………
Лабораторная работа 2. Выполнение фрагмента строительного плана
здания в программе "Компас-3D" ………………………………………..
Лабораторная работа 3. Разработка параметрического чертежа в программе
T-FLEX CAD 3D …………………………………………………………….
Лабораторная работа 4. Трехмерное моделирование в системе T-FLEX
CAD 3D ………………………………………………………………………
Лабораторная работа 5. Конечно-элементный анализ инженерной задачи …
Контрольные вопросы…………………………………………………………..
Библиографический список……………………………………………………..
3
5
7
15
20
23
33
38
38
4
ВВЕДЕНИЕ
Увеличение производительности труда разработчиков новых изделий,
сокращение сроков проектирования, повышение качества разработки проектов – важнейшие проблемы, решение которых определяет уровень ускорения
научно-технического прогресса общества. Развитие систем автоматизированного проектирования опирается на научно-техническую базу: современные
средства вычислительной техники, новые способы представления и обработки
информации, создание новых численных методов решения инженерных задач и
оптимизации.
В настоящее время созданы и применяются в основном средства и методы, обеспечивающие автоматизацию рутинных процедур и операций (подготовка текстовой документации, преобразование технических чертежей, создание графических изображений и др.).
Основные виды проектной деятельности (примерные оценки) [1]:
вычерчивание проектируемого изделия и его составляющих – 70 % от
общей трудоемкости;
организация архивов и их ведение – 15 %;
собственно проектирование – 15 %.
Проектирование подразделяется
на копирование архивных прототипов – 70 %;
модификацию вариантов – 20 %;
исправление ошибок – 9 %;
разработку – 1 %.
Система автоматизированного проектирования (САПР) определена в
ГОСТ 23501.0-79 как организационно-техническая система, состоящая из
комплекса средств автоматизации проектирования, взаимодействующего с подразделениями проектной организации, и выполняющая автоматизированное
проектирование.
Автоматизация проектирования является одним из основных способов
повышения производительности труда инженеров-проектировщиков и конструкторов.
Возможности САПР:
быстрое выполнение чертежей (в три раза быстрее) позволяет в более
сжатые сроки выпускать продукцию и реагировать на требования рынка;
5
повышение точности выполнения чертежей – на чертеже, построенном с
использованием программных средств, место любой точки определено точно,
для детального просмотра есть средство, позволяющее увеличить любую часть
чертежа;
качественное выполнение чертежей;
многократное использование чертежа;
ускорение расчетов и анализа при проектировании;
высокий уровень проектирования – мощные средства компьютерного моделирования (например, метод конечных элементов) позволяют проектировать
нестандартные геометрические модели, которые можно быстро модифицировать и оптимизировать;
сокращение затрат на усовершенствование – средства имитации и анализа, включенные в САПР, позволяют значительно сократить затраты времени и
средств на исследование и совершенствование прототипов, которые являются
дорогостоящими этапами процесса проектирования.
Цель лабораторного практикума по дисциплине "Системы автоматизированного проектирования систем электроснабжения"– ознакомить студентов с
программным обеспечением по выполнению автоматизированного проектирования: "Компас-3D" (ЗАО "Аскон", Санкт-Петербург), AutoCAD (Autodesk), TFLEX CAD 3D (АО "Топ-системы", Москва).
В качестве задания преподаватель выдает фрагменты электрических схем
силового электроснабжения объектов гражданского назначения, их планы, выполненные в проектных организациях. Создавая электронную версию выданного чертежа, студент учится "читать" графические документы и работать в указанных выше программах, повышая свой уровень владения ЭВМ, что несомненно пригодится ему в дальнейшей профессиональной деятельности.
Защита выполненных работ проходит непосредственно за персональным
компьютером, в процессе которой студент показывает свое умение работать в
указанных программах.
При необходимости можно записать соответствующие программы на
диск, обратившись к администратору вычислительного класса.
6
Лабораторная работа 1
ВЫПОЛНЕНИЕ ФРАГМЕНТА СХЕМЫ ЭЛЕКТРОСНАБЖЕНИЯ
ОБЪЕКТА В ПРОГРАММЕ AutoCAD
Ц е л ь р а б о т ы: ознакомиться с основными принципами построения
двумерного чертежа и приобрести навыки работы в программе AutoCAD; выполнить фрагмент схемы электроснабжения объекта гражданского назначения
(файл *.dwg).
1.1. Краткие теоретические сведения
В настоящее время программа AutoCAD является наиболее распространенным пакетом прикладных программ по выполнению проектно-конструкторской документации в России и за рубежом. В подразделениях системы
управления электроснабжением железных дорог имеются большие наработки,
выполненные в AutoCAD, в виде схем подстанций и контактной сети, и для их
корректировки в электронном виде необходима соответствующая квалификация персонала.
Пакет программ AutoCAD англоязычный, что является основной трудностью при освоении его студентами, особенно начинающими пользователями
ЭВМ. В учебном процессе используются английские версии AutoCAD, поэтому
необходимо знание английского языка как основного при общении с ЭВМ и
программными продуктами различного назначения. В помощь студентам
в настоящих указаниях наряду с английскими терминами дается их русский перевод (более подробная информация – в специальной литературе [2]).
При работе с AutoCAD в распоряжении пользователя имеются
графические примитивы (точка, отрезок, окружность и др.);
команды их редактирования (стирание, перенос, копирование и т. п.);
команды установки свойств примитива (задание толщины, типа и цвета
графических объектов);
команды выбора формата и масштаба чертежа;
команды автоматической и ручной простановки размеров;
средства управления изображением на экране и др.
Так как все элементы объектов имеют векторный характер, то при получении жесткой копии качество изображения чертежа не теряется.
7
Векторное представление определяет описание изображений в виде
линий и фигур (можно с закрашенными областями). Для описания объектов используются комбинации компьютерных команд и математических формул. Это
позволяет различным устройствам компьютера (монитору или принтеру) при
рисовании вычислять, где необходимо помещать реальные точки.
Векторную графику часто называют объектно-ориентированной, или чертежной. Имеется ряд простейших объектов (примитивов): эллипс, прямоугольник, линия. Эти примитивы и их комбинации используются для создания более
сложных изображений. Основное преимущество векторной графики в том, что
описание объекта является простым и занимает небольшой объем компьютерной памяти.
1.2. Начало работы
При запуске программы появляется диалоговое окно "Startup" (рис. 1),
в котором предлагается:
1) загрузить существующий файл (стандартный значок Windows – открытая желтая папочка);
2) выбрать систему единиц: метрическую (все размеры на чертеже –
в миллиметрах) или английскую (все размеры – в дюймах и футах);
Рис. 1. Вид диалогового окна "Startup"
3) принять шаблон выполнения чертежа (template), так как изначально
в AutoCAD отсутствуют российские стандарты: нет рамки, соответствующих
8
шрифтов, поэтому их необходимо подбирать вручную либо загружать дополнительные утилиты (дополнения к программе);
4) определить дополнительные условия исполнения чертежа – единицы
измерения угловых величин, область чертежа и др.
При создании нового чертежа обычно пользуются второй вкладкой, после
нажатия кнопки "ОК" загружается рабочее окно программы.
Интерфейс программы AutoCAD стандартный (сверху вниз):
цветная полоска со значком и названием программы, имя файла (слева),
операции с текущим окном (свернуть, развернуть, закрыть) (справа);
системное меню;
панели инструментов (ниже системного меню, справа и слева), они могут
быть помещены пользователем в любое место вокруг рабочего поля следующим образом: установить курсор мыши возле начала панели (двойная выпуклая
линия), нажать левую клавиши мыши и, удерживая ее, переместить панель в
нужное место;
командная строка;
строка состояния с координатами курсора; по значению координаты
можно определить, в какой системе координат начинает работать пользователь
(метрической или английской), на это следует обратить внимание перед работой над чертежом, чтобы избежать потери времени на переход к метрической
системе;
на уровне строки состояния справа расположены "клавиши" команд:
SNAP – привязка курсора к сетке;
GRID – включение (выключение) сетки;
ORTHO – ортогональный режим (при его включении можно создать
только горизонтальные либо только вертикальные линии);
POLAR – показ полярных координат точки;
OSNAP – объектная привязка;
OTRACK – отслеживание объектной привязки;
LWT (lineweight) – выбор толщины линии, включение опции дает возможность просмотра линий разной толщины;
MODEL (model or paper space) – модель или пространство бумаги – показ
расположения чертежа на листе бумаги при выводе на печать.
Рабочее поле программы по умолчанию черное, линии чертежа белые, но
при выводе на печать все как обычно: бумага белая, линии черные.
9
По желанию пользователя можно сделать экран белым: системное меню
Tools (инструменты) – Options (опции) – Display (дисплей) – Colors (цвета) –
White (белый) – Apply & Close (применить и закрыть) – "OK". Описание
команд системного меню и соответствующих вкладок приведено для английской версии программы AutoCAD.
Все команды могут быть запущены из системного меню и с панели инструментов. Пользователь может "вытащить " в рабочее окно программы необходимые ему панели следующим образом: системное меню View (вид) –
Toolbars (панели инструментов) – в появившемся диалоговом окне поставить
"галочку" против названия нужной панели, после чего последняя появляется на
экране монитора.
Ознакомимся с основными правилами работы с программой AutoCAD,
без знания и использования которых невозможно грамотно выполнить точный
чертеж. Большие белые (прозрачные) стрелки в левом нижнем углу черного поля определяют начало и направление осей координат. "Включенная" сетка показывает область листа (по умолчанию определен формат А3, горизонтальная
ориентация). Выполнять чертеж можно на листе любого формата, наличие рамки и штампа необязательно.
1.3. Командная строка
Пакет программ AutoCAD создавался для работы в операционной системе DOS (дисковая операционная система), поэтому он имеет характерную особенность подобных программ – командную строку.
Командная строка расположена ниже рабочего поля программы над строкой состояния C o m m a n d: (рис. 2).
Рис. 2. Вид командной строки
10
С помощью командной строки осуществляется диалог пользователя и
программы. Любая команда, активированная с панели инструментов или из системного меню, обязательно отображается в командной строке. После активации команды в командной строке появляются соответствующие опции, которые
имеются у данной команды. Опции пишутся в квадратных скобках через косую
черту, для их активации необходимо в командной строке с клавиатуры набрать
соответствующую букву (заглавную букву в названии опции) и нажать клавишу
"Enter".
Различия для командной строки между прописными и строчными буквами нет, и ставить курсор в командную строку нет необходимости: все, что
набирается с клавиатуры, отражается в командной строке.
Читать командную строку н е о б х о д и м о, так как она содержит запрос
о дальнейшем шаге работы. Например, после нажатия иконки "Отрезок" на панели инструментов в командной строке появляется запись "_line Specify first
point" (команда "Line" (линия), определите первую точку). Выход из любой
команды осуществляется нажатием на клавиатуре клавиши "Esc" либо активацией по щелчку правой клавиши мыши из всплывающего меню команды "Cancel". Если программа ждет команды пользователя, то командная строка чистая
и в ней мигает курсор.
1.4. Привязки
В любом графическом пакете есть возможность "включить" (вывести на
экран) сетку, т. е. точки либо линии, расположенные в зоне чертежа с определенным шагом. Сетка включается командой "Grid" (grid – сетка), которую можно набрать в командной строке либо активировать нажатием на соответствующее слово на уровне строки состояния. Изменяется шаг сетки вызовом всплывающего меню щелчком правой клавиши мыши при расположении курсора на
команде "GRID".
В появившемся диалоговом окне (рис. 3) "Drafting Settings" (установки
чертежа, рисования) можно
"включить" или "выключить" сетку (поставить "галочку" или убрать ее
соответственно возле слов "Grid On");
изменить шаг сетки – соответствующие позиции показывают расстояние
между точками сетки по осям Х и У;
11
активировать или отключить команду "SNAP" (привязка курсора к сетке).
При выполнении чертежа необходимо использовать объектные привязки
(команда "OSNAP") или просто привязки. Это означает, что курсор будет "цепляться" за определенные точки уже нарисованных объектов.
Рис. 3. Вид диалогового окна "Установки чертежа"
Наиболее часто используемые привязки:
endpoint – конечная точка;
midpoint – середина (отрезка);
center – центр (окружности или дуги);
intersection – пересечение;
nearest – скольжение по кривой (прямой);
tangent – касание.
Наименование конкретной привязки в AutoCAD высвечивается всплывающим текстом и соответствующим геометрическим значком желтого цвета
(например, конечная точка – квадратик, середина – треугольник).
1.5. Примеры выполнения команд
При выполнении несложных чертежей по заданным размерам используют
следующие команды.
К о м а н д а "L i n e" (линия, отрезок) вызывается с панели инструментов
нажатием на соответствующую иконку, на которой нарисован отрезок, либо из
12
системного меню "Draw" – "Line", либо набором этой команды в командной
строке. Подобными тремя способами в AutoCAD вызывается любая команда.
После запуска команды курсор на экране меняет свой вид и в командной строке
появляется соответствующий запрос.
Из курса геометрии известно, что отрезок задается двумя точками. AutoCAD запрашивает первую и вторую точки отрезка. Первую точку задают щелчком левой клавиши мыши в нужном месте рабочего поля программы либо вводом ее координат (в командной строке – через точку с запятой). Начало координат расположено в левом нижнем углу рабочего поля программы. После задания (указания) первой точки следует запрос "Specify Next Point" (задайте вторую точку). Как правило, из задания известны длина отрезка и его направление,
т. е. смещение второй точки относительно первой. Для последних версий AutoCAD достаточно указать направление линии мышью и, не трогая ее, ввести в
командной строке длину отрезка, после чего нажать клавишу "Enter". После
этого можно увидеть, что за курсором мыши опять тянется линия, т. е. конечная
точка первого отрезка является началом второго. Опять следует указать
направление отрезка и ввести его длину с клавиатуры и т. д. Выход из команды осуществляется нажатием клавиши "Esc" либо по команде из всплывающего
меню по щелчку правой клавиши мыши (всплывающее меню является удобным
средством диалога с программой).
При неактивной команде щелчок правой клавиши мыши вызывает всплывающее меню (рис. 4), которое содержит следующие команды (активны –
темные):
"Repeat
Line"
вторить, линия)
– повторить последнюю выполненную команду,
в
данном случае –
"Line";
"Cut"
(вырезать) – вырезать
в буфер обмена;
Рис. 4. Вид всплывающего меню
13
"Copy" (копировать) – копировать в буфер обмена;
"Copy with Base Point" – копировать с базовой точкой;
"Paste" (вставить) – вставить из буфера обмена;
"Undo" (отменить) – отменить последнюю команду;
"Pan" (панорама) – переместить чертеж с помощью мыши (нажать левую
клавишу и удерживать ее); чтобы выйти из этой команды, необходимо нажать
правую клавишу мыши, затем активировать команду "Exit";
"Zoom" (вид) – увеличить или уменьшить вид чертежа (без изменения его
размеров);
"Quick Select ..." – выполнить быстрый выбор по свойствам примитивов;
"Find ..." – найти текст;
"Options..." – опции (повторяется команда из системного меню "Tools").
При нажатии правой клавиши мыши в разных местах рабочего поля
программы появляются различные всплывающие меню, команды в них практически идентичны описанным выше.
К о м а н д а "C o n s t r u c t i o n L i n e" (линия построения) используется
для создания вспомогательных линий (бесконечных прямых), с помощью которых удобно увязывать проекции. После активации команды необходимо указать первую точку в рабочем поле чертежа либо выбрать нужную опцию из
приведенных в скобках в командной строке: Hor/Ver/Ang/Bisect/Offset (горизонтальная, вертикальная, под углом, биссектриса, параллельная).
Например, требуется провести прямую под углом 60°: вызываем команду
"Construction Line", выбираем опцию "Ang", для чего набираем в командной
строке заглавную букву в названии опции – "а", нажимаем клавишу "Enter", затем вводим число 60 (угол относительно положительного направления оси Х),
нажимаем клавишу "Enter". По экрану за курсором перемещается прямая под
углом 60°. Остается только зафиксировать ее в нужном месте чертежа.
Линии построения удобно использовать в качестве вспомогательных линий, например, для связи двух проекций. В этом случае целесообразно задать
цвет этих линий отличным от цвета основного чертежа. Удаление вспомогательных линий, как и других элементов чертежа, производится вручную.
Для проведения отрезков, обозначающих невидимые или центральные
линии (штриховая, штрихпунктирная), следует загрузить их из системного меню "Стиль линии …" с помощью команды "Загрузить", в появившемся диалоговом окне нужно выделить необходимые типы линий и нажать кнопку "ОК".
14
Остальные команды требуют аналогичных действий, т. е. диалога с
командной строкой. Если знаний по английскому языку недостаточно, то рекомендуется использовать словарь. После освоения нескольких приемов построения чертежа работа в AutoCAD, как правило, не вызывает затруднений.
Лабораторная работа 2
ВЫПОЛНЕНИЕ ФРАГМЕНТА СТРОИТЕЛЬНОГО ПЛАНА ЗДАНИЯ
В ПРОГРАММЕ "Компас-3D"
Ц е л ь р а б о т ы: ознакомиться с основными принципами построения
двумерной модели (чертежа) и приобрести навыки работы в программе "Компас-3D"; выполнить фрагмент строительного плана здания (файл *.cdw).
2.1. Краткие теоретические сведения
В отличие от AutoCAD программа "Компас-3D" разработана российской
фирмой "Аскон". Эта программа получила в России широкое распространение,
так как в ней заложены все российские стандарты по выполнению различного
вида документации (чертежи, спецификации, пояснительные записки и т. д.)
[2]. Пакет программ "Компас-3D" имеет большую библиотеку элементов, работа с которой проста и логична. Приемы работы в программе "Компас-3D" несколько отличаются от приемов работы в программе AutoCAD, например,
нажатие правой клавиши мыши вызывает всплывающее меню совсем иного,
чем в AutoCAD, содержания, однако пользователи быстро привыкают к этому,
так как имеется справочная система на русском языке.
Основным графическим документом в системе "Компас-3D" является
лист чеpтежa (расширение фaйлa – cdw). Чертеж обязательно имеет рамку и
штамп, выполненные согласно действующим стандартам. Другой документ, который может создать эта система, называется фрагментом (чистый лист без
рамки). Файл с фрагментом имеет расширение frw. Первые шаги в программе
"Компас-3D" рекомендуется делать на листе чертежа в рамке. На бесконечном
поле фрагмента неопытный пользователь может потерять свой рисунок.
2.2. Начало работы
После запуска программы открывается рабочее поле либо загружается
последний выполнявшийся документ. В этом случае следует закрыть его и
15
начать работу в соответствии с указаниями, изложенными далее. В настоящих
методических указаниях все команды и рисунки приводятся для программы
"Компас-3D V8". Предыдущие версии имеют схожий интерфейс и практически
идентичные команды. Существенные отличия будут оговорены.
Для создания нового документа следует активировать команду "Создать"
из системного меню либо нажать одноименную кнопку, затем выбрать необходимый тип документа "Компас-3D". В данном случае нужно указать на "Чертеж" и нажать кнопку "ОК" – загружаются полное системное меню, панели
инструментов и лист с рамкой и штампом. По умолчанию установлен формат
А4. Можно изменить формат, воспользовавшись командой системного меню
"Сервис" – "Параметры…". В открывшемся диалоговом окне слева необходимо
найти строку "Параметры первого листа" и щелкнуть левой клавишей мыши по
"плюсу" рядом с ней. В списке следует открыть "Формат" и в окне справа установить точки в нужных позициях.
При знакомстве с программой "Компас-3D" в первую очередь целесообразно изучить назначение кнопок на компактной панели инструментов слева на
рабочем поле программы. Наименование этих и других кнопок покажет всплывающая подсказка, которая появляется при подведении курсора мыши к объекту исследования. Подобные всплывающие подсказки характерны для всех программ, имеющих стандартный интерфейс операционной системы Windows.
При нажатии кнопки, например, "Геометрия", ниже появляются иконки
(кнопки) команд данной группы. "Компас-3D", как и другие пакеты чертежной
графики, использует для описания двух- и трехмерных моделей векторную
графику, т. е. оперирует математическими выражениями для хранения в своих
файлах свойств модели. Поэтому в командах панели "Геометрия" можно увидеть список примитивов (прямая, отрезок, окружность, дуга и т. д.), которые
являются компонентами любого сколь угодно сложного чертежа.
2.3. Основные команды и приемы работы в программе "Компас-3D"
16
А к т и в а ц и я любой команды производится одиночным щелчком левой
клавиши мыши по соответствующей кнопке: она изменит свой цвет (станет
"нажатой"), ниже появятся имеющиеся опции, или инструменты.
В ы х о д и з к о м а н д ы можно выполнить
с помощью клавиши "Esc" на клавиатуре (самый быстрый способ);
нажатием ярко-красной кнопки с надписью "Stop" в правом нижнем углу
поля программы (на панели свойств);
щелчком правой клавиши мыши всплывающего меню и выбором в нем
команды "Прервать команду";
повторным нажатием кнопки активной команды.
Рекомендуется следить за тем, чтобы была нажата кнопка "Автосоздание
объекта" на панели свойств, тогда не придется каждый раз щелкать мышью на
панели свойств для подтверждения создания объекта.
Изменить м а с ш т а б и з о б р а ж е н и я можно вращением колесика мыши
(скролла). П е р е м е щ е н и е чертежа в пределах экрана производится с помощью команды "Сдвинуть" или с помощью линеек прокрутки, которые по
умолчанию отключены. Вывести на экран линейки прокрутки можно с помощью команды системного меню "Сервис" –
"Параметры" – вкладка "Текущее окно" – "Линейки прокрутки". При нажатии и удерживании
черного треугольника в правом нижнем углу
кнопки каждой команды вызывает ее опции
Рис. 5. Опции команд
(рис. 5), активировать которые можно, переместив курсор мыши на нужную опцию и отпустив
клавишу мыши.
Использование п р и в я з о к позволяет выполнить красивый и грамотный чертеж. По
умолчанию включены некоторые привязки (рис.
6). С помощью приведенного диалогового окна
можно установить или снять какую-либо привязку, причем это можно делать, не выходя из текущей команды.
Рис. 6. Привязки
В ы д е л е н и е элементов чертежа производится охватом рамкой при нажатии и удерживании левой клавиши мыши либо
щелчком этой же клавиши по элементу. Выделенные фрагменты приобретают
17
зеленый цвет. Для снятия пометки с элемента достаточно просто щелкнуть в
свободном месте чертежа.
Быстрый двойной щелчок вызовет появление панели свойств и возможность редактирования параметров указанного элемента. Закрепить внесенные
изменения позволит нажатие кнопки "Создать объект" на панели свойств
(кнопка с изображением символа "Enter" клавиатуры).
У д а л е н и е выделенных объектов производится клавишей "Delete" клавиатуры.
В процессе работы над чертежом некоторые линии могут исчезнуть, поэтому следует помнить о том, что программа – это инструмент в руках пользователя (такой же, как молоток или отвертка), и
само собой ничего не исчезает и ниоткуда не берется. Во избежание лишних действий и искажения чертежа следует обновлять изображение на
Рис. 7. Обновление
экране с помощью команды "Обновить изобраизображения
жение" (рис. 7) или движения скролла мыши.
2.3.1. Создание отрезка
При нажатии кнопки "Геометрия" появляются команды, необходимые для
создания простейших элементов чертежной графики: точка (вспомогательная
точка), линия (бесконечная прямая), отрезок, окружность и т. д.
После активации команды "Отрезок" курсор изменяет свой вид (появляется крестик с единичкой), это говорит о том, что нужно указать первую точку
отрезка на поле чертежа. После ее указания в изображении курсора появится
цифра "2", т. е. требуется определить положение второй точки отрезка. Если
известна длина отрезка, то следует набрать соответствующее число на клавиатуре и нажать клавишу "Enter" (в предыдущих версиях программы "Компас-3D"
следует поставить курсор мыши в поле "Длина" на панели свойств внизу на рабочем поле, стереть имеющиеся там цифры, набрать требуемые и также нажать
клавишу "Enter"). Отрезок примет заданную длину, теперь достаточно указать
направление и щелкнуть левой клавишей мыши.
При включенной опции "Округление"
будет динамически отслеживаться длина отрезка (рис. 8), округленная до целых, что дает
18
Рис. 8. Опция "Округление"
возможность не вводить данные с клавиатуры и значительно ускорить процесс
выполнения чертежа.
2.3.2. Команды панели "Редактирование"
Панель редактирования служит для выполнения операций над элементами чертежа. Наиболее часто используются операции копирования, сдвига с базовой точкой, симметрии (они становятся доступными после выделения элементов чертежа)
и "Усечь кривую" (рис. 9). Последняя применяется, например, для удаления части линии, заключенной между двумя другими.
После активации команды следует "поймать" в появившийся "прицел" подлежащий
Рис. 9. Операция
удалению фрагмент линии и щелкнуть левой
"Усечь кривую"
клавишей мыши. Если удаление было ошибочным, то можно отменить выполненные действия (не выходя из команды "Усечь
кривую") с помощью команды "Отменить" (синяя круглая стрелка вверху на
стандартной панели инструментов), после чего необходимо обновить изображение.
Копировать элементы чертежа в другие фрагменты (чертежи) следует
средствами операционной системы через буфер обмена с указанием базовой
точки (выделенные объекты "привязываются" к базовой точке как к системе
координат). Выполнение команды "Копирование" элементов внутри одного и
того же чертежа производится с помощью средств "Компас-3D": командой системного меню "Редактор" – "Копия" либо нажатием кнопки "Копирование" на
панели "Редактирование".
Во всех случаях при работе над чертежом следует читать запросы и подсказки системы (в строке состояния) и отвечать на них, не совершать лишних
щелчков клавишами мыши и периодически сохранять выполненные наработки.
Лабораторная работа 3
РАЗРАБОТКА ПАРАМЕТРИЧЕСКОГО ЧЕРТЕЖА
В ПРОГРАММЕ T-FLEX CAD 3D
19
Ц е л ь р а б о т ы: освоить основные принципы двумерного моделирования на примере построения параметрического чертежа заданного объекта (файл
"чертеж_2D.grs").
3.1. Краткие теоретические сведения
Система T-FLEX CAD 3D ("Топ-системы", Москва) является системой
параметрического твердотельного моделирования, которая имеет в своем составе современные инструменты для создания моделей различной сложности.
Эта программа сочетает в себе мощную функциональность параметрического
твердотельного трехмерного моделирования с полным набором инструментов
двумерного черчения. T-FLEX CAD 3D – это система параметрического трехмерного твердотельного моделирования, которая является развитием системы
T-FLEX CAD 2D. Функциональные возможности системы T-FLEX CAD 3D
ставят ее в один ряд с лучшими системами трехмерного моделирования, а
наличие полного набора средств двумерного проектирования и оформления
чертежной документации делает эту систему идеальным решением для автоматизации конструкторско-технологической подготовки производства.
3.2. Основные приемы работы
В системе T-FLEX CAD 3D необходимо выполнить п а р а м е т р и ч е ск и й чертеж. Чертежи, созданные с помощью программ AutoCAD и "Компас3D", называют эскизными. Параметрический чертеж создается по совершенно
иному принципу, который похож на реальное выполнение проектировщиком
чертежа (например, "в туши" на ватмане), т. е. сначала человек рисует чертеж в
тонких линиях карандашом, а затем обводит необходимые линии тушью. Такой
же подход используется и при параметрическом черчении в системе T-FLEX
CAD: контур детали создается с помощью линий построения (пунктирные), которые обводятся в нужных пределах линиями изображения (рис. 10).
Линии построения можно скрыть соответствующей командой (именно
скрыть, а не удалить), после которой независимо от видимости этих линий на
чертеже на печать они не выводятся.
20
С помощью элементов построения автоматически создается
параметрический образ модели, и
при правильном построении чертежа при изменении одной проекции автоматически будут пересчитываться и другие, а также и
трехмерная модель (если она построена по чертежу).
В процессе работы над параметрическим чертежом необхоРис. 10. Линии построения и
димо проверять правильность его
изображения
выполнения (связь проекций). Для
этого следует подвести курсор к какой-либо линии построения и нажать
правую клавишу мыши (рис. 11). Во всплывающем меню выбрать опцию "Изменить". Линия будет перемещаться за курсором, и если вместе с ней будут логично двигаться и другие элементы чертежа, то это означает, что построение
выполнено верно.
Следует обращать внимание на то, чтобы на параметрическом чертеже узлы
были только в виде крестиков (см. рис. 10, 11) и чтобы
элементы не накладывались
друг на друга (визуально это
незаметно, а структура параметрической модели становится нелогичной – появляются лишние и противоречивые связи).
Рис. 11. Вид всплывающего
меню с командой "Изменить"
Для прорисовки чертежа следует применять команду "Обновить окна документа" (иконка с изображением картины на панели инструментов "Вид").
К программе T-FLEX CAD 3D прилагается руководство (учебник), выполненное в pdf-формате (для чтения необходима программа Acrobat Reader),
21
аналогов которому программы AutoCAD и "Компас-3D" не имеют. Рекомендуется начинать работу в программе T-FLEX CAD 3D с изучения этого руководства, в котором содержатся сведения о принципах создания параметрического чертежа, 3D-модели и подробное пошаговое описание разработки моделей.
Опыт работы пользователей показывает, что необходимо повторить все
шаги по руководству, а затем приступать к созданию собственного чертежа, в
результате чего значительно меньше времени тратится на освоение программы
и допускается меньше ошибок. Таким образом, целесообразно запустить файл
"Руководство. 3D-моделирование": "Пуск" – "Программы" – "T-FLEX CAD ..."
(рис. 12), открыть программу T-FLEX CAD 3D и, переключая окна, работать с
руководством. Нет необходимости изучать полностью все руководство сначала,
достаточно открыть раздел "Краткий вводный курс по созданию 3D-модели" –
"Метод "От чертежа к 3D-модели" и внимательно выполнять указания. Следует
помнить о том, что для программы каждый щелчок мыши является командой
пользователя, которую она рано или поздно исполнит.
Рис. 12. Фрагмент окна для запуска руководства к программе T-FLEX CAD
3D
В процессе создания параметрического чертежа программой разрабатывается математическая модель двумерного объекта, в которой увязаны все элементы чертежа, поэтому на рабочем поле не должно быть ничего лишнего
(наложенных друг на друга линий построения, узлов, которые ничего не связывают и т. д.). Все погрешности, допущенные при создании параметрического
чертежа, проявятся при построении трехмерной модели по этому чертежу.
22
Лабораторная работа 4
ТРЕХМЕРНОЕ МОДЕЛИРОВАНИЕ В СИСТЕМЕ T-FLEX CAD 3D
Ц е л ь р а б о т ы: построить трехмерную модель заданного объекта
на основе разработанного (в предыдущей работе) параметрического чертежа
(файл "2D_3D.grs") и основным способом (файл "3D.grs")
4.1. Краткие теоретические сведения
Трехмерное моделирование в системе T-FLEX CAD 3D может осуществляться непосредственно в 3D-пространстве или на основе данных двумерного
чертежа. Проектировщик может выбрать любой способ работы в программе
T-FLEX CAD 3D или их комбинацию. Настоящая лабораторная работа посвящена выполнению трехмерной модели по разработанному ранее параметрическому чертежу.
Алгоритм разработки объемной модели является характерным для
всех систем твердотельного моделирования: эскиз (профиль) протягивается
в пространстве вдоль вектора выталкивания, который, как правило, направлен
по нормали к профилю.
Особенностью создания твердотельной модели по чертежу является то,
что профиль задается штриховкой необходимой области на чертеже, а вектор
выталкивания – двумя пространственными узлами (3D-узлами), которые строятся по двум проекциям на чертеже. Рассмотрим подробнее этапы создания
твердотельной модели в T-FLEX CAD 3D.
4.2. Разработка трехмерной модели на основе параметрического чертежа
4.2.1. Построение рабочих плоскостей
Для работы в пространстве необходимо на поле чертежа создать рабочие
плоскости. Первым шагом является задание с помощью команд "Построить
прямую" – "Создать две перпендикулярные прямые и узел" узла, который будет
точкой начала координат рабочих плоскостей (рис. 13). Очевидно, что точка
начала координат должна находиться между тремя проекциями и не должна
быть связана ни с одним элементом чертежа.
23
Следующий шаг – построение рабочих плоскостей с помощью команд
"Построить рабочую плоскость" – "Создать стандартную рабочую плоскость".
"Построить
прямую"
Рис. 13. Вид окна при создании узла – начала координат рабочих плоскостей
В появившемся диалоговом окне следует нажать ту кнопку (расположены справа), в которой указаны необходимые для текущего построения проекции (рис. 14).
"Построить рабочую
плоскость"
"Создать стандартную
рабочую плоскость"
Рис. 14. Вид окна с командами построения рабочей плоскости
Далее на запрос команды (внизу на строке состояния) "Выбрать начало
координат" следует щелкнуть левой клавишей мыши на узле, который для этих
целей был ранее создан. На чертеже появятся рабочие плоскости, их границы
будут обозначены линиями зеленого цвета. Заметим, что стандартные рабочие
плоскости создаются в пределах листа бумаги, по умолчанию – в формате А3.
В случае, если чертеж построен за пределами рабочих плоскостей, можно не
24
перестраивать чертеж, а изменить размеры листа бумаги с помощью команды
системного меню "Настройка" – "Размеры страницы". После активации команды на границах листа бумаги (серые линии) появятся квадратики, которые следует "ухватить" нажатием левой клавиши мыши и "утащить" в нужное место.
Утвердить положение новых границ необходимо щелчком левой клавиши мыши на зеленой "галочке" слева вверху на панели инструментов.
4.2.2. Задание профиля выталкивания штриховкой
Для задания профиля выталкивания штриховкой используются команды
"Штриховка" – "Режим автоматического поиска контура" (рис. 15). Указанный
режим имеет преимущества в том, что он
показывает ошибки, совершенные при обводке линиями изображения сложного контура (например, при наличии сопряжений).
Далее следует щелкнуть левой клавишей
мыши внутри необходимого контура. Если
проекция содержит несколько замкнутых
контуров, то нужно щелкать внутри каждого, следя за изменениями границ будущей
Рис. 15. Задание контура
штриховки и добиваясь желаемых результаштриховкой
тов. Завершают создание штриховки нажатием зеленой "галочки". При необходимости можно изменить свойства штриховки (например, сделать невидимой) нажатием кнопки "Р" (от английского
слова properties – свойства) на панели инструментов.
4.2.3. Задание вектора выталкивания
Вектор выталкивания в данном способе построения трехмерной модели
задается двумя пространственными узлами, создание которых производится
с помощью команд "Построить 3D-узел" – "По двум проекциям" (рис. 16). После активации команды от программы последует запрос "Задать первую проекцию 3D-узла", что и нужно сделать, указав на чертеже плоский узел-крестик.
После этого соответствующая рабочая плоскость подсветится красным цветом
и программа запросит вторую проекцию 3D-узла. Создание пространственного
узла произойдет только после указания двух проекций и нажатия зеленой "галочки". Отменить ошибочно выбранную проекцию можно щелчком правой
25
клавиши мыши. Во время всех действий необходимо внимательно следить за
запросами программы.
Для просмотра появившихся 3D-узлов и дальнейшей работы необходимо
открыть 3D-окно.
"Построить 3D-узел"
Для открытия
3D-окна нажать
Рис. 16. Вид экрана с командами построения 3D-узла
Например, открыть 3D-вид можно с помощью кнопок со стрелками,
которые располагаются в левом нижнем и правом верхнем углах окна текущего чертежа рядом с полосами прокрутки (см. рис. 16). Для этого необходимо
подвести курсор к кнопке, которая находится в верхнем правом углу, щелкнуть
левой клавишей мыши, указывая на кнопку, и окно текущего чертежа будет
разделено на два окна по вертикали. В первом окне будет виден двумерный
чертеж, а во втором (в процессе построения 3D-модели) будут отображаться
3D-элементы и трехмерные тела. При этом необходимо следить за тем, чтобы в
появившемся 3D-окне были включены элементы построения (на панели "Вид",
расположенном по умолчанию справа на экране, не должно быть нажатых
кнопок), в противном случае построенные 3D-узлы не будут отображаться на
экране и придется строить их снова, что приведет к лишним затратам труда и
времени и некорректной работе программы.
26
4.2.4. Построение 3D-профиля
Программой предусматривается много способов образования 3Dпрофилей. В данном случае необходимо построить 3D-профиль на основе
штриховки, созданной ранее, используя команды "Построить 3D-профиль" –
"Выбрать штриховку" (рис. 17).
"Построить 3D-профиль"
Рис. 17. Вид окна при построении 3D-профиля на основе штриховки
Далее следует щелкнуть левой клавишей мыши внутри контура штриховки (рабочая плоскость и сама штриховка подсветятся), на основе которой создается 3D-профиль. В 3D-окне появится выбранный контур, а в строке состояния – запрос "Выбрать 3D-узел для привязки плоскости контура" (рис.
18), после чего нужно щелчком левой клавиши мыши указать на узел в 3Dокне, который является начальной точкой вектора выталкивания (если после
первого щелчка контур не переместится, то нужно повторить щелчок).
Рис. 18. Вид окна при выполнении привязки контура к 3D-узлу
27
После перемещения контура (привязки его к выбранному узлу) следует
нажать зеленую "галочку".
4.2.5. Выталкивание
Согласно теории трехмерной компьютерной графики поверхности, созданные с помощью операции выталкивания заданного профиля (эскиза) вдоль
определенной линии, называемой вектором выталкивания, носят название "поверхности-экструзии" (от английского слова extrusion – выдавливание, выталкивание), поэтому в различных системах твердотельного моделирования могут
встречаться такие названия операции "Вытолкнуть", как "Вытянуть", "Выдавить", "Extrude" и др.
Поверхностями-экструзиями являются также фигуры вращения, которые
создаются с помощью операции "Вращение". Как правило, в качестве профиля,
подлежащего вращению, используется половина поперечного сечения тела,
в качестве оси вращения – ось симметрии сечения либо ребро контура.
Некоторые трехмерные тела нельзя построить с помощью операции
"Выталкивание" или "Вращение" (например, усеченную пирамиду). В таком
случае используется операция "По сечениям", для выполнения которой необходимо создать трехмерные профили – основания пирамиды, и далее применить
команду "Операции" – "По сечениям".
Для совершения операции выталкивания необходимо ответить программе
на три вопроса: "Что выталкивать?", "Откуда?" и "Куда?", а затем выбрать
команду "Создать выталкивание" (рис. 19).
Рис. 19. Вид окна при выполнении операции "Выталкивание"
28
По умолчанию активна опция "Выбрать контур" ("Что выталкивать?").
После щелчка по контуру будет представлено предполагаемое тело. Вектор выталкивания при построении объемного тела по чертежу задается не длиной
(слева на панели свойств), а трехмерными узлами, построенными на основе
чертежа.
Для продолжения операции выталкивания следует активизировать опцию
"Выбрать начальную точку выталкивания" (рис. 20), указать узел, принадлежащий контуру ("Откуда?"), он станет желтым, затем – второй узел ("Куда?"), он
тоже станет желтым и тело приобретет нужную длину. Завершить операцию
выталкивания следует нажатием зеленой "галочки".
Рис. 20. Вид окна при задании вектора выталкивания
По умолчанию на панели "Вид" (справа на рабочем поле программы) активна опция "Реберное изображение", согласно которой модель представляется
в виде каркаса. Для получения реалистичного объемного изображения следует
включить опцию "Тоновая закраска с материалами" или "Тоновая закраска".
По умолчанию материал модели не определен – "Материал_0". Для точного
расчета массовой и инерционных характеристик объекта (массы, момента
инерции и др.) можно указать программе материал, из которого изготовлено
тело. Из всплывающего меню (по щелчку правой клавиши мыши) выбирается
команда "Свойства операции". В появившемся диалоговом окне "Параметры
выталкивания" (для операции выталкивания) следует раскрыть список материалов и указать в нем необходимый.
4.2.6. Создание отверстий, вырезов
При создании трехмерной модели объекта следует помнить о том, что
любая операция выталкивания или вращения создает отдельное тело. Если требуется сделать отверстие в модели, т. е. создать пустоту, или объединить два
тела в единое целое, то необходимо применить булевы операции (булева алгебра или алгебра логики – названа по имени ее создателя английского математика
Джорджа Буля) командой "Создать булеву операцию". Далее следует указать
29
оба тела, над которыми будут производиться действия (для операции "Вычитание" первым указывается тело, из которого вычитают), и выбрать необходимую
булеву операцию: "Сложение", "Вычитание" или "Пересечение" (рис. 21).
Вся структура модели, все построения и действия,
совершенные пользователем, отражаются в дереве модели.
Рис. 21. Булевы
При наведении курсора мыши на какой-либо элемент в деоперации
реве модели последний будет подсвечиваться на самой
модели в окне 3D-вида.
С помощью дерева (структуры) модели удобно отслеживать все построения, удалять лишние и проверять логику разработки трехмерной модели.
4.3. Разработка трехмерной модели основным методом
Создание трехмерной модели основным способом описано в руководстве
пользователя "Руководство. 3D-моделирование" (разделы "Краткий вводный
курс по созданию 3D-модели" – "Основной метод создания 3D-модели"). Принцип создания твердотельной модели основным методом тот же, что и при
построении по чертежу – протягивание профиля по направляющей на заданное
расстояние. В отличие от метода "От чертежа к 3D-модели" длина вектора выталкивания (основной параметр операции выталкивания) задается не трехмерными узлами по данным параметрического чертежа, а в явном виде на панели
свойств. Затем используются булевы операции для объединения тел в единое
целое или для вычитания одного из другого (см. п. 4.2.6).
4.3.1. Создание профиля выталкивания
Разработка любой объемной модели может идти различными путями
в зависимости от формы объекта и способностей конструктора логически определить порядок построения модели, поэтому на основе полученных знаний
об основах твердотельного моделирования в первую очередь следует определиться с логикой дальнейшей работы в программе. Критериями служат экономичность, т. е. количество требуемых действий (операций), сложность выполняемых операций и умение вести диалог с программой. Например, скругленные
ребра модели можно выполнить двумя способами: трудоемким – нарисовать
соответствующий профиль и выталкивать его; рациональным – протолкнуть
30
прямоугольный профиль и выполнить операцию "Скругление" уже на объемной модели сразу всех требуемых ребер.
После запуска системы T-FLEX CAD 3D на экране появляется рабочее
поле программы и на его фоне – диалоговое окно "Добро пожаловать", в котором нужно открыть вкладку "Новый" – "3D-модель". На экране появятся: справа – окно структуры 3D-модели, слева – рабочее окно с пространственными
плоскостями ("Вид спереди", "Вид сверху", "Вид слева"). Сначала нужно определиться, на какой из этих плоскостей будет находиться профиль выталкивания. После этого следует подвести курсор мыши к выбранной плоскости (она
подсветится) и щелкнуть правой клавишей мыши, в появившемся всплывающем меню выбрать опцию "Чертить на рабочей плоскости" (рис. 22).
Рис. 22. Вид диалогового окна для активизации рабочей плоскости
П
осле щелчка на указанной опции рабочая плоскость изменит свою ориентацию
и появится панель "Управление активной рабочей плоскостью". На выбранной плоскости необходимо выполнить двумерное построение профиля выталкивания (3D-профиля). Следует помнить о том, что профиль должен быть замкнутым и не должен иметь внутренних пересечений. Выполнять чертеж можно
непосредственно в трехмерном пространстве или в 2D-окне, открыть которое
можно с помощью кнопки
"Открыть 2D-окно с текущей рабочей плоскостью"
(рис. 23). Появится обычный белый лист, на коРис. 23. Вид панели для открытия 2D-окна
тором можно выполнять построения. По завершении черчения на данной рабочей плоскости следует
31
щелкнуть левой клавишей мыши по зеленой "галочке" на панели "Управление активной рабочей плоскостью", в результате 2D-окно закроется, пространственные плоскости примут первоначальный вид, а правильно выполненный
профиль проявится зеленым контуром на выбранной изначально рабочей плоскости.
При построении профиля на плоскости иногда в центре рабочей плоскости полезно создать две пересекающиеся прямые и узел, относительно которых
можно вести дальнейшие построения.
Это можно сделать с помощью команд
"Построить прямую" – "Создать две
перпендикулярные прямые и узел" –
Рис. 24. Вид окна при создании
узла в центре рабочей плоскости
"Создать линии построения и узел в
точке (0,0)" (рис. 24).
4.3.2. Выталкивание
Протягивание профиля в пространстве совершается с помощью команды
"Создать выталкивание". После ее активации от программы последует запрос
"Выбрать контур", на который нужно ответить, подведя курсор мыши к требуемому контуру (он подсветится) и щелкнув левой клавишей мыши (программа
покажет предполагаемое направление выталкивания). Справа появится панель
свойств "Параметры выталкивания" (ее содержание желательно изучить), на
которой требуется указать длину выталкивания и выбрать нужное направление.
Завершить команду необходимо нажатием зеленой "галочки". Следует помнить
о том, что система остается в текущей команде, для выхода из которой нужно
щелкнуть правой клавишей мыши.
4.3.3. Дальнейшее моделирование
Для выполнения отверстия в какой-либо грани необходимо активизировать эту грань. Действия при активизации грани аналогичны первым действиям
при работе с рабочей плоскостью: подводят курсор мыши к требуемой грани
(она подсвечивается), щелкают правой клавишей мыши (грань становится зеленой), из всплывающего меню выбирают опцию "Чертить на грани" и т. д.
32
Выполнение булевых операций описано ранее. Следует обратить внимание на то, что операция "Вычитание" результативна, если она применяется к
двум телам, но не к трем и более. Например, если необходимо сделать отверстие в двух телах с помощью одного цилиндра (окружность протянута через два
ранее созданных тела), то сначала следует объединить эти два тела в одно (булевой операцией "Сложение"), а затем выполнить операцию вычитания.
Применяя основные простейшие приемы работы в системе T-FLEX CAD
3D, при работе в программе следует обращать внимание на ее запросы, выбирать нужные опции команд (при подведении курсора мыши на кнопку появляется всплывающая подсказка с названием опции), иными словами, необходимо
вести диалог с системой, и тогда процесс моделирования будет творческим занятием.
Лабораторная работа 5
КОНЕЧНО-ЭЛЕМЕНТНЫЙ АНАЛИЗ ИНЖЕНЕРНОЙ ЗАДАЧИ
Ц е л ь р а б о т ы: ознакомиться с возможностями модуля экспрессанализа; освоить основные принципы проведения конечно-элементного анализа
твердых тел на примере прочностного расчета (файл "задача.grs").
5.1. Краткие теоретические сведения
В основе практически всех программных продуктов, в возможности которых входит решение какой-либо инженерной задачи (прочностный расчет,
определение теплопроводности, расчет электромагнитных полей и т. д.) лежит
метод конечных элементов (МКЭ). При применении МКЭ исходная область
определения функции разбивается с помощью сетки (в общем случае – неравномерной) на отдельные подобласти – конечные элементы. Искомая непрерывная функция аппроксимируется кусочно-непрерывной, определенной на множестве конечных элементов.
Конкретную реализацию алгоритма метода конечных элементов или его
частного случая – метода конечных объемов – можно посмотреть на примере
модуля "Экспресс-анализ" системы T-FLEX CAD 3D 10 ST. Учебная версия,
рассматриваемая в настоящих методических указаниях, имеет значительные
ограничения в сравнении с коммерческой, тем не менее ее возможностей доста33
точно для ознакомления с основными приемами работы в системах конечноэлементного анализа.
Порядок работы расчетного модуля:
1) построение трехмерной модели;
2) генерация сеточной конечно-элементной модели изделия с помощью
препроцессора: создание конечно-элементной (КЭ) сетки, отражающей геометрию изделия и наложение граничных условий, определяющих физическую задачу, подлежащую решению. Кроме построения КЭ-сетки с помощью препроцессора задаются граничные условия. Препроцессор автоматически переносит граничные условия на КЭ-модель для построения тетраэдальной КЭмодели изделия);
3) расчеты в процессоре: генерация расчетных систем уравнений и их решение (результатами работы КЭ-процессора являются значения искомых целевых функций);
4) анализ результатов работы в постпроцессоре: анимация, отображение
деформированного состояния и т. д.
5.2. Порядок проведения конечно-элементного анализа
Основные приемы работы и команды расчетного модуля рассмотрим на
примере прочностного расчета кронштейна опоры контактной сети.
5.2.1. Создание новой задачи и наложение сетки
Задача анализа создается по команде системного меню "Анализ" – "Новая
задача" – "Конечно-элементный анализ" или "Динамический анализ" (рис. 25).
Рис. 25. Фрагмент окна для создания новой задачи
В данной работе рассматривается алгоритм выполнения конечноэлементного анализа (при необходимости или по заданию преподавателя может
быть выполнен и динамический анализ). Следует помнить основное правило
работы в любой программе: видеть поле и отвечать на запросы программы.
34
После активации команды "Конечно-элементный анализ" слева появляется панель свойств, на которой в строке "Создать сетку" должна стоять "галочка". Далее следует указать щелчком левой клавиши мыши расчетное тело (оно
приобретет зеленый отсвет) либо щелкнуть на иконке "Выбрать все тела" (тела
будут подсвечены желтым цветом) – станет активна зеленая "галочка" завершения выбора объектов расчета, которую следует нажать. На панели свойств появится шкала размеров сетки, которые можно изменить, переместив движок
нажатой левой клавишей мыши в требуемое место (рис. 26).
Рис. 26. Вид окна с результатом работы генератора конечно-элементной сетки
5.2.2. Задание граничных условий
Непременным условием любого конечно-элементного анализа является
наложение граничных условий, в данном случае – закрепление тела и задание
внешних воздействий на него (силы, давления).
Закрепление кронштейна выполняется командой системного меню "Анализ" – "Ограничение" – "Полное закрепление" (в учебной версии доступна
только указанная опция). Указать закрепляемую грань и нажать зеленую "галочку" на панели свойств – модель приобретет желтые "отростки" на закрепленной грани. В случае неверного указания грани следует удалить операцию
"Закрепление" из дерева задачи и повторить процедуру сначала.
Задание внешнего воздействия производится по команде системного меню "Анализ" – "Нагружение" – "Давление" или "Сила". Следует указать место
приложения силы (грань, вершину, ребро) и необходимые данные на панели
свойств.
35
Результат задания граничных условий и дерево задачи, которое подобно
дереву трехмерной модели отражает все выполненные операции экспрессанализа, приведены на рис. 27.
Рис. 27. Вид окна с граничными условиями и деревом задачи
5.2.3. Конечно-элементный расчет
Конечно-элементный расчет выполняется по команде системного меню
"Анализ" – "Расчет". После запуска программы на расчет появляется окно
сообщений с характеристиками проведенного конечно-элементного расчета,
которое представлено на рис. 28, где СЛАУ – система линейных алгебраических уравнений; tol (tolerance) – погрешность. Время решения задачи зависит в
основном от производительности используемой ЭВМ.
Рис. 28. Вид окна сообщений с характеристиками конечно-элементного расчета
36
5.2.4. Визуализация результатов расчета
Результаты расчета выводятся из дерева задачи (см. рис. 28). Раскрытие
"+" у папки "Результаты" показывает возможные результаты расчета: "К-т (коэффициент) запаса по эквивалентным напряжениям", "Напряжения эквивалентные", "Перемещения, модуль". Следует подвести указатель мыши к нужной
строке (она станет цветной) и щелкнуть правой клавишей мыши. Из всплывающего меню выбрать "Открыть в новом окне". Результат операции приведен на
рис. 29.
Рис. 29. Вид окна с визуализацией результатов расчета
Количественные результаты конечно-элементного анализа в виде отчета
недоступны в рассматриваемой учебной версии программы. Характеристики
материала объекта можно вывести с помощью команды системного меню
"Анализ" – "Материал …". Наглядно видно изменение значения коэффициента
запаса по эквивалентным напряжениям в зависимости от материала модели, который можно изменять, при этом не пропадают наложенные ранее граничные
условия. Программа лишь запросит обновление сетки ("Сетка не актуальна"),
причем будет использовать результаты предыдущих расчетов, так что при изменении конструкции время расчета возрастает незначительно.
37
Контрольные вопросы
1. Как расшифровывается аббревиатура 3D (2D)?
2. Каково назначение CAD-, CAM- и CAE-систем автоматизированного
проектирования?
3. В каких программах булевы операции присутствуют в явном виде?
4. Что общего имеют в своем составе программы твердотельного моделирования, описанные в данной работе?
5. Для чего предназначено дерево модели (дерево построения) и каковы
его назначение и содержание?
6. Для чего нужна командная строка в программе AutoCAD?
7. Как увидеть опции команд в программе "Компас-3D"?
8. Можно ли при работе в программах обойтись без панелей инструментов, если "да", то с помощью чего?
9. Как изменить цвет фона рабочего поля AutoCAD?
10. В возможности какой системы (CAD, CAM, CAE) входит конечноэлементный анализ?
11. Какие виды инженерного анализа возможны в версии T-FLEX CAD
3D 10 ST?
12. Что означают понятия "препроцессор" и "постпроцессор"?
При самостоятельной подготовке к ответам на контрольные вопросы рекомендуется использовать литературные источники [1 – 3].
Библиографический список
1. К л и м а ч е в а Т. Н. AutoCAD 2008 для студентов: самоучитель /
Т. Н. К л и м а ч е в а. М.: ДМК-Пресс, 2008. 368 с.
2. А в е р и н В. Н. Компьютерная инженерная графика / В. Н. А в е р и н.
М.: Академия, 2009. 218 с.
3. Г е р а с и м о в А. А. "Компас-3D V10" / А. А. Г е р а с и м о в. СПб: БХВПетербург, 2009. 956 с.
38
Учебное издание
МАЛЬЦЕВА Алла Викторовна
МЕТОДИЧЕСКИЕ УКАЗАНИЯ
К ВЫПОЛНЕНИЮ ЛАБОРАТОРНЫХ РАБОТ ПО ДИСЦИПЛИНЕ
"СИСТЕМЫ АВТОМАТИЗИРОВАННОГО ПРОЕКТИРОВАНИЯ
СИСТЕМ ЭЛЕКТРОСНАБЖЕНИЯ"
____________________________________
Редактор Н. А. Майорова
***
Подписано в печать 06.11.2012. Формат 60 × 84 1/16.
Плоская печать. Бумага офсетная. Усл. печ. л. 2,4. Уч.-изд. л. 2,7.
Тираж 50 экз. Заказ
.
**
Редакционно-издательский отдел ОмГУПСа
Типография ОмГУПСа
*
644046, г. Омск, пр. Маркса, 35
39
Документ
Категория
Без категории
Просмотров
3
Размер файла
488 Кб
Теги
927
1/--страниц
Пожаловаться на содержимое документа