close

Вход

Забыли?

вход по аккаунту

?

3. Как добавить объекты базы данных в DataSet

код для вставкиСкачать
Этот документ извлечен из статей, которые вы можете найти по следующим ссылкам.
In the Microsoft(r) Visual Studio(r) 2005 documentation at
* Walkthrough: Creating a Dataset with the Dataset Designer
ms-help://MS.VSCC.v80/MS.MSDNQTR.v80.en/MS.MSDN.v80/MS.VisualStudio.v80.en/dv_raddata/html/12360f54-db6c-45d2-a91f-fee43214b555.htm
Walkthrough: Add Database Objects to a DataSet.
В этом руководстве, вы создадите набор данных с помощью Dataset Designer.
Он покажет вам процессы создания нового проекта и добавления новой DataSet к ней. В узнаете как создавать таблицы основанные на таблицах из базы данных не используя Wizard.
В этом руководстве вы узнаете как:
* Создать новый проект Microsoft Windows(r) Application.
* Добавить в проект пустой DataSet.
* Создать и настроить источник данных в приложении с помощью Dataset Designer.
* Создать новое подключение к базе данных Northwind на Server Explorer.
* Создать DataTables с TableAdapters в источнике данных основанных на таблицах из базы данных. Что бы выполнить данную процедуру необходимо иметь доступ к базе данных Northwind. (Microsoft SQL Server(r) or Access version).
Создание нового Windows приложения. * В меню File создайте новый проект.
* Создайте Windows приложение на удобном вам языке.
* Назовите проект DatasetDesignerWalkthrough и нажмите ОК.
Visual Studio добавит проект в Solution Explorer и в конструкторе отобразит новую форму.
Добавление нового DataSet в проект.
* В меню Project, щелкнуть по Add New Item.
* В Templates кликните по DataSet.
* Введите имя NorthwindDataset и кликните Add.
Visual Studio добавит файл в проект и назовет его NorthwindDataset.xsd и отобразит его в Dataset Designer.
Создание нового подключения к базе данных Northwind.
* В меню View кликните по Server Explorer
* В Server Explorer нажмите на кнопку Connect to Database.
* Создайте подключение к базе данных Northwind. В этом пошаговом руководстве вы можете подключиться только к SQL Server или Access версии Northwind.
Создание таблицы Customers.
* Разверните Tables и подключение, которое вы только что создали в Server Explorer.
* Перетащите таблицу Customers из Server Explorer в Dataset Designer.
Создание таблицы Orders.
* Перетащите таблицу Orders из Server Explorer в Dataset Designer Создание таблицы OrderDetails.
* Перетащите таблицу OrderDetails из Server Explorer в Dataset Designer
Добавление функциональности в приложение
* Dataset который вы только что создали сейчас доступен в окне Data Sources. В меню Data кликните по Show Data Sources что бы посмотреть источник данных. Вы можете выбирать элементы из Data Sources окна и перетаскивать их на форму.
* Добавить код что бы сохранить изменения набора данных в базе данных.
* Добавить больше запросов в ableAdapters.
* Добавить проверку события к ColumnChanging или RowChanging таблицам данных в источнике данных. 
Документ
Категория
Рефераты
Просмотров
73
Размер файла
42 Кб
Теги
данных, добавить, базы, dataset, объекты
1/--страниц
Пожаловаться на содержимое документа