close

Вход

Забыли?

вход по аккаунту

?

Интеграция средств САПР (ЛР 09.04.02)

код для вставкиСкачать
1
Министерство образования и науки Российской Федерации
Федеральное государственное бюджетное образовательное учреждение
высшего образования
«Воронежский государственный лесотехнический университет
имени Г.Ф. Морозова»
ИНТЕГРАЦИЯ СРЕДСТВ САПР
Методические указания к лабораторным работам
по направлению подготовки
09.04.02 – Информационные системы и технологии
Воронеж 2016
2
УДК 004
Лавлинский, В. В. Интеграция средств САПР [Электронный ресурс] : Методические указания к лабораторным работам по направлению подготовки
09.04.02 – Информационные системы и технологии / В.В. Лавлинский, К.В.
Зольников, Т.В. Скворцова, С.А. Евдокимова ; М-во образования и науки РФ,
ФГБОУ ВО «ВГЛТУ им. Г.Ф. Морозова». – Воронеж, 2016. – 28 с.
Печатается по решению учебно-методического совета
ФГБОУ ВО «ВГЛТУ» (протокол № __ от _______ 2016 г.)
Рецензент начальник лаборатории ОАО «НИИЭТ» к.т.н. А. И. Яньков
3
ВВЕДЕНИЕ
Методические указания подготовлены в соответствии с рабочей программой дисциплины «Методы проектирования и создания современных
САПР» для магистров по направлению подготовки 09.04.02 – Информационные
системы и технологии (уровень магистратуры). Целью изучения данной дисциплины является формирование у магистров умений и навыков по использованию методов проектирования и создания современных САПР.
Чтобы лучше представить работу в САПР Cadence необходимо научиться
создавать собственные проекты. Следующая часть научного проекта содержит
методические указания по выполнению лабораторных работ в среде OrCAD.
Лабораторный практикум содержит работы по исследованию, особенностям
проектирования и моделирования в OrCAD, созданию библиотек элементов,
корпусов, принципиальных электрических схем, списка соединений, трассировке и изучению методики проектирования механических узлов и контуров
печатной платы в программном модуле Visual CADD.
4
Лабораторная работа №1
ИССЛЕДОВАНИЕ
СТРУКТУРЫ
И
ОСОБЕННОСТЕЙ
ПРИМЕНЕНИЯ САПР СКВОЗНОГО ПРОЕКТИРОВАНИЯ РЭС ORCAD
Цель работы
Познакомиться с основными компонентами пакета OrCAD, научится создавать проекты OrCAD и конфигурировать редактор Capture.
Состав пакета OrCAD
Система OrCAD, подобно Microsoft Office, состоит из набора вполне автономных программных модулей, каждый из которых может использоваться отдельно для решения частных задач в цепочке проектирования электронных
схем.
Основными компонентами этой системы можно назвать:
1. Capture – графический редактор, предназначенный для создания принципиальных электронных схем. С этой программы обычно начитается работа
над проектом.
2. Layout – графический редактор печатных плат. Данные об электронных компонентах, из которых состоит проектируемое устройство, а также данные о соединениях обычно передаются в редактор печатных плат из OrCAD
Capture, но простые печатные платы можно создавать без использования редактора схем.
3. PSpice – программа моделирования аналоговых и смешанных аналогоцифровых электронных схем. Обычно данные в PSpice передаются из Capture
или Schematics.
В пакет OrCAD 9.2, также входят:
PSpice Schematics – редактор схем;
PSpice Optimizer – программа параметрической оптимизации электронных схем;
GerbTool – программа создания и доработки файлов для фотоплоттеров;Capture CIS (Component Information System), аналогичный Capture но дополненный информационной системой ведения базы электронных компонентов;
Два несколько модифицированных редактора Layout.
1. Layout Plus – дополненный бессеточным автотрассировщиком
SmartRoute, использующим методы оптимизации нейронных сетей.
2. Layout Engineer's Edition – программа просмотра печатных плат, созданных с помощью Layout или Layout Plus, средство общей расстановки компонентов на плате и прокладки наиболее критических цепей, выполняемых инженером-схемотехником перед выдачей задания на проектирование печатной
платы конструктору.
Создание проекта OrCAD
5
Проектирование любого электронного устройства начинается с создания
его принципиальной схемы. В зависимости от сложности устройства схема может быть простой или иерархической – состоящей из отдельных функциональных блоков, каждый из которых имеет собственную принципиальную схему. В
системе OrCAD принципиальная схема (файл с расширением .dsn, называемый
Design) и сопутствующие файлы объединяются в проект (Project, файл с расширением .opj).
Проекты создаются в редакторе Capture с помощью мастера проектов.
Для создания нового проекта нужно: запустить Capture, в меню File выбрать
New project, или нажать соответствующую кнопку на панели инструментов.
В окне мастера проектов (рис. 1.1) необходимо латинскими буквами ввести имя (Name) создаваемого проекта и выбрать тип проекта.
Рис. 1.1 – создание нового проекта
Предлагаются следующие типы проектов:
1. Analog or Mixed A/D – аналоговые, цифровые или смешанные аналогоцифровые устройства, моделируемые с помощью программы PSpice A/D (возможна также дальнейшая разработка печатной платы в Layout).
2. PC Board Wizard – печатные платы (моделирование смешанных аналого-цифровых устройства выполняется с помощью PSpice). Необходимость
проведения моделирования указывается в диалоговом окне PCB Project Wizard.
Для добавления возможности моделирования нужно пометить галочкой строку
Enable project simulation.
3. Programmable Logic Wizard – проектирования программируемых логических матриц (далее не рассматривается).
4. Schematic – не специализированные проекты (возможно только создание и документирование принципиальных схем, моделирование и разработка
печатных плат не предусматривается).
6
В окошке Location мастера проектов нужно указать место размещения файлов создаваемого проекта. Путь к папке проекта также должен состоять
только из латинских букв. Папку проекта можно выбрать нажав кнопку
Browse. Дальнейшие действия зависят от выбранного типа проекта.
Analog or Mixed A/D
В окне создания проекта (Create PSpice Project) (рис. 1.2) предлагается
создать новый проект на базе имеющегося (Create based upon an existent project),
который будет служить отправной точкой, или "пустой" проект.
Рис. 1.2 – создание проекта PSpise
В качестве базового может использоваться любой ранее созданный проект, который можно указать нажав кнопку Browse. Базовый проект также можно выбрать из списка выпадающего меню.
Это может быть проект:
- простой (simple.opj),
- иерархический (hierarchical.opj),
- простой со всеми библиотеками (simple_all_libs.opj),
- иерархический со всеми библиотеками (herarchicle_all_libs.opj).
Для создания пустого проекта нужно отметить Create a blank project.
PC Board Wizard
В окне PC Board Wizard (рис. 1.3) можно разрешить моделирование электронной схемы в PSpice (Add Simulation to project) – мастер добавит соответствующие ресурсы в проект.
Далее предлагается выбрать библиотеки электронных компонентов
(рис. 1.4), которые планируется использовать в проекте.
7
Рис. 1.3 – окно мастера проектов РСВ
Рис. 1.4 – выбор библиотек для проекта РСВ
Если в процессе работы над проектом окажется, что требуется не включенная ранее библиотека, ее можно легко добавить.
Schematic
При выборе Schematic окна проекта открываются без дополнительных
вопросов.
Настройка редактора Capture
Рассмотрим возможности настройки редактора. Как и в других программах, доступ к настройкам можно получить через меню Options, состав которого
меняется в зависимости от активного окна.
Вне зависимости от активного окна доступны:
8
1. Preferences – задаются настройки Capture, которые применяются ко
всем открываемым проектам.
2. Design Template – настройки, применяемые к вновь создаваемым проектам, на созданные ранее не влияют.
3. Product Configuration – выборразновидностей Capture и PSpice.
Если активным является окно редактора схем, доступна опция Schematic
Page Properties.
Доступ этому окну также можно получить из контекстного меню, которое
появляется при щелчке правой кнопкой мыши на вкладку страницы схемы в
окне менеджера проектов.
Для созданной по умолчанию первой страницы это будет PAGE1 в папке SCHEMATIC1. Как следует из названия, здесь устанавливаются свойства
конкретной страницы.
Рассмотрим возможности настройки подробнее.
Preferences
Это окно содержит несколько закладок (рис. 1.5).
Рис. 1.5 – окно свойств редактора Capture
В первой (Colors/Print) можно задать цвет объектов для их отображения
на экране компьютера и галочкой отметить, будут ли эти элементы выводиться при печати. Кнопка Use Default позволяет вернуть первоначальные установки.
Grid Display- отображение сетки.
9
Отдельно для редактора схем и редактора символов можно включить
отображение сетки, переключить стиль сетки: отображать узлы точками
(Dots) или рисовать сетку линиями (Lines). В этой закладке включается привязка курсора к сетке. Шаг сетки в Capture менять нельзя, он задается для вновь
создаваемых проектов в Design Template, вкладке Page Size. Невозможность
изменить шаг сетки не является существенным недостатком, поскольку привязку к сетке можно отключить.
Pan and Zoon позволяет установить коэффициент увеличения/уменьшения (Zoom Factor) при изменении масштаба и скорость автоматического перемещения (Auto Scroll) по листу при приближении курсора с выделенным объектом (перемещении) к краю окна. Если этот параметр установлен в
0, автоматическая прокрутка отключается. Как и в предыдущей закладке, вышеперечисленные параметры устанавливаются отдельно для редактора элементов и редактора схем.
Select настраивает способ выделения элементов схемы. При включенном Intersecting выделяются все объекты, которые даже частично попали в область выделения. Fully Enclosed позволяет определить выделение только для
тех объектов, которые полностью попали в область выделения. Здесь же определяется максимальное число выделенных элементов, при котором будет сохраняться качественное отображение их начертаний во время перемещения. Если число выделенных объектов превосходит установленное, при перемещении будут отображаться только их контуры.
Две последние вкладки позволяют изменить настройки по умолчанию
при редактировании графики в окне редактора схем и элементов, изменить настройки текстового редактора и параметры автосохранения.
Design Template
Как было сказано выше, в этом окне (рис. 1.6) определяются настройки
по умолчанию для вновь создаваемых проектов, на текущий и ранее созданные
они действия не оказывают. Окно имеет ряд вкладок.
Fonts позволяет задать шрифты, которые будут использоваться по умолчанию для различных текстовых элементов.
Title Block определяет значение полей углового штампа, а также позволяет определить библиотеку, в которой находится угловой штамп, имя углового
штампа, который будет использоваться по умолчанию. С пакетом OrCAD поставляется библиотека capsym.olb в которой находятся угловые штампы стандартов ISO и ANSI.
Page Size задает единицы измерения и размер листов схемы по умолчанию. Доступны листы стандартных размеров, также можно задавать произвольные размеры листа. В этой вкладке определяется расстояние между выводами элементов схем, что соответствует шагу сетки в окне редактора схем.
Следует иметь в веду, что изменение этого параметра повлияет на масштаб
имеющих выводы графических элементов схемы.
10
Рис. 1.6 – окна настройки шаблона
Grid Reference определяет разбивку поля чертежа на зоны, отображение
разбивки, рамки и углового штампа в окне редактора схем и при печати.
Hierarchy определяет типы иерархических блоков и элементов по умолчанию.
STD Compatibility определяет соответствие полей элементов при преобразовании в STD формат.
Schematic Page Properties
Это меню (рис. 1.7) позволяет определить установки текущей страницы открытого проекта.
Проект может состоять из нескольких страниц, и для каждой из них могут быть заданы различные свойства, такие как размер листа (закладка Page
Size), отображение рамки, разбивки на блоки и углового штампа (Grid
Reference). В закладке Miscellaneous можно посмотреть дату и время создания
и последнего изменения листа. Все вкладки повторяют те, что присутствуют в
окне Design Template.
Задание на лабораторную работу
1. Познакомиться с составом пакета OrCAD 9.2.
2. Создать проект типа PC Board с возможностью моделирования электронных схем.
3. Познакомиться с возможностями конфигурирования редактора
Capture, изменить настройки по умолчанию для вновь создаваемых проектов.
11
Рис. 1.7 – окно свойств страницы
Контрольные вопросы
1. Состав пакета OrCAD 9.2.
2. Создание проектов в OrCAD Capture.
3. Типы проектов OrCAD, их назначения.
4. Возможности настройки редактора Capture.
5. Задание параметров для вновь создаваемых проектов.
12
Лабораторная работа №2
СОЗДАНИЕ УСЛОВНЫХ ГРАФИЧЕСКИХ ИЗОБРАЖЕНИЙ
ЭЛЕКТРОРАДИОЭЛЕМЕНТОВ РЭС И БИБЛИОТЕК НА ИХ ОСНОВЕ В
САПР ORCAD
Цель работы
Научиться создавать в Capture: библиотеки, односекционные и многосекционные компоненты, символы.
Введение
Пакет OrCAD поставляется с библиотеками, содержащими наиболее распространенные компоненты и угловые штампы. Все они выполнены в соответствии с западными стандартами, которые отличаются от российских. Таким образом, большая часть компонентов библиотек Capture оказывается непригодной
при оформлении конструкторской документации, требующей соблюдения
ГОСТ.
Существуют библиотеки, предлагаемые третьими фирмами, которые соответствуют требованиям российских стандартов, однако нельзя гарантировать,
что в них окажется условное обозначение требуемого вам компонента.
Решить эту проблему можно создавая собственные библиотеки компонентов и символов. Эта задача достаточно удобно решена в пакете
OrCAD. Редакторы Capture и Layout имеют встроенные редакторы компонентов
и корпусов.
Создание библиотек в редакторе Capture
Как было отмечено выше, в библиотеках OrCAD нет угловых штампов,
соответствующих ГОСТ 2.104-68, но есть возможность их создать. Как и другие элементы, угловые штампы хранятся в библиотеках. Пользователь может
добавлять свои элементы, включая штампы, в уже существующие библиотеки,
либо создавать свои собственные библиотеки.
Мы выберем второй путь и создадим библиотеку с именем russian.olb.
Для того чтобы создать библиотеку, нужно в меню File редактораCapture
выбратьNew, затемLibrary. Если эти действия производились в открытом проекте, в окне папки Design Resources Library менеджера проекта появится новая
библиотека, именуемая по умолчанию library1.olb (рис. 2.1).
13
Рис. 2.1 – окно менеджера проекта
Для изменения имени или расположения библиотеки нужно выделить
файл библиотеки в окне менеджера проектов и в контекстном меню, которое
появляется при нажатии правой кнопки мыши на имени библиотеки, или в меню Design выбрать Save As. В библиотеку могут входить компоненты (Part) и
символы (Symbol). Компоненты отличаются тем, что имеют корпус.
Угловой штамп относится к символам. Для создания нового углового
штампа нужно в контекстном меню библиотеки или в меню Design при выделенной библиотеке выбрать New Symbol и в появившемся окне свойств нового
символа (New Symbol Properties) (рис. 2.2) указать имя символа (это может
быть A4) и тип символа. Возможны следующие типы символа:
Рис. 2.2 – создание нового символа
Power – это символ общего провода (земля) и символы питающих напряжений;
14
Off-Page Connector –- символ, с помощью которого показывается передача сигнала с одной страницы схемы на другую, если схема состоит из нескольких страниц;
Hierarchical Port используется для передачи сигнала между иерархическими блоками;
Title Block – угловой штамп.
В нашем случае тип должен быть Title Block. Для создания компонентов
и символов используется редактор, аналогичный редактору схем Capture
(рис. 2.3).
Рис. 2.3 – окно редактора символов с панелью инструментов
Шаг сетки в редакторе символов не меняется и не зависит от установок
проекта. Шаг всегда равен 0.1 дюйма, что соответствует 2.54 мм. Если привязка
к сетке отключена, курсор будет перемещаться с шагом 0.01 дюйма (0.254 мм).
Включение-выключение привязки к сетке осуществляется с помощью кнопки ,
расположенной на панели инструментов, или сочетания клавиш CTRL+T.
Для изменения масштаба изображения используются клавиши
I – приблизить, O – отодвинуть.
Также для изменения масштаба можно использовать кнопки панели инструментов. Компоненты и символы располагаются в прямоугольнике, размеры
которого кратны 0.1 дюйма. Размеры области можно менять, растягивая прямоугольник за углы.
Следует отметить, что сам прямоугольник, определяющий область символа, при вставке в схему не рисуется, поэтому контур элемента, если требуется, нужно рисовать отдельно.
Доступные для рисования графические примитивы представлены в таблице 2.1.
Графические примитивы - Таблица 2.1.
15
Для замкнутых фигур можно задавать способ заливки и тип линии контура (рис. 2.4), для незамкнутых только тип линии.
Рис. 2.4 – окно редактирования свойств замкнутых фигур
Доступ к окну редактирования свойств выделенных замкнутых или незамкнутых линий осуществляется: через главное меню Edit -> Properties, Edit
Properties контекстного меню, с помощью сочетания клавиш Ctrl+E или двойного щелчка левой кнопкой мыши по объекту, свойства которого необходимо
редактировать. В угловом штампе (рис. 2.5) можно поместить поля, которые
будут заполняться автоматически.
Рис. 2.5 – угловой штамп
16
Для этого, находясь в редакторе символов, в меню Option выбирается
Part Properties. В окне User Properties (Рис. 2.6) с помощью кнопки New можно добавить новое поле и установить его свойства нажав кнопку Display.
Рис. 2.6 – окно редактора пользовательских свойств символа
Создание компонентов
Создание компонентов аналогично созданию символов, для этого в контекстном меню библиотеки или меню Design выбирается команда NewPart.
Компоненты могут состоять из нескольких секций, при этом секции могут быть
однородные (Homogeneous) и неоднородные (Heterogeneous).
Многосекционными называют такие компоненты, которые в одном корпусе содержат более одного элемента, например микросхема 74HC00, российским аналогом которой является 1564ЛА3, содержит четыре логических элемента 2И-НЕ.
Если элементы функционально одинаковые, компонент называется однородным, в противном случае - неоднородным.
В окне создания нового компонента, которое появляется после выполнения команды New Part (рис. 2.7), указывают: название (Name) компонента; префикс символьного обозначения (Part Referens Prefix), так в соответствии с российским стандартом резисторы обозначаются буквой R, конденсаторы C, а цифровые интегральные схемы - DD; здесь же можно указать тип корпуса (PCB Footprint), количество блоков, тип компонента, а также способ нумерации блоков (Part Numbering) для многоблочных компонентов.
17
Рис. 2.7 – окно создания нового компонента
Нумерация может быть алфавитной (Alphabetic) или цифровой
(Numeric). При алфавитном обозначении блоков первый элемент микросхемы
DD1 будет именоваться DD1A, при численном - DD1-1.
Второй способ ближе к российским стандартам, согласно которым секции
обозначаются как DD1.1. После заполнения полей окна создания компонента и
нажатия кнопки OK запускается редактор компонентов. Редактор компонентов
аналогичен редактору символов, за исключением того, что к специализированной панели инструментов добавились две кнопки для размещения выводов
(Pin).
С помощью кнопки или выбрав в меню Plase подменю Pin можно разместить один вывод. При выборе этого инструмента появляется меню (рис. 2.8),
позволяющее определить свойства вывода.
В поле Name задается имя вывода, Number - номер вывода, Width – ширина. Свойства Shape и Type описаны в таблицах 2.2 и 2.3.
Рис. 2.8 – окно свойств вывода
18
Форма вывода – Таблица 2.2
Тип выводов - Таблица 2.3
Для размещения массива выводов предусмотрена кнопка, соответствующая опции Pin Array меню Plase. Окно свойств массива выводов аналогично
окну одного вывода и представлено на рис. 2.9.
19
Рис. 2.9 – окно размещения массива выводов
При создании многосекционных компонентов, каковым является
1564ЛА3 (рис. 2.10), переход между секциями осуществляется с помощьюменю
View -> Next Part или Previous Part.
Рис. 2.10 – секции А и В микросхемы 1564ЛА3 (74НС00)
Некоторые выводы, например питание, могут быть общими, для этого все
секции создаются с этими выводами, при этом они должны иметь одинаковые
номера и названия. Отображение имен и номеров выводов, а также другие параметры компонента можно настроить, выбрав в меню Options пункт Part
Properties (рис. 2.11).
20
Рис. 2.11 – окно свойств компонента
Задание на лабораторную работу
1. Создать проект типа Schematic.
2. Создать библиотеку с именем russian.olb.
3. Создать угловой штамп в соответствии с ГОСТ 2.104-68.
4. Создать указанные преподавателем компоненты: одноблочный и
многоблочный.
Контрольные вопросы
1. Создание библиотек.
2. Создание углового штампа.
3. Создание одноблочных компонентов.
4. Создание многоблочных компонентов.
21
Лабораторная работа №3
СОЗДАНИЕ ПРИНЦИПИАЛЬНЫХ ЭЛЕКТРИЧЕСКИХ СХЕМ
УЗЛОВ РЭС В САПР ORCAD
Цель работы
Научиться создавать и редактировать принципиальные схемы в редакторе
Capture.
Введение
Первым этапом при разработке электронного устройства является создание его принципиальной схемы.
Для этого в пакете OrCAD есть два редактора:
- Capture,
- Schematic.
Основным является Capture, на нем мы и сфокусируем наше внимание.
Редактирование схем формально можно представить как размещение на листе
схематических обозначений электронных компонентов (part) и соединение их
выводов проводниками (wire).
Проводники могут объединяться в шины (bus), для подключения к которым используются вводы (bus entry). Для объединения схем, состоящих из нескольких страниц, используются специальные соединители (off-page
connector). Соединение двух проводников обозначают точкой (junction). Для
иерархический схем используются порты (port).
Кроме элементов схемы и их соединений на листе может присутствовать
поясняющий текст (text) и вспомогательная графика, состоящая из прямых
(line) и ломаных (polyline) линий, прямоугольников (rectangle), эллипсов
(ellipse) и дуг (arc).
Для графических элементов можно задавать стиль и цвет образующих их
линий аналогично тому, как это делалось в редакторе символов и компонентов.
Создание схем в Capture
Прежде чем приступить к редактированию схемы, рассмотрим организацию многооконного интерфейса Capture. В Capture можно выделить три типа окон (рис. 3.1).
22
Рис. 3.1 – оконный интерфейс редактора Capture
1. Окно менеджера проекта (Project manager), которое имеет две вкладки: файл (File) и иерархия (hierarchy).
Для простых проектов вкладка иерархия малоинформативная, поскольку
содержит ссылку на одну схему. Во вкладке файл можно посмотреть ресурсы
проекта (Design Resources), в которые входят схема и библиотеки, выходные
данные и ресурсы PSpice. Папка схемы содержит две вложенные папки: SCHEMATIC1, Design Cache.
В папке SCHEMATIC1 находятся страницы схемы PAGE1 и т.д. Если
открыть PAGE1, появится окно редактора схем.
2. Окно редактора схем предназначено для создания и редактирования схем проекта. Слева от окна редактора, когда редактор активен, расположена панель инструментов.
3. Окно текстового редактора предназначено для редактирования и просмотра текстовых файлов. В нем отображается Session log, который также можно открыть из меню Window.
В новом проекте схема по умолчанию называется SCHEMATIC1, и содержит одну страницу с именем PAGE1. С помощью менеджера проекта можно
изменить название схемы и ее страниц.
Размещение компонентов схемы
Чтобы поместить компонент на лист, можно нажать кнопку, которая располагается на панели инструментов, или в меню Place выбрать Part, а также
используя сочетанием клавиш Shift + P.
При этом появится окно выбора компонента (Place Part) (рис. 3.2).
23
Рис. 3.2 – окно выбора компонента
Название компонента можно ввести в окно Part или выбрать из списка
Part List.
В списке отображаются компоненты из выделенных библиотек списка
Libraries. Если какой-либо библиотеки не достает, ее можно добавить с помощью кнопки Add Library, ненужные библиотеки можно удалить с помощью
кнопки Remove Library, предварительно их выделив.
Если не известно, в какой библиотеке находится требуемый компонент,
нужно использовать поиск. Окно поиска (рис. 3.3) вызывается нажатием кнопки Part Search.
24
Рис. 3.3 – окно поиска компонентов
В поле Part Name вводится имя компонента. Допускается использование
шаблонов, при этом знак "?" заменяет один символ, а "*" любое количество
символов.
В поле Library Path указывается путь к папке с библиотеками Capture.
Для начала поиска нужно нажать кнопку Begin Search.
Если компонент, имя которого удовлетворяет запросу, найден, библиотеки, в которых он найден, будут показаны в окне Libraries. Здесь же можно выбрать нужный компонент и нажав кнопку OK перейти к окну выбора компонентов (рис. 3.2). Символическое изображение выбранного компонента отображается в нижнем правом углу окна.
Ниже можно видеть две пиктограммы, свидетельствующие о том, что для
данного компонента указан корпус, который будет использоваться в редакторе
печатных плат, и модель PSpice.
Для компонентов, состоящих из нескольких функциональных элементов, в меню Packaging можно указать секцию.
После того как нужный элемент выбран и нажата кнопка OK, в редакторе схем появляется его контурное изображение, которое перемещается
в требуемое место (рис. 3.4).
25
Рис. 3.4 – размещение компонентов на листе
Повернуть изображение можно с помощью контекстного меню, которое
появляется по щелчку правой кнопки мыши, или при нажатии на клавишу R.
Можно зеркально отобразить элемент по вертикали (клавиша V) или горизонтали (клавиша H). Те же действия доступны для уже размещенных на
листе компонентов. Размещение подтверждается нажатием левой кнопки мыши.
Чтобы выйти из режима размещения выбранного элемента, нужно в контекстном меню выбрать команду End Mode, выбрать другой инструмент, нажать Shift + E или Esc.
Изменение масштаба в окне редактора схем осуществляется аналогично
редактору компонентов.
Размещение компонентов схемы
Чтобы поместить компонент на лист, можно нажать кнопку , которая располагается на панели инструментов, или в меню Place выбрать Part, а также
используя сочетанием клавиш Shift + P.
При этом появится окно выбора компонента (Place Part) (рис. 3.2). Название компонента можно ввести в окно Part или выбрать из списка Part List.
В списке отображаются компоненты из выделенных библиотек списка
Libraries. Если какой-либо библиотеки не достает, ее можно добавить с помощью кнопки Add Library, ненужные библиотеки можно удалить с помощью
кнопки Remove Library, предварительно их выделив.
Если не известно, в какой библиотеке находится требуемый компонент,
нужно использовать поиск.
Окно поиска (рис. 3.3) вызывается нажатием кнопки Part Search.
В поле Part Name вводится имя компонента. Допускается использование
шаблонов, при этом знак "?" заменяет один символ, а "*" любое количество
символов.
В поле Library Path указывается путь к папке с библиотеками Capture.
Для начала поиска нужно нажать кнопку Begin Search.
26
Если компонент, имя которого удовлетворяет запросу, найден, библиотеки, в которых он найден, будут показаны в окне Libraries.
Здесь же можно выбрать нужный компонент и нажав кнопку OK перейти
к окну выбора компонентов (рис. 3.2). Символическое изображение выбранного
компонента отображается в нижнем правом углу окна.
Ниже можно видеть две пиктограммы, свидетельствующие о том, что для
данного компонента указан корпус, который будет использоваться в редакторе
печатных плат, и модель PSpice.
Для компонентов, состоящих из нескольких функциональных элементов,
в меню Packaging можно указать секцию.
После того как нужный элемент выбран и нажата кнопка OK, в редакторе
схем появляется его контурное изображение, которое перемещается в требуемое место (рис. 3.4).
Повернуть изображение можно с помощью контекстного меню, которое
появляется по щелчку правой кнопки мыши, или при нажатии на клавишу R.
Можно зеркально отобразить элемент по вертикали (клавиша V) или горизонтали (клавиша H).
Те же действия доступны для уже размещенных на листе компонентов. Размещение подтверждается нажатием левой кнопки мыши.
Чтобы выйти из режима размещения выбранного элемента, нужно в контекстном меню выбрать команду End Mode, выбрать другой инструмент, нажать Shift + E или Esc. Изменение масштаба в окне редактора схем
осуществляется аналогично редактору компонентов.
Соединение компонентов схемы
Разместив компоненты на листе, переходим к соединению их проводниками.
Режим размещения проводников можно включить: кнопкой , расположенной на панели инструментов, выбрав в меню Place -> Wire или с помощью
комбинации клавиш Shift + W.
Выходят из режима размещения проводников аналогично тому, как выходят из режима размещения компонентов. Если нужно отметить места соединения проводников (обычно точка соединения устанавливается автоматически),
пользуются: инструментом Place -> Junction или Shift + J.
В том случае, если требуется провести шину, используют: инструмент,
меню Place -> Bus или сочетание клавиш Shift + B.
Проводники подсоединяют к шинам с помощью отводов (Bus Entry) ,
меню Place -> Bus Entry или Shift + E.
Для лучшей читаемости схемы и правильного соединения цепей при подсоединении проводника к шине следует использовать:
инструмент размещения псевдонимов цепи (Net Alias) , меню Place ->
Net Alias илиShift + N.
27
В окне размещения в поле Alias указывается псевдоним цепи, ниже можно выбрать цвет текста, шрифт и поворот текста.
Вращать текст можно и после размещения текста аналогично вращению компонентов.
БИБЛИОГРАФИЧЕСКИЙ СПИСОК
Основная литература
1. Основы автоматизированного проектирования: [Электронный
ресурс]:Учебник / Под ред. А.П.Карпенко - М.: НИЦ ИНФРА-М, 2015. - 329 с.–
ЭБС "Знаниум".
2. Левицкий, А. А. Проектирование микросистем. Программные
средства обеспечения САПР [Электронный ресурс] : Учеб. пособие / А. А.
Левицкий, П. С. Маринушкин. - Красноярск : Сиб. федер. ун-т, 2010. – 156 с. –
ЭБС "Знаниум".
Дополнительная литература
3. Зольников, В. К. Автоматизация проектирования электронной
компонентной базы [Электронный ресурс] : электронный учебник / В. К.
Зольников, В. В. Лавлинский, В. А. Смерек ; В. К. Зольников, В. В. Лавлинский,
В. А. Смерек; ВГЛТА. - Воронеж, 2012.
4. Зольников, В. К. Программирование на языке VHDL [Электронный
ресурс] : учебное пособие для направления 230200.62 Информационные
системы и 230.400.62 Информационные системы и технологии / В. К.
Зольников, В. В. Лавлинский, В. А. Смерек ; В. К. Зольников, В. В. Лавлинский,
В. А. Смерек; ВГЛТА. - Воронеж, 2013.
5. Руководство по САПР. Cadence.
28
Лавлинский Валерий Викторович
Зольников Константин Владимирович
Скворцова Татьяна Владимировна
Евдокимова Светлана Анатольевна
ИНТЕГРАЦИЯ СРЕДСТВ САПР
Методические указания для лабораторных работ
по направлению подготовки
09.04.02 – Информационные системы и технологии
(уровень магистратуры)
Редактор
Подписано в печать
. Формат 60×90 /16. Объем
п. л.
Усл. печ. л. . Уч.-изд. л.
. Тираж экз. Заказ
ФГБОУ ВО «Воронежский государственный лесотехнический
университет имени Г.Ф. Морозова»
РИО ФГБОУ ВО «ВГЛТУ». 394087, г. Воронеж, ул. Тимирязева, 8
Отпечатано в УОП ФГБОУ ВО «ВГЛТУ»
394087, г. Воронеж, ул. Докучаева, 10
Документ
Категория
Без категории
Просмотров
4
Размер файла
924 Кб
Теги
интеграция, средств, сапр
1/--страниц
Пожаловаться на содержимое документа