close

Вход

Забыли?

вход по аккаунту

?

laba 1 Vosstanovlen

код для вставкиСкачать
 МІНІСТЕРСТВО ОСВІТИ І НАУКИ МОЛОДІ ТА СПОРТУ УКРАЇНИ
ХМЕЛЬНИЦЬКИЙ НАЦІОНАЛЬНИЙ УНІВЕРСИТЕТ
Кафедра радіотехніки та зв'язку
Лабораторна робота №1
з дисципліни "Радіоелектроні системи"
Виконала:
ст. гр. РТ-10-2
Стецюк І.В.
Перевірив:
Чесановський І. І.
Хмельницький 2013 Лабораторна робота №1
Ознайомлення з універсальними системами математичних розрахунків MathCAD та MatLab
Мета роботи:
Вивчення основ роботи із програмою Mathcad i MatLab. Освоєння мови систем. Керування обчислювальним процесом. Побудова і форматування графіків. Виконання символьних операцій.
Основні теоретичні відомості
Основні теоретичні відомості
Призначення системи Mathcad
Система Mathcad по праву називається сучасною універсальною масовою математичною системою для всіх користувачів. Відмітною рисою інтегрованих математичних систем Mathcad, розроблювачем яких є фірма Mathsoft (США), є підготовка документів, у яких поєднуються задання вихідних даних, математичний опис їх обробки і результати обчислень у вигляді числових даних, таблиць і графіків. В Mathcad вдало вирішена проблема передачі змін числових даних по всьому ланцюжкові обчислень. Текст документа Mathcad майже нічим не відрізняється від тексту наукових статей. Графічне середовище програми дозволяє записувати математичні формули у звичному вигляді. З появою Mathcad студенти, аспіранти, інженери і вчені одержали у свої руки чудовий інструмент для повсякденної роботи. Для навчання роботі із системою фірма Mathsoft пропонує набір коротких прикладів розв'язку типових математичних завдань. Тому поряд з електронними книгами по розрахунках (Booksampler) і інтерфейсу (Desktop Reference) і самоучителем (Tutorial) Mathcad містить безліч коротких прикладів - шпаргалок (Quicksheet).
Mathcad є повноцінним Windows додатком із вбудованими засобами обміну і підтримує технологію OLE. Цей пакет має природню вхідну мову представлення математичних залежностей і інструменти для їхнього набору. Система дозволяє виконувати як чисельні, так і аналітичні (символьні) обчислення, має надзвичайно зручний математично інтегрований інтерфейс і прекрасні засоби наукової графіки. Вбудований текстовий процесор дозволяє оформити текст документа без застосування Word. Користувач створює програму засобами текстового, формульного й графічного редактора, а система Mathcad сама становить програму, яка раниться в ОЗУ, доти, поки не буде збережена у файлі з розширенням MCD або RTF. Mathcad призначений, зокрема, для * проведення розрахунків з дійсними і комплексними числами; * розв'язку лінійних та нелінійних рівнянь і систем рівнянь; * спрощення, розгортання і груповання виразів; * транспонування, обертання матриць, обчислення визначника; * побудови двовимірних і тривимірних графіків; * оформлення науково-технічних текстів, що містять складні формули; * диференціювання і інтегрування, аналітичного і чисельного; * проведення статистичних розрахунків і аналізу даних.
Робоче місце системи Mathcad
Робочий простір Mathcad складається з рядка заголовка, у якому перебуває ім'я документа за замовчуванням (Untitled:1), рядка меню; панелей інструментів, рядка стану. Настроювання рабочого простору здійснюється командами меню Вид. Вікно документа пунктирною лінією розділене на дві частини. Права частина (недрукуєма) використовується для складних допоміжних розрахунків, і її розмір по горизонталі перевищує видиму на экрані область У системі Mathcad можна працювати одночасно з 8-ю документами, перемикання між відкритими документами здійснюється за допомогою меню Вікно. Кожний документ представляється сукупністю областей у вигляді блоків прямокутної форми (текстових, графічних, формульних, табличних). Mathcad виконує обробку блоків у строго певному порядку: ліворуч праворуч і зверху вниз, враховуючи й усі блоки в правій частині документа. Тому перекриття блоків не допускається. У математичному процесорі Mathcad закладений послідовний принцип розрахунків: значення всіх змінних, які використовуються в математичному вираженні, повинні бути визначені лівіше і (або) вище тих виразів, де вони використовуються (за винятком глобальних змінних).
Математичні області з'являються при клацанні мишею на вільному місці виникаючий червоний хрестик фіксує місце введення формули. Текстові області створюються натисканням кнопки з буквою А на панелі інструментів. Області на екрані легко можна перетаскувати мишею або мереміщувати командами меню Виправлення.
Система Mathcad може працювати у двох основних режимах: автоматичному ( за замовчуванням) і ручному. Щоб уникнути перерахування результатів на екрані при кожній внесеній зміні, треба відключити команду Математика/Автоматичний режим. При відключеному автоматичному режимі для відновлення результатів потрібно натискати <F9>. Іноді виникає необхідність відключити обчислення в конкретному формульному блоці. Для цього треба на ньому клацнути й виконати команду Математика/Відключити вираження. Для переривання обчислень натискається < Esc >. Натискання <F9> відновляє їх.
Покажчик миші використовується, щоб розміщати курсор Mathcad у документі. Курсор приймає три різні форми: візир (червоний хрестик), маркер введення (синя вертикальна риска), виділяюча рамка (прямокутник або дві сторони прямокутника, що охоплюють вираз або його частину). Яка із трьох форм буде використана, залежить від того, на якому об'єкті виконане клацання мишею. рамка, що виділяє, натисканням клавіші Стрільця вниз перетворюється в маркер уведення, яке переміщається по вираженню за допомогою клавіш керування курсором. Маркер введення натисканням клавіші Стрілка нагору перетворюється в виділяюючу рамку. Усе, що попадає в цю рамку, стає операндом наступного вираження.
Щоб виділити область цілком або кілька областей, треба клацнути поруч із областю, і втримуючи натиснутої ліву кнопку миші, переміщати мишу доти, поки прямокутник, що виділяє не охопить усі області. Виділені області можна переміщати за допомогою миші, копіювати й вставляти, видаляти, використовуючи команди меню Виправлення. Дійсні розміри областей документа більше гаданих. Щоб побачити дійсні розміри треба виконати команду Виправлення/Області/Показати області. Якщо області перекриваються, можна виділити їх і перетягнути в різні сторони або вибрати команду Виправлення/Області/Розділити області.
Вхідна мова системи Mathcad
Система Mathcad має спеціалізовану мову програмування надвисокого рівня, орієнтованим на математичні розрахунки. Від користувача Mathcad вимагає, насамперед, коректного опису алгоритму розв'язку математичного завдання вхідною мовою, дуже нагадуючою загальноприйняту мову опису математичних і науково-технічних розрахунків. Алфавіт вхідної мови системи містить рядкові і прописні латинські та грецькі букви, арабські цифри, спеціальні знаки і слова, які використовуються при заданні команд. До типів даних Mathcad відносяться числові константи, звичайні і системні змінні, масиви (вектори й матриці), дані файлового типу.
Числові константи вводяться за допомогою арабських цифр, знаку мінус і десяткової крапки (а не коми!). Порядок числа вводиться множенням мантиси на 10 у ступені, що визначає порядок. Знак множення (клавіша *) при виводі числа на екран міняється на крапку, а операція зведення в ступінь (клавіша ^) відображається представленням порядку у вигляді надрядкового елемента. Система може працювати з десятковими, восьмеричними і шістнадцятирічними числами. Останні наприкінці позначаються латинськими буквами o (octal) або h (hexagonal). Комплексні числа звичайно представляються в алгебраїчному виді. Перед використанням будь-яких операцій з комплексними числами корисно спочатку визначити i або j як уявну одиницю ( тобто привласнити їм значення квадратного кореня з -1). При введенні комплексного числа уявна частина повинна бути помножена на уявну одиницю.
Розмірні константи - це особливий тип констант, який крім числового значення характеризується вказівкою на те, до якої фізичної величини вони відносяться. Щоб прикріпити до імені змінної або константи одиницю вимірювання, треба просто помножити ім'я або константу на відповідну одиницю. Натисканням клавіш <Ctrl>+<U> викликається діалогове вікно Вставити одиниці, у якому представлені всі доступні в обраній системі одиниці вимірювання. Проведення розрахунків з розмірними величинами і змінними особливо зручно при розв'язку різних фізичних завдань, коли правильна розмірність результату є додатковим чинником коректності виконаних розрахунків.
Змінні це іменовані об'єкти, що мають деяке значення, яке може змінюватися по ходу виконання програми. Ідентифікатори (імена змінних і констант) у системі Mathcad повинні починатися обов'язково з букви і можуть мати практично будь-яку довжину. Для того щоб можна було обчислити вираз, що залежить від яких-небудь змінних, значення цих змінних повинні бути визначені. Для визначення (задання) змінної в програмі потрібно: * ввести ім'я змінної;
* ввести двокрапку ":", що приведе до появи знака присвоювання ":=" і наступного за ним поля введення;
* надрукувати в поле введення число або вираз;
* Mathcad обчислить відповідне значення і привласнить його імені змінної.
Усі змінні і функції, що присутні в уведеному виразі, повинні бути визначені заздалегідь. А якщо ні, то змінні, значення яких не визначені до моменту обчислення виразу, будуть відзначені на екрані червоним кольором.
Для того щоб одержати числовий результат (значення константи або змінної), потрібно ввести відповідний ідентифікатор і потім ввести знак рівності "=". Після цього Mathcad обчислює вираз і виводить результат обчислень. Для задання формату числових даних, модифікації і заміни шрифтового оформлення математичних виразів використовується команда Математика/Формат числа.
Використання незаданої змінної є помилкою, яку необхідно виправити для продовження обчислень. Змінна в Mathcad може бути: * локальною (знак локального присвоювання ); використання локальної змінної можливе тільки в нижче розташованих блоках; * глобальної (знак глобального присвоювання (); глобальне присвоювання може проводитися в будь-якому місці документа.
Mathcad, обробляючи документ, прочитує його двічі, рухаючись щораз ліворуч праворуч і зверху вниз. При першому проході Mathcad виконує всі дії, запропоновані глобальним оператором присвоювання ''. При другому проході Mathcad виконує всі дії, запропоновані локальним оператором присвоювання ':=', і відображає всі необхідні результати обчислень. Кожне вираження має крапку прив'язки. Mathcad використовує крапки прив'язки, щоб визначити порядок проходження виражень. Щоб побачити точки прив'язки, треба виконати команду Виправлення/Області /Показати області.
Система Mathcad містить розширений набір вбудованих елементарних функцій. Функції задаються своїм іменем і значенням аргументів у круглих дужках. У відповідь на звертання до них функції повертають обчислені значення (числове, символьне, матриця або вектор). Аргумент і значення функцій можуть бути дійсними або комплексними числами. Кожну із вбудованих функцій можна помістити в робочий документ за допомогою діалогового вікна, що викликається командою Вставити функцію. Нижче наведений перелік розділів, по яких класифікуються різноманітні функції, вбудовані в Mathcad:
* бесселєві функції * ймовірнісні розподіли * гіперболічні функції * доступ до файлів * задання умов * інтегральні перетворення * інтерполяція * моделювання або наближення даних * зворотні гіперболічні функції * зворотні тригонометричні функції * округлення і відсікання * побудова гістограм * робота з векторами і матрицями * робота з комплексними числами * розв'язок рівнянь * сортування * стандартні статистики * тригонометричні функції * експонента і логарифми * розривні функції Для того щоб визначити в Mathcad функцію користувача, потрібно:
* ввести в активний документ ім'я функції і ліву круглу дужку;
* ввести через кому аргументи і завершити введення правою дужкою;
* ввести двокрапку ":", що приведе до появи знака присвоювання ":=" і поля введення;
* ввести в поле введення вираз. Функція може задаватися локально або глобально. Усі змінні, що використовуються у виразі в полі введення, повинні бути або визначені заздалегідь, або входити в список аргументів. А якщо ні, то змінні значення, що не мають, будуть відзначені червоним кольором. Ранжирувані змінні представляють в Mathcad особливий клас змінних, які заміняють керуючі структури (цикли). Ці змінні мають ряд фіксованих значень чисел, що змінюються від початкового до кінцевого значення з певним кроком. Ранжирована змінна фактично є векторною величиною, що займає відповідний об'єм пам'яті. І в цьому її відмінність від скалярної змінної. Ранжована змінна цілочисельного типу із кроком 1 або -1 створюється виразомм: ім'я:=ПочЗнач..КінЗнач. Тут символ ".." вводиться клавішею <;>. У загальному випадку використовується повне вираження: ім'я:=ПочЗнач,ПочЗнач+Крок..КінЗнач.
Дискретні змінні найчастіше використовуються при побудові графіків функцій. Визначте дискретний аргумент, що пробігає діапазон значень незалежної змінної, по яких потрібно побудувати графік функції. Натисніть клавішу @, щоб створити область декартового графіка. Помістіть ім'я дискретного аргументу в шаблон на осі Х, а ім'я функції від дискретного аргументу в шаблону на осі Y.
Масив - це сукупність кінцевої кількості числових або символьних елементів що має ім'я, упорядкованих по рядках і стовпцям, що мають певні адреси в пам'яті. Елементи матриць (двовимірних масивів) і векторів (одномірних масивів) є індексованими змінними, імена яких збігаються з іменами матриць. Для присвоєння i- ому елементу вектора До деякого значення, наприклад, К2 := 5 послідовно натискаються клавіші: К [2:5. Для присвоєння значення елементу матриці наприклад, К23 := 5 послідовно натискаються клавіші: ДО [(2,3):5.
Файлові дані Mathcad - це масиви, які можуть бути записані на згадку у вигляді файлу. У ході створення файлу елементи матриць зчитуються поелементно ліворуч праворуч і зверху вниз. Для створення файлу використовується функція WRITE (ім'я файлу), а для зчитування файлу даних функція READ (ім'я файлу).
Системні змінні мають визначені системою початкові значення, які користувач при необхідності може перевизначити. Визначені математичні постійні: * число  ( клавіші <Ctrl+P>);
* системна нескінченність  ( клавіші <Ctrl+Z>);
* число е (основа натурального логарифма);
* уявна одиниця i або j ( потрібно вводити 1i або 1j, а не i або j);
* відсоток % (рівняється 0.01 і призначений для зручності роботи з відсотками).
Визначені системні постійні:
* TOL = 0.001. Визначає точність обчислення інтегралів, похідних, а також розв'язків, що вертаються блоками розв'язку рівнянь. Дуже маленькі значення TOL приводять до збільшення часу обчислень, пов'язаних з ітеративними процедурами; більші значення TOL зменшують час обчислень за рахунок точності.
* ORIGIN = 0. Визначає індекс, з якого починають нумеруватися стовпці й рядка в масивах. Щоб змінити значення за замовчуванням, виберіть команду Математика/Вбудовані змінні. Можна встановити значення ORIGIN рівним будь-якому цілому числу, позитивному або негативному. Значення ORIGIN буде впливати на будь-який масив у робочому документі;
* PRNPRECISION = 4. Визначає число значущих цифр числа, записуваних у файл функцією WRITEPRN (може бути цілим числом між 1 і 16);
* PRNCOLWIDTH = 8. Визначає ширину стовпця в ASCII файлі, створюваному функцією WRITEPRN (може бути цілим числом між 1 і 132).
Підготовка обчислювальних блоків у системі Mathcad полегшує завдяки виводу шаблону при завданні того або іншого оператора. Шаблони вводяться натисканням відповідних кнопок на наявних панелях інструментів:
* Арифметичні оператори * Оператори математичного аналізу * Логічні оператори * Векторні й матричні оператори У складі складних шаблонів є шаблони для введення окремих даних. Вони мають вигляд чорних квадратиків, по яких можна переміщатися клавішею <Tab>. Символьні обчислення
Системи комп'ютерної алгебри забезпечуються спеціальним процесором для виконання аналітичних (символьних) обчислень. Його основою є ядро, що зберігає всю сукупність формул і формульних перетворень, за допомогою яких і проводяться аналітичні обчислення. Ядро символьного процесора Mathcad є спрощеним варіантом ядра відомої системи символьної математики Maple V. Існують два способи проведення символьних перетворень виражень:
1. використання символьного знака рівності (вводиться комбінацією клавіш Ctrl+=) для безпосереднього одержання символьних результатів; цей спосіб дуже схожий на проведення чисельних викладень і існує тільки в Mathcad PLUS.
2. використання команд меню Символіка; цей спосіб дозволяє більш точно управляти формою результатів символьних обчислень.
Усі команди символьного меню працюють приблизно однаково. Для виконання символьної операції необхідно виділити преутворене вираження частково або цілком. Для ряду операцій досить не виділяти весь вираз, а тільки вказати змінну, щодо якої потрібно виконати перетворення. Для цього маркер введення повинен розташовуватися правіше змінної. Потім вибрати відповідну команду з меню Символіка.
Mathcad виводить перетворене вираження в активний документ. Залежно від установленого способу розташування результату Mathcad або заміщає виділене вираження, або поміщає нове вираження праворуч або знизу від вихідного. Якщо символьне перетворення не вдалося, то нове вираження збігається зі старим. Потрібно відзначити, що отримані з використанням команд меню Символіка результати перетворень не міняються при внесенні змін у документ. Команди меню Символіка дозволяють виконати наступні обчислення:
1. символьна алгебра (спрощення, розкриття дужок, розкладання на множники, приведення подібних членів, визначення коефіцієнтів багаточлена, ряди, елементарні дроби, символьні суми і добутки);
2. символьні дії аналізу (похідні, інтеграли, границі);
3. символьний розв'язок рівнянь (розв'язок рівнянь, розв'язок системи рівнянь);
4. символьні дії з матрицями (матрична алгебра, транспонування матриці, обертання матриці, визначник матриці);
5. символьні перетворення (перетворення Фур'є, Лапласа, z-перетворення доступні тільки в Mathcad PLUS).
Робота із графікою в Mathcad
Програмний графічний процесор, вбудований в Mathcad, створює графіки, більшість параметрів яких задаються за замовчуванням. Тому для побудови графіка досить вказати його тип: декартовий, полярний, графік поверхонь, контурний графік, точковий, векторне поле або тривимірна гістограма.
Для створення декартового графіку треба нажати клавішу @ і заповнити поле введення для кожної з осей. Для заповнення поля введення по ньому треба клацнути. Для одночасної побудови двох і більш графіків треба після заповнення шаблону даних для осі Y нажати клавішу з комою і заповнити другий шаблон, що з'явився, і т.д. Щоб побудувати графік, треба нажати клавішу <F9>, або клацнути за межами графіка. Для видалення графіка треба клацнути на графіку, щоб виділити його, і потім нажати клавіші <Ctrl+X>. Для переміщення графіка треба укласти його в пунктирний, що виділяє прямокутник і потім перетягнути мишею, або вирізати й вставити графік на нове місце. Для зміни розміру графіка треба перемістити покажчик миші на праву або нижню границю пунктирний рамки. Коли покажчик змінить свій вид на двонаправлену стрілку, можна змінити розмір графіка.
Щоб змінити границі чисел на осях графіка, встановлені в Mathcad за замовчуванням, треба клацнути в графіку в поле введення для границь на осях і ввести нові значення для кожної осі у відповідні поля введення. Далі нажати клавішу <F9>, щоб заново відобразити графік. Для форматування графіка треба двічі клацніть мишею на графіку й вибрати в діалоговому вікні, що відкрилося, потрібну вкладку. Тут можна встановити лінійний або логарифмічний масштаб осей, лінії сітки з нумерацією або без неї, тип осей, змінити вид ліній.
Для створення тривимірної гістограми використовується команда Графіка/Тривимірна гістограма. Потім у єдине поле введення міститься ім'я матриці, яка буде відображатися у вигляді гістограми. Для форматування гистограммы треба клацнути двічі мишею на графіку. З'явиться діалогове вікно, що включає установки перегляду графіка й перетворення його в інший тип графіка.
Оформлення текстових областей документа Текст у документі може бути присутнім у двох формах: у формі текстових параграфів і текстових областей. Текстові параграфи більш зручні для більших фрагментів текстів, текстові області зручні для коротких пояснень. Вибір підходящої форми залежить від кількості тексту й від його бажаного вистави. Текстові області можуть мати довільну ширину й можуть бути розташовані в будь-якому місці документа. Текстові параграфи мають наступні властивості:
* розташовуються на всю ширину сторінки,
* дозволяють вирівнювати текст по заданому зразку,
* дозволяють визначити відступи для всіх рядків і для першого рядка,
* відсувають сусідні області в міру збільшення обсягу тексту.
Щоб створити текстовий параграф, треба клацнути в рядку, де немає інших областей і виконати команду Створити текстовий параграф. З'являться дві горизонтальні лінії, що відзначають займане параграфом місце. Лінії будуть продовжувати охоплювати, що вводиться текст і зникнуть, якщо клацнути мишею поза текстовим параграфом. Натискання <Enter> приведе до переходу на новий рядок усередині параграфа. Щоб створити текстову область, треба клацнути в потрібному місці й виконати команду Створити текстову область. З'явиться текстова рамка, яка в міру введення тексту буде збільшуватися. Для форматування текстової області треба клацнути в області і виконати команду Текст/Змінити формат параграфа. З'явиться діалогове вікно Властивості параграфа. Для введення в текстові коментарі математичних виражень треба клацнути усередині тексту, у який потрібно помістити математичну область, і виконати команду Текст/Впровадити формули. Установка параметрів сторінки при друкуванні документа, його попередній перегляд і печатання виконуються відповідними командами меню Файл. Для примусового переходу на нову сторінку треба виконати команду Вставити розрив сторінки.
Виконання лабораторної роботи
Перейдіть у документ Звіт_01. Задайте два числа (a, b), використовуючи формат представлення чисел із плаваючою крапкою, наприклад а:=9.345*10-3. Виведіть результати наступних арифметичних операцій із числами:
Задайте константу j як уявну одиницю. Задайте комплексні числа z1 = a + j b, z2 = b + j a. Виведіть значення суми, різниці, добутку, частки чисел z1 і z2. Виведіть значення модуля й аргументу (у рад. і в град.) комплексних чисел z1 і z2.
Для обчислення значень основних тригонометричних функцій задайте дійсну позитивно розмірну константу x, рад. Виведіть значення синуса, косинуса, тангенса, котангенса, секанса й косеканса x.
Задайте ранжирувану змінну r, що змінюється від -2 до +2 із кроком 0,025.
Побудуйте в декартових координатах на одному малюнку графіки двох тригонометричних функцій синуса і косинуса.
Задайте квадратну дійсну матрицю розміром 44. Елементи матриці - двухзначні десяткові числа, позитивні і негативні. Виконаєте обернення і транспонування матриці; виведіть її визначник, максимальне і мінімальне значення. Привласніть елементам матриці в першому 5, -9, 3,-7. Виведіть визначник матриці. Задайте цілочисельну ранжирувану змінну i, що змінюється від 0 до 10 із кроком 1. Виведіть суму і добуток елементів заданого вектора. Виведіть таблицю значень вектора і таблицю квадратів значень цього ж вектора.
Вправа 3. Побудова двовимірного графіка
Створіть новий документ і збережіть його в папці Студент під іменем Графік.mcd.
Задайте дві розмірні константи: U=100 В,  =0,001 с. Визначіть функцію виду h(t) = - U (1- exp{- t/}).
Для створення таблиці значень функції h (t) треба виконати дискретизацію аргументу t у діапазоні від нуля до 5. Крок дискретизації t визначається кількістю точок n у зазначеному інтервалі, включаючи граничні точки: t=5 /(n-1). Враховуючи це, задайте ранжировану змінну t1, якщо n=30.
Виведіть таблицю значень t1 і поруч таблицю значень h(t1)/В. Виділіть отримані табличні області і вирівняйте їх по горизонталі.
Побудуйте декартовий графік h (t1). Збережіть документ.
Вправа 4. Побудова тривимірного графіка поверхні
Створіть документ і збережіть його в папці Студент під іменем Графік поверхні.mcd. У цьому документі має бути визначена функція z(x, y). Далі представити її матрицею M ординат Z і побудувати графік тривимірної поверхні. Матриця M будується на сітці значень змінних x і y у прямокутнику, розміри якого задаються константами xmin, xmax, ymin, ymax. Крок дискретизації по осі X (x) визначається числом точок nx, а крок дискретизації по осі Y (y) визначається числом точок ny.
Визначите функцію z(x, y) = cos(x y)  sin(x y). Задайте константи xmin = -2, xmax = 2, ymin = -, ymax = , nx =40, ny =20.
Задайте цілочисельну ранжирувану змінну i, що змінюється від 0 до (nx -1) із кроком 1. Задайте целочисленную ранжирувану змінну j, що змінюється від 0 до (ny - 1) із кроком 1. Визначите дві змінні: x = (xmax - xmin)/( nx-1) і y = (ymax - ymin)/( ny-1).
Використовуючи поелементне формування (індексовані змінні), задайте вектор xd у вигляді: xdi = xmin + i x; і вектор yd у вигляді: ydj = ymin +j y.
Використовуючи поелементне формування матриці, задайте матрицю M у вигляді: Mij = z(xdi, ydj).
Виведіть матрицю M. Перегляньте її, використовуючи смуги прокручування.
Створіть тривимірний графік поверхні, введіть у шаблон даних ім'я матриці: M. Встановіть формат графіка поверхні з видаленням невидимих ліній функціональним зафарбуванням. Збільшіть розмір графіка і установіть використання кольорів. Збережіть документ.
У папці РЕС/Mathcad/Графіки перебувають 10 файлів з прикладами графічних можливостей системи Mathcad. Скопіюйте ці файли в папку Студент. Переглянете всі ці файли, по черзі, змінюючи в кожному з них параметри графіків.
Вправа 5. Аналітичні розрахунки
Створіть документ і збережете його в папці Студент під іменем Аналітика.mcd.
Введіть зазначені нижче вирази і для кожного з них виконайте символьне обчислення (команда Evaluate Symbolically). Для правильного виконання команди вираз повинен бути виділеним, тобто охоплене синьою рамкою.
Використовуючи символьну команду Simplify, спростіть наступні математичні вирази:
Використовуючи символьну команду Expand Expression, розкладіть по ступенях математичні вирази:
Вправа 6. Розв'язок системи лінійних рівнянь
Відкрийте документ Звіт_01.mcd. Задайте в матричному вигляді систему двох рівнянь із двома невідомими x1, x2. При цьому використовуйте матрицю А для задання значень коефіцієнтів системи, матрицю B для задання вільних членів. Знайдіть розв'язок системи у вигляді вектора X:
Змініть матриці А и В так, щоб досліджувати можливість розв'язку рівнянь із комплексними коефіцієнтами, наприклад:
Вправа 7. Аналітичний розв'язок системи рівнянь
У документі Звіт_01.mcd необхідно знайти розв'язок системи лінійних рівнянь у загальному вигляді. Для цього використовуються ключове слово given і функція find. Ознайомтесь з нижченаведеним прикладом і виконаєте аналогічне завдання в документі Звіт_01.mc. Збережіть документ.
Вправа 8. Розв'язок нелінійних рівнянь
У документі Звіт_01.mcd необхідно визначити корінь нелінійного рівняння x + x2 +x1/2 =4.75 з точністю 10-3, якщо x0 = 1,5.
Для цього введіть функцію f(x):= x + x2 +x1/2, далі необхідну точність TOL:= 10-3, потім початкове значення змінної х:= 1,5. Для розв'язку рівняння за допомогою функції root наберіть нижче: x1:= root(f(x),x). Після чого виведіть на екран значення x1, що є наближеним розв'язком заданого рівняння. Знайомство з системою комп'ютерної математики - математичною матричною лабораторією MATLAB(r).
Мета роботи:
Ознайомитися з основними елементами і складовими частинами системи комп'ютерної математики MatLab(r) і її робочим і програмним середовищем.
Теоретичні відомості
При запуску даного програмного продукту на екрані відкривається робоче вікно програми, зображене на рис. 1.
Рис. 1. Робоче середовище системи MATLAB.
Основними елементами робочого середовища є:
* меню;
* панель інструментів з кнопками і випадаючим меню;
* вікна з вкладками W orkspace і Current Directory для перегляду змінних та для встановлення робочого каталогу з використовуваними файлами-сценаріями і функціями;
* вікно Command W indow (аналог командної стрічки), призначене для введення команд і виведення результатів;
* вікно Command Hisory - для перегляду і повторного виконання раніше введених команд;
* рядок стану та кнопка Start.
При натисненні на кнопку Start відкривається меню, приклад якого зображ ено на рис. 2, з його допомогою забезпечується доступ до усіх основних засобів системи.
Рис. 2. Меню, яке відкривається при натисненні на кнопку Start.
Вікно Command W indow складається з наступних елементів:
* заголовка з назвою вікна і двома кнопками справа;
* робочої області з командною стрічкою, в якій знаходиться мигаючий вертикальний курсор;
* смуг прокрутки.
В полі назви кожного вікна, поряд з кнопкою закривання, знаходиться кнопка "Undock..." для витягування вікна з робочого середовища (якщо воно вбудовано), або кнопка "Dock..." для вбудовування окремого вікна в робоче середовище MATLAB.
При запуску пакету в робочій області вікна Command W indow з'являються два посилання: MATLAB Help і Demos - для виклику довідкової системи або демонстраційних прикладів.
Арифметичні обчислення
Вбудовані математичні функції дозволяють знаходити значення виразів будь-якої складності, причому для обчислень можна використовувати також мову сценаріїв системи, що є мовою програмування високого рівня.
Також система MATLAB(r) надає можливість управління форматом виведення результатів.
Найпростіші обчислення
Виберіть вигляд робочого середовища "по замовчуванню", наберіть в командному рядку 1+2 і натисніть <Enter>.
В результаті в командному вікні MATLAB(r) відобразиться наступне:
>> 1 + 2 ans =
3
>> |
Якщо обчислюваний вираз не присвоюється змінній, то створюється змінна ans (від слова answer - відповідь). Інформація про змінну ans відразу з'явилася у вікні Workspace (рис. 3.).
В першому стовпці Name записано ім'я змінної. Наступний стовпець Value показує значення змінної у вибраному для її відображ ення форматі. Вміст стовпця Size, по суті, демонструє основний принцип роботи MATLAB(r), яка всі дані представляє у вигляді масивів.
Змінна ans є двовимірним масивом розміром один на один і займає 8 байт пам'яті, про що свідчить стовпець Bytes.
І в останньому стовпці Class вказаний тип змінної - double array, тобто масив, що складається з чисел подвійної точності.
Будь-який стовпець мож на сховати або відобразити, якщо на назві вікна натиснути правою кнопкою мишки і викликати контекстне меню.
Рис. 3. Вікно Workspace з інформацією про використання змінних середовища.
Якщо необхідно продовжити роботу з попереднім виразом, наприклад, обчислити (1+2)/4.5, то найпростіше скористатися існуючим результатом, який зберігається в змінній ans. Після набору в командній стрічці ans/4.5 і натиснення клавіші <Enter>, отримаємо:
>> ans/4.5 ans = 0.6667
>> |
Значення змінної ans автоматично замінюється результатом обчислень.
Формат виведення результатів обчислень
Потрібний формат виведення результату визначається користувачем з меню робочого середовища MATLAB(r). Виберіть в меню File пункт Preferences. На екрані з'явиться діалогове вікно Preferences, зображене на рис. 4. В пункті Command Window задається формат із списку, що розкривається, Numeric format панелі Text display.
Рис. 4. Діалогове вікно Preferences.
Хід роботи
Використання елементарних функцій
Наприклад, необхідно обчислити наступний вираз:
>> exp(-2.5)*log(11.3)^0.3-sqrt((sin(2.45*pi)+cos(3.78*pi))/tan(3.3))
ans =
-3.2105
>> (2.1 + 3.2i)*2 + (4.2 + 1.7i)^2
ans =
18.9500 +20.6800i
>>
>> x=0:0.01:1;
y=exp(-x).*sin(10*x);
plot(x,y)
>>
Для побудови графіка функції в робочому середовищі MATLAB(r) повинні бути визначені два вектори однакових розмірів, наприклад x та y. Вектор x містить значення аргументів, а y - значення функції цих аргументів.
Команда plot з'єднує точки з координатами (x(i), y(i)) прямими лініями, автоматично масштабуючи осі для найкращого візуального розміщення графіка по осях.
Рисунок 5 - Графік функції
Якщо ж відображення графічного результату в системі за замовчуванням користувачу не підходить, можна параметри візуалізації задати індивідуально для кожного графіка, або налаштувати їх вже після відображення результату. Використовуючи кнопку Dock Figure (справа в стрічці меню вікна) можна вмонтувати графічне вікно в робоче середовище так, як це показано на рис. 6.
Порівняння декількох функцій зручно виконувати, якщо їх графіки відобразити в одній системі координат.
Для побудови графіків функцій і потрібно набрати наступну послідовність команд:
x = -1:0.005:-0.3;
>> f = sin(x.^-2);
>> g = sin(1.2*x.^-2);
>> plot(x, f, x, g)
Також з допомогою команди plot можна задати стиль та колір ліній, наприклад:
>> plot(x, t, 'k-', x, g, 'k:')
Аргументи 'k-' і 'k:' задають стиль і колір першої та другої ліній. Тут k означає чорний колір, а дефіс або двокрапка - неперервну або пунктирну лінію
Рис. 6 - Два графіка на одних осях
Файли-функції
Для вирішення обчислювальних задач і написання власних застосувань в MATLAB(r) часто потрібно реалізовувати функції користувача, які здійснюють необхідні дії з вхідними аргументами і повертають результат обчислень. Кількість вхідних і вихідних аргументів залежить від задачі, що вирішується - може бути тільки один вхідний і вихідний аргумент, а може бути декілька вхідних і вихідних, або ж тільки вхідні аргументи. Вхідними аргументами і вихідними даними можуть бути масиви даних довільної розмірності.
Файли-функції з одним аргументом
Реалізувавши один раз файл-функцію, далі можна її використовувати всюди, де необхідно провести потрібні обчислення для заданого аргументу, але для цього файл повинен бути розміщений в робочому каталозі системи.
Відкрийте в редакторі М-файлів новий файл і наберіть наступне: function f = myfun(x)
f = exp(-x)*sqrt((x^2 + 1)/(x^4 +0.1));
Слово function в першій стрічці визначає, що даний файл містить функцію.
Перша стрічка є заголовком функції, в якій знаходяться ім'я функції і списки вхідних і вихідних аргументів. Вхідні аргументи записуються в круглих дужках після імені функції. Вихідний аргумент f вказується зліва від знаку "рівно" в заголовку функції. При виборі імені файла необхідно пам'ятати, що воно повинне співпадати із назвою функції, для якої цей файл реалізовано. Також потрібно потурбуватися про уникнення конфліктів з зайнятими іменами функцій системи MATLAB(r).
Після заголовку розміщується тіло функції - один або декілька операторів, які реалізовують алгоритм отримання значення вихідних змінних з вхідних. Перед запуском файлу потрібно його зберегти в робочому каталозі (File → Save або File → Save as...).
Тепер створену функцію можна використовувати так само, як і вмонтовані sin, cos і інші, наприклад:
>> y=myfun(5)
y =
0.0014
Робота файл-функції з масивом даних
Якщо записати: function f = myfun(x)
f = exp(-x).*sqrt((x.^2 + 1)./(x.^4 +0.1));
то тепер аргументом функції myfun може бути як число, так і вектор чи матриця значень, наприклад:
>> x=[1.3 7.2];
>> y=myfun(x) y =
0.2600 0.0001
Змінна y, в яку записується результат виклику функції myfun, автоматично стає вектором потрібного розміру.
Для того, щоб побудувати графік на відрізку [0, 4] з допомогою файлу- сценарію програми або з командної стрічки необхідно набрати:
>> x=0:0.5:4;
>> y=myfun(x);
>> plot(x,y) або
fplot('myfun',[0 4])
а)в)
Рис. 7 - Порівняння plot і fplot
Оператори ц иклу
Схожі і повторювані дії виконуються з допомогою операторів циклу for та while. Цикл for призначений для виконання заданої кількості дій, що повторюються, while - для дій, кількість яких наперед невідома, але відома умова виконання і закінчення циклу.
Цикл for
Використання for здійснюється наступним чином: for count = start:step:final
команди MATLAB end
Тут count - змінна циклу, start - її початкове значення, final - кінцеве значеня, а step - крок, на який збільшується count при кож ному наступному заході у цикл.
Цикл закінчується, як тільки значення count стає більше ніж final. Змінна циклу мож е приймати не тільки цілі числа, а й дійсні значення з будь-яким знаком. Наприклад, для виводу графіків кривих для , яке задано функцією , що залеж ить віл параметра а, для значень параметра а від -0,1 до 0,1 з кроком 0,002. В редакторі М-файлів потрібно набрати код:
figure %
x = 0:pi/30:2*pi; % for a = -0.1:0.02:0.1
y = exp(-a*x).*sin(x); % hold on;
plot(x, y); end
Рис. 9. Сімейство кривих Цикл while
Документ
Категория
Рефераты
Просмотров
149
Размер файла
504 Кб
Теги
vosstanovlen, laba
1/--страниц
Пожаловаться на содержимое документа