close

Вход

Забыли?

вход по аккаунту

?

CPP LW

код для вставкиСкачать
Лабораторная работа №1
Тема работы: главное окно программы.
Цель работы: проектирование интерфейса главного окна программы.
Домашнее задание: изучить визуальные компоненты TForm, TMainMenu, TPopupMenu, TStatusBar, а также глобальный класс TApplication.
Порядок выполнения работы
1. Создать главную форму программы со следующими свойствами:
* окно формы должно быть изменяемых размеров, содержать кнопки системного меню и появляться в центре экрана;
* заголовок окна формы должен содержать Ф.И.О. студента;
* окно формы должно иметь пиктограмму, отличную от пиктограммы по умолчанию (см. рис. 1.1).
2. Разместить на форме визуальный компонент типа TMainMenu (главное меню). Создать главное меню программы из пяти пунктов (элементов) со следующими названиями: "Данные", "Вычисления", "Результаты", "Справка", "Выход" (предусмотреть клавиши быстрого выбора для всех пунктов меню).
Рис. 1.1
3. Разместить на форме визуальный компонент типа TPopupMenu (вспомогательное меню) с тремя элементами без названия.
4. Разместить на форме визуальный компонент типа TStatusBar (панель состояния) и расположить его вдоль нижней границы формы.
5. Создать обработчик события OnActivate формы, в котором присвоить названиям элементов вспомогательного меню названия соответственно первых трёх элементов главного меню.
6. Создать обработчик события OnClick элемента главного меню "Выход", который закрывает окно формы и завершает работу программы.
7. Создать обработчики события OnClick элементов главного меню "Данные", "Вычисления", "Результаты", в которых вывести на панель статуса (объект типа TStatusBar) названия соответствующих элементов (пунктов) главного меню.
8. Создать обработчики события OnClick элементов вспомогательного меню, в которых обеспечить вызов соответствующих обработчиков события OnClick элементов главного меню с совпадающими названиями.
9. Сохранить проект в личной папке под уникальным именем. Расположение папки согласовать с преподавателем.
10. Откомпилировать и запустить программу.
11. Изучить работу программы при управлении мышью и клавиатурой.
12. Изучить приёмы отладки программы.
13. Ответить на контрольные вопросы.
Контрольные вопросы
1. Структура проекта программы на BC++ Builder.
2. Как установить на форму визуальный компонент?
3. Для чего нужен инспектор объектов (Object Inspector)?
4. Как установить пиктограмму и заголовок для программы, формы?
5. Как управлять программой при помощи мыши, клавиатуры?
6. Структура модуля BC++ Builder.
7. Как управлять объектами на этапе выполнения программы?
8. Как спроектировать главное меню программы?
9. Как спроектировать вспомогательное меню программы? 10. Как запрограммировать поведение приложения при запуске и завершении работы программы?
Лабораторная работа №2
Тема работы: ввод данных.
Цель работы: использование визуальных компонентов для ввода и отображения данных.
Домашнее задание: изучить файловый ввод/вывод, а также визуальные компоненты TEdit, TMemo, TCheckBox, TListBox, TComboBox, TRadioButton, TRadioGroup, TStringGrid, TTrackBar, TUpDown, TButton, TBitBtn, TCSpinEdit.
Порядок выполнения работы
1. Добавить в проект учебной программы (см. лабораторную работу №1) модуль с формой с именем unData. Доработать обработчик события OnClick элемента главного меню "Данные". В обработчике создать и активизировать диалоговую модальную форму (окно) с именем fmData модуля unData. Форма должна создаваться в момент первого вызова обработчика события OnClick. Сформировать заголовок формы (свойство Caption), совпадающий с названием вызывающего элемента главного меню, а также обеспечить расположение формы на экране в центре родительской формы. Модуль unData должен обеспечивать выполнение следующих действий:
* считывание данных из дискового файла;
* ввод данных при помощи мыши и клавиатуры с проверкой правильности ввода;
* отображение данных;
* сохранение данных в дисковом файле.
Пример реализации модуля unData приведён на рис. 2.1.
Рис. 2.1
Предусмотреть "горячие" клавиши для активизации используемых визуальных компонентов. Типы визуальных компонентов для управления вводом/выводом взять из табл. 2.1 в соответствии с заданным вариантом. Тип файла взять из табл.2.2 в соответствии с заданным вариантом. Объём и характеристики данных взять из табл. 2.3 в соответствии с заданным вариантом. После закрытия формы fmData модуля unData очистить панель статуса главной формы.
2. Откомпилировать, запустить и протестировать программу.
3. Изучить работу программы при управлении мышью и клавиатурой.
4. Ответить на контрольные вопросы.
Таблица 2.1
№ вариантаТипы визуальных компонентов11, 324, 73641, 954, 261, 774, 381, 294, 5101, 4114, 8121, 5
В табл. 2.1 приняты следующие обозначения: 1 - TEdit, 2 - TCheckBox, 3 - TListBox, 4 - TComboBox, 5 - TRadioButton или TRadioGroup, 6 - TStringGrid, 7 - TTrackBar, 8 - TUpDown, 9 - TCSpinEdit.
Таблица 2.2
№ вариантаТип файла1Текстовый2Без типа Таблица 2.3
№ вар.ДанныеПараметр 1Параметр 2Параметр 3Параметр 4ИмяТипДиапа-зонИмяТипДиапа-зонИмяТипДиапа-зонИмяТипДиапа-зон1NsЦ.50-100NgЦ.1-16В.0.001-0.1В.0-0.12NsЦ.110-190NgЦ.1-19В.0-0.5Ц.1,23NsЦ.75,125,175NgЦ.1-21В.0.05-10---4NsЦ.100-150NgЦ.3-9В.0.005-0.5В.0.05-0.155NsЦ.75-225NgЦ.5,9,15,21В.0.001-0.25Ц.2,46NsЦ.50,125,175,250NgЦ.3,9,11,13В.0.1-10В.0.002-0.37NsЦ.150-200NgЦ.5-24В.0.01-1В.0.1-0.28NsЦ.50,150,200NgЦ.5,11,25В.0.1,1,
10В.0.0015-0.29NsЦ.50,100,150,200NgЦ.3-17В.0.1-5---10NsЦ.200-250NgЦ.1-32В.0.01-0.75В.0.15-0.25 Контрольные вопросы
1. Условный оператор.
2. Оператор переключатель.
3. Файловый ввод/вывод. Текстовые файлы.
4. Файловый ввод/вывод. Файлы без типа (двоичные файлы). Класс TFileStream.
5. Однострочный редактор текста.
6. Независимый переключатель.
7. Список выбора.
8. Комбинированный список выбора.
9. Зависимый переключатель, группа зависимых переключателей.
10. Таблица текстовых строк.
11. Управление целой величиной. 12. Кнопки.
13. Создание и активизация формы на этапе выполнения программы.
14. Обработка исключительных ситуаций.
Лабораторная работа №3
Тема работы: обработка данных.
Цель работы: изучение алгоритма вычисления дискретной свёртки.
Домашнее задание: изучить организацию циклов, а также работу с массивами (определение типа-массива, объявление переменной-массива, обращение к элементам массива).
Порядок выполнения работы
1. В обработчике события OnClick элемента главного меню "Вычисления" учебной программы (см. лабораторные работы №1, №2) обеспечить выполнение следующих действий:
* формирование вектора (массива) , компоненты которого представляют собой некоррелированные значения случайной нормально распределённой величины с математическим ожиданием E и среднеквадратическим отклонением Sigma. Для формирования вектора S1 использовать библиотечные функции Randomize() и RandG(∙). Значения параметров E и Sigma взять из табл. 3.1 в соответствии с заданным вариантом;
* вычисление дискретной свёртки , где:
Тип функции g() взять из табл. 3.2 в соответствии с заданным вариантом. В качестве значений параметров и параметров функции g() использовать значения одноимённых параметров, введённых в обработчике события OnClick элемента главного меню "Данные" (см. лабораторную работу №2).
* сохранение исходных данных и векторов S1, S2 (массивов S1, S2) в двоичном файле (фале без типа);
* очистка панели статуса главной формы.
2. Откомпилировать, запустить и протестировать программу.
3. Ответить на контрольные вопросы.
Таблица 3.1
№ вар.E (Mean)Sigma (StdDev)15120503-53410755-2106+257-154815109-2030102040 Таблица 3.2
№ вар., 12345678910 Контрольные вопросы
1. Определение типа-массива. Объявление переменной-массива.
2. Операции над массивами.
3. Многомерные массивы.
4. Оператор цикла for ....
5. Оператор цикла с предусловием while ....
6. Оператор цикла с постусловием do ... while.
7. Сравнение операторов цикла. Условия эффективного использования.
8. Вложенные циклы. Обработка многомерных массивов.
9. Селективная обработка строк/столбцов двумерного массива (матрицы).
10. Операторы break и continue.
11. Запись массивов в файл и чтение массивов из файла.
12. Алгоритм вычисления дискретной свёртки. Лабораторная работа №4
Тема работы: графическое представление числовых данных.
Цель работы: использование визуального компонента TChart для графического представления числовых данных.
Домашнее задание: изучить визуальный компонент TChart.
Порядок выполнения работы
1. Добавить в проект учебной программы модуль с формой с именем unResults (см. лабораторную работу №1). Форма должна иметь пиктограмму, совпадающую с пиктограммой главного окна. Доработать обработчик события OnClick элемента главного меню "Результаты". В обработчике создать и активизировать модальную форму (окно) с изменяемыми размерами с именем fmResuts модуля unResults. Форма должна создаваться в момент первого вызова обработчика события OnClick. Сформировать заголовок формы (свойство Caption), совпадающий с названием вызывающего элемента главного меню, а также обеспечить расположение формы на экране в центре родительской формы. Модуль unResults должен обеспечивать выполнение следующих действий:
* считывание исходных данных и массивов S1, S2 из дискового файла (см. лабораторную работу №3);
* построение на экране в одном поле графиков функций S1(x), S2(x) по их дискретным значениям {S1(i), S2(i), i=0,1,...,Ns-Ng};
* оформление графического поля (установка размеров, определение заголовка, обозначение осей, установка типа и цвета линий и др.);
* печать графиков;
* отображение исходных данных.
Пример реализации модуля unResults приведён на рис. 4.1.
Рис. 4.1
Для отображения исходных данных использовать визуальный компонент TMemo (многострочный редактор текста). После закрытия формы fmResuts модуля unResults очистить панель статуса главной формы.
2. Откомпилировать, запустить и протестировать программу.
3. Ответить на контрольные вопросы.
Контрольные вопросы
1. Построение и печать графиков с использованием визуального компонента TChart.
2. Форматирование графиков на этапе визуального проектирования.
3. Форматирование графиков на этапе выполнения программы.
4. Указатели. Создание, доступ, уничтожение.
5. Классы TStrings, TStringList. Свойство TMemo.Lines. Лабораторная работа №5
Тема работы: разработка инструкции пользователя.
Цель работы: разработка файла справки; подключение файла справки к программе и создание контекстно-чувствительной справочной службы.
Домашнее задание: изучить основы работы с программой hcw (Microsoft Help Workshop), а также вопросы подключения help-файла к программе, вызова help-файла и организации контекстно-чувствительной справки.
Порядок выполнения работы
1. Скопировать из папки, указанной преподавателем, в папку хранения файла справки учебной программы файл-заготовку для хранения текста справки (файл в формате RTF).
2. Запустить Microsoft Word, открыть файл заготовку и ввести текст в разделы справки.
Примечание: чтобы не нарушить структуру файла-заготовки, нужно избегать редактирования заголовков разделов и концевых сносок.
3. Запустить программу hcw. Создать проект help-службы учебной программы на базе сформированного файла в формате RTF. Пронумеровать разделы справки.
4. Откомпилировать проект help-службы.
5. Запустить и протестировать сформированный файл справки (файл с расширением hlp). 6. Подключить help-файл ко всем формам учебной программы.
7. Доработать обработчик события OnClick элемента главного меню "Справка" учебной программы (см. лабораторную работу №1), в котором выполнить вызов help-службы.
8. Подключить различные разделы help-службы к соответствующим объектам программы для организации контекстно-чувствительной справки.
9. Откомпилировать, запустить и протестировать программу.
10. Ответить на контрольные вопросы.
Контрольные вопросы
1. Назначение и основы работы с программой hcw (Microsoft Help Workshop).
2. Структура файла хранения текста справки.
3. Разработка файла-содержания справки.
4. Подключение help-файла к форме. Команда вызова help-файла.
5. Связывание разделов help-файла с объектами программы. Вызов контекстно-чувствительной справки.
Документ
Категория
Рефераты
Просмотров
17
Размер файла
194 Кб
Теги
cpp
1/--страниц
Пожаловаться на содержимое документа