close

Вход

Забыли?

вход по аккаунту

?

Лабораторная работа№ 11 12 Отчеты

код для вставкиСкачать
Факультет СПО СПбГУ ИТМО
Специальность 230105
Дисциплина: Базы данных
Лабораторная работа № 11-12
Тема: "Создание и печать отчетов"
Цель: Овладеть практическими навыками проектирования и создания отчетов с использованием средств VFP 9.0.
Оборудование: Компьютерный класс
Практическое задание
1. Создать отчет с использованием конструктора отчетов (согласно индивидуальному заданию).
2. Для формирования отчета использовать представление данных (View). При создании представления использовать конструктор представления.
3. При создании отчетов использовать вычисляемые поля, упорядочение данных, переименование столбцов, фильтрацию данных, группирование данных, итоговые значения (по возможности).
Технология выполнения работы
СОЗДАНИЕ И ПЕЧАТЬ ОТЧЕТОВ
1. Что такое отчет
Отчет представляет собой форматированное представление данных, выводимое на экран, принтер или в файл.
Отчет, создаваемый в Visual FoxPro, может быть представлен в табличном виде или в свободной форме. Табличный отчет - это напечатанная таблица, в которой строка представляет собой запись, а каждый из элементов строки содержит поле исходной таблицы или вычисляемое поле. Данные в таблице упорядочены. Табличные отчеты используются для печати данных, представленных в виде списка.
При подготовке писем, почтовых этикеток поля используемых в отчете таблиц должны располагаться в специально выделенных для них местах. В этом случае табличный отчет не подходит и используются отчеты в свободной форме. При создании такого отчета можно воспользоваться стандартным форматом, автоматически создаваемым Visual FoxPro для каждой таблицы, при котором поля исходной таблицы располагаются вертикально. Используя конструктор отчетов, можно разрабатывать собственные форматы отчета, где поля исходной таблицы будут расположены там, где нужно. В процессе создания отчета выполняются все или часть из приведенных ниже процедур: * определение среды окружения; * размещение объектов в отчете: текста, полей, линий, прямоугольников и рисунков; * группирование данных в отчете; * сохранение отчета; * просмотр созданного отчета в окне предварительного просмотра; * печать отчета. 2. Создание отчета с помощью конструктора отчетов
2.1. Окно конструктора отчетов
Существует несколько различных вариантов открытия окна конструктора отчетов. Если нужно модифицировать ранее созданный отчет, то в окне проекта установить курсор на его названии и нажать кнопку Modify (Модификация). Для открытия окна конструктора отчетов при создании нового отчета выполнить одно из следующих действий. * В меню File (Файл) выберите команду New (Новый). В открывшемся диалоговом окне New (Новый) выберите опцию Report (Отчет) и нажмите кнопку New file (Новый файл). * Нажмите кнопку New (Новый) в окне проекта, предварительно выбрав группу Reports (Отчеты). * Нажмите кнопку New (Новый) на стандартной панели инструментов; в открывшемся диалоговом окне New (Новый) установите опцию Report (Отчет) и нажмите кнопку New file (Новый файл). Для работы в конструкторе отчетов используются панели инструментов Report Designer (Конструктор отчета) и Report Controls (Элементы управления отчета), а также команды пункта Report (Отчет) (рис. 8.1), появивляюшегося в строке основного меню при открытии конструктора. В табл.1 приведено краткое описание кнопок панели инструментов Report Controls (Элементы управления отчета). Более подробно назначение кнопок этой панели будет рассмотрено в разделах, посвященных размещению в отчетах различных элементов управления. Рис.1. Окно конструктора отчета
Таблица 1. Кнопки панели инструментов Report Controls
КнопкаНаименованиеНазначениеSelect Objects (Выбор объектов) Является указателем выбора объектов отчета Label (Метка) Размещает текст Field (Поле) Размещает поля Line (Линия) Рисует линии Rectangle (Прямоугольник) Рисует прямоугольники Rounded Rectangle (Скругленный прямоугольник) Рисует прямоугольник со скругленными краями Picture/Act! vX Bound Control (Изображение/Ас1!уХ-объект) Помещает в отчет рисунок Button Lock (Закрепитель кнопки) Закрепляет выбор кнопки Задание для самостоятельной работы: изучить работу с конструктором отчетов (лабораторный практикум "Создание и печать отчетов").
2.2. Типы полос окна конструктора отчета
Вся рабочая область конструктора отчетов по умолчанию разделена на три полосы, ограничиваемые разделительными строками (см. рис. 8.1). Наименование полосы отображается на разделительной строке, находящейся непосредственно под этой полосой. При использовании в отчете группирования данных, добавлении в него титульной страницы и итоговых данных появляются дополнительные полосы. Каждая полоса может содержать элементы управления отчета, такие как текст, табличные и вычисляемые поля, линии, прямоугольники, рисунки. Типы возможных в отчете полос приведены в табл.2. Основное назначение полосы - определять, когда и где будут печататься размещенные в полосе объекты. Таблица 2. Типы полос отчета
ПолосаНазначениеTitle (Титул) В этой полосе размещается информация, появляющаяся перед основным отчетом и называемая титульной. Это может быть имя отчета, сопроводительное письмо или любые данные, которые необходимо поместить на первой странице отчета Page Header (Верхний колонтитул) Эта полоса в отчете называется верхним колонтитулом. Данные, помещенные в полосу, печатаются в начале каждой страницы. Примерами элементов управления могут быть название отчета, текущая дата, номер страницы и т. д. Group Header (Группа сверху) В этой полосе печатается информация, используемая при группировке. При группировке данных группа может иметь верхние полосы, печатаемые до нее. Они помогают идентифицировать информацию, содержащуюся на каждом уровне группировки Detail (Детали) Эта полоса содержит данные полей из таблицы или результат вычислений над ними Group Footer (Группа снизу) В полосе размещается итоговая информация по группе Page Footer (Нижний колонтитул) В нижнем колонтитуле печатается название отчета, дата, номер страницы и итоговые значения по данным текущей страницы Summary (Итоги) В итоговой части отчета содержится информация, появляющаяся один раз после основного отчета и содержащая итоговые значения или заключительный текст Задание для самостоятельной работы: изучить работу с конструктором отчетов (лабораторный практикум "Создание и печать отчетов").
2.2. Пример создания простого однотабличного отчета
Последовательность действий по созданию отчета для одной таблицы (здесь: customer, содержащей список клиентов): 1. Открыть проект (Sales). 2. Открыть базу данных проекта. Для этого на вкладке Data (Данные) установить курсор на названии базы данных и нажать кнопку Open (Открыть) окна проекта. При этом на стандартной панели инструментов в списке Databases (Базы данных) появляется название открытой базы данных. 3. Перейти на вкладку Documents (Документы), выбрать группу Reports (Отчеты) и нажать кнопку New (Новый). 4. В открывшемся диалоговом окне New Report (Новый отчет) выбрать опцию New Report (Новый отчет). Открывается окно конструктора, предназначенное для создания нового отчета. 5. Для задания среды окружения отчета открыть диалоговое окно Data Environment (Среда окружения), выбрав команду Environment (Окружение) в меню View (Вид) или Data Environment (Среда окружения) контекстного меню. 6. Для добавления таблицы в окружение отчета в меню Data Environment (Среда окружения) выбрать команду Add (Добавить). 7. В открывшемся диалоговом окне Add Table or View (Добавить таблицу или представление) выбрать таблицу customer и нажать кнопку ОК. В окне Data Environment (Среда окружения) будет отображена выбранная таблица. 8. Открыть окно свойств таблицы. Для этого установить курсор на ее названии, нажать правую кнопку мыши и выбрать из контекстного меню команду Properties (Свойства). 9. Выделить свойство order (Порядок). Для упорядочения данных в отчете по кодам клиентов в поле коррекции свойства нажать кнопку раскрытия списка и из списка индексов таблицы выбрать icdcustomer. 10. Закрыть окно Data Environment (Среда окружения). 11. Для размещения полей таблицы в отчете воспользоваться командой Quick Report (Быстрый отчет) в меню Report (Отчет). Открывается диалоговое окно Quick Report (Быстрый отчет). 12. Выбрать вариант размещения полей по столбцам и нажать кнопку Fields (Поля). 13. В диалоговом окне Field Picker (Выбор поля) выбрать поля, помещаемые в отчет, и перенести их в список Selected fields (Выбранные поля), используя кнопку Move (Перенести). Нажать ОК. 14. Возвратившись в диалоговое окно Quick Report (Быстрый отчет), нажать кнопку ОК для завершения процедуры размещения полей в отчете. 15. Используя кнопку Label (Метка) панели инструментов Report Controls (Элементы управления отчета), скорректировать заголовки полей. 16. Для того чтобы придать отчету законченный вид, добавить область заголовка отчета, выбрав в меню Report (Отчет) команду Title/Summary (Титул/Итоги). 17. В открывшемся диалоговом окне Title/Summary (Титул/Итоги) установить флажок Title Band (Полоса титула) и ОК. В отчете появляется полоса Title (Титул). Разместить в ней текст заголовка отчета с помощью кнопки Label (Метка) панели инструментов Report Controls (Элементы управления отчета). 18. Просмотреть внешний вид отчета (рис. 8.11), воспользовавшись командой контекстного меню Preview (Просмотр). 19. Сохранить отчет. На рис.2 приведен созданный отчет в окне предварительного просмотра.
Рис.2. Предварительный просмотр отчета "Список клиентов"
2.3. Пример создания табличного отчета
Создать в конструкторе отчетов табличный отчет, содержащий список заказов. При создании отчета использовать три таблицы. Таблица Ordsaiem содержит сведения о заказе на товары - это главная таблица, на основании которой строится отчет. Остальные две таблицы являются вспомогательными. Таблица ordsaied содержит сведения о товарах, входящих в заданный заказ (количество купленных товаров и цена товара), а таблица Customer - информацию о клиентах. Приступим к созданию отчета. 1. Открыть новое окно в конструкторе отчетов. 2. В среду окружения отчета Data Environment (Среда окружения) добавить поочередно таблицы Ordsaiem, customer и ordsaied. При создании связей между таблицами для данного отчета необходимо учитывать следующее: * таблица Ordsaiem является родительской по отношению к таблицам Ordsaied и Customer; * связь между таблицами Ordsaiem и customer осуществляется по коду клиента; * связь между таблицами Ordsaiem и ordsaied осуществляется по коду заказа; * данные в таблице Ordsaiem должны быть упорядочены по коду заказа, в таблице customer - по коду клиента, в таблице ordsaied - no коду заказа. Установив связи между таблицами и упорядочив данные (рис. 8.23), закрыть окно Data Environment (Среда окружения). 3. Используя команду Quick Report (Быстрый отчет) из меню Report (Отчет), разместить в отчете следующие поля: * ccompany с наименованием компании из таблицы Customer; * dDoc, содержащее дату продажи из таблицы Ordsaiem; * nQuant с количеством проданного товара из таблицы Ordsaied; * nUnitprice с ценой товара из таблицы Ordsaied. 4. Создать вычисляемое поле, которое содержит выражение для подсчета стоимости проданного товара: OrdSaled.nQuant * OrdSaled.nUnitPrice 5. Добавьить в полосу Page Header (Верхний колонтитул) заголовки для размещенных полей. 6. Добавить в отчет заголовок и итоговую часть отчета, выполнив команду Title/Summary (Титул/Итоги) из меню Report (Отчет). 7. В заголовке отчета ввести Список заказов. Рис.3. Диалоговое окно Data Environment
Рис.4. Созданный отчет в окне конструктора отчетов
8. В итоговой части отчета создать поле, которое вычислит стоимость всех заказов, просуммировав стоимость проданного товара. 9. Отчет в окне конструктора отчетов будет иметь вид, представленный на рис.4. Просмотреть внешний вид отчета в окне предварительного просмотра (рис.5). 10. Сохранить отчет. Рис.5. Просмотр табличного отчета
2.4. Группировка данных в отчете
Посмотрите на отчет, представленный на рис.5. Видно, что клиент может приобрести разные товары. Вопрос: а нельзя ли объединить данные в отчете таким образом, чтобы иметь краткую информацию о том, какие товары приобрел тот или иной клиент? Для группировки данных в отчете используется команда Data Grouping Группировка данных) меню Report (Отчет) и команда Data Grouping Группировка данных) контекстного меню, которые позволяют создавать до 20 уровней вложенности групп и выполнять над ними следующие операции: * печатать текст, идентифицирующий конкретные группы; * печатать каждую группу отчета с новой страницы; * при печати каждой группы начинать новую нумерацию страниц. Рис.6. Диалоговое окно Data Grouping
При выполнении данных команд открывается диалоговое окно Data Grouping (Группировка данных) (рис.6), содержащее список созданных в отчете групп. Используя расположенные в окне кнопки, можно редактировать или удалять имеющиеся в отчете группы, добавлять новые. Для формирования выражения, по которому будут группироваться данные в отчете, можно использовать построитель выражения или ввести требуемое выражение непосредственно в поле Group expressions (Выражение группировки). В диалоговом окне Data Grouping (Группировка данных) можно установить следующие параметры группировки данных (табл.3). Таблица 3
Параметры группировки данных окна Data Grouping
ФлажокНазначениеStart group on new column (Каждая группа в новой колонке) Если флажок установлен, то при каждом изменении группы происходит формирование новой колонки Start each group on a new page (Каждая группа на новой странице) При установке флажка каждая группа отчета размещается на новой странице Reset page number to 1 for each group (Сброс нумерации страниц для каждой группы) При установке флажка каждая группа отчета размещается на новой странице. Нумерация страниц группы начинается с 1 Reprint group header on each page (Верхняя полоса группы для каждой страницы) Если группа занимает несколько страниц, то при установке флажка верхняя полоса группы размещается после верхнего колонтитула страницы Start group on new page when less than (Печатать группу с новой страницы, если) Если под заголовком группы остается расстояние меньше указанного в данном поле, то информация группы будет перенесена на новую страницу С помощью кнопки Insert (Вставить) диалогового окна Data Grouping (Группировка данных) можно добавить в отчет новую группу. Для удаления полосы группы используется кнопка Delete (Удалить). 2.5. Использование группировки в отчете
Модифицировать отчет, созданный в предыдущем примере. Добавить в него группировку по клиентам и разместим в полосах группы наименование клиента и итоговую сумму приобретенных им товаров. 1. Открыть отчет, созданный в предыдущем примере. 2. Для группировки данных в отчете по полю icdCustomer в меню Report (Отчет) выберите команду Data Grouping (Группировка данных). 3. В поле Group expressions (Выражение группировки) открывшегося диалогового окна Data Grouping (Группировка данных) нажать кнопку вызова построителя выражения. 4. В окне построителя сформировать выражение группировки. Для этого в списке Fields (Поля) дважды щелкнуть мышью на поле icdCustomer таблицы Ordsalem. 5. Закрыть окно построителя выражения. В поле Group expressions (Выражение группировки) диалогового окна Data Grouping (Группировка данных) появилось выбранное нами поле icdCustomer. 6. Закрыть диалоговое окно, нажав кнопку ОК. 7. В отчет добавились полосы группировки. Расширить полосу Group Header (Группа сверху). Для этого установите курсор в нижнюю часть полосы и, когда он примет вид двунаправленной стрелки, переместить вниз. 8. Перенести в образовавшуюся область поле с наименованием клиента, а также его заголовок. Рис.7. Группировка данных в отчете по коду клиента
Рис.8. Просмотр отчета с группировкой данных
9. Расширить полосу Group Footer (Группа снизу) и создайте в ней итоговое поле, которое будет показывать сумму продаж по каждому клиенту. При формировании поля указать суммирование по следующему выражению: OrdSaled.nQuant * OrdSaled.nUnitPrice Отчет в окне конструктора отчетов будет иметь вид, представленный на рис.7. 10. Просмотреть внешний вид отчета в окне предварительного просмотра (рис.8). 11. Сохранить созданный отчет. 3. Представления данных
Представление (View) - это виртуальная таблица, данные для которой получаются из базовых таблиц или других представлений. Может быть получено из одной или нескольких таблиц и включать в себя вычисляемые поля. Представление можно рассматривать как хранимый запрос (оно и выражается с помощью запроса). Представление можно использовать в запросах наряду с реальными таблицами. Оно упрощает создание сложных запросов (отчетов).
Задание для самостоятельной работы: изучить создание представление с помощью конструктора представлений и использовать представление при создании отчет (в составе проекта).
Содержание отчета
1. Титульный лист (только по образцу).
2. Цель работы.
3. Практическое задание.
4. Выполнение:
I. Описание отчета (в свободной форме).
II. Листинг отчета.
Охарактеризовать, какая информация сформирована в виде представления, которое используется для построения отчета.
Примечание. Допускается привести в качестве листинга скриншот отчета в окне предварительного просмотра.
5. Вывод.
1
Документ
Категория
Рефераты
Просмотров
69
Размер файла
943 Кб
Теги
отчёты, работа, лабораторная
1/--страниц
Пожаловаться на содержимое документа