close

Вход

Забыли?

вход по аккаунту

?

Отчёт по лаб 4

код для вставкиСкачать
МИНОБРНАУКИ РОССИИ
Федеральное государственное бюджетное образовательное учреждение высшего профессионального образования "Ижевский государственный технический университет имени М.Т.Калашникова"
Кафедра "Вычислительная техника"
Отчет
По лабораторной работе №4 по дисциплине
ИНФОРМАТИКА
на тему: "Аппроксимация функций методом наименьших квадратов в табличном процессоре Excel"
Выполнилстудент гр. Б01-781-2
Синявин И.Е.
Принял к.т.н., доцент кафедры ВТ
И.В. Коробейникова
Ижевск 2013
Вариант 7
Цель: проанализировать данные с использованием метода наименьших квадратов в Excel. Построить два графика по заданному набору данных, используя функции ТЕНДЕНЦИЯ и РОСТ. Сравнить результаты.
Заданный набор пар значений независимой переменной и функции
x0,10,20,30,40,50,60,70,80,91y12,36,57,99,112,316,421,833,442
Задание 1. Для заданного набора пар значений независимой переменной и функции (см. таблицу) определить наилучшее линейное приближение в виде прямой с уравнением 1.1. Найти коэффициенты уравнения прямой с помощью функции ЛИНЕИН. Рассчитать значения аппроксимирующей функции в узловых точках. Получить линейное приближение без явного определения параметров с помощью ТЕНДЕНЦИЯ. Вычислить сумму квадратов невязок.
1.2. Построить на одной диаграмме графики аппроксимируемой и аппроксимирующей функций. Добавить линию тренда и вывести величину достоверности аппроксимации.
1.3. Продолжить набор значений независимой переменной (ввести еще 5 значений). Предсказать поведение линии тренда на отрезке [1.1, 1.5].
Ввести заданный набор пар значений. Найти значения коэффициента а с помощью формулы "=ИНДЕКС(ЛИНЕЙН(B2:K2;B1:K1);1)" и значение коэффициента b с помощью формулы "=ИНДЕКС(ЛИНЕЙН(B2:K2;B1:K1);2)". Получить линейное приближение без явного определения параметров с помощью функции ТЕНДЕНЦИЯ. Для выделить диапазон B6:K6, ввести формулу "=ТЕНДЕНЦИЯ(B2:K2;B1:K1)" и нажать ctrl+shift+enter. То же самое вычислить с помощью параметров a и b: ввести формулу "=$B$3*B1+$B$4" и скопировать её по направлению вправо. Получим абсолютно одинаковые значения. Ниже вычислить квадрат разности значений y по формуле "=(B6-B2)^2". Используя полученные данные, вычислить сумму квадратов невязок, введя в ячейку D10 формулу "=СУММ(B7:K7)". Далее построить графики аппроксимируемой и аппроксимирующей функций. Добавить линию тренда и вывести величину достоверности аппроксимации.
В ячейки L1:P1 ввести ещё 5 значений из интервала [1.1, 1.5]. Выделить диапазон L6:P6, ввести туда формулу "=ТЕНДЕНЦИЯ(B2:K2;B1:K1;L1:P1)" и нажать ctrl+shift+enter. Таким образом можем предсказать поведение линии тренда на новом интервале.
Задание 2. Пункт 1 повторить для показательной аппроксимирующей функции (использовать функции ЛГРФПРИБЛ и РОСТ)
Ввести заданный набор пар значений. Найти значения коэффициента а с помощью формулы "=(ИНДЕКС(ЛГРФПРИБЛ(B2:K2;B1:K1);1))" и значение коэффициента b с помощью формулы "=(ИНДЕКС(ЛГРФПРИБЛ(B2:K2;B1:K1);2))". Воспользоваться функцией РОСТ. Для выделить диапазон B6:K6, ввести формулу "=РОСТ(B2:K2;B1:K1)" и нажать ctrl+shift+enter. То же самое вычислить с помощью параметров a и b: ввести формулу "=$B$4*$B$3^B1" и скопировать её по направлению вправо. Получим абсолютно одинаковые значения. Ниже вычислить квадрат разности значений y по формуле "=(B6-B2)^2". Используя полученные данные, вычислить сумму квадратов невязок, введя в ячейку B9 формулу "=СУММ(B7:K7)". Далее построить графики аппроксимируемой и аппроксимирующей функций. Добавить линию тренда и вывести величину достоверности аппроксимации.
В ячейки L1:P1 ввести ещё 5 значений из интервала [1.1, 1.5]. Выделить диапазон L6:P6, ввести туда формулу "=РОСТ(B2:K2;B1:K1;L1:P1)" и нажать ctrl+shift+enter. Таким образом можем предсказать поведение линии тренда на новом интервале. Вывод: Сравниваем результаты пункта 1 и пункта 2. Во втором случае сумма квадратов невязок намного меньше, а величина достоверности аппроксимации больше. Следовательно второй график является более точным. 
Документ
Категория
Рефераты
Просмотров
111
Размер файла
130 Кб
Теги
лаб, отчет
1/--страниц
Пожаловаться на содержимое документа