close

Вход

Забыли?

вход по аккаунту

?

Lr1 sh

код для вставкиСкачать
 Цель: Изучение основных компонентов интегрированной среды разработки приложений Visual Basic, преобретение начальных навыков работы в среде при создании простейших приложений.
Оборудование: Методические рекомендации преподавателя, инструкция лабораторного занятия.
Выполнение задания:
1. Условия задачи
Создать простое приложение, отражающее "Привет мир! Я тебя люблю.".
2. Листинг программы
Public Class Form1
Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
MsgBox("Привет мир! Я тебя люблю.", 64, "Привет мир!") End Sub
End Class
Ответы на контрольные вопросы
1. Что в среде Visual Basic принято называть проектами?
Проект - это разработанная на Visual Basic приложение. Проект включает в себя форму или несколько взаимосвязанных форм содержащие управленческие элементы, а также программные модули событийных процедур, которые описывают поведение объектов и способ их взаимодействия между собой.
2. Назовите основные рабочие окна среды Visual Basic
* Окно конструктора форм
* Окно свойств
* Окно редактора меню
* Окно просмотра объектов
* Окно макета формы * Окно редактора исходного кода
* Окно проводника проекта
* Окно локальных переменных
* Окно контроля работы приложения
* Окно ручного ввода и выполнения команд
3. Для чего нужно окно конструктора форм?
Окно конструктора форм является основным рабочим окном, в котором выполняется визуальное проектирование приложения.
В окне конструктора форм визуально конструируются все формы приложения с использованием инструментария среды разработки.
Размер формы в окне можно изменять, используя маркеры выделения формы и мышь. Для изменения размера формы необходимо установить указатель мыши на маркер и, когда он примет вид двунаправленной стрелки, перемещать до получения требуемого размера.
4. Для чего нужна сетка в окне конструктора форм?
Для точного позиционирования объектов в форме в окне имеется сетка. Размер ячеек сетки можно менять.
5. Как изменить шаг сетки окна конструктора форм?
При необходимости сетку можно отключать, воспользовавшись параметрами диалогового окна Options, открываемого командой Options (Параметры) из меню View (Вид). Допустимые значения изменения сетки 24 - 1088.
6. Для чего нужна панель элементов управления?
Панель элементов управления - основной рабочий инструмент при визуальной разработке форм приложения.
Панель элементов управления вызывается из меню View (Вид) командой Toolbox (Панель элементов управления). Для вызова этой панели можно воспользоваться также кнопкой Toolbox на стандартной панели инструментов.
В составе панели элементов управления содержатся основные элементы управления форм - метки, текстовые поля, кнопки, списки и другие элементы для быстрого визуального проектирования макета формы.
7. Как поместить новые компоненты на панель элементов управления?
Поместить на панель элементов управления компоненты можно используя пункт Components...(Компоненты) контекстного меню, вызываемого правой кнопкой мыши при нахождении курсора на свободной области панели элементов управления. При этом откроется окно выбора компонентов.
Окно выбора компонентов содержит три вкладки:
Controls (Средства управления) - позволяет выбрать компоненты, размещаемые на панели элементов управления. Компоненты хранятся в файлах, имеющих расширение .OCX или в файлах динамических библиотек .DLL. Выбрать файлы можно также вручную, используя кнопку Browse... (Просмотр)
Designers (Проектировщики) - позволяет подключить динамические библиотеки, необходимые для работы создаваемого в среде Visual Basic приложения.
Insertable Objects (Встраиваемые объекты) - позволяет выбрать компоненты, представляющие собой OLE - объекты или программные приложения. Компоненты хранятся в файлах, имеющих расширение .OCX, в файлах динамических библиотек .DLL или в исполняемых файлах .EXE.
Ключ Select Items Only (Только выбранные пункты) позволяет исключить из списка компонентов пункты, не отмеченные ключами выбора.
8. Как показать в окне выбора компонентов только активные пункты?
Ключ Select Items Only (Только выбранные пункты) позволяет исключить из списка компонентов пункты, не отмеченные ключами выбора.
9. Как разместить объекты на форме?
Для размещения элементов управления в форме с помощью панели элементов выполните следующие действия:
1. Выделите требуемый элемент управления с помощью мыши.
2. Перейдите в окно конструктора форм. Указатель мыши при этом превратится в крестик, при помощи которого можно установить местоположение размещаемого объекта. Левой кнопкой мыши зафиксируйте позицию нового объекта и, удерживая кнопку, задайте размеры объекта.
10. Как сохранить подготовленный проект?
Для сохранения проекта выполните следующие действия:
1. В меню File (Файл) выберите команду Save Project (Сохранить проект) или нажмите кнопку Save Project на стандартной панели инструментов. 2. В открывшемся диалоговом окне Save File As список Тип файла содержит значение Form Files, указывая, что сохраняется входящая в приложение форма (файл с расширением .frm). Используя раскрывающийся список Папка, выберите папку, в которой будет сохранена форма, затем в поле Имя файла введите имя формы и нажмите кнопку Сохранить. 3. Так как никаких компонентов, кроме формы, новое приложение не содержит, появляется диалоговое окно Save Project As (Сохранить проект как) для сохранения самого проекта (файлы с расширениями .vbp и vpw). По умолчанию в списке Папка выбрана папка, в которой сохранили форму. Введите наименование проекта и нажмите кнопку Сохранить. При последующем сохранении проекта Visual Basic по умолчанию сохраняет файлы под их именами. Если же в проект с момента последнего сохранения были добавлены новые компоненты, откроется диалоговое окно Save File As для присвоения им имен.
11. Что надо сделать для запуска (выполнения) созданного в Visual Basic приложения?
Для запуска (выполнения) созданного в Visual Basic приложения можно:
- выполнить команду Start , расположенную в пункте Run (Выполнить) главного меню; - нажать кнопку Start на стандартной панели инструментов Visual Basic; - нажать клавишу <F5> на клавиатуре ПК.
После этого приложение начнет выполнять запрограммированные в нем действия.
Для завершения работы приложения можно:
- нажать на крестик в правом верхнем углу формы;
- выполнить команду End , расположенную в пункте Run главного меню; - нажать кнопку End на стандартной панели инструментов Visual Basic; - нажать сочетание клавиш Alt + <F4> на клавиатуре ПК.
12. Для чего предназначен редактор исходного кода?
Редактор кода Code (Код) - это мощный встроенный редактор с удобными средствами ввода текста (исходного кода) программы. Из меню View (Вид) перейти в редактор кода можно с помощью команды Code (Код). Для быстрого открытия окна редактора кода достаточно дважды щелкнуть левой кнопкой мыши, установив указатель на форме приложения. После начала редактирование кода программы имя открытого окна появляется и в списке команд перехода между окнами Window (Окно) главного меню. Переход между макетом и окном редактора кода можно выполнять, используя список меню Window.
Вывод
На лабораторной работе мы изучили основные компоненты интегрированной среды разработки приложений Visual Basic.
Документ
Категория
Рефераты
Просмотров
94
Размер файла
71 Кб
Теги
lr1
1/--страниц
Пожаловаться на содержимое документа