close

Вход

Забыли?

вход по аккаунту

?

Лаб1 Quartus

код для вставкиСкачать
 Лабораторная работа № 1
Освоение среды разработки цифровых схем Quartus II.
Цель: Знакомство с особенностями работы приложения Quartus II в процессе синтеза цифровых устройств на программируемых логических интегральных схемах (ПЛИС).
ТЕОРЕТИЧЕСКАЯ ЧАСТЬ
Открытие проекта Запустите приложение Quartus II. Для этого необходимо кликнуть Пуск→Программы→Altera→Quartus II 9.0sp2 Web Edition→Quartus II 9.0sp2 Web Edition. Выберите в главном меню File→New Project Wizard ... ("Файл→Мастер создания проекта..."). Запуск нового проекта можно начать, кликнув на кнопке Create a New Project вкладки Getting Started With Quartus II Software. Здесь же можно открыть уже существующий проект, кликнув на кнопе Open Existing Project либо на названии проекта из списка, отображаемого на данной вкладке. В появившемся окне New Project Wizard: Introduction ("Мастер создания проекта: введение") можно поставить "галочку" у надписи Don't show me this introduction again ("Не показывать мне это вводное окно снова"), если хочется, чтобы данное нефункциональное окно в будущем не появлялось, и щелкнуть по кнопке Next ("Следующий шаг"). Для создаваемого проекта в появившемся окне New Project Wizard: Directory, Name, and Top-Level Entity [page 1 of 6] ("Мастер создания проекта: папка, имя и модуль верхнего уровня [страница 1 из 6]") щелкнуть по кнопке с тремя точками у верхнего поля ввода и в новом окне Select Directory ("Выбрать папку"), переместившись в желаемое место на диске, "зайти" в требуемую папку. При необходимости папку можно создать, используя известные стандартные процедуры. Размещение проекта в отдельной папке вызвано тем, что проект может содержать достаточно большое количество файлов. Для того чтобы все разрабатываемые проекты находились в одном месте рабочего диска, их желательно помещать в папку с именем, соответствующем номеру группы студента. После этого щелкнуть по кнопке "Открыть" окна Select Directory. После возвращения в окно New Project Wizard: Directory, Name, and Top-Level Entity [page 1 of 6], убедитесь в том, что в верхнем поле ввода занесен полный маршрут ко вновь созданной папке (рис. 1). Во втором сверху поле введите имя проекта. В третьем (нижнем) поле автоматически отобразится имя модуля верхнего уровня, аналогичное имени проекта введенного во втором поле. Можно переместиться и в другие страницы данного окна, выполняя клики на кнопке Next. Вместе с тем начальную процедуру создания проекта можно завершить, щелкнув по кнопке Finish ("Завершение").
При создании несложных устройств, функционально-логическое описание которых содержится в одном конструкторском файле (Device Design File), следует давать проекту и модулю верхнего уровня одно и то же имя. В начале каждого последующего сеанса работы с уже созданным проектом необходимо выбрать в главном меню File→Open Project. В появившемся окне Open Project найти папку проекта и, выделив файл проекта, щелкнуть по кнопке "Открыть". При запуске системы Quartus II открывается главное окно, показанное на рисунке 2.
В верхней части окна отображается имя проекта и текущего файла проекта. Ниже представлены кнопки основных инструментов системы. В левой части главного окна размещены навигатор, отражающий дерево иерархии проекта, и окно состояний решаемых задач. В правой части главного окна размещено рабочее окно, в котором в зависимости от решаемой задачи выводятся окна конструкторского файла, редактора временных диаграмм и отчета о компиляции. Нижнюю часть главного окна занимает окно сообщений об ошибках и предупреждениях.
Рисунок 1 - Окно задания имен папки, проекта и модуля верхнего уровня
Рисунок 2 - Главное окно системы Quartus II Создание конструкторского файла
Для создания конструкторского файла выберите в главном меню File→New... ("Файл→Новый"). В появившемся окне New (рис. 3)на закладке Device Design Files ("Конструкторские файлы устройств") можно выбрать тип создаваемого конструкторского файла.
Конструкторский файл устройства - это главный файл проекта, он содержат функционально-логическое описание устройства. Пакет Quartus II поддерживает ввод описания проекта на основе пяти типов конструкторских файлов: • AHDL File - файл на языке описания аппаратуры фирмы Altera (AHDL - Altera Hardware Description Language); • Block Diagram/Schematic File - файл в виде графического представления схемы или блок-схемы проекта; • EDIF File - файл в формате обмена электронными проектами (Electronic Design Interchange Format); • Verilog HDL File - файл на универсальном языке описания аппаратуры Verilog; • VHDL File - файл на универсальном языке описания аппаратуры VHDL (Very High Speed Integrated Circuit Hardware Description Language). Рисунок 3 - Меню выбора типа конструкторского файла
Рассмотрим проектирование, основанное на использовании языка описания аппаратуры AHDL. В окне New (рис. 3) выберите строку AHDL File ("Файл языке описания аппаратуры AHDL"). Далее щелкните по кнопке "OK" в нижней части окна. В рабочем поле главного окна (в правом верхнем углу) появится окно созданного файла с именем AHDL1.tdf. Его расширение означает, что это "Text Design File", т. е. файл с текстовым (программным) представлением проекта.
Текст описания проекта можно непосредственно ввести в рабочее окно приложения либо ранее подготовленное в любом из текстовых редакторов описание перенести в данное рабочее окно. Строки описания проекта нумеруются (рис. 4).
Рисунок 4 - Окно конструкторского файла
Незаполненный конструкторский файл имеет имя AHDL1.tdf. Если в него вводится программа, имя файла меняется на AHDL1.tdf*. Подготовленное описание проекта следует сохранить с именем, соответствующим имени проекта. Для этого следует выбрать в главном меню File→Save As... ("Файл→Сохранить с новым именем..."). В появившемся диалоговом окне "Сохранить как" будет предложено сохранить файл с именем проекта и расширением "tdf". Следует принять предложение и щелкнуть по кнопке "Сохранить". В результате имя AHDL1 файла заменится на имя проекта.
В левой части окна конструкторского файла размещены кнопки инструментов, используемых для создания программы проекта. Среди кнопок особый интерес может представлять две кнопки: Detach Window и Insert Template (обозначены стрелками на рис. 4). Первая позволяет менять размер окна конструкторского файла, а вторая обеспечивает получение информации о принципах построения основных структур программы. Названия кнопок высвечиваются при наведении курсора мыши на них.
Выбор микросхемы и компиляция проекта Поскольку реализация проекта предполагается на основе определенной микросхемы программируемой логической интегральной схемы (ПЛИС), необходимо в проекте указать тип выбранной микросхемы. Для этого выберите в главном меню Assignments→Device... ("Назначения→Микросхема..."). В открывшемся окне Device в списке Family ("Семейство") выбрать семейство микросхем, например MAX3000A. В расположенном ниже списке Available devices ("Доступные микросхемы") выбрать микросхему, например EPM3032ALC44-10. Окно выбора микросхемы имеет вид, показанный на рисунке 5.
Рисунок 5 - Окно выбора типа микросхемы
После назначения микросхемы можно выполнить компиляцию проекта. Выберите в главном меню Processing→Start Compilation ("Процессы→Запуск компиляции"). По окончании компиляции в рабочем окне отобразится информация о процессе компиляции (рис. 6).
На экране присутствуют следующие окна: • окно иерархии проекта Project Navigator (состав и подчиненность модулей) - было на экране до компиляции; • окно конструкторского файла ("Text Design File") - было до компиляции (в процессе компиляции становится неактивным); • окно состояния процесса Tasks ("Status window") - было до компиляции незаполненным; в ходе компиляции отражает текущий объем выполнения отдельных этапов в процентах и фиксирует время, затраченное на каждый этап и на весь процесс; • окно отчета о компиляции ("Compilation Report") - появилось в процессе компиляции; • окно сообщений ("Message Window") - было незаполненным до компиляции; отражает статистическую информацию о проекте, а также предупреждения (warnings) и сообщения об ошибках (error messages), если они имеются; • информационное окно ("Quartus II") - появляется по окончании процесса компиляции; сообщает о его успешном или неудачном завершении. Рисунок 6 - Отображение результатов компиляции
Наибольший интерес представляют последние два окна. Информационное окно не позволит продолжать работу, пока вы не щелкните по кнопке "OK", размещенной в данном окне. В окне сообщений, в случае аварийного завершения процесса компиляции, будут представлены сообщения об ошибках. Щелчок по сообщению об ошибке вызывает выделение элемента, к которому относится ошибка. В случае появления сообщения об ошибках, установив местоположение ошибок, необходимо устранить их. После этого повторить компиляцию проекта. Далее следует добиться успешного завершения процесса компиляции.
Информация, размещенная в окне Compilation Report-Flow Summary, позволяет проверить состояние статуса компиляции, название проекта, выбор микросхемы, число используемых макроячеек и количество задействованных выводов. Детальное назначение выводов микросхемы можно посмотреть, используя меню Compilation Report→Fitter→Resource Section→All Package Pins.
Если назначение выводов, сделанное средой проектирования, не удовлетворяет пользователя, необходимые назначения можно осуществить вручную, кликнув Assigments→Pins. В результате выведется окно планировщика выводов Pin Planner (рис. 7), в котором показан внешний вид (схема выводов) микросхемы и обозначен тип используемых выводов, а также в левой части окна дается перечень групп, а в нижней части - список входных и выходных переменных проекта. При подведении курсора к любому из выводов микросхемы выводится расшифровка его назначения.
Рисунок 7 - Окно планировщика выводов
Переменным проекта, показанным в нижней части окна, можно сделать назначение выводов микросхемы. Для этого в поле Location после двойного клика открывается меню, из которого можно выбрать номер назначаемого вывода. При переходе в ячейку Location другой строки назначение задействованного вывода микросхемы фиксируется и назначенный вывод отмечается на схеме красным цветом. Аналогично можно сделать назначения других переменных проекта. После закрытия окна планировщика выводов все сделанные назначения сохраняются. Для того чтобы назначения вступили в силу, следует повторно выполнить компиляцию проекта.
После выполнения компиляции, используя меню Compilation Report→Fitter→Resource Section→All Package Pins, можно посмотреть назначения выводов микросхемы.
Клик на << >> нижнего поля окна планировщика позволяет ввести имя новой переменной, назначаемой выводу микросхемы.
Увеличить размеры окна Compilation Report можно следующим образом. Навести курсор мыши на кнопку Compilation Report, кликнуть правой кнопкой мыши и в выпадающем меню выбрать Detach Window.
Закрытие ненужных окон реализуется кликом правой кнопкой мыщи на названии выбранного окна и выбором Close из выпадающего меню.
ПОРЯДОК ВЫПОЛНЕНИЯ РАБОТЫ
1. Запустить приложение Quartus II. 2. На диске W:\ создать папку с номером группы, в которой в дальнейшем будет сохраняться создаваемый проект. 3. Выполнить действия, описанные в разделе "Открытие проекта", учитывая, что названия имени проекта и имени модуля верхнего уровня должны совпадать с именем программы, введенном в tdf-файл после слова SUBDESIGN.
4. Выполнить действия по созданию конструкторского файла, описанные в разделе "Создание конструкторского файла".
5. Ввести в редактор системы Quartus II текст представленной ниже программы, заменив символы "х" в модуле объявления таблицы на 0 или 1 в зависимости от требуемой структуры:
% Ф.И.О., гр. 735, 7-сегментный индикатор % SUBDESIGN prim1
-- Название проекта (
i[3..0] : INPUT;
a, b, c, d, e, f, g : OUTPUT;
-- Объявления входных и выходных переменных
)
BEGIN
TABLE
i[3..0] => a, b, c, d, e, f, g;
H"0" => 1, 1, 1, 1, 1, 1, 0;
H"1" => х, х, х, х, х, х, х;
H"2" => х, х, х, х, х, х, х;
H"3" => х, х, х, х, х, х, х;
H"4" => х, х, х, х, х, х, х;
H"5" => х, х, х, х, х, х, х;
H"6" => х, х, х, х, х, х, х;
H"7" => х, х, х, х, х, х, х;
H"8" => х, х, х, х, х, х, х;
H"9" => х, х, х, х, х, х, х;
H"A" => х, х, х, х, х, х, х;
H"B" => х, х, х, х, х, х, х;
H"C" => х, х, х, х, х, х, х;
H"D" => х, х, х, х, х, х, х;
H"E" => х, х, х, х, х, х, х;
H"F" => х, х, х, х, х, х, х;
END TABLE;
END;
Семисегментный индикатор имеет семь сегментов (светодиодов), размещаемых пространственно в порядке, показанном на приведенном ниже рисунке. Каждый из сегментов индикатора имеет буквенное обозначение.
Структура начертания символов на семисегментном индикаторе имеет следующий вид:
.
6.Сохранить введенную программу в созданной ранее папке. Имя файла должно соответствовать имени проекта.
7.Выбрать микросхему, используемую для реализации проекта. Например, микросхему семейства MAX3000A - EPM3032ALC44-10.
8. Выполнить компиляцию программы. При наличии стилистических ошибок в программе исправить их.
9. Просмотреть параметры загрузки (используемые ресурсы микросхемы), тип и назначение выводов ПЛИС.
10. Изменить назначения выводов микросхемы таким образом, чтобы для входных сигналов использовались выводы в меньшими номерами, а следом за ними располагались выводы выходных сигналов. Назначать можно только комбинированные выводы I/O (input/output). Назначения сделать в следующем порядке i[0], i[1], i[2], i[3], a, b, с, d, e, f, g.
10. Составить программы для синтеза комбинационных устройств по приведенным ниже схемам.
11. В программе названия переменных можно определить следующим образом, например NEA или \EA.
12. Программа должна содержать название проекта, объявление входных и выходных переменных, размещенное в круглых скобках, логические выражения, размещенные в операторных скобках BEGIN ...END.
13. Выполнить компиляцию программ и исправить возможные ошибки.
Отчет о выполнении лабораторной работы должен содержать:
- название и цель работы;
- программы, сформированные в процессе выполнения работы; - название выбранной микросхемы ПЛИС, параметры ее загрузки и назначения выводов.
1
стр. 1 из 3Лаб_1
Документ
Категория
Рефераты
Просмотров
535
Размер файла
414 Кб
Теги
quartus, лаб1
1/--страниц
Пожаловаться на содержимое документа