close

Вход

Забыли?

вход по аккаунту

?

Vasin Epishkina Ivanova Protokoly marshrutizacii v setyah provajderov

код для вставкиСкачать
ФЕДЕРАЛЬНОЕ ГОСУДАРСТВЕННОЕ ОБРАЗОВАТЕЛЬНОЕ
БЮДЖЕТНОЕ УЧРЕЖДЕНИЕ ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ
ПОВОЛЖСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ
ТЕЛЕКОММУНИКАЦИЙ И ИНФОРМАТИКИ
Васин Н. Н., Епишкина Е. Ю., Иванова Е. А.
Протоколы маршрутизации в сетях провайдеров
Методические указания по лабораторным работам
Самара - 2015
ФЕДЕРАЛЬНОЕ АГЕНТСТВО СВЯЗИ
Федеральное государственное образовательное бюджетное учреждение
высшего профессионального образования
Поволжский государственный университет телекоммуникаций и информатики
Васин Н.Н., Епишкина Е.Ю., Иванова Е.А.
Протоколы маршрутизации
в сетях провайдеров
Методические указания по лабораторным работам
Для студентов по направлению подготовки магистров:
210700 Инфокоммуникационные технологии и системы связи
Самара
ИУНЛ ПГУТИ
2015
2
УДК 004.722
Васин Н.Н.
Протоколы маршрутизации в сетях провайдеров: Методические указания по
лабораторным работам / Васин Н.Н., Епишкина Е.Ю., Иванова Е.А. – Самара: ИУНЛ
ПГУТИ, 2015. – 70 с.
Комплекс лабораторных работ посвящен конфигурированию протоколов
маршрутизации OSPF, BGP в сетях IPv4 и IPv6. В методических указаниях приведены схемы
сетей, адреса устройств, порядок выполнения лабораторных работ, примеры
конфигурирования устройств.
Федеральное государственное образовательное бюджетное учреждение высшего
профессионального образования
Поволжский государственный университет телекоммуникаций и информатики
Васин Н.Н., Епишкина Е.Ю., Иванова Е.А.
2015
3
Введение
Совокупность
сетей,
представленных
маршрутизаторами
под
общим
административным управлением, образует автономную систему (рис. В.1). Примерами
автономных систем являются сети провайдеров ISP. Автономные системы нумеруются (AS1,
AS2, …AS107, …).
AS1
AS107
BGP
Автономная система 1
Автономная система 107
Рис. В.1. Взаимодействие автономных систем
Протоколы внутренней маршрутизации (Interior Gateway Protocols - IGP), к которым
относятся RIP, RIPv2, EIGRP, OSPF, IS-IS функционируют внутри автономной системы. На
сегодняшний день, самыми известными и распространенными протоколами внутренней
маршрутизации являются протокол OSPFv2 в сетях IPv4 и протокол OSPFv3 в сетях IPv6,
которые изучаются в первой части комплекса лабораторных работ. Лабораторные работы по
OSPF для нескольких областей выполнены Васиным Н.Н., Епишкиной Е.Ю.
Во второй части комплекса лабораторных работ рассматривается протокол внешней
маршрутизации (Exterior Gateway Protocols - EGP), осуществляющий маршрутизацию между
автономными системами. Примером протокола внешней маршрутизации является Border
Gateway Protocol – BGP, который работает на пограничных маршрутизаторах автономных
систем (рис. В.1). Лабораторные работы по BGP выполнены Васиным Н.Н., Ивановой Е.А.
ПРОТОКОЛ OSPF
Лабораторная работа № 1
4
Настройка OSPFv2 для нескольких областей
Часть 1. Построение сети. Настройка интерфейсов
1.Для начала работы необходимо открыть Packet Tracer
2.Постройте сеть данной топологии (не забудьте добавить на каждый маршрутизатор модуль
HWIC-2T)
Рис.1.1
3.Необходимо выполнить настройку всех интерфейсов в соответствии с таблицей 1
Таблица 1
Устройство
Router1
Router2
Router3
Иденти
фикатор
1.1.1.1
2.2.2.2
3.3.3.3
Интерфейс
S0/0/0
(DCE)
G0/0
G0/1
S0/0/0
(DCE)
S0/0/1
G0/0
S0/0/1
G0/1
G0/0
IPv4
адрес Connected
интерфейса
Network
192.168.10.1
192.168.10.0/24
Область
OSPF
Area 0
10.20.20.1
10.30.30.1
10.20.20.0/24
10.30.30.0/24
Area 1
Area 1
192.168.20.1
192.168.20.0/24
Area 0
192.168.10.2
10.40.40.1
192.168.20.2
10.60.60.1
10.50.50.1
192.168.10.0/24
10.40.40.0/24
192.168.20.0/24
10.60.60.0/24
10.50.50.0/24
Area 0
Area 0
Area 0
Area 2
Area 2
5
Router4
Router5
Router6
Router7
Router8
4.4.4.4
5.5.5.5
6.6.6.6
7.7.7.7
8.8.8.8
G0/0
G0/0
G0/0
G0/0
G0/0
10.30.30.2
10.20.20.2
10.40.40.2
10.50.50.2
10.60.60.2
10.30.30.0/24
10.20.20.0/24
10.40.40.0/24
10.50.50.0/24
10.60.60.0/24
Area 1
Area 1
Area 0
Area 2
Area 2
Приведем пример для Router 1(перед началом конфигурирования необходимо включить
маршрутизаторы)
Router>en
Router#conf t
Router(config)#int g0/0
Router(config-if)#ip add 10.20.20.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int g0/1
Router(config-if)#ip add 10.30.30.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int s0/0/0
Router(config-if)#ip add 192.168.10.1 255.255.255.0
Router(config-if)#clock rate 2000000
Router(config-if)#no shutdown
Команда clock rate 2000000 говорит о том, что данный интерфейс S0/0/0
является
интерфейсом ,имеющим DCE подключение .
4.Сконфигурируйте все остальные интерфейсы в соответствии с таблицей 1.
5.Сохранить текущую конфигурацию!!!
Сохранение созданного конфигурированного файла производится по команде copy runningcofig startup-config или сокращенно copy run start.
Сохраненный файл можно просмотреть с помощью команды show startup-config
Router#show startup-config
Using 867 bytes
!
interface GigabitEthernet0/0
ip address 10.20.20.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.30.30.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.10.1 255.255.255.0
clock rate 2000000
6
!
end
Также конфигурацию можно посмотреть по команде sh run или sh ip route:
Router#sh run
!
interface GigabitEthernet0/0
ip address 10.20.20.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.30.30.1 255.255.255.0
duplex auto
speed auto
!!
interface Serial0/0/0
ip address 192.168.10.1 255.255.255.0
clock rate 2000000
!
!
end
Router#
Router# sh ip route
Codes: L - local, C - connected, S - static, R
- RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.20.20.0/24 is directly connected, GigabitEthernet0/0
L 10.20.20.1/32 is directly connected, GigabitEthernet0/0
C 10.30.30.0/24 is directly connected, GigabitEthernet0/1
L 10.30.30.1/32 is directly connected, GigabitEthernet0/1
Router#
5.Объяснить, что показывают команды sh run и sh ip route и записать в отчет.
Часть 2. Настройка OSPFv2
7
1.Настройка OSPFv2 на маршрутизаторе R1, используя идентификатор процесса 1 и
идентификатор маршрутизатора 1.1.1.1.
Router(config)#router ospf 1
Router(config-router)#router-id 1.1.1.1
Router(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router(config-router)#network 10.20.20.0 0.0.0.255 area 1
Router(config-router)#network 10.30.30.0 0.0.0.255 area 1
2. Настройка OSPFv2 на маршрутизаторе R2, используя идентификатор процесса 1 и
идентификатор маршрутизатора 2.2.2.2
Router(config)#router ospf 1
Router(config-router)#router-id 2.2.2.2
Router(config-router)#network 192.168.10.0 255.255.255.0 area 0
Router(config-router)#network 192.168.20.0 255.255.255.0 area 0
Router(config-router)#network 10.40.40.0 255.255.255.0 area 0
Маска должна быть инверсной, но если вы укажете ее в обычном виде, как и в примере, то
программа изменит ее автоматически.
3. Настройка OSPFv2 на маршрутизаторе R3, используя идентификатор процесса 1 и
идентификатор маршрутизатора 3.3.3.3
Router(config)#router ospf 1
Router(config-router)#router-id 3.3.3.3
Router(config-router)#network 192.168.20.0 0.0.0.255 area 0
Router(config-router)#network 10.50.50.0 0.0.0.255 area 2
Router(config-router)#network 10.60.60.0 0.0.0.255 area 2
4. Аналогично настройте OSPFv2 на остальных маршрутизаторах.
Часть 3. Проверка и изучение OSPFv2 для нескольких областей
1. Проверьте подключение ко всем областям OSPFv2
С маршрутизатора R1 отправьте эхо-запросы каждому из следующих удалѐнных устройств в
области 0: 10.40.40.2 и области 2 : 10.50.50.2 и 10.60.60.2
Router#ping 10.40.40.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.40.40.2, timeout is 2 seconds:
!!!!!
8
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/18 ms
Router#
Router#ping 10.50.50.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.50.50.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 11/14/24 ms
Router#
Router#ping 10.60.60.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.60.60.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/14 ms
Router#
2.Что означает !!!!! в команде ping? Расскажите какие еще могут быть ответы команды ping
?
3. Используйте команды show для изучения текущей работы OSPFv2.
Сделать выводы по каждой команде и записать в отчет для Router 1.
Используйте следующие команды для сбора информации о текущей реализации OSPFv2 для
нескольких областей
show ip protocols
show ip route
show ip route ospf
show ip ospf database
show ip ospf interface
show ip ospf neighbor
Пример для Router 1:
1). Для проверки состояния OSPF используйте команду show ip protocols. Результат
команды показывает, какие протоколы маршрутизации настроены на маршрутизаторе. Он
также содержит конкретные данные протокола маршрутизации, такие как идентификатор
маршрутизатора, число областей для маршрутизатора и сети, входящие в конфигурацию
протокола маршрутизации.
Выполните команду Router#show ip protocols
Какие сети являются Routing for Networks?Какую ещѐ информацию показывает данная
команда?
9
2). Наиболее распространѐнной командой, используемой с целью проверки конфигурации
OSPF для нескольких областей, является команда show ip route
Router#sh ip route
К каким сетям имеются маршруты? Как получены значения метрики?Каковы
значения hext hop?
3). Добавьте параметр ospf к команде show ip route, чтобы вывести только данные,
относящиеся к OSPF.
Router#show ip route ospf
Прокомментируйте результат.
4). Используйте команду show ip ospf database для проверки содержимого базы данных
LSDB.
Для команды show ip ospf database доступно множество параметров.
Объясните , какие параметры можно просмотреть по данной команде.
5).
Выполните команду Router# show ip ospf interface
Проанализируйте, какую информацию выводит данная команда.
6).
Router#show ip ospf neighbor
Какие сведения можно получить по данной команде?
Вопросы к лабораторной работе 1
1.Что задает команда clock rate ?
2.Что показывает команда show ip protocols ?
3.Какую роль в лабораторной работе имеет протокол ICMP ?
4.В чѐм основное преимущество использования OSPF для нескольких областей?
5.Чем отличается команда sh ip route от sh ip route ospf ?
6.Найдите ошибку в данной команде Router(config)#network 10.50.50.0 0.0.0.255 area 2 ?
Лабораторная работа 2
Настройка OSPFv3 для нескольких областей
10
Часть 1. Построение сети. Настройка интерфейсов
1.Постройте сеть данной топологии
Рис.1.2
2. Настройте для всех интерфейсов индивидуальные адреса IPv6, приведѐнные в таблице
адресации.
Таблица 1
Устройство
Идентификатор
Интерфейс
Router1
1.1.1.1
Router2
2.2.2.2
Router3
3.3.3.3
PC0
PC1
PC2
PC3
PC4
-
S0/0/0(DCE)
G0/0
S0/0/0(DCE)
S0/0/1
G0/1
G0/0
S0/0/1
G0/0
G0/1
F0/0
F0/0
F0/0
F0/0
F0/0
IPv6
адрес
интерфейса
2001:db8:a:1::1/64
2001:db8:b:1::1/64
2001:db8:a:2::1/64
2001:db8:a:1::2/64
2001:db8:ab:1::1/64
2001:db8:bc:2::1/64
2001:db8:a:2::2/64
2001:db8:c:1::1/64
2001:db8:d:1::1/64
2001:db8:c:1::30/64
2001:db8:b:1::30/64
2001:db8:bc:2::30/64
2001:db8:ab:1::30/64
2001:db8:d:1::30/64
Область
OSPF
Area 0
Area 1
Area 0
Area0
Area 2
Area 2
Area 0
Area 0
Area 0
Area 0
Area 1
Area 2
Area 2
Area 0
Приведем пример для Router 1
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#int g0/0
11
Router(config-if)#ipv6 add 2001:db8:b:1::1/64
Router(config-if)#no shutdown
R1(config)#int s0/0/0
R1(config-if)#ipv6 add 2001:db8:a:1::1/64
R1(config-if)#clock rate 128000
R1(config-if)#no shutdown
Аналогично настраиваем все остальные интерфейсы в соответствии с таблицей 1.
Часть 2. Настройка OSPFv3
1.Включите
маршрутизацию
для
индивидуальной
адресации
IPv6 на каждом маршрутизаторе. Для этого необходимо использовать команду:
R1(config)#ipv6 unicast-routing
2.Настройка OSPFv3 на маршрутизаторе R1, используя идентификатор процесса 1 и
идентификатор маршрутизатора 1.1.1.1.
R1(config)#ipv6 router ospf 1
R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#exit
3. Объявите на маршрутизаторе R1 все напрямую подключенные сети протокола
OSPFv3.
Настройте OSPFv3 на всех включенных интерфейсах IPv6, назначая каждый интерфейс в
область, приведенную в таблице адресации.
R1(config)#int g0/0
R1(config-if)#ipv6 ospf 1 area 1
R1(config)#int s0/0/0
R1(config-if)#ipv6 ospf 1 area 0
4. Настройте OSPFv3 на маршрутизаторах R2 и R3.
Повторите шаги 1 - 3 для маршрутизаторов R2 и R3, изменяя идентификатор
маршрутизатора на 2.2.2.2 и 3.3.3.3, соответственно.
Часть 3. Проверьте работу OSPFv3 для нескольких областей
1.Проверьте подключение к каждой из областей OSPFv3.
С маршрутизатора R1 отправьте эхо-запросы каждому из следующих устройств в области 0 и
области 2: 2001:DB8:C:1::30, 2001:DB8:D:1::30, 2001:DB8:AB:1::30, 2001:DB8:BC:2::30 .
R1#ping 2001:DB8:C:1::30
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:C:1::30, timeout is 2 seconds:
12
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/9/26 ms
R1#ping 2001:DB8:D:1::30
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:D:1::30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/16/43 ms
R1#ping 2001:db8:ab:1::30
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:db8:ab:1::30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/17 ms
R1#ping 2001:db8:bc:2::30
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:db8:bc:2::30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/43 ms
Так же для проверки пошлем ping с PC 1
PC>ping 2001:db8:C:1::30
Pinging 2001:db8:C:1::30 with 32 bytes of data:
Reply from 2001:DB8:C:1::30: bytes=32 time=26ms TTL=125
Reply from 2001:DB8:C:1::30: bytes=32 time=12ms TTL=125
Reply from 2001:DB8:C:1::30: bytes=32 time=11ms TTL=125
Reply from 2001:DB8:C:1::30: bytes=32 time=17ms TTL=125
Ping statistics for 2001:DB8:C:1::30:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 11ms, Maximum = 26ms, Average = 16ms
PC>ping 2001:db8:D:1::30
Pinging 2001:db8:D:1::30 with 32 bytes of data:
Reply from 2001:DB8:D:1::30: bytes=32 time=14ms TTL=125
Reply from 2001:DB8:D:1::30: bytes=32 time=17ms TTL=125
Reply from 2001:DB8:D:1::30: bytes=32 time=13ms TTL=125
Reply from 2001:DB8:D:1::30: bytes=32 time=14ms TTL=125
Ping statistics for 2001:DB8:D:1::30:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
13
Approximate round trip times in milli-seconds:
Minimum = 13ms, Maximum = 17ms, Average = 14ms
PC>ping 2001:db8:AB:1::30
Pinging 2001:db8:AB:1::30 with 32 bytes of data:
Reply from 2001:DB8:AB:1::30: bytes=32 time=14ms TTL=126
Reply from 2001:DB8:AB:1::30: bytes=32 time=15ms TTL=126
Reply from 2001:DB8:AB:1::30: bytes=32 time=15ms TTL=126
Reply from 2001:DB8:AB:1::30: bytes=32 time=11ms TTL=126
Ping statistics for 2001:DB8:AB:1::30:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 11ms, Maximum = 15ms, Average = 13ms
PC>ping 2001:db8:BC:2::30
Pinging 2001:db8:BC:2::30 with 32 bytes of data:
Reply from 2001:DB8:BC:2::30: bytes=32 time=14ms TTL=126
Reply from 2001:DB8:BC:2::30: bytes=32 time=14ms TTL=126
Reply from 2001:DB8:BC:2::30: bytes=32 time=11ms TTL=126
Reply from 2001:DB8:BC:2::30: bytes=32 time=11ms TTL=126
Ping statistics for 2001:DB8:BC:2::30:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 11ms, Maximum = 14ms, Average = 12ms
2.Используйте команды show для изучения текущей работы OSPFv3.
Используйте следующие команды для сбора информации о реализации OSPFv3 для
нескольких областей.
2.1. R1# sh run
hostname R1
!
no ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:B:1::1/64
14
ipv6 ospf 1 area 1
!
interface Serial0/0/0
no ip address
ipv6 address 2001:DB8:A:1::1/64
ipv6 ospf 1 area 0
clock rate 128000
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
!
ipv6 router ospf 1
router-id 1.1.1.1
log-adjacency-changes
!
end
R1#
Где указано, что включения маршрутизация IPv6?
2.2. Выполните команду show ipv6 ospf
Что показывает эта команда?
2.3. show ipv6 route
R1# sh ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:DB8:A:1::/64 [0/0]
via Serial0/0/0, directly connected
L 2001:DB8:A:1::1/128 [0/0]
via Serial0/0/0, receive
O 2001:DB8:A:2::/64 [110/128]
via FE80::2D0:97FF:FE20:401, Serial0/0/0
C 2001:DB8:B:1::/64 [0/0]
via GigabitEthernet0/0, directly connected
L 2001:DB8:B:1::1/128 [0/0]
via GigabitEthernet0/0, receive
15
O 2001:DB8:C:1::/64 [110/129]
via FE80::2D0:97FF:FE20:401, Serial0/0/0
O 2001:DB8:D:1::/64 [110/129]
via FE80::2D0:97FF:FE20:401, Serial0/0/0
OI 2001:DB8:AB:1::/64 [110/65]
via FE80::2D0:97FF:FE20:401, Serial0/0/0
OI 2001:DB8:BC:2::/64 [110/65]
via FE80::2D0:97FF:FE20:401, Serial0/0/0
L FF00::/8 [0/0]
via Null0, receive
R1#
Какие сети являются внешними OSPF сетями? Как задаются идентификаторы в сетях
IPv6 ?
2.4. show ipv6 ospf database
R1# sh ipv6 ospf database
Прокомментируйте данную команду.
show ipv6 ospf interface
R1# sh ipv6 ospf interface
К каким областям относятся интерфейсы маршрутизатора?
show ipv6 ospf neighbor
R1# sh ipv6 ospf neighbor
Какие сведения нам дает данная команда и как она помогает проверить настроено ли
OSPFv3 ?
Вопросы к лабораторной работе 2
1.Какая команда позволяет включить маршрутизацию для индивидуальной адресации IPv6?
2.В чем заключается упрощение конфигурирования OSPFv3 по сравнению OSPFv2?
3.Как задается идентификатор в конфигурировании OSPFv3?
4.Как задается маска в IPv6 ?
5.Какое расширение появится после команды ipv6 router ospf 1 ?
Лабораторная работа 3
Поиск и устранение неполадок в сети OSPFv3 для нескольких областей
Часть 1. Построение сети. Настройка интерфейсов
16
Рис. 1.3
Таблица 1
Устройство
Идентификатор
Интерфейс
IPv6
интерфейса
адрес Область
OSPF
Router1
1.1.1.1
Router2
2.2.2.2
PC1
-
S0/0/1
G0/0
S0/0/0(DCE)
G0/0
F0/0
2001:db8:a:2::2/64
2001:db8:a:3::1/64
2001:db8:a:2::1/64
2001:db8:a:1::1/64
2001:db8:a:3::4/64
Area 0
Area 2
Area 0
Area 1
Area 2
PC2
-
F0/0
2001:db8:a:1::4/64
Area 1
Часть 2. Проверьте работу OSPFv3 для нескольких областей
1.Проверьте подключение к каждой из областей OSPFv3.
С маршрутизатора R1 отправьте эхо-запросы устройству в области 1
R1#ping 2001:db8:a:1::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:db8:a:1::4, timeout is 2 seconds:
.....
17
Success rate is 0 percent (0/5)
Видно, что в работе OSPFv3 имеются неполадки.
2.Используйте команды show для изучения текущей работы OSPFv3.
R1#sh run
Building configuration...
hostname R1
!
no ip cef
ipv6 unicast-routing
!
no ipv6 cef
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:A:3::1/64
!
interface Serial0/0/1
no ip address
ipv6 address 2001:DB8:A:4::2/64
ipv6 ospf 1 area 0
!
ipv6 router ospf 1
router-id 1.1.1.1
log-adjacency-changes
!
end
R2# sh run
hostname R2
!
no ip cef
ipv6 unicast-routing
!
no ipv6 cef
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:A:1::1/64
ipv6 ospf 1 area 1
!
interface Serial0/0/0
no ip address
ipv6 address 2001:DB8:A:2::1/64
18
ipv6 ospf 1 area 3
clock rate 128000
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
!
End
R1#sh ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:DB8:A:3::/64 [0/0]
via GigabitEthernet0/0, directly connected
L 2001:DB8:A:3::1/128 [0/0]
via GigabitEthernet0/0, receive
C 2001:DB8:A:4::/64 [0/0]
via Serial0/0/1, directly connected
L 2001:DB8:A:4::2/128 [0/0]
via Serial0/0/1, receive
L FF00::/8 [0/0]
via Null0, receive
R1#
R2#sh ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:DB8:A:1::/64 [0/0]
via GigabitEthernet0/0, directly connected
L 2001:DB8:A:1::1/128 [0/0]
via GigabitEthernet0/0, receive
C 2001:DB8:A:2::/64 [0/0]
via Serial0/0/0, directly connected
L 2001:DB8:A:2::1/1
3.Проанализируйте полученную информацию и исправьте ошибки в работе OSPFv3
Благодаря командам show можно увидеть 2 ошибки в настройках OSPFv3 для
нескольких областей:
1).Неверно указан адрес интерфейса S0/0/1 маршрутизатора R1
19
Для устранения данной неполадки необходимо сначала отменить существующий адрес, а
потом задать новый.
R1(config)#int s0/0/1
R1(config-if)#ip
R1(config-if)#no ipv6 add 2001:db8:a:4::2/64
R1(config-if)#ipv6 add 2001:db8:a:2::2/64
2).Неверно указана область , к которой относится интерфейс S0/0/0 маршрутизатора R2
Для устранения ошибки необходимо просто перезаписать команду назначения интерфейса в
область, приведенную в таблице адресации.
R2(config)#int s0/0/0
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#
Обязательно проверьте конфигурацию после настройки по команде sh run.
4.Проверьте подключение к каждой из областей OSPFv3.
4.1. С маршрутизатора R1 отправьте эхо-запросы устройству в области 1
R1# ping 2001:db8:a:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:db8:a:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R1#
R1# ping 2001:db8:a:1::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:db8:a:1::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/11/51 ms
4.2. Теперь с конечного устройства из области 1 с PC 2 отправьте ping на R1
PC>ping 2001:DB8:A:2::2
Pinging 2001:DB8:A:2::2 with 32 bytes of data:
Request timed out.
5. Так как, ping не проходит , следовательно, не все ошибки устранены, но процесс
маршрутизации настроен. Необходимо проверить настройки на конечном узле PC2
20
Рис. 1.4
Из данной конфигурации можно увидеть , что неверно указан «шлюз по умолчанию».
Необходимо исправить IPv6 Default Gateway .
6. Теперь с конечного устройства из области 1 с PC 2 отправьте ping на R1 и на конечный
узел из области 2 на PC 2
PC>ping 2001:DB8:A:2::2
Pinging 2001:DB8:A:2::2 with 32 bytes of data:
Reply from 2001:DB8:A:2::2: bytes=32 time=2ms TTL=254
Reply from 2001:DB8:A:2::2: bytes=32 time=1ms TTL=254
Reply from 2001:DB8:A:2::2: bytes=32 time=1ms TTL=254
Reply from 2001:DB8:A:2::2: bytes=32 time=1ms TTL=254
Ping statistics for 2001:DB8:A:2::2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 2ms, Average = 1ms
PC>ping 2001:DB8:A:3::4
Pinging 2001:DB8:A:3::4 with 32 bytes of data:
Reply from 2001:DB8:A:3::4: bytes=32 time=12ms TTL=126
Reply from 2001:DB8:A:3::4: bytes=32 time=17ms TTL=126
Reply from 2001:DB8:A:3::4: bytes=32 time=14ms TTL=126
21
Reply from 2001:DB8:A:3::4: bytes=32 time=14ms TTL=126
Ping statistics for 2001:DB8:A:3::4:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 12ms, Maximum = 17ms, Average = 14ms
7.Выполните команды sh run
и
sh ipv6 route
на маршрутизаторах R1 и R2.
Прокомментируйте их и занесите их в отчет.
Вопросы к лабораторной работе 3
1.С каких команд необходимо начинать поиск неполадок в сети?
2.Если неверно указан адрес интерфейса IPv6, то как его исправить?
3.Если неверно указан маршрут, то как его исправить?
4.Для чего нужен Default Gateway ?
5.В стек какого протокола входит команда ping ?
6.Приведите пример ошибки , если команда ping от РС1 к РС2 проходит, а от РС2 к РС1 нет?
7.Приведите пример не менее 3 неполадок в сети.
Лабораторная работа 4
22
Настройка комбинированной сети с использованием протоколов OSPFv2 и OSPFv3
1. Построение сети. Настройка интерфейсов
Рис. 1.5
Таблица 1
Устройство
Идентификатор
Интерфейс
IP адрес интерфейса
Область
OSPF
Router 1
Router 2
1.1.1.1
2.2.2.2
Router 3
3.3.3.3
Router 4
4.4.4.4
Router 5
5.5.5.5
G0/0
G0/1
G0/0
Tunnel 0
G0/0
G0/1
G0/0
G0/1
Tunnel 0
G0/1
2001:128:0:1::7/64
2001:128:0:1::1/64
192.168.2.1/24
2001:128:0:23::1/64
192.168.3.2/24
192.168.2.2/24
2001:128:0:4::3/64
192.168.3.3/24
2001:128:0:23::3/64
2001:128:0:4::4/64
Area 0
Area 0
Area 1
Area 0
Area 1
Area 1
Area 0
Area 1
Area 0
Area 0
2.Настройка туннелирования.
В переходный период будут существовать оба сетевых протокола IPv4 и IPv6. В
одних сетях будет использоваться IPv4 , в других – IPv6. Поэтому необходимы механизмы
перехода из одной сети в другую. Можно отметить три метода сетевой миграции:
1.двойной стек;
2.туннелирование;
3.преобразование адресов.
В данной лабораторной работе используется туннелирование. При туннелировании пакеты
IPv6 инкапсулируются в пакеты IPv4 , при этом , пакеты IPv6 воспринимаются как обычные
передаваемые данные. Это позволяет передавать пакеты IPv6 через сети IPv4.
Пример конфигурирования интерфейса Tunnel 0 на маршрутизаторе R2:
23
R2(config)#interface Tunnel0
R2(config-if)#ipv6 address 2001:128:0:23::1/64
R2(config-if)#tunnel source GigabitEthernet0/0
R2(config-if)#tunnel destination 192.168.3.3
R2(config-if)#tunnel mode ipv6ip
Аналогично настройте интерфейс Tunnel 0 на маршрутизаторе R4.
3. Настройка OSPFv2
.Настройка OSPFv2 на маршрутизаторе R2, используя идентификатор процесса 1 и
идентификатор маршрутизатора2.2.2.2
Router(config)#router ospf 1
Router(config-router)#router-id 2.2.2.2
Router(config-router)#network 192.168.2.0 0.0.0.255 area 1
4. Настройка OSPFv3
Включите
маршрутизацию
для
индивидуальной
адресации
IPv6 на каждом маршрутизаторе. Для этого необходимо использовать команду:
R2(config)#ipv6 unicast-routing
5.Настройка OSPFv3 на маршрутизаторе R2, используя идентификатор процесса 1 и
идентификатор маршрутизатора 2.2.2.2
R2(config)#ipv6 router ospf 1
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#exit
6. Объявите на маршрутизаторе R2 все напрямую подключенные сети протокола
OSPFv3.
Настройте OSPFv3 на всех включенных интерфейсах IPv6, назначая каждый интерфейс в
область, приведенную в таблице адресации.
R1(config)#int g0/1
R1(config-if)#ipv6 ospf 1 area 0
R1(config)#int Tunnel 0
R1(config-if)#ipv6 ospf 1 area 0
7. Для проверки работы выполните командв sh run , sh ip route и sh ipv6 route
8. Для проверки работы также используйте команду traceroute :
R1#traceroute 2001:128:0:4::4
Type escape sequence to abort.
Tracing the route to 2001:128:0:4::4
1 2001:128:0:1::1 1 msec 0 msec 0 msec
2 2001:128:0:23::3 11 msec 11 msec 16 msec
24
3 2001:128:0:4::4 16 msec 16 msec 10 msec
R1#
R5#traceroute 2001:128:0:1::7
Type escape sequence to abort.
Tracing the route to 2001:128:0:1::7
1 2001:128:0:4::3 2 msec 0 msec 0 msec
2 2001:128:0:23::1 16 msec 16 msec 12 msec
3 2001:128:0:1::7 15 msec 10 msec 10 msec
R5#
Проанализируйте данную команду.
Так же проверьте работу внутри области 1:
R2#ping 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
R4#traceroute 192.168.2.1
Type escape sequence to abort.
Tracing the route to 192.168.2.1
1 192.168.3.2 1 msec 0 msec 2 msec
2 192.168.2.1 0 msec 0 msec 0 msec
Вопросы к лабораторной работе 4
1.В чем отличие команд traceroute и ping ?
2.Какое назначение имеет данная команда R2(config-if)#tunnel mode ipv6ip?
3.В каком состоянии по умолчанию находится интерфейс Tunnel ?
4.Как команда sh ipv6 route позволяет показать, что используется метод туннелирования?
5.Влияет ли туннель на работу сети IPv4 области 1?
ПРОТОКОЛ BGP
Конфигурирование сети на реальном оборудовании
25
Оборудование лаборатории «Технологии пакетной коммутации» включает 6
маршрутизаторов 2800 фирмы Cisco, 6 коммутаторов 2960 фирмы Catalyst, размещенных в
двух телекоммуникационных шкафах (рис. 2.1).
Рис. 2.1.
Кроме того, оборудование включает 12 компьютеров, шесть из которых используются
для подключения к консольным портам маршрутизаторов с целью их конфигурирования, а 6
– подключены к коммутаторам для создания сети (рис. 2.2).
26
Рис. 2.2.
1.
Убедиться,
что
консольные
кабели
(плоские
голубого
цвета)
компьютеров №12, №10, №8, №6, №4, №2 подсоединены к СОМ- портам и выведены
на соответствующий разъем (помечен символом С).
2.
С помощью «патч-кордов» соединить последовательные интерфейсы
СОМ1 компьютеров №12, №10, №8, №6, №4, №2 с консольными портами
маршрутизаторов согласно схеме рис. 1.1.
3.
Включить коммутаторы и маршрутизаторы.
27
Работа с Hyper Terminal
На рабочем столе компьютера найти программу
Hyper Terminal и
запустить ее.
Далее создать новое подключение и установить следующие настройки (Рис. 2.3):
Рис. 2.3
Запускается программа Hyper Terminal. При появлении сообщения "Would you like to
enter the initial configuration dialog ?" (Рис. 2.4) прописать "no" и нажать Enter.
28
Рис. 2.4
Далее можно приступить к работе.
Важно! Перед началом конфигурирования сбросьте все существующие настройки
маршрутизаторов!
Лабораторная работа №1
Настройка протокола BGP с использованием
маршрутизации по умолчанию
1.
Подготовка маршрутизаторов для работы.
Постройте сеть согласно топологии сети (рис. 2.5).
Необходимые ресурсы:
3 маршрутизатора Cisco 2801
3 коммутатора Cisco 2960
3 персональных компьютера
Последовательные и консольные кабели, Ethernet кабели.
29
Рис. 2.5
2. Конфигурирование имен хостов и адресов интерфейсов.
2.1.
Назначьте имена маршрутизаторов. Используя схему адресации показанную в
топологии, создайте последовательные интерфейсы и назначьте IP-адреса этих и
последовательные интерфейсов на R-A (R1), R-C (R3), и R-B (R2). Loopbacks интерфейсы RA, R-C имитируют реальные сети, которые могут быть достигнуты через R-A, R-C. Два
последовательных интерфейса для маршрутизатора R-B имитируют связь между граничным
маршрутизатором R-B и их ключевых маршрутизаторов. Установите адресную информацию,
в том числе clock rate, на всех интерфейсах, чтобы получилась конфигурация, приведенная в
п.2.2. Используйте команду Ping для проверки подключения между непосредственно
связанными маршрутизаторами. Обратите внимание, что маршрутизатор R-A не может
достичь маршрутизатор R-C.
2.2.
После настройки команда show running-config должна показать следующие
конфигурации маршрутизароров:
30
Router R1 (hostname R-A)
hostname R-A
!
interface Lo0
description R-A Internet Network
ip address 10.1.1.1 255.255.255.0
!
interface Serial0/3/0
description R-A -> R-B
ip address 10.0.0.1 255.255.255.252
clock rate 128000
no shutdown
!
end
Router R2 (hostname R-B)
hostname R-B
!
interface Lo0
description Core router network link 1
ip address 192.168.0.1 255.255.255.0
!
interface Lo1
description Core router network link 2
ip address 192.168.1.1 255.255.255.0
!
interface Serial0/3/0 description R-B -> R-A
ip address 10.0.0.2 255.255.255.252
no shutdown
interface Serial0/3/1
description R-B -> R-C
ip address 172.16.0.2 255.255.255.252
clock rate 128000
no shutdown
!
end
Router R3 (hostname R-C)
hostname R-C
!
interface Lo0
description R-C Internet Network
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/3/1
description R-C -> R-B
ip address 172.16.0.1 255.255.255.252
31
no shutdown
!
end
3. Настройка протокола BGP на маршрутизаторах.
3.1.
Настройте BGP на маршрутизаторах R-A и R-C.
R-A(config)# router bgp 200
R-A(config-router)# neighbor 10.0.0.2 remote-as 100
R-A(config-router)# network 10.1.1.0 mask 255.255.255.0
R-C(config)# router bgp 300
R-C(config-router)# neighbor 172.16.0.2 remote-as 100
R-C(config-router)# network 172.16.1.0 mask 255.255.255.0
3.2.
Настройте BGP на граничном маршрутизаторе R-B.
R-B(config)# router bgp 100
R-B(config-router)# neighbor 10.0.0.1 remote-as 200
R-B(config-router)# neighbor 172.16.0.1 remote-as 300
R-B(config-router)# network 192.168.0.0
R-B(config-router)# network 192.168.1.0
Вы должны увидеть сообщение на консоли, похожее на следующее
*May 4 15:07:38.667: %BGP-5-ADJCHANGE: neighbor 10.0.0.2 Up
Прокомментируйте вышеприведенные конфигурации!
3.3.
Чтобы проверить конфигурацию, проверьте таблицу маршрутизации R-B
командой show ip route.
R-B# show ip route
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:00:32
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:31
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
32
R-B имеет маршруты к сетям loopback на каждом маршрутизаторe R-A, R-C.
Прокомментируйте вышеприведенную таблицу маршрутизации!
Каково административное расстояние протокола BGP?
4. Проверка BGP на маршрутизаторах.
4.1.
Чтобы проверить работу BGP на R-B, выполните команду show ip bgp.
R-B# show ip bgp
BGP table version is 5, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next
Metric LocPrf
Weight Path
*> 10.1.1.0/24
Hop
0
0 200 i
*> 172.16.1.0/24
0
0 300 i
*> 192.168.0.0
172.16.0.1
10.0.0.
0.0.0.0
1
0
32768
i
*> 192.168.1.0
0.0.0.0
0
32768
i
Какой ID у локального маршрутизатора?
Какая версия таблицы отображается?
Что показывает звездочка (*) и угловая скобка (>)?
4.2.
Чтобы проверить работу R-A, используйте команду show ip bgp.
R-A# show ip bgp
BGP table version is 5, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next
*> 10.1.1.0/24
Hop
*> 172.16.1.0/24
10.0.0.2
0.0.0.
10.0.0.2
0
*> 192.168.0.0
Metric LocPrf
0
Weight32768 Path
i
0100 300 i
0
0100i
33
*> 192.168.1.0
10.0.0.2
0
0100i
Какой путь к сети 172.16.1.0/24 от R-A?
4.3.
На маршрутизаторе R-A, выполните команду shutdown на Loopback0. Затем на
R-B, выполните еще раз команду show ip bgp.
R-B# show ip bgp
BGP table version is 6, local router ID is 192.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next Hop
*>
*> 172.16.1.0/24
10.1.1.0/24
10.0.0.1
172.16.0.1
*> 192.168.0.0
*> 192.168.1.0
Metric LocPrf
Weight Path
0.0.0.0
0
0
0 300
200 i
32768
i
0.0.0.0
0
32768
i
Какая отображается версия таблицы? Почему?
Что случилось с маршрутом для сети 10.1.1.0/24?
4.4.
Включите заново Loopback0 маршрутизатора R-A используя команду no
shutdown. Прокомментируйте изменения в таблице BGP.
4.5.
На R-B выполнить команду show ip bgp neighbors. Ниже приводится часть
распечатки, команда показывает соседа 172.16.0.1.
BGP neighbor is 172.16.0.1, remote AS 300, external link
BGP version 4, remote router ID 172.16.1.1
BGP state = Established, up for 00:16:00
Last read 00:00:54, last write 00:00:43, hold time is 180, keepalive
Interval is 60 seconds
Neighbor capabilities:Route refresh: advertised and received(new) New ASN Capability:
advertised and received
Address family IPv4 Unicast: advertised and received
Message statistics:
34
InQ depth is 0
OutQ depth is 0
Sent
Rcvd
Opens:
1
1
Notifications:
0
0
Updates:
5
1
15
17
0
0
21
19
Keepalives:
Route Refresh:
Total:
Default minimum time between advertisement runs is 30 seconds
<output omitted>
На основе результатов этой команды сделайте вывод о том, каково состояние
между этим маршрутизатором и маршрутизатором R-C?
Как долго было включено это соединение?
5. Настройка фильтров маршрутов.
5.1.
Проверьте таблицу маршрутизации R-C с помощью команды show ip route. R-
C должен иметь маршрут к сети 10.1.1.0.
R-C# show ip route
<output omitted>
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
C 172.16.1.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
B 10.1.1.0 [20/0] via 172.16.0.2, 00:05:22
B 192.168.0.0/24 [20/0] via 172.16.0.2, 00:17:45
B 192.168.1.0/24 [20/0] via 172.16.0.2, 00:17:45
Если R-B объявляет маршрут, принадлежащий R-A, R-C устанавливает этот
маршрут в своей таблице. R-C может затем попытаться маршрутизировать транзит
трафика через R-B. Необходимо запретить транзит трафика. Настройте маршрутизатор R-B
35
так, чтобы он объявлял только сети R-B 192.168.0.0 и 192.168.1.0 для двух маршрутизаторов
R-A и R-C.
5.2.
На маршрутизаторе R-B, настройте список доступа, который разрешает
доступ всем узлам сети 192.168.0.0 0.0.1.255.
R-B(config)# access-list 1 permit 192.168.0.0 0.0.1.255
5.3.
Применить этот список доступа в качестве фильтра маршрутов, используя
ключевое слово distribute-list вместе с ВGP neighbor заявлением.
R-B(config)# router bgp 100
R-B(config-router)# neighbor 10.0.0.1 distribute-list 1 out
R-B(config-router)# neighbor 172.16.0.1 distribute-list 1 out
Какую функцию выполняет параметр distribute-list 1 out?
5.4.
Снова проверьте таблицу маршрутизации для R-C. Пути к 10.1.1.0, R-A,
должны остаться в таблице. Почему?
5.5.
Вернуться к R-B и выдать команду clear ip bgp. Подождите, пока
маршрутизаторы достигают исходных состояний, это может занять несколько секунд, а
затем снова проверьте таблицу маршрутизации R-C. Путь к R-A, сети 10.1.1.0, не должен
быть в таблице маршрутизации для R-C, и путь к R-C, сеть 172.16.1.0, не должен быть в
таблице маршрутизации для R-A.
R-B# clear ip bgp *
R-B#
*May 4 15:45:28.091: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Down User reset
*May 4 15:45:28.091: %BGP-5-ADJCHANGE: neighbor 172.16.0.1 Down User reset
*May 4 15:45:31.151: %BGP-5-ADJCHANGE: neighbor 172.16.0.1 Up
*May 4 15:45:47.095: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Up
Примечание: Команда clear ip bgp * разрушительна, потому что она полностью
сбрасывает все смежности BGP. Это является приемлемым в лабораторных условиях, но
может быть проблематичным в производственной сети. Вместо этого, если только
изменение входящей / исходящей политики маршрутизации должно быть выполнено
36
достаточно оформить команды clear ip bgp * in или clear ip bgp *out. Эти команды
выполняют только синхронизацию новой базы данных BGP без разрушительных
последствий полного сброса смежности BGP. Все текущие Cisco IOS версии поддерживают
возможность обновления маршрута, который заменяет функцию входящей
мягкой
реконфигурации, что ранее нужно было настраивать на каждого соседа.
R-C# show ip route
<output omitted>
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
C 172.16.1.0/24 is directly connected, Loopback0
B 192.168.0.0/24 [20/0] via 172.16.0.2, 00:02:13
B 192.168.1.0/24 [20/0] via 172.16.0.2, 00:02:13
R-A# show ip route
<output omitted>
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Loopback0
C 10.0.0.0/30 is directly connected, Serial0/3/0
B 192.168.0.0/24 [20/0] via 10.0.0.2, 00:05:06
B 192.168.1.0/24 [20/0] via 10.0.0.2, 00:05:06
Прокомментируйте полученные таблицы маршрутизации.
6. Настройка основного и резервного маршрутов с использованием плавающих
статических маршрутов.
6.1.
Выполните команду show ip route на маршрутизаторе R-B.
R-B# show ip route
<output omitted>
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:06:58
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
37
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:06:58
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
Обратите внимание, что шлюз последней надежды не определен.
6.2.
В рассматриваемых примерах R-B моделирует сетевого оператора, R-A -
основного провайдера, R-C - дублирующего провайдера, показатель расстояния для
маршрута к R-A (210) по сравнению с трассой резервного копирования в R-C (расстояние
метрической 220).
R-B(config)# ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
R-B(config)# ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
6.3.
При помощи команды show ip route убедитесь, что маршрут по умолчанию
определен.
R-B# show ip route
<output omitted>
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:11:41
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:11:41
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [210/0] via 10.0.0.1
6.4.
Проверить этот маршрут по умолчанию путем создания неоповещаемого
последовательного интерфейса на маршрутизаторе для R-A.
R-A# config t
R-A(config)# interface loopback 100
R-A(config-if)# ip address 192.168.100.1 255.255.255.0
38
6.5.
Выполните команду show ip route для того, чтобы убедиться в том, что вновь
добавленный адрес 192.168.100.0/24 сети не появился в таблице маршрутизации.
R-B# show ip route
<output omitted>
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:16:24
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:01:47
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
S* 0.0.0.0/0 [210/0] via 10.0.0.1
Прокомментируйте полученные таблицы маршрутизации.
6.6.
Выполните расширенный режим Ping интерфейса 192.168.100.1 R-A loopback1
с источником происходящих от границы 192.168.1.1 R-B loopback1.
R-B# ping
Protocol [ip]:
Target IP address: 192.168.100.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 192.168.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
39
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/36 ms
Примечание: Вы можете пропустить запрос расширенного режима ping и выполнить
при
ping
задании
адреса
источника
с
помощью
одной из этих сокращенных команд:
R-B# ping 192.168.100.1 source 192.168.1.1
или
R-B# ping 192.168.100.1 source Lo1
7. Настройка основного и резервного маршрута, используя сеть по умолчанию и
статические маршруты.
7.1.
Другой способ настройки основного и резервного маршрутов является
использование команды ip default-network вместо маршрута 0.0.0.0/0. Удалите плавающие
статические маршруты, настроенные в шаге 7.
R-B(config)# no ip route 0.0.0.0 0.0.0.0 10.0.0.1 210
R-B(config)# no ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
7.2.
Сеть, которая была добавлена в шаге 7, 192.168.100.0/24, теперь должна быть
объявлена на маршрутизаторе R-A. Вам, возможно, потребуется подождать несколько
секунд, чтобы BGP оповестил новую сеть.
R-A(config)# router bgp 200
R-A(config-router)# network 192.168.100.0
R-A(config-router)# end
7.3.
Убедитесь,
что
классовая
сеть
192.168.100.0/24
появится
в
таблице
маршрутизации R-B.
R-B# show ip route
<output omitted>
40
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:30:10
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:02:33
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:02:33
7.4.
На маршрутизаторе R-B, настроить ip default-network для восстановления
шлюза последней инстанции.
R-B(config)# ip default-network 192.168.100.0
Примечание: режим этой команды ориентирован на традиционную адресацию на
основе полного класса.
7.5.
Подождите несколько минут, а затем пересмотрите таблицу маршрутизации на
R-B.
R-B# show ip route
<output omitted>
Gateway of last resort is 10.0.0.1 to network 192.168.100.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:32:55
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:05:19
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
41
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:05:19
Эта команда устанавливает R-A в качестве единственного маршрута по умолчанию.
7.6.
Сделате на R-C резервное соединение, добавив резервный маршрут на R-B к
R-C serial 0/0/1 interface 172.16.0.1.
R-B(config)# ip route 0.0.0.0 0.0.0.0 172.16.0.1 220
Маршрут по умолчанию выступает в качестве резервной копии, если 192.168.100.0 /
24 сеть недоступна из-за неисправности или неправильной работы, или в течение короткого
периода
7.7.
после
Убедитесь,
последовательный
команды
что
маршрут
clear
недавно
по
ip
добавленный
умолчанию
в
то
bgp
маршрут
время
как
10.0.0.1.
устанавливает
соединение
BGP
между R-B и R-A восстанавливается. Обратите внимание, что таблица маршрутизации
включает
в
себя
два
маршрута
кандидата
по
умолчанию
(*), только один из которых используется, из-за различных административных расстояниях.
R-B# show ip route
<output omitted>
Gateway of last resort is 10.0.0.1 to network 192.168.100.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:35:42
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:08:05
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:08:05
S* 0.0.0.0/0 [220/0] via 172.16.0.1
R-B# clear ip bgp 10.0.0.1
R-B# show ip route
<output omitted>
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
42
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:36:46
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:00:00
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B 192.168.100.0/24 [20/0] via 10.0.0.1, 00:00:00
S* 0.0.0.0/0 [220/0] via 172.16.0.1
Спустя время маршрут восстанавливается.
R-B# show ip route
<output omitted>
Gateway of last resort is 10.0.0.1 to network 192.168.100.0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Serial0/3/1
B 172.16.1.0/24 [20/0] via 172.16.0.1, 00:38:05
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [20/0] via 10.0.0.1, 00:01:19
C 10.0.0.0/30 is directly connected, Serial0/3/0
C 192.168.0.0/24 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Loopback1
B* 192.168.100.0/24 [20/0] via 10.0.0.1, 00:01:19
S* 0.0.0.0/0 [220/0] via 172.16.0.1
7.8.
Выполните следующий Tcl skript на всех маршрутизаторах, чтобы проверить,
есть ли подключение.
R-B# tclsh
R-B(tsl)# foreach address { 10.0.0.1
10.0.0.2
10.1.1.1
172.16.0.1
43
172.16.0.2
172.16.1.1
192.168.0.1
192.168.1.1
192.168.100.1
} { ping $address }
Могут ли R-A и R-C пинговать все компоненты в сети?
Лабораторная работа №2
Использование атрибута AS_PATH
1. Подготовка маршрутизаторов для работы.
Постройте сеть согласно топологии сети (рис. 2.6).
Необходимые ресурсы:
3 маршрутизатора Cisco 2801
3 коммутатора Cisco 2960
3 персональных компьютера
Последовательные и консольные кабели, Ethernet кабели
44
Рис. 2.6
2. Конфигурирование имен хостов и адресов интерфейсов.
2.1.
Назначьте имена маршрутизаторов. Используя схему адресации показанную в
топологии, создайте последовательные интерфейсы и назначьте IP-адреса этих и
последовательные интерфейсов. Установите clock rate на последовательных интерфейсах
DCE. Используйте команду Ping для проверки подключения между непосредственно
связанными маршрутизаторами. R-A не сможет достичь ни последовательный интерфейс
провайдера (10.2.2.1) ни последовательный интерфейс R-C (10.3.3.1).
2.2.
После настройки команда show running-config должна показать следующие
конфигурации маршрутизароров:
Router R1 (hostname R-A)
45
hostname R-A
!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Serial0/3/0
ip address 192.168.1.5 255.255.255.252
clock rate 128000
no shutdown
Router R2 (hostname R-B)
hostname R-B
!
interface Loopback0
ip address 10.2.2.1 255.255.255.0
!
interface Serial0/3/0
ip address 192.168.1.6 255.255.255.252
no shutdown
!
interface Serial0/3/1
ip address 172.24.1.17 255.255.255.252
clock rate 128000
no shutdown
Router R3 (hostname R-C)
hostname R-C
!
interface Loopback0
ip address 10.3.3.1 255.255.255.0
!
interface Serial0/3/1
ip address 172.24.1.18 255.255.255.252
no shutdown
3. Настройка BGP.
3.1.
Настройте BGP для нормальной работы. Введите необходимые команды BGP
на маршрутизаторах, так чтобы они определили своих BGP соседей и оповещали свои
закольцованные сети.
R-A (config)# router bgp 100
R-A(config-router)# neighbor 192.168.1.6 remote-as 300
R-A (config-router)# network 10.1.1.0 mask 255.255.255.0
R-B(config)# router bgp 300
46
R-B(config-router)# neighbor 192.168.1.5 remote-as 100
R-B(config-router)# neighbor 172.24.1.18 remote-as 65000
R-B(config-router)# network 10.2.2.0 mask 255.255.255.0
R-C(config)# router bgp 65000
R-C(config-router)# neighbor 172.24.1.17 remote-as 300
R-C(config-router)# network 10.3.3.0 mask 255.255.255.0
3.2.
Убедитесь, что маршрутизаторы установили соответствующие отношения c
соседями, выполнив команду show ip bgp neighbors на маршрутизаторах.
R-B# show ip bgp neighbors
BGP neighbor is 172.24.1.18, remote AS 65000, external link
BGP version 4, remote router ID 10.3.3.1
BGP state = Established, up for 00:02:05
<output omitted>
BGP neighbor is 192.168.1.5, remote AS 100, external link
BGP version 4, remote router ID 10.1.1.1
BGP state = Established, up for 00:04:19
<output omitted>
4. Отключение номера частной AS.
4.1.
Отобразите таблицу маршрутизации R-A с помощью команды show ip route.
R-A должен иметь маршрут к 10.2.2.0 и 10.3.3.0. Устраните неполадки, если это необходимо.
R-A# show ip route
...
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 3 subnets
B
10.3.3.0 [20/0] via 192.168.1.6, 00:01:11
B
10.2.2.0 [20/0] via 192.168.1.6, 00:02:16
C
10.1.1.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C
4.2.
192.168.1.4 is directly connected, Serial0/3/0
Выполните Ping адреса 10.3.3.1 с R-A.
47
Почему результат "прозвонки" отрицательный?
4.3.
Выполните Ping снова, на этот раз в качестве расширенного Ping, исходящего
из адреса интерфейса Loopback0.
R-A# ping
Protocol [ip]:
Target IP address: 10.3.3.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.1.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/64/68 ms
Примечание: Вы можете пропустить расширенный режим Ping и указать адрес
источника, используя одну из следующих команд:
R-A# ping 10.3.3.1 source 10.1.1.1
or
R-A# ping 10.3.3.1 source Lo0
Прокомментируйте результат.
4.4.
Проверьте таблицу BGP от R-A с помощью команды show ip bgp. Обратите
внимание на путь к сети 10.3.3.0 . AS 65000 должен быть указан в пути к 10.3.3.0.
48
R-A# show ip bgp
BGP table version is 5, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next Hop
Metric LocPrf Weight Path
*> 10.1.1.0
0.0.0.0
0
*> 10.2.2.0
192.168.1.6
0
*> 10.3.3.0
192.168.1.6
32768
i
0 300 i
0 300 65000 i
Примечание: AS 65000 является частной AS, которая не должна публично
оповещаться в Интернете. В противном случае, клиенты двух взаимосвязанных провайдеров,
имеющие тот же самый секретный номер AS видели бы свои собственные AS, в маршруте
объявления друг от друга. В результате, каждый клиент будет неправильно делать вывод, что
оповещения пришли от самого себя , и он будет игнорировать его.
4.5.
Настройте R-B, чтобы лишить AS частных номеров у BGP маршрутов
обменивающихся с R-A, используя слеедующие команды.
R-B(config)# router bgp 300
R-B(config-router)# neighbor 192.168.1.5 remove-private-as
4.6.
После использования этих команд, используйте команду clear ip bgp * на
маршрутизаторе
провайдера,
чтобы
восстановить
BGP
отношение
между
тремя
маршрутизаторами. Подождите несколько секунд, а затем вернитесь к R-A, чтобы проверить
его таблицы маршрутизации. Примечание:
команда clear ip bgp *
также может быть
использована для осуществления отправки BGP таблицы каждым маршрутизатором.
Есть ли еще у R-A маршрут к 10.3.3.0?
R-A должен пинговать сеть 10.3.3.1, используя его loopback 0 интерфейс в качестве
источника пингования.
R-A# ping 10.3.3.1 source lo0
49
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms
4.7.
Теперь проверьте таблицу BGP на R-A. AS_PATH к сети 10.3.3.0 должен быть
AS 300. AS_PATH больше не имеет частных AS в пути.
R-A# show ip bgp
BGP table version is 8, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next Hop
*> 10.1.1.0
*> 10.2.2.0
*> 10.3.3.0
Metric LocPrf Weight
0.0.0.0
192.168.1.6
192.168.1.6
0
0
Path
32768
0
0
Обратите внимание, что частный адрес 65000 исчез из таблицы.
i
300 i
300 i
5. Используйте атрибут AS_PATH для фильтрации маршрутов.
5.1.
В окончательной конфигурации, используйте атрибут AS_PATH
фильтрации маршрутов на основе их происхождения. В сложной
среде
для
вы можете
использовать этот атрибут для обеспечения политики маршрутизации. В этом случае,
маршрутизатор провайдера, R-B, должны быть настроены так, чтобы он не распространял
маршруты, которые происходят из AS 100 к маршрутизатору клиентов R-C. Списки доступа
AS_PATH
читаются
как и обычные списки доступа. Утверждения читаются
последовательно, и в конце списка есть команда по умолчанию - запретить все остальное
("deny"). Настройте особый вид списка доступа, чтобы соответствовать BGP маршрутам с
атрибутом AS_PATH так, чтобы оба начинались и заканчивались номером 100. Введите
следующие команды на R-B.
R-B(config)# ip as-path access-list 1 deny ^100$
R-B(config)# ip as-path access-list 1 permit .*
50
Первая команда использует символ ^ чтобы указать, что AS путь должен начинаться с
заданного числа 100. Символ $ означает, что атрибут AS_PATH должен заканчиваться на
100. По существу, это заявление соответствует только путям, которые получены из AS 100.
Другие пути, которые могут включать AS 100 по дороге, не будут соответствовать этому
списку.
Во второй команде . (период) является шаблоном, * (звездочка) означает повторение
подстановки. Вместе . * соответствуют любому значению атрибута AS_PATH, которые в
действительности разрешают любые обновления которые не были запрещены в предыдущем
списке доступа.
5.2.
Применить сконфигурированный список
доступа с помощью команды
neighbor вместе с опцией filter-list.
R-B(config)# router bgp 300
R-B(config-router)# neighbor 172.24.1.18 filter-list 1 out
Слово out
определяет, что список применяется для маршрутизации информации,
отправляемой этому соседу.
5.3.
Используйте команду CLEAR IP BGP * чтобы сбросить информацию о
маршрутизации. Подождите несколько секунд, а затем проверьте таблицу маршрутизации
для
R-B.
Путь
к
10.1.1.0
должен
быть
в
таблице
маршрутизации.
Примечание: Чтобы заставить локальный маршрутизатор сбросить свою BGP таблицу
маршрутизации, менее разрушительным вариантом является использование команды clear ip
bgp * out или clear ip bgp * soft (вторая команда выполняет для ресинхронизации обоих
маршрутов как исходящих, так и входящих).
R-B# show ip route
<output omitted>
172.24.0.0/30 is subnetted, 1 subnets
C 172.24.1.16 is directly connected, Serial0/3/1
10.0.0.0/24 is subnetted, 3 subnets
B 10.3.3.0 [20/0] via 172.24.1.18, 00:07:34
C 10.2.2.0 is directly connected, Loopback0
B 10.1.1.0 [20/0] via 192.168.1.5, 00:10:53
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, Serial0/3/0
51
5.4. Проверьте таблицу маршрутизации для R-C. Он не должен иметь маршрут к
10.1.1.0 в своей таблице маршрутизации.
R-C# show ip route
<output omitted>
172.24.0.0/30 is subnetted, 1 subnets
C 172.24.1.16 is directly connected, Serial0/3/1
10.0.0.0/24 is subnetted, 2 subnets
C 10.3.3.0 is directly connected, Loopback0
B 10.2.2.0 [20/0] via 172.24.1.17, 00:11:57
5.5.
Вернитесь к R-B и убедитесь, что фильтр работает, как предполагалось.
Выполните команду show ip bgp regexp ^100$ .
R-B# show ip bgp regexp ^100$
BGP table version is 4, local router ID is 10.2.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network
*> 10.1.1.0
Next Hop
192.168.1.5
Metric LocPrf Weight Path
0
0 100 i
Распечатка этой команды показывает, что путь к 10.1.1.0, совпадает со списком
доступа и отфильтровывает обновления от R-C.
5.6.
Выполните следующий Tcl skript на всех маршрутизаторах, чтобы проверить,
есть ли подключение.
R-B# tclsh
R-B(tsl)# foreach address {
10.1.1.1
10.2.2.1
10.3.3.1
192.168.1.5
192.168.1.6
172.24.1.17
172.24.1.18
} { ping $address }
Сделайте выводы.
52
Лабораторная работа № 3
Настройка IBGP и EBGP сессии, локальное предпочтение, и MED
1. Подготовка маршрутизаторов для работы
Постройте сеть согласно топологии сети (рис. 2.7).
Необходимые ресурсы:
3 маршрутизатора (Cisco 1841 с Cisco IOS Release 12/4(24) T1 Advanced IP
Services или сопоставимые, такие как Cisco 2801 или Cisco 2811 )
3 персональных компьютера
Последовательные и консольные кабели
Рис. 2.7
53
2. Конфигурирование имен хостов и адресов интерфейсов.
2.1.
Назначьте имена хостов маршрутизаторов. Используя схему адресации
показанную в топологии, создайте последовательные интерфейсы и назначьте IP-адреса этих
и последовательные интерфейсов. Установите clock rate на последовательных интерфейсах
DCE. Используйте команду Ping для проверки подключения между непосредственно
связанными маршрутизаторами. Оба маршрутизатора R-B и R-C, должны пинговать друг
друга и их местный R-A IP-адрес последовательного соединения. R-A маршрутизатор не
может достичь сегмент между R-B и R-C.
2.2.
После настройки команда show running-config должна показать следующие
конфигурации маршрутизароров:
Router R1 (hostname R-A)
hostname R-A
!
interface Loopback0
ip address 192.168.100.1 255.255.255.0
!
interface Serial0/3/0
ip address 192.168.1.5 255.255.255.252
clock rate 128000
no shutdown
!
interface Serial0/3/1
ip address 192.168.1.1 255.255.255.252
no shutdown
Router R2 (hostname R-B)
hostname R-B
!
interface Loopback0
ip address 172.16.64.1 255.255.255.0
54
!
interface Serial0/3/0
ip address 192.168.1.6 255.255.255.252
no shutdown
!
interface Serial0/3/1
ip address 172.16.1.1 255.255.255.0
clock rate 128000
no shutdown
Router R3 (hostname R-C)
hostname R-C
!
interface Loopback0
ip address 172.16.32.1 255.255.255.0
!
interface Serial0/3/0
ip address 192.168.1.2 255.255.255.252
clock rate 128000 no shutdown
!
interface Serial0/3/1
ip address 172.16.1.2 255.255.255.0
no shutdown
3. Настройка EIGRP
3.1.
Настройте EIGRP между маршрутизаторами R-B и R-C.
R-B(config)# router eigrp 64512
R-B(config-router)# no auto-summary
R-B(config-router)# network 172.16.0.0
R-C(config)# router eigrp 64512
55
R-C(config-router)# no auto-summary
R-C(config-router)# network 172.16.0.0
4. Настройка IBGP и проверка BGP соседей.
4.1.
Настройте IBGP между маршрутизаторами R-B и R-C. На маршрутизаторе R-B,
введите следующую конфигурацию.
R-B(config)# router bgp 64512
R-B(config-router)# neighbor 172.16.32.1 remote-as 64512
R-B(config-router)# neighbor 172.16.32.1 update-source lo0
Если существует несколько путей к ближнему BGP соседу, маршрутизатор может
использовать несколько IP интерфейсов для связи с ним. IP-адрес источника, следовательно,
зависит
от
исходящего
интерфейса.
Команда
Update-source
lo0
инструктирует
маршрутизатор использовать IP-адрес интерфейса Loopback0 как IP-адрес источника для
всех
сообщений,
4.2.
отправленных
BGP
этому
соседу.
Завершите настройку IBGP на R-C с помощью следующих команд.
R-C(config)# router bgp 64512
R-C(config-router)# neighbor 172.16.64.1 remote-as 64512
R-C(config-router)# neighbor 172.16.64.1 update-source lo0
4.3.
Убедитесь, что R-B и R-C стали BGP соседями используя команду show ip bgp
neighbor на R-B. Посмотрите, что выдает команда. Если BGP не установлено, устраните
неполадки.
R-C# show ip bgp neighbors
BGP neighbor is 172.16.64.1,
remote AS 64512, internal link BGP
version 4, remote router ID 172.16.64.1
BGP state = Established, up for 00:00:01
<output omitted>
Связь между R-B и R-C должна быть определена в качестве внутреннего звена.
56
5. Настройка EBGP и проверка BGP соседей.
5.1.
Настройте R-A для запуска EBGP с R-B и R-C. Введите следующие команды на
R-A.
R-A(config)# router bgp 200
R-A(config-router)# neighbor 192.168.1.6 remote-as 64512
R-A(config-router)# neighbor 192.168.1.2 remote-as 64512
R-A(config-router)# network 192.168.100.0
Так как EBGP сеансы почти всегда устанавливается на соединениях точка-точка, нет
никаких причин, чтобы использовать update-source в этой конфигурации. Только один путь
существует между компонентами. Если этот путь идет вниз, альтернативных путей не
имеется.
5.2.
Настройте R-B, как EBGP равный R-A.
R-B(config)# ip route 172.16.0.0 255.255.0.0 null0
R-B(config)# router bgp 64512
R-B(config-router)# neighbor 192.168.1.5 remote-as 200
R-B(config-router)# network 172.16.0.0
5.3.
Используйте SHOW IP BGP соседи команду, чтобы убедиться, что R-B и R-A
достигли установленного состояния. Устраните неполадки при необходимости.
R-B# show ip bgp neighbors
BGP neighbor is 172.16.32.1,
remote AS 64512, internal link BGP
version 4, remote router ID 172.16.32.1
BGP state = Established, up for 00:03:10
<output omitted>
BGP neighbor is 192.168.1.5, remote AS 200, external link BGP version
4, remote router ID 192.168.100.1
BGP state = Established, up for 00:03:10
57
<output omitted>
Вы должны также увидеть информационное сообщение, указывающее на создание
отношений соседа BGP.
*May
5.4.
8 19:41:14.111: %BGP-5-ADJCHANGE: neighbor 192.168.1.5 Up
Настройте R-C, как EBGP равный R-A.
R-C(config)# ip route 172.16.0.0 255.255.0.0 null0
R-C(config)# router bgp 64512
R-C(config-router)# neighbor 192.168.1.1 remote-as 200
R-C(config-router)# network 172.16.0.0
6. Просмотр BGP таблицы на выходе.
6.1.
В шаге 5, команда show ip bgp neighbor была использована для проверки того,
что R-B и R-A достигли установленного состояния. Полезной альтернативой этой команды
является show ip bgp summary. Вывод команды должен быть похож на следующее.
R-C# show ip bgp summary
BGP router identifier 172.16.32.1, local AS number 64512
BGP table version is 2, main routing table version 2
1 network entries and 1 paths using 137 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 2/1 prefixes, 2/1 paths, scan interval 15 secs
Neighbor
State/PfxRcd
V
AS
MsgRcvd MsgSent TblVer
172.16.64.1
4
64512
21
24
192.168.1.1
4
200
14
15
InQ
OutQ
Up/Down
2
0
0
00:03:02
2
2
0
0
00:03:36
1
58
7. Убедитесь, какую часть занимает трафик.
7.1.
Очистите IP-BGP "разговоры" командой clear ip bgp*. Подождите некоторое
время пока не восстановятся "разговоры" с каждым маршрутизатором R-B и R-C.
7.2.
Протестируйте может ли R-A пинговать адрес loopback 0 172.16.64.1 на R-B и
последовательную связь между R-B и R-C, 172.16.1.1.
7.3.
Теперь пропингуйте от R-A до адреса loopback 0 172.16.32.1 на R-C и
последовательной связи между R-B и R-C, 172.16.1.2.
Вы должны увидеть успешный ping к каждому IP-адресу на маршрутизаторе R-C.
Ping 172.16.64.1 172.16.1.1 должен потерпеть неудачу. Почему это происходит?
7.4.
Выполните команду show ip bgp на R-A, чтобы проверить BGP маршруты и
метрики.
R-A# show ip bgp
BGP table version is 3, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
Next Hop
Metric LocPrf Weight Path
*> 172.16.0.0
192.168.1.2
0
0 64512 i
*
192.168.1.6
0
0 64512 i
*> 192.168.100.0
0.0.0.0
0
32768 i
Обратите внимание, что R-A имеет два действительных маршрутов к сети
172.16.0.0, как указано *. Тем не менее, соединение на R-C было выбрано в качестве
лучшего пути. Почему R-A предпочитает соединение на R-C вместо R-B?
Будет ли изменение полосы пропускания метрики на каждом соединении
помогите исправить эту проблему? Объясните.
59
BGP работает иначе, чем все другие протоколы. В отличие от других протоколов
маршрутизации, которые используют сложные алгоритмы и связанные факторы, такие как
пропускная способность, задержка, надежность, нагрузка, чтобы сформулировать метрику,
BGP основан на политиках. BGP определяет лучший путь на основе переменных, таких как
AS path, веса, локальное предпочтение MED, и так далее. Если все равны, BGP предпочитает
маршрут, ведущий к динамике BGP с наименьшим BGP ID маршрутизатора.
7.5.
Теперь, маршрутизатор R-A должен быть в состоянии добраться до каждой
сети, подключенной к R-B и R-C от loopback адреса 192.168.100.1. Для проверки используйте
команду расширенного ping c указанием адреса источника R-A lo0.
R-A# ping 172.16.1.1 source 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds: Packet
sent with a source address of 192.168.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms
R-A# ping 172.16.32.1 source 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.32.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
R-A# ping 172.16.1.2 source 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
Packet sent with a source address of 192.168.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/15/16 ms
R-A#
R-A# ping 172.16.64.1 source 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.64.1, timeout is 2 seconds: Packet
sent with a source address of 192.168.100.1
60
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms
Вы также можете использовать расширенный режим Ping указать адрес источника,
как показано в примере.
R-A# ping
Protocol [ip]:
Target IP address: 172.16.64.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 192.168.100.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]: Data
pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: Sweep
range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.64.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/48/52 ms
Была продемонстрирована полная достижимость между маршрутизатором R-A и
обоими R-B и R-C.
8. Конфигурирование функции BGP next-hop-self.
R-B не знает о связи между R-A и R-C, и R-C не знает о связи между R-A и R-B.
Прежде чем R-A сможет успешно пинговать все внутренние последовательные интерфейсы
как AS 64512, эти последовательные каналы должны быть объявлены с помощью BGP на
маршрутизаторе R-A. Также это можно сделать
с помощью EIGRP на каждом
маршрутизаторе R-B и R-C. Предпочтительный способ для R-A для оповещения этих
соединений.
8.1.
Выполните следующие команды на маршрутизаторе R-A.
R-A(config)# router bgp 200
R-A(config-router)# network 192.168.1.0 mask 255.255.255.252
61
R-A(config-router)# network 192.168.1.4 mask 255.255.255.252
8.2.
Выполните команду show ip bgp чтобы убедиться, что R-A правильно ввел
свои WAN соединения в BGP.
R-A# show ip bgp
BGP table version is 5, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –
internal Origin codes: i - IGP, e - EGP, ? – incomplete
Network
Next Hop
Metric LocPrf Weight Path
*> 172.16.0.0
192.168.1.2
0
0 64512 i
*
*> 192.168.1.0/30
192.168.1.6
0.0.0.0
0
0
0 64512 i
32768 i
0
0
32768 i
32768 i
*> 192.168.1.4/30
*> 192.168.100.0
8.3.
0.0.0.0
0.0.0.0
Проверьте на R-B и R-C, что противоположные WAN соединения включены в
таблицу маршрутизации.
R-C# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS
inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C
172.16.32.0/24 is directly connected, Loopback0
S 172.16.0.0/16 is directly connected, Null0
C 172.16.1.0/24 is directly connected, Serial0/3/1
D
172.16.64.0/24 [90/2297856] via 172.16.1.1, 01:02:10, Serial0/3/1
62
192.168.1.0/30 is subnetted, 2 subnets
C
192.168.1.0 is directly connected, Serial0/3/0
B
192.168.1.4 [20/0] via 192.168.1.1, 00:01:13
B
192.168.100.0/24 [20/0] via 192.168.1.1, 00:33:32
Рассмотрим следующую
проблему - BGP политику маршрутизации между
автономными системами. Next-hop атрибут маршрута в разных AS устанавливает IP-адрес
пограничного маршрутизатора в следующей AS в направлении получателя, и этот атрибут не
изменяется по умолчанию, когда этот маршрут оповещается через IBGP. Таким образом, для
всех IBGP членов, он либо должен знать маршрут к этому граничному маршрутизатору (в
другом соседнем AS), или наш собственный пограничный маршрутизатор должен оповещать
внешние маршруты с помощью функции next-hop-self, переопределяя адрес следующего
перехода с собственным IP-адресом. Маршрутизатор R-C направляет политику на R-B и
наоборот. Политика маршрутизации от AS 64512 к AS 200 для пересылки пакетов на
интерфейс 192.168.1.1. R-B имеет аналогичную, а также противоположную политику: он
перенаправляет запросы к интерфейсу 192.168.1.5. Если какое-либо WAN соединение не
удастся, то противоположный маршрутизатор становится действительным шлюзом. Это
достигается, если на R-B и R-C настроена команда next-hop-self .
8.4.
Просмотрите выход, прежде чем выдать команду next-hop-self.
R-C# show ip bgp
BGP table version is 11, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –
internal
Network
*> 172.16.0.0
* i192.168.1.0/30
*>
* i192.168.1.4/30
*>
* i192.168.100.0
*>
8.5.
Origin codes: i - IGP, e - EGP, ? - incomplete
Next Hop
0.0.0.0
192.168.1.5
192.168.1.1
192.168.1.5
192.168.1.1
192.168.1.5
192.168.1.1
Metric LocPrf
0
0
100
0
0
100
0
0
100
0
Weight
32768
0
0
0
0
0
0
Path i
200
200
200
200
200
200
i
i
i
i
i
i
Выполните команду next-hop-self на R-B и R-C.
R-B(config)# router bgp 64512
63
R-B(config-router)# neighbor 172.16.32.1 next-hop-self
R-C(config)# router bgp 64512
R-C(config-router)# neighbor 172.16.64.1 next-hop-self
8.6.
Сбросьте настройки BGP на любом маршрутизаторе командой clear ip
bgp*soft.
8.7.
Выполните команду show ip bgp ,чтобы посмотреть, что было исправлено
командой next-hop-self.
R-C# show ip bgp
BGP table version is 11, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? – incomplete
Network
*> 172.16.0.0
Next Hop
0.0.0.0
Metric LocPrf Weight Path
0
* i192.168.1.0/30
172.16.64.1
0
*>
192.168.1.1
0
* i192.168.1.4/30
172.16.64.1
0
*>
192.168.1.1
0
* i192.168.100.0
172.16.64.1
0
*>
192.168.1.1
0
32768
100
i
0 200 i
0 200 i
100
0 200 i
0 200 i
100
0 200 i
0 200 i
9. Установите локальное предпочтение BGP.
На данный момент, все выглядит хорошо, за исключением маршрутов по умолчанию,
исходящего потока данных, и въездного потока пакетов.
9.1.
Так как локальное значение предпочтения распределяются между IBGP
соседями, настройте простую карту маршрута, которая ссылается на локальное значение
64
предпочтений на R-B и R-C. Эта политика регулирует исходящий трафик предпочитая
соединение от маршрутизатора R-B вместо дозированного T1 выкл R-C
R-B(config)# route-map PRIMARY_T1_IN permit 10
R-B(config-route-map)# set local-preference 150
R-B(config-route-map)# exit
R-B(config)# router bgp 64512
R-B(config-router)# neighbor 192.168.1.5 route-map PRIMARY_T1_IN in
R-C(config)# route-map SECONDARY_T1_IN permit 10
R-C(config-route-map)# set local-preference 125
R-B(config-route-map)# exit
R-C(config)# router bgp 64512
R-C(config-router)# neighbor 192.168.1.1 route-map SECONDARY_T1_IN in
Используйте команду clear ip bgp*soft после настройте эту новую политику. Когда
"разговоры" будут восстановлены, выполните команду show ip bgp на R-B и R-C.
R-B# clear ip bgp * soft
R-C# clear ip bgp * soft
R-B# show ip bgp
BGP table version is 8, local router ID is 172.16.64.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –internal Origin codes: i IGP, e - EGP, ? - incomplete
Network
* i172.16.0.0
*>
*> 192.168.1.0/30
*> 192.168.1.4/30
*> 192.168.100.0
Next Hop
172.16.32.1
0.0.0.0
192.168.1.5
192.168.1.5
192.168.1.5
Metric LocPrf Weight Path
0
100
0 i
0
32768 i
0
150
0 200i
0
150
0 200i
0
150
0 200i
R-C# show ip bgp
BGP table version is 11, local router ID is 172.16.32.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
65
Network
*> 172.16.0.0
*i
*>i192.168.1.0/30
*
*>i192.168.1.4/30
*
*>i192.168.100.0
*
Next Hop
0.0.0.0
172.16.64.1
172.16.64.1
192.168.1.1
172.16.64.1
192.168.1.1
172.16.64.1
192.168.1.1
Metric LocPrf Weight Path i
32768
0
0
100
0 i
0
150
0 200
0
125
0 200
0
150
0 200
0
125
0 200
0
150
0 200
0
125
0 200
Теперь это означает, что маршрутизация сегмента loopback для R-A 192.168.100.0/24
может быть достигнута только через общее соединение R-B и R-A.
10. Установите BGP MED.
Как будет возвращаться
трафик из сети 192.168.100.0 / 24? Будет ли он
проходить через R-B или R-C?
10.1. Используйте расширенный режим команды Ping . Укажите опцию record.
R-C# ping
Protocol [ip]:
Target IP address: 192.168.100.1
Repeat count [5]: 2
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
y
Source address or interface: 172.16.32.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]: Data
pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: record
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
66
Packet has IP options:
Total option bytes= 39, padded length=40
Record route: <*>
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
Reply to request 0 (48 ms).
Received packet has
options Total option bytes= 40, padded length=40
Record route: (172.16.1.2)
(192.168.1.6)
(192.168.100.1)
(192.168.1.1)
(172.16.32.1) <*>
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
End of list
Reply to request 1 (48 ms).
Received packet has
options Total option bytes= 40, padded length=40
Record route:
(172.16.1.2)
(192.168.1.6)
(192.168.100.1)
(192.168.1.1)
(172.16.32.1) <*>
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
End of list
67
Если вы не знакомы с опцией записи, важно отметить, что каждый IP-адрес в скобках
это исходящий интерфейс. Выход может быть интерпретирован следующим образом:
1.Ping, который поставляется из 172.16.32.1 выходит в R-C через s0/0/1, 172.16.1.2.
Затем поступает в интерфейс S0/0/1 для R-B.
2.R-B S0/0/0, 192.168.1.6, маршруты пакетов прибывают из S0/0/0 интерфейса R-A.
3.Цель достигнута 192.168.100.1: 192.168.100.1.
4.Пакет затем перенаправляется на S0/0/1, интерфейс 192.168.1.1 для R-A и прибывает
на интерфейс для R-C S0/0/0.
5.R-C затем пересылает пакет из последнего интерфейса, loopback 0, 172.16.32.1.
Хотя неограниченное использование T1 с R-B здесь предпочтительно, R-A в настоящее
время
занимает
соединение
из
R-C
для
всего
обратного
трафика.
10.2. Создайте новую политику, чтобы маршрутизатор R-A возвращал весь трафик
через R-B. Создайте вторую карту маршрута с использованием MED (метрическая), которая
коллективная между EBGP соседями.
R-B(config)#route-map PRIMARY_T1_MED_OUT permit 10
R-B(config-route-map)#set Metric 50
R-B(config-route-map)#exit R-B(config)#router bgp 64512
R-B(config-router)#neighbor 192.168.1.5 route-map PRIMARY_T1_MED_OUT out
R-C(config)#route-map SECONDARY_T1_MED_OUT permit 10
R-C(config-route-map)#set Metric 75
R-C(config-route-map)#exit
R-C(config)#router bgp 64512
R-C(config-router)#neighbor 192.168.1.1 route-map SECONDARY_T1_MED_OUT out
10.3. Используйте команду clear ip bgp*soft после создания этой новой политики.
Вывод команды show ip bgp на R-B или R-C ничего о недавно определенной политике не
указывает.
68
R-B# clear ip bgp * soft
R-C# clear ip bgp * soft
R-B# show ip bgp
BGP table version is 10, local router ID is 172.16.64.1
Status codes: s suppressed, d damped, h history, * valid, > best, i –internal
codes: i - IGP, e - EGP, ? – incomplete
Origin
Network
* i172.16.0.0
Next Hop
172.16.32.1
Metric LocPrf Weight Path
0
100
0 i
*>
*> 192.168.1.0/30
*> 192.168.1.4/30
0.0.0.0
192.168.1.5
192.168.1.5
0
0
0
150
150
i
0 200
0 200
*> 192.168.100.0
192.168.1.5
0
150
0 200
32768
10.4. Повторите расширенную команду ping с помощью команды record.
R-C# ping
Protocol [ip]:
Target IP address: 192.168.100.1
Repeat count [5]: 2
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.16.32.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]: record
Number of hops [ 9 ]:
Loose, Strict, Record, Timestamp, Verbose[RV]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
Packet has IP options:
Total option bytes= 39, padded length=40
Record
route: <*>
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
69
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
Reply to request 0 (64 ms).
Received packet has options
Total option bytes= 40, padded length=40
Record route:
(172.16.1.2)
(192.168.1.6)
(192.168.100.1)
(192.168.1.5)
(172.16.1.1)
(172.16.32.1) <*>
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
End of list
Reply to request 1 (64 ms).
Received packet has
options Total option bytes= 40, padded length=40
Record route:
(172.16.1.2)
(192.168.1.6)
(192.168.100.1)
(192.168.1.5)
(172.16.1.1)
(172.16.32.1) <*>
(0.0.0.0)
(0.0.0.0)
(0.0.0.0)
End of list
Выполните команду show ip bgp.
R-A# show ip bgp
BGP table version is 12, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal
70
Origin codes: i - IGP, e - EGP, ? - incomplete
Network
*
*>
*>
*>
*>
Next Hop
172.16.0.0
192.168.1.0/30
192.168.1.4/30
192.168.100.0
Metric LocPrf Weight Path
192.168.1.2
192.168.1.6
0.0.0.0
0.0.0.0
0.0.0.0
75
50
0
0
0
0 64512 i
0 64512 i
32768 i
32768 i
32768 i
11. Создание сети по умолчанию.
Последним шагом является создание маршрута по умолчанию. Настройте R-B и R-C
использовать сеть 192.168.100.0/24, как сеть по умолчанию. Следующие шаги настройки
маршрутизатора R-B. Сделайте то же самое на маршрутизаторе R-C.
11.1. Просмотрите таблицы маршрутизации до создания IP-сети по умолчанию.
R-B# show ip route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
D
172.16.32.0/24 [90/20640000] via 172.16.1.2, 02:43:46, Serial0/1
B
172.16.0.0/16 [200/0] via 172.16.32.1, 00:12:32
C
C
172.16.1.0/24 is directly connected, Serial0/1
172.16.64.0/24 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
B
C
B
192.168.1.0 [20/0] via 192.168.1.5, 00:14:05
192.168.1.4 is directly connected, Serial0/0
192.168.100.0/24 [20/0] via 192.168.1.5, 00:14:05
11.2. Настройте сеть по умолчанию.
R-B(config)#ipdefault-network 192.168.100.0
11.3. Просмотрите таблицы маршрутизации после создания IP-сети по умолчанию.
R-B# show ip route
Gateway of last resort is 192.168.1.5 to network 192.168.100.0
71
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
D
172.16.32.0/24 [90/20640000] via 172.16.1.2, 02:44:09, Serial0/1 B
172.16.0.0/16 [200/0] via 172.16.32.1, 00:12:55
C
172.16.1.0/24 is directly connected, Serial0/1 C
connected, Loopback0
172.16.64.0/24 is directly
192.168.1.0/30 is subnetted, 2 subnets
B
192.168.1.0 [20/0] via 192.168.1.5, 00:14:28
C
B*
192.168.1.4 is directly connected, Serial0/0
192.168.100.0/24 [20/0] via 192.168.1.5, 00:14:29
Что потребуется, чтобы добавить в будущем связь T3 на R-C и для того, чтобы
иметь предпочтение входящего и исходящего трафика?
11.4. Выполните следующий Tcl-skript на всех маршрутизаторах для проверки
полного соединения.
R-A# tclsh
R-B(tsl)# foreach address {
192.168.100.1
172.16.64.1
172.16.32.1
192.168.1.1
192.168.1.2
192.168.1.5
192.168.1.6
172.16.1.1
172.16.1.2
} { ping $address }
Сделайте выводы.
72
Список литературы
1. Олифер В.Г., Олифер Н.А. Компьютерные сети. Принципы, технологии, протоколы.
СПб: Питер, 2011. – 944 с.
2. Гольдштейн Б.С., Соколов Н.А., Яновский Г.Г. Сети связи: Учебник для ВУЗов. СПб.
БХВ-Петербург, 2010 – 400 с.
3. Васин Н.Н. Технологии пакетной коммутации. Часть 1. Основы построения сетей
пакетной коммутации. Учебное пособие / Самара, ПГУТИ 2014. – 239 с.
4. Васин Н.Н. Технологии пакетной коммутации. Часть 2. Маршрутизация и коммутация.
Учебное пособие / Самара, ПГУТИ 2015. – 261 с.
5. Васин Н.Н. Системы и сети пакетной коммутации: Конспект лекций. – Самара:
ПГУТИ, Издательство Ас-Гард, 2012. – 364 с
73
Документ
Категория
Без категории
Просмотров
0
Размер файла
1 346 Кб
Теги
ivanovo, provajderov, marshrutizacii, setyam, epishkin, protokol, vasil
1/--страниц
Пожаловаться на содержимое документа