close

Вход

Забыли?

вход по аккаунту

?

Soldatov Machihin Kompyuternoe modelirovanie RES v programme Multisim 2017

код для вставкиСкачать
Федеральное государственное бюджетное образовательное
учреждение высшего образования
«ПОВОЛЖСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ
ТЕЛЕКОММУНИКАЦИИ И ИНФОРМАТИКИ»
Кафедра радиоэлектронных систем РЭС
Солдатов А.А.
Мачихин В.П.
«КОМПЬЮТЕРНОЕ МОДЕЛИРОВАНИЕ РЭС В
ПРОГРАММЕ «MULTISIM »
Методические указания к
лабораторным работам
Самара 2017
СОДЕРЖАНИЕ
Лабораторная работа №1. Моделирование элементов цепи…………….3
Лабораторная работа №2. Моделирование волновых процессов…….…8
Лабораторная работа №3. Моделирование активных элементов….…..14
Лабораторная работа №4. Моделирование усилителей………..…........22
Лабораторная работа №5.Моделирование активных устройств……...29
Лабораторная работа №6. Решение задачи Коши в среде Maxima……..35
Приложение 1. Основы работы в среде Multisim…………………………...38
Приложение 2. Моделирование переходных процессов………..…………..71
ЛИТЕРАТУРА…………………………………………………………………75
1. Цели и задачи дисциплины
Основными целями преподавания дисциплины являются:

формирование базовой подготовки студентов по основам компьютерного проектирования и моделирования РЭС

освоение программ проектирования РЭС–Electronics Workbench,
Multisim и Maxima
Основными обобщенными задачами преподавания дисциплины являются:

приобретение студентами навыков работы на ЭВМ

ознакомление с основами математического моделирования, которые используются в радиотехнике и связи.
получение представления о методах проектирования многополюсников РЭС посредством матричного представления;
получение представления о моделировании РЭС с помощью
теории графов;
получение представления о функциональном и схемотехническом моделировании РЭС;
умение моделировать и проектировать РЭС в средах Electronics




Workbench, Multisim и Maxima
2
ЛАБОРАТОРНАЯ РАБОТА №1
Моделирование элементов цепи
1. ЦЕЛЬ РАБОТЫ
1 – знакомство с программой Multisim; моделирование простейших элементов цепи.
2. ПОДГОТОВКА К ЛАБОРАТОРНОЙ РАБОТЕ
При подготовке к лабораторной работе необходимо:
 изучить задание на работу, цель работы;
 изучить работу компьютера в пределах данной программы;
 получить у преподавателя допуск к проведению моделирования.
3. КОНТРОЛЬНЫЕ ВОПРОСЫ
1. Для чего предназначено меню File , перечислить ее основные команды.
2. Какие функции выполняет меню Edit , перечислить ее основные
команды.
3. Какие функции выполняет меню Sources, перечислите основные
приборы в команде.
4. Какие функции выполняет меню Basic , перечислите основные элементы в команде.
5. Какие функции выполняют меню Window и Help .
6. Какой командой можно скопировать изображение схемы в отчет к
лабораторной работе, подготавливаемый в текстовом редакторе Word.
7. Какими командами можно изменить графическое изображение элемента и его параметры (резистор и конденсатор).
3
8. Рассказать о возможностях и порядке работы с контрольно –
измерительными приборами ( мультиметр и функциональный генератор).
9. Рассказать о возможностях и порядке работы с контрольно –
измерительными приборами ( осциллограф и измеритель АЧХ ).
Рис.1.1. Делитель мощности
4. ПОРЯДОК РАБОТЫ
4.1. Собрать схему согласно рис. 1.1. Исследуйте влияние емкости С и
резистора R на коэффициент деления на частотах 10 Гц, 10 кГц, 10 Мгц. Для
этого измерьте напряжение на мультиметре при R равном 5 кОм, 10 кОм, 15
и 20 кОм (С=3 пФ).
4.2. Измерьте напряжение на мультиметре при С равном 1, 2, 3 и 5 пФ
(R=10 кОм). Построить кривые зависимости напряжения от R и С.
4
Снятие вольтамперных характеристик
4.3. Собрать схему согласно рис. 1.2. Изменяя значение Ie от 0.1 мА
до 2 А, снять значения Ueb ( значение Ukb постоянно и задается преподавателем). Построить кривые зависимости Ueb =f(Ie) . Затем изменяя значение Ukb
от 100 мВ до 1 В , снять значения Iк ( значение Ie постоянно и задается преподавателем). Построить кривые зависимости Iк = f(Ukb). В обоих случаях
значения снимаются в 6-8 точках.
Рис.1.2. Схема снятия ВАХ транзистора
Исследование выходных ВАХ транзистора с помощью
характериографа.
4.4. Собрать схему согласно рис.1.3.
5
Рис.1.3. Схема измерения динамических ВАХ транзистора
Установить на генераторе и осциллографе режимы, показанные на
рис. 1.4.
Рис.1.4. Режимы работы
6
Меняя ток на источнике 0.3 mA, 0.6 mA, 1 mA снимите с осциллографа ВАХ. Снятые кривые представьте в отчете.
5. СОДЕРЖАНИЕ ОТЧЕТА
Отчет должен содержать :
 наименование работы;
 цель работы;
 функциональные схемы рассматриваемых моделей;
 результаты моделирования ( в виде таблиц и графиков).
7
ЛАБОРАТОРНАЯ РАБОТА №2
Моделирование волновых процессов
1. ЦЕЛЬ РАБОТЫ
1 – знакомство с программой Multisim; 2 - моделирование волновых процессов; 3 – моделирование колебательных контуров.
2. КОНТРОЛЬНЫЕ ВОПРОСЫ
1. Какой командой можно присвоить компоненту позиционное обозначение (С1, С2, R1 и тд.) и какое правило используется при присвоении
позиционных обозначений однотипных компонентов.
2. Какие функции выполняют команды DC и Transient меню Analysis.
3. Какой командой производится расчет режима по постоянному току
и что означает моделирование схемы по постоянному току.
4. Какой командой производится выбор параметров МОП – транзисторов.
5. Какие математические методы используются в EWB.
6. Каким образом можно индивидуально изменить температуру компонента моделируемой схемы.
7. Составьте уравнение цепи на рис. 3, используя законы Кирхгофа.
3. ПОРЯДОК РАБОТЫ
3.1. Операции с гармоническими операциями.
Как известно из тригонометрии, при сложении двух колебаний синусоидальной формы
A1 = A1m sin( ωt + B1 )и A2 = A2 m sin( ωt + B2 )
(2.1)
образуется синусоидальный сигнал той же формы
8
A = Am sin( ωt + B ) где
Am = A12m + A22m + 2 A1m A1m cos( B1
B2 ) ;
(2.2)
tgB = ( A1m sin B1 + A2 m sin B2 ) /( A1m cos B1 + A2 m cos B2 ).
Собрать схему согласно рис.2.1.
Рис.2.1. Исследование суммы гармонических сигналов
Рис.2.1.б. Режимы работы осциллографа
9
3.2. Снять на осциллографе осциллограммы при установленном на
входе осциллографа режиме Y/T.
3.3. Поставить на входе осциллографа режим В/А и зарисовать полученные кривые 2-го порядка.
3.4. Получить у преподавателя для каждой группы значения амплитуд и фаз источников токов и проделать пункты 3.1. и 3.3.
3.5. Моделирование резонансных цепей.
3.6. В случае малых омических потерь резонансная частота последовательного и параллельного контура частота рассчитывается по следующей
формуле:
ω0 =
U1 
1
f0 =
LC
0 LU m
R
;
Uc 
1
2π LC
Um .
R0 C 
(2.3)
(2.4)
Получить значения L и С согласно варианту:
1. L=0.5 Н,
2. L=0.8 Н,
3. L=1 Н,
4. L=1.2 Н,
5. L=1.4 H,
С=0,5 F;
С=0,7 F;
С=1 F;
С=1,5 F;
С=1,4 F.
3.7. Собрать схему по рис.2.2.
10
Рис.2.2. Исследование колебательного контура
3.8. По формулам (2.3) рассчитайте 0 и f 0 ; выставьте на источнике переменного напряжения рассчитанную частоту. Запишите показания амперметра и вольтметра.
3.9. Изменяя вправо и влево от резонансной частоты с шагом 25 Гц
частоту задающего генератора (по три отсчета в каждую сторону), снимите
показания амперметра и вольтметра. Постройте кривые зависимости тока и
напряжения от частоты.
3.10. Соберите схему согласно рис.2.3.
3.11. По формулам (2.4) рассчитайте U1 и Uс .
3.12. Выставьте на задающем генераторе рассчитанную в пункте
3.6 частоту. Измерьте напряжение U1 и Uс ., сравните измеренные значения с
рассчитанными в пункте
3.6. Установите режимы на плоттере, согласно
рис.2.4.
3.13. Нарисуйте в отчете кривые, снятые с осциллографа и плоттера.
11
Рис.2.3. Моделирование колебательного контура 2
Рис.2.4. Режимы устанавливаемые на плоттере для схемы рис.2.3.
12
4. СОДЕРЖАНИЕ ОТЧЕТА
Отчет должен содержать :
 наименование работы;
 цель работы;
 функциональные схемы рассматриваемых моделей;
 результаты моделирования ( в виде таблиц и графиков).
13
ЛАБОРАТОРНАЯ РАБОТА №3
Моделирование активных элементов
1. ЦЕЛЬ РАБОТЫ
1 – знакомство с программой Multisim; 2 - моделирование двухпозиционных выпрямителей; 3 - моделирование компараторов; 4 - моделирование активных фильтров.
2. КОНТОЛЬНЫЕ ВОПРОСЫ
1.
Какие функции выполняет команды DC Sweep меню Analy-
2.
Какие функции выполняет команды AС Frequency меню
3.
В чем различие схем однополупериодного и двухполупери-
sis.
Analysis.
одного выпрямителей ( схемное и принципиальное отличие).
4.
Для чего предназначен измеритель АЧХ и ФЧХ и как он
подключается к исследуемой схеме.
5.
Какие функции выполняет компаратор и каковы особенности
его моделирования.
6.
В чем особенности моделирования компаратора с гистерези-
7.
Особенности моделирования пассивных и активных филь-
сом.
тров.
3. ПОРЯДОК РАБОТЫ
3.1. Моделирование выпрямителей.
Выпрямители используются для преобразования переменного
напряжения в постоянный . На рис. 1 показана схема однополупериодного
выпрямителя, который позволяет получать инвертируемую копию отрица14
тельной полуволны входного сигнала Ui. Когда Ui. отрицательно , диод D1
смещен в прямом, а D2 в обратном направлениях, и схема функционирует как
обычный инвертирующий усилитель с единичным коэффициентом усиления.
Для положительного напряжения Ui. диод D1 заперт, а D2 находится в проводящем состоянии , благодаря чему возникает отрицательная обратная связь,
устанавливающая на выходе ОУ запирающее напряжение для диода D1.
В двухполупериодном выпрямителе (рис.3.2) положительная полуволна входного сигнала непосредственно передается на выход выпрямителя
через цепь обратной связи. Когда входное напряжение больше нуля, на выходе инвертирующего усилителя действует отрицательное напряжение. Поэтому диод D1 заперт и ОУ фактически не участвует в передаче сигнала. При
отрицательной полуволне на входе схема функционирует как усилитель с
коэффициентом передачи R1/R2. В практических схемах симметрирование
выходного сигнала выпрямителя достигается с помощью резистора R3.
3.2. Соберите схему согласно рис.3.1.
Рис.3.1. Схема однополупериодного выпрямителя
15
3.3. Снимите с осциллографа кривые входного и выходного сигналов. Нарисуйте полученные кривые для отчета.
3.4. Соберите схему согласно рис.3.2.
Рис.3.2. Схема двухполупериодного выпрямителя
3.5. Снимите с осциллографа кривые входного и выходного сигналов. Нарисуйте полученные кривые для отчета.
3.6. Моделирование компараторов.
Компаратор является одним из важнейших элементов преобразовательной техники, в частности, аналого-цифровых преобразователей; систем
предельного контроля и т.д. Компаратор должен переключаться из одного
состояния в другое с максимально возможной скоростью. Простейший компаратор состоит (рис.3) из ОУ без обратной связи; опорное напряжение Un
подается на неинвертирующий вход ОУ, а на инвертирующий вход поступает суммарный входной сигнал Un от источников напряжения ( источник Uр
16
имитирует напряжение источников помех ). При Ui Un на выходе компаратора устанавливается напряжение Uо =- Us (отрицательное напряжение насыщения); в противоположном случае (Un Ui) получаем Uо = + Us . Если поменять местами входы, это приведет к инверсии выходного сигнала.
3.7. Простейший компаратор напряжения.
Собрать схему согласно рис.3.3.
3.8. Снимите с осциллографа кривые входного и выходного сигналов. Нарисуйте полученные кривые для отчета.
3.9. Моделирование компаратора с гистерезисом.
Рис.3.3. Простейший компаратор и его передаточная функция
17
Рис.3.4. Компаратор с гетерезисом и его передаточная функция
Для предотвращения ложных срабатываний применяют цепь положительной обратной связи, за счет которой часть выходного напряжения
подается на неинвертирующий вход. Такой компаратор называется компаратор с гистерезисом (рис.3.4).
3.10. Соберите схему компаратора с гистерезисом по рис. 4. Снимите с осциллографа кривые входного и выходного сигналов. Нарисуйте полученные кривые для отчета.
3.11. Активные фильтры.
Фильтрующие элементы используются в блоках питания для фильтрации сигналов, в качестве корректирующих звеньев в блоках управления и
т.д. Фильтры делятся на два класса – пассивные и активные, причем основным отличием активного фильтра является наличие усилительного элемента –
обычно это ОУ. Если в фильтре содержится один реактивный элемент (ем18
кость или индуктивность), то такой фильтр называется фильтром первого
порядка, если два – то второго порядка, и т. д.
Наиболее распространенным пассивным фильтром первого порядка
является интегрирующая RC – цепь. Этот фильтр в технике электропитания
называется Г-образным сглаживающим фильтром, в аудиотехнике – фильтром нижних (ФНЧ).
Классической схемой пассивного фильтра второго порядка является
последовательная RLC-цепь.
Полосно-пропускающий (ПФ) фильтр пропускает определенную
полосу частот. Для активного ПФ с многопетлевой обратной связью (рис.5)
коэффициент передачи К0 , резонансная частота 0 и затухание d определяются по формулам:
K0 
R3
R1(1  C 2
1
; 0  ( 1  1 ) / R3C1C 2  ;
R2
 R1

)
C1
2
(3.1)
1
1
1
2
d  1 / ( 1  1 ) R3  C1 / C 2  2   C 2 / C1 2  .
R1
R2

 

3.12. Собрать схему активного ПФ согласно рис.3.5. Рассчитать параметры фильтра по формулам (3.1). Установить первоначально на генератоне 10 Гц и амплитуду 1 В. Зарисовать АЧХ фильтра с плоттера.
19
Рис.3.5. ПФ с многопетлевой связью
Рис.3.6. Режимы на плоттере для ПФ с многопетлевой связью
3.13. Провести анализ ПФ с помощью команды AC Analysis меню
Analysis в программе Simulate . Нарисовать АЧХ и ФЧХ, полученные при
анализе. Сравните результаты расчета по формулам (3.1) с результатами моделирования.
20
4. СОДЕРЖАНИЕ ОТЧЕТА
Отчет должен содержать :
 наименование работы;
 цель работы;
 функциональные схемы рассматриваемых моделей;
 результаты моделирования ( в виде таблиц и графиков).
21
ЛАБОРАТОРНАЯ РАБОТА №4
Моделирование усилителей
1. ЦЕЛЬ РАБОТЫ
1 –изучение программы Multisim; 2 – моделирование усилителей.
2.
КОНТРОЛЬНЫЕ ВОПРОСЫ
1. Что такое полевой транзистор. Режимы его включения и работы.
2. Что такое ряды Фурье и какими командами меню Analysis можно
провести Фурье анализ спектра внутренних шумов.
3. Какие функции выполняет команда Distortion меню Analysis.
4. Какой командой можно удалить или поменять из схемы обозначения номинальных значений компонентов или их тип.
5. Какие математические методы используются в Multisim.
6. Какие функции выполняют выходные каскады усилителей и какие требования к ним предъявляются.
7. В чем особенность моделирования усилителей на полевых транзисторах.
8. Особенности моделирования усилителей мощности.
9. Рассказать о трех схемах включения биполярного транзистора в
цепь.
3. ПОРЯДОК ПРОВЕДЕНИЯ РАБОТЫ
3.1.
Моделирование базовых усилительных каскадов.
Основные схемы построения усилителей на биполярных транзисторах определяются возможными способами их включения – ОБ,ОЭ и ОК. Базовые каскады характеризуются входным RВХ и выходным RВЫХ сопротивлениями, коэффициентом усиления тока Кi и напряжения Кu .
Для усилительного каскада , изображенного на рис.4.1 , расчет статистического режима заключается в выборе такого коллекторного тока I co
22
(его называют током покоя или током в рабочей точке), при котором падение
напряжения на коллекторной нагрузке Rk , во-первых, равно падению напряжения на транзисторе (напряжение коллектор-эмиттер
U cc ) и, во-вторых,
было бы меньше амплитудного значения при максимальном входном сигнале.
Первое условие применительно к схеме на рис. 4.1. запишется следующим
образом:
I k Rk + U ke + I e Re = U cc ,
где I e = β I k
(4.1)
(β - 1) –ток эмиттера.
Рис.4.1. Усилительный каскад с ОЭ
Поскольку β   1, то Ik Ie. В таком случае выражение (4.1) запишется в виде:
2 I k Rk + I k Re = U cc ,
откуда находим ток покоя:
(4.2)
I k = U cc (2 Rk + Re ) .
23
Напряжение на базе относительно линии (учитывая Ik Ie. в статическом режиме)
(4.3)
U bo = U be + I e Re ,
где U be – напряжение база-эмиттер (в пределах 0,7 … 0,9 В).
Поскольку Ubo равно падению напряжения на резисторе
R2
, ток
через него равен:
I 2 = U bo R2 = (U be + I co Re ) R2 .
Через резистор R1 протекает сумма тока базы, равного I k β , и тока
I 2 . Падение напряжения на резисторах R1 , R2 , равно напряжению питания
U cc . Поэтому для базовой цепи:
(4.4)
R1 (I k β + U b R2 ) + U b = U cc ;
Обычно выбирается:
R1 >> R2 , I k β >> I 2 ,
(4.5)
U be = I k Re
отсюда получается соотношение:
(4.6)
R1 R2 = Rk Re .
3.2.
Собрать схему согласно рис.4.1.
Выбирая
U cc = 10 В , найдите
сопротивление
нагрузки
Re = 2 кОм,
U be = 0.8 В ,
I k из формулы (4.5), затем Rk из формулы (4.2) и R1 , R2 ,
используя соотношение (4.6).
Подставляя измеренные значения в схему 4.1 (вместо 1 кОм), измерьте напряжение в статическом режиме, при этом на генераторе устанавливается сигнал с амплитудой 1мкВ. Запишите показания вольтметров.
Затем подавая сигнал с частотой 100 кГц и амплитудой 0,5 В снимите осциллограмму на входе и выходе усилителя. Меняя амплитуду на генераторе найти режим отсечки. Сравнивая сигналы на осциллографе, найти коэффициент усиления.
3.3. Провести анализ усилителя с помощью команды AC Analysis
меню Analysis. Нарисовать АЧХ и ФЧХ, полученные при анализе.
Если, рассчитанный усилитель, не работает, собрать усилитель, показанный на рис. 4.2. и проделать пункты 3.2-3.3.
24
Рис.4.2. Рассчитанный усилительный каскад с ОЭ
Рис.4.3. Режимы генератора к рис.4.4
3.4. Моделирование усилителей на полевых транзисторах.
Усилительные каскады на полевых транзисторах , в отличие от биполярных, управляются напряжением, приложенным или к запертому p-n
переходу ( в транзисторах с управляющим p-n переходом ) или между электрически изолированным затвором и подложкой.
Среди базовых каскадов на полевых транзисторах на практике
наибольшее значение наибольшее распространение получили каскады с общим истоком ( аналог ОЭ ) и истоковые повторители ( аналог ОК ).
25
3.5. Соберите схему согласно рис.4.4.
Рис.4.4. Усилительный каскад с ОИ
3.6. Выставьте на задающем генераторе частоту 1 кГц, напряжение
0.2 В. Снимите и зарисуйте с осциллографа входной и выходной сигнал ,
прикиньте коэффициент усиления (разделите амплитуду выходного сигнала
на амплитуду входного). Меняя напряжение на задающем генераторе с шагом 0.2 В определите коэффициент усиления на каждом шаге, измерения проводить до начала отсечки выходного сигнала (срез синусоиды выходного
сигнала ). Постройте кривую зависимости коэффициента усиления от входного напряжения.
3.7. Моделирование усилителей мощности.
Усилители мощности применяются в бытовой аппаратуре , для
управления исполнительными устройствами автоматических систем, в измерительных генераторах и т.д.
Один из вариантов такого усилителя показан на рис.4.5. Усилитель
состоит из ОУ, охваченного отрицательной обратной связью через резистор
R0 . На выходе усилителя включен комплементарный каскад на транзисторах
VT1 и VT2 разной проводимости с низкоомной нагрузкой Rn , имитирующей
26
сопротивление оконечного устройства (например, громкоговорителя). Конденсаторы Cb выполняют роль фильтрирующих элементов (блокировочных),
они уменьшают помехи, возникающие в цепях питания при работе с низкоомной нагрузкой. Ключ А позволяет коммутировать вход усилителя с выходом ОУ или выходом транзисторного каскада для моделирования двух режимов работы усилителя.
3.8. Соберите схему по рис.4.5.
Рис.4.5. Усилитель мощности
3.8. Выставьте на задающем генераторе частоту 100 Гц, напряжение
3 В.
Снимите и зарисуйте с осциллографа входной и выходной сигнал,
прикиньте коэффициент усиления (разделите амплитуду выходного сигнала
на амплитуду входного). Проведите моделирование при двух положениях
ключа.
27
4. СОДЕРЖАНИЕ ОТЧЕТА
Отчет должен содержать :

наименование работы;

цель работы;

функциональные схемы рассматриваемых моделей;

результаты моделирования ( в виде таблиц и графиков).
28
ЛАБОРАТОРНАЯ РАБОТА №5
Моделирование активных устройств
1.
ЦЕЛЬ РАБОТЫ
1 –изучение программы Multisim; 2 – моделирование каскодной
схемы; 3 – моделирование генераторов.
2.
КОНТРОЛЬНЫЕ ВОПРОСЫ
1. Назовите команду для задания параметров переходных процессов (расшифруйте ее).
2. Какой командой можно провести анализ модели в частотной области и какие характеристики при этом можно получить.
3. Какие функции выполняет команда Parameter sweep… меню
Analysis.
4. Какие функции выполняет команда Temperature sweep… меню
Analysis.
5. Особенности моделирования каскодной схемы.
6. Особенности моделирования низкочастотных генераторов.
7. Особенности моделирования RC-генераторов.
8. Особенности моделирования пилообразных генераторов.
9. Особенности моделирования мультивибраторов.
3. ПОРЯДОК ВЫПОНЕНИЯ РАБОТЫ
3.1. Моделирование каскодной схемы.
Под каскодной схемой ( или просто каскодом ) понимается схема, в
которой два транзистора соединены последовательно, так что через них в статическом режиме проходит один и тот же ток.
29
На рис.5.1 показана такая каскодная схема. Транзистор VT1 включен по схеме с ОЭ, а VT2 – по схеме с ОБ. Режим по постоянному току задается с помощью резисторов R1,R2,R3. Режим ОБ транзистора VT2 по переменной составляющей обеспечивается блокировочным конденсатором Cb,
подключенным к его базе.
3.2. Собрать схему согласно рис.5.1.
Рис.5.1. Каскодная схема
3.3. Выставьте на задающем генераторе частоту 100 Гц, напряжение
0.5 В. Снимите и зарисуйте с осциллографа входной и выходной сигнал ,
прикиньте коэффициент усиления (разделите амплитуду выходного сигнала
на амплитуду входного).
3.4. Генераторы RC.
30
Рис.5.2. RC-генератор
В RC генераторах обратная связь осуществляется за счет RC цепей,
обладающих избирательными свойствами и обеспечивающих на одной определенной частоте выполнение условий возбуждения колебаний. В этих генераторах выходное напряжение практически повторяет форму коллекторного
тока транзистора. Поэтому они не могут работать с отсечкой и имеют сравнительно низкий КПД. Генераторы RC типа достаточно просты в реализации,
них значительно ниже потери, чем в LC- генераторах (см. генератор Колпитца), они дешевы, имеют малые габариты и массу. Однако стабильность частоты колебаний в них ниже, чем в LC-генераторах [4].
Трехзвенный RC-генератор показан на рис.2. Частоту колебаний такого генератора можно рассчитать по формуле:
f 0 = 1 /( RC 3 ) .
(5.1)
3.5. Собрать схему по рис.5.2.
3.6. Провести анализ генератора с помощью команды AC Analysis
меню Analysis. Нарисовать АЧХ и ФЧХ, полученные при анализе. Провести
31
Фурье- анализ. Рассчитать частоту генерации по формуле (5.1). Сравните рассчитанные и измеренные частоты.
3.7. Генераторы пилообразного напряжения (ГПН).
Генераторы пилообразного напряжения (ГПН) чаще всего выполняются с внешним управлением. При этом длительность рабочего хода определяется длительностью внешнего управляющего импульса прямоугольной
формы. При необходимости можно создать генераторы, работающие в ждущем (с запуском от короткого импульса), автоколебательном или в режиме
синхронизации.
В простейшем случае, когда не требуется высокая линейность рабочего участка выходного напряжения, ГПЧ выполняется по схеме интегрирующей RC – цепи со сбросом заряда при обратном ходе. Схема такого генератора (рис.5.3) содержит интегрирующею RC- цепь, ключ на транзисторе и
генератор импульсов сброса.
32
Рис.5.3. Генератор пилообразного напряжения со стабилизатором
тока
3.8. Собрать схему согласно рис.5.3.
3.9.Снять осциллограмму выходного сигнала и сигналов сброса. Зарисовать кривые для отчета.
3.10. Провести анализ генератора с помощью команды AC Analysis
меню Analysis. Нарисовать АЧХ и ФЧХ, полученные при анализе. Провести
Фурье- анализ
3.10. Моделирование мультивибратора.
Классическая схема мультивибратора (рис.5.4) содержит два ключа
на транзисторах и две задающие RC-цепи.
3.11. Собрать схему, изображенную на рис.5.4.
3.12. Снять осциллограмму. Определить частоту генерации по осциллографу.
Рис.5.4. Схема мультивибратора
3.13. Если, мультивибратор не работает, поменять значение R2 на 2
кОм.
33
4. СОДЕРЖАНИЕ ОТЧЕТА
Отчет должен содержать :
 наименование работы;
 цель работы;
 функциональные схемы рассматриваемых моделей;
 результаты моделирования ( в виде таблиц и графиков).
34
ЛАБОРАТОРНАЯ РАБОТА №6
Решение дифференциальных уравнений
в среде Maxima
Дифференциальным уравнением называется уравнение вида
dy
 f ( y,x ) .
dx
(6.1)
Вместе с заданным уравнением (6.1) и граничными условиями (ГУ)
(x=a , y=b), поставленная задача называется задачей Коши.
1.
ЦЕЛЬ РАБОТЫ
1 –изучение программы Maxima; 2 – моделирование Нелинейная
RC – схемы; 3 – решение ОДУ при разных ГУ.
2. КОНТРОЛЬНЫЕ ВОПРОСЫ
1. Две формы представления исходной модели схемы для расчёта
переходных процессов.
1. Нелинейная RC – схема. Составить систему уравнений.
3. Нелинейная RC – схема. Точное решение уравнения при Е=
R=C=1.
4. Численные методы решения ОДУ, постановка задачи.
5. Простейшие численные методы решения ОДУ
6. Численный метод решения задачи для нелинейной RC – схемы.
Ниже приведена программа решения дифференциальных уравнений
в среде Maxima. Нужно набрать программу в среде Maxima и решить задачу
ОДУ для своего варианта.
Производная вводится следующим образом
dy
 diff ( y,x ) . Ниже
dx
приведена программа для 1-го варианта.
35
Программа
Рис.6.1. Программа решения дифференциальных уравнений
Нужно ввести дифференциальное уравнение, согласно варианту. Для
каждого варианта задано два ГУ. Каждое новое вычисление начинается с
первой стоки. В программе приведен пример для dy  2 y  e x .
dx
Варианты заданий
dy
1.
 4 y  e 2 x , ГУ – (x=0, y=1; x=1, y=1)
dx
dy
 y  2 x , ГУ – (x=0, y=1; x=1, y=2)
dx
dy
3.
 y  2 x  e x , ГУ – (x=0, y=1; x=1, y=0)
dx
dy
4.
 2 y  3 sin( x ) , ГУ – (x=0, y=0; x=0, y=1)
dx
2.
36
5.
dy
 y  2 cos( x ) , ГУ – (x=0, y=0; x=0, y=1)
dx
Число e набирается как % e, π - %pi, диапазон в построении графика
подбирается от -2 до 2. Для 4-го и 5-го варианта [x, 0, %pi].
В отчете нужно представить решение уравнения, решение при 2-х
ГУ, графики для 2-х ГУ.
37
ПРИЛОЖЕНИЕ 1
Основы работы в среде MULTISIM
Введение в среду
Разработка любого радиоэлектронного устройства сопровождается физическим или математическим моделированием. Физическое моделирование связано с большими материальными затратами, поскольку требуется изготовление макетов и их трудоемкое исследование. Часто физическое моделирование просто невозможно из-за чрезвычайной сложности
устройства, например, при разработке больших и сверхбольших интегральных микросхем. В этом случае прибегают к математическому моделированию с использованием средств и методов вычислительной техники.
1. Назначение программы.
Программа «NI MULTISIM» позволяет проводить анализ электрических схем аналогично программе «ELECTRONIC WORKBENCH», а
именно:
- создать принципиальную электрическую схему устройства и отредактировать ее;
- провести расчет статического режима по постоянному току;
- рассчитать частотные характеристики и переходные процессы;
- провести оценку уровня внутреннего шума и предельной чувствительности;
- провести многовариантный анализ, включая статистический анализ по методу Монте-Карло;
- наращивать библиотеку компонентов;
- представлять данные в форме, удобной для интерпретации и дальнейшего анализа;
38
- реализовывать другие сервисные функции, типичные для такого
класса программ;
- провести печать схемы на электронную плату.
2. Вход в программу.
Запустить программу NI MULTISIM можно двумя способами:
1.
Запустить программу NI MULTISIM.exe;
2.
Запустить через ярлык MULTISIM с панели управления.
1.
Структура окна и система меню
Рабочее окно программы версии 13.0 показаны на рис. п.1.1.
Рис. п.1.1
Окно программы NI MULTISIM (рис. п.1.1) содержит поле меню,
линейку контрольно-измерительных приборов и линейку библиотек компонентов, одна из которых в развернутом виде показана в левой части окна. В
рабочем поле программы располагается моделируемая схема с подключенными к ней иконками контрольно-измерительных приборов. При необходи39
мости каждый из приборов может быть развернут для установки режимов его
работы и наблюдения результатов. Линейки прокрутки используются только
для перемещения схемы. В правой части окна программы располагается меню
инструментов
Рассмотрим команды меню программы NI MULTISIM в порядке
их следования на рис. п. 1.1.
1.1. МЕНЮ FILE
Меню File предназначено для загрузки и записи файлов, получения
твердой копии выбранных для печати составных частей схемы, а также для
импорта/экспорта файлов в форматах других систем моделирования и программ разработки печатных плат. На рис. п.1. 2 показан вид меню File:
40
Рис. п.1. 2
1. Четыре команды этого меню: New (Ctrl+N), Open... (Ctrl+0), Save
(Ctrl+S), Save As... -типичные для Windows команды работы с файлами и
поэтому пояснений не требуют. Для этих команд имеются кнопки (иконки)
со стандартным изображением в инструментарии (Toolbar) – Standart, который отображается чуть ниже меню File. Схемные файлы программы NI
MULTISIM имеют расширение .ms13. Save All - команда для сохранения
всех схем, отображенных в окне программы. Export template – команда экс41
порта схемы, сохраненной другом расширении. Open samples – команда открытия стандартных примитивных образцов схем, встроенных в NI MULTISIM.
2. Close, Close all - закрытие текущей схемы (всех схем).
3. Print... (CTRL+P) - выбор данных для вывода на принтер.
4. Print Preview... – команда предварительного просмотра изображения схемы, посланного на принтер.
5. Print options – команда, содержащая в себе опции, с помощью
которых пользователь может предварительно настроить в какой форме ему
нужно вывести на печать полученную схему (опция Print Sheet Setup). Опция Print Instruments позволяет выбрать инструменты программы NI MULTISIM (к примеру Oscilloscope), изображение на которых будет выведено на
печать.
6. Snippets - команда меню, содержащая в себе подкоманды: Save
Selection As Snippets – команда, позволяющая сохранить выбранные фрагменты схемы как изображения в расширении .png, Save Activate Design As
Snippets – команда, позволяющая сохранить всю схему как изображение в
формате .png, Open snippet file - команда, позволяющая открыть сохраненный рисунок схемы в расширении .png.
7. Projects and Packing – команда меню с подкомандами: New project - создать новый проект, Open project – команда, позволяющая открыть
новый проект, Save project, Close project – команды, позволяющие сохранить
и закрыть текущий проект. Команды Pack project, Unpack project, Upgrade
project позволяют запаковать, распаковать, усовершенствовать проект соответственно. Version control – команда, отображающая информацию о текущей версии проекта. Проектом в NI MULTISIM может считаться готовая
схема на электронной плате, которую можно послать в печать на станок, позволяющий печатать платы.
42
8. Recent design – команда переключения между задействованными
в данный момент в программе NI MULTISIM схемами.
9. Recent Projects - команда переключения между задействованными в данный момент в программе NI MULTISIM проектами.
10. File Information - команда, отображающая информацию об текущей открытой схеме.
11. Exit (ALT + F4) -выход из программы.
1.2. МЕНЮ EDIT.
На рис.п.1.3 показано меню Edit:
43
Рис. п.1.3
Меню Edit позволяет выполнять команды редактирования схем
и копирования экрана.
1. Cut (CTRL+X)– стирание (вырезание) выделенной части схемы с
сохранением ее в буфере обмена (Сlipboard). Выделение одного компонента
производится щелчком мыши на изображении (значке) компонента. Для выделения части схемы или нескольких компонентов необходимо поставить
курсор мыши в левый угол воображаемого прямоугольника, охватывающего
44
выделяемую часть, нажать левую кнопку мыши и, не отпуская ее, протянуть
курсор по диагонали этого прямоугольника, контуры которого появляются
уже в начале движения мыши, и затем отпустить кнопку.
2. Copy (CTRL+C) -копирование выделенной части схемы в буфер
обмена.
3. Paste (CTRL+V) -вставка содержимого буфера обмена на рабочее поле программы. Поскольку в EWB нет возможности помещать импортируемое изображение схемы или ее фрагмента в точно указанное место, то
непосредственно после вставки, когда изображение еще является отмеченным
(выделено красным) и может оказаться наложенным на создаваемую схему,
его можно переместить в нужное место клавишами курсора или ухватившись
мышью за один из отмеченных компонентов. Таким же образом перемещаются и предварительно выделенные фрагменты уже имеющейся на рабочем поле
схемы. Paste Special команда, содержащая в себе подкоманды: Paste as subcircuit – вставить как подсхему, Paste without renaming on page connectors –
вставить как часть схемы без переименования элементов на странице.
4.Delete (Del) -стирание выделенной части схемы.
5. Select Аll (CTRL+A) -выделение всей схемы.
6. Undo, Redo – команды, позволяющие отменить последнее действие над схемой/ вернуть предыдущее отмененное действие.
7. Find - команда поиска элемента на странице.
Остальные команды в работе нам не понадобятся.
1.3. МЕНЮ VIEW
Меню View используется при подготовке к работе программы, выведения на экран нужных инструментариев (Toolbars). На рис. п.1.4 показано
меню View:
45
Рис. п.1.4
В данном меню нам понадобятся команды:
1. Zoom In, Zoom Out, Zoom Area – увеличение, уменьшение, увеличение области схемы.
2. Show Grid, Show Border – показывать сетку для удобства рисования схемы (по умолчанию эта опция выключена, остальные включены),
показать границу окна схемы.
3. Toolbars – команда для вызова на экран инструментариев. Нам
понадобятся меню инструментариев: Standard, View, Main, Components,
Ladder Diagram, Simulation Switch, Simulation, Instruments – в данных меню содержатся команды сохранения, открытия, закрытия, печати, дублирования команд увеличения части схемы, содержатся меню включения схемы,
меню инструментов и т.д.
46
Activate (CTRL+G) -запуск моделирования, Stop (СТRL+Т) остановка моделирования. Эта и предыдущая команды могут быть выполнены также нажатием кнопки, расположенной в правом
верх- нем
углу экрана.
Pause (F9) -прерывание моделирования.
1.4. МЕНЮ PLACE
Основное меню, которое нам понадобиться. В нем содержатся все
элементы для создания схемы. Меню показано на рис. п.1.5.
Рис. п.1.5
Команда Components содержит все компоненты для создания электрической схемы. Вид подменю команды показан на рис. п.1.6.
47
Рис. п.1. 6
В данной команде есть подменю Database, Group. Первая команда
позволяет выбрать базу данных элементов для схемы, вторая команда позволяет выбрать подгруппы элементов, на которые разбита выбранная база данных элементов схемы.
Выберем один из элементов, к примеру резистор. Сделаем двойной
щелчок левой клавишей мыши по нему. Появится меню, показанное на
рис.п.1. 7.
48
Рис. п.1.7
В данном окне можно выделить следующие подменю:
1. Label (CTRL+L) -ввод позиционного обозначения выделенного
компонента (например, R1 -для резистора, C5 -для конденсатора и т.д.) с
помощью диалогового окна. При необходимости сдвига обозначения вправо,
можно слева ввести необходимое число пробелов.
49
2. Value (CTRL+U) – изменение номинального значения параметра
компонента с помощью диалогового окна; команда выполняется так же двойным щелчком мыши по компоненту. Номинальное значение параметра вводится с клавиатуры, после чего нажатием курсором мыши на кнопки вверхвниз выбирается множитель, кратный 1000.
Данные подменю понадобятся при работе.
Работа с меню, как и во всех других подобных случаях, заканчивается нажатием кнопок OK или Cancel -с сохранением или без сохранения
введенных изменений.
Также есть команды Text, Graphics с помощью которых можно
вставить текст и графические элементы в окно схемы.
Средства управления базами данных позволяют перемещать
компоненты, объединять две базы в одну и редактировать их. Все
базы данных разделяются на группы, а они, в свою очередь., на семейства. Когда пользователь выбирает компонент и помещает его в схему,
создается новая копия, Все изменения с ней никак не затрагивают
информацию, хранящуюся в базе данных.
База данных Master Database разделена на группы:
Sources. Cодержит все источники напряжения и тока, заземления. Например, power sources (источники постоянного, переменного
напряжения, заземление, беспроводные соединения - VCC, VDD, VSS,
VEE), signal voltage sources (источники прямоугольных импульсов, источник сигнала через определенные промежутки времени), signal current
sourses (постоянные, переменные источники тока, источники прямоугольных импульсов).
Basic. Содержит основные элементы схемотехники: резисторы,
индуктивные элементы, емкостные элементы, ключи, трансформаторы,
реле, коннекторы и т.д.
50
Diodes. Содержит различные виды диодов: фотодиоды, диоды
Шоттки, светодиоды и т.д.
Transistors. Содержит различные виды транзисторов: pnp-,npnтранзисторы,биполярные транзисоры, МОП-транзисторы, КМОП- транзисторы и т.д.
Analog. Содержит все виды усилителей: операционные, дифференциальные, инвертирующие и т.д.
TTL. Содержит элементы транзисторно-транзисторной логики
CMOS. Содержит элементы КМОП-логики.
MCU Module – управляющий модуль многопунктовой связи (от
англ. multipoint control unit)
Advanced_Peripherals.
Содержит
подключаемые
внешние
устройства (дисплеи, терминалы, клавишные поля).
Misc Digital. Содержит различные цифровые устройства.
Mixed. Содержит комбинированные компоненты
Indicators. Содержит измерительные приборы (вольтметры, амперметры), лампы и т.д.
1.5. МЕНЮ SIMULATE
В данном меню содержатся команды RUN, PAUSE, STOP, позволяющие запустить симуляцию схемы, остановить симуляцию схемы, поставить симуляцию схемы на паузу.
Команда Instruments содержит в себе необходимые для замеров
инструменты, к примеру осциллоскоп, мультиметр, частотомер и т.д. Данная
команда дублируется справа в подменю Instruments..
51
Команда Analyses позволяет провести анализ колебаний в схеме, к
примеру - AC Analysis, Fourier Analysis, Noise Analysis и т.д. На рис.п.1. 8
показано для примера окно AC Analysis.
В Multisim предусмотрено множество режимов анализа данных
эмуляции, от простых до самых сложных, в том числе и вложенных.
Основные виды анализа:
1) DC – анализ цепи на постоянном токе.
Анализ цепей на постоянном токе осуществляется для резистивных
схем. Это правило следует напрямую из теории электрических цепей;
при анализе на постоянном токе конденсаторы заменяют разрывом,
катушки индуктивности – коротким замыканием, нелинейные компоненты, такие как диоды и транзисторы, заменяют их сопротивлением постоянному току в рабочей точке. Анализ цепи на постоянном токе выявляет узловые потенциалы исследуемой схемы
2) AC – анализ цепи на переменном токе.
Анализ цепей на переменном токе заключается в построении частотных характеристик.
3) Transient – анализ переходных процессов
Анализ переходных процессов в цепях позволяет определить форму выходного сигнала, то есть построить график сигнала как функции времени.
Список всех функций Multisim приведен на следующем рисунке:
52
Рис. п.1.8
Чтобы начать анализ, выберите пункт меню Simulate\ Analyses выберите требуемый режим.
53
Рис. п.1.9
Analysis Options позволяет внести максимум точек анализа и внести название анализа. Frequency Parameters позволяет задать начальную и
конечную частоты анализа.
На рис. п.1.9 показана схема RLC фильтра из стандартной библиотеки NI MULTISIM.
54
Рис. п.1.10
Для данной схемы на рис. п.1.10 приведен пример AC Analysis:
55
Рис. п.1.11
1.6. МЕНЮ HELР.
Меню Help построено стандартным для Windows способом. Оно
содержит краткие сведения по всем рассмотренным выше командам, библиотечным компонентам и измерительным приборам, а также сведения о самой
программе. Отметим, что для получения справки по библиотечному компоненту его необходимо отметить на схеме щелчком мыши (он высветится
красным цветом) и затем нажать клавишу Fl.
Остальные меню в работе нам не понадобятся.
56
Виртуальные приборы
Обычно приборы расположены на правой панели инструме нтов
схемы и их можно перенести на схему, удерживая левую клавишу м ыши.
Рассмотрим основные рабочие измерительные приборы.
Мультиметр
Мультиметр предназначен для измерения переменного или постоянного тока или напряжения, сопротивления или затухания между
двумя узлами схемы. Диапазон измерений мультиметра подбирается автоматически. Его внутреннее сопротивление и ток близки к идеальным значениям, но их можно изменить.
Изображается на схеме:
Рис. п.1.12
Генератор сигналов
Генератор сигналов (function generator) – это источник напряжения, который может генерировать синусоидальные, пилообразные и прямоугольные импульсы. Можно изменить форму сигнала, его частоту, амплитуду, коэффициент заполнения и постоянный сдвиг. Диапазон генерато57
ра достаточен, чтобы воспроизвести сигналы с частотами от нескольких
герц до аудио и радиочастотных.
Он изображается на схеме в виде:
Рис. п.1.13
Осциллограф
В Multisim есть несколько модификаций осциллографов, которыми можно управлять как настоящими. Они позволяют устанавливать
параметры временной развертки и напряжения, выбирать тип и уровень
запуска измерений. Данные осциллографов можно посмотреть после
Эмуляции с помощью самописца (Grapher) из меню Вид\Плоттер (View/Grapher).
В Multisim есть следующие осциллографы:
- 2-х канальный
- 4-х канальный
- осциллограф смешанных сигналов Agilent 54622D
4-х канальный цифровой осциллограф с записью Tektronix TDS 2024.
Изображается на схеме:
58
Рис 14
Рис п.1.15
Построитель частотных характеристик (Боде Плоттер)
Отображает относительный фазовый или амплитудный отклик
входного и выходного сигналов. Это особенно удобно при анализе свойств
полосовых фильтров. Плоттер изображается на следующей схеме:
59
Рис п.1.16
Спектральный анализатор
Спектральный анализатор (spectrum analyzer) служит для измерения амплитуды гармоники с заданной частотой. Также он может
измерить мощность сигнала и частотных компонент, определить наличие гармоник в сигнале.
Результаты работы спектрального анализатора отображаются в
частотной области, а не временной. Обычно сигнал- это функция времени, для её измерения используется осциллограф. Иногда ожидается
синусоидальный сигнал, но он может содержать дополнительные гармоники, в результате, невозможно измерить уровень сигнала. Если же
сигнал измеряется спектральным анализатором, получается частотный состав сигнала, то есть определяется амплитуда основной и дополнительных гармоник.
60
Рис. п.11.17
Ваттметр
Прибор предназначен для измерения мощности и коэффициента мощности.
Рис. п.1.18
Postprocessor и Grapher
Postprocessor и Grapher — это программы пакета Multisim,
которые позволяют отобразить результаты моделирования в графическом виде.
Данная функция позволяет строить необходимые графики после проведенного анализа. Для работы с функцией Postprocessor
необходимо знать названия узлов. Только те параметры (входные и вы61
ходные переменные), которые указываются при выполнении любого
вида анализа(AC Sweep, DC Sweep, Transient Analysis и т.д.) отображаются на графиках функции Postprocessor и Grapher.
С помощью данной функции можно создать несколько графиков, изменять параметры графика, удалять объекты, производить логические и алгебраические операции над графиками(сложение, умножение,
возведение в квадрат и т.д.).
Вызов функции осуществляется:
Рис. п.1.19
Создание графика:
-внесение данных, необходимых для построения:
62
Рис. п.1.20
Select simulation results-добавление данных проведенного анализа. Variables-переменные, необходимые для построения графика.
Functions-алгебраические действия над графиками.
63
Рис. п.1.21
В окне Expressions available выбираем необходимые графики для
построения.
Общие правила моделирования
При моделировании схем необходимо соблюдать следующие
общие правила:
1)
Любая схема должна обязательно содержать хотя бы
один символ заземления.
2)
Любые два конца проводника либо контакта устрой-
ства, встречающихся в точке, всегда считаются соединенными. При
соединении трех концов (Т-соединение) необходимо использовать
символ соединения (узел). Те же правила применяются при соединении четырех и более контактов.
64
3)
В схемах должны присутствовать источники сигнала (тока
или напряжения), обеспечивающие входной сигнал, и не менее одной
контрольной точки (за исключением анализа схем постоянного тока).
Топология схем
1)
В схеме не должны присутствовать контуры
из катушек
индуктивности и источников напряжения.
2)
Источники тока не должны соединяться последовательно
3)
Не должно присутствовать короткозамкнутых катушек
4)
Источник напряжения должен соединяться с катушкой
индуктивности и трансформатором через последовательно включенный
резистор. К конденсатору, подключенному к источнику тока, обязательно должен быть параллельно присоединен резистор.
Пример моделирования схемы
Для примера рассмотрим усилительный каскад на биполярном транзисторе, включенным в схему с общим эмиттером. Построим графики
зависимости выходного и входного напряжений от времени, передаточную характеристику, амплитудно-частотную и фазо-частотную характеристики.
1)
Соберем исследуемую схему в среде Multisim. Приме-
чание:
-двойное нажатие левой кнопкой мыши на элемент позволяет изменить
его параметры
65
-для удобства при работе можно изменять цвет проводов (выделяем провод правой кнопкой мыши и в появившемся контекстном меню выбираем Change Color). Показано на рис. п.1.22.
Рис. п.1.22
2)
Запускаем схему, осциллограф автоматически строит
графики зависимости входного и выходного напряжений от времени (для
того, чтобы их посмотреть, достаточно нажать левой кнопкой мыши на осциллографе).
В активном окне Oscilloscope-XSC1 можно увеличивать и
уменьшать масштаб, сдвигать графики по осям ординат и абсцисс, с помощью курсора смотреть параметры в каждой точке графика, с помощью
кнопки Save можно сохранить данные осциллографа в виде таблице в текстовом файле.
66
Рис.п.1. 23
3)
Построение аналогичных графиков с помощью Transient
Analysis.
С помощью кнопки плоттера отображение курсоров и данных
можно посмотреть значение напряжений в любой точке. При анализе графики для удобства отображаются разными цветами.
В окне Transient Analysis на вкладке Output выбираем необходимые для анализа величины, а на вкладке Analysis Parameters можно установить начальное и конечное время анализа (такие же действия производятся
в любом виде анализа).
67
Рис. п.1.24
4)
Построение передаточной характеристики (зависимость вы-
ходного напряжения от входного) с помощью DC-Sweep Analysis. Работа в
плоттере (Grapher View) с графиком осуществляется аналогично.
Рис.п.1. 25
68
5) Построение АЧХ и ФЧХ (с помощью AC-Analysis).
Рис. п.1.26
69
Горячие клавиши
Ctrl+N
Создать новый файл
Ctrl+O
Открыть файл
Ctrl+S
Сохранить текущий файл
Ctrl+P
Печать графиков / текущий файл
Ctrl+Z
Отмена действия
Ctrl+X
Вырезать
Ctrl+C
Копировать
Ctrl+V
Вставить
Ctrl+D
Открывает Circuit Description Box
Ctrl+F
Поиск
Delete
Удалить выделенную группу
Ctrl+W
Выбор устройств
Ctrl+J
Вставка узла
Ctrl+Q
Добавление провода
Ctrl+I
Вставка коннектора
Ctrl+B
Вставка подсхемы
Ctrl+T
Вставка текста
F5
Запуск схемы
F6
Пауза
Alt+Y
Зеркальное отображение по вертикали
Alt+X
Зеркальное отображение по горизонта-
Ctrl+R
ли
Поворот
на 90 вправо
Ctrl+Shift
+R
Поворот на 90 влево
Клавиши кур-
Перемещает выделенное устройство
сора
влево, вправо, вверх, вниз
70
ПРИЛОЖЕНИЕ 2
Моделирование переходных процессов
Явная форма модели. Наиболее распространены две формы представления
исходной модели схемы для расчёта переходных процессов - явная и неявная. Явная форма в общем случае состоит из двух подсистем
dxi
 F1i ( x, v, w, ), i  1,..., n
dt
F2 j  ( x, v, w, )  0,
Здесь
(п.2.1)
j  1,..., p;
– вектор переменных U c , iL , реактивных элементов,
x
называемых переменными состояниями;
v
– вектор постоянных и временно
зависимых источников E, I; W  вектор переменных u и i, линейных и нелинейных резистивных элементов.
Подсистема (п.2.1) – это система обыкновенных дифференциальных
уравнений (ОДУ) первого порядка, разрешенных относительно производных.
Такая система называется нормальной системой ОДУ.
Вторая подсистема (п.2.1) – это система конечных, в общем случае –
нелинейных уравнений.
Рис. п.2.1 Нелинейная RC – схема
Пример:
71
Модель схемы на рис. (2.1) в явной форме имеет вид
dU C 1 E  U C  U D E  U C  U D
 (

)
dt
C
R1
R2
U R1 U R 2


 0
R1
R2

E  U C  U D  U R1  0


E  U C  U D  U R2  0


I 0 (eU D / / m1 )  1) 
Первое уравнение – дифференциальное, а три последних образуют
нелинейную систему конечных уравнений.
Представление модели схемы в явной форме налагает ограничения на
выбор независимых переменных – ими могут быть только напряжения на емкостях и токи в индуктивностях.
Методы решения системы (2.1) рассмотрим на примере одиночного
уравнения:
dx (t )
 f ( x(t ), t )
dt
(п.2.2)
Поскольку решение системы ОДУ (п.2.1) аналогично уравнению
(п.2.2) математически формируется как задачи Коши, заключающаяся в том,
что ищется решение x(t) уравнения (п.2.2), удовлетворяющее заданному
начальному условию x(t 0 )  x0 на интервале t 0  t  t k , при чем конец интервала заранее может быть и не известен.
При решении численными методами искомая функция x(t) определяется в отдельных точках интервала t1 , t 2 ,..., t n , называемых узлами, в виде
таблицы
значений
x1 , x2 ,..., xn ,,
приближенно
равных
значениям
x(t1 ), x(t 2 ),..., x(t n ) , точного решения x(t). Расстояние между узлами
t  t n1  t n называется шагом интегрирования h и может быть либо заданным перед началом вычислений ( интегрирование с постоянным шагом), либо
определяться в процессе вычислений (интегрирование с автоматическим вы72
бором шага). Значения искомой функции в двух соседних узлах связаны соотношением
x(t  1)  x(t n ) 
t n 1
 f ( x(t ), t )dt
(п.2.3)
tn
Простейшими методами решения уравнения (п.2.3) являются:
Явный метод Эйлера - xn1  xn  hf ( xn , t n );
Метод трапеций - x n 1  x n 
Неявный метод -
h
[ f ( x n , t n )  f ( x n , t n )];
2
xn1  xn  hf ( xn1 , t n1 )
Главное отличие явных методов от неявных состоит в том, что явные методы всегда имеют ограничение на шаг интегрирования ОДУ
h  hм акси превышение этого значения приводит к потере устойчивости системы, т.е. неограниченному росту ошибки по мере продолжения решения.
Неявные методы таких ограничений или вообще не имеют, или эти ограничения значительно слабее.
Пример:
Переходный процесс в простейшей RC – цепи, в которую подан
сигнал E(t), описывается дифференциальным уравнением
dU C (t ) E  U C (t )
.

dt
RC
Положим для простоты E=R=C=1, тогда явный метод Эйлера для
этого уравнения будет иметь вид
U C ,n1  U C ,n  h(1  U C ,n );
а неявный метод – вид:
U C ,n1  U C ,n  h(1  U C ,n1 ) ,
отсюда
U C ,n1  (U C ,n  h) /(1  h) .
73
Значения U C ,n1 , вычисленные обоими методами приведены в табл.
п.2.1 (для разного шага h)
Таблица п.2.1
номер шага
Метод
Явный метод
Эйлера
Неявный
метод Эйлера
значения
шага
0.5
0
0
1
2
3
1
0
0
0
0
1
2
3
0.5
1
0
-3
0.75
1
2
9
0.675
1
0
-15
0.9575
9
99
0
0
0.9
0.99
0.99
0.999
0.999
0.9999
0.9999
0.99999
1
0.5
2
0.75
3
0.875
4
0.9375
Видно, что явный метод Эйлера уже при h>2 теряет устойчивость,
тогда как неявный устойчив даже при h=99.
74
ЛИТЕРАТУРА
1. Автоматизированное проектирование радиоэлектронных средств
[Текст]: учебник для вузов / Под ред. О.В. Алексеева.- М.: Высшая
школа ,- 2000.-479 с. - (Учебник)
2. Головков А.А., Пивоваров. И.Ю., Кузнецов И.Р. Компьютерное
моделирование и проектирование радиоэлектронных средств [Текст]:
учебник для вузов / А.А. Головков и др. – Петербург: ООО Издательство «Питер», 2015, - 208 с. - (Учебник)
3. Автоматизация схемотехнического моделирования [Текст]: учебник для вузов / Под ред. В.Н. Ильина.- М.: Радио и связь ,- 1987.- 292
с. - (Учебник)
4. Пасынков В.В., Чиркин Л.К. Полупроводниковые приборы [Текст]:
учебник для вузов / В.В. Пасынков, Л.К.Чиркин .- М.: Издательство
«Лань», - 2002.-480 с. - (Учебник)
5. Хернитер Марк Е. Самоучитель по Electronics Workbench Multisim
[Текст]:
самоучитель
/
Марк
Е.
Хернитер
.
-
М.:
Изд. дом ДМК-пресс , 2006.-488 с. – (Самоучитель)
6. Моделирование цифровых и аналоговых схем в программе Multisim. Электрические цепи. [Текст]: методические указания к лабораторным работам / под ред. И.А. Патракова. – Архангельск. ; Северный арктический университет, 2011. – 67 с. – (Методические указания)
75
Документ
Категория
Без категории
Просмотров
19
Размер файла
2 014 Кб
Теги
modelirovanie, programma, 2017, soldatova, machihin, res, kompyuternye, multisim
1/--страниц
Пожаловаться на содержимое документа