close

Вход

Забыли?

вход по аккаунту

?

KozlovSmirnov

код для вставкиСкачать
Министерство образования и науки российской федерации
Федеральное государственное автономное образовательное
учреждение высшего профессионального образования
САНКТ-ПЕТЕРБУРГСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ
АЭРОКОСМИЧЕСКОГО ПРИБОРОСТРОЕНИЯ
МОДЕЛИРОВАНИЕ И ИССЛЕДОВАНИЕ
КОНСТРУКЦИЙ ЭЛЕКТРОННЫХ УЗЛОВ
С ИСПОЛЬЗОВАНИЕМ SOLIDWORKS И ANSYS
Методические указания
к лабораторным работам
Санкт-Петербург
2015
Составители: А. А. Козлов, О. Л. Смирнов
Рецензент – кандидат технических наук, доцент Н. В. Соловьёв
Издание предназначено для студентов специальностей «Проектирование и технология электронных средств», «Лазерные системы
в ракетной технике», «Информатика и вычислительная техника»,
«Радиотехника», «Вычислительные машины, комплексы, системы
и сети», выполняющих лабораторный практикум на дневном и вечернем факультетах, а также слушателей факультета повышения квалификации преподавателей.
Печатается в авторской редакции.
Компьютерная верстка Н. Н. Караваевой
Сдано в набор 20.03.15. Подписано к печати 24.04.15. Формат 60×84 1/16.
Бумага офсетная. Усл. печ. л. 1,2. Тираж 100 экз. Заказ № 146.
Редакционно-издательский центр ГУАП
190000, Санкт-Петербург, Б. Морская ул., 67
 
©  Санкт-Петербургский государственный
  университет аэрокосмического
  приборостроения (ГУАП), 2015
ПРЕДИСЛОВИЕ
Радиоэлектроника и вычислительная техника используется во
всех сферах человеческой деятельности. Основу всех этих устройств
составляют печатные платы, создание которых требует от разработчика и конструктора учета разнообразных и противоречивых требований. Внедрение микросхем и многослойных печатных плат,
привело к тому, что их конструирование стало невозможным без
средств автоматизации (САПР). Современные САПР позволяют
произвести качественное проектирование изделия, с обеспечением
технических требований к его функционированию.
Обзор существующих САПР, позволяющих провести всестороннее исследование устойчивости устройства к внешним воздействиям, показал, что одним из наиболее универсальных систем, позволяющих провести наиболее широкий спектр исследований над обширными классами устройств и сред, является АНСИС.
Актуальность работы заключается в отсутствии учебных пособий по проверке работоспособности разрабатываемого электронного
устройства средствами САПР, подобных ANSYS.
Цикл лабораторных работ на основе приложений SOLIDWORKS
и ANSYS предназначен для студентов радиотехнических и вычислительных специальностей, обучающихся на кафедре конструирования и технологии электронных и лазерных средств и включает.
– создание модели платы
– определение резонансной частоты устройства;
– определение виброперемещений и возникающих нагрузок;
– определение температуры, воздействующей на элементы устройства;
– сравнение полученных результатов с теоретическими расчётами для оценки работоспособности устройства.
Структурно лабораторный практикум объединяет 5 лабораторных работ, каждая из которых содержит теоретический материал,
3
порядок выполнения работы и оформления результатов. Результаты работы представляются в виде файлов, формат и наименование
которых определяется требованиями по оформлению.
Каждая работа заканчивается контрольными вопросами, позволяющими провести самоконтроль и укрепить теоретические знания и практические навыки.
Библиографический список включает учебные пособия и научно-техническую литературу, предназначенные для более глубокого
изучения дисциплины.
4
Лабораторная работа №1
Создание геометрической модели платы в SolidWorks
Цель работы: приобретение навыков работы в SolidWorks при
разработке геометрической модели платы.
Исходными данными для создания геометрической модели печатной платы служат “DXF” файлы, содержащие контуры корпусов компонентов, монтажных отверстий и контактных площадок.
Если работа с данными файлами производится в САПР AutoCAD,
то перед копированием необходимо произвести операцию разбиения (“Modify/Explode”).
Создание геометрической модели платы можно разделить на следующие этапы:
– создание основания платы;
– создание навесных элементов;
– сборка навесных элементов на основании платы .
Для создания основания платы необходимо выполнить следующие действия:
1. Создать параллелепипед с габаритами платы (рис. 1.1);
Рис. 1.1 – Создание основания платы
2. Скопировать чертёж вида спереди в буфер обмена;
3. Выбрать переднюю плоскость заготовки;
4. Вставить чертёж. Вероятно, чертёж окажется на каком-то расстоянии от заготовки, но в той же плоскости (рис. 1.2);
5
Рис. 1.2. Несовпадение чертежа и заготовки
5. Запустить редактирование эскиза заготовки;
6. Выбрать чертёж в дереве проекта, и с помощью контекстного
меню выбрать команду “Вперёд” (рис. 1.3);
Рис. 1.3. Запуск редактирования заготовки
и высвечивание чертежа
7. Указать расстояния от края заготовки до крепёжных отверстий на чертеже и применить изменения;
8. Выбрать все крепёжные отверстия чертежа и применить инструмент “Вытянутый вырез”;
9. Выбрать тыльную сторону заготовки;
10. Скопировать чертёж вида сзади в буфер обмена;
11. Вставить чертёж вида сзади;
12. Запустить редактирование чертежа;
13. Выбрать все элементы;
14. Создать блок, выполнив команду “Инструменты\Блоки\Создать” (рис. 1.4).
6
Рис. 1.4. Создание блока
15. Указать расстояние между монтажными отверстиями и краями платы. Так как чертёж представляет собой блок, он переместится целиком.
Результаты создания подложки платы приведены на рис. 1.5.
Рис. 1.5. Основание платы
7
Создание навесных компонентов зависит от того, что за компоненты используются в сборке. При создании компонентов, состоящих из нескольких материалов, следует создавать сборку. Важно
помнить, что чем меньше поверхностей в сборке, тем быстрее производится генерация сетки и расчёт физических характеристик.
В связи с этим не следует включать в сборку мелкие детали.
При размещении компонентов на плате следует определять положение размещаемых компонентов на основании платы. Для повышения удобства размещения имеет смысл отключать отображение
неиспользуемого чертежа. Для этого следует выбрать его в дереве
проекта и в контекстном меню выбрать “Скрыть”. Обратной командой является команда “Отобразить”.
Рис. 1.6. Изменение цвета детали
Рис. 1.7. Пример модели платы
8
Также для облегчения размещения, имеет смысл изменить цвет
платы или навесных элементов. Для этого следует найти интересующий элемент в дереве проекта, вызвать контекстное меню и выполнить команду “Внешний вид\Цвет…” (рис. 1.6).
При размещении компонентов следует помнить, что САПР не может генерировать поверхности нулевой длины, в связи с чем, не следует размещать цилиндрические элементы касательно к поверхностям других тел. Пример модели платы приведён на рис. 1.7. Полученную модель следует сохранить в формате “Parasolid (*.x_t)”.
Содержание отчета:
Краткие теоретические сведения, описание этапов и результатов
моделирования платы и навесных элементов.
Контрольные вопросы
1.1. Как создаётся модель основания платы?
1.2. Как создаётся модель навесного элемента?
1.3. Как устанавливается положение навесных элементов на основании платы?
1.4. Как устранить несовпадение чертежа и заготовки?
 
9
Лабораторная работа №2
Создание библиотеки материалов в САПР Ansys
Цель работы: приобретение навыков работы с библиотеками материалов в САПР Ansys 14
Создание библиотеки можно разделить на следующие этапы:
1. Запуск редактора библиотек;
2. Создание новой библиотеки;
3. Создание материалов.
Для запуска редактора библиотек необходимо выполнить следующие шаги:
1. Выбрать произвольный тип анализа. Для этого нужно перетащить какую-либо пиктограмму, к примеру “Modal”, из окна “Toolbox” в окно “Project Schematic” или дважды кликнуть по ней левой
кнопкой мыши (рис. 2.1).
Рис. 2.1. Окно выбора системы анализа
2. Запустить редактор библиотек. Для этого нужно дважды
кликнуть левой кнопкой мыши по пиктограмме “Engineering Data”
или выбрать кнопку “Edit” в контекстном меню (рис. 2.2).
Рис. 2.2. Запуск редактора библиотек
10
Для создания новой библиотеки следует выполнить следующие
действия:
1. В редакторе библиотек необходимо нажать кнопку “Engineer(рис. 2.3).
ing Data Sources”, обозначенную пиктограммой
Рис. 2.3
2. В окне “Engineering Data Sources” промотать список библиотек до конца.
3. Нажать левой кнопкой мыши на поле с текстом “Click here to
add a new library” (рис. 2.4).
Рис. 2.4. Добавление новой библиотеки
4. Ввести название новой библиотеки.
5. Нажать Enter.
6. Указать путь и название файла библиотеки. Нажать “Сохранить” (рис. 2.5).
Рис. 2.5. Сохранение библиотечного файла
11
Для добавления материала в библиотеку необходимо выполнить
следующие действия:
1. В окне “Engineering Data Sources” выбрать нажатием левой
кнопки мыши редактируемую библиотеку (рис. 2.6). и перетащить
её в окно “Outline of …” (рис. 2.7).
2. В столбце “Edit Library”, обозначенном пиктограммой
установить галку в чекбоксе напротив редактируемой библиотеки.
Рис. 2.6. Включение режима редактирования библиотеки
3. В окне “Outline of …” нажать левой кнопкой мыши на поле
с текстом “Click here to add a new material”.
Рис. 2.7 – Добавление нового материала
4. Ввести название материала и нажать “Enter”.
5. Добавить физические свойства материала, например плотность (“Density”), дважды щёлкнув по их названиям в окне “Toolbox” (рис. 2.8). Если интересующего свойства нет в списке – необходимо отключить фильтр свойств по анализу, отжав кнопку “Filter
Engineering Data for Physics, Analysis and Solver”, обозначенную
(рис. 2.9).
пиктограммой
6. Проверить размерность свойств в окне “Properties of Outline
Row…” (рис. 2.10).
7. Ввести значения физических свойств материала, щёлкнув
мышкой на жёлтое поле в окне “Properties of Outline Row…”. Нажать “Enter” (рис. 2.10).
12
Рис. 2.8. Окно с перечнем физических свойств
Рис. 2.9. Отключение фильтра
Рис. 2.10 – Свойство материала
8. В окне “Engineering Data Sources” в столбце “Edit Library”,
снять галку в чекбоксе напротив
обозначенном пиктограммой
редактируемой библиотеки. В открывшемся окне подтвердить изменения нажатием кнопки “Да” (рис. 2.11).
Рис. 2.11 – Подтверждение изменений
13
Содержание отчета:
Краткие теоретические сведения, описание этапов создания
свойств материалов библиотеки, результаты выполнения работы и
выводы.
Контрольные вопросы:
 1.1. Как создаётся новая библиотека элементов?
 1.2. Как создаётся новый материал в библиотеке элементов?
 1.3. Как задаются новые свойства материалов?
 1.4. Как проверить размерность свойств новых материалов?
14
Лабораторная работа №3
Моделирование резонансных частот устройства
Цель работы: приобретение навыков работы с моделирование резонансных частот в САПР Ansys 14
Чтобы произвести моделирование резонансных частот изделия
в САПР Ansys Workbench необходимо:
1. Выбрать модальный анализ. Для этого нужно перетащить
пиктограмму “Modal” из окна “Toolbox” в окно “Project Schematic”
или дважды кликнуть по ней левой кнопкой мыши (рис. 3.1).
Рис. 3.1. Окно выбора системы анализа
2. Открыть редактор библиотек. Для этого нужно дважды кликнуть левой кнопкой мыши по пиктограмме “Engineering Data” или
выбрать кнопку “Edit” в контекстном меню (рис. 3.2).
Рис. 3.2. Запуск редактора библиотек
3. В редакторе библиотек необходимо нажать кнопку “Engineer, для отображеing Data Sources”, обозначенную пиктограммой
ния полного перечня библиотек (рис. 3.3).
15
Рис. 3.3
4. В открывшемся окне “Engineering Data Sources” нужно выбрать интересующую библиотеку нажатием левой кнопки мыши.
В окне “Outline of …” нужно выбрать интересующий материал, при
помощи левой кнопки мыши. В окне “Properties of Outline Row …:
…” отобразятся физические свойства данного материала. Материал
можно добавить в проект нажатием кнопки “+” (рис. 3.4).
Рис. 3.4. Редактор библиотек
16
5. Закрыть редактор библиотек. Для обновления информации
о проекте необходимо нажать кнопку “Refresh Project”. Для возврата к меню проекта нужно нажать кнопку “Return to Project”
(рис. 3.5).
Рис. 3.5
6. Загрузить 3D модель исследуемой платы. Для этого нужно
кликнуть правой кнопкой мыши по пиктограмме “Geometry”. В открывшемся меню необходимо выбрать строку “Import Geometry”
и нажать кнопку “Browse…”. В диалоговом окне “Открыть” нужно
выбрать интересующий файл и нажать кнопку “Открыть” (рис. 3.6).
Рис. 3.6. Загрузка геометрии
6. Перейти к окну редактирования модели. Для этого нужно
дважды кликнуть левой кнопкой мыши по пиктограмме “Model”
или выбрать кнопку “Edit” в контекстном меню (рис. 3.7).
Рис. 3.7. Запуск редактора модели
17
7. Задать материалы деталям модели. Для этого в окне “Outline” во вкладке “Model”/“Geometry” нужно выбрать интересующую деталь нажатием левой кнопки мыши. В окне “Details of “…””
во вкладке “Material” нужно нажать левой кнопкой мыши на треугольник, расположенный в строке “Assignment” и выбрать материал из контекстного меню. В контекстном меню будет отображен
список из всех материалов, которые были подключены к проекту
(рис. 3.8).
Рис. 3.8. Выбор материала для тела “Плата”
8. Может потребоваться указать метод генерации сетки. Для этого в окне “Outline” во вкладке “Model” выбрать раздел “Mesh”. Добавить в проект метод генерации сетки, выбрав “Method”, во вкладке
“Mesh Control” (рис. 3.9).
Рис. 3.9. Добавление метода разбиения
18
9. Выбрать тела, сетка на которых будет генерироваться согласно выбранному методу. Для этого в окне “Outline” во вкладке “Model”/“Mesh” выбрать “Automatic Method”. В окне “Details of
“…” - Method” во вкладке “Scope” в строке “Geometry” нажать левой
кнопкой мыши на ячейку “No Selection”. Ячейка изменит внешний
вид на кнопки “Apply” и “Cancel”. Выбрать интересующие тела и нажать кнопку “Apply” (рис. 3.10).
Рис. 3.10. Выбор тел
Тела выбираются щелчком левой кнопки по 3D модели, при одиночном выборе (“Single Select”) или путём обвода рамкой (“Box Select”). Если нужно выбрать несколько тел в режиме одиночного
выбора, то последующие тела нужно выбирать с зажатой кнопкой
“Ctrl”. Для выбора точек должна быть активирована иконка куба,
с зеленой точкой, для выбора граней – с линией, для выбора поверхностей – с поверхностью, а для выбора тел – с полностью закрашенным кубом (рис. 3.11).
Рис. 3.11. Смена типа выбора
19
10. Принудительно задать тетраэдрический тип конечных элементов. Для этого в окне “Outline” во вкладке “Model”/“Mesh” выбрать “Automatic Method”. В окне “Details of “…” - Method” во вкладке “Definition” в строке “Method” выбрать “Tetrahedrons” (рис. 3.12).
Рис. 3.12. Выбор метода
11. Сгенерировать сетку. Для этого в окне “Outline” во вкладке
“Model” нажать правой кнопкой по вкладке “Mesh”. В контекстном
меню выбрать “Generate Mesh” (рис. 3.13).
Рис. 3.13. Запуск генератора сетки
20
12. Указать тип закрепления модели. Для этого в окне “Outline”
во вкладке “Model” выбрать вкладку “Modal”. Нажать кнопку “Supports” и добавить интересующий тип закрепления детали. Наиболее подходящим типом закрепления является “Fixed Support”
(рис. 3.14).
Рис. 3.14. Добавление ограничений
13. Выбрать поверхности, на которых происходит закрепление
детали. Для этого в окне “Outline” во вкладке “Model”/“Modal” выбрать “Fixed Support”. В окне “Details of “Fixed Support”” во вкладке “Scope” в строке “Geometry” нажать левой кнопкой мыши на
ячейку “No Selection” (рис. 3.15). Ячейка изменит внешний вид на
кнопки “Apply” и “Cancel”. Выбрать интересующие поверхности и
нажать кнопку “Apply” (рис. 3.16).
Рис. 3.15. Выбор геометрии
21
Рис. 3.16. Выбор мест крепления платы
14. Произвести решение модели. Для этого в окне “Outline” во
вкладке “Model”/“Modal” нажать правой кнопкой по вкладке “Solution”. В контекстном меню выбрать “Solve” (рис. 3.17).
Рис. 3.17. Запуск решателя
15. Выбрать моды для визуализации. Для этого в окне “Outline”
во вкладке “Model”/“Modal” выбрать “Solution” (рис. 3.18). В окне
“Graph” или “Tabular Data” нажать правой кнопкой и выбрать “Se22
lect All” в контекстном меню. В окне “Graph” или “Tabular Data” нажать правой кнопкой и выбрать “Select Create Mode Shape Results”
в контекстном меню (рис. 3.19).
Рис. 3.18. Выбор мод для визуализации
Рис. 3.19. Полготовка визуализации
16. Произвести визуализацию. Для этого в окне “Outline” во
вкладке “Model”/“Modal” нажать правой кнопкой по вкладке “Solution”. В контекстном меню выбрать “Evaluate All Results” (рис. 3.20).
Рис. 3.20 Создание визуализации
23
Выбирая в окне “Outline” во вкладке “Model”/“Modal” вкладку
“Total Deformation”, для интересующей моды можно посмотреть
форму колебаний, а также узнать, в какой части платы нагрузка будет максимальна (рис. 3.21).
Рис. 3.21. Результаты работы программы
Содержание отчета:
Краткие теоретические сведения по моделирование резонансных
частот в САПР Ansys 14, описание этапов выполнения работы, результаты выполнения работы и выводы.
Контрольные вопросы:
1.1. Как отобразить физические свойства материала?
1.2. Как загрузить 3D модель исследуемой платы?
1.3. Как задать материалы деталям модели?
1.4. Как указать тип закрепления модели?
24
Лабораторная работа №4
Моделирование виброперемещений и деформаций
Цель работы: приобретение навыков работы с моделирование
виброперемещений и деформаций плат в САПР Ansys 14.
Данный вид анализа является продолжением модального. Для
моделирования следует выполнить следующие действия:
1. Добавить анализ в проект. Для этого пиктограмму “Random
Vibration” из окна “Toolbox” нужно перетащить в окно “Project
Schematic” на строку “Solution” модального анализа (рис. 4.1).
Рис. 4.1. Добавление анализа
2. Перейти к окну редактирования модели. Для этого нужно
дважды кликнуть левой кнопкой мыши по пиктограмме “Model” окна “Modal” или выбрать кнопку “Edit” в контекстном меню (рис. 4.2).
Рис. 4.2. Запуск редактора модели
25
3. Указать тип нагрузок. Для этого в окне “Outline” во вкладке
“Model” выбрать “Random Vibration”. Нажать кнопку “PSD Base Excitation” и добавить интересующий тип нагрузки. Подходящим типом нагрузки является ускорение “PSD Acceleration” (рис. 4.3).
Рис. 4.3. Добавление нагрузок в проект
4. Указать закрепления модели. Для этого в окне “Outline” во
вкладке “Model”/“Random Vibration” выбрать “PSD Acceleration”.
В окне “Details of “PSD Acceleration”” во вкладке “Scope” в строке
“Boundary Condition” нажать на стрелку в ячейке “None”. Из выпадающего списка выбрать “Fixed Support” (рис. 4.4).
Рис. 4.4. Выбор закреплений
5. Задать анализируемые параметры вибраций. Для этого в окне
“Outline” во вкладке “Model”/“Random Vibration” выбрать “PSD Acceleration”. В окне “Tabular Data” указать значения частоты и ускорения (рис. 4.5). Ячейки выбираются двойным щелчком мыши.
26
Ячейка с частотой должна быть заполнена первой. Значения вводятся с клавиатуры, ввод подтверждается нажатием клавиши
“Enter”.
Ускорения между ячейками таблицы объединяются по линейному закону, что позволяет исследовать диапазоны частот с заданным
параметром виброускорения.
Важно помнить, что если по той или иной причине в модальном
анализе было указано ограничение частот, то нужно указывать частоты из исследуемого диапазона.
Также следует обращать внимание на размерность величин, указанных в проекте.
Рис. 4.5. Параметры анализа
6. Задать направление колебаний. Для этого в окне “Outline” во
вкладке “Model”/“Random Vibration” выбрать “PSD Acceleration”.
В окне “Details of “PSD Acceleration”” во вкладке “Definition”
в строке “Direction” нажать на стрелку в ячейке “None”. Из выпадающего списка выбрать “Z Axis” (рис. 4.6).
Рис. 4.6. Выбор направления колебаний
27
7. Произвести решение модели. Для этого в окне “Outline” во
вкладке “Model”/“ Random Vibration ” нажать правой кнопкой по
вкладке “Solution”. В контекстном меню выбрать “Solve” (рис. 4.7).
Рис. 4.7. Запуск решателя
8. Добавить визуализацию деформаций. Для этого в окне “Outline” во вкладке “Model”/“Random Vibration” нажать правой кнопкой по вкладке “Solution”. В контекстном меню выбрать “Insert”\“D
eformation”\“Directional” (рис. 4.8).
9. Указать параметры визуализации. Для этого в окне “Outline”
во вкладке “Model”/“Random Vibration” выбрать “Directional Deformation”. В окне “Details of “Directional Deformation”” во вкладке
“Scope” в строке “Geometry” щёлкнуть по ячейке “All Bodies”, выбрать плату и нажать “Apply” (рис. 4.9).
Во вкладке “Definition” в строке “Orientation” щёлкнуть на
стрелку и выбрать “Z Axis” (рис. 4.9).
Рис. 4.8. Добавление визуализации деформаций
Рис. 4.9 - Настройка визуализации
28
10. Добавить визуализацию напряжений. Для этого в окне
“Outline” во вкладке “Model”/“Random Vibration” нажать правой кнопкой по вкладке “Solution”. В контекстном меню выбрать
“Insert”\“Stress”\“Equivalent (von-Mises)” (рис. 4.10).
Рис. 4.10. Добавление визуализации нагрузок
11. Указать параметры визуализации. Для этого в окне “Outline” во вкладке “Model”/“Random Vibration” выбрать “Equivalent
Stress”. В окне “Details of “Equivalent Stress”” во вкладке “Scope”
в строке “Geometry” щёлкнуть по ячейке “All Bodies”, выбрать плату и нажать “Apply” (рис. 4.11).
Рис. 4.11 - Настройка визуализации
12. Произвести визуализацию. Для этого в окне “Outline” во
вкладке “Model”/“Random Vibration” нажать правой кнопкой по
вкладке “Solution”. В контекстном меню выбрать “Evaluate All Results” (рис. 4.12–4.14).
Рис. 4.12. Выполнение визуализации
29
Рис. 4.13. Виброперемещения
Рис. 4.14. Внутренние напряжения
30
Содержание отчета:
Краткие теоретические сведения, описание этапов моделирования виброперемещений и деформаций плат, результаты выполнения работы и выводы.
Контрольные вопросы:
1.1. Как указать тип нагрузок?
1.2. Добавление нагрузок в проект?
1.3. Как задать анализируемые параметры вибраций?
1.4. Выбор направления колебаний?
1.5. Как добавить визуализацию напряжений?
31
Лабораторная работа №5
Моделирование тепловых полей
Цель работы: приобретение навыков работы с моделирование тепловых полей плат в САПР Ansys 14.
Чтобы произвести моделирование тепловых полей в САПР Ansys
Workbench необходимо:
1. Выбрать термостатический анализ. Для этого нужно перетащить пиктограмму “Steady-State Thermal” из окна “Toolbox” в окно “Project Schematic” или дважды кликнуть по ней левой кнопкой
мыши (рис. 5.1).
Рис. 5.1. Окно выбора системы анализа
2. Открыть редактор библиотек. Для этого нужно дважды кликнуть левой кнопкой мыши по пиктограмме “Engineering Data” или
выбрать кнопку “Edit” в контекстном меню (рис. 5.2).
Рис. 5.2. Запуск редактора библиотек
3. В редакторе библиотек необходимо нажать кнопку “Engineer, для отображеing Data Sources”, обозначенную пиктограммой
ния полного перечня библиотек (рис. 5.3).
32
Рис. 5.3
4. В открывшемся окне “Engineering Data Sources” нужно выбрать интересующую библиотеку нажатием левой кнопки мыши.
В окне “Outline of …” нужно выбрать интересующий материал, при
помощи левой кнопки мыши. В окне “Properties of Outline Row …:
…” отобразятся физические свойства данного материала. Материал
можно добавить в проект нажатием кнопки “+” (рис. 5.4).
Рис. 5.4. Редактор библиотек
5. Закрыть редактор библиотек. Для обновления информации
о проекте необходимо нажать кнопку “Refresh Project”. Для возврата к меню проекта нужно нажать кнопку “Return to Project”
(рис. 5.5).
Рис. 5.5
33
6. Загрузить 3D модель исследуемой детали. Для этого нужно кликнуть правой кнопкой мыши по пиктограмме “Geometry”.
В открывшемся меню необходимо выбрать строку “Import Geometry” и нажать кнопку “Browse…”. В диалоговом окне “Открыть”
нужно выбрать интересующий файл и нажать кнопку “Открыть”
(рис. 5.6).
Рис. 5.6. Загрузка геометрии
7. В случае если модель представляет собой плату в корпусе, может потребоваться добавить воздушную прослойку. Для этого необходимо выполнить следующие действия:
7.1. Открыть редактор геометрии. Для этого необходимо дважды кликнуть левой кнопкой мыши по пиктограмме “Geometry” или выбрать кнопку “Edit Geometry…” в контекстном меню
(рис. 5.7).
Рис. 5.7. Запуск редактора геометрии
7.2. Сгенерировать импортированные тела. Для этого в окне
“Tree Outline” во вкладке “Steady-State Thermal” нажать правой
кнопкой по вкладке “Import”. В контекстном меню выбрать “Generate”. Внимание, окно “Tree Outline” по умолчанию объединено с
окном “Sketching Toolboxes”. Переключение осуществляется кнопками “Sketching” и “Modeling”, находящимися в нижней части окна (рис. 5.8).
34
Рис. 5.8. Генерирование тел
7.3. Выбрать одну из крайних поверхностей корпуса. Для выбора
воспользоваться инструментом “Single Select” и при активной кноп. При необходимости выбора нескольке выбора поверхностей
ких смежных поверхностей можно воспользоваться клавишей
“Ctrl” (рис. 5.9).
Рис. 5.9. Выбор одной из крайних поверхностей
7.4. Создать в данной плоскости прямоугольник, превышающий
по габаритам корпус. Для этого необходимо перейти в окно “Sketching Toolboxes” нажатием соответствующей кнопки, выбрать инст35
румент “Rectangle” во вкладке “Draw” и обвести им корпус, оставляя некоторый запас (рис. 5.10).
Рис. 5.10. Создание контура
7.5. Создать тело, охватывающее корпус. Для этого выполнить
команду “Create”\“Extrude”. В случае если контур для создания тела не будет выбран автоматически – выбрать его при помощи инструмента “Single Select” при активной кнопке выбора граней
(рис. 5.11).
Рис. 5.1. Выдавливание тела
36
В окне “Details View” указать:
– “Operation” – “Add Frozen”;
– “Direction” – должно быть выбрано то направление (“Normal”
или “Reversed”), при котором выдавливание происходит в сторону
корпуса. Направление можно определить по лучам, исходящим из
контура выдавливания;
– “Extent Type” – “To Surface” (рис. 5.12).
В строке “Target Face” необходимо указать ограничивающую поверхность. Выбор поверхности производится инструментом “Single
(рис. 5.12).
Select” и при активной кнопке выбора поверхностей
Рис. 5.12. Параметры выдавливания
7.6. Сгенерировать тело. Для этого в окне “Tree Outline” во
вкладке “Steady-State Thermal” нажать правой кнопкой по вкладке
“Extrude”. В контекстном меню выбрать “Generate” (рис. 5.13).
Рис. 5.13. Генерация тела
37
7.7. Добавить в проект инструмент “Enclosure”, выполнив команду “Tools”\ “Enclosure” (рис. 5.14).
Рис. 5.14. Добавление инструмента в проект
7.8. Указать настройки инструмента. В окне “Details View” указать:
– “Shape” – “User Defined”;
– “Target Bodies” – “All Bodies”.
В строке “User Defined Body” необходимо выбрать созданное ранее тело. Выбор тела производится инструментом “Single Select”
(рис. 5.15).
и при активной кнопке выбора тел
Рис. 5.15. Параметры инструмента “Enclosure”
В некоторых случаях может потребоваться создать тело без вырезов под некоторые элементы. В таком случае “Target Bodies” уста38
навливается в режим “Selected Bodies”, а в строке “Bodies” выбираются только те тела, которые должны быть вырезаны.
7.9. Произвести разбиение. Для этого в окне “Tree Outline” во
вкладке “Steady-State Thermal” нажать правой кнопкой по вкладке “Enclosure”. В контекстном меню выбрать “Generate” (рис. 5.16)/
Рис. 5.16. Разбиение тел
Если в модели присутствуют поверхности нулевой толщины,
произойдёт ошибка. Такие поверхности возникают при контакте
угла или цилиндра с другими поверхностями.
7.10. Отключить лишние тела. В окне “Tree Outline” во вкладке
“Steady-State Thermal”\ “… Parts, … Bodies” следует выбрать лишнее тело, вызвать контекстное меню нажатием правой кнопкой и
выбрать “Suppress Body” (рис. 5.17).
Рис. 5.17. Отключение лишнего тела
7.11. Вернуться к окну проекта. Для этого следует нажать кнопку
“Generate”, после чего закрыть окно редактора геометрии (рис. 5.18).
Рис. 5.18. Обновление проекта
39
8. Открыть редактор модели. Для этого необходимо дважды
кликнуть левой кнопкой мыши по пиктограмме “Model” или выбрать кнопку “Edit…” в контекстном меню (рис. 5.19) .
Рис. 5.19 – Запуск редактора модели
9. Задать материалы деталям модели. Для этого в окне “Outline”
во вкладке “Model”/“Geometry” нужно выбрать интересующую деталь нажатием левой кнопки мыши. В окне “Details of “…”” во вкладке “Material” нужно нажать левой кнопкой мыши на треугольник,
расположенный в строке “Assignment” и выбрать материал из контекстного меню (рис. 5.20). В контекстном меню будет отображен
список из всех материалов, которые были подключены к проекту.
Рис. 5.20 – Выбор материала для тела “Плата”
40
10. Сгенерировать сетку. Для этого в окне “Outline” во вкладке
“Model” нажать правой кнопкой по вкладке “Mesh”. В контекстном
меню выбрать “Generate Mesh” (рис. 5.21).
Рис. 5.21. Запуск генератора сетки.
11. Добавить конвекцию. Для этого в окне “Outline” во вкладке
“Model” выбрать вкладку “Steady-State Thermal”. Нажать кнопку
“Convection” (рис. 5.22).
Рис. 5.22/ Добавление конвекции
12. Выбрать поверхности, через которые происходит теплоотдача. Для этого в окне “Outline” во вкладке “Model”/“Steady-State
Thermal” выбрать “Convection”. В окне “Details of “Convection”” во
вкладке “Scope” в строке “Geometry” нажать левой кнопкой мыши
на ячейку “No Selection”. Ячейка изменит внешний вид на кнопки
“Apply” и “Cancel”. Выбрать интересующие поверхности и нажать
кнопку “Apply”. Для выбора необходимо воспользоваться инстру41
ментом “Single Select” при активной кнопке выбора поверхно. Так как необходимо выделить несколько поверхностей,
стей
выбор следует производить с зажатой клавишей “Ctrl”.
13. Указать температуру конвекции и коэффициент теплоотдачи.
Для этого следует в окне “Outline” во вкладке “Model”/“Steady-State
Thermal” выбрать “Convection”. В окне “Details of “Convection”” во
вкладке “Definition” в строке “Film Coefficient” ввести значение
коэффициента теплоотдачи, а в строке “Ambient Temperature” –
температуру конвекции. Следует обратить внимание на размерности величин (рис. 5.23).
Рис. 5.23. Свойства конвекции
14. Добавить источники теплоты. Для этого в окне “Outline” во
вкладке “Model” выбрать вкладку “Steady-State Thermal”. Нажать
кнопку “Heat” и выбрать “Internal Heat Generation” (рис. 5.24).
Рис. 5.24. Добавление источника теплоты
42
15. Скрыть тела, мешающие выбору источников теплоты. Выбрать тела, или их элементы, вызвать контекстное меню нажатием
правой кнопки мыши и нажать кнопку “Hide Body” (рис. 5.25).
Рис. 5.25. Скрытие тел
16. Указать источники теплоты и величину выделяемой мощности. Для этого в окне “Outline” во вкладке “Model”/“SteadyState Thermal” следует выбрать “ Internal Heat Generation”. В окне
“Details of “Internal Heat Generation”” во вкладке “Scope” в строке “Geometry” нажать левой кнопкой мыши на ячейку “No Selection”. Ячейка изменит внешний вид на кнопки “Apply” и “Cancel”.
Выбрать элемент, и нажать кнопку “Apply”. Если несколько элементов генерируют одинаковое количество теплоты – можно выбрать их всех. Значение удельной мощности указывается в строке
“Magnitude” раздела “Definition” (рис. 5.26).
17. Для облегчения работы имеет смысл переименовать источник
теплоты в название элемента. Для этого следует выбрать “Internal
Heat Generation” в дереве проекта, вызвать контекстное меню и нажать кнопку “Rename”. После ввода нового названия следует нажать “Enter” (рис. 5.27).
,
Рис. 5.26 – Свойства источника теплоты
43
Рис. 5.27. Переименование
18. Запуск решателя. Для запуска решателя необходимо выбрать
в окне “Outline” вкладку “Model”\“Steady-State Thermal”, вызвать
контекстное меню и нажать “Solve” (рис. 5.28).
Рис. 5.28. Запуск решателя
19. Добавление визуализации. Для добавления визуализации
следует выбрать в окне “Outline” вкладку “Model”\“Steady-State
Thermal”\“Solution”, вызвать контекстное меню и выбрать “Insert”
\“Thermal”\“Temperature”(рис. 5.29) .
Рис. 5.29. Добавление визуализатора температуры
44
20. Так как для анализа наиболее важна температура элементов, в визуализаторе рекомендуется ограничить тела только платой
и элементами. Проще всего сделать это следующим способом:
– скрыть элементы корпуса, при помощи команды “Hide Body”
контекстного меню;
– произвести групповое выделение всего проекта;
– открыть свойства визуализации, щёлкнуть по ячейке “All Body” в строке “Geometry” и согласиться с изменением
(рис. 5.30).
Рис. 5.30 –Настройка визуализатора температуры
21. Произвести визуализацию. Для этого в окне “Outline” во
вкладке “Model”\“Steady-State Thermal” нажать правой кнопкой
по вкладке “Solution”. В контекстном меню выбрать “Evaluate All
Results” (рис. 5.31).
Рис. 5.31 Визуализация температуры
45
Содержание отчета:
Краткие теоретические сведения, описание этапов моделирования тепловых полей. Результаты выполнения работы и выводы.
Контрольные вопросы.
1.1. Как сгенерировать импортированные тела?
1.2. Как сгенерировать сетку?
1.3. Как указать температуру конвекции и коэффициент теплоотдчи?
1.4. Как указать источники теплоты и величину выделяемой
мощности?
Библиографический список
1. В.П. Исаченко, В.А. Осипова, А.С. Сукомел, Теплопередача,
Москва, “Энергия”, 1975г.
2. В.А. Лопухин, Д.К. Шелест, Конструирование и технология
производства электронной аппаратуры, Санкт-Петербург, ГУАП,
2001г.
3. Л. Сегерлинд, Применение метода конечных элементов, Москва, “Мир”, 1979г.
4. http://aton.by/products/cosmoworks.html
5. http://cae-expert.ru
6. http://impact.sourceforge.net/index_ru.html
7. http://ls-dyna.ru
8. http://www.autodesk2010.ru/soft/autodesk-simulation-mechanical.html
9. http://www.nenastran.ru/article/nenastran-pluses
10. http://www.tesis.com.ru/software/abaqus
46
Приложения
Приложение 1.
Определение резонансной частоты плоской пластины
Расчет частоты свободных колебаний прямоугольных пластин
производится на основе следующих допущений:
– изгибные деформации пластины при вибрации по сравнению с
ее толщиной малы, упругие деформации подчиняются закону Гука;
– пластина имеет постоянную толщину, нейтральный слой пластины не подвержен деформациям растяжения-сжатия;
– материал пластины идеально упругий, однородный и изотропный;
– все прямые, нормальные к поверхности нейтрального слоя до
деформации, остаются прямыми и нейтральными к ней после деформации.
Дифференциальное уравнение свободных незатухающих колебаний пластины имеет вид:
m
d 2z
 d4 z
d4 z
d4 z 
D
+
+
2
+
0,
=
 dx4
dt2
dx2dy2 dy4 

где Z - виброперемещение пластины; m – масса пластины; D – жесткость пластины на изгиб (цилиндрическая жесткость).
Цилиндрическая жёсткость определяется по формуле:
D=
Eh3
(
12 1 − ε2
)
,
где E – модуль упругости материала; ε – коэффициент Пуассона материала; h – толщина пластины.
В случае свободной опоры всех сторон частота свободных колебаний пластины может быть найдена по формуле [2]:
f
=
π  i   j 
  +  
2  a   b 
2
2
D
,

 ρh
где I, j – число полуволн синусоиды, укладывающихся вдоль сторон
пластин; , b – размеры сторон; ρ – плотность материала пластины.
Параметры пластины, для проверки достоверности моделей
САПР приведены в табл. П1.1.
47
Таблица П1.1
Параметры пластины
Параметр
Значение
a, м
0,2
b, м
0,15
h, м
E×
1010,
0,002
Н/м2
3,02
ε
r
×10–3
0,22
кг/м3
2,05
Результаты теоретических расчётов, значения полученные путём моделирования и форма колебаний приведены в табл. П1.2
Таблица П1.2
Результаты моделирования
Мода
Расчётное
значение, КГц
Практическое
значение, КГц
Погрешность,
%
1
247,7
246,5
0,5
2
515,2
512,7
0,5
3
723,2
721,1
0,3
4
961,0
957,3
0,4
48
Форма колебаний
Аналитические вычисления подтверждают достоверность модели. Значения полученные, теоретическим путём, и путём моделирования лежат в пределах погрешности вычислений.
Приложение 2.
Термораспределение в стержне
Расчёт термораспределения в стержне производится на основу
следующих допущений:
– стержень находится в среде с постоянной температурой;
– коэффициент теплоотдачи от поверхности стержня к окружающей среде постоянный для всей поверхности;
– учитывается изменения температуры только вдоль оси стержня;
– теплоотдача с торца стержня не учитывается.
Расчёт температуры в произвольном сечении стержня ведётся по
формуле [1]:
(l-x)
t(x) = tf + (t0 - tf )
e
e
l
2α p
λ×r
λ×r
+e
2α p
λ×r
2α p
(x-l)
-l
+e
2α p
,
λ×r
где t(x) – температура стержня в точке х; tf – температура окружающей среды; t0 – температура, поддерживаемая в одном из торцов
стержня; l – длинна стержня; r – радиус сечения стержня; λ – коэффициент теплопроводности материала стержня; αp – коэффициент
теплоотдачи.
Параметры стержня, необходимые для расчётов приведены
в табл. П2.1.
Таблица П2.1
Параметры стержня
Параметр
Значение
l, м
0.1
r, м
0.001
tf,
oC
20
t0,
oC
100
αp,
Вт/м2оС
5,6
λ,
Вт/моС
384
49
Результаты теоретических расчётов и значения, полученные путём моделирования, приведены в табл. П2.2.
Таблица П.2.2
Результаты моделирования
x, м
Расчётное
значение, оС
Практическое
значение, оС
Погрешность,
%
0,02
96,20
96,20
0
0,04
93,29
93,29
0
0,06
91,23
91,23
0
0,08
90,01
90,0
0,01
0,1
89,60
89,60
0
Результат работы программы приведён на рис. П2.1
Рис. П2.1 Распределение температур в стержне.
Аналитические вычисления подтверждают достоверность модели. Значения полученные, теоретическим путём, и путём моделирования лежат в пределах погрешности вычислений.
50
Приложение 3.
Определение резонансной частоты платы
Данные, необходимые для расчётов приведены в табл. П3.1
Таблица П3.1
Параметры печатной платы
Параметр
Значение
a, м
0.2
b, м
0.15
h, м
E×
1010,
0.002
Н/м2
3.02
v
0.22
M, кг
0.43
Схема закрепления
На 4 болтах
Цилиндрическая жёсткость:
D=
=
D
Eh3
(
12 1 − ν2
)
3.02 ⋅ 1010 ⋅ 0.0023
= 21.16
12 1 − 0.222
(
)
Частота собственных колебаний:
π i
j  D
f0 = 
+ 
ab
2
2 a
b2  M
π 1
1  21.16
f0 = 
+
⋅ 0.2 ⋅ 0.15 =
133
2  0.22 0.152  0.43
Результаты моделирования приведены на рис. П3.1.
Относительная погрешность составляет 32%. Данную погрешность можно объяснить тем, что в теоретических расчётах не учитывается неравномерность распределения массы по пластине, а также тот факт, что навесные элементы обладают физическими характеристиками, отличающимися от характеристик пластины.
51
Рис. П3.1 – Результаты модального анализа.
Приложение 4.
Моделирование виброперемещений и деформаций
Разрушающее напряжение при растяжении для стеклотекстолита в среднем составляет 200–220 МПа. Усталостная прочность,
для большинства материалов, составляет 30–40% от разрушающего напряжения.
Параметры вибраций и результаты моделирования приведены
в таблице 6.2.1. Номиналы частот и виброускорений основаны на
ГОСТ РВ 20.39.304-98. Строки с допустимыми параметрами выделены
рамкой.
Результаты работы программы приведены на рис. П4.1 и П4.2.
52
Таблица П4.1
Результаты моделирования
Диапазон
частот, Гц
Ускорение,
м/с2
Виброперемещение, мм
Максимальное давление
при деформации, МПа
1–35
10
0.1
8.0
10–40
20
0.1
11.0
1–60
20
0.2
16.9
1–80
40
0.4
37.6
1–200
20
1.5
132.9
1–300
20
1.5
132.9
1–300
30
1.8
162.8
1–300
50
2.3
210.2
1–300
60
2.5
230.2
1–300
100
3.3
297.2
1–500
50
2.3
213.6
5–2000
100
3.3
317.6
1–2000
300
5.7
550.3
Рис. П4.1. Виброперемещение платы
53
Рис. П4.2. Напряжения в материале подложки
Приложение 5.
Определение теплоустойчивости устройства
Результаты моделирования для температуры 25 °С приведены
на рис. П5.1.
Рис. П5.1. Распределение температуры
54
По результатам визуализации можно судить о том, что максимальной температуре подвержены следующие элементы: 78L05,
79L05, К176ИД2, К176ИЕ13, К561ЛН3, К561ЛС2, KP142EH19A
и КТ315Г. Для теоретических расчётов температуры был выбран
транзистор КТ315Г с допустимой рабочей температурой 125оС.
Точное аналитическое описание температурных полей внутри
блока невозможно из-за громоздкости задачи и неточ­ности исходных данных: мощности источников теплоты, теплофизических
свойств материалов, размеров границ. Поэтому при рас­чете теплового режима блоков РЭА используют приближенные методы анализа и расчета [2].
Параметры, необходимые для теоретического расчёта приведены в табл. 6.1.
Таблица П6.1
Параметр
Значение
Температура окружающей среды, °С
25
Мощность, выделяемая блоком, Вт
6,5
Длина блока, м
0,205
Ширина блока, м
0,157
Высота блока, м
0,055
Мощность, выделяемая в нагретой зоне, Вт
0,71
Длина нагретой зоны, м
0,050
Ширина нагретой зоны, м
0,032
Высота нагретой зоны, м
0,010
Мощность, выделяемая элементом, Вт
0,04
Длина элемента, м
0,005
Ширина элемента, м
0,004
Высота элемента, м
0,005
Площадь определяется по формуле:
S = 2 ( ab + c ( a + b ) ) ,
где S – площадь; a – длина; b – ширина; с – высота.
Площадь корпуса составляет 0,104м2.
Площадь нагретой зоны составляет 0,005м2.
55
Площадь элемента составляет 0,0001м2.
Удельная мощность определяется по формуле:
P
Q= ,
S
где Q –удельная мощность; P –мощность.
Удельная мощность корпуса составляет 62,5Вт/м2.
Удельная мощность нагретой зоны составляет 142Вт/м2.
Удельная мощность элемента составляет 400Вт/м2.
Температура корпуса определяется по формуле:
Òê= Tc + ΔTê ,
где Tк – температура корпуса; Тс – температура окружающей среды;
ΔТк – температура перегрева корпуса.
Температура корпуса составляет 33оС.
Температура нагретой зоны определяется по формуле:
Òíç= Tê + ΔTíç ,
где Tнз – температура нагретой зоны; ΔТнз – температура перегрева
нагретой зоны.
Температура нагретой зоны составляет 48 °С.
Температура элемента определяется по формуле:
Ò=
ý Tíç + ΔTý ,
где Tэ – температура элемента; ΔТэ – температура перегрева элемента.
Температура элемента составляет 84оС.
Зависимость перегрева от удельной поверхностной мощности
приведена на рис. П5.2.
∆tk, °C
40
30
20
10
0
0
100 200 300 400 gk, Вт/м2
Рис. П5.2. Зависимость перегрева от удельной поверхностной мощности
56
Результаты моделирования и теоретических расчётов приведены в табл. П5.2. Номиналы температуры среды основаны на ГОСТ
РВ 20.39.304-98.
Таблица П5.2
Результаты расчётов и моделирования
Допустимое
Практическая
Относительная
значение
температура
погрешность, %
температуры, °С
элемента, °С
Температура
среды, °С
Расчётная
температура
элемента, °С
25
84
97,2
13
125
35
94
107,1
12
125
40
99
112,1
12
125
45
104
117,1
11
125
50
109
122,0
11
125
55
114
127,0
10
125
60
119
132,0
10
125
70
129
142,0
9
125
Высокая погрешность обусловлена низкой точностью аналитической модели.
Приложение 6.
Анализ результатов моделирования
Допустимые условия эксплуатации и результаты моделирования
приведены в табл. П6.1. Категории размещения указаны в соответствии с ГОСТ РВ 20.39.304-98.
Таблица П6.1
Код
категории
размещения
Температура
эксплуатации, °С
Температура
элемента, °С
Диапазон
частот, Гц
2.1.1
40
112,1
1–60
20
16.9
2.1.2
45
117,1
1–60
20
16.9
2.1.5
35
107,1
1–60
20
16.9
2.3.1
40
112,1
1–35
10
8.0
2.3.2
45
117,1
1–35
10
8.0
Давление
Ускорение,
при
2
м/с
деформации,
МПа
57
Окончание табл. П6.1
Код
категории
размещения
Температура
эксплуатации, °С
Температура
элемента, °С
Диапазон
частот, Гц
Давление
Ускорение,
при
м/с2
деформации,
МПа
2.3.5
35
107,1
1–35
10
8.0
2.5.1
35
107,1
1–60
20
16.9
2.6.1
35
107,1
1–60
20
16.9
По результатам анализа можно сделать вывод, что данное устройство может эксплуатироваться в ограниченном числе категорий
размещения. Для расширения зон эксплуатации требуется доработка:
– установка пассивного или активного охлаждения;
– смена типа закрепления платы или внедрение демпфера.
58
Содержание
ПРЕДИСЛОВИЕ.......................................................... Лабораторная работа №1............................................... Создание геометрической модели платы в SolidWorks....... Лабораторная работа №2............................................... Создание библиотеки материалов в САПР Ansys........... Лабораторная работа №3............................................... Моделирование резонансных частот устройства............ Лабораторная работа №4............................................... Моделирование виброперемещений и деформаций........ Лабораторная работа №5............................................... Моделирование тепловых полей................................. Библиографический список....................................... Приложения............................................................... Приложение 1.Определение резонансной частоты
плоской пластины.............................................. Приложение 2.Термораспределение в стержне............. Приложение 3. Определение резонансной частоты
платы............................................................... Приложение 4.Моделирование виброперемещений
и деформаций.................................................... Приложение 5.Определение теплоустойчивости
устройства........................................................ Приложение 6.Анализ результатов моделирования. ..... 3
5
5
10
10
15
15
25
25
32
32
46
47
47
49
51
52
54
57
59
Документ
Категория
Без категории
Просмотров
0
Размер файла
2 195 Кб
Теги
kozlovsmirnov
1/--страниц
Пожаловаться на содержимое документа