close

Вход

Забыли?

вход по аккаунту

?

Malahanov1

код для вставкиСкачать
МИНИcТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ
Государственное образовательное учреждение
высшего профессионального образования
САНКТ-ПЕТЕРБУРГСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ
АЭРОКОСМИЧЕСКОГО ПРИБОРОСТРОЕНИЯ
ДИСКРЕТНЫЕ УСТРОЙСТВА
ОТОБРАЖЕНИЯ ИНФОРМАЦИИ
Методические указания
к выполнению лабораторной работы
Санкт-Петербург
2011
Составитель Р. Н. Малаханов
Рецензент доктор технических наук профессор В. К. Хамидуллин
Методические указания знакомят с принципами управления полупроводниковыми индикаторами; позволяют изучить восьмиразрядный микроконтроллер NEC uPD78F9222, его архитектуру и технические характеристики, методику разработки программного обеспечения, ознакомиться с программными пакетами для разработки
программного обеспечения и программирования микроконтрол­
лера.
Приведено описание лабораторной работы по дисциплинам «Дискретные информационно-измерительные системы» и «Цифровые
вычислительные устройства и микропроцессоры приборных комплексов».
Предназначены для студентов всех форм обучения по направлению «Приборостроение» и специальности «Авиационные приборы и
измерительно-вычислительные комплексы».
Подготовлены кафедрой компьютерного проектирования аэрокосмических измерительно-вычислительных комплексов и рекомендованы к изданию редакционно-издательским советом СанктПетербургского государственного университета аэрокосмического
приборостроения.
Редактор А. В. Подчепаева
Верстальщик И. Н. Мороз
Сдано в набор 18.01.11. Подписано к печати 09.03.11. Формат 60×84 1/16.
Бумага офсетная. Усл. печ. л. 1,5. Уч.-изд. л. 1,6.
Тираж 100 экз. Заказ № 57.
Редакционно-издательский центр ГУАП
190000, Санкт-Петербург, Б. Морская ул., 67
© Санкт-Петербургский государственный
университет аэрокосмического
приборостроения (ГУАП), 2011
Лабораторная работа
ДИСКРЕТНЫЕ УСТРОЙСТВА
ОТОБРАЖЕНИЯ ИНФОРМАЦИИ
Цель работы: изучить принципы управления полупроводниковыми индикаторами с помощью восьмиразрядного микроконтроллера NEC uPD�����������������������������������������������
��������������������������������������������������
78���������������������������������������������
F��������������������������������������������
9222, ознакомиться с его архитектурой и техническими характеристиками, изучить программные пакеты для
разработки программного обеспечения и программирования микроконтроллера.
1. Методические указания
Современные измерительные приборы, а также системы управления, в которых предусмотрены элементы ручного управления
или наблюдения за их функционированием, содержат устройства
или системы отображения информации, основной частью которых
яв­ляются индикаторы. Индикатор – это техническое средство или
вещество, предназначенное для установления наличия какой-либо
физической величины или превышения уровня ее порогового значения [1]. Показывающее устройство средства измерений – это
совокупность элементов средства измерений, которые обеспечивают визуальное восприятие измеряемой величины или связанных с
ней величин [1].
В настоящее время в аппаратном обеспечении систем отображения информации в качестве элементов индикации широко используются жидкокристаллические дисплеи, полупровод­никовые индикаторы и люминесцентные вакуумные индикаторы.
Высокие технические характеристики полупроводниковых ин­
дикаторов обеспечили их успешное внедрение в качест­ве элементов индикации в различной аппаратуре. Достоинствами полупроводниковой технологии являются:
3
возможность их конструктивного исполнения в виде унифицированных модулей;
сов­местимость уровней управляющих напряжений и потребля­
емых токов с напряжениями логических уровней и токами логических интегральных микросхем, что позволяет значительно упростить схемы управления элементами индикации и за счет этого повысить надежность индикаторных устройств;
высокая ремонтопригодность устройств отображения инфор­
мации.
Классификация полупроводниковых индикаторов
Полупроводниковые индикаторы являются одним из видов знакосинтезирующих индикаторов, поэтому рассмотрим основные термины и определения в соответствии с нормативным документом [2].
Знакосинтезирующий индикатор (ЗСИ) – прибор, в котором информация, предназначенная для зритель­ного восприятия,
отображается с помощью одного или совокупности дискретных
­элементов. Информационное поле ЗСИ – конструктивная часть
ЗСИ, в пределах которой возможно отображение информации.
­Элемент отображения (информации ЗСИ) – конструктивная
часть информационного поля ЗСИ, имеющая самостоятельное
управление.
В зависимости от принципа действия ЗСИ подразделяются на
активные и пассивные. Активный (знакосинтезирующий) индикатор – это ЗСИ, принцип действия которого основан на преобразовании энергии электрического поля в световой поток. Пассивный (знакосинтезирующий) индикатор – это ЗСИ, принцип действия которого основан на модуляции проходящего или отраженного ­потока.
Полупроводниковый (знакосинтезирующий) индикатор – активный ЗСИ, в котором используется явление инжекционной электролюминесценции. Электролюминесценцией называется люминесценция, возникающая под действием электрического поля; инжекционная электролюминесценция – это электролюминесценция, возникающая при рекомбинации электронов и дырок на p-n
переходе полупроводникового кристалла, включенного в прямом
направлении [2].
По виду отображаемой информации ЗСИ подразделяются на
единичные, шкальные, цифровые, буквенно-цифровые, мнемонические и графические. По виду информационного поля ЗСИ под4
разделяются на сегментные, матричные, экраны, модули и составные индикаторы.
Единичный (знакосинтезирующий) индикатор – ЗСИ, состоящий из одного элемента изображения и предназначенный для отображения информации в виде точки или геометрической фигуры.
Шкальный (знакосинтезирующий) индикатор – ЗСИ, предназначенный для отображения информации в виде уровней или значений величин.
Сегментный (знакосинтезирующий) индикатор – ЗСИ, элементы отображения которого являются сегментами, сгруппированными в одно или несколько знакомест.
Цифровой (знакосинтезирующий) индикатор – ЗСИ, предназначенный для отображения информации в виде цифр.
Буквенно-цифровой (знакосинтезирующий) индикатор – ЗСИ,
предназначенный для отобра­жения информации в виде букв, цифр,
математических знаков, знаков препинания.
Матричный (знакосинтезирующий) индикатор – ЗСИ, элементы отображения которого сгруппированы по строкам и
столбцам.
Мнемонический (знакосинтезирующий) индикатор – ЗСИ,
предназначенный для отображения информации в виде мнемосхемы или части мнемосхемы.
Графический (знакосинтезирующий) индикатор – ЗСИ, предназначенный для отображения информации в виде знаков, символов и графиков.
(Знакосинтезирующий) экран – матричный ЗСИ без фиксированных знакомест с числом элементов отображения не менее
10 000.
(Знакосинтезирующий) модуль – ЗСИ, конструктивное исполнение которого обеспечивает возможность создания составных индикаторов без потери информации в местах стыковки.
Составной (знакосинтезирующий) индикатор – ЗСИ, конструктивно выполненный как единое целое из отдельных модулей.
В данной работе будет рассмотрено управление светоизлучающими диодами, которые часто применяются в качестве единичных
индикаторов.
Параметры полупроводниковых индикаторов
Перечень основных светотехнических па­раметров полупроводниковых ЗСИ и их определения [2] приведены в табл. 1.
5
Таблица 1
Наименование параметра и его
буквенное обозначение
Определение
Яркость элемента
отображения (информации
ЗСИ), LЭ
Среднее по площади значение яркости
элемента отображения информации ЗСИ
Сила света, Iv
Физическая величина, определяемая
отношением светового потока,
распространяющегося от источника
света внутри малого телесного угла,
содержащего рассматриваемое
направление, к этому углу
Ширина спектра (излучений Диапазон длин волн, в котором
спектральная плотность светового потока
ЗСИ), Δλ0,5
ЗСИ составляет не менее половины ее
максимального значения
Доминирующая длина волны Длина волны, определяемая по графику
цветности МКО и характеризующая цвет
(ЗСИ), λd
свечения ЗСИ
Перечень электрических параметров полупроводниковых ЗСИ
и их определения [2] приведены в табл. 2.
Таблица 2
Наименование параметра
и его буквенное обозначение
На русском языке
на английском
языке
Определение
Напряжение
питания, Uп
Supply
voltage, Uc.c
Значение напряжения источника
питания, обеспечивающего работу
полупроводникового ЗСИ в заданном
режиме
Постоянное
прямое
напряжение, Uпр
Continuous
direct
forward
voltage, UF
Значение постоянного прямого
напряжения на полупроводниковом
ЗСИ при заданном прямом токе
Постоянное
Continuous
обратное
reverse
напряжение
voltage, UR
(на элементе
отображения), Uобр
6
Значения постоянного напряжения,
приложенного к элементу
отображения информации
полупроводникового ЗСИ в обратном
направлении
Продолжение таблицы 2
Наименование параметра
и его буквенное обозначение
На русском языке
на английском
языке
Определение
Импульсное
Peak reverse
обратное
voltage, URM
напряжение
(на элементе
отображения
информации), Uобр.и
Наибольшее мгновенное значение
обратного напряжения на элементе
отображения информации
полупроводникового ЗСИ
Ток потребления,
Iпот
Значение тока, потребляемое
полупроводниковым ЗСИ
от источника питания
Постоянный
прямой ток
элемента
отображения
(информации), Iпр
Forward
current, IF
Значение постоянного тока, протека­
ющего через элемент отображения
информации полупроводникового
ЗСИ в прямом на­правлении
Обратный ток, Iобр Reverse
current, IR
Значение постоянного
тока, протекающего через
полупроводниковый ЗСИ в обратном
направ­лении при заданной обратном
напряжении
Импульсный
прямой ток
элемента
отображения
(информации),
Iпр.и
Peak forward
current, IFM
Наибольшее мгновенное значение
прямого тока, протекающего
через элемент отображения
информации полупроводникового
ЗСИ при заданной скважности и
длительности импульса
Средний прямой
ток (элемента
ото­бражения
информации),
Iпр.ср
Average
forward
current,
IF(Av)
Среднее за период значение
прямого тока, протекающего через
элемент отображения информации
полупроводникового ЗСИ
Средняя
рассеиваемая
мощность, Ррас.ср
Average
power
dissipation,
PAv
Среднее за период значение
мощности, рассеиваемой
полупроводниковым ЗСИ
при протекании тока в прямом
и обратном направлениях
7
Схемы управления светоизлучающими диодами
Схемы подключения светоизлучающих диодов непосредственно
к выводам интегральных микросхем (ИМС) приведены на рис. 1.
На схеме рис. 1, а включение светоизлучающего диода происходит при логическом единич­ном уровне напряжения на выходе
ИМС. Значение сопротивления токоограничивающего резистора
определяется из выражения
R = (U1вых – Uпр)/Iпр,
где U1вых – напряжение логиче­ской единицы на выходе ИМС.
На рис. 1, б включение светоизлучающего диода происходит при
нулевом уровне напряжения на выходе ИМС. При таком включения можно использовать схемы с открытым коллектором. Значение сопротивления токоограничивающего резистора определяется
выражением
R = (Uпит – Uпр – U0выx)/Iпр,
где Uпит – напряжение источника электрического питания; U0выx –
нулевой логи­ческий уровень выходного напряжения ИМС.
Описание лабораторной установки
Лабораторная установка представляет собой макетную плату NEC “Low Pin Count – Do it!” и позволяет изучить технические
характеристики микроконтроллера NEC uPD78F9222 семейства
78K0S. Программное и аппаратное обеспечения, входящее в состав
данного комплекта, позволяет [3]:
изучить программирование интегрированных аппаратных модулей микроконтроллера;
создавать собственное программное обеспечение объемом исполняемого кода до 4 кБ;
а)
ИМС
б)
VD
ИМС
Рис. 1
8
Uпит
R
R
VD
подключать дополнительное оборудование пользователя к макетной плате.
Электрическое питание макетной платы и программирование
микроконтроллера осуществляется с помощью интерфейса USB.
Микроконтроллер NEC �����������������������������������
uPD��������������������������������
78������������������������������
F�����������������������������
9222 обладает следующими техническими характеристиками [4]:
максимальное значение тактовой частоты – 10 МГц;
минимальное время выполнения инструкции – 0,2 мкс (при тактовой частоте 10 МГц);
объем оперативного запоминающего устройства (ОЗУ) –
256 кБайт;
объем перепрограммируемого постоянного запоминающего
устройства (Flash-ППЗУ) – 4 кБайта;
количество цифровых линий ввода/вывода – 17;
4 таймера, один из которых 16-разрядный;
четырехканальный интегрированный модуль 10-разрядного
аналого-цифрового преобразователя (АЦП);
последовательный интерфейс UART (Universal Asynchronous
Receiver Transmitter) с поддержкой шины LIN;
встроенный узел сброса при включении питания РОС (Power-On
Clear) и детектор снижения напряжения пита­ния LVI (Low Voltage
Indicator);
встроенный сторожевой таймер WDT (Watchdog Timer);
напряжение электрического питания от 2,0 до 5,5 В;
диапазон рабочих температур от минус 40 до 85 °С.
Обозначение выводов микросхемы микроконтроллера приведены на рис. 2, а их назначение – в табл. 3.
Рис. 2
9
Внешний вид макетной платы показан на рис. 3. Позиционные
обозначения элементов и их назначение приведены в табл. 4.
Электрическая схема подключения светоизлучающих диодов
D1 – D4 к цифровым выводам микроконтроллера приведена на
рис. 4. Номинальные значения резисторов R1 – R4 – 4,7 кОм; прямой ток диодов – 10 мА.
Таблица 3
Обозначение
вывода
Назначение вывода
ANI0-ANI3
Аналоговые входы модуля АЦП
AVREF
Аналоговый вход опорного напряжения модуля АЦП
INTP0-INTP3
Входы источников внешних прерываний
P20-P23
Порт цифрового ввода/вывода 2
P30, P31, P34
Порт цифрового ввода/вывода 3
P40-P45
Порт цифрового ввода/вывода 4
P121-P123
Порт цифрового ввода/вывода 12
P130
Порт цифрового ввода/вывода 13
RESET
Сигнал аппаратного сброса
RxD6
Прием данных модуля UART
TI000, TI010
Входы таймеров
TO00, TOH1
Выходы таймеров
TxD6
Передача данных модуля UART
VDD
Напряжения электрического питания
VSS
Общий провод
X1, X2
Подключение кварцевого резонатора
10
Рис. 3
Таблица 4
Обозначение
IC3
Назначение
Микроконтроллер NEC uPD78F9222
IC1, IC2, IC4 Микросхемы для программирования микроконтроллера
D1–D4
Светоизлучающие диоды
R24
Потенциометр
SW1
Кнопка, подключенная ко входу INTP0 микроконтроллера
SW2
Кнопка аппаратного сброса микроконтроллера
SW3
Переключатель для выбора режима работы макетной платы
CN7
Разъем USB для подключения платы к персональному
компьютеру
CN1, CN2, Переключатели для выбора режимов работы платы
CN10, CN12
CN3 - CN6
Макетное поле для установки дополнительных элементов
пользователя
11
VDD
IC 3
D1
VDD
R1
D2
R2
D3
R3
D4
R4
P23
P130
0
P45
P123
V3SS
Рис. 4
Регистры конфигурации портов
Для обозначении цифровых линий ввода/вывода (выводов или
разрядов порта) используется буква Р – первая буква английского
слова Port (см. рис. 2). Первые цифры обозначают порядковый номер порта, а последняя цифра – порядковый номер цифровой линии ввода/вывода этого порта. Например, вывод, обозначенный
как Р21, является первой линией порта 2, а Р130 – нулевой линией
(нулевым разрядом) порта 13.
Для управления режимами работы портов цифрового вводы/
вывода микроконтроллера используются регистры режима порта
PMn, где n = 1, 2, 3 и 12; состояния порта Рn, где n = 2, 3, 4, 12
или 13 и регистр РМС2 для управления режимом порта 2 [4].
Для установки режима, в котором будет работать отдельный
цифровой вывод порта (на ввод или на вывод), предназначены регистры PMn, где n = 1, 2, 3 и 12. Название регистров РМ состоит
из первых букв англ. слов Port Mode – режим порта. Формат этих
регистров приведен в табл. 5. Функции выводов портов в зависимости от значения битов регистров PMn приведены в табл. 6. Для
того чтобы вывод порта микроконтроллера работал в режим цифрового вывода, необходимо сбросить соответствующий бит в регистре
PMn. Для того чтобы вывод порта микроконтроллера работал в режим цифрового ввода, необходимо установить соответствующий
бит в регистре PMn. Например, строка программы на языке программирования Си
12
Таблица 5
Регистр
PM2
PM3
PM4
PM12
бит 7
бит 6
бит 5
1
1
1
1
1
1
1
1
1
1
PM45
1
Биты регистра
бит 4
бит 3
бит 2
1
PM23 PM22
1
1
1
PM44 PM43 PM42
1
PM123 PM122
бит 1
бит 0
PM21 PM20
PM31 PM30
PM41 PM40
PM121
1
Таблица 6
Значение бита PMmn,
где m = 2, 3, 4 или 12; n = 0, 7
Режим работы вывода
микроконтроллера
0
1
Цифровой вывод
Цифровой ввод
РМ4 = 0хF1;
настраивает выводы микроконтроллера РМ45, РМ44 и РМ41 как
линии цифрового ввода, а выводы РМ43, РМ42 и РМ40 – как линии цифрового вывода.
После сброса все биты регистров PMn устанавливаются в единицу, т. е. все выводы портов устанавливаются в режим цифрового
ввода.
Для установки данных на выводе микроконтроллера в режиме
цифрового вывода и для чтения данных в режиме цифрового ввода предназначены регистры состояния Рn, где n = 2, 3, 4, 12 или
13. Формат этих регистров приведен в табл. 7; значения битов –
в табл. 8. Для того чтобы установить на выводах порта высокие логические уровни напряжения, необходимо установить соответст­
вующие биты регистра Pn в единицы. Для того чтобы установить
на выводах порта низкие логические уровни напряжения, необхоТаблица 7
Регистр
P2
P3
P4
P12
P13
бит 7
бит 6
бит 5
Биты регистра
бит 4
бит 3
1
1
1
1
1
1
1
1
1
1
1
1
P45
1
1
1
1
P44
1
1
P23
1
P43
P123
1
бит 2
бит 1
бит 0
P22
1
P42
P122
1
P21
P31
P41
P121
1
P20
P30
P40
1
P130
13
Таблица 8
Значение
бита
Pmn
m = 2, 3, 4, 12 или 13; n = 0, 7
Режим цифрового вывода
Режим цифрового ввода
0
Установка низкого логического
уровня на выводе порта
На вывод порта подается
низкий логический уровень
1
Установка высокого логического На вывод порта подается
уровня на выводе порта
высокий логический уровень
димо установить соответствующие биты регистра Pn в нули. Например, строка программы на языке программирования Си
P2 = 0хF5; // 1111 0101
или
P2 = 5; // 0000 0101
устанавливает на выводах микроконтроллера P22 и Р20 высокие
логические уровни напряжения, а на выводах P23 и Р21 – низкие
логические уровни напряжения. Значения битов с 4 по 7 (нули или
единицы) не имеют значения, потому что эти выводы у микроконтроллера физически не реализованы. При этом предварительно все
выводы порт Р2 должен быть настроены на цифровой вывод строкой PM2 = 0;.
Для ввода цифровых данных из порта следует использовать
­дополнительную переменную. Пусть в программе определена
­переменная unsigned char d; и все выводы порта Р2 настроены на
цифровой ввод данных строкой программы РМ2 = 0х0F;. Тогда
чтение цифровых данных из порта Р2 и сохранение их в переменной d осуществляется строкой программы
d = P2;.
Если d = F3h, то это означает, что на выводы микроконтроллера
Р20 и Р21 подаются высокие логические уровни напряжения, а на
выводы Р22 и Р23 – низкие.
14
Программа управления светодиодным индикатором
В листинге 1 в качестве примера приведена программа для микроконтроллера NEC uPD78F9222, которая производит логический
сдвиг влево значения переменной n и отображения этого значения
в двоичном виде на единичных индикаторах D1 – D4. Начальное
значение переменной n равно единице, поэтому результатом программы является поочередное приведение в активное состояние
индикаторов D1 – D4 справа налево.
Обобщенная блок-схема алгоритма изображена на рис. 5.
Листинг 1
// включение файла с определениями имен регистров
#include “io78f9222.h”
// Определение байта конфигурации (Option Byte)
#pragma location = «OPTBYTE»
__root const unsigned char optbyte = 0x9A;
int main( void )
{
unsigned i, j;
// Значение переменной n будет отображаться на
// единичных индикаторах D1 – D4
unsigned char n = 1;
WDTM = 0x70; // отключение сторожевого таймера
// Настройка портов ввода/вывода
PM2 = 0; PMC2 = 0; PM3 = 0; PM4 = 0; PM12 = 0;
// бесконечный рабочий цикл
while(1)
{
// временная задержка
for(i = 0; i < 6500; i++)
for(j = 0; j < 1000; j++);
// Управление светодиодным индикатором D4
P12 = (n & 0x01) ? P12 & ~0x08 : P12 | 0x08;
// Управление светодиодным индикатором D3
P4 = (n & 0x02) ? P4 & ~0x20 : P4 | 0x20;
// Управление светодиодным индикатором D2
P13 = (n & 0x04) ? P13 & ~0x01 : P13 | 0x01;
// Управление светодиодным индикатором D1
P2 = (n & 0x08) ? P2 & ~0x08 : P2 | 0x08;
15
// логический сдвиг влево на один разряд
n <<= 1;
if(n = = 0x10)
n = 1;
}
return 0;
}
Начало
Инициализация переменных и
настройка портов
Бесконечный цикл
Временная задержка
Изменение состояния
светоизлучающих диодов
Да
n = 10h?
n =1
Нет
Бесконечный цикл
Конец
Рис. 5
16
2. Порядок проведения лабораторной работы
Для выполнения лабораторной работы на персональном компьютере должны быть установлены следующие программные
приложения: среда разработки IAR Embedded Workbench и NEC
PG-LPC.
Предварительно создайте на жестком диске компьютера новую
рабочую папку, в которой будут находится файлы создаваемой программы.
Подготовка макетной платы к работе
Для подготовки макетной платы к работе произведите следующие действия:
установите переключатель S1 группового DIP-переключателя
SW3 в положение ON;
установите контакты переключателей CN1, CN2 и CN12 как
указано в табл. 9.
Таблица 9
Переключатель
CN1
CN2 и CN12
Контакты
Положение
1–2
Разомкнуты
3–5
Замкнуты
4–6
Замкнуты
1–2
Замкнуты
3–4, 5–6, 7–8, 9–10
не имеет значения
Создание проекта и компиляция программы в среде
IAR Embedded Workbench
  1. Запустите на выполнение программу IAR Embedded
Workbench. Для этого выберите в меню «Пуск» пункт «Все программы» – «IAR Systems» – «IAR Embedded Workbench Kickstart
for��������������������������������������������������������
�������������������������������������������������������
NEC����������������������������������������������������
78�������������������������������������������������
K������������������������������������������������
» – «�������������������������������������������
IAR����������������������������������������
���������������������������������������
Embedded�������������������������������
������������������������������
Workbench���������������������
». После запуска программы появится диалоговое окно «Embedded Workbench Startup»
(рис. 6, а).
17
a)
б)
Рис. 6
Перед разработкой программного обеспечения следует создать
рабочую область (workspace), в которую могут входит несколько
проектов (projects), при этом каждый проект может содержать различные группы файлов (groups).
Создание рабочей области и проекта
  2. В диалоговом окне «Embedded Workbench Startup» нажмите
на кнопку Create new project in current workspace – «создать новый
проект����������������������������������������������������������
�������������������������������������������������������
���������������������������������������������������������
текущей������������������������������������������������
�������������������������������������������������������
�����������������������������������������������
рабочей����������������������������������������
области��������������������������������
���������������������������������������
». После
�����������������������������
этого появится диалоговое окно «Create New Project» – «создать новый проект» (рис. 6, б).
Если окно «Embedded Workbench Startup» (см. рис. 6, а) после
запуска программы не появилось (это может произойти в том случае, если другой пользователь установил галочку в поле «Do not
show�������������������������������������������������������������
������������������������������������������������������������
this��������������������������������������������������������
�������������������������������������������������������
window�������������������������������������������������
������������������������������������������������
at����������������������������������������������
���������������������������������������������
startup��������������������������������������
» – «не показывать это окно при первоначальном запуске»), то произведите следующие действия:
выберите пункт меню «File» – «New» и в появившемся окне с названием «New» в одноименном списке выберите пункт «Workspace»
и нажмите кнопку ОК;
выберите пункт основного меню «Project» – «Create New Project».
После этого появится окно с названием «Create New Project»
(см. рис. 6, б).
18
  3. В выпадающем списке «Toolchain» выберите пункт «78KO
and 78KOS».
  4. В списке «Project templates» (шаблоны проекта) выберите
язык, на котором будет производится разработка программного
обеспечения. Если программа разрабатывается на языке программирования Си, то выберите пункт «С». Нажмите кнопку ОК. После
этого появится диалоговое окно «Сохранить как».
 ���������������������������������������������������������
5. В списке «Папка» выберите рабочую папку, созданную ранее, в которой будут находится все файлы проекта. В поле «Имя
файла:» введите имя проекта. Имя проекта может быть произвольным. Нажмите кнопку Сохранить. После этого будет создана рабочая область и проект с этим именем. В проекте будет создан файл с
именем «main.c» с функцией int main(void).
Настройка проекта
  6. В окне рабочей области «Workspace» в выпадающем списке
выберите пункт «Release». По умолчанию в этом списке установлен
пункт «Debug».
  7. Выберите пункт основного меню «Projects» – «Options…».
После этого откроется окно с названием «��������������������������
Options�������������������
for���������������
������������������
node����������
��������������
…» с указанием названия проекта.
  8. В списке «Category» выберите пункт «General Options».
  9. Выберите вкладку «Target».
10. В списке «Processor variant» выберите «78KOS».
11. В списке «Category» выберите пункт «Linker».
12. Выберите вкладку «Output».
13. В групповом объекте «�������������������������������������
Output�������������������������������
������������������������������
file��������������������������
» установите флажок в пункте «Override default».
14. В поле редактирования, в котором указано имя проекта, измените расширение с «d26» на «hex».
15. В групповом объекте управления «Format» выберите пункт
«Other».
16. Выберите вкладку «Config».
17. В групповом объекте управления «Linker command line»
установите флажок в поле «Override default».
18. В поле ввода выберите файл «���������������������������
DF�������������������������
9222_��������������������
V�������������������
4.�����������������
xcl��������������
», который находится в директории ����������������������������������������
Program���������������������������������
��������������������������������
Files���������������������������
/��������������������������
IAR�����������������������
����������������������
Systems���������������
/��������������
Embedded������
�����
Workbench 4.3/78k/config.
19. Нажмите кнопку ОК.
19
20. Удалите текст программы по умолчанию из окна «main.c».
21. Поместите текст программы, представленный на рис. 5, в
окно «main.c».
22. Сохраните рабочую область, выбрав пункт основного меню
«File» – «Save Workspace». В появившемся окне с названием «Save
Workspace As» выберите рабочую папку и в поле «Имя файла:»
введите имя рабочей области (которое может быть произвольным)
и нажмите кнопку Сохранить. Файлы рабочей области имеют расширение «eww».
При следующих сеансах работы для открытия рабочей области
следует выбрать пункт основного меню «File» – «Open Workspace…»
и в открывшемся после этого окне «Open Workspace» в поле «Тип
файлов:» выбрать «����������������������������������������������
Workspace�������������������������������������
������������������������������������
Files�������������������������������
(*.���������������������������
eww������������������������
)» и в списке файлов выбрать файл сохраненной ранее рабочей области.
Компиляция программы
23. Выберите пункт основного меню «���������������������������
Project��������������������
– Rebuild����������
�����������������
���������
All������
». Если компиляция прошла успешно, то в окне сообщений «Messages»
будет выдано сообщение
«IAR Universal Linker V4.59F/386
Copyright 1987-2004 IAR Systems. All rights reserved.
32 bytes of CODE memory (+ 2 absolute)
128 bytes of DATA memory
Errors: none
Warnings: none
Total number of errors: 0
Total number of warnings: 0»,
в котором сообщается об отсутствии ошибок («Errors: none» и
­«Total number of errors: 0») и предупреждений («Warnings: none»
���������������������������������������������������������������
«Total number of warnings: 0»). Если
�������������������������������
ошибок нет, то можно переходить к следующему пункту. Количество предупреждений не имеет значения.
Если ошибки будут обнаружены, то в окне сообщений будет приведен их список с указанием файла и номера строки, в котором об20
наружена ошибка. В тексте программы строки, в которых обнаружены ошибки, отмечаются с левой стороны красной галочкой.
Для указания строки программы, в которой обнаружена ошибка, дважды щелкните кнопкой мыши на строке ошибки в окне сообщений. После этого курсор в окне текста программы будет установлен на строке с ошибкой. Исправьте ошибку и повторите компиляцию программы. Это следует повторять до тех пор, пока не будут
исправлены все ошибки.
Результатом компиляции будет файл программы с именем проекта и расширением «�����������������������������������������
hex��������������������������������������
», который будет находится в папке ���
Release/Exe, которая будет создана в рабочей папке проекта.
Программирование микроконтроллера
24. Запустите программу PG-LPC.exe, выбрав пункт меню
«Пуск» – «Все программы» – «����������������������������������
NEC�������������������������������
Tools�������������������������
������������������������������
32» – «������������������
PG����������������
-���������������
LPC������������
». После запуска программы в окне сообщений должно появится сообщение
«>> FlashOpening…
Flash Open OK».
25. Выберите в меню пункт «Device» – «Setup…». После этого
появится диалоговое окно с одноименным названием.
26. Нажмите на кнопку PRM File Read и в открывшемся диалоговом окне «Открыть» в поле «Имя файла» выберите файл параметров компилятора «78������������������������������������������
F�����������������������������������������
9222.������������������������������������
prm���������������������������������
», который находится в папке Pro����
gram Files/NECTools32/PG-LPC/prm. Нажмите кпопку Открыть.
27. В списке «Port» выберите пункт «COM3»; в списке «Speed»
выберите пункт «115200».
28. В поле «��������������������������������������������������
Frequency�����������������������������������������
» установите значение 8, а в поле «������
Multiply rate» – значение 1.
29. В групповом поле «Operation Mode» выберите пункт «Chip».
30. Выберите вкладку «�������������������������������������
Advance������������������������������
». В «������������������������
Command�����������������
����������������
options���������
» установите флажок в пункте «Blank check before Erase».
31. Нажмите кнопку ОК. После этого в окне сообщений должно
появится сообщение
«>>COMMAND: Device Setup
PRM File Read OK».
21
32. Выберите пункт меню «�����������������������������������
File�������������������������������
» – «��������������������������
Load����������������������
…». В открывшемся диалоговом окне «Открыть» выберите файл программы, который имеет имя проекта и расширение «hex». Нажмите кнопку Открыть.
В окне сообщений должно появиться сообщение
«>>COMMAND: LoadFile Open()
Success read HEX file».
33. Выберите пункт основного меню «Device» – «Autoproce­
dure(EPV)». После этого начнется программирование flash-памяти
микроконтроллера, которое может занять несколько минут. Ход
процесса программирования будет отображаться в окне сообщений. После окончания программирования появится сообщение
«>>COMMAND: Reset
Flash Resetting...
OK.
sending reset command...
OK.
>>COMMAND: AutoProcedure(Epv)
Flash Blank Checking...
not blank, then erase.
Flash Erasing...
chip erase finish.
Flash Programming Start...
Flash Programming <10%>...
Flash Programming <20%>...
Flash Programming <30%>...
Flash Programming <40%>...
Flash Programming <50%>...
Flash Programming <60%>...
Flash Programming <70%>...
Flash Programming <80%>...
Flash Programming <90%>...
Flash Programming finish!
Flash Internal Verify OK!».
22
После этого программа успешно записана во flash�����������
����������������
-память микроконтроллера.
34. Для запуска программы нажмите кнопку SW2 на макетной
плате.
35. В соответствии со своим вариантом, полученным у преподавателя и приведенным в табл. 10, разработайте алгоритм рабо-
Таблица 10
№
варианта
Вид индикатора
Примечание
1
Сдвиг числа 1 вправо
2
Сдвиг числа 3 вправо
3
Сдвиг числа 1 вправо
и влево
Цикл по сдвигу влево начинается
сразу же после окончания цикла по
сдвигу вправо
4
Сдвиг числа 3 вправо
и влево
Цикл по сдвигу влево начинается
сразу же после окончания цикла по
сдвигу вправо
5
Сдвиг числа 1 влево
и вправо
Цикл по сдвигу вправо начинается
сразу же после окончания цикла по
сдвигу влево
6
Сдвиг числа 3 влево
и вправо
Цикл по сдвигу вправо начинается
сразу же после окончания цикла по
сдвигу влево
7
Шкальный индикатор
с отображением шкалы
вправо
Сначала загорается
светоизлучающий диод D1, затем
D2 и т.д. После того как будет
отображена вся шкала – все
повторяется сначала
8
Шкальный индикатор
с отображением шкалы
влево
Сначала загорается
светоизлучающий диод D4, затем
D3 и т.д. После того как будет
отображена вся шкала – все
повторяется сначала
23
Продолжение таблицы 10
№
варианта
Вид индикатора
Примечание
9
Шкальный индикатор
с отображением шкалы
вправо и влево
Комбинация вариантов 7 и 8
10
Счетчик
Счет производится
от 0 до 15 и значение счетчика
отображается в двоичном виде
11
Реверсивный счетчик
Счет производится
от 15 до 0 и значение счетчика
отображается в двоичном виде
ты и программу на языке Си; произведите компиляцию программы
и запишите ее в память микроконтроллера; запустите программу
на выполнение; проверьте правильность ее работы.
Все изменения в программу в зависимости от варианта следует
вносить в окне «main.c».
Для компиляции программы следует выполнить пункт 23.
После этого скомпилированный файл программы с последними ­изменениями с расширением «hex» будет находится в папке
­Release/Exe.
Для записи файла программы в память микроконтроллера и ее
запуска на выполнение следует повторить пункты 32–34.
36. Составьте отчет о проделанной работе.
3. Оформление отчета
Оформить отчет в соответствии с требованиями нормоконтроля.
Отчет должен содержать:
цель работы;
задание на лабораторную работу;
электрическую схему подключения светоизлучающих диодов к
микроконтроллеру;
обобщенную блок-схему алгоритма программы;
текст программы на языке Си;
выводы о проделанной работе.
24
Библиографический список
1. РМГ29-99. Государственная система обеспечения единства
измерений. Метрология. Основные термины и определения.
2. ГОСТ 25066-91. Индикаторы знакосинтезирующие. Термины, определения и буквенные обозначения.
3. Low Pin Count – Do it! Demonstration Kit for the NEC Low Pin
Count Devices. User’s Manual. Nec Electronics (Europe) GmbH, 2004.
67 c. Сайт производителя http://www.renesas.eu.
4. Горюнов Г. В., Шестакова А. В. NEC������������������
���������������������
78����������������
KOS�������������
/������������
KA����������
1+. 8-разрядные однокристальные микроконтроллеры uPD������������
���������������
78����������
F���������
9221, ���
uPD78F9222. ООО «Элтех», 2006. 324 с. http://www.eltech.spb.ru/
pdf/nec/234/nec_234.pdf.
25
Содержание
1. Методические указания....................................................... 3
2. Порядок проведения лабораторной работы........................... 17
3. Оформление отчета . ......................................................... 24
Библиографический список................................................... 25
26
Документ
Категория
Без категории
Просмотров
0
Размер файла
893 Кб
Теги
malahanov1
1/--страниц
Пожаловаться на содержимое документа