close

Вход

Забыли?

вход по аккаунту

?

markovcki j

код для вставкиСкачать
ФЕДЕРАЛЬНОЕ АГЕНТСТВО ПО ОБРАЗОВАНИЮ
Государственное образовательное учреждение
высшего профессионального образования
САНКТ'ПЕТЕРБУРГСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ
АЭРОКОСМИЧЕСКОГО ПРИБОРОСТРОЕНИЯ
СХЕМОТЕХНИКА ЭВМ
Компьютерный анализ
и синтез элементов и узлов ЦВМ
на базе программного продукта MicroCAP'8
Методические указания
Санкт'Петербург
2006
Составители: О. И. Курсанов, С. Г. Марковский, Л. А. Осипов,
А. И. Попов
Рецензент
кандидат технических наук В. П. Попов
В издании содержится краткое описание пакета программ MicroCAP'8
применительно к моделированию операционных элементов и устройств
ЦВМ. Пособие сопровождается большим количеством примеров, иллюст'
рирующих способы построения и анализа цифровых схем малой и сред'
ней степени интеграции.
Предназначено для студентов, обучающихся по специальностям «Вы'
числительные машины, комплексы, системы и сети», «Информационные
системы в бизнесе». Оно может быть также использовано студентами дру'
гих специальностей, изучающими операционные элементы и устройства
ЦВМ.
Методические указания подготовлены кафедрой информационно'сете'
вых технологий и рекомендованы к изданию редакционно'издательским
советом Санкт'Петербургского государственного университета аэрокосми'
ческого приборостроения.
Редактор В. А. Черникова
Верстальщик Т. М. Каргапольцева
Сдано в набор 18.12.06. Подписано к печати 19.12.06.
Формат 60х84 1/16. Бумага тип. № 1. Печать офсетная. Усл. печ. л. 1,33.
Уч.'изд. л. 0,94. Тираж 150 экз. Заказ № .
Редакционно'издательский центр ГУАП
190000, Санкт'Петербург, Б. Морская ул., 67
© ГУАП, 2006
2
1. ОСНОВНЫЕ СВЕДЕНИЯ О ПРОГРАММЕ
1.1. Пакет MicroCAP
MicroCAP'8 — это универсальный пакет программ схемотехни'
ческого анализа, предназначенный для решения широкого круга за'
дач. Характерной особенностью этого пакета является наличие удоб'
ного и дружественного графического интерфейса, что делает его осо'
бенно привлекательным для непрофессиональной студенческой ауди'
тории. Несмотря на достаточно скромные требования к программно'
аппаратным средствам ПК, его возможности достаточно велики.
С его помощью можно анализировать не только аналоговые, но и
цифровые устройства. Возможно также и смешанное моделирование
аналого'цифровых электронных устройств, в полной мере реализу'
емое опытным пользователем пакета, способным в нестандартной си'
туации создавать собственные макромодели, облегчающие имитаци'
онное моделирование без потери существенной информации о пове'
дении системы. Однако авторы пакета программ обоснованно утвер'
ждают, что для более полного представления об областях примене'
ния MicroCAP'8 необходима дополнительная справочная литерату'
ра [1, 3, 6, 8–15].
Следует отметить, что по возможностям схемотехнического моде'
лирования MicroCAP'8 приближается к интегрированным пакетам
DESIGNLAB, ORCAD, PCAD2002 — профессиональным средствам
анализа и проектирования электронных устройств, требующим боль'
ших компьютерных ресурсов и достаточно сложных в использова'
нии. Поэтому MicroCAP'8 является весьма привлекательным для
моделирования электронных устройств средней степени сложности.
В случае необходимости дополнительные (и более подробные) сведе'
ния могут быть получены из встроенной подсказки системы (вызы'
вается клавишей <F1> или через меню Помощь).
Для учебных целей в соответствии действующими ГОСТами и стан'
дартами авторами была выполнена русификация ряда схем, доста'
точных для выполнения лабораторных работ и курсового проекти'
рования.
3
1.2. Состав программного пакета МС8
1.2.1. Составляющие модуля МС8.exe
Система MicroCap'8 имеет в своем составе один исполнимый мо'
дуль MC8.exe. В рамках изучаемого предмета нами будут рассмотре'
ны следующие составляющие:
Default.SAN — текстовый файл, содержащий ограничения (по
минимуму и максимуму), принятые по умолчанию для параметров
математических моделей компонентов схем;
DEMO.MC8 — файл, в котором записаны демонстрационные при'
меры, помогающие начинающему пользователю (предполагается
лишь наличие у него знаний по основам электроники) освоить рабо'
ту в среде программы. Они вызываются через меню Помощь (3'я ниж'
няя группа подменю с именами демонстрационных файлов). Для пра'
вильной работы demo'примеров в подменю Файл/Путь для файлов
схем в DATA должен быть установлен путь ...\MC8\DATA. Остано'
вить работу demo'примера (для чтения поясняющих сообщений на
английском языке можно с помощью нажатия клавиши <PAUSE>),
возобновить воспроизведение — с помощью нажатия любой клави'
ши (удобно использовать повторное нажатие <PAUSE>). Рассмот'
рев подробно работу demo'примеров в замедленном режиме (исполь'
зуя клавишу <PAUSE>), начинающий пользователь может освоить
все особенности работы с системой;
HELP.MC8 — файл, используемый программой для выдачи сооб'
щений об ошибках;
MC8.CNT — содержание встроенной подсказки программы;
MC8.HLP — встроенная помощь для программы МС8;
AP.DAT — файл конфигурации программы МС8. Этот файл созда'
ется автоматически после первого запуска программы. В нем, в час'
тности, указываются значения модельных параметров компонентов,
принятые по умолчанию; текущие установки схемного редактора и
окон анализа; текущие установки глобальных параметров; полные
имена подкаталогов, аналогичных подкаталогам \LIBRARY и \DATA
и установленных с помощью подменю Файл/Путь;
MCAP.INC — глобальные установки пользователя, доступные для
всех схем;
STANDARD.CMP — стандартная библиотека компонентов, со'
держащаяся в программном пакете;
STANDARD.PKG — стандартная библиотека расположения вы'
водов компонентов (необходима для создания списков соединений
схем, передаваемых в программы разработки печатных плат);
4
STANDARD.SHP — стандартная библиотека условных графиче'
ских обозначений (УГО) символов компонентов;
TIP.MC8 — типовые сообщения и подсказки, выдаваемые про'
граммой при диалоге с пользователем.
1.2.2. Подкаталоги DATA и LIBRARY
В подкаталог МС8DАТА заносятся файлы схем и результатов мо'
делирования. По умолчанию приняты следующие соглашения о рас'
ширениях имен файлов (здесь перечислены только интересующие нас
расширения):
.CIR — файлы описания схем в формате MicroCap'8. Именно та'
кие файлы создаются пользователем при помощи графического ре'
дактора и загружаются из каталога ...MC8\DATA для различных
видов анализа;
.CIR_BAK — предыдущая версия схемного файла, остающаяся
на диске после сохранения текущего отредактированного файла опи'
сания схемы;
.СКТ — файлы описания схем и заданий на моделирование на язы'
ке SPICE.
В подкаталог MC81LIBRARY заносятся файлы библиотек мате'
матических моделей компонентов. По умолчанию принято следу'
ющее соглашение о расширениях имен файлов:
.CIR — макромодели электронных компонентов, оформленные в
виде подсхем;
.LBR — сокращенные бинарные файлы библиотек математиче'
ских моделей компонентов, созданных с помощью меню MODEL,
без сохранения экспериментальных данных; просматриваются и ре'
дактируются с помощью программы МС8;
.LIB — текстовые файлы библиотек математических моделей ком'
понентов в формате SPICE; просматриваются и редактируются про'
граммой МС8 и любым текстовым редактором;
.MAC — макромодели электронных компонентов, оформленные в
виде подсхем (аналогично .CIR);
.MDL — полные бинарные файлы библиотек математических мо'
делей компонентов, созданных с помощью меню MODEL с сохране'
нием экспериментальных данных;
.MOD — текстовые файлы математических моделей отдельных
компонентов в формате SPICE;
.USR — текстовые файлы дискретных отсчетов выборок сигна'
лов;
5
NOM_LIB.INX — индексный файл библиотек математических
моделей компонентов (создается программой);
NOM.LIB — перечень загружаемых библиотек математических мо'
делей компонентов (текстовый файл, по умолчанию создается при
инсталляции программы и редактируется пользователем).
1.3. Работа с программой
1.3.1. Основные способы общения с программой
MicroCAP'8 является программой с многооконным графическим
интерфейсом, позволяющим строить и редактировать схемы, модели
и изображения компонентов, а также представлять результаты рас'
четов в графическом виде. Для работы с этой программой удобно ис'
пользовать манипулятор мышь. При помощи мыши можно менять
расположение и размер окон, а также выбирать команды меню. Од'
новременно можно редактировать несколько схемных файлов, раз'
мещенных в разных окнах.
В интегрированном пакете МС8 используется стандартный много'
оконный интерфейс с ниспадающими и разворачивающимися меню
(рис. 1.1).
Первая строка — строка системного меню команд программы,
с нажатием которых появляются ниспадающие меню команд про'
граммы МС8.
Следующие строки — строки инструментов. В этих строках пред'
ставлены пиктограммы наиболее употребляемых команд. Интересу'
ющие нас пиктограммы будут рассмотрены ниже при использовании
соответствующих пунктов меню. Пиктограммы команд немедленно'
го действия остаются нажатыми непродолжительное время и затем
восстанавливают свое первоначальное положение. Пиктораммы ко'
манд, переключающие режимы, остаются в положении «Включено»
до выполнения следующей команды.
Две линейки прокрутки позволяют панорамировать окно схем или
текста по горизонтали или вертикали.
Внизу размещены закладки переключения окна схем и окна тек'
ста. Нажатие на закладку Text выводит в рабочее окно содержание
текстового окна, в котором можно размещать описание математи'
ческих моделей компонентов текущей схемы, директивы и другую
текстовую информацию, или содержание окна схем. Переключение
между текущим окном схемы и текстовым окном производится так'
же нажатием клавиш Ctrl + G.
6
Рис. 1.1. Окно программы
Нажатием на закладки Page 1, Page 2... открываются соответ'
ствующие страницы схемы. Новая страница схемы создается по ко'
манде всплывающей панели Add + Page, открываемой щелчком пра'
вой кнопки мыши, когда курсор находится на строке названия стра'
ницы.
Нажатием на закладку Модель открывается текстовая страница
схемы, в которой находятся модельные директивы, помещаемые туда
по команде меню Редактирование/Обновить модели.
При нажатии правой кнопки мыши в окне схем курсор приобрета'
ет форму руки, и его перемещение при нажатой кнопке позволяет
перемещать схему.
При работе с МС8 возможно использование выбора объекта (ком'
понента схемы, его позиционного обозначения, значения параметра,
электрической цепи, блока схемы или строки текста). Выбор отдель'
ного объекта выполняется щелчком мыши, выбор блока — заключе'
нием его в прямоугольную рамку (для этого нужно щелкнуть кноп'
кой мыши, поместив курсор в один из углов прямоугольной области,
и, не отпуская ее, растянуть рамку до необходимых размеров, после
7
чего отпустить кнопку). Выбранный объект изменяет цвет; его мож'
но перемещать с помощью мыши и редактировать.
Для ускорения работы с программой используется не только
мышь, но и клавиатура. Если команда меню имеет подчеркнутый
символ, то эта команда вызывается одновременным нажатием кла'
виш Alt + подчеркнутый символ. Например, меню Редактирование
открывается нажатием клавиш Alt + E.
Команды ниспадающего подменю, например Select All, вызыва'
ются нажатием подчеркнутого символа, в данном примере — симво'
ла А. Другой способ — нажатием клавиш ↑↓ выбрать нужную строку
и затем нажать Enter.
Многие команды, помимо пиктограмм, вызываются нажатием го(
рячих клавиш и комбинаций клавиш.
1.3.2. Основные команды меню
Остановимся подробнее на меню команд программы МС8. Здесь и
далее при описании пунктов ниспадающего меню в скобках указыва'
ются сочетание «горячих клавиш» и пиктограмма кнопки панели
инструментов (2 и 3 строки экрана, см. рис. 1.1), нажатием которых
производятся аналогичные действия. Ниже представлено описание
наиболее употребляемых команд в рамках дисциплины. Более под'
робную информацию можно найти в [1].
Начальное проектирование начинается с открытия меню ФАЙЛ
(рис. 1.2).
На рисунке также видны и значения горячих клавиш. Отдельные
пункты меню требуют пояснений.
Новый — создать новый схемный файл (либо в формате МС8 — в
виде схемы, либо в виде текстового файла формата SPICE), либо биб'
лиотечный файл, либо файл *.MDL модели для Model (рис. 1.3). Пос'
ледние два здесь не рассматриваются.
Открыть — открыть для редактирования или анализа схемный
файл. Команда вызывает диалоговое окно открытия файла,
с помощью которого можно открыть схемный файл (CIR, .MAC, .СКТ)
или библиотечный файл (.LIB, .LBR, .STM, .MDL, .RES, .CAP, .IND).
Перемещение — позволяет передать файлы компонентов из более
ранней версии программы MicroCAP. После того как будет указано
расположение файла MCAP.DAT более старой версии программы,
МС8 прочитает его и сформирует список файлов, которые могут быть
импортированы (*.cmp, *.shp, *.pkg).
8
Рис. 1.2. Меню ФАЙЛ
Рис. 1.3. Меню начала проек(
тирования
Преобразование — изменение форматов схемных файлов (тексто'
вого формата SPICE в графический формат MicroCAP и наоборот,
схемного МС8 в схемный более ранних версий MicroCAP
и др.).
9
10
Рис. 1.4. Меню выбора компонентов
1.3.3. Меню Компоненты
Меню Компоненты содержит иерархический каталог библиотек
аналоговых и цифровых компонентов. Оно имеет систему разворачи'
вающихся иерархических меню, открывающихся при наведении на
них курсора. В основном названия компонентов понятны из англий'
ского названия, однако в программный пакет дополнительно вклю'
чены представления компонентов и в русской транскрипции в соот'
ветствии действующими ГОСТами и стандартами для лучшей ориен'
тации на этапе обучения. На рис. 1.4 показан пример выбора компо'
нентов для построения схемы.
Как видно из рисунка, для удобства выбираемые компоненты ото'
бражаются в левом нижнем углу. В дальнейшем из набора компо'
нентов можно приступить к их рациональному размещению на поле
рабочего стола, соединением входов'выходов, заданием начальных
условий и последующим анализом результатов.
На рис. 1.5 показана процедура начала анализа цифровой схемы.
Рис. 1.5. Выбор исследования переходных процессов
При выборе Исследование переходных процессов рабочий стол
делится на две части. На одной части будет представлена исследуе'
мая схема, можно наблюдать временные процессы в различных уз'
лах схемы и таким образом проверять правильность решений.
Более подробно процесс анализа будет показан на примере постро'
ения макроса.
11
12
Рис. 1.6. Работа D(триггера
2. НЕКОТОРЫЕ ОСОБЕННОСТИ
ИМИТАЦИОННОГО МОДЕЛИРОВАНИЯ
На первом этапе знакомства и использования программного па'
кета MicroCAP'8 необходимо помнить, что элементная составля'
ющая пакета — это набор программ, в алгоритмы которых заложены
электрофизические свойства реальных приборов. Известные в вы'
числительной технике явления гонок, правильное задание частот'
ных и временных свойств входных сигналов, синхронизация процес'
сов на всех этапах их обработки, задание начальных условий в про'
цессе моделирования в ряде случаев не учитывается, что приводит,
на первый взгляд, к неработоспособности простых устройств. Рас'
смотрим примеры наиболее часто встречающихся ошибок. На рис. 1.6
показаны варианты правильного и неправильного задания началь'
ной установки D'триггера и временные диаграммы. Для верхнего
триггера неопределены начальные установки, нижний триггер был
установлен в «0» и работает нормально. При использовании тригге'
ров следует обращать внимание на синхровход, а именно, по какому
фронту (срезу) — переднему или заднему — происходит прием инфор'
мации. В нашем примере триггер работает по переднему фронту.
Гонки или ложные сигналы устраняются временной разностью
подхода сигналов с помощью включения и подбора элемента задерж'
ки в цепь с меньшим временем хода.
2.1. Применение макроопределений (макросов) при моделирова'
нии устройств и построении принципиальных схем
В процессе выполнения задания в ряде случаев отдельные элемен'
ты могут отсутствовать в библиотеке компонентов. В этом случае
необходимо строить макросы, представляющие собой компиляцию
однородных или разнородных элементов, объединенных в отдель'
ную схему, которой присваивается определенное название. Это так'
же удобно применять для объединения блоков схемы одинакового
функционального назначения с целью упрощения самой принципи'
альной схемы.
Рассмотрим процедуру составления макроса на примере 4'разряд'
ного трехстабильного буферного элемента, широко используемого
для подключения к общей магистрали.
Входы: макрос имеет 4 информационных входа, один управля'
ющий вход OE и 4 информационных выхода. Принцип работы: при
подаче на вход OE сигнала низкого уровня происходит соединение
13
информационных входов и выходов. Если на ОЕ подать высокий
уровень, элемент переходит в третье состояние (состояние высокого
сопротивления).
Для создания макроса открываем меню Файл, выбираем пункт
Новый, выбираем Схема, нажимаем кнопку OK. Появляется пустое
окно, в котором нужно нарисовать схему (см. рис. 1.2 и 1.3). Захо'
дим в меню Компоненты, выбираем пункт Russian Digital, выбираем
пункт Буферные элементы, выбираем K555LP8 (см. рис. 1.4). Раз'
множаем выбранный элемент и располагаем 4 полученных элемента
вертикально. Объединяем входы OE всех элементов на один вывод.
Этот вывод называем OE, нажав на иконку с буквой T. На каждом
информационном входе всех элементов создаем (рисуем) выводы,
каждый из которых помечаем соответственно D0, D1, D2, D3, а вы'
ходы Y0, Y1, Y2, Y3 (рис. 2.1). Сохраняем схему под именем buff_4
с расширением mac.
Рис. 2.1. Начальный вид макроса
14
Для разработанного макроса необходимо создать (нарисовать) его
условное обозначение в соответствии с действующими ГОСТами и
стандартами. В меню Окна выбираем пункт Редактор графики ком(
понента, далее справа в дереве нажимаем кнопку Добавить, вводим
имя buff_4, рисуем фигуру, соответствующую элементу «БУФЕР'
НЫЙ ЭЛЕМЕНТ на 4 входа и 4 выхода», затем нажимаем кнопку
Закрыть, подтверждая сохранение изменений (рис. 2.2).
Вторично выбираем меню Окна, выбираем пункт Редактор ком(
понентов. Нажимаем Add component. В поле Name записываем
buff_4. В поле Форма выбираем buff_4. В поле Определение выбира'
Рис. 2.2. Окно составления макроса и выводов
15
ем Macro. Устанавливаем галочки в полях в соответствии с рис. 2.3.
В окне с изображением схемы наводим курсор на каждую ножку и
вводим ее название в соответствии с названиями на схеме. Нажима'
ем кнопку Закрыть, подтверждая сохранение изменений (рис. 2.3).
Рис. 2.3. Окно обозначения выводов буфера
16
17
Рис. 2.4. Пример анализа построенного макроса
На этом заканчивается процесс создания макроса. Следует отме'
тить, что созданные макросы могут выступать как подмакросы при
построении макросов более высокого уровня.
На рис. 2.4 показан пример анализа построенного макроса. Для
условия выхода буфера из третьего состояния на вход ОЕ подан низ'
кий потенциал. На входы буфера подключены выходы генератора
импульсов. Временная диаграмма демонстрирует функционирование
буфера. Здесь по вертикальным пунктирным линиям наблюдается
задержка между входными и выходными сигналами.
2.2. Применение генераторов сигналов
в задачах моделирования цифровых схем
Генераторы сигналов в схемах используются для синхронного взаи'
модействия элементов схемы, создания информационных сигналов
и для их стробирования. При моделировании необходимо определить
предельно допустимые параметры генераторов, при которых схема
работает устойчиво. К таким параметрам относятся период следова'
ния сигналов (частота) и длительность сигналов. Ниже приводятся
варианты настройки параметров генераторов.
Следующие строки допустимы в описании поля COMMAND гене'
раторов:
COMMAND= 0 0 LABEL=START +50n 1 +50n 0 +50n
GOTO START –1 TIMES
COMMAND= 0 0 LABEL=START 50n 1 100n 0 150n
GOTO START –1 TIMES
COMMAND= 0 0 LABEL=START +5c 1 +5c 0 +5c
GOTO START –1 TIMES
COMMAND= 0 0 REPEAT FOREVER 50n 1 100n 0 150n
ENDREPEAT
LABEL=START — установка точки возврата
GOTO START N TIMES — переход на ранее заявленную точку воз'
врата N раз (при N=–1 бесконечное число раз)
REPEAT <условие> ... ENDREPEAT — цикл по условию
(FOREVER — всегда).
Все они генерируют следующую последовательность во времени:
T
D(IN)
0
0
50n
1
18
100n
150n
200n
250n
300n
350n
... ...
0
1
0
1
0
1
Допустима запись вида:
.define IN
+ 0ns 0
+ LABEL=START
+ +50n 1
+ +50n 0
+ +50n GOTO START '1 TIMES
Данная запись производится на закладке Text рабочего файла,
при этом в поле COMMAND генератора записывается IN (см. выше).
*******************************************************************
COMMAND= 0 0 LABEL=START +25n INCR BY 1 50n
GOTO START UNTIL GT B +100ns F
FORMAT = 4
INCR BY 1 — увеличить на 1.
GOTO START UNTIL GT B — выполнять, пока значение меньше
или равно B (1011).
+100ns F — через 100ns выдать значение F (1111).
T
0
25n
50n
75n
100n
125n
150n
175n
200n
225n
250n
D(4,3,2,1)
0000
0001 цикл увеличения значения числа на 1 каждые 25ns
0010
0011
0100
0101
0110
0111
1000
1001
1010
19
275n
300n
425n
1011
1100
1111
появилось значение, большее числа B(1011).
на 325ns цикл заканчивается и через 100ns.
(425ns) появляется значение F (1111).
*******************************************************************
COMMAND= LABEL=START 5ns RND 10ns GOTO START –1 TIMES
Данная команда генерирует каждые 5ns случайное значение на
выходе генератора (RND)
*******************************************************************
COMMAND= 0ns ??A10 100ns ??4FR 200ns ??801 300ns ??BXZ
400ns 00000
T
D(IN8,IN7,IN6,IN5,IN4,IN3,IN2,IN1)
0
??101010 ;IN8, IN7 случайны (0 или 1)
100n ??0100FR ;IN8, IN7 случайны (0 или 1), IN2 — значение
Fall,
;IN1 – значение Rise
200n ??100001 ;IN8, IN7 случайны (0 или 1)
300n ??1011XZ ;IN8, IN7 случайны (0 или 1), IN2 неизвестно,
;IN1 – high impedance
400n 00000000 ;Все выводы установлены в 0.
20
БИБЛИОГРАФИЧЕСКИЙ СПИСОК
11. Цифровые интегральные микросхемы: справочник / М. И. Богдано'
вич и др. Минск: Беларусь, Полымя. 1996. 605 с.
12. Пухальский Г. И. Новосельцева Т. Я. Цифровые устройства: учеб.
пособие для втузов. СПб.: Политехника, 1996. 885 с.
13. Шило В. Л. Популярные цифровые микросхемы: справочник. М.:
Радио и связь, 1988. 352 с.
14. Разевиг В. Д. Система схемотехнического моделирования. М.: Го'
рячая линия'Телеком. 2001. 344 с.
15. Завадский В. А. Компьютерная электроника. Киев: ВЕК, 1996. 368 с.
16. Новиков Ю. В. Основы цифровой схемотехники. М.: Мир, 2001. 379 с.
17. Амелина М. А. Компьютерный анализ и синтез электронных уст'
ройств: конспект лекций: электрон. вариант. Смоленск: Филиал Москов'
ского энергетического института (Технический университет), 2006. 135 с.
18. ГОСТ 7.32–91. Отчет о научно'исследовательской работе. Структу'
ра и правила оформления. М.: Изд'во стандартов, 1991. 18 с.
19. ГОСТ 2.105–95. Единая система конструкторской документации.
Общие требования к текстовым документам. М.: Изд'во стандартов, 1995.
36 с.
10. ГОСТ 2.301–68. Единая система конструкторской документации.
Форматы. М.: Изд'во стандартов, 1968. 2 с.
11. ГОСТ 2.321–84. Единая система конструкторской документации.
Обозначения буквенные. М.: Изд'во стандартов, 1984. 2 с.
12. ГОСТ 2.109–73. Единая система конструкторской документации.
Основные требования к чертежам. М.: Изд'во стандартов, 1973. 43 с.
13. ГОСТ 2.701–84. Единая система конструкторской документации.
Схемы. Виды и типы. Общие требования к выполнению. М.: Изд'во стан'
дартов, 1984. 16 с.
14. ГОСТ 24460'80. Микросхемы интегральные цифровых устройств.
Основные параметры. М.: Изд'во стандартов, 1980. 3 с.
15. ГОСТ 2.743'91. Единая система конструкторской документации.
Обозначения условные графические в схемах. Элементы цифровой техни'
ки. М.: Изд'во стандартов, 1991. 62 с.
16. Гуртовцев А. Л., Гудыменко А. В. Программы для микропроцессо'
ров: справ. пособие. Минск: Высшая школа, 1989. 352 с.
17. Балашов Е. П, Пузанков Д. В. Микропроцессоры и микропроцес'
сорные системы. М.: Радио и связь, 1981. 328 с.
18. Злобин В. К., Григорьев В. А. Программирование арифметических
операций в микропроцессорах: учеб.пособие для вузов. М.: Высшая шко'
ла, 1991. 302 с.
21
19. Каган Б. М. Электронные вычислительные машины и сиcтемы:
учеб. пособие для вузов. 3'е изд., перераб. и доп. М.: Энергоатомиздат,
1991. 592 с.
20. Янсен Й. Курс цифровой электроники. М.: Мир, 1987. 825 с.
21. Лысиков Б. Г. Арифметические и логические основы цифровых
автоматов. М.: Высшая школа, 1980. 336 с.
22. Схемотехника ЭВМ: метод. указ. к выполнению курсового проекта.
СПб.: ГУАП, 2002. 42 с.
22
СОДЕРЖАНИЕ
1. Основные сведения о программе . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.1. Пакет MicroCAP . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.2. Состав программного пакета МС8 . . . . . . . . . . . . . . . . . . . . . . .
1.2.1. Составление модуля МС8.exe . . . . . . . . . . . . . . . . . . . . . .
1.2.2. Подкаталоги DATA и LIBRARY . . . . . . . . . . . . . . . . . . . .
1.3. Работа с программой . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.3.1. Основные способы общения с программой . . . . . . . . . . .
1.3.2. Основные команды меню . . . . . . . . . . . . . . . . . . . . . . . . .
1.3.3. Меню Компоненты . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
2. Некоторые особенности имитационного моделирования . . . . . . . .
2.1. Применение макроопределений (макросов) при моделирова'
нии устройств и построении принципиальных схем . . . . . . . . . . .
2.2. Применение генераторов сигналов в задачах моделирования
цифровых схем . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Библиографический список . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
3
3
4
4
5
6
6
8
11
12
12
18
21
23
Документ
Категория
Без категории
Просмотров
0
Размер файла
434 Кб
Теги
markovcki
1/--страниц
Пожаловаться на содержимое документа