close

Вход

Забыли?

вход по аккаунту

?

Nikiforov Paroli sktyt

код для вставкиСкачать
С. Н. НИКИФОРОВ,
М. М. РОМАДАНОВА
ЗАЩИТА ИНФОРМАЦИИ
Пароли, скрытие, удаление данных
Министерство образования и науки
Российской Федерации
Санкт-Петербургский государственный
архитектурно-строительный университет
С. Н. НИКИФОРОВ, М. М. РОМАДАНОВА
ЗАЩИТА ИНФОРМАЦИИ
Пароли, скрытие, удаление данных
Учебное пособие
Санкт-Петербург
2017
УДК 681.3.06
Рецензенты: д-р физ.-мат. наук, профессор Б. Г. Вагер (СПбГАСУ);
д-р физ.-мат. наук, профессор Е. Л. Генихович (Главная геофизическая обсерватория им. А. И. Воейкова)
Никифоров, С. Н.
Защита информации. Пароли, скрытие, удаление данных: учеб. пособие / С. Н. Никифоров, М. М. Ромаданова; СПбГАСУ. – СПб., 2017. –
108 с.
ISBN 978-5-9227-0783-1
Предназначено для всех пользователей, стремящихся обеспечить защиту своей информации: рассматриваются вопросы генерирования, установки и хранения паролей, качественного удаления данных, скрытия различных объектов и следов работы с файлами.
Ил. 181. Библиогр.: 11 назв.
Рекомендовано Учебно-методическим советом СПбГАСУ в качестве
учебного пособия.
1. ЗАЩИТА КОМПЬЮТЕРА
ПАРОЛЕМ ВКЛЮЧЕНИЯ
Данная система защиты требует ввода пароля сразу же после
включения компьютера. После ее установки компьютер не будет загружать операционную систему (как DOS, так и Windows), пока не
будет введен корректный пароль.
Детали процесса установки пароля включения изменяются от
компьютера к компьютеру, однако первый шаг – это обращение
к системным установкам CMOS1, хранящим важную информацию
о параметрах операционной системы компьютера (дате, времени,
типах дисководов и пр.) в специальной микросхеме, работающей
от небольшой батарейки. Компьютер считывает эти данные всякий
раз, когда включается электропитание.
Как правило, обращение к CMOS производится при запуске
компьютера нажатием клавиши F2 либо другой назначенной клавиши (сообщение, какую именно клавишу следует нажать, появляется при включении компьютера). Назначенная клавиша и порядок
установки пароля зависят от BIOS2.
1.1. Установка пароля
Первый способ
1. Нажать клавишу F2 (успеть, пока не начался вход в систему):
появится BIOS SETUP UTILITY.
ISBN 978-5-9227-0783-1
© С. Н. Никифоров, М. М. Ромаданова, 2017
© Санкт-Петербургский государственный
архитектурно-строительный университет, 2017
1
CMOS (от англ. complementary metal-oxide-semiconductor – комплементарная структура металл-оксид-полупроводник) — набор полупроводниковых технологий построения
ин-тегральных микросхем, а также соответствующая схемотехника.
2
BIOS (от англ. basic input/output system — базовая система ввода-вывода) – системное программное обеспечение.
3
1. Шифрование данных
1.2. Изменение и снятие пароля
2. Выбрать Security → Change User Password и нажать Enter:
появится окно с предложением Enter New Password.
3. Ввести пароль (допустим, lena), который отобразится как
****, и нажать Enter: появится окно с предложением Confirm New
Password.
4. Подтвердить пароль lena, который снова отобразится как
****, и нажать Enter.
5. Выбрать Password check [Setup] и нажать Enter: появится
окно с вариантами Options – setup и always.
6. Выбрать always и нажать Enter.
7. Нажать F10 (Save and Exit): появится окно с вопросом Save
configuration Change and exit setup?
8. Выбрать OK и нажать Enter.
Второй способ
1. Нажать клавишу Del (успеть, пока не начался вход в систему): появится BIOS SETUP UTILITY.
2. Выбрать BOOT → Security и нажать Enter.
3. Выбрать Change User Password и нажать Enter: появится
окно с предложением Enter Password.
4. Ввести пароль (допустим, lena), который отобразится как ****,
и нажать Enter: появится окно с предложением Confirm Password.
5. Подтвердить пароль lena, который отобразится как ****,
и нажать Enter: появится окно с сообщением Password Installed –
OK. Снова нажать Enter.
6. Выбрать Password check [Setup] и нажать Enter: появится
окно с вариантами Options – setup и always.
7. Выбрать always и нажать Enter.
8. Нажать F10 (Save and Exit): появится окно с вопросом Save
configuration Change and exit setup?
9. Выбрать OK и нажать Enter.
В результате этих действий появится окно с предложением Enter Password и уже в этом первом сеансе для продолжения работы
на компьютере необходимо будет ввести выбранный пароль.
В дальнейшем при каждом включении компьютера будет появляться сообщение Enter Password, на которое следует отвечать
паролем lena (он будет отображаться как символы ****) и нажатием клавиши Enter, – только после этого будет осуществляться вход
в систему.
Снятие/изменение пароля, установленного первым способом
1. После включения электропитания нажать клавишу F2: появится сообщение Enter Password.
2. Ввести известный пароль (в данном случае – lena): появится
BIOS SETUP UTILITY.
3. Выбрать Security → Change User Password: появится окно
с предложением Enter New Password.
4. Ничего не вводить и нажать Enter: появится окно с сообщением Password uninstalled.
5. Выбрать ОК и нажать Enter.
6. Нажать F10 (Save and Exit): появится окно с вопросом Save
configuration Change and exit setup?
7. Выбрать OK и нажать Enter.
Теперь вход в систему будет выполняться без запроса пароля.
Замечание
Для изменения пароля следует в п. 4 в окно Enter New Password
ввести новый пароль.
Снятие/изменение пароля, установленного вторым способом
1. После включения электропитания нажать клавишу Del: появится сообщение Enter CURRENT Password.
2. Ввести известный пароль (в данном случае – lena): появится
BIOS SETUP UTILITY.
3. Выбрать BOOT → Security и нажать Enter.
4. Выбрать Clear User Password и нажать Enter: появится окно
с вопросом Clear User Password?
5. Выбрать ОК и нажать Enter.
6. Нажать F10 (Save and Exit): появится окно с вопросом Save
configuration Change and exit setup?
7. Выбрать OK и нажать Enter.
4
5
1.2. Изменение и снятие пароля
1. Шифрование данных
Теперь вход в систему будет выполняться без запроса пароля.
Замечание
Для изменения пароля следует в п. 4 выбрать Change User
Password и ввести новый пароль.
2. СОЗДАНИЕ НАДЕЖНЫХ ПАРОЛЕЙ
Для повышения уровня компьютерной безопасности следует использовать надежные пароли. Крайне важно применять надежные
пароли как для всех учетных записей компьютера при входе в локальную сеть, так и для учетной записи администратора на каждом
компьютере.
Надежный пароль должен отвечать следующим требованиям:
• содержать не менее 8 знаков (наиболее надежные пароли состоят из 8 или 14 знаков, причиной этого является способ кодировки);
• одновременно включать знаки трех групп:
Буквы латинского алфавита
(прописные и строчные)
Цифры
Символы (все знаки, не являющиеся буквами или цифрами)
A, B, C... (a, b, c...)
0, 1, 2, 3, 4, 5, 6, 7, 8, 9
~!@#$%^&*()_+-={}|[]
\ : « ; ‘ < > ? , . / и т. д.
• содержать не менее 1 символа в позициях со второй по шестую;
• значительно отличаться от паролей, применявшихся пользователем ранее;
• не состоять из фамилии или имени пользователя;
• не являться распространенным словом или именем.
Пароли могут стать самым слабым звеном в системе безопасности компьютера. Необходимость использования надежных паролей
обусловлена постоянным совершенствованием средств для их расшифровки. Так, сетевой пароль, для взлома которого раньше потребовались бы недели, теперь может быть раскрыт за несколько часов.
Для взлома паролей применяются следующие программные методы: интеллектуальный взлом, словарные атаки, система
6
7
2. Создание надежных паролей
2.2. Хранение паролей: программа KeePass Password Safe
автоматического подбора всех возможных комбинаций знаков и др.
Имея достаточно времени, можно взломать любой пароль методом
автоматического перебора. Однако для взлома надежного пароля
по-прежнему требуются месяцы.
Пароли Windows могут содержать до 127 символов, но если компьютеры с Windows XP используются в сети, где имеются машины
с Windows 95 или Windows 98, не следует назначать учетным записям пароли длиной свыше 14 символов. Дело в том, что Windows 95
и Windows 98 поддерживают пароли длиной до 14 знаков, и если
пароль пользователя длиннее, ему не удастся войти в сеть с этих
компьютеров.
2.1. Генерирование паролей
Примером онлайн-генератора паролей является сайт www.genpas.narod.ru.
Если в окне Создание своего пароля (рис. 2.1) установить, например, Заглавные буквы, Маленькие буквы, Цифры, Знаки,
Длина пароля – 14, Количество паролей – 10, а затем нажать
кнопку Создать пароль!, то в окне Результат (рис. 2.2) можно увидеть сгенерированные для вас пароли.
Рис. 2.2
Подбор созданных паролей полным перебором (методом «грубой
силы», англ. – brute force) займет так много времени, что может потерять актуальность, особенно если периодически, например раз в три
месяца, менять пароль.
Недостаток один – эти пароли очень трудно запомнить.
2.2. Хранение паролей: программа
KeePass Password Safe
Утилита для хранения паролей KeePass Password Safe распространяется бесплатно. Кроме того, программа имеет portable-версию, позволяющую запускать ее с флеш-накопителя.
2.2.1. Установка программы
KeePass Password Safe
Рис. 2.1
8
Для установки программы нужно обратиться по адресу http://
keepass.info/download.html и выполнить следующие действия:
• в появившемся окне Getting KeePass – Downloads щелкнуть
по разделу, например, KeePass 1.24 (Inststaller EXE for Windows)
(рис. 2.3);
9
2. Создание надежных паролей
2.2. Хранение паролей: программа KeePass Password Safe
Рис. 2.3
• в появившемся окне Загрузка файла – предупреждение системы безопасности нажать на кнопку Сохранить (рис. 2.4);
Рис. 2.5
• в появившемся окне Загрузка завершена нажать на кнопку Запустить (рис. 2.6);
Рис. 2.4
Рис. 2.6
• в появившемся окне Сохранить как подтвердить имя и место
сохранения файла (в данном случае – Мои документы), нажав на
кнопку Сохранить (рис. 2.5);
• в появившемся окне Internet Explorer – Предупреждение системы безопасности нажать на кнопку Выполнить (рис. 2.7);
10
11
2. Создание надежных паролей
2.2. Хранение паролей: программа KeePass Password Safe
• в измененном окне Установка – KeePass Password Safe выбрать Я принимаю условия соглашения и нажать на кнопку Далее
(рис. 2.10);
Рис. 2.7
• в появившемся окне Выберите язык установки выбрать Русский и нажать на кнопку ОК (рис. 2.8);
Рис. 2.10
Рис. 2.8
• в появившемся окне Установка – KeePass Password Safe нажать на кнопку Далее (рис. 2.9);
• в измененном окне Установка – KeePass Password Safe выбрать
место установки программы (или подтвердить предлагаемое по умолчанию) и нажать на кнопку Далее (рис. 2.11);
Рис. 2.9
Рис. 2.11
12
13
2. Создание надежных паролей
2.2. Хранение паролей: программа KeePass Password Safe
• в измененном окне Установка – KeePass Password Safe установить флажки Создать значок на Рабочем столе и Создать значок
в Панели быстрого запуска и нажать на кнопку Далее (рис. 2.12);
• в измененном окне Установка – KeePass Password Safe нажать
на кнопку Завершить (рис. 2.14).
Рис. 2.12
• в измененном окне Установка – KeePass Password Safe нажать
на кнопку Установить (рис. 2.13);
Рис. 2.14
После установки программы на Рабочем столе появится значок
KeePass (рис. 2.15).
Рис. 2.15
Рис. 2.13
14
На этом процесс установки можно закончить, но при желании
можно установить и русифицированную версию программы. Для
этого необходимо:
• в окне, изображенном на рис. 2.3, нажать на кнопку Translations (рис. 2.16);
15
2. Создание надежных паролей
2.2. Хранение паролей: программа KeePass Password Safe
• в появившемся окне Загрузка файла нажать на кнопку Сохранить (рис. 2.18);
Рис. 2.16
Рис. 2.18
• в появившемся окне выбрать раздел Russian и нажать на пиктограмму [1.x] (рис. 2.17);
• в появившемся окне Сохранить как подтвердить имя и место
сохранения файла (в данном случае – Мои документы), нажав на
кнопку Сохранить (рис. 2.19);
Рис. 2.17
Рис. 2.19
16
17
2. Создание надежных паролей
• в появившемся окне Загрузка завершена нажать на кнопку Открыть папку (рис. 2.20);
2.2. Хранение паролей: программа KeePass Password Safe
• в появившемся окне Russian-1.24 найти файл Russian (рис. 2.22);
Рис. 2.22
• перенести
(рис. 2.23);
файл
Russian
в папку
Рис. 2.20
• в появившемся окне (в данном случае – Мои документы) найти
папку Russian-1.24 (рис. 2.21) и распаковать, дважды щелкнув по ней
левой клавишей мыши;
Рис. 2.23
• открыть папку KeePassX (рис. 2.24);
Рис. 2.21
Рис. 2.24
18
19
KeePassX-0.4.3-win32
2. Создание надежных паролей
2.2. Хранение паролей: программа KeePass Password Safe
• создать ярлык для файла KeePassX (рис. 2.25).
Рис. 2.27
Рис. 2.25
В результате на Рабочем столе появится Ярлык для KeePassX
(рис. 2.26).
Рис. 2.28
Для работы с русифицированной программой необходимо:
• щелкнуть по пиктограмме Создать базу паролей (рис. 2.29);
Рис. 2.26
2.2.2. Использование программы KeePass Password Safe
Для запуска программы нужно дважды щелкнуть по пиктограмме, изображенной на рис. 2.15, после чего появится окно KeePass
Password Safe (рис. 2.27).
Если дважды щелкнуть по значку, изображенному на рис. 2.26,
то появится окно KeePassX – Password Manager (рис. 2.28) русифицированной версии, которую мы и будем рассматривать далее.
20
Рис. 2.29
• в появившемся окне New Database ввести главный пароль или
файл-ключ и нажать ОК (рис. 2.30);
21
2. Создание надежных паролей
2.2. Хранение паролей: программа KeePass Password Safe
• в появившемся окне Мой почтовый ящик / Новая запись заполнить нужные поля и нажать ОК (пароль можно ввести с клавиатуры, а можно сгенерировать, нажав кнопку Генерация) (рис. 2.33);
Рис. 2.30
• в измененном окне New Database повторно ввести главный пароль и нажать ОК (рис. 2.31);
Рис. 2.31
• в появившемся окне [новый]* - KeePassX щелкнуть по пиктограмме Добавить новую запись (например, пароль от электронной
почты) (рис. 2.32);
Рис. 2.33
• в появившемся измененном окне [новый]* - KeePassX ознакомиться с информацией о параметрах созданной записи (рис. 2.34);
Рис. 2.32
Рис. 2.34
22
23
2. Создание надежных паролей
2.2. Хранение паролей: программа KeePass Password Safe
• дважды щелкнуть левой клавишей мыши по пиктограмме Сохранить базу паролей (рис. 2.35);
Рис. 2.37
Для использования пароль необходимо выделить, затем дважды
щелкнуть левой клавишей мыши по пиктограмме Скопировать пароль в буфер обмена (рис. 2.38), после чего выполнить вставку пароля в нужное окно.
Рис. 2.35
• в появившемся окне Сохранить базу паролей... выбрать место
сохранения файла и нажать на кнопку Сохранить (рис. 2.36);
Рис. 2.38
Рис. 2.36
• в измененном окне Сохранить базу паролей... нажать на кнопку Да (рис. 2.37), а затем закрыть программу.
24
25
3.1. Создание учетной записи
3. УЧЕТНЫЕ ЗАПИСИ
ПОЛЬЗОВАТЕЛЕЙ
Учетная запись пользователя – это совокупность его идентификатора (логина) и пароля.
3.1. Создание учетной записи
Для создания учетной записи необходимо выполнить следующие действия:
• нажать на кнопку Пуск и в появившемся меню выбрать Настройка → Панель управления (рис. 3.1);
Рис. 3.2
Рис. 3.1
• в окне Панель управления выбрать раздел Учетные записи
пользователей (рис. 3.2);
• в окне Учетные записи пользователей выбрать раздел Создание учетной записи (рис. 3.3);
26
Рис. 3.3
• в измененном окне Учетные записи пользователей задать
имя новой учетной записи, например Дед, и нажать на кнопку Далее
(рис. 3.4);
27
3. Учетные записи пользователей
3.2. Защита учетной записи паролем
Рис. 3.6
Рис 3.4
• в измененном окне Учетные записи пользователей выбрать
тип записи, например Администратор компьютера, и нажать на
кнопку Создать учетную запись (рис. 3.5);
3.2. Защита учетной записи паролем
Для установки пароля на учетную запись необходимо выполнить следующие действия:
• в окне Учетные записи пользователей (см. рис. 3.6) выбрать
изменяемую учетную запись (в данном случае – Дед) и щелкнуть
по ней левой клавишей мыши;
• в измененном окне Учетные записи пользователей выбрать
Создание пароля (рис. 3.7);
• в измененном окне Учетные записи пользователей ввести
пароль (например, Старый), который отобразится как ••••••, затем
снова ввести его для подтверждения и, наконец, ввести подсказку
о пароле (например, слово Я), после чего нажать на кнопку Создать пароль (рис. 3.8);
Рис. 3.5
• убедиться в появлении новой учетной записи в окне Учетные
записи пользователей (рис. 3.6).
Если на этом завершить процесс создания учетной записи, то
она получит статус общего доступа, т. е. открыть ее и работать
в ней сможет любой пользователь. Чтобы закрыть общий доступ
к учетной записи, целесообразно защитить ее паролем.
Рис. 3.7
28
29
3. Учетные записи пользователей
3.3. Удаление учетной записи
3.3. Удаление учетной записи
Для удаления учетной записи необходимо:
• нажать на кнопку Пуск и выбрать в меню Настройка → Панель управления (см. рис. 3.1);
• в окне Панель управления выбрать раздел Учетные записи
пользователей (см. рис. 3.2);
• в окне Учетные записи пользователей (рис. 3.10) выбрать
изменяемую учетную запись, например Дед, и щелкнуть по ней левой клавишей мыши;
Рис. 3.8
• убедиться, что учетная запись Дед в окне Учетные записи пользователей приобрела атрибут Защита паролем (рис. 3.9).
Теперь для входа в учетную запись Дед необходимо будет вводить пароль Старый.
Рис. 3.10
• в измененном окне Учетные записи пользователей выбрать
Удаление учетной записи (рис. 3.11);
Рис. 3.9
Рис. 3.11
30
31
3. Учетные записи пользователей
3.3. Удаление учетной записи
• при желании перед удалением учетной записи сохранить все
принадлежавшие ей файлы в автоматически создаваемой папке, нажав
кнопку Сохранить эти файлы в измененном окне Учетные записи
пользователей (рис. 3.12);
Рис. 3.14
Рис. 3.12
• в измененном окне Учетные записи пользователей подтвердить удаление учетной записи, нажав на кнопку Удалить учетную
запись (рис. 3.13);
Замечания
Удалять учетные записи могут только пользователи с учетной
записью администратора компьютера. Однако даже администратор не может сам удалить свою учетную запись, для этого ему необходимо обратиться к другому администратору компьютера. При
отсутствии на локальном компьютере других учетных записей
администраторов, нужно изменить учетную запись какого-либо
пользователя на администратора и попросить его удалить соответствующую учетную запись.
Таким образом, на компьютере всегда существует по крайней
мере один пользователь с учетной записью администратора, который может управлять всеми учетными записями и вносить в компьютер изменения на уровне системы.
Рис. 3.13
• убедиться в отсутствии учетной записи в измененном окне
Учетные записи пользователей (рис. 3.14).
32
33
4.1. Защита папок
4. ЗАЩИТА ПАПОК И ФАЙЛОВ
В WINDOWS XP
4.1. Защита папок
Защита папок осуществляется посредством ограничения общего
доступа к ним. Чтобы сделать какую-либо папку доступной только вам, нужно одновременно отменить общий доступ к ней и защитить свою учетную запись паролем. Для этого необходимо:
• щелкнуть по выбранной папке правой клавишей мыши
и в появившемся меню выбрать Общий доступ и безопасность...
(рис. 4.1);
Рис. 4.2
• в появившемся окне Доступ на вопрос Хотите задать пароль
для вашей учетной записи? ответить Да (рис. 4.3);
Рис. 4.3
Рис. 4.1
• в появившемся окне Свойства на вкладке Доступ включить
флажок Отменить общий доступ к этой папке и нажать на кнопку
Применить (рис. 4.2);
• в появившемся окне Учетные записи пользователей ввести пароль (например, крякря), который отобразится как ••••••, затем снова
ввести его для подтверждения и, наконец, ввести подсказку (например, утка), после чего нажать на кнопку Создать пароль (рис. 4.4);
34
35
4. Защита папок и файлов в Windows XP
4.2. Защита файлов
• в измененном окне Учетные записи пользователей окно ввода
текущего пароля оставить пустым, ввести пароль крякря и подтвердить его, а затем ввести подсказку (рис. 4.6) и нажать на кнопку Изменить пароль.
Рис. 4.4
• в измененном окне Учетные записи пользователей выбрать
Изменение пароля (рис. 4.5);
Рис. 4.6
4.2. Защита файлов
4.2.1. Установка пароля
на открытие файла
Рис. 4.5
36
Для защиты паролем файлов MS Office 2003 необходимо:
• находясь в защищаемом файле, выбрать в верхнем горизонтальном меню Файл команду Сохранить как... (рис. 4.7);
• в появившемся окне Сохранение документа нажать на кнопку Сервис (рис. 4.8);
• в меню Сервис выбрать Параметры безопасности...
(рис. 4.9);
37
4. Защита папок и файлов в Windows XP
4.2. Защита файлов
Рис. 4.9
• в появившемся окне Безопасность ввести пароль для открытия файла (рис. 4.10) и нажать ОК.
Рис. 4.7
Рис. 4.8
Рис. 4.10
38
39
4. Защита папок и файлов в Windows XP
4.2. Защита файлов
Для установки пароля на открытие файла в MS Office 2010
требуется:
• находясь в нужном файле, выбрать в верхнем горизонтальном
меню Файл подменю Сведения → Защитить документ (рис. 4.11);
• в появившемся окне Шифрование документа ввести пароль
для открытия файла (например, 1234), который отобразится как ••••,
и нажать ОК (рис. 4.13);
Рис. 4.11
Рис. 4.13
• в подменю Защитить документ выбрать Зашифровать паролем (рис. 4.12);
• в появившемся окне Подтверждение пароля еще раз ввести тот же пароль, который снова отобразится как ••••, и нажать ОК
(рис. 4.14);
Рис. 4.12
Рис. 4.14
40
41
4. Защита папок и файлов в Windows XP
4.2. Защита файлов
• сохранить файл и закрыть.
Теперь при попытке открыть данный файл появится окно Пароль, где необходимо ввести установленный пароль, т. е. 1234, который отобразится как ••••, и нажать ОК (рис. 4.15), после чего
файл откроется и станет доступен для работы.
Рис. 4.16
Рис. 4.15
4.2.2. Снятие пароля
Для снятия пароля с файла MS Office 2003 необходимо:
• находясь в нужном файле, выбрать Файл → Сохранить как...;
• в появившемся окне Сохранение документа выбрать Сервис
→ Параметры безопасности...;
• в появившемся окне Безопасность в окне пароль для открытия файла ничего не вводить и нажать ОК;
• сохранить файл и закрыть.
Чтобы снять пароль с файла MS Office 2010, требуется:
• находясь в нужном файле, выбрать Файл → Сведения → Защитить документ → Зашифровать паролем;
• в появившееся окно Шифрование документа ничего не вводить и нажать ОК (рис. 4.16);
• сохранить файл и закрыть.
42
43
5.1. Защита листов MS Excel 2010
5. ЗАЩИТА ОБЪЕКТОВ
MS EXCEL 2010
В MS Excel 2010 предусмотрено несколько уровней защиты
данных:
• ограничение доступа к файлу (запрет на несанкционированное открытие и/или изменение);
• защита элементов книги (запрет на просмотр и/или изменение
отдельных листов);
• защита определенных элементов листа, например ячеек с формулами (частичный или полный запрет доступа).
Все уровни защиты являются не взаимоисключающими, а взаимодополняющими.
Рис. 5.1
5.1. Защита листов MS Excel 2010
5.1.1. Установка пароля
Для защиты паролем листа MS Excel 2010 необходимо выполнить следующие действия:
• находясь в нужном файле, выбрать ярлычок предназначенного
для защиты листа (в данном случае – Лист3) и щелкнуть по нему
правой клавишей мыши;
• в появившемся подменю выбрать Защитить лист...
(рис. 5.1);
• в появившемся окне Защита листа ввести пароль для отключения защиты листа, например 111, затем с помощью флажков указать, чтó разрешается всем пользователям этого листа, и нажать ОК
(рис. 5.2);
Рис. 5.2
• в появившемся окне Подтверждение пароля снова ввести выбранный пароль и нажать ОК (рис. 5.3).
Рис. 5.3
44
45
5. Защита объектов MS Excel 2010
5.2. Защита книги MS Excel 2010
Теперь данные выбранного листа защищены от несанкционированного изменения.
листами, под защитой окна – запрет на перемещение, изменение
размеров, скрытие, показ и закрытие окна.
5.1.2. Снятие пароля
5.2.1. Установка пароля
Для снятия пароля с листа MS Excel 2010 требуется:
• находясь в нужном файле, выбрать ярлычок листа, с которого
снимается пароль (в данном случае – Лист3), и щелкнуть по нему
правой клавишей мыши;
• в появившемся подменю выбрать Снять защиту листа... (рис. 5.4);
Для защиты паролем книги MS Excel 2010 необходимо:
• открыть нужную книгу, выбрать вкладку Рецензирование и в группе Изменения нажать на кнопку Защитить книгу
(рис. 5.6);
Рис. 5.4
• в появившемся окне Снять защиту листа ввести пароль для отключения защиты (в данном случае – 111) и нажать ОК (рис. 5.5).
Рис. 5.6
• в появившемся окне Защита структуры и окон установить
флажки для защиты структуры и окон книги, затем в поле Пароль
ввести пароль (например, 111) и нажать ОК (рис. 5.7);
Рис. 5.5
Теперь данные листа доступны для изменений.
5.2. Защита книги MS Excel 2010
От изменений можно защитить структуру и/или окно книги. Под
защитой структуры книги понимается запрещение действий с ее
46
Рис. 5.7
• в появившемся окне Подтверждение пароля ввести пароль еще
раз и снова нажать ОК (рис. 5.8).
47
5. Защита объектов MS Excel 2010
5.3. Пометка окончательной версии файла MS Excel 2010
Рис. 5.11
Рис. 5.8
Теперь при попытке выполнить с книгой недопустимое действие
появится соответствующее сообщение (рис. 5.9).
Рис. 5.9
5.2.2. Снятие пароля
5.3. Пометка окончательной версии файла MS Excel 2010
5.3.1. Установка пометки на файл
Прежде чем разрешить другим пользователям доступ к файлу,
можно воспользоваться командой Пометить как окончательный,
чтобы сделать файл доступным только для чтения и предотвратить
его изменение. В таком файле недоступны или отключены команды
ввода и редактирования, а также проверка правописания.
Для пометки версии книги как окончательной необходимо:
• открыть книгу и выбрать Файл → Сведения → Защитить
книгу → Пометить как окончательный (рис. 5.12);
Для снятия защиты с книги MS Excel 2010 необходимо:
• открыть книгу, выбрать вкладку Рецензирование и в группе
Изменения нажать на кнопку Защитить книгу (рис. 5.10);
Рис. 5.10
• в появившемся окне Снять защиту книги в поле Пароль ввести установленный пароль и нажать ОК (рис. 5.11).
Рис. 5.12
48
49
5. Защита объектов MS Excel 2010
• в появившемся окне Microsoft Excel подтвердить установку пометки, нажав на кнопку ОК (рис. 5.13);
6. ЗАЩИТА ОБЪЕКТОВ MS WORD 2010
Рис. 5.13
• в измененном окне Microsoft Excel снова нажать ОК (рис. 5.14).
Файлы MS Word 2010 можно защищать не только от несанкционированного открытия (см. раздел 4.2), но и от изменения другими пользователями.
6.1. Защита документа MS Word 2010
Рис. 5.14
Замечание
Команда Пометить как окончательный не является средством
обеспечения полной безопасности. Любой пользователь, получивший копию такого файла, может отредактировать его, отменив данную команду.
5.3.2. Работа с окончательной версией файла
При открытии файла, помеченного как окончательный, отображается панель сообщений с надписью Помечена как окончательная (рис. 5.15). Если в файл требуется внести изменения, нужно
нажать на кнопку Все равно редактировать, после чего с данным
документом можно будет выполнять любые действия.
Для защиты документа MS Word 2010 от несанкционированных
изменений необходимо:
• находясь в файле, предназначенном для полной или частичной
защиты от редактирования, выбрать Рецензирование → Ограничить редактирование (рис. 6.1);
Рис. 6.1
Рис. 5.15
• в появившемся подменю Ограничить форматирование и редактирование в разделе 2. Ограничения на редактирование включить флажок Разрешить только указанный способ редактирования
документа, а в полосе прокрутки выбрать Только чтение (рис. 6.2);
• затем в разделе 3. Включить защиту нажать на кнопку Да,
включить защиту (см. рис. 6.2);
• в появившемся окне Включить защиту выбрать способ
защиты Пароль, ввести в поле выбранный пароль (например,
222), который отобразится как ***, подтвердить его и нажать ОК
(рис. 6.3).
50
51
6. Защита объектов MS Word 2010
6.2. Частичное и полное снятие защиты
6.2. Частичное и полное снятие защиты
Для снятия защиты от редактирования с документа MS Word
2010 необходимо:
• открыть документ и выбрать Рецензирование → Ограничить редактирование → Ограничить форматирование и редактирование → Отключить защиту (рис. 6.4);
Рис. 6.2
Рис. 6.4
• в появившемся окне Снятие защиты ввести установленный пароль (в данном случае – 222), который отобразится как ***, и нажать
ОК (рис. 6.5).
Рис. 6.3
Теперь весь документ (или отдельные его фрагменты, если вы заполнили раздел Исключения (необязательно) меню, показанного на
рис. 6.2) защищен от несанкционированного изменения.
52
Рис. 6.5
53
6. Защита объектов MS Word 2010
Теперь документ доступен для редактирования.
Для снятия защиты от редактирования и форматирования
с документа MS Word 2010 требуется:
• снять защиту документа от редактирования, как описано
выше;
• затем в подменю Ограничить форматирование и редактирование в разделе 2. Ограничения на редактирование снять
флажок Разрешить только указанный способ редактирования
документа (рис. 6.6);
7. СКРЫТИЕ ОБЪЕКТОВ WINDOWS XP
7.1. Скрытие панели задач
Панель задач в Windows XP можно сделать невидимой для всех
практических применений, однако она будет показываться, если
курсор мыши пройдет над местом ее расположения.
Для скрытия панели задач необходимо:
• нажать на кнопку Пуск и выбрать в меню Настройка → Панель управления → Оформление и темы (рис. 7.1);
Рис. 6.6
• сохранить файл и закрыть.
Теперь в документ можно будет вносить любые изменения без
ввода пароля.
Рис. 7.1
• в появившемся окне Оформление и темы выбрать Панель
задач и меню «Пуск» (рис. 7.2);
54
55
7. Скрытие объектов Windows XP
7.2. Очистка корзины
• нажать кнопку Применить, а затем ОК;
• закрыть окно Оформление и темы.
7.2. Очистка корзины
В соответствии со стандартными установками Windows удаленные файлы фактически сохраняются в папке Корзина, откуда их
можно восстановить, чтобы просмотреть. По этой причине Корзину следует периодически очищать.
Для очистки Корзины необходимо:
• щелкнуть правой клавишей мыши по папке Корзина;
• в появившемся контекстном меню выбрать Очистить корзину (рис. 7.4).
Рис. 7.2
• в появившемся окне Свойства панели задач и меню «Пуск»
установить флажок Автоматически скрывать панель задач
(рис. 7.3);
Рис. 7.4
Помещение файлов в Корзину удобно для восстановления случайно удаленных документов. Если же вместо периодической очистки этой папки вы хотите сразу окончательно удалять файлы, настройки Корзины необходимо изменить:
• щелкнуть правой клавишей мыши по папке Корзина;
• в появившемся контекстном меню выбрать Свойства
(рис. 7.5);
Рис. 7.3
Рис. 7.5
56
57
7. Скрытие объектов Windows XP
7.3. Очистка и скрытие меню Документы
• в появившемся окне Свойства: Корзина выбрать Глобальные
и установить флажок Уничтожать файлы сразу после удаления, не
помещая их в корзину (рис. 7.6);
Рис. 7.7
Для очистки меню Документы в классическом меню «Пуск» необходимо:
• нажать на кнопку Пуск и выбрать Настройка → Панель задач и меню «Пуск” (рис. 7.8);
Рис. 7.6
• нажать на кнопку Применить, а затем ОК.
Теперь восстановить удаленные файлы будет невозможно.
7.3. Очистка и скрытие
меню Документы
При нажатии на кнопку Пуск в разделе меню Документы отображаются пиктограммы последних открывавшихся файлов, с помощью которых можно быстро попасть в любой из них (рис. 7.7).
С одной стороны, это удобно, но с другой – позволяет легко установить, с какими файлами вы работали в последнее время, что может
быть нежелательно.
58
Рис. 7.8
• в появившемся окне Свойства панели задач и меню «Пуск»
(рис. 7.9) выбрать вкладку Меню «Пуск»;
59
7. Скрытие объектов Windows XP
7.3. Очистка и скрытие меню Документы
• в появившемся окне Настройка классического меню «Пуск»
нажать на кнопку Очистить (рис. 7.11).
Рис. 7.9
• в измененном окне Свойства панели задач и меню «Пуск» нажать на кнопку Настроить напротив пункта Классическое меню
«Пуск» (рис. 7.10);
Рис. 7.11
Теперь в меню Документы не будет ни одного файла (рис. 7.12).
Рис. 7.10
Рис. 7.12
60
61
7. Скрытие объектов Windows XP
7.3. Очистка и скрытие меню Документы
Если в окне Свойства панели задач и меню «Пуск» на вкладке Меню «Пуск» установить флажок напротив пункта Меню «Пуск»
(рис. 7.13), то можно не только очищать меню Документы, но и скрывать его.
Для этого необходимо:
• нажать на кнопку Настроить напротив Меню «Пуск»
(см. рис. 7.13);
Рис. 7.14
Рис. 7.13
• в появившемся окне Настройка меню «Пуск» (рис. 7.14) выбрать вкладку Дополнительно;
• в разделе Недавние документы снять флажок Отображать
список недавно использовавшихся документов и нажать ОК
(рис. 7.15);
• во вновь появившемся окне Свойства панели задач и меню
«Пуск» (см. рис. 7.13) нажать на кнопку Применить, а затем ОК.
После этого при нажатии на кнопку Пуск будет появляться панель меню иного вида без раздела Документы (рис. 7.16).
62
Рис. 7.15
63
7. Скрытие объектов Windows XP
7.4. Очистка списка последних открытых файлов в MS Office
7.4. Очистка списка последних открытых файлов в MS Office
Многие программы MS Office отображают список из нескольких
последних открытых документов, который можно использовать для
быстрого доступа к файлам. Эта возможность по умолчанию включена, но ее можно выключить, а список очистить или настроить количество отображаемых в нем файлов.
Для очистки списка последних открывавшихся файлов, например в MS Word 2010, необходимо:
• выбрать пункт меню Файл (рис. 7.18);
Рис. 7.16
Если же в окне Настройка меню «Пуск» (см. рис. 7.15) включить
флажок Отображать список недавно использовавшихся документов
и последовательно нажать ОК → Применить → ОК, то при нажатии
кнопки Пуск появится панель с разделом Недавние документы, разворачивающимся в список последних открытых файлов (рис. 7.17).
Рис. 7.18
• выбрать раздел Последние (рис. 7.19);
Рис. 7.17
Этот список можно очистить, если в окне Настройка меню
«Пуск» нажать кнопку Очистка списка.
Рис. 7.19
64
65
7. Скрытие объектов Windows XP
7.4. Очистка списка последних открытых файлов в MS Office
• в списке Последние документы удалить нужный элемент, щелкнув по нему правой клавишей мыши и выбрав в появившемся контекстном меню Удалить из списка (рис. 7.20). Таким образом можно
удалить из списка все файлы.
Рис. 7.21
Рис. 7.20
Количество файлов в списке Последние документы можно изменять в диапазоне от 0 до 50. Для этого необходимо:
• выбрать раздел меню Файл → Параметры (рис. 7.21);
• в появившемся окне Параметры Word выбрать раздел Дополнительно (рис. 7.22);
• в появившемся измененном окне Параметры Word выбрать
раздел Экран, в окошке Число документов в списке последних
файлов установить нужное число (в данном случае – 0) и нажать
ОК (рис. 7.23).
Рис. 7.22
66
67
7. Скрытие объектов Windows XP
8. СКРЫТИЕ ОБЪЕКТОВ
MS OFFICE 2010
В данном разделе под термином «скрытый» понимается «невидимый». Установив соответствующий атрибут, можно сделать
файл невидимым, т. е. не позволять Проводнику отображать его
имя [7].
8.1. Скрытие файлов
Рис. 7.23
Теперь раздел Файл → Последние → Последние документы
будет пустым (рис. 7.24).
Рис. 7.24
68
Файлы, хранящиеся в компьютере, имеют определенные атрибуты (свойства, характеристики), например:
• только для чтения (Read-only) – файл защищен от изменений, его нельзя удалить командой Del (но можно при помощи Проводника);
• архивный (Archive) – архивным можно считать любой программный файл;
• скрытый (Hidden) – файл не отображается на экране при
просмотре списка файлов каталога.
С точки зрения безопасности интерес представляют атрибуты
только для чтения (Read-only) и скрытый (Hidden).
Любой атрибут можно установить при помощи Проводника.
Установка атрибутов не зависит от типа файла, атрибуты можно менять у любых файлов.
Для скрытия файла, т. е. для установки атрибута скрытый (Hidden), необходимо:
• щелкнуть правой клавишей мыши по имени нужного файла и выбрать в появившемся контекстном меню Свойства
(рис. 8.1);
69
8. Скрытие объектов MS Office 2010
8.1. Скрытие файлов
В данном случае атрибут Скрытый применен к файлу с именем
Стандартные 2010 посл 20.09.2012 дубль. В каталоге своей папки
указанный файл еще виден (см. рис. 8.2).
Теперь файл с атрибутом скрытый (Hidden) невозможно будет
увидеть при помощи Проводника, но только после того, как будут изменены установки Проводника. Для этого необходимо:
• последовательно выбрать Пуск → Программы → Стандартные → Проводник (рис. 8.3);
Рис. 8.1
• в появившемся окне Свойства на вкладке Общие установить флажок атрибута Скрытый, а затем нажать Применить и ОК
(рис. 8.2).
Рис. 8.3
• в появившемся окне Мои документы выбрать пункт меню Сервис (рис. 8.4);
Рис. 8.2
Рис. 8.4
70
71
8. Скрытие объектов MS Office 2010
8.2. Скрытие папок
• в появившемся контекстном меню выбрать Свойства папки...
(рис. 8.5);
Рис. 8.5
• в появившемся окне Свойства папки выбрать вкладку Вид
и в окне Дополнительные параметры включить флажок Не показывать скрытые файлы и папки, а затем нажать Применить и ОК
(рис. 8.6).
Рис. 8.7
8.2. Скрытие папок
Рис. 8.6
После изменения установок Проводника скрытый файл Стандартные 2010 посл 20.09.2012 дубль уже не виден в каталоге своей
папки (рис. 8.7).
72
Атрибут скрытый (Hidden) можно установить не только на отдельный файл, но и на папку в целом. Для этого необходимо:
• щелкнуть правой клавишей мыши по выбранной папке (в данном случае – материалы по защите из интернета) и в появившемся контекстном меню выбрать Свойства (рис. 8.8);
• в появившемся окне Свойства установить флажок атрибута
Скрытый, а затем нажать Применить и ОК (рис. 8.9);
• в появившемся окне Подтверждение изменения атрибутов выбрать параметры применения атрибутов (например, К этой
папке и ко всем вложенным папкам и файлам) и нажать ОК
(рис. 8.10).
Теперь необходимо изменить установки Проводника:
• щелкнуть правой клавишей мыши по скрываемой папке и в появившемся контекстном меню выбрать Проводник
(рис. 8.11);
73
8. Скрытие объектов MS Office 2010
8.2. Скрытие папок
Рис. 8.10
Рис. 8.8
Рис. 8.11
• в окне выбранной папки нажать на кнопку Сервис (рис. 8.12);
Рис. 8.9
74
75
8. Скрытие объектов MS Office 2010
Рис. 8.12
8.3. Скрытие объектов MS Excel 2010
Рис. 8.14
• в появившемся контекстном меню выбрать Свойства папки...
(рис. 8.13);
Рис. 8.15
Рис. 8.13
• в появившемся окне Свойства папки выбрать Вид и в разделе Дополнительные параметры включить флажок Не показывать скрытые файлы и папки, а затем нажать Применить и ОК
(рис. 8.14).
После изменения установок Проводника скрытая папка материалы по защите из интернета уже не видна в каталоге своей
папки Конспект лекций по стандартным средствам защиты информации (рис. 8.15).
76
8.3. Скрытие объектов MS Excel 2010
8.3.1. Скрытие листов
От просмотра можно скрывать как один лист книги, так и сразу
несколько (в этом случае их нужно сгруппировать).
Для скрытия листа в MS Excel 2010 необходимо щелкнуть по ярлычку выбранного листа правой кнопкой мыши и в появившемся
контекстном меню выбрать Скрыть (рис. 8.16).
77
8. Скрытие объектов MS Office 2010
8.3. Скрытие объектов MS Excel 2010
• в появившемся окне Подтверждение пароля ввести пароль еще
раз и нажать ОК (рис. 8.19);
• сохранить файл.
Рис. 8.16
Рис. 8.19
После этого обязательно нужно защитить структуру книги:
• в верхнем горизонтальном меню выбрать Рецензирование →
Защитить книгу (рис. 8.17);
Теперь скрытый лист больше не будет виден.
Замечания
Нельзя скрыть все листы книги. Хотя бы один лист всегда должен отображаться.
Данные, находящиеся на скрытых листах, остаются доступны
для вычислений и прочих действий.
8.3.2. Отображение скрытых листов
Рис. 8.17
• в появившемся окне Защита структуры и окон установить
флажок защиты структуры, ввести пароль (например, 222) и нажать
ОК (рис. 8.18);
Для отображения скрытого листа (листов) необходимо:
• находясь в нужном файле, в верхнем горизонтальном меню
выбрать Рецензирование → Защитить книгу (см. рис. 8.17);
• в появившемся окне Снять защиту книги ввести установленный пароль и нажать ОК (рис. 8.20);
Рис. 8.20
Рис. 8.18
• щелкнуть по ярлыку любого листа книги правой кнопкой мыши
и выбрать в контекстном меню команду Показать... (рис. 8.21);
78
79
8. Скрытие объектов MS Office 2010
8.3. Скрытие объектов MS Excel 2010
Рис. 8.23
Рис. 8.21
• в появившемся окне Вывод на экран скрытого листа выбрать
имя отображаемого листа (листов) и нажать ОК (рис. 8.22).
Рис. 8.24
Рис. 8.22
Теперь столбец D не будет отображаться на листе (рис. 8.25).
После этого ярлыки выбранных листов отобразятся внизу окна.
8.3.3. Скрытие столбцов и строк
Для скрытия столбца (столбцов) листа необходимо:
• выделить заголовок нужного столбца (в данном случае –
столбца D) (рис. 8.23);
• щелкнуть по выделенному заголовку правой кнопкой мыши
и выбрать в контекстном меню команду Скрыть (рис. 8.24).
80
Рис. 8.25
81
8. Скрытие объектов MS Office 2010
8.3. Скрытие объектов MS Excel 2010
Однако этого недостаточно для защиты от просмотра, после скрытия столбцов нужно также защитить от изменений лист:
• в верхнем горизонтальном меню выбрать Рецензирование →
Защитить лист;
• в появившемся окне Защита листа включить флажки выделение заблокированных ячеек, выделение незаблокированных
ячеек, форматирование столбцов, форматирование строк, затем
ввести пароль для отключения защиты листа и нажать ОК (рис. 8.26);
Теперь выбранный столбец D будет скрыт.
Замечания
Скрытие строк листа в MS Excel 2010 осуществляется аналогично скрытию столбцов.
Данные, находящиеся в скрытых столбцах и строках, остаются
доступны для вычислений.
8.3.4. Отображение скрытых столбцов и строк
Для отображения скрытого столбца (столбцов) необходимо:
• находясь на листе, данные которого собираемся отобразить,
в верхнем горизонтальном меню выбрать Рецензирование → Защитить лист (см. рис. 8.17);
• в появившемся окне Снять защиту листа ввести установленный пароль и нажать ОК;
• выделить все ячейки листа;
• щелкнуть правой клавишей мыши по заголовку любого
столбца и в появившемся контекстном меню выбрать Показать
(рис. 8.28);
Рис. 8.26
• в появившемся окне Подтверждение пароля ввести пароль еще
раз и нажать ОК (рис. 8.27).
Рис. 8.27
82
Рис. 8.28
83
8. Скрытие объектов MS Office 2010
8.3. Скрытие объектов MS Excel 2010
После этого скрытый столбец D вновь появится на листе.
Замечание
Для отображения строк необходимо выполнить аналогичные
действия.
8.3.5. Скрытие формул
Скрытие формул подразумевает запрет на отображение не
только самих формул, но и любого содержимого ячеек в строке
формул.
Для скрытия формул необходимо:
• выделить ячейки, формулы в которых нужно скрыть;
• на вкладке Главная в группе Ячейки нажать на кнопку Формат и выбрать команду Формат ячеек (рис. 8.29) (или щелкнуть
правой клавишей мыши по выделенным ячейкам и в контекстном
меню выбрать Формат ячеек);
Рис. 8.30
Рис. 8.29
Рис. 8.31
• в появившемся окне Формат ячеек выбрать вкладку Защита,
включить флажок Скрыть формулы и нажать ОК (рис. 8.30).
Однако действительно скрыты от просмотра формулы будут
только на листе, защищенном от изменений. Уровень защиты листа значения не имеет – можно, например, защитить лист паролем
(см. раздел 5.1). После установки пароля защиты при выделении
какой-либо из защищенных ячеек (в данном случае – E5) в строке
формул будет пусто (рис. 8.31).
8.3.6. Отображение скрытых формул
84
Для отображения скрытых формул достаточно снять установленную ранее защиту листа от изменений:
• находясь в нужном файле, выбрать Рецензирование → Снять
защиту листа (рис. 8.32);
• в появившемся окне Снять защиту листа ввести установленный пароль и нажать ОК (рис. 8.33).
Теперь скрытые формулы будут снова отображаться в строке
формул (рис. 8.34).
85
8. Скрытие объектов MS Office 2010
9. УДАЛЕНИЕ ДАННЫХ БЕЗ
ВОЗМОЖНОСТИ ВОССТАНОВЛЕНИЯ:
ПРОГРАММА ERASER
Рис. 8.32
Рис. 8.33
Бесплатная программа Eraser предназначена для качественного
удаления любых данных с жесткого диска компьютера.
Для работы программы требуется установка платформы
Microsoft .NET Framework.
9.1. Установка платформы Microsoft .NET Framework
Платформу .NET Framework можно бесплатно скачать по ссылке http://www.microsoft.com/downloads/ru-ru/details.aspx?familyid=9
cfb2d51-5ff4-4491-b0e5-b386f32c0992.
Обратившись по указанному адресу, необходимо:
• ознакомиться с информацией в окне Microsoft .NET Framework 4 и нажать кнопку Загрузить (рис. 9.1);
Рис. 8.34
Рис. 9.1
86
87
9. Удаление данных без возможности восстановления: программа Eraser
9.1. Установка платформы Microsoft .NET Framework
• в появившемся окне выбрать дополнительные загрузки (по желанию) или нажать на кнопку ОТКАЗАТЬСЯ И ПРОДОЛЖИТЬ
(рис. 9.2);
• в появившемся окне Сохранить как подтвердить имя и место
сохранения файла (в данном случае – Мои документы), нажав на
кнопку Сохранить (рис. 9.4);
Рис. 9.2
• в появившемся окне Загрузка файла – предупреждение системы безопасности нажать на кнопку Сохранить (рис. 9.3);
Рис. 9.4
• в появившемся окне Загрузка завершена нажать на кнопку Открыть папку (рис. 9.5);
Рис. 9.3
Рис. 9.5
88
89
9. Удаление данных без возможности восстановления: программа Eraser
9.1. Установка платформы Microsoft .NET Framework
• в появившемся окне (в данном случае – Мои документы) дважды щелкнуть левой клавишей мыши по файлу dotNetFx40_Full_setup
(рис. 9.6);
• в появившемся окне Установка Microsoft .NET Framework 4
подтвердить принятие условий лицензионного соглашения и нажать
на кнопку Установить (рис. 9.8);
Рис. 9.8
Рис. 9.6
• в появившемся окне Открыть файл – предупреждение системы безопасности нажать на кнопку Выполнить (рис. 9.7);
• в измененном окне Установка Microsoft .NET Framework 4 нажать на кнопку Готово (рис. 9.9);
Рис. 9.7
Рис. 9.9
90
91
9. Удаление данных без возможности восстановления: программа Eraser
9.2. Установка программы Eraser
• в измененном окне Установка Microsoft .NET Framework 4
(рис. 9.10) выбрать Перезагрузить сейчас (внимание: это вызовет немедленную перезагрузку компьютера, поэтому сначала сохраните все
данные).
• в измененном окне Eraser щелкнуть по строке Ластик
6.0.10.2620 (рис. 9.12);
Рис. 9.10
Платформа .NET Framework установлена, теперь можно переходить к установке программы Eraser.
9.2. Установка программы Eraser
Рис. 9.12
• в измененном окне Eraser нажать на кнопку Download
(рис. 9.13);
Для установки программы необходимо:
• зайти на сайт http://www.eraser.heidi.ie (на рис. 9.11 показана
его главная страница, переведенная машинным способом) и нажать
на кнопку Downloads;
Рис. 9.13
Рис. 9.11
• в появившемся окне Загрузка файла – предупреждение системы безопасности нажать на кнопку Сохранить (рис. 9.14);
• в появившемся окне Сохранить как подтвердить имя и место
сохранения файла (в данном случае – Мои документы), нажав на
кнопку Сохранить (рис. 9.15);
92
93
9. Удаление данных без возможности восстановления: программа Eraser
9.2. Установка программы Eraser
Рис. 9.14
Рис. 9.16
• в появившемся окне (в данном случае – Мои документы) найти
файл Eraser 6.0.10.2620 и дважды щелкнуть по нему левой клавишей
мыши (рис. 9.17);
Рис. 9.15
• в появившемся окне Загрузка завершена нажать на кнопку Открыть папку (рис. 9.16);
Рис. 9.17
94
95
9. Удаление данных без возможности восстановления: программа Eraser
9.2. Установка программы Eraser
• в появившемся окне Открыть файл – предупреждение системы безопасности нажать на кнопку Выполнить (рис. 9.18);
• в появившемся окне Eraser 6.0.10.2620 Setup нажать на кнопку
Next (рис. 9.20);
Рис. 9.18
• в появившемся окне Установка Microsoft .NET Framework 3.5
SP1 нажать на кнопку Выход (рис. 9.19);
Рис. 9.20
• в измененном окне Eraser 6.0.10.2620 Setup установить флажок
I accept the terms in the License Agreement (принятие условий лицензионного соглашения) и нажать на кнопку Next (рис. 9.21);
Рис. 9.19
Рис. 9.21
96
97
9. Удаление данных без возможности восстановления: программа Eraser
9.3. Использование программы Eraser
• в измененном окне Eraser 6.0.10.2620 Setup нажать на кнопку
Typical (рис. 9.22);
Рис. 9.22
• в измененном окне Eraser 6.0.10.2620 Setup нажать на кнопку
Install (рис. 9.23);
Рис. 9.24
После установки программы Eraser на Рабочем столе появится
соответствующая пиктограмма (рис. 9.25).
Рис. 9.25
9.3. Использование программы Eraser
• в измененном окне Eraser 6.0.10.2620 Setup нажать на кнопку
Finish (рис. 9.24).
Допустим, например, что на Рабочем столе существует Новая
папка, а в ней – три файла, которые нужно удалить (рис. 9.26).
Для этого необходимо выполнить следующие действия:
• запустить программу Eraser, дважды щелкнув по значку, изображенному на рис. 9.25;
• в появившемся окне Eraser выбрать раздел Erase Schedule
(рис. 9.27);
• в меню Erase Schedule выбрать New Task (рис. 9.28);
98
99
Рис. 9.23
9. Удаление данных без возможности восстановления: программа Eraser
9.3. Использование программы Eraser
• в появившемся окне Task Properties выбрать Run immediately (немедленный запуск) и нажать на кнопку Add Data, чтобы указать
файлы, предназначенные для удаления (рис. 9.29);
Рис. 9.26
Рис. 9.29
• в появившемся окне Select Data to Erase выбрать Files in Folder
и нажать на кнопку Browse... (рис. 9.30);
Рис. 9.27
Рис. 9.28
Рис. 9.30
100
101
9. Удаление данных без возможности восстановления: программа Eraser
9.3. Использование программы Eraser
• в появившемся окне Обзор папок выбрать нужную папку (в данном случае – Новая папка) и нажать ОК (рис. 9.31);
Рис. 9.31
• в появившемся измененном окне Select Data to Erase нажать на
кнопку ОК (рис. 9.32);
Рис. 9.33
• в появившемся после удаления файлов окне Eraser удостовериться, что выбранная задача в очереди больше не стоит (Not queued)
(рис. 9.34).
Рис. 9.32
Рис. 9.34
• в появившемся измененном окне Task Properties снова нажать
ОК (рис. 9.33);
Теперь можно закрыть программу Eraser, открыть Новую папку
на Рабочем столе и убедиться, что файлы удалены.
102
103
Приложение
Список полезных интернет-ресурсов
1. Антивирус Comodo Internet Security:
http://www.comodo.com/home/internet-security/free-internet-security.php
2. Антивирус AVZ:
http://z-oleg.com/secur/avz/download.php
3. Антивирусный сканер Dr.Web CureIt!:
http://www.freedrweb.com/cureit
4. Программа шифрования TrueCrypt:
http://www.truecrypt.org/
5. Официальный сайт программного обеспечения Tor:
https://www.torproject.org/
6. Ссылка на получение мостов Tor:
https://bridges.to project.org/
7. Почтовый клиент The Bat!:
http://www.ritlabs.com/ru/products/thebat/
8. Настройка The Bat! для сервиса Mail.ru:
http://help.mail.ru/mail-help/mailer/tb
9. Программа-разблокировщик Unlocker:
http://biblprog.org.ua/ru/unlocker/
10. Онлайн-генератор паролей:
http://genpas.narod.ru/
11. Программа хранения паролей KeePass:
http://keepass.info/download.html
12. Программа Eraser для удаления данных без возможности восстановления:
http://www.eraser.heidi.ie/
13. Платформа NET Framework, необходимая для работы программы
Eraser:
http://www.microsoft.com/downloads/ru-ru/details.aspx?familyid=9cfb2d51-5f
f4-4491-b0e5-b386f32c0992
14. Сайт проекта OpenPGP, посвященного информационной безопасности, криптографии и сетевой анонимности:
https://pgpru.com/
15. Коллекция ссылок на сайты производителей антивирусов:
http://www.antivirus.ru/AvFirm.html
16. Бесплатный онлайн-сканер подозрительных файлов и URL-ссылок:
http://www.virustotal.com/
104
Рекомендуемая литература
1. Аршинов М. Н. Коды и математика (рассказы о кодировании) / М. Н. Аршинов, Л. Е. Садовский. – М. : Наука, 1983. – 144 с. – (Библиотечка «Квант».
Вып. 30).
2. ГОСТ Р 50922–96. Защита информации. Основные термины и определения. – М. : Изд-во стандартов, 1996.
3. Громов Г. Р. Национальные информационные ресурсы: проблемы промышленной эксплуатации / Г. Р. Громов. – М. : Наука, 1984. – 240 с.
4. Касперский Е. Компьютерное зловредство / Е. Касперский. – СПб. :
Питер, 2007. – 202 с.
5. Колисниченко Д. Н. Анонимность и безопасность в Интернете. От «чайника» к пользователю / Д. Н. Колисниченко. – СПб. : БХВ-Петербург, 2012. –
240 с.
6. Михайлов А. В. Компьютерные вирусы и борьба с ними / А. В. Михайлов. – М. : Диалог-МИФИ, 2012. – 148 c.
7. Бэнкс М. А. Информационная защита ПК : пер. с англ. / М. А. Бэнкс. –
Киев : ВЕК+ ; М. : Энтроп ; СПб. : Корона-Принт, 2001. – 272 с.
8. Петров А. А. Компьютерная безопасность. Криптографические методы
защиты / А. А. Петров. – М. : ДМК, 2000. – 448 c.
9. Стратонович Р. Л. Теория информации / Р. Л. Стратонович. – М. : Сов.
радио, 1975. – 424 с.
10. Хэмминг Р. В. Теория кодирования и теория информации : пер. с англ. /
Р. В. Хэмминг. – М. : Радио и связь, 1983. – 176 с.
11. Шанкин Г. П. Ценность информации. Вопросы теории и приложений /
Г. П. Шанкин. – М. : Филоматис, 2004. – 128 с.
105
Оглавление
5.2.2. Снятие пароля.............................................................................. 48
5.3. Пометка окончательной версии файла MS Excel 2010.................. 49
5.3.1. Установка пометки на файл........................................................ 49
Оглавление
5.3.2. Работа с окончательной версией файла.................................... 50
6. ЗАЩИТА ОБЪЕКТОВ MS WORD 2010............................................ 51
6.1. Защита документа MS Word 2010.................................................... 51
1. ЗАЩИТА КОМПЬЮТЕРА ПАРОЛЕМ ВКЛЮЧЕНИЯ.................. 3
1.1. Установка пароля................................................................................. 3
1.2. Изменение и снятие пароля................................................................ 5
6.2. Частичное и полное снятие защиты................................................ 53
7. СКРЫТИЕ ОБЪЕКТОВ WINDOWS XP........................................... 55
7.1. Скрытие панели задач....................................................................... 55
2. СОЗДАНИЕ НАДЕЖНЫХ ПАРОЛЕЙ................................................ 7
7.2. Очистка корзины............................................................................... 57
2.1. Генерирование паролей....................................................................... 8
7.3. Очистка и скрытие меню Документы.............................................. 58
2.2. Хранение паролей: программа KeePass Password Safe.................... 9
7.4. Очистка списка последних открытых файлов в MS Office............ 65
2.2.1. Установка программы KeePass Password Safe............................ 9
2.2.2. Использование программы KeePass Password Safe................. 20
8. СКРЫТИЕ ОБЪЕКТОВ MS OFFICE 2010....................................... 69
8.1. Скрытие файлов................................................................................. 69
3. УЧЕТНЫЕ ЗАПИСИ ПОЛЬЗОВАТЕЛЕЙ........................................ 26
8.2. Скрытие папок................................................................................... 73
3.1. Создание учетной записи.................................................................. 26
8.3. Скрытие объектов MS Excel 2010.................................................... 77
3.2. Защита учетной записи паролем...................................................... 29
8.3.1. Скрытие листов........................................................................... 77
3.3. Удаление учетной записи.................................................................. 31
8.3.2. Отображение скрытых листов................................................... 79
4. ЗАЩИТА ПАПОК И ФАЙЛОВ В WINDOWS XP........................... 34
8.3.3. Скрытие столбцов и строк......................................................... 80
4.1. Защита папок...................................................................................... 34
4.2. Защита файлов................................................................................... 37
8.3.4. Отображение скрытых столбцов и строк.................................. 83
8.3.5. Скрытие формул.......................................................................... 84
4.2.1. Установка пароля на открытие файла....................................... 37
8.3.6. Отображение скрытых формул.................................................. 85
4.2.2. Снятие пароля.............................................................................. 42
9. УДАЛЕНИЕ ДАННЫХ БЕЗ ВОЗМОЖНОСТИ
ВОССТАНОВЛЕНИЯ: ПРОГРАММА ERASER................................. 87
5. ЗАЩИТА ОБЪЕКТОВ MS EXCEL 2010........................................... 44
5.1. Защита листов MS Excel 2010.......................................................... 44
5.1.1. Установка пароля........................................................................ 44
5.1.2. Снятие пароля.............................................................................. 46
9.1. Установка платформы Microsoft .NET Framework......................... 87
9.2. Установка программы Eraser............................................................ 92
9.3. Использование программы Eraser.................................................... 99
5.2. Защита книги MS Excel 2010............................................................ 46
Приложение. Список полезных интернет-ресурсов........................... 104
5.2.1. Установка пароля........................................................................ 47
Рекомендуемая литература.................................................................... 105
106
107
Учебное издание
Никифоров Сергей Николаевич
Ромаданова Мария Михайловна
ЗАЩИТА ИНФОРМАЦИИ
Пароли, скрытие, удаление данных
Учебное пособие
Редактор Т. В. Ананченко
Корректор А. А. Стешко
Компьютерная верстка В. Е. Королевой
Подписано к печати 28.11.2017. Формат 60×84 1/16. Бум. офсетная.
Усл. печ. л. 6,27. Тираж 60 экз. Заказ 127. «С» 92.
Санкт-Петербургский государственный архитектурно-строительный университет.
190005, Санкт-Петербург, 2-я Красноармейская ул., д. 4.
Отпечатано на ризографе. 190005, Санкт-Петербург, ул. Егорова, д. 5/8, лит. А.
Документ
Категория
Без категории
Просмотров
0
Размер файла
4 711 Кб
Теги
nikiforov, sktyt, paroli
1/--страниц
Пожаловаться на содержимое документа