close

Вход

Забыли?

вход по аккаунту

?

графические редаторы

код для вставкиСкачать
Обзор основных графических
редакторов
Photoshop
GIMP
Inscape
Corel Drop
Paint.NET
PhotoFiltre
PICASA
Photo scape
Подготовила Юндунова цурена 1 курс ИС
Photoshop
Программа принадлежала двум
братьям – Томасу и Джону Нолл
.
В 1984 году отец купил один из первых
Макинтошей, функциональные возможности
которого очень разочаровали братьев – именно
это и положило начало созданию программы,
которая в будущем принесёт прибыль в
миллионы долларов.
Несколько десятков инструментов для
рисования, вырезания контуров, обрамления
изображений присутствуют в Adobe Photoshop по
определению. Здесь и прямоугольная рамка, и
рамка со скругленными краями, полигон, эллипс,
линия, произвольный контур (rectangle, rounded
rectangle, ellipse, polygon, line, custom shape). Для
создания своих собственных форм и контуров
можно воспользоваться командами добавления,
вычитания и объединения (add, subtract,
intersect, exclude), в этом случае все лишь
подчиняется вашей фантазии.
Панель инструментов
photoshop
Панель инструментов
(Toolbox) Photoshop - это
основной элемент
интерфейса,
использующийся для
доступа к инструментам.На
панели инструментов
добавлены также некоторые
часто используемые
команды. Среди них
переключатели цветов
переднего плана и фона,
кнопки изменения режимов
отображения документа,
режимов маскирования и
быстрого запуска
программы ImageReady.
Цветовые модели
Векторные изображения, как
правило, выглядят очень плоскими
и скучными из-за отсутствия
визуальных эффектов и поэтому
постобработка в Adobe Photoshop
добавит рисункам больше "жизни",
ярких цветов, контраста, различных
эффектов.
Цветовые модели
любой цвет видимого спектра это
смесь основных цветов красного,
синего, и зелёного в разных
пропорциях. Смесь равных
количеств этих цветов даёт
белый, а полное отсутствие всех
трёх - чёрный. Точно так же из
красного, синего, и зелёного
цвета создаются все цвета в
фотографии, будь то цветная
фотоплёнка или матрица
цифрового фотоаппарата. По
принципу сложения цветов
работают многие технические
устройства: мониторы,
телевизоры, сканеры,
диапроекторы...
Цветовые модели
Photoshop работает в цветовой моделе Lab, однако, это лишь
внутренняя цветовая модель редактора. Можно сказать, что
эта программа думает о цвете в терминах данной системы.
Система Lab весьма специфична, работа в ней дается с
большим трудом. Упомянем еще раз об особенностях этой
системы. Все инструменты тоновой и цветовой коррекции
отличаются повышенной чувствительностью, даже
незначительное изменение одного из параметров Lab-модели
приводит к неожиданным визуальным результатам. Поэтому,
Adobe® System Inc., великодушно позволила работать нам в
любой из описанных цветовых моделей. Рекомендую
начинающим фотографам начать освоение Photoshop c
цветовой модели RGB Color, каEк самой простой для
восприятия и понимания.
Возможности работы с
текстом
Для создания текста существуют
специальные инструменты:
Horizontal Type Tool создаёт текстовый слой, на
котором текст размещается совершенно
традиционным горизонтальным образом.
Vertical Type Toolсоздаёт текстовый слой, на
котром текст размещается сверху вниз.
Vertical Type Mask Tool создаёт текстовое
выделение которое распологает буквы текста
сверху вниз
Horizontal Type Mask Tool создаёт текстовое
выделение слево направо.
Управление текстом совершенно традиционно. Вы можете
выбрать шрифт, его размер, его начертание - обычное,
полужирное, наклонное - также вы можете определить
отображение шрифта - сглаженное, резкое, чёткое. Если у
вас несколько строк текста, то для них можно определить
выравнивание - по левому краю, по центру, по правому
краю.
Основные форматы хранения
TIFF,EPS,BMP,JPEG,GIF
Достоинства и недостатки
Достоиства:
Недастатки:
Реалистичность
передаваемого
изображения,
Размер файлов, что
собственно вытекает из
детальности самого
изображения. На
сегодняшний день
существуют технологии
которые позволяют
бороться с огромными
размерами файлов но
ценою потерь в качестве.
Область применения
он может использоваться для создания
профессиональных DVD, обеспечивает
средства нелинейного монтажа и создания
таких спецэффектов, как фоны, текстуры и т. д.
для телевидения, кинематографа и всемирной
паутины. Основной формат Photoshop, PSD,
может быть экспортирован и импортирован во
весь ряд этих программных продуктов.
Photoshop CS поддерживает создание меню для
DVD. Совместно с Adobe Encore DVD,
Photoshop позволяет создавать меню или
кнопки DVD.
На главную
GIMP
GNU Image Manipulation Program или GIMP
(Гимп) — растровый графический редактор,
программа для создания и обработки
растровой графики. Частично поддерживается
векторная графика. Проект основан в 1995 году
Спенсером Кимбеллом и Питером Маттисом
как дипломный проект, в настоящий момент
поддерживается группой добровольцев.
Распространяется на условиях GNU General
Public License.
История
создания
В 1995 г. два студента из Беркли, Спенсер
Кимболл [Spencer Kimball] и Питер Мэттис
[Peter Mattis], попытались создать для фанатов
свободного ПО нечто взамен Photoshop,
который полюбился художникам на
платформах Windows и Mac. Их ранний код
был, прямо скажем, лоскутный и довольно
нестабильный, и использовал откровенно
ужасный графический интерфейс Motif. И все
же это был прекрасный фундамент для
отличного графического инструмента: 24битный цвет, поддержка целого ряда файловых
форматов, разумная система расширений и
Кросс платформеность
Благодаря своей кросплатформенности GIMP
прекрасно работает как под Windows, так и под
Linux, поэтому его можно рассматривать как
универсальное решение для работы с
изображениями на Eee PC. Также
поддерживается операционной системой
FreeBSD.
Основные возможности
Возможности и функции
1.Полный набор инструментов, включая кисти, карандаш,
распылитель, штамп и т.д.
2.Разумное использование памяти, при котором размер
изображения ограничен только свободным местом на жёстком
диске.
3.Субпиксельная дискретизация для всех инструментов
рисования, дающая высококачественное сглаживание.
4.Полная поддержка альфа-канала для работы с прозрачностью.
5.Слои и каналы.
6.Процедурная база данных для вызова внутренних функций
GIMP из внешних приложений, таких как «Script-Fu»
7.Продвинутые возможности по созданию сценариев.
8.Многократные отмена и повтор действий, ограниченные лишь
свободным пространством на жёстком диске.
9.Инструменты преобразования, включая вращение,
масштабирование, искривление и отражение.
10.Инструменты выделения, включая прямоугольное,
эллиптическое и свободное выделение, «волшебную палочку»,
кривые Безье и «умное» выделение
11.Дополнения, позволяющие легко добавлять поддержку новых
форматов и фильтров.
Панель инструментов
Панель инструментов —
сердце GIMP. Это
единственная часть
приложения, которую вы не
можете продублировать или
закрыть. Вот небольшое
описание того, что вы здесь
найдете.
1.Меню панели инструментов: это особенное меню,
содержащее некоторые команды, которые не найти в
прикрепляемых к изображению меню (хотя
некоторые все-таки можно). Сюда включены команды
для настройки параметров, создания определенных
типов диалогов, и т.д. Содержание систематически
описано в разделе «Меню панели инструментов».
2.Значки инструментов: эти значки являются кнопками,
активирующими инструменты для разнообразных
действий (выделение частей изображений, рисование,
преобразования и т.п.). Раздел Введение в панель
инструментов описывает принципы работы с
инструментами. Каждый инструмент описан в
разделе Инструменты.
3.Цвета фона/переднего плана: область выбора цвета показывает
текущий выбранные вами цвета переднего плана и фона,
применяемые во многих операциях. Щелчок по одному из них
вызовет диалог выбора цвета. Щелчок по двунаправленной
стрелке поменяет местами цвета переднего плана и фона, а
щелчок по небольшому символу в нижнем левом углу
восстановит исходные значения цветов переднего плана и
фона: черный и белый соответственно.
4.Киcть/Текстура/Градиент Расположенные здесь значки
показывают текущие выбранные элементы GIMP, такие как:
кисть, используемую всеми рисующими инструментами
(«рисование», кстати, включает в себя такие операции, как
стирание и размазывание); текстуру, используемую для
заливки выделенных областей изображения, и градиент,
который применяется, когда необходимо создать плавный
цветовой переход. Щелчок по любому из этих значков вызовет
диалоговое, окно позволяющее изменить соответствующий
элемент.
5.Активное изображение: в GIMP вы можете работать с многими
изображениями одновременно, но в любой момент только одно
из них является активным изображением. Этот элемент
интерфейса представляет собой эскиз (уменьшенную копию)
активного изображения. Щелчок по нему вызовет диалог со
списком всех открытых на данный момент изображений,
позволяя вам при желании изменить активное изображение. (А
можно просто щелкнуть мышкой по окну другого
изображения).
Типовые окна GIMP
Цветовые модели.
Стандартной цветовой моделью
GIMP является RGB. При работе
с черно-белыми изображениями
считается целесообразным
использовать модель Grayscale.
Модель CMYK чаще
используется при работе с
векторной графикой.
Несомненным удобством
цветовых моделей является их
универсальность. Зеленый цвет
в любой программе-редакторе,
использующей, например, RGB,
будет иметь код 0,255,0 – это
бывает удобно при переводе
цветовых значений из одной
программы в другую.
FreeType: работа с текстом в
GIMP
FreeType Text — плагин для увеличения
возможностей работы с текстом в GIMP. Он
помогает преобразовывать текстовые слои.
С помощью FreeType можно увеличивать размер
текста, изменять межбуквенное расстояние,
пользоваться разными методами сглаживания
контуров букв. Кроме того, можно вращать
текст, растягивать его по горизонтали и
вертикали, изменять его наклон и всячески
деформировать.
Плагин FreeType Text превращает текстовую составляющую в кривые, а
потом работает именно с ними. Кроме того, можно на выходе получить и
сами кривые, а потом работать непосредственно с ними при помощи
инструмента «Кривые».
Плагин не умеет работать с уже созданными текстовыми слоями. Тексты
для работы нужно вводить в специальное окошко, в котором и происходят
преобразования. Это единственный минус плагина.
Основные форматы хранения
Основным форматом хранения изображений в The GIMP является
собственный формат XCF, позволяющий хранить изображения по
слоям. Файлы этого формата очень плотно сжимаются с помощью
архиваторов bzip и gzip.
Так же The GIMP поддерживает следующие графические форматы:
GIF (включая анимацию), JPEG, PNG, PNM, XPM, TIFF, TGA, MPEG,
PS, PDF, PCX, BMP, SGI, SunRas, XPM, PAT (для матриц
заливки),GBR (для матриц кистей), GIcon (для пиктограмм
инструментов в соответствующей панели).
Отображать без возможности редактирования можно файлы форматов
PSD, SNP, FaxG3. Экспортировать результат работы можно в форматы
FLC/FLI и Header (специальный файл, позволяющий вставлять
изображения в исполняемые программы)..
Что умеет делать GIMP
В нем есть неплохой набор инструментов цветокоррекции (о нем
в следующей части “GIMP на практике”), редактор умеет
корректировать геометрические искажения, удалять дефекты
на изображениях, неплохо реализовано управление цветом,
имеются функции рисования. Интерфейс легко настраивается с
помощью плавающих палитр. Любое меню можно превратить
в свободно перемещаемое окно. Не вызовет сложности
перенастройка клавиатурных комбинаций, действий мыши.
GIMP обладает следующей совместимостью с Adobe Photoshop:
— файлы в формате PSD (с ограничениями);
— файлы кистей (без поддержки динамики);
— действия (actions), за счет gimp-sharp (степень реализации
50%);
— расширения в формате 8bf с помощью проект PSPI.
Дополнительный функционал наращивается с помощью
различных плагинов. Это плагин для работы с RAW-файлам,
аналог известной пользователям Photoshop'a функции “Save for
Web”, наборы различных фильтров, преобразование цветового
пространства из RGB в CMYK и многое другое. Большинство
плагинов англоязычные.
Собственный формат файлов XCF может сохранять в себе текст,
каналы, контуры, и сами слои изображения. Если добавить к
имени файла gz или bz2, сохраняемое изображение будет
автоматически сжато. При последующем открытии не нужно
будет разархивировать файл: GIMP поймет его без проблем.
Что GIMP не умеет делать?
Несмотря на хорошую функциональность, этот редактор
практически невозможно использовать в профессиональной
сфере дизайна, полиграфии, фотографии. Основные причины
следующие:
— нет поддержки плашечных цветов (и палитры Pantone — по
лицензионным соображениям);
— нет полноценной поддержки цветовых моделей, CIELAB и
CIE XYZ;
— нет поддержки режима 16 и более разрядов на цветовой канал;
— нет поддержки HDRi и операторов отображения тонов;
— нет процедурных (коррекционных) слоев и эффектов слоев.
Впрочем, в более простых случаях (к примеру, обработка
фотографий) GIMP со своими задачами прекрасно справляет.
Отсутсвуют и средства автоматической записи сценариев. Взамен
предлагается писать сценарии на различных языках
программирования (TinyScheme, Python, Ruby, Perl, C#).
Удобно для тех, кто разбирается в этом, но совершено не
годится для большинства пользователей.
Разумеется, проект развивается и слабые стороны постепенно
устраняются. Так, к версии 2.8 разработчики обещают
наконец-то реализовать однооконный интерфейс (сейчас
программа использует несколько независимых окон).
Область применения
GIMP можно использовать для обработки
цифровых фотографий. Типичные области
применения включают в себя создание
графики и логотипов, масштабирование и
кадрирование фотографий, раскраска,
комбинирование изображений с
использованием слоёв, ретуширование и
преобразования изображений в различные
форматы.
На главную
Inscape
Inkscape (Инкскейп) — векторный графический редактор, удобен
для создания как художественных, так и технических
иллюстраций (вплоть до использования в качестве САПР
общего назначения, чему также способствует легкость обмена
чертежами). Это стало возможным во многом благодаря
открытому формату SVG, развиваемому консорциумом W3C.
Формат SVG позволяет создавать иллюстрации различного
типа, в том числе анимированные. Поскольку SVG основан на
языке разметки XML, к нему можно писать расширения, чем
авторы Inkscape и пользуются.[2] Программа распространяется
на условиях GNU General Public License.
история
История Inkscape началась с того, что нескольких программистов
и пару дизайнеров, умеющих писать код, перестали устраивать
условия разработки редактора векторной графики Sodipodi.
Поняв, что они не смогут в должной степени применить свои
навыки, они организовали новый проект[3], который назвали
Inkscape. На тот момент в GNU/Linux было всего два редактора
векторной графики, которые можно было использовать в
реальной работе — Sodipodi и SKetch, позднее
переименованный в Skencil. С тех пор разработка Sodipodi и
Skencil сошла на нет. Inkscape де-факто стал самым
популярным свободным редактором в своей области.
Основные возможности
- Обработка текста: рендеринг, вставка текста в контур, правка
как однородного многострочного, так и перетекающего текста.
- Импорт: SVG, SVGZ, EMF, EPS, PostScript, PDF, AI, Dia, Sketch,
PNG, TIFF, JPEG, XPM, GIF, BMP, WMF, WPG, GGR, ANI,
ICO, CUR, PCX, PNM, RAS, TGA, WBMP, XBM, XPM.
- Экспорт: PNG, SVG, EPS, PostScript, PDF, Dia, AI, Sketch, POVRay, LaTeX, OpenDocument Draw, GPL, EMF, POV, DXF.
- Множество инструментов для удобства рисования: Эллипс,
Звезда, Спираль, Каллиграфическое перо, Текст, Градиент,
Пипетка.
- Работа с контурами: логические операции, динамическая и
связанная втяжка, упрощение контура, оконтуривание штриха,
создание составных контуров, вставка нового узла в любую
точку контура, быстрая смена типа узла с острого на
сглаженный или симметричный, динамические контурные
эффекты.
- Большое количество продуманных клавиатурных комбинаций
для быстрого вызова функций.
Кросплатформенность
Распространяется для платформ Windows и Linux.
- Информативная статусная строка с информацией о выделенных
объектах и подсказывающая клавиатурные комбинации.
- Встроенный векторизатор растровых изображений.
- Расширенные возможности работы с клонами объектов,
создание узора из клонов при помощи любой из 17 групп
симметрии.
- Коллективное рисование через протокол XMPP (Jabber).
- Редактор XML-кода документа с деревом объектов — для
доступа к временно неподдерживаемым в графическом
интерфейсе параметрам документа.
- Сохранение и открытие документов в сжатом виде, с
использованием алгоритма компрессии gzip.
Панель инструментов
Inkscape удобен в использовании и имеет
привычные инструменты: Выделение,
Масштабирование, Правка узлов,
Прямоугольник, Эллипс, Звезда, Спираль,
Линия от руки, кривые Безье,
Каллиграфическое перо, Текст,
Соединительные линии, Градиент, Пипетка.
Меняющие контур
режимы инструмента
Корректор позволяют
толкать, сокращать,
наращивать,
отталкивать,
притягивать и огрублять
любой контур для
произвольного
изменения формы
обектов.
Принцип работы
меняющих цвет
режимов нового
инструмента Корректор,
похож на принцип
работы мягкой кисти в
редакторах растровой
графики. Если в рисунке
есть несколько объектов,
можно выбрать их все и
рисовать по ним любым
цветом заливки или
обводки.
Inkscape имеет встроенный
векторизатор растровых
изображений, использующий
SIOX для выделения
объектов на переднем плане.
Расширенные возможности
работы с клонами объектов,
создание узора из клонов
при помощи любой из 17
групп симметрии,
поддержку наклона и силы
нажатия стилуса при
использовании графических
планшетов (инструмент
Каллиграфическое перо).
Цветовые модели
Возможности работы с текстом
В Inkscape поддерживаются метаданные (Creative
Commons) - правка узлов, сложные операции с
контурами, слои, векторизация растров,
заверстывание текста в фигуру, текст может быть
изменен прямо на изображении.
Основной формат хранения
Импорт: SVG, SVGZ, EMF, EPS, PostScript,
PDF, AI (9.0 и выше), Dia, Sketch, PNG,
TIFF, JPEG, XPM, GIF, BMP, WMF, WPG,
GGR, ANI, ICO, CUR, PCX, PNM, RAS,
TGA, WBMP, XBM, XPM.
Экспорт: PNG, SVG, EPS, PostScript, PDF
1.4 (с полупрозрачностью), Dia, AI, Sketch,
POV-Ray, LaTeX, OpenDocument Draw,
GPL, EMF, POV, DXF.
Достоинства
Inkscape – один из лучших редакторов
масштабируемой векторной графики.
Открытый исходный код и бесплатная
лицензия - главное преимущество утилиты
над конкурентами.Для любых видов
обработки документов векторной графики
Inkscape использует язык Phyton.
Встроенные скрипты Phyton применяются
для редактирования яркости, контраста и
оттенков иллюстрации. В Inkscape можно
добавить точки, выпрямить линии и кривые
Безьера, а также раздробить рисунок.
Недостатки
- повышенные требования к системным
ресурсам и вследствие этого —
медлительность;
- «сырость» ряда фильтров импорта.
Область применения.
Удобен для создания как художественных, так и
технических иллюстраций.
иллюстрации для офисных циркуляров, презентаций,
создание логотипов, визиток, плакатов;
технические иллюстрации (схемы, графики и пр.);
векторная графика для высококачественной печати (с
предварительным импортом SVG в Scribus);
веб-графика — от баннеров до макетов сайтов,
пиктограммы для приложений и кнопок сайтов,
графика для игр.
На главную
Corel Draw
CorelDRAW — векторный графический
редактор, разработанный канадской
корпорацией Corel.
Сorel Draw
история
Программа CorelDRAW впервые поразила воображение
пользователей графических программ в 1989 году, став первой
в истории программой для создания полноцветных
иллюстраций и макетов страниц. Через два года компания
Corel продолжила революцию в сфере компьютерной графики,
выпустив первый в мире универсальный графический пакет
CorelDRAW 3. Этот пакет сочетал инструменты для создания
векторных иллюстраций, макетов страниц, редактирования
фотографий и другие возможности.
продолжение...
Спустя более чем 20 лет CorelDRAW Graphics Suite X5
продолжает инновационное развитие. Среди новых
особенностей этой версии — поддержка многоядерных
процессоров для повышения скорости работы, большее
количество разнообразного содержимого и профессиональных
шаблонов, улучшенная совместимость с поддержкой более 100
форматов файлов, переработанная система управления цветом,
новые возможности подготовки веб-графики (в том числе
поддержка анимации Flash), а также дополнительные
возможности вывода для печати и Интернета. Эта версия
оптимизирована для использования с новейшими
операционными системами Windows® и продолжает традиции
развития профессиональных графических пакетов для ПК.
Кросплатформенность.
Текущая версия продукта — CorelDRAW
Graphics Suite X5, доступна только для
Microsoft Windows. Более ранние версии
выпускались также для Apple Macintosh и для
GNU/Linux. Последняя версия для GNU/Linux
— 9-я версия, выпущенная в 2000 году. В 2002
году вышла последняя 11-я версия для
Macintosh.
Основной формат хранения.
.cdr (CorelDraw) Собственный векторный формат, используется для переноса и
хранения графических документов, созданных в программе CorelDraw.
.cdt (CorelDraw Template) Векторный формат, для записи рисунков-шаблонов
.pat (Pattern File) Векторный формат, для хранениямногоцветных шаблонов для
заливки
.clk (Corel R.A.V.E) Собственный векторный формат Corel R.A.V.E, предназначен
для хранения анимационных графических документов
.cpt (Corel Photo-Paint) Растровый формат программы Corel Photo-Paint , для
хранения многослойных изображений. Поддерживает инф. О слоях, каналах и
векторных контурах растрового изображения.
.csl (Corel Symbol Library) Используется встроенным менеджером символов
(Symbol Manager) для хранения внешних библиотек символов
.cmx (Corel Prezentation Exchange) Векторный формат, поддерживающий
векторную, растровую и текстовую информацию
Возможности работы с текстом.
По возможностям работы с
текстом CorelDRAW не
уступает многим текстовым
редакторам. Однако
дополнительно вы можете
выполнять сложное
оформление текста и
создавать оригинальные
рисунки из символов.
Дополнительные
возможности
форматирования текста
помогут создать документ
любой сложности.
Цветовые модели.
Электронная цветовая палитра
подобна палитре художника за
исключением того, что
вмещает гораздо больше
готовых цветов, чем может
разместить на своей палитре
художник. Электронная
палитра состоит из множества
цветовых ячеек, и каждая из
них представляет отдельный
стандартный цвет.
Разнообразные цветовые
палитры CorelDraw содержат
различные наборы цветов,
относящихся к моделям
цветовоспроизведения CMYK,
RGB или к цветам плашечной
печати.
Достоинства CorelDRAW
Достоинства CorelDRAW заключаются в
точности форм, возможности ввода с
клавиатуры любого параметра, использовании
градиента, огромном количестве встроеных
палитр (неговоря о том что можно придумать
или загрузить свою), удобном интерфейсе и
поддержке множества форматов.
Недостатки CorelDRAW
Частое зависание, в смысле не всей программы. а рабочей
области (например после выделения текста может
остаться след, а он сильно мешает, приходится
сворачивать и разворачивать окно). В этом редакторе не
поддерживаются размеры меньше чем 30 на 30 пикселей,
а для любого хорошего веб - мастера это важно. Здесь
практически невозможно подобрать цвет заливки
который подходил бы к обычной палитре RGB (кроме
белого), с каким бы качеством вы не экспортировали
свой рисунок. Ещё в этом редакторе не поддерживается
прозрачность всего рисунка. При экспорте рисунка на
его краях виднеется белая граница (как в таблице), но
она легко устраняется с помощью MSPaint.
Область применения.
Основными областями применения программы CorelDRAW
являются:
Полиграфия. Программа успешно используется в
профессиональной полиграфической деятельности для
создания листовок, плакатов, визиток, буклетов, календарей
и другой продукции. Однако, существуют ограничения на
применение программмы в данной области, они в основном
связаны с версткой текста в больших объемах,
многостраничностью издания — в таких случаях удобнее
применение специализированных программ верстки (Quark
XPress, Adobe InDesign).
Веб-дизайн. В программу включены специальные команды
экспорта графики для веб, а инструмент "Управление
цветом" позволяет как выбрать уже готовые настройки для
Web, так и создать свои.
на главную
Paint.NET
Paint.NET — растровый графический редактор
для Windows NT, основанный на .NET
Framework. Приложение начато как проект,
разработанный в Университете штата
Вашингтон для Microsoft Windows под
руководством Microsoft. Paint.NET написан на
C#, с некоторым количеством C++,
используемого при установке и интеграции с
оболочкой.
история
Paint.NET создан как проект старшекурсников по компьютерным
наукам весной 2004 года. Рик Брюстер, один из основных
разработчиков, в своём блоге сказал, что версия 1.0 была написана
«за 4 месяца… и содержала 36 000 строк кода»[3]. Недавний
релиз, версия 3.10 — приблизительно 140 000 строк кода. Проект
Paint.NET продолжался летом и по осенний семестр 2004 г., в
результате чего появились версии 1.1 и 2.0.
Двое выпускников Университета штата Вашингтон, которые
работали над проектом в студенческие годы, продолжают его
развитие и сейчас, являясь сотрудниками Microsoft.
По состоянию на май 2006 года программа была загружена по
крайней мере 2 миллиона раз.[4], с темпом порядка 180 000 в
месяц[5].
кроссплатформенность
Основные возможности
программы Paint.NET:
* работы со слоями
* применение эффектов
* работа со сканером и камерой
* коррекция красных глаз
* масштабирование от 1% до 3200%
панельинструментов
Основные команды:
Кнопки этой группы предоставляют быстрый доступ к некоторым
часто используемым командам. Первые четыре команды
позволяют (если считать слева направо): создать новое, открыть
уже существующее, сохранить, и распечатать изображение:
используются для того чтобы вырезать,
скопировать, вставить, обрезать по выделению и
отменить выделение:
Второй ряд панели
инструментов начинается
с кнопки «Инструмент:»,
которая позволяет выбрать
текущий инструмент. Если
вы щелкните по этой
кнопке, откроется
выпадающий список
инструментов, а также
команда «Настройки поумолчанию…»:
Цветовые модели
RGB, CMYK, Lab Color.
Основной формат хранения
Paint.NET поддерживает популярные форматы
изображений – JPEG, PNG, GIF, TIFF и другие
– кроме файлов RAW с высоким разрешением.
Стандартных и вспомогательных эффектов и
функций приложения хватит любому
поклоннику красивых картинок, хотя
инструмента удаления красных глаз
недостаточно для качественной редакции –
рисунок придется обрабатывать вручную.
Paint.NET имеет ряд
преимуществ, отличающих его
от конкурентов:
* программа бесплатна для распространения и
использования;
* оптимизирован для работы с двуядерными и
четырехядерными процессорами;
* имеет удобный интерфейс, похожий на
Photoshop;
* позволяет работать с несколькими документами
одновременно;
* поддерживает работу со слоями;
* прост в использовании.
Недостатки Point.NET
Один из главных недостатков Paint.NET - это сама платформа
.NET. Во-первых, программы на ней отличаются особенной
требовательностью к ресурсам компьютера, во-вторых (что
куда хуже) авторы Paint.NET, заполучив в свои руки
возможность контролировать прозрачность окон, использовали
её на полную катушку. Если увеличение прозрачности
вспомогательных окон при потере фокуса вполне можно
счесть за положительное качество (особенно при низком
разрешении экрана, когда для всех окон частенько не хватает
места), то полупрозрачные диалоговые окна - это уже перебор.
В любом случае, можно было бы оставить возможность
вернуть окнам привычный вид.
Интерфейс вообще не самая
сильная сторона
Paint.NET. Здесь нет
возможности открыть
больше одного рисунка
(прямо как в
оригинальном Paint),
вспомогательные окна не
объединяются в панели,
панель инструментов,
отвечающая за настройку
шрифта присутствует на
экране постоянно.
Область пременения
Paint.NET является отличной заменой редактору
графических изображений, входящему в состав
стандартных программ операционных систем
Windows.
На главную
PhotoFiltre — компактный универсальный
графический редактор для операционной
системы Windows. Бесплатен для
некоммерческого использования и
образовательных целей. Автор и разработчик
программы — Антонио Да Круз (Antonio Da
Cruz). Интерфейс программы переведён на
несколько десятков языков.
Основные возможности
Возможности программы:
» Применение различных фильтров
» Использование двух типов векторного выделения
» Создание и использование слоев
» Инструмент очистки изображения
» Инструмент для автоматического наложения прозрачного
градиента
» Функция удаления эффекта красных глаз
» Создание анимированных GIF-изображения с помощью
встроенного генератора
» Интегрированный модуль ФотоМаски
» Создание и экспорт 32x32, 48x48, 64x64 иконок
» Интегрированный браузер для просмотра изображений
Панель интсрументов
# Для создания нового изображения: .
После нажатия этой кнопки вам предоставляется возможность
выбрать размер, цвет или заливку шаблоном вашего нового
документа.
# Чтобы открыть имеющееся изображение, нажимаем . В
окошке проводника выбираете нужную папку, нужный файл и
открываете его.
# Для сохранения файла нажимаем .
# Для вывода изображения на печать нажимаем .
# Для импорта документа со сканнера нажимаем .
# Для отмены последнего действия (отката) нажимаем .
# Для того, чтобы вернуть то, что отменили: .
# Для того, чтобы скрыть выделение (если вы что-нибудь
выделяли) нажимаем .
Повторный клик по этому значку снова покажет выделение.
# Для перехода в режим RGB (красный-зеленый-синий)
нажимаем .
Некоторые фильтры работают только в этом режиме. Именно на
этот значок нужно нажать, если ваше изображение в режиме
индексированных цветов, то есть в GIF или PNG (иначе вы
просто не сможете работать с иструментами).
# Для перехода в режим индексированных цветов - .
# Для того, чтобы задать прозрачность: .
Для того, чтобы вы могли использовать этот инструмент, нужно
перейти в режим 256 цветов "индексированный цвет".
Картинка должна быть, например, в формате JPEG (JPG).
Пипеткой выбирается тот цвет, который вы хотите заменить на
прозрачность. Эта опция удобна для создания прозрачного
фона. JPEG в таком случае превращается в GIF или PNG.
# Для изменения размеров изображения нажимаем .
Кроме этого, вы можете воспользоваться "горячими клавишами"
Ctrl+H или соответствующей строчкой в меню "Изображение"
("Рисунок"). Кому как удобно.
# Для выбора размера рабочей зоны нажимаем .
Для этой опции также есть "горячие клавиши" - Shift+H. В
открывшемся меню можно изменять параметры расположения
картинки, выбирать шаблон, цвет фона.
# Кнопка для создания текста: .
Выбираем шрифт, размер, текстовые эффекты (обратите
внимание на вторую вкладку!)
# Очень полезная кнопка, открывающая внизу рабочего окна
проводник изображений - .
Просматривайте ваши папки, при необходимости открывайте
дополнительные картинки. Это часто нужно при наложении
масок, специальных вставках и применении эффекта кистей.
# Для автоматизации процесса можно нажать кнопку .
Можно "оптом" изменять размеры открытых изображений,
менять формат и т.д. Знаете о макросах? Тогда и этого не
испугаетесь))
# Сохранить свои предпочтения (определенные папки, размер
сетки и т.д.) можно нажатием кнопки .
Основные форматы
сохранения
сохранить рисунок можно с расширением JPG
(JPEG) или GIF.
Достоинства и недостатки
Утилита позволяет
осуществлять легкое и
более глубокое
редактирование рисунков,
а также накладывать
поверх них различные
эффекты и использовать
на них богатый набор
фильтров. PhotoFilter
просто и понятен в
работе, обладает
понятной панелью
инструментов и
грамотной справочной
системой. Имеется
русский интерфейс.
в PhotoFiltre нет слоев. Если
нам нужно, допустим,
наложить на имеющуюся
фотографию
определенную маску с
применением того или
иного эффекта, то
необходимо вначале
нарисовать эту маску в
отдельном файле, а
затем воспользоваться
встроенным фильтром
PhotoMasque.
Область пременения
бесплатный редактор в обзоре - PhotoFiltre,
любопытный продукт для работы с
фотографиями; по крайней мере, именно так
его позиционирует разработчик. Здесь есть
практически все, что может потребоваться как
для простых, так и довольно сложных
манипуляций с изображениями.
На главную
PICASA
программа для работы с цифровыми фотографиями. 13
июня 2004 года Picasa была приобретена компанией
Google. Picasa интегрирована с Blogger, Gmail, YouTube и
Google Earth.
Основные возможности:
Загрузка фотографий в компьютер со сканера и камеры.
Автоматическая индексация фотографий на жёстком
диске компьютера.
Просмотр фотографий в обычном и полноэкранном
режимах, в том числе в виде слайд-шоу.
Geotagging (привязка к местности): Picasa может
записывать координаты в метаданные Exif. С версии 3.5
для этого уже не нужен установленный Google Earth.
Применение к фотографиям различных эффектов, в том
числе коррекция эффекта красных глаз.
Присвоение фотографиям ярлыков и ключевых слов.
Распечатка фотографий.
Создание коллажей фотографий.
Отправка фотографий по электронной почте и
публикация их в блогах.
Создание на основе фотографий экранных заставок и
компакт-дисков со слайд-шоу из фотографий.
Панель инструментов
На панели инструментов Picasa
крайняя левая кнопка
вызывает диалоговое окно
импорта изображений.
Программа предлагает
переписать фотографии с
компакт-диска, а если в
текущий момент
подключены мобильные
носители, то и с них тоже.
Если материал уже
находится на жестком диске,
то необходимо
дополнительно указать
папку.
Перед импортом документов
можно выделить отдельные
миниатюры, а также
обработать все изображения в
текущей папке. Надо
заметить, что сама процедура
не занимает много времени.
Миниатюры фотографий
создаются очень быстро. По
сравнению с режимом поиска
документов на жестком диске,
импорт из указанного
носителя или папки выглядит
чрезвычайно резвым. После
окончания импорта
открывается диалоговое окно
систематизации
обработанного материала.
недостатки
одна проблема - количество картинок на компьютере. Picasa
полностью сканирует диск при инсталяции и создает свою
уникальную базу графики. В моем случае на диске хранятся
тысячи картинок в сотнях каталогов. Забудем что
сканирование занимает кучу времени, но количество
сгенерированных пунктов в левом списке получается тоже
бесконечным! И авторы предлагают править его вручную:
сливать альбомы, скрывать их и т.д. Т.е. после автоскана вам
предстоит еще огромная ручная работа по организации своего
каталога.
Далее - а что делать с добавлением новой графики в однажды
созданную базу? По версии Picasa - это тоже каждый раз
ручками, даже для одной единственной картинки :-(
достоинтсва
Picasa упорядочивает и редактирует фотографии,
печатает красивые коллажи.
В этом редакторе легко создать себе фотоальбом,
который автоматически можно разместить на
личных веб-страничках, в различных
социальных сетях. Очень удобно, вспомните,
сколько это занимает времени, если
проделывать это вручную.
Picasa позволяет создавать слайдшоу, добавлять к нему ваш текст и
привязывать к этому слайд-шоу
любую музыку, по вашему
выбору.
Ролик готов, остается только нажать
на кнопочку: «Разместить на
YouTube» (есть здесь такая), и
ваша страничка на YouTube
пополнится еще одним фильмом.
Область пременения
основная область применения - это просмотр и
упорядочивание изображений.
она умеет взаимодействовать и с другими
интернет-сервисами от компании Google.
photoscape
Графический редактор с расширенными
возможностями. Photoscape позволяет
просматривать изображения, редактировать
графику, обрабатывать файлы в пакетном
режиме, конвертировать RAW-файлы.
Основные возможности
Помимо этого в Photoscape можно создавать
анимированные файлы GIF, делать скриншоты,
определять цвета пикселей, настраивать
яркость, цветовую насыщенность, баланс
белого, проводить коррекцию контрастности.
Программа позволяет создавать рамки,
графический текст, рисовать картинки,
обрезать изображения, применять различные
фильтры, удалять эффект "красных глаз" и
многое другое.
В нижней части экрана выбираете вкладку "обрезать":
Выбираете одну из предложенных пропорций фото.
Стандартное соотношение 3х4. Но можно выбрать и
другие соотношения или вообще отказаться от жесткой
фиксации пропорций снимка.
Основной формат хранения
универсальный RAW-формат для цифровых
изображений, названный DNG (Digital
Negative), а также новую бесплатную утилиту
Adobe DNG Converter для преобразования
RAW-файлов любых форматов в формат DNG
JPG, PNG, GIF, BMP.
Возможности работы с
текстом
Печать. Возможность печати фотографий,
визитных карточек и т.?п.
Поддержка 34 языков.
Добавлен инструмент Clone Stamp (Editor ->
Tools Tab).
— Добавлен инструмент Paint Brush (Editor ->
Tools Tab).
— Интегрированный инструмент Color Picker
(Editor -> Tools Tab & Object Tab).
— Доработан мозаичный фильтр.
— В просмотрщик и редактор добавлена
функция печати.
Достоинства и недостатки
простота в изучение и
использовании,
многофункциональность,
поддержка
редактирования
графических файлов
практически всех
форматов, в том числе и
RAW, функция пакетной
обработки. Но это далеко
не все.
Большой недостаток –
отсутствие хотя бы
небольших продвинутых
функций
Область пременения
Позволяет просматривать изображения, редактировать графику,
обрабатывать файлы в пакетном режиме, конвертировать
RAW-файлы, создавать анимированные файлы GIF и еще
много другого. Photoscape, кроме вышеперечисленного,
позволяет делать скриншоты, определять точные цвета
пикселей, настраивать яркость, цветовую насыщенность,
настраивать баланс белого, проводить коррекцию
контрастности. Программа позволяет создавать рамки,
добавлять графический текст, фигуры ссылок, рисовать
картинки, обрезать изображения, применять различные
фильтры, удалять эффект "красных глаз", ретушировать и
многое другое.
Пример редактирования
изображения в photoscape
Вот и все!
На главную
Документ
Категория
Презентации по информатике
Просмотров
115
Размер файла
5 760 Кб
Теги
1/--страниц
Пожаловаться на содержимое документа